>> 中身

某ゲームのシミュレータです。謎です。 ソレっぽいモノです。とにかく謎です。


>> Infomation

  • InternetRanking対応
    今までテスト版として別途配布されていたIR機能ですが、
    1014版からnazobmplay本体に組み込まれました。
    起動画面のIRタブでログインする事によりプレイするたびにプレイしたスコアがIRに登録されます。

  • イベントモード搭載
    曲の展示、または複数のBMSを一つのファイルとして公開する等のイベント用に作られたのがこのモードです。
    jukeboxフォルダにイベント定義ファイルを置くことにより、そのフォルダ内でイベント向けの特殊な機能を付けることができます。

  • RANDOMとMIRROR追加されました
    今までのnazoのランダムはラインごとではなく、１オブジェごとのランダムでしたが、
    1014版からラインごとのランダムに変わりました。旧RANDOMはshiffleになっています。
    また、ミラーも追加されていますがこちらは少し特殊で、
    1Pのみミラー、2Pのみミラー、両方ミラーの３種類が搭載されています。
    5keyでは5keyランダム(orミラー)、7keyでは7keyランダム(orミラー)として機能します。

  • リプレイオブジェクト復活
    オフィシャル版nazobmplayで表示されていたリプレイオブジェ機能ですが、
    unofficial版でも表示できる様になりました。
    リプレイオブジェクトとはリプレイ時のみ表示される記録時に叩いた場所をそのままオブジェに変換したものです

  • 曲セレクト画面が新しくなってます。
    元々はLoZical Dash #02で使用された物を使っていますが…。
    とりあえず新しくなっています。

  • 操作方法が一部変更されました。
    ハイスピードの操作方法が変更されています。ハイスピードは 1P側 Q,W 、 2P側 Y,U で変更です。
    F9はオートスクラッチとなりました。F9で1P→2P→両方→無しを繰り返します。
    これに従い、プレイ中のスキン変更はセレクト画面では通用しなくなりましたのでご了承下さい。
    なお、BSキーでフィルタリング機能となっております、1P→2P→DP→全てを繰り返します。

  • WAV拡張定義に対応
    BM98deで拡張されたWAV拡張定義に対応しました。
    数値はbm98deの基準通り00～FZまで読み込み可能です。

  • BMP使用制限を拡張
    BM98deでは#BMPの使用制限は255個(00～FF)までとなっておりましたが、
    今回の最新版では00～FZまで読み込み可能です。ただし、動作の保証はしません。

    ついでに、#BGAには対応していません。

  • ロングノートBMSに対応
    rhythm-itで使用されているロングノート仕様に対応しました。
    ロングノートとはBM7thの一回転スクラッチの様な、いわゆる長押しオブジェです。
    対応形式は#LNTYPE1と2です、詳しい仕様はSupport BMSのページにて。
    今回のロングノート対応に従い、bmlの読み込みにも対応しました。
    bmlはロングノート専用BMSですが、基本はBMSの仕様と変わりません。
    なお、mgq形式には対応していません。

  • ストップシーケンスに対応
    Delight Delight Reduplication、rhythm-itに対応しているストップシーケンス仕様に対応しました。
    ストップシーケンスとはDDRで使用されているシーケンスを指定した時間だけ停止する命令です。
    その時点までに再生された音はそのまま流れ続けます。

    ちなみに、書式方法は以下の通り(DDRのサポートページより転載)
    #STOPxx yyy
    #zzz09:zz

    xxは01～FFです。 yyyは整数で、停止する時間を192分音符単位で指定します。
    zzはオブジェ配置で、停止する位置を指定します。

  • brd仕様を一部追加
    ロングノート対応に伴い、ロングノート専用にbrd命令が追記されています。
    詳しい説明に関してはbrd解析にて。

  • MP3に対応
    しました。#wavが.mp3じゃなくても同じフォルダにwavが無かった時点でmp3を探してくれます。その逆もOK。
    これで大体のmp3入りBMSはプレイできると思います。

  • FORCEモード追加
    セレクト画面でF10キーを押すとFORCE TO 1P→FORCE TO 2P→FORCE TO DP→無しに変える事ができます。
    FORCEとはターゲット先に譜面を写す意味で、例えば1P譜面でFORCE TO 2Pを選ぶとバトルプレイに、FORCE TO DPを選ぶとバトルダブルプレイに、
    2P譜面でFORCE TO 1Pを選ぶとごちゃ混ぜ譜面に、FORCE TO DPを選ぶと2P譜面がそのままダブルプレイとしてプレイする事ができます。

  • BMSch.08 BPM拡張機能に対応
    bemaniaDXで使われている拡張BPM仕様(ch.08)に対応しました。
    これで拡張BPMを使用したBMSをプレイする事ができます。

    ちなみに、書式方法は以下の通り(bemaniaDXマニュアルより転載)

    チャンネルナンバー08で指定できる、拡張BPM途中変更機能です。
10進数表記で小数点まで対応しています。これにより256以上のBPMにも変更可能です。
（使用例）
  #BPM01 573.59　　　　　//01番に 573.59BPM を定義
  #01208:01　　　　　　　//12小節目に01番に指定したBPMに変更

  • ENDLESS関係
    同曲被り回避の為にクリアした曲は次から選曲しないようになりました。
    また、ENDLESSをプレイした曲は全てlastplay.txtに出力されます。

  • 漢字→１バイト文字変換機能強化
    なにやら強行的な事やってます。
    とりあえず随分と偉くなったのではないかと…。

  • brd記述に"#skinstyle"追加
    1P/2P/DP用にスキンを定義する項目です。
    例えば「1P,2P」にすると、F9キーのスキン入れ替え時に1P及び2Pのみbrdを読み込みます。
    「DP」にするとDPの時のみbrdを読み込みます。

    ちなみに、起動メニューのスキンマッパーはまだ振り分け対応してないです。ご注意を。

  • ウィンドウモードで非アクティブ時にキー入力を受け付けない様に
    ウィンドウモードでnazo自体が非アクティブでも矢印キー辺りを押すと勝手に動いてましたが、今回のバージョンからnazoがアクティブ時以外は動かなくなりました。

  • スキンが新しくなってます
    変更された大部分と言えばこれでしょうか、製作に苦労しましたよ(;´Д｀)
    これにより仕様が変わってます。
      default.brd	スキン設定ファイル　通常
  default_DP.brd	スキン設定ファイル　通常(ダブルプレイ)
  default_L.brd	スキン設定ファイル　軽量版
  default_L_DP.brd	スキン設定ファイル　軽量版(ダブルプレイ)
  default_H.brd	スキン設定ファイル　ハーフ
  default_DPH.brd	スキン設定ファイル　ハーフ(ダブルプレイ)

    これらのスキンの変更方法は起動メニューの「スキン」タブで1P、2P、DPに振り分けてください。
    デフォルトではdefault.brd、default.brd、default_DP.brdとなっています。
    スクラッチ位置の変更はプレイ中にF1で1P側、F2で2P側で変更可能です。
    セレクト画面中でのF9スキン変更は無効です、プレイ中に行ってください。
    ちなみに、演奏開始直前に押すと変更が完了するまで停止します。

  • 4D、CROSS搭載、nazo廃止の代わりにDeceleを搭載
    4Dはプレイ中にF5キー、CROSSはnazoの項目に入ってます(２回押すと有効)
    また、nazoが廃止されて変わりにDeceleが搭載されています。
    中身の方は…自らやってみればわかると思います。

  • ウィンドウモード搭載、ハーフも搭載（Win2Kじゃないと見づらいかも）
    起動メニューの「その他」タブにあります。その名の通りウィンドウモードで起動可能です。
    ただしウィンドウモードを選択した場合、同時にDirectBltにもチェックが付きます。
    ハーフはウィンドウモードでのみ適用されるモードで、画面が半分になります。
    Win2Kだとアンチエイリアス処理が適用されますが、Win9xでは適用されないので、結構見難いです。

  • 内部オブジェ数上限搭載
    起動メニューの「その他」タブにあります。
    これは一つのBMS（もしくはコースプレイで組まれたBMS全て）で定義されたオブジェ数の限界値を上げるオプションです。
    デフォルトでは65536となってます。これを上げると数十曲以上組まれたエキスパートコースも難なく読み込めますが動作の保証はしません。

  • セレクトフォント変更可能
    nbm_conf.iniを開き、"font"の部分を好きなフォントに変えると、そのフォントが使える様になります。
    英字フォントを指定すると日本語が文字化けするので注意。

  • プレイ画面の背景画像機能
    brd定義ファイルの最初辺りに「//#BACKGND back_.bmp」という項目があるので、
    この最初にある「//」部分を削除し、"back_.bmp"の部分を背景画像にしたいファイル名を指定すると、
    プレイ画面に背景を付けることができます。背景画像はスキンと同じフォルダ、いわゆる_nbmfilesにないと読み込めません。
    背景画像機能は結構重いです、注意。

  • BGA拡大機能
    ※拡大修正済みのbrdと通常brdをZip圧縮で同封しておきました。これを利用するとbrdを開くこと無く変える事ができます。
    brd_bganormal.zip	通常BGA版brd
brd_large.zip		拡大BGA版brd
    手動で弄りたい方は、brdの前半部分あたりにこんな記述があります。
    #BGA_1P		192,48,256,256			// BGA表示位置(1P)
#BGA_2P		192,48,256,256			// BGA表示位置(2P)

// BGA拡大表示は以下の//を削除し、上の#BGA部分に//を付けると適用されます。

//#BGA_1P		173,  0,467,480
//#BGA_2P		173,  0,293,450

    コメント部分にも書いてある通り、BGA拡大表示は以下の//を削除し、上の#BGA部分に//を付けると適用されます。
    当然の如く拡大機能を使うと重くなります。注意。

  • 他は通常のnazoBMplayと一緒
    とりあえず一緒、かもです。

  • テスト版のバグ報告はfeedbackへ。
    改めて言っておきますがサポートは受け付けてませんので。


>> 必要環境

  • PentiumII300MHz以上のCPU
  • 64MB以上のメモリ
  • VRAM8MB以上推奨 でないとCPUが高スペックでない限りマトモに動きません。
    なお、オンボードビデオカードでの動作はほぼ絶望的だと思ってください。
  • OSはWin95/98/Me/2000/XPで動作確認済み。
    但し、VB6ランタイムとDirectX8以降必須です。


>> ファイル構成

nazobmplay.exe | 起動ファイル
nazobmplay.chm | コレ
_nbmfiles\
courselist\ | コースリストデータ
default\ | デフォルトスキン画像データフォルダ
graphic\ | セレクト画面フォント画像データフォルダ
jukelist\ | ジュークリストデータ
wav\ | セレクト画面フォント画像データフォルダ
brd_append.zip | 追加brdファイル
cnvdict.txt | 特殊文字用変換辞書ファイル
default.brd | スキン設定ファイル　TYPE-01(軽量版)
default_DP.brd | スキン設定ファイル　TYPE-01(軽量版ダブルプレイ)
default_TYPE02_DP.brd | スキン設定ファイル　TYPE-02(ダブルプレイ)
default_TYPE02_DPHL.brd | スキン設定ファイル　TYPE-02 ハーフ(ダブルプレイ)
default_TYPE02_SC.brd | スキン設定ファイル　TYPE-02(STATE)
default_TYPE02_SP.brd | スキン設定ファイル　TYPE-02
default_TYPE02_SPHL.brd | スキン設定ファイル　TYPE-02 ハーフ
default_TYPE03_1P.brd | スキン設定ファイル　TYPE-03(1P専用)
default_TYPE03_2P.brd | スキン設定ファイル　TYPE-03
default_TYPE02_2C.brd | スキン設定ファイル　TYPE-03(STATE)
default_TYPE03_DP.brd | スキン設定ファイル　TYPE-03(ダブルプレイ)
default_TYPE02_SC.brd | スキン設定ファイル　TYPE-03(STATE)
ir_bmshdr.cache | IR用キャッシュデータ
ir_bmsid.chace
nbm_conf.ini | 設定ファイル
nbm_keyconf.dat | キー設定データ
nbm_searchdir.txt | BMS検索フォルダリスト
rank_back.bmp | ランキング背景
rank_irback.bmp | IRランキング背景
rank_tips.bmp | ランキングパーツデータ
resback_a.bmp | リザルト背景(Aランク)
resback_b.bmp | リザルト背景(Bランク)
resback_c.bmp | リザルト背景(Cランク)
resback_d.bmp | リザルト背景(Dランク)
resback_e.bmp | リザルト背景(Eランク)
resback_f.bmp | リザルト背景(クリア失敗時)
resback_s.bmp | リザルト背景(Sランク)
resback_ss.bmp | リザルト背景(SSランク)
res_back.bmp | リザルト背景
res_clr.bmp | リザルト背景２(クリア時)
res_fail.bmp | リザルト背景２(クリア失敗時)
res_tips.bmp | リザルトパーツ
ssbg.bmp | セレクト画面
ssnostg.bmp | セレクト画面でのSTAGEFILE表示時に使用するノイズBMP
ssobj.bmp | セレクト画面で使用するオブジェクトBMP
ssobj2.bmp

この色の項目は起動時に自動作成されます。
この色の項目は同封されていませんので別途用意してください。
waveフォルダについてはこちらを参照


>> 起動ウィンドウ

起動すると一見見ただけでは訳の分からない設定画面が出てきます。
設定項目は４つに別れています。

>> メイン
>> BMS検索
>> スキン
>> その他
>> IR

>> メイン

nazobmplayの動作に関する設定をします。

>> 基本設定

WAVEロード方法
BMPロード方法 		ファイルの読み込み方法を指定します。
初回一括 ロード時にファイルを全て読み込みます。
一般的なロード方式です。
逐次読込 リアルタイムでファイルを読み込みます。
メモリ少ない人でHDDはまともに速いという人はコチラを選ぶと改善されるかもしれません。
Course Play時 CoursePlay時での読み込み方法を指定します。
逐次読込 | リアルタイムでファイルを読み込みます。
曲ごと | 一曲終わる事に次の曲のファイルを全て読み込みます。
初回一括 CoursePlayで組み込まれた曲全てを読み込みます。
大量のメモリが必要です。
DrawLimit プレイ画面での描画制限を行います。
低スペックな方はこれを利用すると効果があるかもしれません。
また、この機能はプレイ中やセレクト中、F11で切り替えが可能です。
無制限(1) | 表示するモノ全て表示します。これがデフォルト。
ちょっと制限(2) | 表示部分を一部表示しないようにします。
かなり制限(3) | 基本的な部分以外は全て表示しません。結構虚しいです。
DirectBlt FlipではなくBltで行います。
CPUスペックが良く、ビデオカードのメモリが少ない環境ではこの機能をオンにすると改善されるかもしれません。
NO VSYNC 垂直回帰信号と同期しません。必要時のみチェックして下さい。
CPUスペックが良く、ビデオカードのメモリが少ない環境ではこの機能をオンにすると改善されるかもしれません。
DirectBltと併用するといいです。

>> 曲セレ関係

曲リストをスムーズスクロールしない そのまんまです。
チェックをオンにすると曲セレクト時、曲リストの項目移動させる時のスムーズ移動を無くします
BMS Preview機能を有効にする 曲セレクト中、選択されているBMSをリアルタイムにデータを読み込み、同時再生を行います。
このチェックを外すと再生を行いません。
また、この機能は曲セレクト中、F7でOn/Offの設定が可能です。
xx秒後に再生開始 | 曲セレクト後、指定された秒数後に再生を行います。
Endlessモードは1Pのみ | このチェックをオンするとEndlessモード時に2PBMSやDPBMSに引っ掛からない様にします。
クリアした曲は文字色を変える このチェックをオンにすると、曲リスト時にクリアしたファイルは色が変わります。
また、Replayファイルが入っている場合、☆の部分が★に変わります。
ただし、読み込みに多少処理落ちします。

>> プレイ関係

キーコンフィグ このボタンを押すと設定画面に入ります。

設定したいボタンをクリックして、そのキーを押して下さい。
また、1,2キーでも移動可能です。
拡大処理を無効にする ゲーム中で使用されている拡大処理を全て無効にします。
拡大が苦手なビデオカードはこのチェックをオンにすると解決するかもしれません。
BGA逐次解放を有効にする 現在使用できません
use another BGA Stretch Method BGA拡大時の処理方法を変えます。
GeForce、ATI系はこれをチェックすると良くなるかと。

※このオプションはBGAを拡大するオプションではありません。BGA拡大は直接brdを弄ってください。

>> ネットワーク

接続・サーバー起動 「サーバー起動」はネットワークプレイ時に自らサーバーとなります。
「接続」はサーバーに繋げる場合に使用します。
IPウィンドウが表示されたら接続先を入力し、接続します。
ネットワークプレイはコチラ参照。
現在この機能は使用できません
あなたの名前 ネットワークプレイ時、及びハイスコア入力時に使用する名前です。
英数字半角じゃないと多分表示できません。

>> 起動

nazobmplayを起動します。

>> BMS検索

BMSの検索及び再検索を行います。
「追加」ボタンを押して追加したいフォルダを選択してください。
また、フォルダリストの中にエクスプローラ等でフォルダをドラッグ＆ドロップしても追加することができます。
要らなくなったフォルダは「削除」ボタンを押せばリストから削除できます。
ただし、リストから削除するだけで、フォルダ自体を削除する事はありません。
ちなみに「無確認で削除」にチェックを入れると問い合わせ無しでそのまま削除されます。

検索したいフォルダリストのチェックをオンにし、「検索開始」ボタンを押すとフォルダを検索し、BMSを検出します。
チェックリストをいちいち一個ずつ付ける(外す)のが面倒な方は「全選択」で全てのリストにチェックを付け、
「全解除」でリストの取り消し、「選択の反転」でチェックがオンになっているものはオフに、オフになっているものはオンになります。

基本的に読み込みは一層フォルダのみです。
１層以下のフォルダを読み込みたい場合は、「階層無制限に検索」のチェックをオンにし検索を行うと、フォルダ内にあるBMS全てを読み込みます。

>> スキン

1P,2P,DP時にロードするスキンを割り当てます。1P、2P、DPにそれぞれお好きなスキンを割り当てて下さい。
デフォルトではdefault.brd、default.brd、default_DP.brdとなっています。
なお、プレイ中に変更(F9キー)した場合はそのファイル名が保存されます。
スクラッチ位置は1P側、2P側のスクラッチ位置を割り当てます。
また、プレイ中にF1で1P側、F2で2P側でスクラッチ位置を変更可能です。

>> その他

ヘタに弄ると死にます
Windowモード プレイ画面をフルスクリーンではなくウィンドウで起動します。
これにチェックを入れると自動的にDirectBltにもチェックが付きます。
ハーフ(謎) Windowモード時のみ有効。画面の大きさを半分にします。
AGPの種類によってはアンチエイリアスがかかったりかからなかったり
Debug デバックモードです。画面に何か表示される事以外は特に何も。
内部オブジェ数制限 BMSの内部オブジェ制限数を設定します。
内部オブジェとは演奏オブジェ（不可視含む）、BGAオブジェ、バックオブジェ数を全て数えた数です。
これを65536以上にすると数十曲組み込まれたエキスパートで不都合が発生しなくなりますが、動作の保証はしません

>> IR

InternetRanking(nazoIR)専用の設定です。
プレイヤーID
パスワード 		nazoIR上で必要なIDとパスワードを入力します。
アカウントを持っていない方は新規登録で入手してください。
パスワードを保存する | パスワードを保持するにはこのチェックをオンにして下さい。
パスワードを保存する ログイン方法を設定します。
手動でログイン | このIRタブでログインしない限りログインはしません。
起動時に確認 | 起動ごとに「nazoIRにログインしますか？」というダイアログが表示されます。
自動的にログイン | 起動時に自動的にログインします。
プロキシ | 何らかの事情で直接接続ができない場合、こちらにプロキシのアドレスを入力して下さい。


>> セレクト画面

起動すると曲セレクト画面に入ります。

>> リストの見方

起動したときはjukeモードとなり、プレイしたいjukeboxを選びます。
そのあと、曲リストが表示されます。

「クリア色を変更する」にチェックを付けている場合、クリア・未クリアによって色が変わります。
  また、リプレイファイルがある場合は☆が★に変化し、更に色が変化します。

☆…リプレイ無しでクリア
★…リプレイ有りでクリア
★…リプレイ無しで未クリア
☆…リプレイ有りで未クリア

※基本的にBMS PreviewをonにしてないとTOTAL NOTESの判別ができません。

>> Key-Assign

矢印キー 上下で曲・ジューク選択 ←、→でjukeと曲の入れ替えができます。
TAB | 通常<>コース切り替え | コースモードと通常モードを切り替えます。
SPACE | コースエディット | コースセレクト中のみ有効。コース編集を行います。
DEL | コース削除 | コースセレクト中のみ有効。選んだコースの削除を行います。

1,2 | Sleep値の増減 | Sleep値を設定します。基本的に0で支障は無いでしょう。
3+1,2 | RealSpeedの調節 | BPMと共に音の早さも変わります。x0.25～x3.0まで設定可能です。
Q,W
Y,U 		Hi-Speedの調節

見た目だけ速くなるアレです
x0.25、x0.75、x1.0。x1.0からは0.5ごとに増えていきます。
0でRandom Hi-Speedです。
Q,Wは1P側のハイスピード、Y,Uは2P側のハイスピードを調整します。
また、DP譜面のみ両方統一で調整できます。

※ハイスピ変更キーはキーコンフィグで変更可能です

5 | BGA on/off | BGAを表示します。BGAがoffの時は読み込み時にBGAを読み込みません。
7,8 Volumeの調節 音量を調節します。
ちなみにコレ、Windows自体の音量を弄っています。

F1 | Hidden | オブジェクトが途中から消えます。
Sudden | オブジェクトが途中から現れます。
Hid+Sud | オブジェクトが瞬時に表示されます。
Stealth | 小節線以外は何も表示されなくなります。
F2 Random
(1P/DP) 		オブジェクトが列ごとにランダム配置になります。
1P側適用・両方適用の２種類あります。
Shuffle
(1P/DP) 		オブジェクトが一個一個ランダム配置になります。
1P側適用・両方適用の２種類あります。
ExRand | オブジェクトが一個一個ランダム配置になりますが、途中までどこに配置されるかわかりません。
MIRROR
(1P/2P/DP) 		オブジェクトが左右反転された配置になります。
三種類あり、1P側・2P側・両方にそれぞれに適用されます。
F3 | Accel | オブジェクトが加速しながら落ちてきます。
Dccel | オブジェクトが減速しながら落ちてきます。
F4 | CROSS | 判定バーが真ん中になって、白鍵盤は上から、黒鍵盤＋スクラッチが下から来ます。
F5 | 4D Mode | オブジェがバラバラに降ってきます。
F6 RECORD BMSのプレイを記録します。プレイしたデータはリプレイファイルとして記録されます。
リプレイファイルは基本的にRECORDをオンにした状態で最後にプレイしたデータが記録されます。
REPLAY | リプレイファイルがあればリプレイを再生します。
F7 | BMS Preview on/off | 選択されているBMSをリアルタイムにデータを読み込み、同時再生を行います。
F8 AutoPlay
(1Pon/2Pon/1P2Pon/off) 		BMSを自動的に演奏します。
F8キーを押すたびに1P側のみ→2P側のみ→両方→オフが選べます。
F9 AutoScrath
(1P/2P/DP) 		スクラッチのみ自動演奏になります。
順に押すと1P側→2P側→両方に設定できます。
F10 FORCE TO 1P/2P/DP/DP(EXCAHNGE) FORCEとはターゲット先に譜面を写す意味で、
例えば1P譜面でFORCE TO 2Pを選ぶとバトルプレイに、FORCE TO DPを選ぶとバトルダブルプレイに、
2P譜面でFORCE TO 1Pを選ぶとごちゃ混ぜ譜面に、FORCE TO DPを選ぶと2P譜面がそのままダブルプレイとしてプレイする事ができます。
FORCE TO DP(EXCHANGE)は2P/ダブルプレイの譜面を1P側2P側入れ替えます。
F11 DrawLimit 1,2,3 プレイ画面での描画制限を行います。
数字が大きくなるほどヘボくなります。
F12 PRESSURE(緑) １回でもミスると即死です
結構緊張します。
PRESSURE(黄) GOOD以下を出すと即死です
どこかのゲームで言うライフ無し鬼モード
PRESSURE(赤) GREAT以下を出すと即死です
つまりオールパーフェクト出さないと無理
Cruel | 判定がものすごく厳しくなるモードです。

Num 1 レベル順にソート ソートを行います。同じキーを押すと順番が変わります。
あまり役に立ちません。
Num 2 | ジャンル順にソート
Num 3 | タイトル順にソート
Num 4 | アーティスト名順にソート
BS レベル順にソート プレイヤー数のフィルタリングを行います。
同じキーを押すたびに1P→2P→DP→オフになります。

Enter | 決定 | 選択した曲/juke/コースを決定します。
Shift+
Enter 		拡張決定 通常曲セレ時: ゲージがexモードになります。
ジューク選択時: Endlessモードになります。

ESC | 終了 | 終了
SIHFT+ESC | 強制終了 | 強制的に終了します。

>> コースプレイ時

TABキーを押すとコースプレイのリストが出てきます。 Enterキーで設定されたコースをプレイします。 [MAKE NEW COURSE]、もしくは既に存在するコースでスペースキーを押すと COURSE EDITOR画面になります。↑↓キーで項目を選択し決定してください。
COURSE NAME | コース名。ファイル名になります。
STARS | ☆の数。プレイには影響しません。画面上のみ。
[曲リスト] | Enterで曲変更できます。
[ADD NEW SONG] | 新規に曲を追加します

編集を終えた後、F10キーを押すと保存されリスト画面に戻ります。
ESCで保存せずにリストへ戻ります。

コースの曲数の制限は128曲までです。
ただし、内部オブジェ65536個を越えるとプレイできません。
この件に関しては内部オブジェ制限数を変える事により回避する事ができます。
詳しくは→起動ウィンドウ


>> プレイ画面

曲を設定するとデータを読み込み、プレイ画面になります。
これは説明するまでも無いでしょう。

>> 基本ルール

押されたタイミングによってPERFECT/GREAT/GOOD/BAD/POORの５つの判定にわかれます。
GOOD以上でグルーヴゲージが上がり、BAD以下で下がります。
最終的にグルーヴゲージが８０％以上になっていればクリアです。

また、GOOD以上だとコンボとなり、数値がどんどん上がっていきます。
ただし、BAD以下だとコンボか切れ、また１から数え直しとなります。

>> 基本操作

デフォルトではz,x,c,vが白鍵盤、s,d,fが黒鍵盤、ShiftとSpaceがスクラッチです。
1,2 | Sleep値の増減 | Sleep値を設定します。基本的に0で支障は無いでしょう。
3+1,2 RealSpeedの調節 BPMと共に音の早さも変わります。x0.25～x3.0まで設定可能です。
ただし、これを使用した時点でスコア記録が無効になります。
Q,W
Y,U 		Hi-Speedの調節

見た目だけ速くなるアレです
x0.25、x0.75、x1.0。x1.0からは0.5ごとに増えていきます。
0でRandom Hi-Speedです。
Q,Wは1P側のハイスピード、Y,Uは2P側のハイスピードを調整します。
また、DP譜面のみ両方統一で調整できます
Q,Wを同時押しするとCOMBOLinkedHispeedになります。

5 BGA on/off BGAを表示します。
曲セレ時で既にoffしていた場合はonにしてもBGAを表示できません。
7,8 Volumeの調節 音量を調節します。
ちなみにコレ、Windows自体の音量を弄っています。

F1,F2 | スクラッチ位置変更 | スクラッチの位置を変更します。F1で1P、F2で2P。
F8 AutoPlay
(1Pon/2Pon/1P2Pon/off) 		BMSを自動的に演奏します。
F8キーを押すたびに1P側のみ→2P側のみ→両方→オフが選べます。
F9 スキン切り替え スキンを切り替えます。
演奏開始直前に押すと押し続けてる間は演奏を始めません
F11 DrawLimit 1,2,3 プレイ画面での描画制限を行います。
数字が大きくなるほどヘボくなります。

ESC 演奏中止 演奏中止します。
ただし、0.5秒以上押さないと適用されません。
このキーを押した後、リザルトは出ますがスコアは記録されません。
SIHFT+ESC | 強制終了 | 強制的に終了します。
Scroll Lock | 時計on/off | 時計・バージョン情報のon/off切り替えをします。

>> 表示関係

Score ２０万点満点で表示されます。
コースプレイの場合はExポイントで表示されます。
j-pts 別のスコア表示です。判定度が更に細かくなり、
スコアも違ってきます。BAD以下だとスコアが下がります。


>> リザルト画面

曲終了後、リザルト画面となり結果が表示されます。
EnterキーまたはESCキーを押すとそのままハイスコアランキング画面になります。
適当に名前を入力してEnterキーを押すと保存され、曲セレクト画面に戻ります。
(IRにログオンしている場合は、このままIRスコア登録画面に移ります)
ランキングは一つのBMSごとに保存され、最大１０位まで保存可能です。

ただしスコアがランキング外だったり、以下のような事を行うとリザルト表示後、そのまま曲セレクト画面に戻ります。

・AutoPlayがONになっている場合
・プレイ中、RealHispeedを変更をした場合。
・プレイ中に一時停止キーを押した場合。

また、下記の状態ではスコアが記録できません（ランキング入力画面は出ますが入力した項目が反映されません）

・BMSのフォルダに書き込み禁止属性がついている場合。


IR

>> IR モードについて

IR ログイン済み状態で曲をプレイすると、プレイ終了後に IR 登録画面が出てきます。
ローカルランキング(10位)で名前を入力済みの場合はコメント入力に移ります。
そうでなければまずスコアネームを入力して、 Enter キーで決定してください。
コメント入力では漢字が使えます。 128 文字以内でコメントを入力して下さい。とりあえず何も入力せずに Enter でも構いません。

入力終了後に IR へスコアの送信を行います。スコアの送信が正常に終了すると結果が表示されます。
なお、ここで表示される結果は、その時のスコアの結果です。
  All = その曲全体でのランキング
  Player = その曲のプレイヤー中のランキング
  Self = その曲の自己ランキング

ランキングはnazoIR webから見ることができます。

なお、 IR は現在の所 BMS 単体と、イベントモードのコースのみに対応しています。

>> リプレイアップロードについて

IR ログイン済みで尚かつ、リプレイ RECORD モード時に、 IR スコア登録を行うと、自動的にリプレイファイルもアップロードします。

このとき、 Tar32.dll を入れてあると、アップロード前に圧縮してからアップロードするので、転送に掛かる時間を 8 割短縮できます。
入れていなくても転送はできますが、低速回線だと少し待たされます。

・Tar32.dll のインストール方法:
   caldix (K.INABA) を使うと簡単にインストールできます。
  http://www.kmonos.net/lib/caldix.html

>> OCX が無い場合

> 実行時エラー'339';
> コンポーネント'MSWINSCK.OCX'、またはその依存関係のひとつが適
> 切に登録されていません。ファイルが存在しないか（略

のようなエラーが出てくる人は、
http://www.runan.net/program/runtime/download.cgi?ocx+MSWinSck.lzh
からファイルを落として解凍して、
MSWinSck.inf を右クリック→インストールしてください。

>> レジストリ情報が不正な場合

> WinSock コントロールのレジストリ情報が不正か、あるいは WinSock
> コントロールが正常にインストールされていません。
( あるいは新規登録が checking status... で止まる、等 )

のようなエラーが、レジストリ情報が不正な場合に出ることがあるよ うです。この場合は、 RegCleaner というソフトを利用してレジスト リ情報を削除して下さい。

(RegCleaner についてはこちらのサイトを参照)
http://ringonoki.net/tool/system/regcleaner.html


>> 効果音

_nbmfiles\wavに以下のファイルを置くと音が鳴ります。
selstart.wav | 曲セレ開始時の音
select.wav | 曲セレ時のBGM(ループ)
sngchg.wav | 曲スクロール時の音
sngdecide.wav | 曲決定時の音

fade.wav | 画面切り替わりの音
loading.wav | 曲ロード時のBGM(ループ)
ready.wav | 曲開始時の音
res_clear.wav | リザルト(cleared)
res_fail.wav | リザルト(failed)
ptscount.wav | 得点カウント音(ループ)


>> ネット対戦

現在のバージョン(UnOfficial1025版)ではネット対戦自体使用不可です。ご注意ください

nazoBMplayでは、DirectPlayを利用して他ＰＣ間でのネット対戦ができます。
とは言っても、プレイ画面横に他プレイヤーの情報が表示されるだけですが。

まず、ネット対戦をするには誰かがサーバーになる必要があります。
その為にはサーバー側になる人が自分の現IPを相手に教えなければなりません。
自分の現IPを知るにはスタートメニューの「ファイル名を指定して実行」→「winipcfg」を実行し、グローバルIPを相手に伝えて下さい。
Windows2000の場合はコマンドプロンプトで「ipconfig」を実行すると確認することができます。

IPを教えたらサーバー側は「サーバー起動」ボタンを押します。
起動したらそのまま曲セレ画面に入りますが、普段の曲セレ画面と変わりません。

クライアント側は「接続」ボタンを押して、IP入力ウィンドウが出るのでIPを入力してサーバーへ接続して下さい。
接続が成功すればそのまま曲セレ画面に入ります。

自分以外に参加者がいれば画面右側に情報ウィンドウが表示され、相手の選曲状況が確認できます。
全員が曲を決定すればゲーム開始となります。

プレイ中は画面右側に情報ウィンドウが表示される事以外は普段の画面と一緒です。

一応、テンキーの番号で対戦相手に攻撃できます。今のところ攻撃回数無制限です。
ネットワーク対戦字に右上に表示されるパネルの番号をテンキーで１つ押すとその相手に「邪魔」が入ります。

演奏終了するとリザルト画面が表示されます。
ただし、相手の演奏が完了するまで曲セレ画面へは戻れません。

突然操作できなくなったり、相手の反応が無くなった場合はSIHFT+ESCを押して強制的終了してください。
また相手が何らかの理由で落ちたりすると不安定になるのでもしそうなった場合もSIHFT+ESCを押してください。

ちなみに、この機能自体にチャット機能は存在しないので、JavaチャットかIRCと併用するといいです。


>> ジョイスティックについて

nazoBMplayではジョイスティックに対応してますが、まだ怪しいです。
とりあえず、使う上での注意点ですが…
  • キーコンフィグについて
    キーコンフィグ画面で「認識数: 0」だと認識されてません。
    コントロールパネルでちゃんと設定できてるか確認してください。
    キーコンフィグは通常のキーボード時と同じ操作で設定できます。

    普通は「XY軸移動を検知」はoffで大丈夫なはずです。必要な場合だけonの方向で。 ビーマニコントローラー使用時は「特殊キー」で
          →「ESC」 をSTARTボタンに
          →「★」 をSELECTボタンに
    割り当てといてください。いろいろ便利ですので。

  • 曲セレについて。
    下の「ビーマニコントローラ使用時の曲セレ」の説明を参考にしてください。


>> ビーマニコントローラ使用時の曲セレ

一応、スクラッチでも曲選択は出来ます。
が、どうもウチではPSジョイパッドminiのドライバーが「一つのボタン」としての
値しか教えてくれません。というかコントローラが回し具合に対応してないっぽい。

・・・これじゃぁ回し具合で速くしたり遅くしたり出来ません。

仕様とさせてくださゐ。

なお、回し続けると加速していくってコトで一応。

       ②④⑥	Ｓ: 曲選択
       ｜｜｜	①,③,⑤,⑦: 決定。②押しながら決定とかも可。
       ■■■
  ○　□□□□	②: SHIFTキーの代わりになります。
  ｜　｜｜｜｜	④: 「←」キーの代わり。曲セレからジュークセレに戻る時に。
  Ｓ  ①③⑤⑦	⑥: TABキーの変わり。(コース/通常モード切替)

  キーコンフィグで★キーを割り当てた場合は以下の操作も可能です。

        ★+Ｓ: HiSpeed調整

        ★+①: F1キーと同等(HIDDEN/SUDDEN/STEALTH)
        ★+③: F2キーと同等(RANDOM/ExRand)
        ★+⑤: F3キーと同等(Accel)
        ★+⑦: F4キーと同等(Nazo)

        ★+②: フルキーの[5]キーと同等(BGA on/off)
        ★+④: F8キーと同等(DEMO on/off)
        ★+⑥: F12キーと同等(PRESSURE on/off)
尚、この配置は変わることがあります。ってーか変わります。ご了承を。


brd解析ファイル

brdとは何？

いわゆるnazoBMplayでのスキン定義ファイルです。略称は多分ありません。
これはnazoBMplay0622版以降で適用され、スキンのほぼ全てがこのファイルを利用することにより自由にカスタマイズすることができます。

このファイルは何？

そんな自由にカスタマイズ可能なbrdの解析ファイルだったりします。
brd自体は分かり易くできていますので、理解できる人は簡単に作ることができますが、まぁとりあえず。
ちなみに、UnOfficialに入ってるbrdの説明文章は仕様が全然決まってなかった頃に書いたのでデタラメだったりします。
それぞれ一項目ずつ説明するにあたって、特定のコマンドのみ色分けされています。
その色分けと意味は以下の通り。
青：今後仕様が変更される可能性あり
赤：今のところ未実装。今後実装される予定
緑：未実装。今後削除される可能性あり
基本的に全てにおいて仕様が変更される可能性がありますが、これらの色は最も変更される可能性がある項目です。

基本事項

基本的には
#command param [,param2,param3...]
というルールで指定します。
スペースもしくはtabがcommandとparamの区切りです。param同士は","
必要に応じて桁揃えなどを行っても可です。

なお、commandの大文字小文字は区別されません。全角半角は区別されます。

"//"以降はコメントと見なされます。
尚、先頭が#でない行は読みこみ時に全て無視されます。
(特に先頭に"//"を付けなくてもコメント扱いです)

brd構成

brdの構成は以下の５つに分けられます。

▽システム・汎用オブジェクト定義
▽表示位置/オブジェ定義
▽スコア数字定義/スコア表示定義
▽ネットワーク部分定義
▽OPTIONランプ関係

の以上五項目です。（リンクの部分をクリックすると直接その項目へ飛ぶことができます）
この五項目にわけてbrdを解析していきます。

システム・汎用オブジェクト定義

▽#TITLE [titlename]
スキン定義ファイルのタイトルです。
起動メニューのスキンマッパーにタイトルとして使われています。
目印としてドウゾ。

定義例：タイトルを「nazobmplay [DEFAULT-skin for 1P/2P]」にする
#title nazobmplay [DEFAULT-skin for 1P/2P]

▽#skinstyle 1P,2P,DP
1P/2P/DP用にスキンを定義する項目です。
例えば「1P,2P」にすると、F9キーのスキン入れ替え時に1P及び2Pのみbrdを読み込みます。
「DP」にするとDPの時のみbrdを読み込みます。

▽#YPOSBASE height
譜面が流れてくる大きさを指定します。
heightに特定の数値をドット単位で入れてください。
（大体300～400辺りが良いです）

定義例：譜面の流れてくる大きさを360ピクセルに設定
#YPOSBASE	360

▽#FILEch [filename]
スキンの元となる画像データを読み込みます。ファイル形式はbmpのみです。
chは個別の番号。00～FFまで指定可能です。
（現バージョンでは09までしか読み込めません）
filenameは読み込むファイル名を指定します。

定義例：ファイルID01にskin_default_a.bmpを読み込みます。
#FILE01 skin_default_a.bmp

▽#SYSFONT left, top, width, height
システムフォントを読み込みます。
システムフォントの文字位置は下記のように固定されており、順番を間違えると正しく表示できません。

!"#$%&'()*+.-,/0123456789:;<=>@ ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_` abcdefghijklmnopqrstuvwxyz{|}~ フォントを用意した後、一番左上にある「！」の部分の左上の座標と大きさ指定すれば、
そのままシステムフォントとして読み込みます。
定義例：X座標273px、Y座標455pxに縦横それぞれ8pxの大きさのシステムフォントを取り込みます。
#SYSFONT 	273,455,8,8

▽#SONGINFO x, y, width, height
▽#MSGPOS x, y, width, height
曲情報、及びシステム情報の表示位置を定義します。
大きさはシステムフォントの大きさに合わせてください。
x,yは座標、width,heightは行数、桁数ではなく行数（１行固定）と桁数をシステムフォントの大きさでかけた数値を指定して下さい

定義例：X座標252px、Y座標10pxに横203px、縦9pxの範囲に情報を表示します。
#SYSFONT 	252,10,203,9

▽#BGA_1P x, y, width, height
▽#BGA_2P x, y, width, height
BGAを表示する座標と大きさを定義します。
BGAの大きさは256x256が通常表示で、この数値以外を指定すると拡大表示（もしくは縮小表示）となります。
1Pは1P時、2P時は2P時もしくはDP時に表示されるBGA定義です。

定義例：1P時にX座標370px、Y座標98pxに横縦256pxの大きさでBGAを表示します。
#BGA_1P		370,98,256,256

▽#CLIPch bmpID, left, top, width, height[, dir, spacing, frames, interval], invisible
凡用オブジェクトID定義です。これを利用してスキン画像からそれぞれのデータを取っていきます
後にこのCLIPを利用していろいろなオブジェ定義をしていきます。
定義内容は以下の通り。

 ch	ID	個別の番号。00～FFまで指定可能です。

 bmpID	ID	#FILEchのch部分です。このファイルから切り抜きます。
 left	数字	クリップ範囲の左辺 (ピクセル)
 top	数字	クリップ範囲の上辺 (ピクセル)
 width	数字	クリップ範囲の幅 (1コマの)
 height	数字	クリップ範囲の高さ (1コマの)
これは、#FILEで指定された画像内にあるx座標(left)とy座標(top)の位置からwidthとheightで指定された大きさで取っていきます。
以下、アニメーション定義です。アニメーションしない場合は不要です。
 dir	1,2	方向(1=右方向へ,2=下方向へ)
 spacing	数字	1コマ1コマの間の間隔を指定します(区切り線避け)
 frames	数字	総コマ数を指定します
 interval	数字	アニメーションする間隔を時間単位もしくはピクセル単位
        で指定します。(負の値を指定するとピクセル単位です)
dirは並べられたアニメーションデータの方向を指定します。
spacingはアニメーションパターンごとに間に区切りがある場合に指定します。
区切りが無い場合は0で構いません。
framesはアニメーションする数です。framesで指定されたアニメーションのスピードはintervalで決定されます。
時間単位はms単位となっています。ピクセル単位は曲プレイ中のBPMによって変動します。

ちなみにinvisibleは透過率の指定だったのですが、廃止するかもです。

定義例：CLIPID番号７番にFILEナンバー01の画像のX座標25、Y座標1、横の大きさ158、縦の大きさ360のパターンを格納します。
#CLIP07 01,25,1,158,360

低比例：CLIPID番号１番にFILEナンバー01の画像のX座標285、Y座標157、横の大きさ18、縦の大きさ8のパターンを指定した後
        そこから下方向に１ドット間隔で8パターンを格納。再生スピード48msに設定してアニメーションとして再生します。
#CLIP01 01,285,157,18,5,2,1,8,48

表示位置/オブジェ定義

▽#NOTEch clip, LASERclipID, AUTOclipID, LX, RX, REPLAYclipID
それぞれのキーとオブジェIDをを関連づけます。
これで指定した座標の縦0pxからYPOSBASEで指定されたpxまで譜面が落ちてきます。
定義内容は以下の通り

ch		ID	個別の番号。
            11～19は1P(L)、21～29は2P(L)
clip		ID	CLIPで指定された番号のオブジェを指定します
LASERclipID	ID	叩くと光るレーザーのClipID
AUTOclipID		ID	オートプレイパート時のclipID
LX		数字	左スクラッチでのX座標表示位置
RX		数字	右スクラッチでのX座標表示位置
REPLAYclipID	ID	リプレイオブジェクトのClipID

chはBMSのチャンネルフォーマットと一緒で、11～15が１鍵盤目～５鍵盤目、16がスクラッチ、18,19が６，７鍵盤目です。
2Pはそのまま十の位を2に変えて下さい。
リプレイオブジェクトのCLIPデータは必ずアニメーション指定でPRFECT、GREAT、GOOD、BAD、POORの5パターンの順に並べてください。

定義例：１鍵盤目(11ch)のレーザーの画像をオブジェID8番、オートプレイパート時の画像をオブジェID81番
        左スクラッチ時のX座標を49に、右スクラッチ時のX座標を16に、リプレイオブジェの画像をオブジェID0C番に設定します。
#NOTE11 01,09,81, 49, 16,0c

▽#LONGNOTEch ONup, ONmiddle, ONdown, OFFup, OFFmiddle, OFFdown

ch		ID	個別の番号。
            11～19は1P(L)、21～29は2P(L)
ONup		ID	ロングノートの最上部を指定します。
ONmiddle	ID	ロングノートの中間部を指定します。
ONdown		ID	ロングノートの最下部を指定します。
OFFup		ID	ロングノート(失敗)の最上部を指定します。
OFFmiddle	ID	ロングノート(失敗)の中間部を指定します。
OFFdown		ID	ロングノート(失敗)の最下部を指定します。

chはBMSのチャンネルフォーマットと一緒で、11～15が１鍵盤目～５鍵盤目、16がスクラッチ、18,19が６，７鍵盤目です。
2Pはそのまま十の位を2に変えて下さい。
なお、ロングノートの縦サイズは全て通常のオブジェと同じサイズの物を指定して下さい。
特に中間部分は数値が小さければ小さいほど処理が重くなります。

▽#LAYERch clip,X,Y,2P
それぞれの部分とオブジェIDをを関連づけます。
いわゆる「枠部分」や「ベースパネル」となる部分はこれで指定します。
定義内容は以下の通り

ch		ID	個別の番号。00～FFまで指定可能です。
clip		ID	CLIPで指定された番号のオブジェを表示します
X		数値	横座標です。数値は0～640まで指定可能です。-1で非表示です。
Y		数値	縦座標です。数値は0～480まで指定可能です。-1で非表示です。
2P		数値	2P及びDP時のみで表示するオプションです。1で2P・DPのみ表示

これを利用すれば画面内に最大２５６個まで"飾り"を置くことができます。
また、アニメーション定義がされているオブジェIDはinterval間隔でアニメーションされます。

定義例：2P/DP時のみオブジェID30番をX座標0、Y座標0に表示する。
#LAYER01 30,  0,  0,1

▽表示位置/オブジェ定義(特殊)
ゲージ表示や判定文字等の特殊定義については特殊な命令の名前を使用します。
特に特殊な物が無い限り定義は全てCLIP,X,Yで固定されています。

☆#LINE_1P_Lch
☆#LINE_1P_Rch
☆#LINE_2P_Lch
☆#LINE_2P_Rch

縦線を表示します。
1P,2PそれぞれLは左スクラッチ用、Rは右スクラッチ用に分けられています。
chは00～16まで指定可能です。

☆#LENBARch

曲の長さバーを表示します。
このバーは曲の時間が経っていくうちに、上から段々と消えていきます。
chは1～4まで指定可能です。

☆#KEY1P_L
☆#KEY1P_R
☆#KEY2P_L
☆#KEY2P_R

キーパネルを表示します。
#LINE同様、1P,2PそれぞれLは左スクラッチ用、Rは右スクラッチ用に分けられています。

☆#JUDGEPOS_1P_L
☆#JUDGEPOS_1P_R
☆#JUDGEPOS_2P_L
☆#JUDGEPOS_2P_R

判定バーを表示します。
判定バーは必ずYPOSBASEから判定バーの縦の大きさを引いた分の所に置いて下さい。
#LINE同様、1P,2PそれぞれLは左スクラッチ用、Rは右スクラッチ用に分けられています。

☆#BLIGHT_ch ClipID,LX,LY,RX,RY

特殊設定の部類に入る、光るキーパネルです。
光る場所はchに応じて変わります。
ちなみにchはBMSのチャンネルフォーマットと一緒で、11～15が１鍵盤目～５鍵盤目、16がスクラッチ、18,19が６，７鍵盤目です。
LX,LYは左スクラッチの座標、RX,RYは右スクラッチの座標となります。

☆#GAUGEPOSBG_1P ClipID,X,Y,dir
☆#GAUGEPOS_1P ClipID,X,Y,dir
☆#GAUGEPOSBG_2P ClipID,X,Y,dir
☆#GAUGEPOS_2P ClipID,X,Y,dir

上から順に1Pグルーヴゲージ背景、1Pグルーヴゲージ、2Pグルーヴゲージ背景、2Pグルーヴゲージ。
こちらもちょっと特殊で、通常の設定にdir追加されています。
dirはグルーヴゲージの方向を設定します。1は左方向、2は右方向です。

☆#EXGAUGEPOSBG_1P ClipID,X,Y,dir
☆#EXGAUGEPOS_1P ClipID,X,Y,dir
☆#EXGAUGEPOSBG_2P ClipID,X,Y,dir
☆#EXGAUGEPOS_2P ClipID,X,Y,dir

#GAUGUPOS～と一緒です。

☆#1PGAUGEHIDPOS 83, 16,456
☆#2PGAUGEHIDPOS FF,424,456

ゲージHiddenで使うバーです。使う予定無いというかベース側で対応させちゃったのでそのうち廃止予定。

☆#CLASS_1P c8,403,379
☆#CLASS_2p c8,403,379

判定クラスを表示します。この場合、CLIP側での設定が特殊です。
SS,S,A,B,C,D,Eを順にIDを連続して割り当てさせた後、SSのclipIDを指定してください。

☆#JUDGE_PERFECT_1P
☆#JUDGE_GREAT_1P
☆#JUDGE_GOOD_1P
☆#JUDGE_BAD_1P
☆#JUDGE_POOR_1P
☆#JUDGE_PERFECT_2P
☆#JUDGE_GREAT_2P
☆#JUDGE_GOOD_2P
☆#JUDGE_BAD_2P
☆#JUDGE_POOR_2P

判定の表示位置を定義します。
判定文字の隣にコンボ数が表示されます。
ちなみにDPは1Pしか表示されません（そのうち変更予定）

☆#FAN00_1P
☆#FAN20_1P
☆#FAN80_1P
☆#FAN99_1P
☆#FAN00_2P
☆#FAN20_2P
☆#FAN80_2P
☆#FAN99_2P

グルーヴゲージによって変化するアニメーション（通称：ファン）の表示位置を定義します。
グルーヴゲージが0%、20%、80%、99%によってファンも変わります。
ちなみに数値は固定です。

☆#BOMB_PERFECT
☆#BOMB_GREAT
☆#BOMB_GOOD

PERFECT、GREAT、GOOD判定時のボムを指定します。
アニメーションで１ループで消えます。
ちなみにclipIDのみで座標を指定する必要はありません。

☆#MODE_FREE
☆#MODE_RANKING
☆#MODE_PRACTICE
☆#MODE_ENDLESS
☆#MODE_EXPERT

現在プレイ中のモードを表示します。
まだ未実装です。

☆#NOMISS
☆#MAXCOMBO
☆#PRESSURE
☆#COMBOGRAPH
☆#COMBOGRAPHBG

上から順にNO!MISS、MAXCOMBO、PRESSURE、コンボグラフ、コンボグラフ背景となります。
座標を指定する必要はありません（そのうち指定できる様にする予定）

▽#GAUGESTEP spacing

ゲージの間隔を設定します。
spacingはxピクセルおきに描画します。

スコア数字定義/スコア表示定義

▽#NUMch bmpID, left, top, width, height, spacing, spacing2, invisible

スコア数字を指定します。
画像は左から順に[空][0][1][2][3][4][5][6][7][8][9][-][.][:]を用意して下さい。
詳しい定義は以下の通り

bmpID	ID	#FILEchのch部分です。このファイルから切り抜きます。
left	数字	クリップ範囲の左辺 (ピクセル)
top	数字	クリップ範囲の上辺 (ピクセル)
width	数字	クリップ範囲の幅 (1コマの)
height	数字	クリップ範囲の高さ (1コマの)
spacing	数字	1コマ1コマの間の間隔を指定します(区切り線避け)
spacing2	数字	スコア一桁一桁の間の間隔を指定します。

画像の[空]の部分のX座標,Y座標と大きさを指定すれば、左から順に数字を取り込みます。
ちなみに、invibisibleはCLIP同様搭載予定はありません。

▽表示位置/オブジェ定義(スコア)
スコア表示定義は全て#name clip, X, Y [, figure]で固定されます
詳しい定義は以下の通り

name	名前	特殊定義の名前です。
ch	ID	個別の番号。00～FFまで指定可能です。
clip	ID	NUMで指定された番号のオブジェを表示します
X	数値	横座標です。数値は0～640まで指定可能です。-1で非表示です。
Y	数値	縦座標です。数値は0～480まで指定可能です。-1で非表示です。
figure	数値	桁数を設定します。
特殊設定の名前は以下の通り。
#COMBONUM | コンボ数字（これに限り座標はいりません）
#SCORE_1P | 1Pスコア
#J-PTS_1P | 1PJ-PTS
#MAXCOMBO_1P | 1PMAXCOMBO
#GAUGE_1P | 1Pグルーヴゲージ
#SC_PERFECT_1P | 1PPERFECT数
#SC_GREAT_1P | 1PGREAT数
#SC_GOoD_1P | 1PGOOD数
#SC_BAD_1P | 1PBAD数
#SC_POOR_1P | 1PPOOR数
#SC_PERFECT_2P | 1PPERFECT数
#SC_GREAT_2P | 1PGREAT数
#SC_GOoD_2P | 1PGOOD数
#SC_BAD_2P | 1PBAD数
#SC_POOR_2P | 1PPOOR数
#MAXCOMBO_2P | 2PMAXCOMBO
#SCORE_2P | 2Pスコア
#J-PTS_2P | 2PJ-PTS
#GAUGE_2P | 2Pグルーヴゲージ
#FPSPOS | FPS表示位置
#BPMPOS | BPM
#PLAYPOS | PLAYTIME
#PLAY_FULLPOS | PLAYTIME(全)
#COUNTPOS | COUNT数
#STAGEPOS | STAGE数(FREEでは非表示)

ネットワーク部分定義

ネットワークプレイ時の設定を行います。
ネット機能自体仕様が纏められていないので仮の状態です。
仕様が変更されるかもしれませんがとりあえず書いておきます。
ネットワーク設定の定義は全て#name clip, X, Y [, figure]で固定されます
詳しい定義は以下の通り

name	名前	特殊定義の名前です。
clip	ID	CLIPで指定された番号のオブジェを表示します
X	数値	横座標です。左上からの位置を相対指定で指定します。
Y	数値	縦座標です。左上からの位置を相対指定で指定します。
特殊設定の名前は以下の通り。
#NETBASEPANEL | ネットワーク情報ベースパネル
#NETEXGAUGEBGPOS | ネットワークエキスパートゲージ(無)
#NETEXGAUGEPOS | ネットワークエキスパートゲージ(有)
#NETGAUGEBGPOS | ネットワークグルーヴゲージ(無)
#NETEXGAUGEPOS | ネットワークグルーヴゲージ(有)
#NETPOWERBGPOS | ネットワークパワーゲージ(無)
#NETPOWERPOS | ネットワークパワーゲージ(有)
#NETPOWERHIDPOS | ネットワークパワーゲージ(Hidden)
#NETEXGAUGEHIDPOS | ネットワークグルーヴゲージ(Hidden)
#NETINFOPLAYPOS | (P)lay プレイ中ランプ
#NETINFOLOADPOS | (L)oad ロード中ランプ
#NETINFOFNISHPOS | (F)inish プレイ完了ランプ
#NETINFOATKPOS | (A)ttack 攻撃中
#NETPOWERLEVELPOS | LEVEL(1～4) 技レベル

▽表示・スコア

基本は上記と一緒で、IDはNUMからとります。
#NET_SCORE | スコア
#NET_JPTS | J-PTS
#NET_PERFECT | PERFECT
#NET_GREAT | GREAT
#NET_GOOD | GOOD
#NET_BAD | BAD
#NET_POOR | POOR
#NET_MAXCOMBO | MAXCOMBO
#NET_GAUGE | グルーヴゲージ
自分用にPOWERゲージを設置（上固定）
※これは相対位置無効
#POWERPOS_1p | POWERゲージ本体
#NETPOWERBGPOS_1p | POWERゲージ背景
#NETPOWERPOS_1p | POWERゲージ
※どうであれ、この部分はまだ完全に仕様が決まってなかったりします。

▼OPTIONランプ関係

このOPTIONランプは何かプレイオプション(Hidden、Random等)をかけた時に光るランプの事です。
この定義は全て#name clip,1PX,1PY,2PX,2PYで固定されます。
#OP_Hidden | Hidden
#OP_Sudden | Sudden
#OP_HidSud | Hidden+Sudden
#OP_Stealth | Stealth
#OP_Random | Random
#OP_Shuffle | Shuffle
#OP_ExRandom | EX.Random
#OP_Mirror | Mirror
#OP_Accel | Accel
#OP_NAZO | Dccel
#OP_AutoPlay | DEMO
#OP_Replay | Replay
#OP_PREESURE | PREESURE
#OP_CROSS | CROSS
#OP_Reverse | Reverse

written by AOiRO_Manbow
Ver.20010812


>> バグ・仕様

  • VRAMが少ない環境ではマトモに動作しません。
  • 2P譜面でのスコア入力時は1Pしか受け付けません。
  • クリアチェック後、ソートを行うとクリアした曲とリストの曲がずれてしまいます。
  • 数字が規定の桁数を越えると振り切れて表示されます。
  • 曲セレクト中にテンキーの３押したら固まります。
  • PREESUREモードで80%以上ゲージが越した状態でミスするとリザルト時にクリア音楽が。
  • 鍵盤の光るタイミングが早いかも。
  • プレイ中、F7を押すと終了。
  • ネットワーク関係がマダ。
  • 判定が甘いのは仕様
  • ２Ｐ側プレイなんてできないよ！


（無題）

よくある質問

▼BMSはどこにありますか？ New!!

適当にGoogleで検索かけてください。

下記のサイトから探すのも手です。

BMS memo
http://cherry.webdos.net/~bmsm/

Bms Journal
http://www.bmsjournal.net/

b.i.n.
http://dot908.s17.xrea.com/bin/ (旧)
http://bin.dot908.net/ (新)

re-rise
http://bmanbo.system.to/rerise/

Re-3
http://www.re-3.com/

BMS Labo
http://members.jcom.home.ne.jp/yasuoku/

←目次へ戻る

▼「起動」ボタンを押しても何も反応が無い。 New!!

DirectX7以降が入っていない可能性があります。
Microsoftのサポートページに行って、DirectXの最新版を導入して下さい。

http://www.microsoft.com/japan/windows/directx/default.aspx

←目次へ戻る

▼ファイルをダウンロードしましたが解凍方法がわかりません。 New!!

20021231版以降はRAR、20011025・1026はGCAで圧縮されています。
RARに関してはLhaplus、eoを使って解凍してください。
GCAはGCA(G Compression Archiver)を使って解凍してください。

←目次へ戻る

▼起動すると「xxxx.xxxがみつかりません」が表示される。 New!!

Visual Basic 6ランタイムが入っていません。
VB6ランタイムを導入して下さい。

ランタイムはこちらの方で入手可能です。
http://www.vector.co.jp/soft/win95/util/se089073.html

←目次へ戻る

動作環境

▼Macでも動きますか？ New!!

動きません。

VirtualPCでの動作は不明です。

←目次へ戻る

▼WindowsNTでも動きますか？ New!!

NTのDirectXは実質5で止まった状態なので動きません。

←目次へ戻る

起動時に関する質問

▼BMSが入ってるフォルダを指定しても読み込んでくれない。 New!!

フォルダの読み込みは基本的に一階層のみです。
jukeboxが作られている親フォルダを指定しても何も読み込みません。

「階層無制限」にチェックを入れるか、フォルダを一つずつ指定してください。
ちなみに階層無制限チェックをしても、内部でフォルダ分けはしません。

←目次へ戻る

▼ウィンドウモードにしたい。 New!!

「その他」タブに「windowモード」がありますので、そこにチェックを入れてください。

←目次へ戻る

▼起動画面で文字化けが起こる。 New!!

vb6jp.dllが入ってません。
VB6ランタイムを導入するか、下記のアドレスにあるdllをwindowsのシステムディレクトリに入れてください。

http://nothing.sh/download/vb6jp.cab

←目次へ戻る

曲選択時に関する質問

▼1P/2P/DPのフィルタリングをしたい。 New!!

曲セレクト中にBSキーを押してください。

無し→1P→2P→DPという順番でかわります。

←目次へ戻る

▼2P側のオプションが設定できません。 New!!

現在のバージョンではハイスピードと一部のオプションを除き1P・2Pのオプションは共通となっております。
つまり、1P SIDEで設定されているオプションはそのまま2Pに適用されます。

←目次へ戻る

▼5key/7keyのフィルタリングができない。 New!!

現在未実装です。

←目次へ戻る

▼COMBOLINK-HISPEEDが出せない。 New!!

プレイ直前にq+wキーを同時に押すとCOMBOハイスピードになります。

←目次へ戻る

▼HS0.25倍の出し方がわからない。 New!!

プレビューオフ、もしくはジュークボックス選択時に一度0倍速にして、そこから１段階上げると0.25倍が出現します。
ちなみにプレビューオンにしている状態で変えようとするとランダムスピードが発生し、正しく変えられない可能性があります。

←目次へ戻る

▼エンドレスモードで全曲プレイをしたい。 New!!

BMS検索でjukeboxが入っているフォルダを追加し、「階層無制限に検索」にチェックを入れ検索し、
ジューク選択画面で検索したjukeを選択し、SHIFT+ENTERを押してください。
ただし、階層無制限に検索するので、差分が入ってるフォルダもENDLESSの対象になるので注意してください。

←目次へ戻る

▼エンドレスモードの出し方を教えてください。 New!!

jukebox選択画面でプレイしたいフォルダを選び、SHIFT+ENTERキーを押してください。

←目次へ戻る

▼オートスクラッチにするにはどうすればいいですか。 New!!

曲セレクト画面でF9を押してください、そうすれば画面右下あたりに「AutoScratch:1player」と表示されます。
2P側のみに適用したいなら2player、両方適用したいならdoubleにしてください。

←目次へ戻る

▼コースエディタで組み込んだ曲をプレイしようとしるとエラーが出る。 New!!

BMS内の総オブジェ数（キー音数、バック音数、BMP数全て含める）が上限数である65535を超えるとエラーが起きます。
これを回避するには「その他」タブにある「内部オブジェ数上限」を65535にしてください。
ただし、この数値を大きくした事によって動作が不安定になる可能性があります。

←目次へ戻る

▼ハイスピードの変更ができない。 New!!

nazobmplay起動メニューの「キーコンフィグ」ボタンを押し、ハイスピード変更の項目を設定するか、
一度初期化ボタンを押してください。

←目次へ戻る

▼曲セレクトでソート機能の「3」を押すと固まる。 New!!

タイトルの先頭に記号（"～"や"＜"等）が入ってるとフリーズします。
現時点でのバグですので、次回以降のリリースまで暫くお待ち下さい。

←目次へ戻る

プレイ中に関する質問

▼BPMが早ければ早いほど判定が厳しくなる。 New!!

仕様です。

nazobmplayは時間軸判定（どのBPMでも判定は変わらない）ではなく、ドット判定（BPMによって判定が変わる）です。

←目次へ戻る

▼WindowsXPで音がズレる。 New!!

一部環境で起こる症状です。
使用しているサウンドカードがオンボードサウンドだった場合、高い可能性で発生します。

コントロールパネルの「サウンドとオーディオのプロパティ」を選択し、
「オーディオ」タブの「詳細設定」ボタンを押し、
「オーディオ詳細のプロパティ」ウィンドウの「パフォーマンス」タブで
サンプリングレート変換の質を標準に、ハードウェアアクセラレータを最大以下にすると解決する可能性があります。
また、WindowsXPSP1を導入すると音ズレが解決するという報告もあります。

←目次へ戻る

▼キーボードで４つ以上の同時押しが効かない。 New!!

これはソフトのバグではなくキーボード側の仕様です。
KB側の仕様で、特定の位置での同時押しは効かない様になっております。
キーコンフィグで同時押しが効く配置にするか、同時押しが効くキーボードに買い換えるか、専用コントローラを接続してください。

#ちなみに同時押しが全部効くキーボードがどうしても欲しいならRealforce 106辺りを買ってください。16000円ぐらいします。

←目次へ戻る

▼コースプレイで音が出ない。 New!!

起動時の設定の「Course Play時」の項目を「初回一括」もしくは「曲ごと」にすると音が鳴る可能性があります。

←目次へ戻る

▼バトルプレイがやりたいが方法がわからない。 New!!

選曲画面でF10を押してください。すると右下あたりに「PLAYER FORCED TO 1P」が出てきますので、これを2Pにしてください。
そうすればバトルプレイができます。

←目次へ戻る

▼プレイ終了後、スコアの保存ができない。 New!!

以下の二点が考えられます。

1.RealHiSpeed、もしくは途中からDEMOに変更した

2.そのBMSが入ってるフォルダが書き込み禁止属性になっている。

2に関しては、BMSが入っているフォルダのプロパティを開き、
「書き込み禁止」のチェックを外してOKボタンを押してください。

←目次へ戻る

▼プレイ中、ESCを押しても反応が無い。 New!!

nazobmplayは仕様上、0.5秒以上押さないと中断と見なされません。
ESCを0.5秒以上押してみて下さい。

←目次へ戻る

▼ロングノートオブジェが表示されません。 New!!

1025版以前のロングノートの定義がないBRDを使用するとこの症状が起こります。
そのbrdの最新版を待つか、自分で定義してください。

←目次へ戻る

▼重い。 New!!

・起動設定画面の「NOSYNC」チェックと「DirectBLT」チェックを入れてみて下さい。
・セレクト画面、もしくはプレイ画面でフルキーの1,2キーを押し、sleepを調整して下さい。
・スキンをLIGHT-SKIN（1025版はdefault_L.brd、1231版はdefault.brd）にしてみてください。
・BGAをオフにしてみてください。
・2000/XPは優先度を上げないと正しく動作しない可能性があります。
  優先君等のツールを使って優先度を「通常以上」または「高」にして起動してみて下さい。
  なお、リアルタイムにすると固まります。

←目次へ戻る

▼動いてはいるが、プレイ画面に何も表示されない。 New!!

真っ暗の画面の中でF9キーを押し続けてみてください。

←目次へ戻る

▼判定が本家より甘い。 New!!

仕様です。

ちなみに今のところ判定を変えるオプションはありません。

←目次へ戻る

nazoIRに関する質問

▼「WinSock コントロールのレジストリ情報が不正か、あるいは WinSock コントロールが正常にインストールされていません。」というエラーが出る。 New!!

レジストリ情報が不正な場合に出ることがあるようです。
この場合は、 RegCleaner というソフトを利用してレジストリ情報を削除して下さい。

RegCleaner
http://ringonoki.net/tool/system/regcleaner.html

→新規登録もしくは"checking status..."で止まります。、 ログオンできない。

←目次へ戻る

▼「コンポーネント'MSWINSCK.OCX'、またはその依存関係のひとつが適切に登録されていません。」というエラーが出る。 New!!

MSWINSOCK.OCXが無いかもしくは壊れている可能性があります。

http://www.runan.net/program/runtime/download.cgi?ocx+MSWinSck.lzh
こちらからファイルを落として解凍して、
MSWinSck.inf を右クリック→インストールしてください。

→ログオンできない。

←目次へ戻る

▼ログオンできない。 New!!

以下の可能性が考えられます。

1.IDもしくはパスワードが間違っている。
2.MSWINSOCK.OCXが正しく登録されていない。
3.接続にプロキシが必要なネット環境を持っている。
4.接続先のサーバーがダウンしてる。

1.は大文字小文字を確認の上、改めて入力し直してください。
3.はプロキシ欄にHTTPプロキシのアドレスを入力してください。
4.は復帰まで暫くお待ち下さい。

2に関しては以下のリンクを参照。

→「コンポーネント'MSWINSCK.OCX'、またはその依存関係のひとつが適切に登録されていません。」というエラーが出る。、 「WinSock コントロールのレジストリ情報が不正か、あるいは WinSock コントロールが正常にインストールされていません。」というエラーが出る。

←目次へ戻る

▼新規登録もしくは"checking status..."で止まります。 New!!

こちらを参照してください。

→「WinSock コントロールのレジストリ情報が不正か、あるいは WinSock コントロールが正常にインストールされていません。」というエラーが出る。

←目次へ戻る

設定に関する質問

▼#BGA命令を使用したBMSを読み込んでも何も表示されません。 New!!

仕様です。#BGAは現在未対応となっております。

←目次へ戻る

▼2P側プレイはできますか。 New!!

できません。

brdを弄れば一応形だけは可能です。

←目次へ戻る

▼BGA拡大ができない。 New!!

BGA拡大はbrdに既存しています。
_nbmfilesフォルダを開き、現在自分が使っているbrdファイル（名称とファイル名はヘルプ参照、デフォルトなら「[DEFAULT-skin TYPE:04(01-REMAKE) for 1P/2P]」）を開き、10行目辺りにある

#BGA_1P 192, 48,256,256 // BGA表示位置(1P)
#BGA_2P 192, 48,256,256 // BGA表示位置(2P)

// BGA拡大表示は以下の//を削除し、上の#BGA部分に//を付けると適用されます。

//#BGA_1P 173, 0,467,432 // BGA拡大表示位置(1P)
//#BGA_2P 173, 0,294,432 // BGA拡大表示位置(2P)

これを以下の様に変更してください。

//#BGA_1P 192, 48,256,256 // BGA表示位置(1P)
//#BGA_2P 192, 48,256,256 // BGA表示位置(2P)

// BGA拡大表示は以下の//を削除し、上の#BGA部分に//を付けると適用されます。

#BGA_1P 173, 0,467,432 // BGA拡大表示位置(1P)
#BGA_2P 173, 0,294,432 // BGA拡大表示位置(2P)

変更した後保存すれば、BGAが拡大されます。

←目次へ戻る

▼brd側でBGA拡大を設定できる様にしても、BGAが拡大されずに表示される。 New!!

起動オプションの「Use another BGA Stretch Method」のチェックをオンにしてください。
尚、VRAMが足りない場合、オンにしても拡大されない可能性があります。

←目次へ戻る

▼MIDI演奏には対応してますか。 New!!

対応してません。

現在の所対応予定もありません。

←目次へ戻る

▼鍵盤をハーフにする事はできますか。 New!!

起動時の設定画面の「スキン」タブで「nazobmplay [DEFAULT-skin TYPE:02 HALF for 1P/2P]」にするか、
プレイ直前にF9キーを押してスキンを「nazobmplay [DEFAULT-skin TYPE:02 HALF for 1P/2P]」にしてください。

←目次へ戻る

その他の質問

▼DDRはプレイできますか。 New!!

できません。

←目次へ戻る

▼DWI,MSD,PMS,GDA,G2Dの読み込みに対応してますか。 New!!

多分どれも対応してません。

サポートしているのはBMS、BME、BMLのみです。

←目次へ戻る

▼nVIDIA系のビデオカードを使用していて、ドライバを変えたら重くなった。 New!!

これはドライバのバージョン41.09～43.45で起こる症状です。
上記のバージョンのドライバを更新するとDirecrDraw系が正しく動作しない症状が出るそうです。
41.09以前のバージョンを入れるか、最新である44.03では症状が軽くなっているらしいので、そちらを導入してください。

←目次へ戻る

▼pop'nはプレイできますか。 New!!

無理言わないでください。

←目次へ戻る

▼オフィシャル版nazobmplayにあったネット対戦はできますか。 New!!

残念ながらunofficial版から停止中です。

そのうち復活させたいそうです。

←目次へ戻る

▼明らかにバグっぽいものを見つけたのですが、どうすればいいですか。 New!!

uonazo BBSにてバグ報告用のスレッドがありますので、そちらに報告してください。

uonazo BBS
http://www.mnxnet.com/~manbow/nazobmplay/cbbs/cbbs.cgi

←目次へ戻る

Wordsworth - Version2.4.0 (C)1999-2002 濱地 弘樹(HAMACHI Hiroki)


>> 連絡先

感想・質問はarea nothing内のBBSで行っております。
バグ報告・要望はarea nothing内のnazoBMplay feedback内で行っております。

tnj @ area[nothing]

document by AOiRO_Manbow


更新履歴

>> history

このヘルプファイルがいつでも放置されていいように

http://wiki.nothing.sh/?nazobmplay

nazbmplayに関する最新の情報はこちらでご確認下さい

rev.794～rev.796

  • 時計(超簡易
  • 時計 on/off ＠ ScrollLock?
  • [nazoIR]スコアにプレイヤーバージョン記録
  • SFMモード(現Cruel)搭載
  • cruelはオプションとして IR 登録もできるように。
  • PRESSURE の種類が増えました。 BAD 以下だけでなく GOOD や GREAT 以下でも落ちます。スコアタ用。
  • RANDOM(DP), SHUFFLE(DP) を追加. 1p/2pごっちゃのひどい譜面を求める方へ.
  • 分解能を上げてみる。192と193でもちゃんとズレます。これでYamajet先生も安心。
  • BMS検索が止まっちゃうバグも修正
  • 18日のフィルタ定義が無いときもフィルタリングされていたのをやめが無効になってたのを修正
  • ハマらないように調整...
  • 2PでEXゲージ時に片方だけ落ちたときでも曲終了だったのを修正
  • 0.25xを普通に選べるように
  • BAD/POOR ハマりをなんとかしてみる(仮) →まだ要改善
  • 1ファイルしかないときに落ちるバグ修正(何か直ってたっぽい?)
  • JukeBox開く時に時間掛かってたの修正(ネット対戦関係が...)
  • 1P/2Pで独立してDEMO(オートプレイ)設定できるように。
  • PLAYER FORCED TO メニュー(F10)に "DP(EXCHANGE)" 追加 (DP で 1P/2P を入れ替え)
  • DP曲あるのにフィルターでDPが出ないときがある(多分listindexの最後か最初を間違ってる)

2003-10-21(db version)

  • コースIR対応（イベントモードのみ）
  • イベントモードで指定されているスキン以外を選択できる様に修正
  • DPプレイ後、1P譜面をやるとDPスキンが適用されたままになる現象を修正
  • ランキング入力画面でEnterの入力を受け付けなかったのを修正
  • MIRROR(1P/2P/DP)モード搭載。

2003-10-15(db version)

  • Windows 9x でイベントモード動かなかったの修正
  • スキンでBGAサイズを256x256以下にしているとBGAが表示されないことがあるのを修正

2003-10-14a(db version)

  • InternetRanking正式対応
  • イベントモード搭載
  • HS変更キーをキーコンフィグでカスタマイズ可能に
  • ダブルプレイ時に片方だけランダムが効かなかったを修正
  • randomのパターンを変更(旧パターンはshuffleになりました)
  • ランキング画面リニューアル

2003-09-14(LZD version)

  • リプレイオブジェクト表示機能復活
  • コースプレイが組み合わせによってフリーズする現象を修正
  • DPで2P側のHSを1P側のHSと同じ数値にする様に修正

2003-02-07(LZD version)

  • WAVメモリ開放が正しく処理されてないバグを修正
  • PRESSUREモードでミスすると音が爆発するバグを修正
  • クラス補正が正しく動作していなかったのを修正
  • 見逃し判定を更に厳密に
  • ロングノート判定の変更
  • 曲スタート時、０倍速から特定のハイスピードへ変わる現象を廃止
  • D&Dでスキンが壊れるバグを修正
  • スクラッチ問題絡みのバグ修正
  • 曲リストの色変更

2002-12-31(LZD version)

  • 曲セレクト画面一新
  • プレイ画面も一新
  • ハイスピードの仕様を変更
  • オートスクラッチ対応
  • 1P/2P/DPフィルタ搭載
  • WAV拡張定義対応
  • ロングノートBMS対応(LYTYPE1/2のみ)
  • bml(LONGNOTE BMS)の読み込みに対応
  • ストップシーケンス対応
  • brdの仕様を一部変更・追加
  • １６分連打で判定が正しく処理されてないバグを修正

2001-11-16(UnOfficial)

  • DrawLimit搭載
  • エキスパートモードで途中落ちてもスコアが記録できる様に変更。

2001-10-25(UnOfficial)

  • MP3に対応
  • FORCEモード追加
  • BMSch.08 BPM拡張機能に対応
  • ENDLESS関係
  • 漢字→１バイト文字変換機能強化
  • brd記述に"#skinstyle"追加
  • ウィンドウモードで非アクティブ時にキー入力を受け付けない様に
  • 音量調整追加

2001-06-22(UnOfficial)

  • スキンが新しくなってます
  • 4D、CROSS搭載、nazo廃止の代わりにDeceleを搭載
  • ウィンドウモード搭載、ハーフも搭載（Win2Kじゃないと見づらいかも）
  • 内部オブジェ数上限搭載
  • セレクトフォント変更可能
  • 他は通常のnazoBMplayと一緒
  • ネット対戦機能はしばらくの間凍結

2001-04-29(23:40)

  • 更新しないとか言って更新してる阿呆が此処に１人。
  • #TOTALが指定されてない曲のゲージ上昇率が変だったのを直しました。
  • リプレイを復活。今んとこ、１つしか記録できませんが、人と交換とかはできます。
    曲と同じフォルダに、bmsfile名.npdとして保存されてるのがそれです。
    F6キーでリプレイ記録/閲覧モード切替で。
  • 漢字→アルファベット変換辞書搭載。あまり意味はないけど今後利用予定有り。
    なお、ひらがなやカタカナ、半角で存在する全角記号などは自動で変換されますので書く必要はありません。

2001-04-27(00:55)

  • うげ、１ヶ月近く更新してねぇ、ってことでちょっと公開できるようにと弄ってました。 ところが、実行中に突然Win2kがSTOPエラーで死亡。再起動後nazobmplayのソースは破壊されてましたとさ。 当然バックアップなんて取ってないのでちょっと困ったことに。 とりあえず過去に少し取ってあった部分を結合して何とか動いてますが、何処か変かも。 まぁ、元々変なのでよくわからないです。
  • ちょこっと安定。
  • スクロールがなめらかに。
  • スキンに関するバグを１箇所修正。
  • クリア曲の色替え表示。
  • あとはもう覚えてないです。時間ないのでこの辺で(´д｀;)

2001-03-30(00:40)

  • 諸々修正。

2001-03-28(23:40)

  • 曲セレ中にF7キーでBMS Previewをon/offできるように。
  • BMP/WAVのアンチリロード判定を強化、必要ないモノをアンロード。
  • スキン切り替え時にサーフェス再生成。BGA変になるの直ったかな。
  • 曲決定時にタイトルBMPが表示されないバグ(無理矢理)多分修正。
  • 他微妙に弄り

2001-03-27(23:30)

  • wavloadmode が -1 になるバグは解決されました。
  • DirectBlt時に強制的にNOVSyncになってたのを修正。
  • 起動メニューの一部修正

2001-03-27(02:20)

  • WAV再生補正を切りました。wav再生がスワップなどでズレてしまうのを補正するための機能だったのですが。
    どうも音が「途切れる」ように感じてしまうのがダメらしいので。
  • 0小節目の最初の音が鳴らないコトがあるバグを修正。
  • 細かいとこ修正

2001-03-26(23:37)

  • WAVのロード関連が変だったので弄りました。微妙なとこ。

2001-03-26(09:25)

  • Layer透過色指定を思いっきり間違ってたのを修正しただけです。申し訳ない。

2001-03-25(23:50)

  • ちょっと致命的バグなのでBGA解放を使用不可に。
    ちなみにいままでチェック外しても無効になってませんでした。ごめんなさい。
  • 曲プレイ中ESCで抜けるときは0.5秒以上押し続けてください。
    コントローラでプレイ中に間違って押しちゃって泣きたくなるので。
  • 同じ曲を２度プレイするときはWAVとか読み直さないようにしました。
  • BMSプレビューの曲頭ズレを抑えました。wavちょっち先読み。
  • BGA-Layerを#000000～#0f0f0fまでは透けるようにしてみました。(未確認

2001-03-23(23:40)

  • コントローラ使用時の曲セレのキー仕様が変わりました。同梱テキスト参照。
  • ↑スクラッチでの曲セレの回転速度を上げてみました。
  • コース名入力時にEnterがBackspaceと同じ働きをしてしまうバグ修正

2001-03-22(02:40a.m.)

  • スキンが一部変わったのでフルセットのみ。
  • コントローラ対応。ポーリング忘れを修正。その他コントローラに関することいろいろ弄りました。
  • それに伴い入力メソッドがDirectInputに変更になりました。右shiftとかも区別が付くようになりましたヨ。
  • 曲セレスクロール速度の変更
  • ランキングネーム未入力時はデフォルト（謎）が入るように。
  • ランキング画面からESCキーで抜けられるようにした(保存されますが)
  • その他細かい点、気づいた点適当に弄り。

2001-03-18(00:18a.m.)

  • ビットマップフォント表示時にスペースが含まれているとサーフェス全部さらけ出してしまうバグ修正。
    もしかしたらこれで軽くなる環境があるかもしれません。低スペック時は顕著かも。不明。
  • SHIFT+ESC抜けチェックを強化しました。
  • 構造を思い出すついでに細かい部分を少しずつ弄ってます。
    というわけで後の修正箇所は覚えてません。

2001-03-16

修正点

  • この更新は重要かもしれない
    えーと、スコアタやってた方々、かなり申し訳ないんですが。
    いままでかなり初歩的なミスで、判定が1pixel単位でしか有効じゃありませんでした。
    本来ならば、0.01pixel位の単位で計算していたハズだったのですが。
    今回の更新で、小数部も有効にになったので相当スコアに差が出ると思います。
    おそらく、J-Ptsは下がり気味、通常スコアが上がるようなコトになってるかと。
  • BMS階層無制限検索時の検索方法を改善。っていうかoffでも３階層検索してたの修正。
  • BGA拡大を復活
  • オブジェが連続するところで、POOR/BADが連なるのを抑制。前判定を調節してみました
  • 既に叩かれたオブジェを点滅させてるのをやめました。
  • 判定基準を変更しました。つーかそのままじゃ甘過ぎなんで。厳しくなりました。
  • 曲中でRealHispeed変えたりDemo変えたりしたときはスコア保存しないようにしました。
  • 曲をクリアできなくてもPlayCountを+1するようにしました。
  • その他ちょこちょこと。

2001-03-15

新規追加

  • 曲セレ時のランキング表示にclass表示がついた。
    但し、埋まってないスコアはSS表示される。コレは今後修正予定。
  • 無駄押しpoorを実装してみる。(仮)
    1/2～1/4小節前で無駄押しに。1/4小節以内はキー判定に入りますので注意。
  • Rankごとの判定難度調整がやっとつきました。
    これでよーやくEASYとVERY HARDの区別が付きます。
    尚、HARDが今までの判定度合と一緒です。
  • リストのなめらかスクロールをoffにできるようにした

修正点

  • 「Endlessモードは1Pのみ」が保存されないバグ修正
  • 初期設定ではまともに遊べない、動作異常を修正
  • ゲージの減りの調節
  • Ex時の回復を調節
  • リストのなめらかスクロールの仕方を調整した
  • 起動メニューのインターフェースの改善
  • class SSの基準を堅く。つーか普通これは無理です。無理なので外しました。
  • JGreat補正を外しました。不評なので戻しました。


>> このヘルプを読むのはダルイと言う方へ

  1. nazobmplay.exeを起動します
  2. オプションを設定します(ロード方法とか画面色数とか)
  3. 「BMS検索」ボタンをクリックします
  4. 「追加」ボタンを押してBMSのあるフォルダを指定します。
    ここで指定されたフォルダ = Jukeboxとなるのでご注意ください。
  5. 「検索開始」を押して完了を待ちます。
  6. 「メイン」ボタンをクリックします
  7. 「起動」ボタンを押してあとはご自由に。