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190 THINGS YOU NEVER KNEW ABOUT PHOTOSHOP 6 
by Trevor Morris ( tmorris@fundy.net | http://user.fundy.net/morris/ ) 
 
 
Part of what makes Photoshop such an incredibly powerful and pleasurable program to use is its 
well-thought out implementation: the interface is polished and uncluttered and easily 
customizable (despite its vast arsenal of tools and commands). In fact, there is a surprising 
amount of "hidden" functionality within Photoshop; so much so, that despite the number of years 
you work with the program, you will undoubtedly keep discovering more and more about it. I 
doubt anyone could claim that they know "everything" about Photoshop (except maybe Adobe's 
software engineers ;-). 
 
The tips below should help you (whether you are a beginner or a seasoned expert) to harness 
some of Photoshop's "hidden" functionality to streamline your work, perform complex tasks more 
quickly or efficiently, or teach yourself something you had no idea Photoshop was capable of! 
 
For your convenience, the tips have been organized into the following ten categories: 
 

• Interface Tips [ 28 Tips ] 
• Tool Tips [ 25 Tips ] 
• Command Tips [ 25 Tips ] 
• Selection Tips [ 10 Tips ] 
• Layer Tips [ 29 Tips ] 

• Tips for Guides & Rulers [ 10 Tips ] 
• Action & Batch Tips [ 11 Tips ] 
• Tips for Duplicating [ 11 Tips ] 
• Type Tips [ 18 Tips ] 
• ImageReady Tips [ 23 Tips ] 

 
Here are a couple of notes before you begin: 
 

• I tend to prefer hotkeys (e.g. [Ctrl+D] ), but I have provided equivalent alternatives (e.g. 
Select » Deselect – which denotes a menu command) wherever possible 

• Mac users: Ctrl = !, Alt = Option (e.g. Ctrl+Alt+D = !·Option·D); right-click = Control·click 
 
 
INTERFACE TIPS 
 
1. Press the Tab key to hide the toolbar and all palettes. Press Shift+Tab to hide only the palettes 
(and leave the toolbar visible). 
 
2. Snap your palettes to the nearest screen edge by Shift-clicking on their titlebars. 
 
3. Minimize palettes by double-clicking on their (names in the) palette tabs. Use the minimize 
button on the palette titlebars to cycle between: compact mode (minimum number of options / 
contents visible) and contents mode (view all palette options / contents). 
 
Note: You can also double-click the toolbar’s titlebar to minimize it. 
 
4. Use the Zoom field (in the bottom-left of the Photoshop window or Navigator palette) to quickly 
enter an exact zoom level. 
 
Tip: Press Shift+Enter after entering a value to have the field remain active. 
 
5. Press Shift+Enter in palette fields to apply the current value but have the field remain active. 
This is a quick way to experiment with different values. 
 
Note: Also see tip 4, above. 
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6. To change the (document size) information displayed in the status bar (bottom of the screen – 
Window » Show Status Bar), click on the ! button and choose a new item from the pop-up 
menu. Click on the status bar (to the left of the ! button) to display the print size of the current 
document. Alt-click to see the image dimensions and resolution. Ctrl-click for tile information. 
 
Tip: Choosing Document Profile from the status bar menu (!) will allow you to monitor the color 
space of any / all documents opened in Photoshop. 
 
7. You can fill the (gray) canvas borders with the foreground color by Shift-clicking on it with the 
Paint Bucket tool [G]. 
 
Note: To replace the default color, change the foreground color to 25% gray (R192,G192,B192) 
and Shift-click on the canvas border again. 
 
8. Hold down the Alt key to change any Cancel button into a Reset button (in any dialog box); this 
allows you to easily restore values without having to cancel and come back. 
 
9. Use the Caps Lock key to turn Precise Cursors on / off. 
 
Note: This does not work if Precise Cursors are already enabled in the Preferences [Ctrl+K, 
Ctrl+3] (Edit » Preferences » Display & Cursors). 
 
10. Press "F" to cycle between three different full screen modes (or use the Mode buttons near 
the bottom of the toolbar). 
 
Tip: Press Shift+F to toggle the menus in full screen mode. 
 
Tip: Shift-click on one of the screen mode buttons in the toolbar to display all open documents in 
the selected mode. 
 
11. Double-clicking on Photoshop's background (the gray background) will summon the Open 
command [Ctrl+O] (File » Open). 
 
12. Shift-click on the color ramp (on the Color palette [F6] (Window » Show Color)) to change the 
spectrum. Alternatively, you may either right-click on the color ramp or open the Color palette 
menu to select an alternate color mode. 
 
13. Right-click on an image window's titlebar to quickly access features like Canvas Size, Image 
Size and Duplicate. 
 
14. Pausing the mouse pointer over an image window's titlebar will reveal (via a tool tip) the full 
path of the current document. 
 
15. Add a custom color to the Swatches palette (Window » Show Swatches) by clicking on any 
empty (gray) area. Remove a color by Ctrl-clicking on it. Replace a color by Shift-clicking on it. 
 
Tip: Choose a background color from the Swatch palette by Alt-clicking on the desired color. 
 
16. Use the hexadecimal color field ( # ) in the Color Picker to copy and paste color values from 
one place in Photoshop to another (or even to another application that supports hexadecimal 
color values). 
 
17. To increase / decrease the size of the Curves window [Ctrl+M] (Image » Adjust » Curves), 
click on the maximize (#) / minimize ($) button. 
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Note: Clicking the maximize (#) / minimize ($) button toggles the Curves grid between 171 
pixels and 256 pixels wide. For greater accuracy, use the larger grid, since you have control over 
all 256 shades of gray in the image (compared to 171 shades by using the small grid). 
 
Tip: Alt-click on the Curves window to increase the grid size. 
 
Tip: Hold down the Alt key to change Auto button into an Options button (and the Cancel button 
into a Reset button – see tip 8, above). 
 
18. Alt-click on a triangle icon (!) to expand or collapse all child elements of an action, layer 
style, or layer set. 
 
19. For dialog boxes that contain multiple pages (e.g. Edit » Preferences » General), use Ctrl+N 
and Ctrl+P to go to the next and previous pages, respectively. 
 
20. Sometimes it is quicker to navigate with the keyboard than to reach for the mouse. Here are 
some useful navigation keys: 
 

HotKey Result 
Home / End go to top-left / bottom-right corner of the canvas 
PageUp / PageDown scroll canvas up / down one page 
Shift+PageUp / PageDown scroll canvas up / down 10 pixels 
Ctrl+PageUp  / PageDown scroll canvas left / right one page 
Ctrl+Shift+PageUp / PageDown scroll canvas left / right 10 pixels 

 
21. Use Ctrl+Tab (or Ctrl+F6) and Ctrl+Shift+Tab to switch between the previous and next 
documents, respectively. Alternatively, you may choose a document, by name, from the (bottom 
of the) Window menu. 
 
22. Ctrl-drag inside of the Proxy Preview Area (in the Navigation palette (Window » Show 
Navigator)) to specify a new view area within the current document. 
 
Tip: Shift-drag within the Proxy Preview Area to move the highlight vertically and horizontally. 
 
Tip: Change the color of the Proxy View highlight by selecting Palette Options from the palette 
menu. 
 
23. Use the Favorites button in Open dialog box to store folders that you visit on a regular basis. 
 
24. You may "stack" palettes by dragging one palette tab onto the top or bottom of another 
palette: a highlight appears to indicate where the palette will be placed. 
 
Tip: You may also group palettes together by dropping one palette onto the middle of another. 
 
25. To calculate the file size of an image, use the following equation: 
 

File Size  = Resolution2 × Width × Height × Depth ÷ 8192 (bits/KB) 
 
For 24-bit images at screen resolution (i.e. 72dpi) use: 
 

File Size = Width × Height × 3 ÷ 1024 
 
Tip: Divide by 1024 (KB/MB) to determine the file size in Megabytes. 
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26. To force Windows (especially for 95/NT) to use a specific monitor profile, do the following: 
 

1. Remove Adobe Gamma Loader from Start Menu » Startup 
2. Establish the Path\Name of the ICM profile to be used (most likely in 

C:\WinNT\System32\Color\) 
3. Run RegEdit (using Start Menu » Run) and navigate to the following entry: 

HKEY_LOCAL_MACHINE » Software » Adobe » Color » Monitor » Monitor0 
4. Create a New Key called Monitor Profile 
5. Enter the Path\Name of the profile (from step 2) into the Monitor Profile key 

 
Note: After installing this profile, do not run Adobe Gamma again since it will reinstall the Adobe 
Gamma Loader (into Start Menu » Startup). 
 
27. Assume that you want to see the dimensions of the current cropping marquee, but the Info 
palette is hidden beneath another palette. You cannot click on the Info palette tab (or press F8) to 
bring it to the foreground: however, you can choose Window » Show Info to bring the palette to 
the foreground! 
 
Tip: To bring a palette to the foreground (of a palette group) while a dialog window is open (such 
as Curves, Levels, etc.), choose the palette name from the Window menu (e.g. Window » Show 
Info), or press its associated hotkey. 
 
28. For palettes that contain thumbnails, right-click in on an empty area of the palette to reveal a 
context menu that allows you to choose from the following thumbnail sizes: None (which is not 
always available), Small, Medium and Large. 
 
Note: This applies for the Layers, Paths, and Channels palettes in Photoshop and the Layers, 
Rollover, and Animation palettes in ImageReady. 
 
 
TOOL TIPS 
 
1. Alt-click on tool icons (in the toolbar) to cycle through the available tools. This is a little faster 
than holding the left mouse button down to wait for the tool list to pop up. 
 
Note: You may also right-click on a tool (in the toolbar) to see a list of the hidden tools (as well as 
their associated hotkeys). 
 
2. Press Enter (or double-click on a tool icon in the toolbar) to reveal the Options palette for the 
currently active tool. Alternatively, you may choose Window » Show Options from the menus to 
reveal the Options palette. 
 
3. Click on a tool's icon in the Options palette (Window » Show Options) to display a menu with 
the following two choices: Reset Tool or Reset All Tools. 
 
Note: You may also reset all tools to their defaults using the Reset All Tools button in the General 
Preferences [Ctrl+K] (Edit » Preferences » General). 
 
4. To draw a straight line with any paint tool, click on the image, move the mouse, and then Shift-
click – Photoshop will join the two points with a straight line using the current tool. 
 
5. Hold down the Ctrl key at any time to access the Move tool [V]. Use Ctrl+Alt to drag a duplicate 
of the current layer or selection. Add the Shift key to constrain movement to 45º increments. 
 
6. Hold down Alt key while using any paint tool to temporarily access the Eyedropper tool. 
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7. Press the Space Bar to access the Hand tool [H] at any time. 
 
8. Access the Zoom tool [Z] at any time by holding Ctrl+Space to zoom in, and Alt+Space to 
zoom out. 
 
9. Zoom in and out by using Ctrl+Plus ( + ) and Ctrl+Minus ( - ), respectively: have the window 
resize to fit by also holding down the Alt key (Ctrl+Alt+Plus and Ctrl+Alt+Minus). 
 
Note: You may also have the document window zoom to fit while using the Zoom tool [Z] by 
enabling "Resize Windows to Fit" in the Options palette. 
 
10. Hold down the Alt key when selecting a color with the Eyedropper tool [ I ] to define a 
background color. 
 
11. Use the Color Sampler tool [Shift+I ] with the help of the Info palette [F8] (Window » Show 
Info) to monitor color changes in the current image. The before / after color values are displayed 
next to their respective color sampler number (e.g. # 1). Specify the sampler color mode via the 
pop-up menu on the Info palette. 
 
To add a new color sampler simply click anywhere on the canvas (with the Color Sampler tool). 
Remove a sampler by Alt-clicking on it. 
 
Note: You may only have a maximum of four color samplers per image. 
 
Tip: To use the Color Sampler tool from within a dialog window (such as Levels, Curves, etc.), 
hold down the Shift key. Alt+Shift-click on a sampler to delete it. 
 
12. While the Measure tool [Shift+I ] is pretty handy for measuring distances (especially on a 
diagonal), you can also use it to measure angles (like a protractor). Make sure the Info palette 
[F8] (Window » Show Info) is visible; then use the Measure tool [Shift+I ] to drag / draw a line. 
Hold down the Alt key and drag a second line out from one of the end nodes (note the angle and 
length of the two lines in the Info palette). 
 
Tip: Move a measure line (or protractor) by dragging it with the Measure tool (you may even 
reposition the endpoints independently). Delete a measure line (or protractor) by dragging it off 
the canvas. 
 
13. The Eyedropper tool [ I ] allows you to copy the hexadecimal value of a color to the Clipboard. 
Simply right-click over the desired color (in the image window) and choose Copy Color as HTML 
from the context menu. You may then paste the color value into your favorite editor. 
 
Note: You may also copy the current color as HTML (e.g. COLOR="#448CCB") by choosing 
Copy Color as HTML from the Color palette menu. 
 
14. While using any of the paint tools, press Enter to display / dismiss the Preset Picker (at the 
current mouse location). To access a list of available brush modes while painting, Shift-right-click 
on the image. To change the current brush / preset options, click directly on the brush / preset 
preview in the Options palette (or choose Edit Brush from the Shift-right-click menu). 
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15. Use the hotkeys in the following table to vary the brush for the current paint tool: 
 

HotKey Result 
[ / ] decrease / increase brush size 
Shift+ [ / ] decrease / increase brush hardness by 25% 
< / > previous / next brush 
Shift+ < / > first / last brush 
Enter display / dismiss Preset Picker (see tip 14, above) 

 
16. Press Enter to stroke a visible path with current paint tool and options (which is the same as 
clicking the Stroke Path button at the bottom of the Paths palette). Press Ctrl+Enter to turn a path 
into a selection (which is the same as clicking the Path to Selection button at the bottom of the 
Paths palette). 
 
Tip: While using the Pen [P], Path Selection [A], or Shape [U] tool, you can press Enter or Esc to 
hide the current path. 
 
17. You can use the Crop tool [C] to enlarge, rotate and even to add perspective to the current 
document! To increase the canvas size, choose full screen mode [F] (using one of the Full 
Screen Mode buttons near the bottom of the toolbar), and then drag any side / node of the crop 
marquee beyond the canvas boundaries. Rotate the image by dragging anywhere outside the 
crop marquee. Add perspective to the cropped region by first enabling the Perspective option in 
the Options palette and then dragging any corner node. 
 
Note: To accept the crop results you may double-click inside the crop region, press Enter, right-
click on the image window and choose Crop, or click the Commit button in the Options palette. To 
cancel the crop, press Esc, right-click on the image window and choose Cancel, or click the 
Cancel button in Options palette. 
 
18. When specifying dimensions for the Marquee [M], Crop [C], Shape [U], and Type [T] tools, 
you may use a variety of different units including: px = pixels, in = inches, cm = centimeters, pt = 
points, pica = picas, and % = percentages. Simply type the number followed by one of the above 
abbreviations (e.g. 5cm, 50%, 2 pt, etc.) 
 
Note: Photoshop will also accept the full name of the above units (e.g. 5 centimeters), but it is 
much simpler to use the abbreviations! 
 
19. Enable the Magnetic Pen tool [P] by turning on the Magnetic option in the Freeform Pen tool's 
[Shift+P] Options palette. Configure its behaviour via the Magnetic Pen Options drop-down 
button. 
 
Tip: Toggle between the Magnetic and Freeform Pen tools by holding down the Alt key. 
 
20. Click on the background color well on the Color palette (not the toolbar) to have any color 
changes affect the background color. A black outline indicates the active color well. 
 
Tip: With the Eyedropper tool [ I ], press the Alt key to choose a color for the opposite color well. 
For example, if the foreground color is the active color well, press the Alt key to select a color for 
the background, and vice versa. 
 
21. Add arrowheads to the Line tool [U] (Shape tool) using the Geometry Options button (menu) 
in the Options palette. 
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22. Use the options available in the Brush Dynamics button menu (on the Options palette) to fade 
the size, opacity, and color of the various brush tools. 
 
Note: For people who use tablets, the above options may also be configured to recognize a 
stylus. 
 
23. With the Auto Erase options enabled for the Pencil tool [B], if you begin painting on an area 
that contains the foreground color, the background color will be used instead, and vice versa. 
 
Note: I have no idea what useful purpose this serves :-) 
 
24. While using the Eraser tool [E], hold the Alt key to erase back to the source history state - 
similar to the behaviour of the History Brush tool [Y]. 
 
Note: You must establish a source history state in the History palette in order for this to work. 
 
25. Normally, when you select a history state and then change the image, all states below the 
active state are deleted (or, more accurately, replaced by the current state). However, if you 
enable the Allow Non-Linear History option (from the History Options in the History palette menu), 
you may select a state, make a change to the image, and the change will be appended to the 
bottom of the History palette (instead of replacing all the states below the active state). You can 
even delete a state without losing any of the states below it! 
 
Note: The color of the horizontal lines between history states indicate their linearity. White 
dividers indicate linear states and black dividers indicate non-linear states. 
 
Note: Not only is a non-linear history very memory intensive, it can also be very confusing! 
 
 
COMMAND TIPS 
 
1. To reapply the last filter, use Filter » Last Filter [Ctrl+F]. To reapply a filter with new settings, 
add the Alt key (Ctrl+Alt+F or Alt + Filter » Last Filter). 
 
Tip: Fade the effects (and change the blending mode) of the last filter (or adjustment), by 
pressing Ctrl+Shift+F (Edit » Fade Last Filter). 
 
2. If you have recently copied an image to the Clipboard, Photoshop will automatically insert the 
dimensions of the Clipboard image when you create a New Document [Ctrl+N] (File » New). To 
bypass this feature and recall the last settings, hold down the Alt key [Ctrl+Alt+N] (Alt + File » 
New). 
 
Tip: To insert the dimensions (as well as resolution and color mode) of any open document into 
the New Document dialog box, choose its name from the bottom of the Window menu. 
 
3. Use Ctrl+Alt+Z (Edit » Step Backward) and Ctrl+Shift+Z (Edit » Step Forward) to step 
backward and forward though the history states (or use the History palette menu to access the 
step commands). Use these commands in conjunction with Undo [Ctrl+Z] (Edit » Undo) to cycle 
between a specific history state and the current state. 
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4. The table below provides some very useful hotkeys for performing the Fill command (Edit » 
Fill) on the current layer / selection: 
 

HotKey Result 
Shift+Backspace open Fill dialog box (Edit » Fill) 
Alt+Backspace fill with foreground color 
Alt+Shift+Backspace fill with foreground color and preserve transparency 
Ctrl+Backspace fill with background color 
Ctrl+Shift+Backspace fill with background color and preserve transparency 
Ctrl+Alt+Backspace fill from current history state 
Ctrl+Alt+Shift+Backspace fill from current history state and preserve transparency 

 
5. Use the hotkeys provided in the table below to quickly transform the current selection or layer: 
 

HotKey Menu Command Result 
Ctrl+T Edit » Free Transform free transform selection / layer 
Ctrl+Alt+T Alt + Edit » Free Transform free transform with duplicate 
Ctrl+Shift+T Edit » Transform » Again repeat previous transformation 
Ctrl+Alt+Shift+T Alt + Edit » Transform » Again repeat transformation with duplicate 

 
6. When transforming a selection / layer, use the following buttons in the Options palette for 
added control: 

• use the "Reference point location" image to position the reference / pivot point 
• press the "Relative positioning" button to switch from absolute (canvas) positioning to relative 

positioning 
• press the "Maintain aspect ratio" button to maintain a 1:1 aspect ratio while transforming 

 
7. To stop the Crop tool [C] from snapping to the image borders, hold down the Ctrl key while you 
are dragging the crop handles. 
 
Note: You may also stop the Crop tool [C] from snapping by turning off View » Snap To » 
Document Bounds (or None); or turn off snapping altogether [Ctrl+ ; ] (View » Snap). 
 
8. To straighten a crooked image, use the Measure tool [Shift+I ] to draw a line along what should 
be a horizontal or vertical line (the edge of the image, a doorframe, across the eyes of a person in 
a portrait, etc.), and then choose Image » Rotate Canvas » Arbitrary: the correct Angle and 
Direction will appear. Press the OK button to apply the rotation. 
 
Tip: The angle of the Measure tool [Shift+I ] is also used (for the current layer / selection) 
automatically when you choose Edit » Transform » Rotate. 
 
Note: You can also use the Crop tool [C] to rotate and crop an image in one step. Select the Crop 
tool [C] and draw a rectangular region. Use the crop handles to scale the marquee, and drag 
outside the marquee to rotate it: press Enter to crop the image. (Also see Tool Tip 17.) 
 
9. Use Layer » New » Layer via Copy [Ctrl+J] (or Cut [Ctrl+Shift+J]) command to perform a copy 
(or cut) and paste in one operation, and have the copied (or cut) elements pasted into the same 
position from which they were copied. 
 
Tip: Add the Alt key to display the Layer Properties dialog box for the Layer via Copy [Ctrl+Alt+J] 
(Alt + Layer » New » Layer via Copy) and Cut [Ctrl+Alt+Shift+J] (Alt + Layer » New » Layer via 
Cut) commands. 
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10. If you crop your image using Image » Crop, you will lose all pixels outside the crop 
boundaries. To crop your image without losing any data, use the Crop tool [C] with Cropped Area 
set to Hide (in the Options palette). 
 
Tip: You may also use Image » Canvas Size to crop the image without losing any data (unless 
you are in Indexed mode). Photoshop will warn you that some clipping will occur, but for some 
reason it does not: all "cropped" data will be preserved outside the canvas boundaries! 
 
Tip: Use the Image » Reveal All command to increase the canvas size and reveal the entire 
image. 
 
11. Stamp Down a copy of the current layer into the layer below by pressing Ctrl+Alt+E (Alt + 
Layer » Merge Down). 
 
Merge a copy of all visible layers into the current layer (or Stamp Visible) by holding down the Alt 
key while selecting Merge Visible [Ctrl+Alt+Shift+E] (Alt + Layer » Merge Visible). 
 
12. An alternative to deleting unwanted plugins (.8be), filters (.8bf) and file formats (.8bi) is to 
prefix their filenames (or containing folders) with a tilde (~). Photoshop will ignore any files or 
folders beginning with a tilde (~). 
 
Example: To disable all “Digimarc” plugins, rename the folder to “~Digimarc”. 
 
13. Holding the Ctrl and Alt keys while launching Photoshop will allow you to change Photoshop's 
Scratch Disk Preferences before it loads. 
 
14. To reset all preferences to their defaults, press (and hold) Ctrl+Alt+Shift immediately after 
launching Photoshop (or ImageReady). A dialog box will appear to ask for confirmation. 
 
15. You may customize the "File » Jump To" and "File » Preview In" menus with Photoshop / 
ImageReady by creating shortcuts to your favorite applications within the Helpers folder: 
 
C:\Program Files\Adobe\Photoshop 6.0\Helpers\ 
 
Note: The above path assumes a default installation (for Windows). 
 
Add your favorite graphics application(s) to Photoshop's “File » Jump To” submenu by creating a 
shortcut in the "Jump To Graphics Editor" folder. 
 
To add your own HTML editor(s) to ImageReady's “File » Jump To” submenu, create a shortcut 
to the desired application(s) within the "Jump To HTML Editor" folder. 
 
To include your preferred browser(s) in ImageReady's "File » Preview In" submenu (or Preview In 
button – in the toolbar), create a shortcut within the "Preview In" folder. 
 
Note: You may need to restart Photoshop / ImageReady for the applications to be displayed in 
their respective menus. 
 
Tip: Choosing a browser from the “File » Preview In” submenu (or Preview In button), assigns 
that browser as the default [Ctrl+Alt+P]. The designated browser takes effect immediately and 
persists the next time you launch ImageReady. 
 
Note: Although you may include additional graphic applications in the “File » Jump To” submenu 
for both Photoshop and ImageReady, you cannot reassign their default graphic applications. 
ImageReady’s default graphics application [Ctrl+Shift+M] is Photoshop, and Photoshop’s default 
graphics application [Ctrl+Shift+M] is ImageReady. 
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16. To free up memory you may choose Edit » Purge » Histories, but be warned that this will 
clear the history states of all open documents. 
 
Note: To purge the history states of the active document (only), hold the Alt key and choose 
Clear History from the History palette menu. This will purge all history states without changing the 
image. 
 
Warning! The above commands cannot be undone. 
 
17. In the Liquify dialog box [Ctrl+Shift+X] (Image » Liquify), hold the Shift key while clicking the 
OK button to temporarily save the current mesh (to a file called C:\Temp\Liquify.tmp). To 
(re)load the mesh file (with your image), hold the Shift key while launching the Liquify command. 
 
Note: The C:\Temp\ folder must already exist on your system to take advantage of this feature. 
 
18. Use Window » Close All [Ctrl+Shift+W] to quickly close all open documents. A save 
confirmation dialog will appear for any files that have not been saved. 
 
19. Use the Revert command [F12] (File » Revert) to restore the current document to its 
previously saved state. 
 
20. To print the current document using the default print settings (without confirmation), press 
Ctrl+Alt+Shift+P (Alt + File » Print One). 
 
21. While working in the Curves dialog window, Ctrl+Shift-click anywhere on the image to add a 
point to each channel's curve (i.e. Red, Green, and Blue for RGB mode) that represents selected 
region. 
 
22. In the Levels dialog window, hold down Alt while you drag the black (left) or white (right) Input 
Levels sliders to adjust the Levels in Threshold Mode. 
 
23. To achieve better results with the Unsharp Mask filter, try applying it twice using a smaller 
Amount (%) setting. 
 
Example: Instead of applying Unsharp Mask once at an amount of 150%, use an amount of 60% 
twice. 
 
24. Unfortunately, if you try to apply the Lens Flare filter (Filter » Render » Lens Flare) to a new 
(empty) layer, you will get an error. However, instead of flattening your image, add a new layer 
and choose Edit » Fill [Shift+Backspace] and select Use: Black. Set the blending mode of the 
layer to Screen (at the top of the Layers palette) and then render the lens flare on the new layer. 
 
Note: The above technique also works when applied to a layer filled with 50% gray 
(R128,G128,B128) and a blending mode of Hard Light. 
 
Tip: To specify the exact origin of the Lens Flare (in pixels), Alt-click anywhere in the Lens Flare 
dialog box to display the Precise Flare Center dialog box. 
 
Tip: If you increase the canvas size, apply the above technique, and then return the canvas to its 
original size, you will be able to move the lens flare layer around on the canvas. 
 
Tip: To render a lens flare at a specific location (or size) on the canvas, draw a selection before 
applying the filter. 
 
25. Hold down the Alt key when choosing Filter » Render » Clouds to increase the contrast of the 
clouds. 
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SELECTION TIPS 
 
Note: Be sure to check out Selection Secrets and Selection Secrets 2 for even more tips on using 
selections effectively. 
 
1. When using the Marquee tools [M], use the Shift key to create perfect circles or squares: use 
the Alt key to draw them from their centers. 
 
2. Use the Reselect command [Ctrl+Shift+D] (Select » Reselect) to load / restore your previous 
selection. 
 
3. You may alternate between Polygonal and Freehand Lasso [L], while you are creating a 
selection, by holding down the Alt key. 
 
Example: See Selection Secrets 2 (Polygonal / Freehand Lasso) for a comprehensive 
description. 
 
4. Use the Space Bar to move a selection while drawing it. 
 
Example: See Selection Secrets (Moving Selections) for a comprehensive description. 
 
5. Hold the Shift or Alt keys to add or subtract selections. Hold down both Shift and Alt together to 
intersect two selections. 
 
Tip: Ctrl-click on a layer thumbnail (in the Layers palette) to load its transparency mask, and then 
Ctrl+Alt+Shift-click a second layer to intersect the two layers' transparency masks. 
 
Example: See Selection Secrets (Intersecting Selections) for a comprehensive description. 
 
6. Retain your selections while scaling or duplicating an image by first switching to Quick Mask 
mode [Q] (or click on the Quick Mask icon near the bottom of the toolbar). 
 
7. Alt-click the Quick Mask button to toggle between masked and selected areas. 
 
8. After editing a selection in Quick Mask mode, Alt-click the Standard mode (Quick Mask off) 
button to invert the current selection. 
 
9. Ctrl-clicking on a layer thumbnail in the Layers palette is a convenient way to load the 
transparency mask for the active layer: however, if the contents of the layer extend beyond the 
edges of the canvas, so too will the resulting selection. To restrict the selection to the document 
bounds, invert the selection [Ctrl+I ] (Select » Invert) twice. 
 
10. By default the Select » Color Range command dialog box displays the entire image in the 
preview area. For a more accurate preview and greater control, create an approximate selection 
around the area of interest. The selected area will be displayed in the preview area. 
 
Tip: Hold the Shift key while choosing Select » Color Range to add the resulting selection to the 
current selection. Hold down Alt to subtract the results from the current selection. 
 
Tip: Hold down the Ctrl key to toggle between Selection and Image previews in the Color Range 
dialog box. Use the Shift key to add colors and the Alt key to subtract colors from the selection. 
 
 

http://user.fundy.net/morris/redirect.html?photoshop8.shtml
http://user.fundy.net/morris/redirect.html?photoshop9.shtml
http://user.fundy.net/morris/redirect.html?photoshop9.shtml
http://user.fundy.net/morris/redirect.html?photoshop8.shtml
http://user.fundy.net/morris/redirect.html?photoshop8.shtml
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LAYER TIPS 
 
1. You can cycle through layer blending modes by using Shift+Plus ( + ) (cycle forward) and 
Shift+Minus ( - ) (cycle backward). Also try Alt+Shift+Letter (where Letter is one of the letters 
listed below) to quickly change the blending mode. 
 

N = Normal 
I = Dissolve 
M = Multiply 
S = Screen 
O = Overlay 
F = Soft Light 
H = Hard Light 
D = Color Dodge 
B = Color Burn 

K = Darken 
G = Lighten 
E = Difference 
X = Exclusion 
U = Hue 
T = Saturation 
C = Color 
Y = Luminosity 

Q = Behind 1 
L = Threshold 2 
R = Clear 3 
W = Shadows 4 
V = Midtones 4 
Z = Highlights 4 

A = Saturate 5 

J = Desaturate 5 

P = Pass Through 6 
 

Only applicable to:  1. Paint tools   2. Indexed mode   3. Dodge and Burn tools [O]   4. Line [U] and 
Bucket [G] tools on multi-layered images   5. Sponge tool [O]   6. Layer sets 

 
Note: The above hotkeys also affect the blending mode of the currently active paint tool, so if you 
wish to change the blending mode of the active layer, be sure to switch to the Move tool [V] or 
one of the selection tools first. 
 
2. Change the opacity of the currently active tool or layer by using the number keys (on the 
keyboard or on the number pad). Press "1" for 10% opacity, "5" for 50%, and so on: use "0" for 
100% opacity. Numbers pressed in succession, such as "85", will result in an opacity of 85%. 
 
Note: The above hotkeys also affect the opacity of the currently active paint tool, so if you wish to 
change the opacity of the active layer, be sure to switch to the Move tool [V] or one of the 
selection tools first. 
 
3. Increase / decrease slider bars by 1% using the left / right arrow keys. Add Shift to increase / 
decrease by 10% increments. 
 
4. Hide / reveal all layers by Alt-clicking on the visibility icon (the eyeball) of the desired layer. 
 
5. Unlink all layers from the current layer by Alt-clicking on the current layer's paintbrush icon. 
 
6. To clear (remove) all layer effects from a layer, hold the Alt key and double-click on the layer's 
effect icon ( ƒ ); or from the menus, choose Layer » Layer Style » Clear Layer Style. 
 
Tip: To disable an individual effect, do one of the following: 

• hold down the Alt key and select the style by name from the Layer » Layer Style submenu 
• hold down the Alt key and select the style by name from the Layer Style icon menu ( � ), at 

the bottom of the Layers palette 
• uncheck the style’s Apply flag in the Layer Style dialog box 

 
7. Alt-click between layers (in the Layers palette) to group them together. This is handy when 
several layers are linked together, and you only want to group specific layers together (since the 
Group with Previous command changes to Group Linked when the current layer is linked to other 
layers). 
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8. Here is a real time-saver for adding adjustment layers (Layer » New Adjustment Layer » 
Adjustment Layer): simply click on the New Fill or Adjustment Layer icon menu, at the bottom of 
the Layers palette, and select the type of adjustment layer you wish to add. 
 
Tip: Hold down the Alt key when choosing a fill or adjustment layer to display the Layer 
Properties dialog box. 
 
9. Alt-click on the Trash icon, at the bottom of the Layers palette, to quickly delete layers (without 
confirmation): this also works with channels and paths. 
 
Tip: This technique also works for layer masks and clipping paths: click on a appropriate 
thumbnail and then Alt-click on the Trash icon to delete the mask or path without confirmation. 
 
10. Below is a table of hotkeys for working efficiently with layer masks: 
 

HotKey Result 
Alt-click layer mask thumbnail edit / reveal layer mask 
Shift-click layer mask thumbnail toggle layer mask on / off 
Ctrl-click mask (or press Ctrl+Alt+ \ ) load layer mask as selection 
Ctrl+Shift-click layer mask thumbnail add to current selection 
Ctrl+Alt-click layer mask thumbnail subtract from current selection 
Ctrl+Alt+Shift-click thumbnail intersect with current selection 
Alt+Shift-click (or press Backslash [ \ ] ) view layer mask in rubylith mode (color) 
Ctrl+ \  switch focus from layer to layer mask 

 
11. Click the Add Mask button, at the bottom of the Layers palette, to add a mask that reveals the 
current selection (Layer » Add Layer Mask » Reveal All). Alt-click on the Add Mask button to add 
a mask that hides the current selection (Layer » Add Layer Mask » Hide All). 
  
12. Turn off all paths easily by clicking on the empty area of the Paths palette (under the path 
layers). 
 
Tip: Toggle paths on / off by pressing Ctrl+Shift+H (View » Show » Target Path). 
 
13. Alt-click on the Fill Path, Stroke Path, Load Path as Selection and Make Path from Selection 
icons (bottom of the Paths palette) to see a list of available tools and / or options. 
 
14. With the Move tool [V] as the current tool (or while holding down the Ctrl key), right-click 
anywhere on the canvas for a list of the layers under the mouse pointer (ordered from top-most to 
bottom-most): select a layer-name from the list to make it the active layer. 
 
Tip: Add the Alt key (Alt-right-click) to automatically choose the top-most layer under the pointer. 
Alternatively, you may turn on the Auto Select Layer option in the Options palette (while the Move 
tool [V] is selected). 
 
Tip: Add the Shift key (Alt+Shift-right-click) to link / unlink the top-most layer that intersects with 
the current layer. 
 
15. Ctrl-click (or drag) with the Move tool [V] to automatically select (or move) the top-most layer 
under the mouse pointer. Ctrl+Shift-click (or drag) with Move tool [V] to link (or move) the top-
most layer with the current active layer. 
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16. By default, (the first nine) channels have hotkeys associated with them. You may use these 
hotkeys (see the table below) to load the selection of a channel. Here are the hotkeys 
corresponding to some common color modes: 
 

RGB Mode: CYMK Mode: Index Mode: 
 
Ctrl+Tilde ( ~ ) = RGB 
Ctrl+1 = Red 
Ctrl+2 = Green 
Ctrl+3 = Blue 
Ctrl+4 = Other Channel 
: 
Ctrl+9 = Other Channel 

 
Ctrl+Tilde ( ~ ) = CYMK 
Ctrl+1 = Cyan 
Ctrl+2 = Yellow 
Ctrl+3 = Magenta 
Ctrl+4 = Black 
Ctrl+5 = Other Channel 
: 
Ctrl+9 = Other Channel 

 
Ctrl+1 = Index 
Ctrl+2 = Other Channel 
: 
Ctrl+9 = Other Channel 

 
17. A fast way to combine several layers into a group is to first link them together, then select 
Group Linked [Ctrl+G] (Layer » Group Linked). You may then unlink the layers if you wish. 
 
Note: You can also Merge [Ctrl+E] (Layer » Merge Down) multiple visible layers using the same 
technique (because, the Merge Down command becomes Merge Linked [Ctrl+E] (Layer » Merge 
Linked) when the current layer is linked to other layers). 
 
18. Here is a slick way to rearrange / reorder multiple layers, simultaneously (within the Layers 
palette): Group [Ctrl+G] (Layer » Group with Previous) the desired layers together, drag the group 
(up or down) into its new position within the Layers palette, and then Ungroup [Ctrl+Shift+G] 
(Layer » Ungroup) them again. 
 
Tip: Alternatively, you could combine the desired layers into a layer set and then move the entire 
set (up or down) within the Layers palette. 
 
19. Use the following technique to apply the same layer style (effect) to multiple layers 
simultaneously: 
 

1. Link all layers to which the layer style is to be applied 
2. Define (or choose an existing) layer style for one of the linked layers 
3. Right-click on the layer's style symbol and choose Copy Layer Style from the context menu 
4. Right-click again (on any of the linked layers) and choose Paste Layer Style to Linked 

 
20. Ctrl-click on the New Layer button or New Set button, at the bottom of the Layers palette, to 
have the new layer or set inserted below the current layer or set. 
 
21. To convert the active path into a layer clipping path, Ctrl-click the Layer Mask icon at the 
bottom of the Layers palette; or choose Layer » Add Layer Clipping Path » Current Path. 
 
Ctrl+Alt-click the Layer Mask icon to add a layer clipping path which hides the contents of the 
active path; or choose Layer » Add Layer Clipping Path » Hide All. 
 
Note: If the current layer already contains a layer mask, the Ctrl key is not required to add a layer 
clipping path. 
 
22. To create a mask for the current layer that represents the contents of the current layer, drag-
and-drop the layer onto the Add Mask button at the bottom of Layers palette. Alt-drag-and-drop 
the layer onto the Add Mask button to add a mask that hides the contents of the current layer (i.e. 
the mask is the inverse of the current layer). 
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23. Changing the blending mode and / or opacity of a layer set affects all layers within the set 
(effectively treating all layers inside as a single layer). 
 
24. To simultaneously place multiple layers into a Layer Set, first link the layers and then choose 
New Set From Linked from the Layer palette menu; or choose Layer » New » Layer Set From 
Linked from the menus. 
 
Tip: Hold down the Alt key while choosing New Set From Linked to skip the dialog box (and use 
the Layer Set's default name and properties). 
 
25. Alt-double-click on a layer-name (in the Layers palette) to display the Layer Properties dialog 
box (i.e. to rename a layer). 
 
Tip: Alt-double-click on a Background layer to turn it into a regular layer (named “Layer 0”) 
without confirmation. 
 
26. To lower the opacity for just a portion of a layer, make a selection, and press 
Shift+Backspace (or choose Edit » Fill from the menus) to access the Fill dialog box: set the 
blending mode to Clear, and set to the opacity as desired for the selected region. 
 
27. To copy a layer mask from one layer to another, first select the layer that you want to apply 
the mask to (and ensure that it does not already have a layer mask); then drag the layer mask 
thumbnail from another layer onto the Layer Mask icon at the bottom of the Layers palette. 
 
28. To lock the transparency, pixels, position, or all of these, for all layers within a set, choose 
Layer » Lock All Layers in Set. 
 
29. Here are several hotkeys associated with layer clipping paths: 
 

HotKey Result 
Click layer clipping path thumbnail edit / reveal layer clipping path 
Shift-click layer clipping path thumbnail toggle layer clipping path on / off 
Ctrl-click layer clipping path thumbnail load layer clipping path as selection 
Ctrl+Shift-click clipping layer thumbnail add to current selection 
Ctrl+Alt-click clipping layer thumbnail subtract from current selection 
Ctrl+Alt+Shift-click thumbnail intersect with current selection 

 
 
TIPS FOR GUIDES & RULERS 
 
1. While dragging guides, hold down the Alt key to switch between vertical and horizontal guides. 
Alt-click on an existing vertical guide to change it into a horizontal guide, and vice versa. 
 
Note: Guides are created by dragging them out from the document rulers, so ensure that the 
rulers are turned on [Ctrl+R] (View » Show Rulers). 
 
2. Dragging guides with the Shift key held down will force them to snap to the ruler increments / 
markings. 
 
3. To prevent guides from snapping to canvas boundaries and layers objects, hold down the Ctrl 
key while dragging them. 
 
4. Double-click on guides to open the Guides & Grid Preferences [Ctrl+K, Ctrl+6] (Edit » 
Preferences » Guides & Grid). 
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5. Double-click on the Rulers [Ctrl+R] (View » Show Rulers) to open the Units & Rulers 
Preferences [Ctrl+K, Ctrl+5] (Edit » Preferences » Units & Rulers). 
 
Tip: You can also select a new unit of measurement from the Cursor Coordinates pop-up menu 
on the Info palette [F8] (Window » Show Info). 
 
6. Center the ruler origin anywhere on the canvas by dragging from the top-left corner (where the 
Rulers [Ctrl+R] (View » Show Rulers) meet). Reset the origin to its default position by double-
clicking on the top-left corner. 
 
7. Use paths to create curved or diagonal guides. Simply draw a path using the Pen tool [P] and 
use it as a guide while drawing or painting (the path will remain visible). 
 
Tip: Use the Show Target Path command [Ctrl+Shift+H] (View » Show » Target Path) to toggle 
the visibility of a path. 
 
8. Guides snap not only to the edges (left, right, top and bottom) of the active layer or selection, 
but also to the vertical and horizontal centers of the current layer or selection. The opposite is 
also true: you may snap a selection or layer to an existing guide (either by edge or center). 
 
Note: Guides do not snap to the Background layer. Also, be sure that Snap [Ctrl+ ; ] (View » 
Snap) and Snap To Guides (View » Snap To » Guides) are turned on for the above tip to work. 
 
Tip: Find the center of the canvas by filling [Shift+Backspace] (Edit » Fill) a New Layer 
[Ctrl+Shift+N] (Layer » New Layer) and snapping a guide to the vertical and horizontal centers. 
(Also see tip 9, below.) 
 
9. To add guides at a specific location on the canvas, use the View » New Guide command. This 
is especially useful for placing guides from within an action. 
 
Example: Click here to download an action that finds the canvas center by placing guides at 
positions 50% horizontal and 50% vertical. 
 
10. Use the View » Show » Show Extras Options dialog box to set which screen objects are 
toggled on / off when you choose View » Show Extras [Ctrl+H]. 
 
 
ACTION & BATCH TIPS 
 
1. Press Ctrl+Alt and choose Save Actions from the Actions palette menu to save all actions to a 
text file. This is very useful for reviewing or printing the contents of an action. 
 
Note: The text file cannot be reloaded into Photoshop. 
 
2. To improve the performance of batch processes (File » Automate » Batch), reduce the number 
of saved history states (in the General Preferences [Ctrl+K] (Edit » Preferences » General)) and 
deselect the Automatically Create First Snapshot option in the History Options (History palette 
menu » History Options). 
 
3. To batch-process (File » Automate » Batch) multiple folders in a single batch, enable the 
Include All Subfolders option, and create shortcuts within the source folder to all folders you 
would like to have processed. 
 

http://user.fundy.net/morris/downloads/CanvasCenter.atn


190 Things You Never Knew About Photoshop 6 Page 17 of 24 

4. To batch-process (File » Automate » Batch) multiple actions, create a new action and record 
the batch for each action that you would like to process. Then run a batch-process using the 
newly created action. 
 
Tip: You may also use this technique in conjunction with tip 3, above. 
 
5. One really powerful aspect of actions is the ability to have them play other actions (even from 
different action sets). This feature is ideal for actions that contain repetitive command segments 
that could be segregated into action “subroutines” (thereby making the action easier to edit and 
maintain). While recording an action, choose another action and press the play button: the play 
command is recorded as an action step (Play action “Name” of Set “Name”) in the current action. 
 
6. To play just one step within an action, choose the step and Ctrl-click on the Play button, at the 
bottom of the Actions palette [F9] (Window » Show Actions). 
 
Note: To change the parameters of a particular command step, double-click on the step to reveal 
the associated dialog box: any new values entered will automatically be recorded. 
 
7. To begin playback from a specific step of an action, simply choose the desired step and press 
the Play button, at the bottom of the Actions palette. 
 
8. If you are recording an action that might be used on different canvas sizes, be sure to switch 
your ruler units to percentage. This will ensure that all commands and brush strokes are recorded 
relative to the canvas size – and not based specific pixel coordinates. 
 
Tip: To quickly change the ruler units, right-click on the Rulers [Ctrl+R] (View » Show Rulers) and 
select the desired unit of measurement. You may also access the ruler settings by double-clicking 
on the rulers, or by choosing Edit » Preferences » Units & Rulers [Ctrl+K, Ctrl+5] from the menus. 
 
Tip: To quickly configure the ruler units, double-click on the Rulers [Ctrl+R] (View » Show 
Rulers), or choose Edit » Preferences » Units & Rulers [Ctrl+K, Ctrl+5] from the menus. 
 
9. While recording / editing an action, you may insert a menu command (which might otherwise 
be unavailable), by choosing Insert Menu Item from the Actions palette menu. 
 
Tip: This is also a great way to keep action steps generic (i.e. the menu commands will not be 
recorded with predefined parameters). 
 
10. Use the File » Automate » Create Droplet command to save an action as a droplet. A droplet 
is a small executable file that will automatically launch Photoshop and apply the designated 
action to any images that you drop onto it. 
 
11. Organize your actions by creating subfolders within the default Photoshop Actions folder 
(C:\Program Files\Adobe\Photoshop 6.0\Presets\Photoshop Actions\ – assuming a default 
install on a PC). Photoshop will still find these actions and even make them available from the 
Action palette menu. 
 
Note: Prefix actions subfolders (or even individual actions) with a tilde (~) to disable them. See 
Command Tip 12 (above). 
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TIPS FOR DUPLICATING 
 
1. You can use the Marquee tool [M] (or Lasso tools [L]) to drag a selection outline from one 
document into another. 
 
Tip: Hold the Shift key down (after initiating the drag – after clicking with the left mouse button) to 
have the selection centered in the destination document. 
 
2. When dragging selections or layers from one document to another, hold down the Shift to have 
them centered on the destination canvas. 
 
Note: If the source and destination documents are the same size (dimensions), the dragged 
elements are placed in the same relative position as they were in the original document (instead 
of being placed in the center of the canvas). 
 
Note: If the destination canvas contains a selection, the dragged item will be placed into the 
center of the selection. 
 
3. To drag multiple layers between documents, first link them together, then use the Move tool [V] 
to drag them from one document window into the other. 
 
Note: You cannot drag multiple layers from the Layers palette [F7] (Window » Show Layers) into 
another document (even if they are linked together) – this will only move the selected layer. 
 
4. To create a duplicate image of the currently selected history state or snapshot in the History 
palette (Window » Show History): 

• click the New Document button 
• choose New Document from the History palette menu 
• drag-and-drop the current state (or snapshot) onto the New Document button 
• right-click on the desired state (or snapshot) and select New Document from the context 

menu 
 
5. Drag a history state from the History palette (Window » Show History) of the current image into 
any other image window to replace the contents of the destination image. 
 
6. Alt-click on any history state (other than the current state), to duplicate it. The duplicated state 
becomes the current (most recent) state. 
 
7. Alt-drag an action step within the Actions palette [F9] (Window » Show Actions) to duplicate it. 
 
8. To duplicate the current document without being prompted for a name (and have "copy" 
automatically appended to the filename), hold the Alt key and choose Image » Duplicate. 
 
9. Here is a neat trick: use Ctrl+J (Layer » New » Layer via Copy) to duplicate the current layer 
(when there is no active selection). 
 
10. Duplicate a layer by dragging it onto the New Layer button at the bottom of the Layers palette; 
or choose Duplicate Layer from the Layers palette menu. 
 
Duplicate a layer set (including all the layers inside) by dragging it onto the New Layer Set button 
at the bottom of the Layers palette; or choose Duplicate Layer Set from the Layers palette menu. 
 
11. Alt-click on the New Snapshot button, at the bottom of the History palette, to display a dialog 
box that allows you to duplicate the current image as a Full Document, Merged Layers, or Current 
Layer. 
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TYPE TIPS 
 
1. Here is a very useful tip for achieving added control over the rendering of small type. Double-
click on an existing type layer ( T ) to enter type / edit mode. Move the type in the image window 
(by holding down the Ctrl key) to cause the anti-aliasing to shift / rerender. Once you are pleased 
with the anti-aliasing, commit / accept the type changes (by pressing Ctrl+Enter). Finally, you may 
reposition the type as desired without affecting the anti-aliasing. 
 
Tip: Also try different anti-aliasing methods for the above tip. 
 
Note: You may adjust the anti-aliasing as often as you like by entering edit mode and moving the 
type. Once out of edit mode, you may move the type without affecting the anti-aliasing. 
 
2. Use the Enter key on the numeric keypad (on the right side of the keyboard), or Ctrl+Enter (on 
the main keyboard) to commit text changes. Press Esc to cancel / discard changes. 
 
Note: You may also use the Commit Changes button (") in the Options palette (Window » Show 
Options) to accept any type changes. Use the Cancel Changes button (#) to discard any 
changes. 
 
3. Use the View » Show Extras [Ctrl+H] command to hide a text selection (while in type / edit 
mode). 
 
4. Hold the Alt key as you click or drag a text box to display a Paragraph Text Size dialog box. 
The dialog box will display the current text box dimensions: enter the desired values for the Width 
and Height. 
 
Note: Another alternative is to simply watch the Width (W) and Height (H) values in the Info 
palette [F8] (Window » Show Info) as you draw the text box. 
 
Note: If you continue to hold Alt key down after the mouse button has been depressed (and you 
begin to drag), the text box will be drawn from the center. Upon releasing the mouse button, the 
Text Box Size dialog box will appear. 
 
5. To modify the properties of several type layers simultaneously (i.e. font, color, size, etc.), link 
the desired type layers together and hold the Shift key while changing the type properties. 
 
Note: This feature applies to changes performed in the Options palette (Window » Show 
Options), the Character palette (Window » Show Character), and / or Paragraph palette (Window 
» Show Paragraph). 
 
6. Anti-aliased type may be rendered inconsistently at small sizes (or low resolutions). To reduce 
this inconsistency, turn off the Fractional Widths option (in the Character palette menu). 
 
7. To restrict the use of certain fonts to Adobe applications, place them in C:\Program 
Files\Common Files\Adobe\Fonts\ 
 
8. Despite the fact that both the Edit » Fill command and the Paint Bucket tool [G] are disabled for 
type layers, Alt+Backspace (fill with foreground color) and Ctrl+Backspace (fill with background 
color) still work! 
 
Note: Also see Command Tip 4 (above). 
 



190 Things You Never Knew About Photoshop 6 Page 20 of 24 

9. The table below provides the navigation and selection hotkeys that are available while in edit 
mode (working with type): 
 

HotKey Result 
Ctrl+H hide selection – see tip 3, above 
Ctrl+A select all type 
Home / End move cursor to beginning / end of line 
Shift+ Home / End select type to beginning / end of line 
Ctrl+ Home / End move cursor to beginning / end of story 
Ctrl+Shift+ Home / End select type to beginning / end of story 
← / → move cursor to previous / next character 
Shift+ ← / → select previous / next character 
Ctrl+ ← / → move cursor to previous / next word 
Ctrl+Shift+ ← / → select previous / next word 
↑  / ↓  move cursor one line up / down 
Ctrl+ ↑  / ↓  move cursor to previous / next paragraph 
Shift+ ↑  / ↓  select one line up / down 
Ctrl+Shift+ ↑  / ↓  select one line up / down to end of line 

 
10. Below is a table of hotkeys for controlling the relative positioning of type: 
 

HotKey Result 
Alt+ ← / → decrease / increase kerning by 20/1000em 
Ctrl+Alt+ ← / → decrease / increase kerning by 100/1000em 
Ctrl+Shift+ < / >  decrease / increase type size by 2px (pt) 
Ctrl+Alt+Shift+ < / > decrease / increase type size by 10px (pt) 
Alt+ ↑  / ↓  decrease / increase leading by 2px (pt) 
Ctrl+Alt+ ↑  / ↓  decrease / increase leading by 10px (pt) 
Alt+Shift+ ↑  / ↓  raise / lower baseline by 2px (pt) 
Ctrl+Alt+Shift+ ↑  / ↓  raise / lower baseline by 10px (pt) 

 
11. The table below provides hotkeys for controlling type / paragraph characteristics: 
 

HotKey Result 
Ctrl+Shift+C center-align type 
Ctrl+Shift+L left-align type 
Ctrl+Shift+R right-align type 
Ctrl+Alt+Shift+A set leading to auto 
Ctrl+Shift+Q set tracking to 0px (pt) 
Ctrl+Shift+U toggle underlining on / off 
Ctrl+Shift+K toggle all caps on / off 
Ctrl+Shift+H toggle small caps on / off 
Ctrl+Shift+ / toggle strikethrough  on / off 
Ctrl+Shift++ toggle superscript on / off 
Ctrl+Alt+Shift++ toggle subscript on / off 
Ctrl+Alt+Shift+H toggle hyphenation on / off 
Ctrl+Alt+Shift+T toggle every-line composer on / off 
Ctrl+Shift+X set horizontal scaling to 0% 
Ctrl+Alt+Shift+X set vertical scaling to 0% 
Ctrl+Shift+F justify paragraph (force last line) 
Ctrl+Shift+J justify paragraph (left-align last line) 
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12. Use the following click and drag features for enhanced type-selection capabilities: 
 

Action Result 
Double-click (and drag) select word (and then select one word at a time) 
Triple-click (and drag) select line (and then select one line at a time) 
Quadruple-click (and drag) select paragraph (then select one paragraph at a time) 
Quintuple-click select all characters in a bounding box 

 
13. If you are experiencing problems (or even crashes) when Photoshop attempts to load, try 
deleting the adobefnt.lst file (in C:\Program Files\Common Files\Adobe\Fonts\ ). Deleting this 
file forces Photoshop to recreate its font list and possibly fix the problem. 
 
14. Photoshop's font (family) name field (in the Options palette – while editing a type layer) has 
an auto-complete feature; so, instead of searching through the font list, simply type the first few 
characters of the desired font and Photoshop will complete the name. 
 
15. Using the Type tool [T], right-click on type layers (in the image window) to display a context 
menu with many useful formatting options. 
 
Note: The right-click menu that appears in ImageReady has many more options available than 
the one that appears in Photoshop. 
 
16. Use the following Alt codes to add smart quotes to your text: 
 
Note: To enter Alt codes, hold down the Alt key and enter the 
number shown using the keypad (on the right side of the 
keyboard). 
 
17. To convert point text to paragraph text (or vice versa), right-click with
choose Convert to Paragraph Text (or choose Layer » Type » Convert to
the menus). 
 
18. While in type mode, press Ctrl+T to display the Character and Paragr
the Palettes button in the Options palette). 
 
 
IMAGEREADY TIPS 
 
1. Some tools in the toolbar have other tools hidden beneath them – as in
arrow in the lower right corner of the tool button. These tools may be rele
separate toolbars by holding down the left mouse button on the tool butto
bottom-most button in the popup (the one with downward-facing arrow on
 
2. Press Ctrl+Y (View » Show View Mode) to cycle through the available 
(Original, Optimized, 2-Up, and 4-Up). 
 
3. Drag any document view tab (e.g. Original, Optimized, 2-Up, or 4-Up) 
window to create a new view of the current image. 
 
Note: Alternatively, you may select View » New View from the menus. 
 
4. To duplicate the current document, hold the Alt key and drag the Origin
the document window (or choose Image » Duplicate). 
 

Quote Alt Code 
 0145 
 0146 ‘’“”

 0147 
 0148 
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5. The following table contains hotkeys for controlling the Animation palette [F11] (View » Show 
Animation): 
 

HotKey Result 
Alt+ ← / → ¹ goto previous / next frame 
Alt+Shift+ ← / → ¹ goto first / last frame 
Shift+Space Bar ² start / stop animation playback 

 
¹ Using these hotkeys in conjunction with one of the following tools may produce undesirable 
results: Move tool [V] (will duplicate the pixels in the current layer or selection), Image Map Select 
tool [P] (will duplicate the active image map – or cause an error if none are selected), Slice Select 
tool [K] (will duplicate the active slice). 
 
² You may also use Ctrl+. or Esc to stop the playback of an animation. 
 
6. When creating an action that includes styles (layer effects), each setting is recorded as a 
separate action step. To record the style in a single step, drag the style from the Layers palette 
[F7] (Window » Show Layers) into the Actions palette [F9] (Window » Show Actions). 
 
7. Use the Eyedropper tool [ I ] to select a color from anywhere on the screen. Click inside the 
current image window, hold the mouse button down, and drag anywhere on the desktop (or even 
over another application window): release the mouse button to select the desired color. 
 
Note: This feature only works provided that ImageReady remains active (i.e. in the foreground). 
 
8. ImageReady allows you to select colors based on a selection marquee. Make a selection in the 
current image and choose Select All From Selection from the Color Table palette menu (Window 
» Show Color Table). 
 
9. To view the occurrence(s) of a color in the Optimized Image window [Ctrl+Y] (View » Show 
Optimized), click and hold the mouse button over a color in the Color Table palette (Window » 
Show Color Table). The selected color will remain temporarily invert (until you release the mouse 
button). 
 
Tip: This also works for multiple selected colors! To view a contiguous group of colors, select a 
color and Shift-click and hold another color. For non-contiguous colors, Ctrl-click to select 
additional colors, then hold the mouse button to temporarily inverted the selected colors. 
 
10. To copy the hexadecimal value of a color to the Clipboard, choose a color with the 
Eyedropper tool [ I ], then right-click over the image window and choose Copy Foreground Color 
as HTML from the context menu. You may then paste the color value into your favorite editor. 
 
Note: You may also choose Edit » Copy Foreground Color as HTML from the menus. 
 
11. Drag a droplet onto the Actions palette [F9] (Window » Show Actions) to create an action step 
(containing all the optimization settings of the droplet). Alternatively, you can select Insert Set 
Optimization Settings to Image Format from the Actions palette menu. 
 
Tip: You can also drag a droplet onto a slice to apply the optimization settings to the slice. 
 
12. Drag a command from the History palette (Window » Show History) to the Actions palette [F9] 
(Window » Show Actions) to create an action step (with or without pressing the Record button). 
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13. When creating / saving animations, enable the Transparency option in the Optimize palette 
[F10] (Window » Show Optimize) to see what effect it has on the file size – even if your animation 
does not contain any transparent regions. By combining transparency, frame disposal (see 
below), and the Optimize Animation options (see below), it is possible to significantly decrease 
the file size of the animation. 
 
Note: Ensure that the disposal method is set to Automatic or Restore to Background. To set the 
disposal method, right-click on a frame (in the Animation palette [F11] (Window » Show 
Animation)) and choose an option from the context menu. 
 
Note: The above technique only works if Bounding Box and / or Redundant Pixel Removal are 
enabled (from Animation palette menu » Optimize Animation). 
 
14. Click the inverted arrow icon in the status bar ( % ), at the bottom of each document window, 
to choose from a list of information options. 
 
Note: In 2-Up and 4-Up view modes, an additional Zoom Level icon (%) is added. 
 
15. To see what your image / animation will look like on a PC / Mac, use the View » Preview 
submenu (and choose a display type). 
 
Note: To permanently adjust your image / animation, use Image » Adjust » Gamma. 
 
16. To center the current layer on the canvas, choose Layer » Set Layer Position and enter 
Horizontal: Center, 0 pixels and Vertical: Center, 0 pixels. You may also use the Set Layer 
Position command to align the current layer to any canvas edge or corner. 
 
17. To organize your ImageReady actions, create subfolders inside of the default actions folder 
(C:\Windows\Application Data\Adobe\Photoshop\6.0\Adobe Photoshop 6 
Settings\ImageReady Actions\). All subfolders within this path will be loaded when ImageReady 
launches. 
 
18. ImageReady actions (ISA – ImageReady Script Action) are simple text / script files (much like 
JavaScript): you may edit them using a text editor (such as NotePad or TextPad). 
 
19. When choosing Paste Frames (from the Animation palette menu), ImageReady presents you 
with a dialog box that allows you to choose how and where the frames will be pasted and whether 
or not any duplicated layers should be linked (applies only to Paste Over Selection). To skip this 
dialog box and paste the frames using the default options (Paste Over Selection without 
duplicating any layers), hold the Alt key down when choosing Paste Frames. 
 
20. Hold down the Alt key while choosing Image » Crop to display a dialog box with the option to 
Hide or Delete the area outside the crop region. 
 
21. Here are two useful options that are hidden away in the Animation palette menu: 

• Add Layer To New Frames adds a new layer every time a new frame is added. 
• New Layers Visible In All Frames makes any new layers that you add visible in all frames of 

the animation (sort of like an automatic Match Layer Across Frames). 
 
22. Like Photoshop, ImageReady also contains a Batch command, but it is hidden in the Actions 
palette menu (under Batch Options). 
 
23. If you rearrange the order of your actions in ImageReady's Actions palette, their order will be 
saved when you exit the program. 
 
 

http://www.textpad.com/
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That's it! I hope that you found the above tutorial comprehensive and easy to follow. Please, if 
you have any comments about this tutorial (or any other), send me an email with your comments 
(good or bad). 
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