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1 Before You Start

This course guide accompanies the Level 1 training sessions in Rhino Release 1. Level 1 shows you how to produce 3-D
models in Rhino.

In class, you will receive information at an accelerated pace. For best results, practice at a Rhino workstation between
class sessions, and consult your Rhino reference manual for additional information.

Course Objectives
In Level 1, you learn how to:

• Customize your modeling environment

• Create basic graphic objects—lines, circles, arcs, curves, solids, and surfaces

• Draw with precision using coordinate input and object snaps

• Modify objects with edit commands

• Display any portion of the model

• Import and merge models

• Output models to different file formats

• Render models





Part Two:
Getting Started With Rhino
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2 Rhino Basics

The Rhino for Windows Interface
Before learning individual tools, we will get acquainted with the Rhino interface. The following exercises examine the
interface elements used in Rhino, the Rhino window, viewports, menus, toolbars, and dialog boxes.  There are many ways
to access the commands in Rhino—the keyboard, menus, and toolbars.  We will focus on the toolbars in this class.

To open Rhino:

♦ Double-click the Rhino Icon from the Windows desktop.

The Rhino Screen
Rhino divides its window into six areas that supply information or prompt you for input.

Screen Area Description

Menu Bar Access commands, options, and help.

Toolbars Access shortcuts to commands and options.

Graphics area Displays the open model. Several viewports can be displayed. The default viewport layout
displays four viewports (Top, Front, Right, Perspective).
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Screen Area Description

Viewports Displays different views of the model within the graphics area.

Command line Lists commands you enter and information produced.

Status bar Displays the coordinates of the pointer, the status of the model, options, and toggles.

Rhino screen

Watch the command line to
find out what’s happening.
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Menus
Most of the Rhino commands can be found in the menus.

Rhino View menu

Toolbars
Rhino toolbars contain buttons that provide shortcuts to commands. You can float a toolbar anywhere on the screen, or
dock it at the edge of the graphics area

Rhino starts up with the Main 1 Toolbar docked above the graphics area and the Main 2 toolbar docked on the left.
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Tooltips

Tooltips tell what each button does. Move your pointer over a button without clicking it. A small yellow tag with the
name of the command appears. In Rhino, many buttons can execute two commands. The tooltip will indicate which
buttons have dual functions with a vertical line between the two commands.

Flyouts

Buttons on a toolbar may include other command options in a flyout. Usually the flyout contains variations on the base
command. After you select a button on the flyout the flyout disappears.

Buttons with flyouts are marked with a small white triangle in the lower right corner. Open the flyout toolbar by holding
down the left button for a second or by pushing both buttons at the same time.

The Lines toolbar is linked to the Main 2 Toolbar.

If you hold the left mouse down the flyout toolbar will open.

Graphics Area
The Rhino graphics area can be customized to suit your preferences. The position of viewports can be arranged in
different configurations.
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Viewports

Viewports are windows in the display area that show you views of your model. You can move and resize viewports by
dragging the title bar or borders. Each viewport has its own construction plane that the cursor moves on, and a projection
mode. You can create new viewports, rename viewports, and use predefined viewport configurations.

You can toggle between a small viewport and one that fills the graphics area by double-clicking the viewport title bar.

Rearranged Rhino screen. Command line at the bottom, single viewport, toolbars placed in different locations.
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Command Window
The command window displays commands and command prompts.  It can be positioned at the top or the bottom of the
screen. The command window shows three lines by default.

The Mouse
In a Rhino viewport, the left mouse button selects objects, and the right mouse button enters. Use the left mouse button to
select objects in the model, commands or options on the menus, and buttons in the toolbars. Use the right mouse button to
complete a command, to move between stages of commands, and to repeat the previous command. The right mouse
button is used to initiate some commands from toolbar buttons.

Drag with the right mouse button to PAN and ROTATE in viewports. Hold down the CTRL key and drag with the right
mouse button to zoom in and out in a viewport. You must press and hold the right mouse button down to activate this
feature.

Entering Commands
Use the command line to type commands, type command options, type coordinates, type distances, angles, or radii, type
shortcuts, and view command prompts.

To enter information typed at the command line, press ENTER, SPACEBAR, or right mouse button.

Shortcuts are customizable key combinations. You can program the function keys and CTRL key combinations to perform
Rhino commands.

Note In Rhino, ENTER and SPACEBAR perform the same function.

Entering options

To enter command options, type the first letters of the option. The interior capitalization is meaningless for entering the
option. For example, for the AroundCurve option, type A not AC. You only need to type enough of the option word to
differentiate it from other options that begin with the same letter.
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Tab to complete command name

Type the first few letters of a command name and press TAB. If the letters you type correspond to a unique command
name, the command will be completed on the command line. If there is more than one command that starts with the
letters you typed, Rhino completes as much as possible.

Repeating commands

You can repeat the last command by right-clicking in a viewport, or by pressing ENTER or SPACEBAR. You can repeat
previous commands by right clicking in the command line window and selecting from a list.

Canceling commands

Cancel a command by pressing ESC, or by entering a new command from a button or a menu.

Help
Rhino Help can be accessed at any time by pressing the F1 key. In addition to finding information about each command,
Rhino help has conceptual information as well as many examples and graphics to help you complete your model.  When
you get stalled for any reason, the first place you should look is the help file. You can also access help for a specific
command by starting the command and then press the F1 key.

View the command line history
The command line history window lists the last 500 command lines from the current Rhino session. The command
history can be viewed at any time by pressing the F2 key.
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Exercise 1—Rhino Basics

To look at your first Rhino model:

1 From the File menu, click Open.

2 In the Open dialog box,  select First Model.3dm.

Two parallel viewports and one perspective viewport.

This model contains five objects: a cube, a cone, a cylinder, a sphere, and a rectangular plane.

You won’t be able to select or move the plane. You will learn about how to do this later. It is just there to provide you
with a floor underneath the objects.

Open
Look for this button.
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3 From the View menu, click Viewport Layout, then click 4 Viewports.

Three parallel viewports and one perspective viewport

4 In the status bar, click Snap to turn on the grid snap.

Grid snap may already be on in your system. Be careful that you don’t turn it off instead of on. If grid snap is on, the
word “Snap” will be black in the status bar. If it is off, the word “Snap” will be gray.

Note This is an important step. Grid snap only lets your cursor move in certain intervals. In this model, by default
grid snap is set to one half of a grid line. Grid snap helps you line up your objects as if you were building with
LEGO blocks.
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5 Click the mouse in the Perspective viewport to make it active.

The title bar highlights when it is active. An active viewport is the viewport where all your commands and actions
take place.

6 From the Render menu, click Shade.

The objects appear shaded. Shade lets you preview the shapes with no color. The model is shaded right in the
viewport, and in shaded mode you can manipulate the view.

Shaded preview.

Shade
Look for this button.
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7 From the Render menu, click Render.

Rendering the model opens a separate display window. The model displays in colors previously assigned to the
objects. You can also set spotlights and a background. You will learn about doing this later. You cannot manipulate
the view in the render display window but the image can be saved to a file.

Render.

8 Close the render Display Window.

9 In the Perspective viewport, click and drag with your right mouse button held down to rotate the view.

Render
Look for this button.
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10 From the Render menu, click Shade.

Rotate the view in shaded mode.

The plane helps you stay oriented. If the objects disappear, you are looking at the bottom of the plane.

11 From the Render menu, click Render.

Render the rotated view.

12 Close the render Display Window.
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13 In the Perspective viewport on the right, drag with your right mouse button to rotate the view around.

Rotating the wireframe view.

14 Rotate your view by dragging from the bottom of the view toward the top.

Looking at the objects from the bottom in wireframe mode.

You are now under the objects looking up.
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15 From the Render menu, click Shade.

The objects are obscured by the plane.

Looking at the objects from the bottom in shaded mode.

In shaded mode, the plane helps you see when your viewpoint is below the objects.

To get back to your original view:

♦ Press the HOME key to undo your view changes.

Navigating Around the Model
You have used the right mouse button to rotate in the Perspective viewport. You can hold SHIFT and drag with the right
mouse button to pan. Dragging the right mouse button to move around does not interrupt any commands in progress.
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To pan in a viewport:

♦ In the Top viewport, hold SHIFT and drag with the right mouse button to pan the view.

Panning with shift and the right mouse button.

Zooming In and Out

Sometimes you want to get closer to your objects or move back so you can see more. This is called zooming. As with
many things in Rhino, there are several ways to do this. The easiest way is to hold down the CTRL key and drag up and
down in a viewport with the right mouse button. If you have a mouse with a scroll button, turn the scroll button to zoom
in and out.

To zoom in and out:

♦ In the Top viewport, hold the CTRL key, click and hold the right mouse button, and drag the mouse up and down.

What if …

Instead of panning or rotating,
something funny happened.

If you just right-click quickly
once in viewport, the last
command starts again. You
must hold the right mouse
button down while panning or
rotating.

I panned in another viewport, it
shaded too. What’s going on?

When you are in shaded mode
and make a change in any
viewport, the viewport also
displays in shaded mode.
Press ESC or click in a viewport
to exit shaded mode.
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Drag up to zoom in.

Drag down to zoom out.

Zooming with CTRL and the right mouse button.

Zooming Extents

The Zoom Extents command zooms a viewport so the objects fill up the viewport as much as possible. You can use this
command to make everything visible.

To zoom extents in a viewport:

♦ From the View menu, click Zoom, and then click Extents.

If you get lost, it’s often handy to zoom extents in all your viewports at once, so there is a command to do just that.

To zoom extents in all viewports:

♦ From the View menu, click Zoom, and then click Extents All.

ZoomExtents
Look for this button.
Left Click this button.

Zooming Extents in the
perspective viewport is
sometimes inaccurate.

ZoomExtentsAll
Look for this button.
Right Click this button.
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Move Objects
Now drag the objects around. You can drag in any viewport. In this model Snap is set to one-half of a grid line. Using this
snap, you should be able to line objects up with each other.

To move objects:

1 Click the cone and drag it.

The cone turns yellow to show it is selected.

The selected cone highlights.



R H I N O  B A S I C S

N o t e s :

Robert McNeel & Associates ❑ 24

2 Drag the cone in the Perspective viewport until it lines up with the cylinder.

It will be inside the cylinder.

The cone moves on the base that is represented by the grid. This base is called a construction plane. Each viewport
has its own construction plane. When you start Rhino, the Perspective viewport has the same construction plane as
the Top viewport. You will learn more about using construction planes later.

Drag the cone to move it.
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3 In the Front viewport, drag the cone to the top of the cylinder.

Watch what happens in the Perspective viewport.

There are many times when you have to watch what is happening in other viewports to accurately place your objects.

Move the cone in the Front viewport.

4 Click in the Perspective viewport.

5 From the Render menu, click Shade.

Shaded preview.
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6 From the Render menu, click Render.

Render.

Try on Your Own

• Move the objects around. Use the Front viewport to move the objects vertically and the Top or Perspective viewport
to move them horizontally.

Copy Objects
To create more objects, copy the shapes.

To start with a fresh model:

1 From the File menu, click Open.

2 Don’t save the changes.

3 In the Open dialog box, select First Model.3dm.

You will find this model in the Rhino-1 folder.
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To copy objects:

1 Click the box to select it.

2 From the Transform menu, click Copy.

3 At the Point to copy from (Vertical InPlace) prompt, click somewhere in the Top viewport.

It usually helps to click a spot that relates to the object like the middle.

Select and copy the box.

4 At the Point to copy to prompt, click where you want the first copy.

Zoom in closer if you like.

To zoom, hold CTRL and drag with the right mouse button.

Copy
Look for this button.
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5 At the next Point to copy to prompts, click other places to make some copies of the box.

Make three copies

6 When you have enough copies, press ENTER.

Shade the new boxes.

Try on Your Own

Make copies of more objects and move them around. See if you can build something.
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3 
Creating Two-dimensional
Objects

Drawing Lines
The Line, Lines, and Polyline commands draw straight lines. Line draws a single line segment. Lines draws continuous
line segments, end to end. Polyline draws a line with multiple vertices (a single linear object with multiple segments).

Exercise 2—Drawing Lines
1 From the File menu, click New.

2 In the template File dialog, click 4viewports.3dm.

3 From the File menu, click Save.

4 In the Save dialog, type Lines, then click Save.

To draw line segments:

1 From the Curve menu, click Line, then click Line Segments to begin the Line command.

2 At the Start of first line prompt, pick a point in a viewport.

3 At the End of line segment  (Undo) prompt pick another point in a viewport. A line segment appears between the
two points.

4 At the End of line segment, press ENTER when done (Undo) prompt, pick another point .

Line Segments
Look for this button.
Right click for Line Segments
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5 At the End of line segment, press ENTER when done (Close Undo) prompt, continue pick points.

Additional segments appear. Each segment meets, but isn’t joined to it, the previous segment.

Option Description

Close Closes the shape by drawing a segment from the last point picked to the first point
picked. This ends the command.

Undo Deletes the last point picked.

6 At the End of line segment, press ENTER when done (Close Undo) prompt, press ENTER to end the command.

To draw a polyline:

1 From the Curve menu, click Line, then click Polyline to begin the Polyline command.

2 At the Start of polyline prompt, pick a point .

3 At the next Next point of polyline (Undo) prompt pick another point .

4 At the Next point of polyline, press ENTER when done (Undo) prompt, pick another point .

5 At the Next point of polyline, press ENTER when done (Close Undo) prompt, continue to pick points.

To draw a single line segment:

1 From the Curve menu, click Line, then click Single Line to begin the Line command.

2 At the Start of line (BothSides) prompt, pick a point .

3 At the End of line (BothSides) prompt, pick another point.

4 The Single Line command ends after one segment is drawn.

To use the Close option:

1 From the Curve menu, click Line, then click Line Segments to begin the Line command.

2 At the Start of first line prompt, pick a point .

3 At the End of line segment (Undo) prompt pick another point .

4 At the End of line segment, press ENTER when done (Undo) prompt, pick another point .

You can press the right button
to enter.

Polyline
Look for this button.
Left click for Polyline.

Single Line
Look for this button.
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5 At the End of line segment, press ENTER when done (Close Undo) prompt, type C and press ENTER. The line
will close back to the original start point.

To use the Undo option:

1 From the Curve menu, click Line, then click Polyline to begin the Polyline command.

2 At the Start of polyline prompt, pick a point .

3 At the Next point of polyline (Undo) prompt pick another point .

4 At the Next point of polyline, press ENTER when done (Undo) prompt, pick another point .

5 At the Next point of polyline, press ENTER when done (Close Undo) prompt, type U and press ENTER.  One
segment of the polyline is removed.

6 At the Next point of polyline, press ENTER when done (Undo) prompt, pick another point .

7 At the Next point of polyline, press ENTER when done (Undo) prompt, press ENTER to end the command.

To use the Bothsides option:

1 From the Curve menu, click Line, then click Single Line to begin the Line command.

2 At the Start of line (BothSides) prompt, type B and press ENTER.

3 At the Start of line prompt, pick a point.

4 At the End of line prompt, pick another point. A segment is drawn with equal length on both sides of the start point.

Drawing Freeform Curves
The Curve from Interpolated Points and Curve commands draw freeform curves. Interpolated Points draws a curve
through the points you pick. Curve uses control points to create a curve.

Exercise 3—Drawing Interpolated Curves
1 From the Curve menu, click Freeform, then click Interpolate Points.

2 At the Start of curve (Tangent Knots=SqrtChord) prompt, pick a point .

3 At the Next point of curve (Tangent Knots=SqrtChord Undo) prompt, pick another point .

4 At the next several Next point of curve (Tangent Knots=SqrtChord Undo) prompts, pick more points.

Interpolated Points
Look for this button.
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5 Or, type an option letter, and press ENTER.

Option Description

Close Closes the shape by drawing a segment from the last point picked to the first point
picked. This ends the command.

Tangent After choosing a point on another curve, the next segment will be tangent to the point
you picked and end the command.

Undo Deletes the last point picked.

Exercise 4—Drawing Curves from Control Points
1 From the Curve menu, click Freeform, then click Control Points.

2 At the Start of curve prompt, pick a point .

3 At the Next point (Undo) prompt, pick another point .

4 At the next several Next point, press ENTER when done (Undo) prompts, pick more points.

5 Or, type an option letter, and press ENTER.

Modeling Aids
Mode commands are modeling aids that you can toggle on or off by pressing shortcut keys, a function key, typing a single
letter command, or picking a button.

Mode Command
Function
Key Description

Ortho O F8 or
SHIFT

Ortho on restricts cursor movement to the points at a specified angle from the last
point created. The default angle is 90 degrees.

Pressing and holding the shift key down toggles Ortho. If Ortho is set to on, the
shift key toggles Ortho off. If Ortho is off, the shift key toggles Ortho on.

Grid Grid F7 Hides or shows a reference grid in the current viewport of the graphics screen at
the construction plane. This toggle does not work if you are in the middle of a
command.

Curve
Look for this button.

Notice the points you pick are
off the curve as control points.
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Mode Command
Function
Key Description

Snap S F9 or Forces the pointer to snap on grid intersections.

Planar P This is a modeling aid similar to ortho. This helps you model planar objects even if
the modeling command was normally able to draw non-planar objects by forcing
input to be on a plane parallel to the construction plane that passes through the
last point that you picked.

Modeling aids can be toggled on and off by clicking their mode buttons on the status bar:

Exercise 5—Drawing lines and curves using mode functions
1 Toggle Snap on and draw some lines.

The cursor snaps to each grid intersection.

2 Toggle Snap off, toggle Ortho on and draw some lines and curves.

You can only input points that are 90 degrees from the last point. By using grid snap and ortho toggles you can draw
with precision.  We will discuss other ways to get precision in a later session.

Model Setup
In Rhino you can create full-size models using precise measurements. You might need to change the modeling
environment depending on the type of model you are creating; the default options may not always work.
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To change the options:

1 From the Tools menu, click Options. The Rhino Options dialog box appears.

2 Click on the Modeling Aids tab.

The Modeling Aids tab allows you to control ortho, object snap, grid snap, and other mode options.

3 Change the Ortho options to Constrain every 30 degrees.
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4 Click on the Grid tab.

You can change the appearance of the modeling environment by changing the grid elements. The grid size, the
frequency of the thick lines, and the number of grid elements can be changed. The Grid dialog allows you to
configure grid settings.

5 Change the Snap Spacing setting to .25.

6 Change the Thick line every setting to 4.

7 Change the Grid Extents setting to 10.

8 Click OK.

9 Draw some more lines and curves with Snap and Ortho on.  Notice that the cursor now snaps between the grid
intersections and that ortho snaps at every 30 degrees.
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10 Try to draw the object below with snap and ortho turned on.

Saving your work
Save your work periodically during a session to keep it from getting accidentally deleted.   

To save your model:

1 From the File menu, click Save.

Or, click one of the other options. You will have an opportunity to save your work.

Command Description

Save Saves your model and keeps it open.

Save As Saves your model to a specified file name, location, and format.

New Offers to save your model before opening a new one.

Open Offers to save your model before opening a different one.

Exit Offers to save your model before ending your Rhino session.

It is good practice to save your
model in stages under different
names, using the Save As
command.  This will allow you
to go back to an earlier version
of your model for modifications
if necessary.
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Layers
Rhino layers work like CAD layering systems. By creating objects on different layers, you can edit and view related
portions of a model separately or as a composite. You can create as many layers as you like.

You can display all layers simultaneously or turn any of them off. You can lock layers so they are displayed but cannot be
selected. Each layer has a color. You can assign a unique name to each layer (for example, BASE, BODY, TOP) to
organize the model or you can use preset layer names (Default, Layer 01, Layer 02, Layer 03).

The Edit Layers dialog box manages layers. Use it to set up layers for your model.
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Exercise 6—Layers

To create a new layer::

1 From the Edit menu, click Layers, then click Edit.

2 The layer Default is created automatically when you start a new model.

3 In the Edit Layers dialog box, click New.

4 The new layer Layer 01 appears in the list, type Line and press ENTER.

5 Click New.

6 The new layer Layer 02 appears in the list, type Curve and press ENTER.

Edit Layers
Look for this button.
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To assign a color to a layer::

1 Click the Color bar on the Line row in the list.

2 In the Select A Color dialog box, click red from the list.

The sample square turns red.

3 Click OK.

4 In the Edit Layers dialog box, the new color appears in the color bar on the Line row of the layer list.

5 Repeat steps 1–3 to make the Curve layer Blue.

6 Click OK to close the dialog box.

To make a layer current:

1 Click in the Layer pane of the Status Bar.

2 Click Line.

Hue is controlled by moving
the line around the circular
portion of the color wheel.

Hue is the color that is referred
to as a scale ranging from red
through yellow, blue and green
and then circularly back to red.

Saturation and Value are
controlled by moving the circle
around in the square portion in
the middle of the color wheel.

Saturation is the vividness of
hue.

Value is the relative lightness
or darkness of a color.
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3 Draw some lines.

4 The lines appear on the Line layer and they are red.

5 Change layers by clicking the Layer area of the status bar. Click Curve.

6 Draw some curves.

7 Draw more lines and curves on each layer.

To lock a layer:

1 From the Edit menu, click Layers, then click Edit.

2 In the Edit Layers dialog box, click the radio button under Lock in the row for Line.

Locking a layer turns it into a reference only layer. You can see and snap to objects on locked layers. You cannot
select any objects on locked layers. You cannot make a locked layer current without unlocking it.

3 Click OK.

To turn a layer off:

1 From the Edit menu, click Layers, then click Edit.

2 In the Edit Layers dialog box, click the radio button under Off in the row for Curve.

Turning a layer off makes all objects on it invisible.

3 Click OK.

Exercise 7—Selecting objects

To select an object:

♦ Move your pointer arrow over the object and left-click.
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To select more than one object:

1 Move your pointer arrow over the first object and left-click.

2 While holding the SHIFT key down, move your pointer over another object and left-click.

To select more than one object using a window:

1 Move your pointer arrow into an open area to the lower left of the objects you want to select. Hold your left button
down and drag diagonally to the right until you have several objects inside the window. Release your mouse button.

All objects completely inside the window will be selected.

2 You can add to your selection set by holding the SHIFT key down while making another selection.

3 Or, type Selwindow and press enter to start a Window selection.

To select more than one object using a crossing window:

1 Move your pointer arrow into an open area to lower right of the objects you want to select. Hold your left button
down and drag diagonally to the left until you have several objects inside or touching the window. Release your
mouse button.

All objects inside or touching the window will be selected.

2 You can add to your selection set by holding the SHIFT key down while making another selection.

3 Or, type Selcrossing and press enter to start a Crossing Window selection.

To hide an object:

1 Select an object.

2 From the Edit menu, click Visibility, then click Hide.

The object becomes invisible.

To show hidden objects:

♦ From the Edit menu, click Visibility, then click Show.
The Show command shows all hidden objects globally.

Hide
Look for this button.
Left click for hide.

Show
Look for this button.
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To Lock an object:

1 Select an object.

2 From the Edit menu, click Visibility, then click Lock.
The object becomes shaded gray. You can see the Locked object, you can snap to it, but you cannot select it.

To Unlock locked objects:

♦ From the Edit menu, click Visibility, then click Unlock.
The Unlock command redisplays all Locked objects globally.

To move an object from one layer to another:

1 Select an object.

2 From the Edit menu, click Layers, then click Change Object Layer.

The Layer for object dialog appears.

3 Select the layer you want the object to move to, then press OK.

Lock
Look for this button.

Unlock
Look for this button.
Right click for unlock.

Change Layer
Look for this button.
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Deleting objects
Delete removes selected objects from the model. Use Delete to practice selection.

Exercise 8—Practice Using Delete and Selection options

To open the practice model:

1 From the File menu, click Open.

2 In the Open dialog box click Delete.3dm and click Open or double-click delete.3dm to open the model.

3 Select the square and the circle.
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4 From the Edit menu, click Delete or press the DELETE key.

The objects disappear.

To start the first practice:

1 Select one of the lines on the hexagon in the top view. Because there are several lines superimposed on each other,
the choose between multiple objects dialog appears.

2 Click Next.

3 It will highlight the next item that is in the same location. You can see the change in the perspective or side view.
When the hexagon on the top is highlighted, click OK.

4 From the Edit menu, click Delete.

5 Make a crossing window to select the surface and the polyline in the top right part of the drawing.
Both objects are selected.

 
6 From the Edit menu, click Delete.
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7 Make a window to select the polyline and the cylinder in the lower right part of the drawing.
Only those objects that are completely inside the window are selected.

 
8 From the Edit menu, click Delete.

9 Continue deleting objects in the drawing. Practice using different selection methods to select and deselect objects.
Use crossing and window. The SHIFT key while selecting will let you add to your selection set. The CTRL key while
selecting will let you to remove objects from your selection set.

To undo deletions:

♦ From the Edit menu, click Undo.
Each time you click it will take you back one command sequence.

To redo:

♦ From the Edit menu, click Redo.
Each time you click it will redo the previous Undo.

Undo
Look for this button.
Left click for undo.

Redo
Look for this button.
Right click for redo.
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4 Precision Modeling

Exercise 9Setting Up a Model

To start the new model :

1 From the File menu, click New.

2 Click 4viewports.3dm, then click Open.

3 From the File menu, click Save. Name the model BOXES.

Modeling With Coordinates
So far you have been drawing imprecise lines. Now we will look at drawing lines at specific places. To do this you will
use coordinates.

Whenever you draw a curve, place a point, or create a solid primitive, Rhino asks you for a series of points. You can tell
that Rhino is asking for point input two ways: the command prompt has a prompt like Start of first line, Start of
polyline, Start of curve, or Next point and the cursor turns into a marker.

You can enter a point two ways: by picking a point in a viewport with the mouse, or by typing coordinates in the
command line.

Rhino uses a fixed Cartesian coordinate system called the World Coordinate System (WCS), based on three axes (the x-,
y-, and z-axes) that define locations in two- and three-dimensional space.

Marker
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Each viewport has a construction plane that defines coordinates for that viewport. We will work in the Top (and
Perspective) viewports where the two coordinate systems are the same.

Absolute Coordinates

The first form of coordinates you will use are called absolute coordinates. Absolute coordinates are exact locations on the
x-, y-, and z-axes.

Use the BOXES model  to learn how to draw with absolute coordinates.

Exercise 10—Entering Absolute Coordinates

To draw lines using absolute coordinates:

1 Maximize the Top Viewport by double-clicking the title bar.

2 From the Curve menu, click Line, then click Polyline.

3 At the Start of polyline prompt, type 0,0, and press ENTER.

4 At the Next point of polyline (Undo) prompt, type 5,0, and press ENTER.

5 At the Next point of polyline, press ENTER when done (Undo) prompt, type 5,5, and press ENTER.

6 At the Next point of polyline, press ENTER when done ( Close Undo) prompt, type 0,5, and press ENTER.

7 At the Next point of polyline, press ENTER when done ( Close Undo) prompt, type C, and press ENTER, to close
the line.

Polyline
Look for this button.
Left click for Polyline.



P R E C I S I O N  M O D E L I N G

N o t e s :

Robert McNeel & Associates ❑ 49

Relative Coordinates

Absolute coordinates can be slow and cumbersome, but they do work. Most of the time, relative coordinates are easier to
use. Every time you select a point, Rhino saves that point as the last point. Relative coordinates are based on this last
point, instead of on the origin (0,0,0) of the CPlane.

Precede the x,y,z coordinates with a single “R” to enter relative coordinates.

Exercise 11—Entering Relative Coordinates
1 From the Curve menu, click Line, then click Polyline.

2 At the Start of polyline prompt, type 8,0, and press ENTER.

3 At the Next point of polyline (Undo) prompt, type R5,0, and press ENTER.

4 At the Next point of polyline, press ENTER when done (Undo) prompt, type R0,5, and press ENTER.

5 At the Next point of polyline, press ENTER when done ( Close Undo) prompt, type R-5,0 and press ENTER.

6 At the Next point of polyline, press ENTER when done ( Close Undo) prompt, type C, and press ENTER, to close
the line.

Polyline
Look for this button.
Left click for Polyline.
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Polar Coordinates

Polar coordinates specify a point that is a distance and direction away from 0,0 in the current construction plane. For
example, if you want a point four units away from the construction plane origin, at a 45° angle clockwise from the
construction plane x-axis, type 4<45, and press ENTER. Relative polar coordinates are preceded by the “r”, absolute
polar coordinates are not. Instead of using x-, y-, and z-coordinates, enter relative polar coordinates like this:
rdistance<angle.

Exercise 12—Entering Polar Coordinates
1 From the Curve menu, click Line, then click Polyline.

2 At the Start of polyline prompt, type 0,8, and press ENTER.

3 At the Next point of polyline (Undo) prompt, type R5<0, and press ENTER.

4 At the Next point of polyline, press ENTER when done (Undo) prompt, type R5<90, and press ENTER.

5 At the Next point of polyline, press ENTER when done ( Close Undo) prompt, type R5<180, and press ENTER.

6 At the Next point of polyline, press ENTER when done ( Close Undo) prompt, type C, and press ENTER, to close
the line.

 

Polyline
Look for this button.
Left click for Polyline.
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Distance and Angle Constraint Entry

Using distance constraint entry, you can specify a point by typing a distance and pressing ENTER. As you move your
cursor in any direction, the length of line will be constrained. This is a good way to specify a line length quickly.

Using angle constraint entry, you can specify an angle by typing < followed by a value and pressing ENTER. The next
point is constrained to lines at the angle you specified.

Distance constraining value 5, angle constraint value 30
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Using the shift key to toggle Ortho on and off:

When Ortho is off you can hold the SHIFT key down to toggle it on. This method is an efficient way to draw
perpendicular lines. In the following example, you draw a line 5 units long using distance constraints.

Exercise 13—Distance Constraint Entry
1 From the Curve menu, click Line, then click Polyline.

2 At the Start of polyline prompt, type 8,8, and press ENTER.

3 At the Next point of polyline (Undo) prompt, type 5, and press ENTER.
Hold the SHIFT key down and pick a point 90 degrees to the right.

4 At the Next point of polyline, press ENTER when done (Undo) prompt, type 5, and press ENTER.
Hold the SHIFT key down and pick a point 90 degrees up.

5 At the Next point of polyline, press ENTER when done ( Close Undo) prompt, type 5, and press ENTER.
Hold the shift key down and pick a point 90 degrees to the left.

6 At the Next point of polyline, press ENTER when done ( Close Undo) prompt, type C, and press ENTER, to close
the line.

Exercise 14—Distance and Angle Constraint Entry
1 From the Curve menu, click Line, then click Polyline.

2 At the Start of polyline prompt, type 16,5, and press ENTER.

3 At the Next point of polyline (Undo) prompt, type 5, and press ENTER, then type <45 and press ENTER.
As you drag your cursor around it snaps to a distance of 5 and an angle of 45 degrees.
Pick a point 45 degrees down and to the right.

4 At the Next point of polyline, press ENTER when done (Undo) prompt, type 5, and press ENTER, then type <45
and press ENTER.
Pick a point 45 degrees up and to the right.

5 At the Next point of polyline, press ENTER when done ( Close Undo) prompt, type 5, and press ENTER, then type
<45 and press ENTER.
Pick a point 45 degrees up and to the left.

6 At the Next point of polyline, press ENTER when done ( Close Undo) prompt, type C, and press ENTER, to close
the line.

Polyline
Look for this button.
Left click for Polyline.

Polyline
Look for this button.
Left click for Polyline.
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7 Save your model.  We will use this model for another exercise.

Exercise 15—Practice
1 Start a new model. Save as Arrow.

2 Draw the arrow with a polyline, using a combination of absolute coordinates (x,y), relative coordinates (Rx,y),
polar coordinates (Rdistance<angle), and distance constraint. Begin your model  at 0,0.

3 Save your model.

To make it 3D:

1 Select the Polyline.

2 From the Surface menu and click Revolve.

3 Toggle Snap on. Revolve
Look for this button.
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4 At the Start of revolve axis prompt, choose the end of the arrow along the center line.

5 At the End of revolve axis prompt, choose the other end of the arrow along the center line.

6 The Revolve Options dialog box will appear. Click OK. Your arrow is now a three-dimensional model.

7 Click the mouse in the Perspective viewport to make it active.

8 From the Render menu, click Shade.

Shade
Look for this button.
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Viewports
Viewports are windows in the Rhino graphics area that show you a view of your model. You can move and resize
viewports by dragging the title bar or borders. The cursor moves along a construction plane, which is defined for each
viewport. You can create new viewports, rename viewports, and use predefined viewport configurations.  To activate a
viewport click anywhere in the viewport and the title highlights.  If you are in a command sequence you simply have to
move your cursor into a viewport to activate it.
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Construction planes

The construction plane is the guide used for modeling Rhino objects. Points you pick are always on the construction
plane unless you use coordinate input, elevator mode, or object snaps.

Each construction plane has its own axes, a grid, and an orientation relative to the world coordinate system.

Default construction planes are provided with the default viewports.

•  The Top construction plane x- and y-axes align with the world x- and y-axes.

• The Right construction plane x- and y-axes align with the world y- and z-axes.

• The Front construction plane x- and y-axes align with the world x- and z-axes.

• The Perspective view uses the Top construction plane.

Each construction plane has a grid. The grid is a plane of perpendicular lines lying on the construction plane. On default
grids, every fifth line is slightly thicker. The red line represents the construction plane x-axis. The green line represents
the construction plane y-axis. The red and green lines meet at the construction plane origin.

The red and green axes on the grid are the x- and y-axes of that viewport’s construction plane. The construction planes
happen to be lined up with world axes when you first start Rhino, so it is confusing in the front and side viewports where
the y-axis of the construction plane happens to be pointing up in the world z- direction. The icon in the left hand corner
always shows world coordinates, which are different from the construction plane axes.

Exercise 16—Modeling  in different viewports
1 Start a new model. Save as Viewports.

In this exercise you will use snap and ortho to draw in different viewports.  When modeling in Rhino, the active
viewport and the construction plane are the same.

2 Toggle Ortho and Snap on.

3 From the Curve menu, click Line, then click Polyline.

4 Move your cursor into the Top viewport.

5 At the Start of polyline prompt, type 0,0, and press ENTER.

6 At the Next point of polyline prompt, pick 8 units to the right.

7 At the Next point of polyline prompt, pick 5 units up.

Polyline
Look for this button.
Left click for Polyline.
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8 At the Next point of polyline prompt, pick 8 units to the left.

9 At the Next point of polyline prompt, type C, and press ENTER to close the line.

To draw in the front viewport:

1 From the Curve menu, click Line, then click Polyline.

2 Move your cursor into the Front viewport.

3 At the Start of polyline prompt, type 0,0 and press ENTER.

4 At the Next point of polyline prompt, pick 8 units to the right.

5 At the Next point of polyline prompt, pick 5 units up.

6 At the Next point of polyline prompt, pick 8 units to the left.

Polyline
Look for this button.
Left click for Polyline.
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7 At the Next point of polyline prompt, type C, and press ENTER to close the line.

To draw in the right viewport

1 From the Curve menu, click Line, then click Polyline.

2 Move your cursor into the Right Viewport.

3 At the Start of polyline prompt, type 0,0, and press ENTER.

4 At the Next point of polyline prompt, pick 5 units to the right.

5 At the Next point of polyline prompt, pick 5 units up.

6 At the Next point of polyline prompt, pick 5 units to the left.

Polyline
Look for this button.
Left click for Polyline.
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7 At the Next point of polyline prompt, type C, and press ENTER to close the line.

 
Look in the perspective view.  Each rectangle was drawn on a different construction plane.  As you input coordinate
data the points will be placed on the construction plane of the active viewport.

Modeling in 3d Space
Rhino makes it easy to draw in 3d space.  As demonstrated in the previous exercise you can draw on a different
construction plane by simply moving your cursor into a different viewport.  Another useful tool for modeling in 3d space
is elevator mode.

Elevator Mode

Elevator mode lets you pick points that are off the construction plane. Elevator mode requires two point picks to
completely define the point. The first specifies the base point. The second specifies how far the final point is above or
below the base point.

After the base point is specified, the marker is constrained to a tracking line perpendicular to the CPlane that passes
through the base point.

Pick a second point to specify the z-coordinate of the desired point. You can pick a point with the mouse, or type a single
number to specify the height above the Cplane. Positive numbers are above the construction plane, negative numbers are
below.

To activate elevator mode, hold the CTRL key while clicking with the left mouse button.
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To draw rectangle using elevator mode:

1 From the Curve menu, click Line, then click Polyline.

2 Move your cursor into the Top Viewport.

3 At the Start of polyline prompt, pick the 0,0 point while holding the CTRL key down.
A tracking line constrains the marker through the base point perpendicular to the CPlane of the current view.

4 Move the cursor to the Front viewport to see the marker track along the tracking line.
Pick a point at the top left of the rectangle.  This is a secondary pick that elevates the first point off the construction
plane.

 
5 At the Next point of polyline prompt, drag your cursor back to the top viewport and pick 8 units to the right.

6 At the Next point of polyline prompt, pick 5 units up.

Polyline
Look for this button.
Left click for Polyline.
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7 At the Next point of polyline prompt, pick 8 units to the left.

8 At the Next point of polyline prompt, type C, and press ENTER to close the line.

Notice that the polyline stays at the same elevation from the construction plane as you pick your next point.  This is
because Ortho is turned on.

9 Experiment using elevator mode with Ortho off.

10 Experiment using elevator mode with Planar mode on.
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Exercise 17—Practice using distance and angle constraints
1 Start a new model. Save as V-Block.

2 Double Click on the title bar in the Front viewport. Create the following model  in the front construction plane.

3 Draw the object below using a combination of absolute coordinates (x,y), relative coordinates (rx,y), and polar
coordinates (rdistance<angle). Start your model  at 0,0 in the Front Viewport.
Try to create the model using a single polyline.

4 Save your model.

5 Double Click on the title bar of the Front viewport to restore your views.
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6 Select the object.

7 From the Solid menu, click Extrude Planar Curve.

8 At the Extrusion distance <1> (Direction Cap=yes Bothsides Tapered) prompt, type 12 and press ENTER.

You can view the model as a three-dimensional object in the perspective viewport.

9 Click the mouse in the Perspective viewport to make it active.

10 From the Render menu, click Shade.

11 Save your model.

Shade
Look for this button.
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Object Snaps
Object Snaps are tools for selecting specific points on existing objects. Use them for precision modeling and to get
accurate data. Object Snaps are often referred to as osnaps.

To open the Osnap toolbar, click Osnap in the status bar. This toolbar controls persistent object snaps. Use persistent
objects snaps to maintain an object snap through choosing several points without having to reactivate the object snap.

When an object snap is active, moving the cursor near a specified point on an object causes the marker to jump to that
point.

Check a box to turn on the object snap. You can place the toolbar anywhere on your desktop.

Command Button Description

End End snaps to the end of a curve.

Near Near snaps to the nearest point on an existing curve.

Point Point snaps to a control point.

Mid Midpoint snaps to the midpoint of a curve.

Cen Center snaps to the center point of a curve. This works best with circles and arcs.
With other curves, you will snap to the center points of circles based on the
curvature at any given point.

Int Intersection snaps to the intersection of two curves.

Perp Perpendicular To snaps to the point on a curve that is perpendicular to the last
selected point. Works only when you’re selecting a series of points.

Tan Tangent To snaps to the point on a curve that is tangent to the last selected point.
This only works when you’re selecting a series of points.

Quad Quad snaps to the quadrant point of a circle, arc, or ellipse.
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Command Button Description

Lock Temporarily turns off running object snaps.

Project Projects the snap point to the construction plane.

In Rhino, reliable modeling and easy editing depends on objects actually meeting at specified points. Objects snaps gives
you precision you cannot get using the “eyeball” method.

Exercise 18—Using Object Snaps
1 Open the Osnap model.

2 Toggle Snap and Ortho off.

Using End and Midpoint:

1 Click Osnap on the status bar. You can leave the Osnap toolbar displayed.

2 Check End and Mid. You can check and uncheck individual osnaps to make modeling with precision easy.

3 From the Curve menu, click Line, then click Polyline.

4 At the Start of polyline prompt, move your cursor close to the end of the line at the lower left corner of the first box
and pick when the marker snaps to the end of the line. Pick to draw the polyline.

The line starts exactly at that corner.

5 At the Next point of polyline prompt, snap to the Midpoint of the right vertical edge of the second box.

Polyline
Look for this button.
Left click for Polyline.

Osnap
End and Mid on
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The marker snaps to the midpoint of the line that the cursor touches, making the new line cross to the exact midpoint
of that side. Pick to draw the polyline.

6 At the Next point of polyline prompt, snap to the End at the upper left corner of the first box.

The marker snaps to the End of the line. Pick to draw the polyline.

7 Press ENTER to end the command.

Using Near to and Perpendicular to:

1 In the Osnap toolbar check Near and Perp; uncheck End and Mid.

2 From the Curve menu, click Line, then click Polyline.

3 At the Start of polyline prompt, pick on the lower edge the circle at the top right.

The marker snaps to the point on the circle nearest to where the cursor was positioned.

4 At the Next point of polyline prompt, pick the top horizontal edge of the second box.

The marker snaps to a point perpendicular to the previous point. Pick to draw the polyline.

5 Press ENTER to end the command.

Using Intersection and Tangent to:

1 In the Osnap toolbar check Int and Tan; uncheck Near and Perp.

2 From the Curve menu, click Line, then click Polyline.
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3 At the Start of polyline prompt, pick on the intersection where the diagonal line crosses the vertical line on the first
box.

The marker snaps to the intersection between the two lines.

4 At the Next point of polyline prompt, pick the top, left edge of the circle on the right.

The marker snaps to a point tangent to the circle.

5 Press ENTER to end the command.

Using Center of:

1 In the Osnap toolbar check Cen; uncheck Int and Tan.

2 From the Curve menu, click Line, then click Polyline.
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3 At the Start of polyline prompt, pick on the edge of a circle.

The marker snaps to the center of the circle.

4 At the Next point of polyline prompt, pick on the edge of the other circle.

The marker snaps to the center of the circle.

5 Press ENTER to end the command.

Using Quadrant of:

1 In the Osnap toolbar Check Quad; uncheck Cen.

2 From the Curve menu, click Line, then click Polyline.
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3 At the Start of polyline prompt, pick a point on the top edge of the first circle.

The marker snaps to the quadrant point of the circle.

4 At the Next point of polyline prompt, pick the left edge of the circle.

The marker snaps to the quadrant point of the circle.

5 At the Next point of polyline prompt, pick the bottom edge of the circle.

6 At the Next point of polyline prompt, pick the right edge of the circle.

7 At the Next point of polyline prompt, type C and press ENTER.

Analysis Commands
Rhino provides analysis tools for finding lengths, angles, areas, distances, volumes and centroids of solids. Additional
commands let you analyze curve curvature, continuity between curves, and find unjoined edges.

Command Description

Distance Displays the distance between two points.

Length Displays the length of an object.

Angle Displays the angle between two lines.

Radius Measures the radius of curvature of a curve, circle, or arc at the point where you pick the curve and
displays it on the command line.
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Command Description

Point The Cartesian coordinates of the point, in both world and CPlane coordinates are displayed on the
command line in x,y,z format.

To find the distance between two points:

1 From the Analyze menu, click Distance.

2 At the First point for distance prompt, pick the intersection where a diagonal line intersects a vertical line.

3 At the Second point for distance prompt, pick the intersection where the other diagonal line intersects the same
vertical line.

4 Press F2 to display the information.

Construction coordinates:
angles: xy = 90  elevation = 0
deltas: dx = 0  dy = 3.07692  dz = 0

World coordinates:
angles: xy = 90  elevation = 0
deltas: dx = 0  dy = 3.07692  dz = 0

Distance = 3.07692 units

Distance
Look for this button.
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To find the length of a line:

1 From the Analyze menu, click Length.

2 At the Select Curve to measure prompt, select the line between the centers of the circles.

The length of the object displays on the command line.

Length:   8.0000 (+/- 0.0008)

To measure the Angle between two lines:

1 From the Analyze menu, click Angle.

2 At the Start of line 1 prompt, select a point that defines the start of an angle line.

3 At the End of line 1 prompt, select a point that defines the end of an angle line.

4 At the Start of line 2 prompt, select a point that defines the beginning of the second angle line.

5 At the End of line 2 prompt, select a point that defines the end of the second angle line.

Length
Look for this button.

Angle
Look for this button.
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The angle will display on the command line in the following format:

Angle is 21.7711 degrees

To measure the radius of a circle:

1 From the Analyze menu, click Radius.

2 At the Select curve for radius measurement prompt, select one of the circles. This will also measure a radius on a
curve.

The radius will display on the command line in the following format:

Radius at pick point is 2.5

To measure a point:

1 From the Analyze menu, click Point.

Radius
Look for this button.

Point
Look for this button.
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2 At the Point to measure prompt, snap to the end point of one of the squares.

The x,y,z point is displayed for the world coordinate plane and the current construction plane.

Point in world coordinates = 8,5,0  cplane coordinates = 8,5,0

Drawing Circles
You can create circles using a center point and radius, center point and a diameter, two points on the diameter, three
points on the circumference, tangent points to two coplanar curves and a radius.

Button Command Description

Circle Creates a circle from a center point and a radius.

Circle3Pt Creates a circle from three points on the circumference.

CircleD Creates a circle from two points on the circumference that are the ends of the
diameter.

CircleTTR Creates a circle from a radius and two objects that the circle is tangent to.

CircleTTT Creates a circle that is tangent to three other objects.
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Button Command Description

Circle V Creates a circle that is perpendicular to the construction plane

Option Description

Diameter Type D, and press ENTER to change to diameter input.  You will have to type R to change back to radius
input.

Vertical Type V, and press ENTER to create a circle that is perpendicular to the construction plane.

AroundCurve Type A, and press ENTER to draw a circle whose axis is perpendicular to a curve.

Exercise 19—Drawing Circles

To draw a center, radius circle:

1 From the Curve menu, click Circle, then click Center, Radius.

2 At the Center of circle (Vertical AroundCurve) prompt, type 20,10 and press ENTER.

3 At the Radius <1> (Diameter) prompt, type 3 and press ENTER. A circle is created.

To draw a center, diameter circle:

1 From the Curve menu, click Circle, then click Center, Radius.

2 At the Center of circle (Vertical AroundCurve) prompt, type 20,3 and press ENTER.

3 At the Radius <3> (Diameter) prompt, type D and press ENTER.

Circle
Look for this button.

Circle
Look for this button.
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4 At the Diameter <6.00> (Radius) prompt, type 5 and press ENTER.

A circle is created that is based on a center point and a diameter.  The diameter option will be the default until it is
changed.

To draw a 3-point circle:

1 From the Curve menu, click Circle, then click 3 Points.

2 At the First point on circle prompt, snap to an End on one of the squares.

3 At the Second point on circle prompt, snap to another End on the same square.
Circle 3Pt
Look for this button.
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4 At the Third point on circle prompt, snap to a third End on the same square.

A circle is created with a circumference that intersects the three ends you picked.

To draw circle diameter:

1 From the Curve menu, click Circle, then click Diameter.

2 At the Start of diameter (Vertical) prompt, pick the first point on the circle diameter by snapping to the End of a
square.

Circle Diameter
Look for this button.
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3 At the End of diameter prompt, type 3 and press ENTER, then turn Ortho on and pick to the right.

A circle is created with the two points you picked as the diameter, and the diameter was constrained to a value of  3.

To draw a tangent, tangent, radius circle:

1 From the Curve menu, click Circle, then click Tangent, Tangent, Radius.

2 At the Select first curve for CircleTTR prompt, select the circle you just created near the top edge.

3 At the Select second curve for CircleTTR prompt, select the circle to the right of the circle you picked near the top
edge.

Circle Tangent, Tangent, Radius
Look for this button.
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4 At the Radius <1> prompt, type 2 and press ENTER. Or, press ENTER to accept the default value.

A circle is created that is tangent to the two circles you selected with a radius of 2. Sometimes this command creates
multiple circles.  Delete the extras.

To draw a tangent, tangent, tangent circle:

1 From the Curve menu, click Circle, then click Tangent to 3 Curves.

2 At the Select First curve: prompt, select the first object that you want the circle to be tangent to.

3 At the Select Second curve: prompt, select the second object that you want the circle to be tangent to.
Circle Tangent to 3 Curves
Look for this button.
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4 At the Select Third curve prompt, select the third object that you want the circle to be tangent to.

Sometimes this command creates multiple circles.  Delete the extras.

To draw a circle vertical to the construction plane:

1 From the View menu, click Viewport Layout, then click 4 Viewports.

2 From the Curve menu, click Circle, then click Diameter.

3 At the Start of diameter (Vertical) prompt, type V and press enter.

4 At the Start of diameter prompt, snap to the Quadrant of one of your circles in the top viewport.
Circle Diameter
Look for this button.
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5 At the End of diameter prompt, snap to the other Quadrant of the same circle.

The circle is drawn perpendicular to the construction plane. You will be able to see it in the one of the other
viewports.

 

To draw a circle around a curve:

1 From the Curve menu, click Circle, then click Center, Radius.

2 At the Center of circle (Vertical AroundCurve): type A and press ENTER.

3 At the Center of circle: prompt, choose a point on a circle.
Circle
Look for this button.
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4 At the Radius: prompt, type 3 and press ENTER.

The circle is drawn perpendicular to the curve at the point you picked. You will be able to see it in the perspective
viewport.
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Exercise 20—Practice
1 Start a new model. Save as Circles.

2 From the Edit menu, click Layers, then click Edit.

3 Click New three times.

4 Rename the new layers Box, Line, Circle.

5 Change the color of the Box layer to green, Line to cyan, and Circle to red.

6 Draw the lines and circles on the appropriate layers. Use Line Segments for the Box and Single Line for the center
lines. You will use several of the circle options and object snaps to complete this model .

To make it 3D:

1 Select the lines that form the rectangle.
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2 From the Solid menu, click Extrude Planar Curve.

3 At the Extrusion distance <1> (Direction Cap=yes Bothsides Tapered) prompt, type 2 and press ENTER.

The rectangle generates a box.

4 Select the circles.

5 From the Solid menu, click Extrude Planar Curve.

6 At the Extrusion distance <2> (Direction Cap=yes Bothsides Tapered) prompt, type -6 and press ENTER.

The circles generate cylinders.

7 Click in the perspective viewport.

Extrude Planar Curve
Look for this button.
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8 From the Render menu, click Shade.

 

Shade
Look for this button.
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Exercise 21—Using Circle related Object Snaps
1 Start a new model.  Save as Link.

2 Complete the model as shown.

3 Draw the three large circles first.

4 Draw the small holes next. Use object snaps to snap to the center of the large circles.

To draw the lines:

1 From the Curve menu, click Line, then click Tangent to 2 Curves.

2 At the Select first curve near tangent point prompt, pick on the edges of the circles where you want the tangent
lines to attach.

Line Tangent to 2 Curves
Look for this button.
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3 At the Select second curve near tangent point prompt, pick on the edges of the circles where you want the tangent
lines to attach.

4 Continue to use this command to complete the model.

5 Save your model.

Drawing Arcs
Arc draws a circular arc through three non-collinear points. You can create arcs from a center point, start point, and
angle, two ends and a point along the arc, the ends and a direction, a start point, circumference point, and an end point,
tangent points two coplanar curves and a radius.

You can continue an existing curve with an arc to an existing curve to a point or by an angle.

Button Command Description

Arc Creates an arc from a center point, a starting point and an end or an angle.

Arc3Pt Creates an arc from three points.

ArcDir Creates an arc from start point, end point, and direction.
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Button Command Description

ArcTTR Creates an arc from tangents and radius.

ExtendByArc Continues an arc by angle.

ExtendByArcToPt Continues an arc to a point.

Exercise 22—Practice With Arcs

♦ Open the Arc1 model.
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To draw a center, start, end or angle arc:

1 From the Curve menu, click Arc, then click Center, Start, Angle.

2 At the the Center of arc prompt, snap to the center of the circle at the lower left.

3 At the Start or arc prompt, snap to the end of the line.

4 At the End point or angle prompt, snap to the end of the other line, or drag your cursor in the direction you want the
arc to go then type 90 and press ENTER.

To draw a start, end, direction arc:

1 From the Curve menu, click Arc, then click Start, End, Direction.

2 At the Start of arc prompt, pick a start point.

3 At the End of arc prompt, pick an end point.

Arc
Look for this button.

Direction Arc
Look for this button.
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4 At the Direction prompt, toggle ortho on and drag straight up for the tangent at the start point and pick.

5 Make another Direction Arc at the upper right.

To add more arc segments:

1 From the Curve menu, click Extend, then click By Arc.

2 At the Select curve to extend prompt, pick the end point of  the arc you just created.

3 At the Radius of arc (MatchRadius) prompt, type 2 and press ENTER.

4 At the End point or angle prompt, toggle ortho on and pick a point straight down.

Extend By Arc
Look for this button.
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The arc will be tangent to the curve you chose.

5 From the Curve menu, click Extend, then click By Arc to Point.

6 At the Select curve to extend prompt, pick the end of the last arc.

7 At the End of arc prompt, pick the end of the line.

To draw a tangent, tangent, radius arc:

1 From the Curve menu, click Arc, then click Tangent, Tangent, Radius.

2 At the Select first curve for ArcTTR prompt, pick an arc, line, circle, or curve.

Extend By Arc To Pt
Look for this button.

Arc Tangent, Tangent, Radius
Look for this button.
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3 At the Select second curve for ArcTTR prompt, pick another arc, line, circle, or curve.

4 At the Radius<1> prompt, type 3 and press ENTER. All of the arcs that are tangent are created. Delete the arcs that
you don’t need.

 
5 Repeat this for the other tangent arc with a radius of 6.

6 Save your model.



P R E C I S I O N  M O D E L I N G

N o t e s :

Robert McNeel & Associates ❑ 92

Exercise 23—Practice With Arcs
1 Start a new model. Save as Arc2.

2 Create this model  using object snaps and the Line, Circle, and Arc commands.

To make it 3D:

1 Select the all of the lines and arcs that form the object.

2 From the Solid menu, click Extrude Planar Curve.

Draw the center lines first: use
their intersection point to draw
your arcs and circles.

Extrude Planar Curve
Look for this button.
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3 At the Extrusion distance <1> (Direction Cap=yes Bothsides Tapered) prompt, type 1 and press ENTER.

The object now has thickness.

4 Click in the perspective viewport.

5 From the Render menu, click Shade.
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Drawing Ellipses and Polygons
You can draw ellipses from the center or by the ends. You can draw Polygons from a center point or an edge. You can
draw a rectangle from diagonal corners or by choosing three points.

Button Command Description

Ellipse Creates an ellipse by specifying the center point, the end of one axis, and a height.

EllipseD Creates an ellipse by specifying the ends of one axis, and a height.

Polygon Creates a polygon from its center and radius.

PolygonEdge Creates a polygon by specifying the ends of one edge.

Rectangle Creates a rectangle using opposite corners.

RectangleCen Creates a rectangle from adjacent corners and a point on the opposite edge.

Ellipse Options

Option Description

Vertical Type V, and press ENTER, to create an ellipse that is perpendicular to the construction plane.

AroundCurve Type A, and press ENTER to draw an ellipse whose axes is perpendicular to a curve.

Polygon Options

Option Description

Circumscribed Type C, and press ENTER, to create a polygon that is circumscribed about a radius. The default is to
create a polygon that is inscribed in a specified radius.
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Exercise 24—Practice With Ellipses and Polygons
Start a new model. Save as Ellipse.

To draw a rectangle from diagonal corners:

1 From the Curve menu, click Rectangle, then click Corner to Corner.

2 At the First corner of rectangle (Rounded) prompt, type -10,-5, and press ENTER.

3 At the Other corner or length prompt, type 20 and press ENTER.

4 At the Width prompt, type 10 and press ENTER.

Rectangle
Look for this button.
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Draw a rectangle from a center point with a length and width, and rounded corners:

1 From the Curve menu, click Rectangle, then click Center, Corner.

2 At the Center of rectangle (Rounded) prompt, type R, and press ENTER to give the rectangle rounded corners.

3 At the Center of rectangle prompt, type 0,0 and press ENTER.

4 At the Corner or length prompt, type 19 and press ENTER.

5 At the Width prompt, type 9 and press ENTER.

5 At the Choose a point in the corner to define roundness (Corner=Arc) prompt type 1,and press ENTER.

If you are creating a rounded rectangle, choose a point in the corner to set its curvature. Or, type C, and press ENTER
to toggle from circular rounded corners to conic rounded corners.

To draw an ellipse from its center and axis ends:

1 From the Curve menu, click Ellipse, then click From Center.

2 At the Center of ellipse (Vertical AroundCurve) prompt, type 0,0 and press ENTER.

3 At the End of First axis prompt, type 4, and press ENTER

4 At the End of First axis prompt, toggle ortho on and pick to the right.

5 At the End of Second axis prompt, type 3, and press ENTER.

To draw a polygon from its center and radius:

1 From the Curve menu, click Polygon, then click Center, Radius.

2 At the Center of polygon (NumSides=4 Circumscribed) prompt, type 3 and press enter to change the number of
sides for the polygon.

3 At the Center of polygon (NumSides=3 Circumscribed) prompt, type -7,-2 and press enter to locate the center point
for the polygon.

4 At the Radius prompt, type 1.5 and press enter.

5 At the Radius prompt, pick a point to orient the polygon.

6 Continue drawing the rest of the polygons. Use the same radius for each one.

Centered Rectangle
Look for this button.

Ellipse
Look for this button.

Polygon
Look for this button.
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To make it 3D:

1 Select the pentagon.

2 From the Solid menu, click Extrude Planar Curve.

3 At the Extrusion distance <1> (Direction Cap=yes Bothsides Tapered) prompt, type 6 and press ENTER.
Extrude Planar Curve
Look for this button.
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4 Continue to extrude all of the polygons, the rectangles, and the ellipse as follows:
hexagon, Extrusion distance <5>
octagon, Extrusion distance <4>
triangle, Extrusion distance <3>
rectangle, Extrusion distance <1>
ellipse, Extrusion distance <2>
rounded rectangle, Extrusion distance <-6>.

5 Click in the perspective viewport.

6 From the Render menu, click Shade.
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Modeling Freeform Curves
The use of freeform curves allows more flexibility to create complex shapes.  If you need to control precision, you can
make construction lines that define your overall parameters.

Button Command Description

Curve Curve by control points creates a curve from specified control points. Control
points do not lie on the curve, but they determine its curvature.

Interpolated curve Interpolated curve creates a curve going through specified interpolate points.
These points lie on the curve and determine its curvature.

Sketch curve Sketch uses a brush-stroke effect to create a curve.  You simply hold your left
mouse button down and move your cursor to create a sketch curve.

Helix Creates a helix.  User can specify a radius, the number of turns, the length and
direction of the axis.

Spiral Creates a spiral.  User can specify two radii, the number of turns, the length and
direction of the axis.

Conic Creates a conic curve, which is part of an ellipse, parabola or hyperbola.

Option Description

Undo Type U, and press ENTER to remove one point at a time.

Close Type C, and press ENTER to close the curve to its start point.

Exercise 25—Practice With Curves
1 Open the Curve model.

In this exercise we will learn how to make a curve by control points, an interpolated curve, and a sketch curve to
compare the differences between the three methods.

2 In the Osnap dialog, check End Osnap, uncheck all others.  If you click with your right mouse on End it will uncheck
all but the one you click on.

3 Toggle Ortho and Snap off.
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To draw a Curve by Control Points:

1 From the Curve menu, click Freeform, then click Control Points.

2 At the Start of curve prompt, snap to the end point of the polyline at 0,0.

3 At the Next point (Undo) prompt, snap to the next End.

4 At the Next point, press Enter when done (Undo) prompt, continue to snap to the Ends on the polyline until you
get to the end.

5 At the Next point, press Enter when done (Close Undo) prompt, press ENTER.

A freeform curve is drawn. The control points were not on the curve except at the two ends.  Control points control
the curvature of the curve but usually do not fall on the curve.

To draw an Interpolated Curve:

1 From the Curve menu, click Freeform, then click Interpolate Points.

2 At the Start of curve (Tangent Knots=SqrtChord) prompt, snap to the End of the polyline at 0,0.

3 At the Next point on curve (Tangent Knots=SqrtChord Undo) prompt, snap to the next End.

4 At the Next point on curve , press Enter when done (Tangent Knots=SqrtChord Undo) prompt, continue to snap
to the next End until you get to the end.

Curve
Look for this button.

Interpolated Curve
Look for this button.
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5 At the Next point on curve , press Enter when done (Tangent Knots=SqrtChord Undo) prompt, press ENTER.

A freeform curve is created from specified interpolate points. These points lie on the curve and determine its
curvature.

To draw a sketch curve:

1 From the Curve menu, click Freeform, then click Sketch.

2 At the Click and drag to sketch (Closed), hold your left mouse button down and drag.

Points will appear as you are dragging, when you release your mouse the curve will replace the points.

To draw a curve with tangency and straight segments.

1 Toggle Snap on.

Curve
Look for this button.
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2 Try to follow the construction lines to generate two curves like the illustration below.  Use Curve by Control Points
(2) for one of the curves and Interpolated Curve (1) for the other curve.

Notice that the Interpolated Curve (1) has bulges at some points and doesn’t follow the construction line very well.

The Curve by Control Points (2) is much smoother.  Notice that if you put three points in a row ninety degrees to
each other it creates a straight segment.  Three points equidistant and in each direction and ninety degrees from each
other creates a smooth corner curve.
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Exercise 26—Practice With Curves
1 Start a new model. Save as Screwdriver.

2 In this exercise we will learn how to make a Curve by Control Points to create the following part.

3 Create Construction, Curve layers.  Make them different colors.

To create the construction lines:

1 Change to the Construction layer.

2 From the Curve menu, click Line, then click Polyline.

3 At the Start of polyline prompt, type 0,0, and press ENTER.

4 At the Next point (undo) prompt, type .69, and press ENTER. With ORTHO on pick a point above the first point.

5 Continue to use distant constraints and ortho mode to draw the construction line.

To create the Curve by Control Points:

1 Change to the Curve layer.

2 From the Curve menu, click Freeform, then click Control Points.

Polyline
Look for this button.

Curve
Look for this button.
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3 At the Start of curve prompt, snap to the end point of the polyline at 0,0.

4 At the Next point (Undo) prompt pick another point on the same segment of the construction line.

5 At the Next point - enter to finish (Undo) prompt pick a point in the direction of the next segment of the
construction line (horizontal).

6 Continue picking points to create the curve. Use the construction lines to help you create the curve.

7 When you get to the shank of the screwdriver, you can get the curve to continue as a straight line if you put three
points in a row (ortho) at the beginning. The next segment will be a straight line.

8 Save your model.

To make it 3D:

1 Toggle Snap and Ortho on.

2 From the Surface menu and click Revolve.

Revolve
Look for this button.
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3 At the Select curve to revolve prompt, select the curve.

4 At the Start of revolve axis prompt, choose the end of the curve along the center line.

5 At the End of revolve axis prompt, choose the other end of the curve along the center line.

6 The Revolve Options dialog box will appear. Click OK. Your model is now a three-dimensional model.

7 Click the mouse in the Perspective viewport to make it active.
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8 From the Render menu, click Shade.

Exercise 27— Drawing special curve forms: helix, spiral.
Start a new model. Save As Helix.

In this exercise we will learn how to make a helix, and a spiral.

To make a helix:

1 Toggle Snap and Ortho on.

2 From the Curve menu, click Helix.

3 At the Start of axis (Vertical AroundCurve) prompt, place your cursor in the Front viewport, type 0,0 and press
ENTER.

4 At the End of axis prompt, type 10 and press ENTER.

Shade
Look for this button.

Helix
Look for this button.
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5 At the End of axis prompt, pick directly above your first point.

This makes a vertical axis of length 10.

6 At the Radius and start point prompt, type 5 and press ENTER.

7 At the Start of helix prompt, move your cursor into the Top viewport and pick directly below your last point. This
establishes where the helix will begin.
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8 In the Helix / Spiral dialog, click OK.

A helix is created

 

To create a spiral:

1 From the Curve menu, click Spiral.

2 At the Start of axis (Flat Vertical AroundCurve) prompt, drag your cursor into the Front viewport , type -15,0 and
press ENTER.

3 At the End of axis prompt, type 10 and press ENTER.

Spiral
Look for this button.
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4 At the End of axis prompt, pick directly above your last point.

5 At the Radius and start point prompt, type 5 and press ENTER.

6 At the Start of spiral prompt, drag your cursor into the Top viewport and pick directly below your last point.

7 At the End radius prompt, type 1 and press ENTER.

8 In the Helix / Spiral dialog, click OK.

A spiral is created
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5 The Display

Changing the view of your model
When you add detail to your models, you’ll need to see different parts of your model with different magnifications. You
can use the view commands, the mouse, and the keyboard to change the view in a viewport.

Each view corresponds to the view through a camera lens. The invisible target of the camera is located in the middle of
the viewport.

Viewports

With Rhino you can open an unlimited number of viewports. Each viewport has its own projection, view, construction
plane, and grid. If a command is active, a viewport becomes active when you move the mouse over it. If a command is not
active, you must click in the viewport to activate it.

Parallel vs. Perspective Projection

Unlike other modelers, Rhino lets you work in both parallel and perspective views. To toggle a viewport between parallel
and perspective, right click on the title bar of the viewport, click Properties, then click parallel or perspective and OK.

Panning and Zooming
The simplest way to change the view is to hold down the SHIFT key and drag the mouse with right mouse button held
down. This pans the view. To zoom in and out, hold down the CTRL key and drag up and down.
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You can also use the keyboard to move around:

Key Action + CTRL

LEFT ARROW Rotate left Pan left

RIGHT ARROW Rotate right Pan right

UP ARROW Rotate up Pan up

DOWN ARROW Rotate down Pan down

PAGE UP Zoom in

PAGE DOWN Zoom out

You can change your view in the middle of a command to see precisely where you want to select an object or choose a
point.

Resetting your view
If you get lost, four view commands can help you get back to a starting place.

To undo and redo view changes:

♦ Click in a viewport, then press your HOME or END key on your keyboard to undo and redo view changes.

To set your view so you are looking straight down on the construction plane:

◆ From the View menu, click Set View, and then click Plan.

To bring all your objects into view:

◆ From the View menu, click Zoom, and then click Zoom Extents.

To bring all your objects into view in all viewports:

◆ From the View menu, click Zoom, then click Extents All.
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Exercise 28—Zooming

♦ Open the Camera model. We will use this to practice changing views. We will create views from six directions
including the oblique perspective view.

To change the viewport layout:

1 From the View menu, click Viewport Layout, then click 4 Viewports.

2 From the View menu, click Zoom, then click Extents All.

4 Viewports
Look for this button.
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To change the number of viewports:

1 Make the Top Viewport active.

2 From the View menu, click Viewport Layout, then click Split Vertical.

3 From the View menu, click Set View, then click Bottom.

4 From the View menu, click Zoom, then click Extents All.

5 Make the Front Viewport active.

6 From the View menu, click Viewport Layout, then click Split Vertical.

7 From the View menu, click Set View, then click Left.

8 From the View menu, click Zoom, then click Extents All.

9 Make the Right Viewport active.

10 From the View menu, click Viewport Layout, then click Split Vertical.

11 Click in the lower right viewport.

12 From the View menu, click Set View, then click Back.

13 From the View menu, click Zoom, then click Extents All.

Zoom Extents All
Look for this button.

Bottom View
Look for this button.

Left View
Look for this button.

Back View
Look for this button.
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14 Adjust the zoom in the Right and the Left viewport.

To change the shape of viewports:

1 Move your cursor to the edge of a viewport until you see the resizing  cursor, hold the left mouse button down
and drag the bar. If two viewports share the edge, both resize.

2 Move your cursor to the corner of a viewport until you see the resizing  cursor, hold the left mouse and drag the
intersection in any direction. If several viewports touch at that corner, all resize.
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To pan in a viewport:

♦ Hold down the SHIFT key and drag with the right mouse button to pan in any viewport.

To zoom in a viewport:

♦ Hold down the CTRL key and drag up or down with the right mouse button. Dragging down zooms out, dragging up
zooms in.

To rotate in a viewport:

1 Drag with right mouse button in a perspective viewport to rotate the view.

2 To rotate the view in a parallel viewport use the arrow keys. See “Using keys to change your view” on page 114.

To maximize and restore a viewport:

1 Double click on the title of the viewport to maximize it.

2 Double click on the title of the maximized viewport to restore it to its smaller size.

Right mouse options:

♦ Right mouse click on the title of a viewport.
A menu appears that allows you to maximize and restore a viewport, zoom a window or extents, change to the top,
front or right view, and close a viewport.
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6 Editing Objects

Once you create objects, you can move and edit them to produce complex and detailed variations.

Fillet
Fillet connects two lines, arcs, circles or curves extending or trimming them to intersect or to join with a circular arc.

Option Description

Radius Sets the fillet radius. A radius of 0 extends or trims the curves to a corner, but doesn’t create a fillet.

Join Yes joins the fillet to the curves.
No doesn’t join the fillet to the curves.

Exercise 29—Fillet

To start the practice model:

◆ Open the Fillet model.

To fillet lines at a zero radius:

1 From the Curve menu, click Fillet.

2 At the Select first curve to fillet (Radius=0 Join=No) prompt, type 0 and press ENTER to change the radius. This
radius will remain the default until it is changed.

Fillet
Look for this button.
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3 At the Select first curve to fillet (Radius=0 Join=No) prompt, select an outer vertical line.

4 At the Select second curve to fillet (Radius=0 Join=No) prompt, select an adjacent horizontal line.

The ends of the lines are trimmed to a corner.

5 Press ENTER to repeat the command.

6 Fillet the other corners, as shown.

Remember to pick on the part
of the line that you want to
keep.
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To fillet lines using an arc:

1 From the Curve menu, click Fillet.

2 At the Select first curve to fillet (Radius=0 Join=No) prompt, type 2 and press ENTER to change the radius. This
radius will remain the default until it is changed.

3 At the Select first curve to fillet (Radius=2 Join=No) prompt, select an outer vertical line.

4 At the Select second curve to fillet (Radius=2 Join=No) prompt, select an adjacent horizontal line.

The ends of the lines are trimmed to a radius.

5 Press ENTER to repeat the command.

6 Fillet the other corners, as shown.

7 Press ENTER to repeat the command.

8 At the Select first curve to fillet (Radius=2 Join=No) prompt, type 1 and press ENTER. This radius will be used for
the smaller object.

9 At the Select first curve to fillet (Radius=1 Join=No) prompt, select an outer vertical line.

10 At the Select second curve to fillet (Radius=1 Join=No) prompt, select an adjacent horizontal line.

Fillet
Look for this button.
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11 Fillet the other corners, as shown.

To fillet circles:

1 From the Curve menu, click Fillet.

2 At the Select first curve to fillet (Radius=1 Join=No) prompt, type 3 and press ENTER. This radius will be used for
the smaller object.

3 At the Select first curve to fillet (Radius=3 Join=No) prompt, select right edge of the circle.

4 At the Select second curve to fillet (Radius=3 Join=No) prompt, select right edged of another circle.

Fillet
Look for this button.
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5 Repeat the command for the other side of  the circles.

To fillet and join objects:

1 From the Curve menu, click Fillet.

2 At the Select first curve to fillet (Radius=3 Join=No) prompt, type J and press ENTER. This radius will be used for
the smaller object.

3 At the Select first curve to fillet (Radius=3 Join=Yes) prompt, select one of the arcs in the middle of the screen.

4 At the Select second curve to fillet (Radius=3 Join=Yes) prompt, select the other arc in the middle of the screen.

Fillet
Look for this button.
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5 Repeat this procedure for the arc and the line at the bottom left.

To join the filleted objects:

1 Select the objects at the top with a window.

2 From the Edit menu, click Join.

The objects are joined together.  Pre-selected curves join only if they touch..

To make 3D with a lofted surface:

1 Change to the Perspective viewport

2 Change to the Surfaces layer.

3 Select the two squares in the upper left part of the Top viewport.

Join
Look for this button.

The lines in this model  are at
two different elevations. We
are going to connect the lines
at different elevations with a
surface.
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4 From the Surface menu, click Loft.

The two squares show a seam direction arrow. They point the same direction.

5 At the Select seam point to adjust, press ENTER when done (FlipDirection Automatic Natural) prompt, press
ENTER.

6 In the Loft Options dialog, change the Style to Straight Sections, then click OK.

A surface is generated between the two squares.

 

Loft
Look for this button.
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7 Repeat the procedure for the rounded squares until the Loft Options dialog appears.

8 In the Loft Options dialog, change the Style to Normal, then click OK.

 
9 Save your model.

10 Click in the Perspective viewport.

11 From the Render menu, click Shade.

Shade
Look for this button.
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Chamfer
Chamfer connects two curves by extending or trimming them to intersect or to join with a beveled line. Chamfer works
on convergent or intersecting lines.

Option Description

Distances The first chamfer distance specifies the distance from the chamfer end on the first curve to the point
where the two curves would intersect. The second chamfer distance specifies the distance of the
chamfer end on the second curve to the intersection point.

A chamfer distance of 0 trims or extends that curve to the intersection point. If the chamfer distance is
non-zero, a chamfer line is created if needed to extend the other curve to the intersection. If you enter 0
for both distances, the curves are trimmed or extended to their intersection, but no chamfer is created.

Exercise 30—Chamfer

To start the practice model:

◆ Open the Chamfer model.

To chamfer lines:

1 From the Curve menu, click Chamfer.

2 To set a distance, at the Select first curve to chamfer (Distances=0,0) prompt, type 1, and press ENTER.

3 At the Second chamfer distance<1> prompt, press ENTER.

The default second chamfer distance always matches the first chamfer distance. This creates chamfers that begin and
end the same distance from the point where the two lines would intersect.

4 At the Select First Curve to chamfer (Distances=1,1) prompt, choose one of the inner vertical lines.

Chamfer
Look for this button.
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5 At the Select Second Curve to chamfer (Distances=1,1) prompt, choose an adjacent horizontal line.

 

6 Continue creating chamfers on all of the corners as shown.

7 Press ENTER to repeat the command.

8 At the Select First Curve to chamfer (Distances=1,1) prompt, type 3, and press ENTER.

9 At the Second chamfer distance<3> prompt, type 2, and press ENTER.

10 At the Select First Curve to chamfer (Distances=3,2) prompt, choose one of the outer horizontal lines.

11 At the Select Second Curve to chamfer (Distances=3,2) prompt, choose an adjacent vertical line.
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12 Continue creating chamfers on all of the corners as shown.

To join the chamfered objects:

1 From the Edit menu, click Select, then click All, then click Curves.

2 From the Edit menu, click Join.

The curves have been joined together.

To make it 3D:

1 Change to the Surfaces layer.

2 From the Edit menu, click Select, then click All, then click Curves.

3 From the Surface menu, click Loft.

4 At the Select seam point to adjust, press ENTER when done (FlipDirection Automatic Natural) prompt, press
ENTER.

5 In the Loft Options dialog, change the Style to Straight Sections, then click OK.

A surface is generated between the two squares.

 

6 Save your model.

7 Click in the Perspective viewport.

Join
Look for this button.

Loft
Look for this button.
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8 From the Render menu, click Shade.

Shade
Look for this button.
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Exercise 31—Practice with Fillet and Chamfer

1 Start a new model. Save as Filletex.
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2 Draw the outline of the part with Line Segments, Circles, and Arcs.

 
3 Use Fillet and Chamfer to edit the drawing as shown.

To make it 3D:

1 From the Edit menu, click Select, then click All, then click Curves.

2 From the Solid menu, click Extrude Planar Curve.

Extrude Planar Curve
Look for this button.
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3 At the Extrusion distance ( Direction Cap=Yes BothSides Tapered ) prompt, type .5 and press ENTER.

 
4 Click in the Perspective viewport.

5 From the Render menu, click Shade.

Shade
Look for this button.
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Move
Use Move to move objects without changing orientation or size.

Option Description

Vertical Moves the selected objects vertical to the current construction plane.

Exercise 32—Move
1 Open the Move model.

2 Turn off both Ortho and Snap so you can move objects freely.

3 Turn Cen object snap on.

To move using object snaps for placement:

1 Select the small circle at the bottom left side of the top view.

2 From the Transform menu, click Move.

3 At the Point to move from (Vertical) prompt, snap to the center of the small circle.
Move
Look for this button.
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4 At the Point to move to prompt, snap to the center of the arc at the lower left of the object.

 

To move using absolute coordinates:

1 From the Edit menu, click Select, then click All, then click Curves.

2 From the Transform menu, click Move.

3 At the Point to move from (Vertical) prompt, snap to the end of the line at the lower part of the object.

4 At the Point to move to prompt, type 0,0 and press ENTER.

The end of the line is exactly at point 0,0 in the top view.

  

Move
Look for this button.
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To move using relative coordinates:

1 Select the large slotted circle in the middle of the object. We will move the slotted circle relative to the part.

2 From the Transform menu, click Move.

3 At the Point to move from (Vertical) prompt, pick any point in the top view.

It is usually better if you pick near the object you are going to move.

4 At the Point to move to prompt, type r0,-.25 and press ENTER.

The circle is moved down .25 units.

 

Copy
Copy duplicates selected objects and places them in a new location. The command repeats to create more than one copy
in the same command sequence.

Option Description

Vertical Copies the selected objects vertical to the current construction plane.

InPlace Duplicates the object at the current location.

Move
Look for this button.
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Exercise 33—Copy

To copy using object snaps for placement:

1 Select the small circle at the lower left of the object.

2 From the Transform menu, click Copy.

3 At the Point to copy from (Vertical InPlace) prompt, snap to the center of the small circle.

4 At the Point to copy to prompt, snap to the center of the arc at the upper left of the object.

 
5 Press ENTER to end the command.

To make multiple copies:

1 Select the small circle at the lower left of the object.

2 From the Transform menu, click Copy.

3 At the Point to copy from (Vertical InPlace) prompt, snap to the center of the small circle.

Copy
Look for this button.

Copy
Look for this button.
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4 At the Point to copy to prompt, begin picking points on the screen.

Each time you pick a circle will be copied to that location.

5 Press ENTER to end the command.

Undo and Redo
If you make a mistake or don’t like the results of a command, use Undo. If you decide that you did like those results, after
undoing them, use Redo command. Redo restores the last thing undone.

Rhino
Button

Mouse
Button Command Description

Left-click or
CTRL+Z

Undo Cancels the effects of the last command.

Right-click
or CTRL+Y

Redo Restores the effects of undo.

The number of undos kept in memory can be set in Rhino Options under the General tab,

If a command has an Undo option, type U to enter it. At the command prompt, type Undo.

You cannot use Undo after you exit a modeling session or open a different model.
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Rotate
Use Rotate to move objects in a circular motion around a base point. For precise rotation, enter a number of degrees to
rotate. Positive numbers rotate counterclockwise, negative numbers rotate clockwise.

Option Description

Copy Duplicates the object as it is rotated

Exercise 34—Rotate
1 Select the large slotted circle in the middle of the object.

2 From the Transform menu, click Rotate.

3 At the Center of rotation (Copy) prompt, snap to the center of the slotted circle. Rotate
Look for this button.



E D I T I N G  O B J E C T S

N o t e s :

Robert McNeel & Associates ❑ 138

4 At the Angle or first reference point (Copy) prompt, type -28 and press ENTER.

The slotted circle rotated clockwise 28 degrees.

Mirror
Mirror creates a copy of the objects flipped over a specified axis on the construction plane.

Exercise 35—Mirror
1 From the Edit menu, click Select, then click Invert.

This selects everything but the object that was previously selected.  All of the curves except the slotted circle should
be highlighted.

2 From the Transform menu, click Mirror.

3 At the Start of mirror plane prompt, type 0,0 or snap to the End of the line at the lower right of the part.

Mirror
Look for this button.
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4 At the End of mirror plane prompt, toggle Ortho on and pick directly above the previous point.

 

Join
Join unites curves that meet at a common end, making a single curve. Join can unite curves that don’t touch, if you select
them after the command has started. As you pick non-touching curves a dialog asks if you want to fill the gap.

Exercise 36—Join
1 From the Edit menu, click Select, then click All, then click Curves.

2 From the Edit menu, click Join.

Join
Look for this button.
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Scale
Scale changes the size of existing objects without changing their shape. This command will scale three-dimensional
objects along all three axes.  There are also 2-dimensional, one-dimensional, and non-uniform scale command.

Option Description

Copy Preserves the object as it creates a new scaled one.

Scale factor Inputs a value for scale factor. Less than one reduces the size, more than one increases the size.

Reference
point

The first reference point shows the current scale factor. The second reference point shows the new scale
factor.

Exercise 37—Scale
1 From the Edit menu, click Select, then click All, then click Curves.

2 From the Transform menu, click Scale, then click Scale 2-D.

3 At the Origin point (Copy) prompt, type 0,0 and press ENTER.

4 At the Scale factor or first reference point (Copy) prompt, type .75 and press ENTER.

The whole part has been scaled to seventy-five percent of its original size.

Scale
Look for this button.
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To scale using the reference point option:

1 From the Edit menu, click Select, then click All, then click Curves.

2 From the Transform menu, click Scale, then click Scale 2-D.

3 At the Origin point (Copy) prompt, snap to the center of the slotted circle.

4 At the Scale factor or first reference point (Copy) prompt, snap to the quadrant of the slotted circle.

The radius of the slotted circle is the reference for the scale factor.

 
5 At the Second reference point (Copy) prompt, type 1.375 and press ENTER.

The slotted circle now has a radius of 1.375.  Everything else was scaled proportionally.

Scale
Look for this button.
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To make it 3D:

1 From the Edit menu, click Select, then click All, then click Curves.

2 From the Solid menu, click Extrude Planar Curve.

3 At the Extrusion distance ( Direction Cap=Yes BothSides Tapered ) prompt, type 1 and press ENTER.

 
4 Click in the Perspective viewport.

5 From the Render menu, click Shade.

Extrude Planar Curve
Look for this button.

Shade
Look for this button.
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Array
Use the Array commands to make multiple copies of selected objects. Array Rectangular makes rows and columns of
objects. Array Polar copies objects in a circle around a center point

Exercise 38—Array

To create a rectangular array:

1 Open the T-Flange model.

 2 Select the cylinder that is visible in the Top viewport.

3 From the Transform menu, click Array, then click Rectangular.

4 At the Number in x direction <1> prompt, type 2 and press ENTER.

5 At the Number in y direction <1> prompt, type 2 and press ENTER.

6 At the Number in z direction <1> prompt, type 1 and press ENTER.

7 At the Unit cell or x spacing prompt, type 4 and press ENTER.

Array Rectangular
Look for this button.
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8 At the Y spacing prompt, type 1.5 and press ENTER.

The cylinders are arrayed on the base of the flange.

 

To create a 3D array:

1 Select the cylinder that is visible in the Front viewport.

When entering distances in the Front viewport the construction plane Y direction is up and the Z direction is toward
you.  The icon that is visible is the World Coordinate Icon.



E D I T I N G  O B J E C T S

N o t e s :

Robert McNeel & Associates ❑ 145

2 From the Transform menu, click Array, then click Rectangular.

3 At the Number in x direction <2> prompt, type 2 and press ENTER.

4 At the Number in y direction <2> prompt, type 2 and press ENTER.

5 At the Number in z direction <1> prompt, type 2 and press ENTER.

6 At the Unit cell or x spacing prompt, type 2 and press ENTER.

7 At the Y spacing prompt, type -2 and press ENTER.

8 At the Z spacing prompt, type -4.5 and press ENTER.

The cylinders are arrayed on both flanges.

 

To remove the holes from the flange:

1 Save your model.

2 From the Solid menu, click Difference.

3 At the Select surface or polysurface prompt, pick the flange.

Array Rectangular
Look for this button.

The reason that negative
numbers are used for the y
and z spacing is because the
hole is arrayed in the negative
direction on each axis.

Always save your model
before doing any boolean
operation.

Boolean Difference
Look for this button.
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4 At the Select surface or polysurface to subtract prompt, pick one of the holes.

The hole is subtracted from the flange.

 
5 Repeat this process for each of the holes.
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6 From the Render menu, click Shade All Viewports.

Shade All Viewports
Look for this button.
Right click this button.
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To create a polar array:

1 Open the Wheel model.

2 Select the cylinder and the rib in the Top viewport.

3 From the Transform menu, click Array, then click Polar.

4 At the Center of polar array prompt, snap to the center of the wheel.

5 At the Number of elements<1> prompt, type 3 and press ENTER.

6 At the Angle to fill<360> prompt, press ENTER.

The cylinders and ribs are arrayed in a circular pattern around the center of the wheel.

Array Polar
Look for this button.

You must include the original
and the copies as the number
in the array.
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To remove the holes from the wheel:

1 Save your model.

2 From the Solid menu, click Difference.

3 At the Select surface or polysurface prompt, pick the wheel.

4 At the Select surface or polysurface to subtract prompt, pick one of the holes.

The hole is subtracted from the flange.

5 Repeat this process for each of the holes.

To add the ribs to the wheel:

1 From the Solid menu, click Union.

2 At the Select surface or polysurface prompt, pick the wheel.

3 At the Select surface or polysurface to union prompt, pick one of the ribs. The rib is added to the wheel.

4 Repeat this process for each of the ribs.

Boolean Difference
Look for this button.

Boolean Union
Look for this button.
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5 From the Render menu, click Shade.

Shade
Look for this button.
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Offset
Offset creates an object parallel or concentric to another object. Use Offset to create specialized copies, such as parallel
lines, concentric circles, and concentric arcs, through specified points or at pre-set distances.

Exercise 39—Offset
Start a new model. Save as Shaft Base.

To create the rounded rectangle:

1 From the Curve menu, click Rectangle, then click Center, Corner.

2 At the Center of rectangle ( Rounded ) prompt, type R and press ENTER.

3 At the Center of rectangle prompt, move you cursor into the Top viewport, type 0,0 and press ENTER.
Rectangle Centered
Look for this button.
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4 At the Corner or length prompt, type 6 and press ENTER.

5 At the Width prompt, type 2 and press ENTER.

6 At the Point for rounded corner to pass through (Corner=Arc) prompt, type 1 and press ENTER.

 

To create offset rounded rectangles:

1 From the Curve menu, click Offset.

2 At the Select curve to offset (Distance=1 Corner=sharp ThroughPoint) prompt, type .25 and press ENTER.

3 At the Select curve to offset ( Distance=.25 Corner=sharp ThroughPoint ) prompt, pick the rounded rectangle.
Offset
Look for this button.
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4 At the Side to offset ( Distance=.25 Corner=sharp ThroughPoint ) prompt, pick outside the rounded rectangle. A
larger rounded rectangle will be created.

5 Continue to offset the remainder of the curves.  Make sure to change the offset distance for each curve.

To draw the holes:

1 Turn on End Osnap.

2 From the Curve menu, click Circle, then click Center, Radius.

3 At the Center of circle (Vertical AroundCurve) prompt, snap to the end point at the bottom right corner of the center
line.

Circle
Look for this button.
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4 At the Radius <1> (Diameter) prompt, type D and press ENTER.

5 At the Diameter <2> (Radius) prompt, type .63 and press ENTER.

6 From the Curve menu, click Circle, then click Center, Radius.

7 At the Center of circle (Vertical AroundCurve) prompt, snap to the same End while holding your CTRL key down to
activate elevator mode, then type .375 and press ENTER.

8 At the Diameter <0.63> (Radius) prompt, type 1 and press ENTER.

This moves the center of the circle off the construction plane.

 

Circle
Look for this button.
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To copy the circles:

1 Select the circles you just created.

2 Turn on End and Quad osnaps.

3 From the Transform menu, click Copy.

4 At the Point to copy from (Vertical InPlace) prompt, pick the end point where the circles are located.

5 At the Point to copy to prompt, pick the End point and Quadrant points for the location of the circles as shown in the
drawing.

6 Create the smaller holes at both ends of the shaft base.

Copy
Look for this button.
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To make it 3D:

1 Select the smallest rounded rectangle.

2 From the Transform menu, click Move.

3 At the Point to move from (Vertical) prompt, move your cursor into the Front viewport and pick a point.

4 At the Point to move to prompt, type R0,.75 and press ENTER.

5 Select the center line curve and delete it.

6 Select the largest rounded rectangle.

7 From the Solid menu, click Extrude Planar Curve.

8 At the Extrusion distance ( Direction Cap=Yes BothSides Tapered ) prompt, type .5 and press ENTER.

9 Select the smallest rounded rectangle.

10 From the Solid menu, click Extrude Planar Curve.

11 At the Extrusion distance ( Direction Cap=Yes BothSides Tapered ) prompt, type .75 and press ENTER.

12 Select the largest rounded rectangle.

13 From the Solid menu, click Extrude Planar Curve.

14 At the Extrusion distance ( Direction Cap=Yes BothSides Tapered ) prompt, type 1.25 and press ENTER.

To add the parts together:

1 Save your model.

2 From the Solid menu, click Union.

3 At the Select surface or polysurface prompt, pick the base.

Circle
Look for this button.

Extrude Planar Curve
Look for this button.

Boolean Union
Look for this button.
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4 At the Select surface or polysurface to union prompt, pick the boss.

 

To subtract the inside of the boss from the base:

1 Save your model.

2 From the Solid menu, click Difference.

3 At the Select surface or polysurface prompt, pick the base.

4 At the Select surface or polysurface to subtract prompt, pick  the inside of the part that sticks up.

 

Boolean Difference
Look for this button.
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5 Repeat this process for the holes.  First extrude the holes and then subtract them from the base.

 

Trim
Trim cuts and deletes portions of an object to make it end precisely at its intersection with another object.

Exercise 40—Trim
1 Open the Trim-Split model.

2 From the View menu, click Zoom, then click Window. Zoom Window
Look for this button.
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3 Make a window around the grid in the lower left corner of the Top viewport.

4 From the Edit menu, click Trim.

5 At the Select cutting edge (Options) prompt, select the two outside vertical lines in the grid.

6 At the Select cutting edge (Options) prompt, press ENTER.

7 At the Select object to trim (Options) prompt, select each of the horizontal lines at their left and right ends. The
lines will be trimmed to the cutting edges.

8 At the Select object to trim (Options) prompt, press ENTER to end the command.

9 From the View menu, click Zoom, then click Extents All.

Trim
Look for this button.

Zoom Extents All
Look for this button.
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10 From the Edit menu, click Trim.

11 At the Select cutting edge (Options) prompt, select the surface that intersects the sphere in the Perspective
viewport.

12 At the Select cutting edge (Options) prompt, press ENTER.

13 At the Select object to trim (Options) prompt, select the right side of the sphere. The sphere is trimmed at the edge
of the surface.

 
14 At the Choose object to trim prompt, press ENTER to end the command.

Split
Splits one object with another, or a curve at a point. Split breaks the object where it intersects of the cutting object, but
does not delete anything.

Exercise 41—Split
1 From the View menu, click Zoom, then click Window.

Trim
Look for this button.
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2 Make a window around the closed curve in the lower right corner of the Top viewport.

3 From the Edit menu, click Split.

4 At the Select object to split prompt, choose the closed curve.

5 At the Select cutting objects (Point) prompt, choose the lines. Split
Look for this button.
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4 At the Select cutting objects (Point) prompt, press ENTER.

The curve is separated into four pieces precisely where the lines intersect it.

6 From the View menu, click Zoom, then click Extents All.

7 From the Edit menu, click Split.

8 At the Select object to split prompt, choose the second sphere.

9 At the Select cutting objects (Point) prompt, choose the surface that intersects the sphere.

The Sphere is separated into two pieces precisely where the surface intersects it.

 

Split
Look for this button.
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Extend
Extend lengthens an object to make it end precisely at its intersection with another object or you can lengthen an object
when there is no intersection.

Exercise 42—Extend
1 Open the Extend model

2 From the Curve menu, click Extend, then click Extend Curve.

3 At the Select boundary objects prompt, pick the line at the left.

4 At the Select boundary objects prompt, press ENTER.
Extend
Look for this button.



E D I T I N G  O B J E C T S

N o t e s :

Robert McNeel & Associates ❑ 164

5 At the Select object to extend (Type=Line) prompt, choose the left ends of the three curves.

The line and curves will be extended to touch the boundary edge on the left.

 
6 At the Select object to extend (Type=Line) prompt, press ENTER to end the command.

To extend with some of the other options:

1 From the Curve menu, click Extend, then click Extend Curve.

2 At the Select boundary objects prompt, pick the curve at the right.

3 At the Select boundary objects prompt, press ENTER.

4 At the Select object to extend (Type=Line) prompt, pick the right end of the line.

The line is extended straight.

5 At the Select object to extend (Type=Line) prompt, type A and press ENTER.

6 At the Select object to extend (Type=Arc) prompt, pick the right end of the curve.

The curve continues with a tangent arc to the boundary edge.

7 At the Select object to extend (Type=Arc) prompt, type S and press enter.

Extend
Look for this button.
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8 At the Select object to extend (Type=Smooth) prompt, pick the right end of the arc.

The arc continues with a tangent curve.

To extend to a surface:

1 From the Curve menu, click Extend, then click Extend Curve.

2 At the Select boundary objects prompt, choose the cylinder on the left.

3 At the Select boundary edges prompt, choose the surface on the right.

4 At the Select boundary edges prompt, press ENTER.

5 At the Select object to extend (Type=Smooth) prompt, type L and press ENTER.

Extend
Look for this button.
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6 At the Select object to extend (Type=Line) prompt, choose both ends of the line and the curve.

The curves will extend to the surface of the sphere and to the surface.

To extend a curve without boundary edges:

1 From the Curve menu, click Extend, then click By Line.

2 At the Select curve to extend prompt, choose near the curve in the upper right side.

3 At the End of line or length prompt, pick a point.

The curve is extended as a tangent line to the point you picked.

 

Extend by Line
Look for this button.
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4 From the Curve menu, click Extend, then click By Arc.

5 At the Select curve to extend prompt, select near the upper end of the line on the left.

6 At the Radius of arc prompt, pick a point to set a radius, or type a value for the radius.

7 At the End point or angle prompt, pick an end for the arc, or type an included angle for the arc.

 

Extend by Arc
Look for this button.
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Exercise 43—Practice
1 Start a new model. Save as Gasket1

2 Use Circle, Arc, Trim, Fillet, and Join to create the part shown.

3 Use Extrude to create the 3d part. The extrusion thickness is .125.
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Exercise 44—Practice
1 Start a new model. Save as Gasket2.

2 Use Circle, Arc, Line, Trim, Offset, Fillet, Copy, and Mirror to draw the part shown.

3 Use Extrude to create the 3d part. The extrusion thickness is .125.
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Exercise 45—Practice
1 Start a new model. Save as Cam.

2 Use Circle, Arc, Line, Trim, Join, and Array to draw the part shown.

3 Use Extrude to create the 3d part. The extrusion thickness is .5.
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Exercise 46—Practice
1 Start a new model. Save as Link.

2 Use Line, Arc, Trim, Offset, Join, Fillet and Circle to draw the part shown.

3 Use Extrude and Subtract to create the 3d part. The extrusion thickness is .5.
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7 Point Editing

Point editing
You can display the control points or the edit points of an object so that you can adjust the shape of an object rather than
manipulating the whole object at once. That is called “point editing.”

You can use point editing on meshes, curves, and surfaces, but not on polysurfaces or solids.

NURBS Curves

Rhino's curves are represented internally by Non-Uniform Rational B-Splines (NURBS). The shape of a NURBS curve is
determined by three things:

• A list of points called "control points"

• Degree

• A list of numbers called "knots"

If you change any of these things, it changes the shape of the curve.

Exercise 47—Control Point Editing

In this exercise we are going to experiment with moving control points.  Understanding how curves and lines react when
control points are moved is very important to understanding NURBS modeling.
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1 Start a new model. Save as Points.

2 Create Polyline, Curve and Surface layers.

3 Turn Ortho and Snap on.

4 Change to the Polyline layer.

5 In the Top viewport draw a polyline 6 units long with a vertex at each unit along the line.

The points disappear when the command terminates.  The illustration below shows the line with the points on.

6 Change to the Curve layer.

7 In the Top viewport draw a curve by control points 6 units long. Make sure that you pick at each snap point, so that
the curve will have a control point at each unit.

Polyline
Look for this button.

Curve
Look for this button.
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8 Use mirror to create two more lines, one curve and one polyline.  Mirror the curves starting at 0,0 in the Top
viewport. Toggle ortho on to pick the second point. Make sure the polylines are on the top and the bottom.

9 From the Edit menu, click Select, then click All, then click Curves.

10 From the Edit menu, click Point Editing, then click Control Points On.

Mirror
Look for this button.

Select All Curves
Look for this button.

PtOn
Look for this button.
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11 In the Top view, click and drag some points on the polylines. Notice that the line has a pointed edge at each control
point and that the control points are exactly on the line.  When a curve or polyline bends at a point like this it is called
a kink.  If you create a surface from a line that has a kink it will have a seam at the kink.

12 Push ESC twice to turn off the control points.

13 From the Edit menu, click Layers, then click Edit.

14 Lock the Polyline layer.

15 Select one of the curves and turn the control points on.
Layer
Look for this button.
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16 Next, we will elevate the points off the Top Cplane. In the Front viewport click and drag some of the control points.

If you the Choose One Object dialog appears make sure it displays Curve point and pick OK.

Note that as you move the point, the curve deforms at the point, but stays the same everywhere else.
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17 Repeat this process for the second curve.  Change the location of some of the points, so that it looks different from
the previous curve.

To change the polylines into curves without kinks:

1 From the Edit menu, click Layers, then click Edit.

2 Turn on the Polyline layer.

3 Select both polylines in the Top viewport.

4 From the Curve menu, click Edit Tools, then click Rebuild.

The Rebuild Curve dialog will appear.

Layer
Look for this button.

Rebuild
Look for this button.
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5 In the Rebuild Curve dialog change the point count to 9 and the degree to 3 and press Preview.

A degree 3 curve cannot have kinks.

6 Change the point count and degree, and press Preview.  Notice how the curve will approximate the geometry at
different degrees and point counts.

7 When you are satisfied with the preview, click OK.

To loft a surface over the curves:

1 Change to the Surfaces layer.

2 Select all of the curves.

3 From the Surface menu, click Loft.

4 In the Loft Options dialog, click OK. Loft
Look for this button.
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A surface appears over the curves.

5 From the Render menu, click Shade.

6 Turn off the Curve and Polyline layers.

7 Select the lofted surface.

8 From the Edit menu, click Point Editing, then click Control Points On.

Shade
Look for this button.

Points On
Look for this button.
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9 Move some of the control points of the surface to see what effect it has on a surface.

10 From the Render menu, click Shade All Viewports.

Shade All Viewports
Look for this button.
Right click this button.
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A few facts about control points, edit points and knots

• Knots are parameters (that is, numbers, not points). You can evaluate a NURBS curve or surface at a knot and get a
“knot point.”

• Control points do not have to be on the curve.

• Edit points and knot points are always on the curve.

• A curve has the same number of control points as edit points.

• Generally, there are more control points than knot points.

• On a polyline, control points = edit points = knot points.

• If a curve is not a polyline, then control points are different from edit points and knot points.

• Rhino lets you edit curves and surfaces by moving control points and edit points.

• Rhino lets you add and remove knots, but you cannot explicitly move knot points.
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Exercise 48—Practice with Freeform Curves and Control Point editing
1 Start a new model. Save as Glass.

  
2 Use Rectangle and Curve to draw the part shown in the Front viewport.
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3 Start by drawing construction lines to help you create an accurate curve.

 
4 Adjust control points if necessary to achieve the design you want for your glass.

To make it 3D:

1 From the Surface menu, click Revolve.

2 At the Select curve to revolve prompt, select the curve you created.

3 At the Start of revolve axis prompt, pick one end of the curve.
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4 At the End of revolve axis prompt, pick the other end of the curve.

5 In the Revolve Options dialog, click Deformable, then click OK.

 
This will make it so that the glass will have control points that can be adjusted.
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6 From the Render menu, click Shade.

7 Save your model.

8 Experiment with adjusting the control points to see what happens.



Part Three:
3D Modeling and Editing
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8 Creating Deformable Shapes

Freeform Modeling
When building models in Rhino, you should first determine which methods should be used for each part of the project.
There are two basic ways to model in Rhino—freeform and accurate. Some models require more attention to exact
dimensions because they might have to be manufactured or parts may have to fit together. Sometimes it is the shape of
the object, not the accuracy that is important. These techniques can be merged together to create accurate, freeform
shapes. This tutorial focuses only on the freeform, squishy aspect. The exact size and placement of the objects is not
critical. The overall form is the main objective.

This exercise shows

• simple surface creation

• surface rebuilding

• control point editing

• curve creation (drawing, projecting)

• splitting surfaces with curves and surfaces

• blending between two surfaces

• lighting and rendering

When you model the rubber ducky, you will use similar modeling techniques for the head and the body. In this exercise
you will create spheres that will be deformed to make the shapes.
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If you need to know more about control points and surfaces search, the Rhino Help index for Control points.

 Exercise 49—Creating a rubber ducky.
1 Start a new model. Save as Ducky.

2 You can use layers to separate your parts, but for this model, it isn’t necessary.

 For more information about layers, search the Rhino Help index for layer.

Create the Body and Head Shapes

The body and head of the ducky are created by modifying two spheres. The size and placement of the spheres doesn’t
need to be exact.
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To create the basic shapes:

1 From the Solid menu, click Sphere, then click Center, Radius.

2 At the Center of sphere prompt, pick a point in the Front viewport.

3 At the Radius (Diameter) prompt, pick another point in the same viewport to create a sphere.

4 Repeat this procedure for the second sphere.

 
5 Select the large sphere.

6 From the Edit menu, click Point Editing, then click Control Points On.

7 Select a control point and drag it.

8 Click in the Perspective view.

Sphere
Look for this button.

Control Points On
Look for this button.
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9 From the Render menu, click Shade.

Notice that you have sharp edges in the sphere. The spheres you just created do not lend themselves well to
deformation. To make them deformable, you have to add control points and the ability to deform smoothly. Rhino has
a command to do this.

 
10 Press ENTER or ESC to exit Shade mode. Press ESC again to turn off control points.

11 From the Edit menu, click Undo.

To make the spheres deformable:

1 Select both spheres.

2 From the Surface menu, click Edit Tools, then click Rebuild.

Shade
Look for this button.

Undo
Look for this button.

Rebuild Surface
Look for this button.
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3 In the Rebuild Surface dialog, change the Point Count to 8 for both U and V.

Change the Degree to 3 for both U and V

Check Delete Input, clear Current Layer, and click OK.

The spheres are now deformable. Having more control points allows more control over smaller parts of the surface. A
degree-three surface will have a smoother shape when deformed.

To modify the body shape:

1 Select the large sphere.

2 From the Edit menu, click Point Editing, then click Control Points On.

Control Points On
Look for this button.
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3 In the Front view select the control points near the bottom of the sphere.

Window select by dragging a box around the control points.

4 From the Transform menu, select Set Points.

5 Make the Set Points dialog look like this, and click OK.

 

Set Points
Look for this button.
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6 Drag the selected control points up.

This will align all of the selected control points to the same z value (vertical in Front viewport), flattening the
surface.

 
7 Adjust the control points at the top of the body using the same technique.
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8 Window select the control points at the upper left edge of the body, and drag them up to form the tail.

Notice in the Top view that two control points are selected, though in the Front view, it looks like only one is
selected. This is because the second control point is directly behind the one you can see in the Front view.

9 Window select the control points at the front of the body, and drag them to the right to bulge out the chest.
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10 Window select the control points at the upper right, and drag them up and to the right.

11 You can adjust the control points further until you get the shape you want.

12 Save your model.

To shade the model:

1 Click in the Perspective viewport.

2 From the Render menu, click Shade.

Shade
Look for this button.
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3 Press ENTER or ESC to exit Shade mode.

4 Press ESC to turn off control points. The first ESC cancels any commands that are active. The next deselects all
selected objects. The next ESC turns off control points.

To create the head:

1 Select the small sphere.

2 From the Edit menu, click Point Editing, then click Control Points On.

3 Select the control points on the right side and drag them to begin forming the bill. Control Points On
Look for this button.

Remember to use a window to
select the control points. There
may be multiple control points
in the same location in this
view.
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4 Select the control points at the top right side and drag down to continue forming the bill.

5 Continue selecting control points and deforming the head until you make it look like a bill as shown below.
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6 From the Render menu, click Shade.

7 Press ESC to turn control points off.

Separate the Bill From the Head

For the final rendering, the bill must be a different color from the body. To do this, they must be separate surfaces. You
can split a single surface into multiple surfaces many ways. The following technique is just one.

To make the head and bill two separate surfaces, split it with a curve. It is easiest to draw a curve in one view and project
it to the surface to create a 3D curve.

Shade
Look for this button.
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To create the curve for the bill:

♦ In the Front view create a curve that looks like the illustration below.

To Project the curve onto the surface of the head to create the shape for the bill.

1 From the Curve menu, click From Objects, then click Project

2 At the Select curves to project prompt, in the Front view, select the curve (1).

3 At the Select curves to project prompt, press ENTER.

4 At the Select surfaces or polysurfaces to project onto prompt, select the head you created (2).

Project
Look for this button.
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5 At the Select surfaces or polysurfaces to project onto prompt, press ENTER.

The curve is projected onto the head.

 
6 Delete the original curve.

To split a surface with a curve:

1 From the Edit menu, click Split.

2 At the Select object to split prompt, select the head (1).

3 At the Select cutting objects prompt, select the curve you just created (2).

4 At the Select cutting objects prompt, press ENTER.

Split
Look for this button.
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 The bill separates from the head.

  
5 Save your model.

Create the Ducky’s Neck

The ducky needs a neck. We are first going to make an edge on the surface of the head and a corresponding edge on the
surface of the body so we can create a blended surface between the two edges.

To create a cutting plane:

1 Select the head.

2 From the Surface menu, click Rectangle, then click Cutting Plane.

3 At Start of cut plane prompt, in the Front view, pick the first point of a line (2) to define a plane.

4 Toggle Ortho on.
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5 At the End of cut plane prompt, select the end point of a line (3) that cuts through the lower part of the head.

6 At the Start of cut plane prompt, press ENTER to end the command.

To trim the head with the cutting plane:

1 From the Edit menu, click Trim.

2 At the Select cutting edges (Options) prompt, select the cutting plane you created (1).

3 At the Select cutting edges (Options) prompt, press ENTER.

 4 At the Select object to trim (Options) prompt, select the bottom edge of the head (2).

Trim
Look for this button.
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5 At the Select object to trim (Options) prompt, press ENTER to end the command.

The bottom of the head will be trimmed.

6 Delete the cutting plane.

To Cut a hole in the body that matches the opening in the bottom of the head:

1 From the Curve menu, click From Objects, then click Project.

2 At the Select curves to project prompt, in the Top view, select the curve at the bottom of the head (1).

3 At the Select curves to project prompt, press ENTER.

 4 At the Select surfaces or polysurfaces to project onto prompt, in the Top view, select the body (2).

Project
Look for this button.
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5 At the Select surfaces or polysurfaces to project onto prompt, press ENTER.

The curve is projected to the top (1) and the bottom (2) of the body.

  
6 From the Edit menu, click Trim.

7 At the Select cutting edges (Options) prompt, select the curve at the top of the body.

8 At the Select cutting edges (Options) prompt, press ENTER.

9 At the Select object to trim (Options) prompt, select the body on the inside of the curve.

10 At the Select object to trim (Options) prompt, press ENTER.

A hole will be created in the body. If Trim doesn’t work try Split.
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11 You can delete the projected curves.

 This may take more than one pick. Occasionally the curve gets broken into pieces.

12 Save your model.

To create the blend surface between the head and body:

1 From the Surface menu, click Blend.

2 At the Select edge to blend - pick near one end (PlanarSections Degree=Quintic) prompt, select the curve at the
bottom of the head.

3 At the Select edge to blend - pick near one end (PlanarSections Degree=Quintic) prompt, select the curve on the
body.

4 At the Select seam point to adjust, press Enter when done (FlipDirection Automatic Natural) prompt, check to
see that the seam point lines up.

If it doesn’t, select one of the seam points and drag it until it lines up with the other one. If the curve direction arrows
are not pointing in the same direction flip one of them.

Blend Surface
Look for this button.
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5 To flip a curve direction, at the Location of seam point (FlipDirection) prompt, pick the point on the curve you want
to flip, then type F and press ENTER.

 
6 At the Location of seam point (FlipDirection) prompt, press ENTER.

A surface is blended between the body and the head.

7 Save your model.
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To join the parts:

1 From the Edit menu, click Join.

2 At the Select object for join prompt, select the body.

3 At the Select next surface or polysurface to join prompt, select the neck.

4 At the Select next surface or polysurface to join prompt, select the head.

5 At the Select next surface or polysurface to join prompt, press ENTER.

 

To make an eye:

1 From the Solid menu, click Ellipsoid.

2 Toggle Ortho and Snap on to help.

3 At the Center of ellipsoid prompt, pick a point in the Top viewport.

4 At the End of first axis prompt, pick a point.

5 At the End of second axis prompt, pick a point that is approximately the same radius as the previous pick.

Join
Look for this button.

Ellipsoid
Look for this button.
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6 At the End of third axis prompt, pick a point in the Front viewport that creates a flat ellipsoid.

 

 

To make the pupil for the eye:

To be able to assign a different color for the pupil of the eye, the ellipsoid surface has to be split into two parts.

1 From the Curve menu, click Circle, then click Center, Radius.

2 At the Center of circle (Vertical AroundCurve) prompt, pick the center of the ellipsoid.

3 At the Radius <1> (Diameter) prompt, pick a point in the Top viewport that is slightly smaller than ellipsoid.
Circle
Look for this button.
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4 From the Curve menu, click From Objects, then click Project.

5 At the Select curves to project prompt, in the Top view, select the circle.

6 At the Select curves to project prompt, press ENTER.

7 At the Choose surfaces or polysurfaces to project onto prompt, in the Top view, select the ellipsoid.

8 At the Choose surfaces or polysurfaces to project onto prompt, press ENTER.

9 Delete the original circle and the one on the bottom of the ellipsoid.

10 From the Edit menu, click Split.

11 At the Select object to split prompt, select the ellipsoid.

12 At the Select cutting objects prompt, select the circle on the top of the ellipsoid.

13 At the Select cutting objects prompt, press ENTER.

 
14   Select the surface at the top of the ellipsoid.  If it is broken into two halves, join the pieces together.  Make sure the

top of the ellipsoid is selected.

15 From the From the Edit menu, click Object Properties.

Project
Look for this button.

Split
Look for this button.

Properties
Look for this button.
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16 In the Object Properties dialog, click Render Color and select a render color for the pupil of the eye, like black.

 

To move the eyes to the surface of the head:

1 From the Transform menu, click Orient, then click On Surface.

2 At the Select base surface prompt, select the head.

3 At the Select objects to orient  prompt, window select the whole eye and press ENTER.

4 At the Base point on surface (WorldCoordinates) prompt, type W and press ENTER.

5 At the Base point in world coordinates (OnSurface) prompt, pick the center of the ellipsoid.

6 At the Offset point prompt, move the cursor onto the head to place the eye.

Orient On Surface
Look for this button.
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7 At the Offset point prompt, press ENTER.

8 Mirror the eye to the other side of the head.

9 Save your model.

Render a Picture of the Ducky

Rendering creates a “realistic” picture of your model with colors you assign. These render colors are different from the
layer colors you might be using, which control the display in wireframe mode.
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To render the ducky:

1 Select the beak.

2 From the From the Edit menu, click Object Properties.

3 In the Object Properties dialog, click Render Color and select a color for the beak, like orange.

 
4 Select the body.

5 From the From the Edit menu, click Object Properties.
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6 In the Object Properties dialog, click Render Color and select a color for the body, like yellow.

 
7 From the Render menu, click Render.

Render
Look for this button.
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To place lights:

1 From the Render menu, click Create Spotlight.

2 At the Base of cone (Vertical) prompt, select a point in the middle of the model.

3 At the Radius prompt, drag the radius until it is approximately twice as large as the model.

4 At the End of cone prompt, pick a point in the Top view while holding the CTRL key down.

This technique activates Elevator Mode. The point should be slightly to the left and below the model.

In the Front view pick a point slightly above the object.

 

Spotlight
Look for this button.
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5 From the Render menu, click Render.

6 Try placing two lights.

  

Render
Look for this button.
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7 From the Render menu, click Render.

8 Save your model.

Render
Look for this button.
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9 Modeling with Solids

Modeling solids
Modeling solids in Rhino is easy. There are several commands that enable you create and edit solid objects.

Button Command Description

Box Creates a rectangular box from two diagonal corners and a height.

Right button option:
Creates a box from two adjacent corners, a point on the edge across from them, and a
height.

Sphere Creates a sphere from a center point and a radius.

SphereD Creates a sphere from the two ends of its diameter.

Sphere3Pt Creates a sphere from three points on its surface.

Cylinder Creates a solid cylinder from a center point, a radius, and a height.

Tube Creates a solid tube from a center point, two radii, and a height.
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Button Command Description

Cone Creates a solid cone from a base point, a base radius, and a height.

TCone Creates a truncated cone that ends in a circular plane from a base point, two radii, and
a height.

Ellipsoid Creates an ellipsoid from a center point, and three axis endpoints.

Torus Creates a solid torus from a center point, a radius for the center of the tube, and a tube
radius.

Pipe Creates a pipe around an existing curve. Pipe bundles the Circle command with the
OnCurve option of one-rail sweep and caps the ends to create solid pipes.

The Thick option lets you specify two radii at each end of the curve to create pipes with
holes bored through the middle like tubing.

Extrude
Closed
Planar Curve

Creates a solid by extruding a closed planar curve vertically.

Extrude
Surface

Creates a solid by extruding a surface vertically.
Extrude planar curve with draft angle

Cap Planar
Holes

Creates simple planar surfaces to close simple planar holes in a surface or partial solid.

Boolean
Union

Boolean operation in Rhino to combine solids.

Boolean
Difference

Boolean operation in Rhino to subtract surfaces and solids from another.

Boolean
Intersection

Boolean operation in Rhino to create the intersection of two surfaces or solids.
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Exercise 50—Creating solids.
Start a new model. Save as Swing Bracket.
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To create the boxes:

1 From the Solid menu, click Box, then click Corner to Corner, Height. Make sure your cursor is in the Front
viewport.

2 At the First corner of box prompt, type -.75,0,-.1875 and press ENTER.

3 At the Other corner or length prompt, type 1.5 and press ENTER.

4 At the Width prompt, type 3.25 and press ENTER.

5 At the Height prompt, type .375 and press ENTER. The first box is created.

6 From the Solid menu, click Box, then click Corner to Corner, Height.  Make sure your cursor is in the Top
viewport.

7 At the First corner of box prompt, type -1.5,-.75,3.25 and press ENTER.

8 At the Other corner or length prompt, type 3 and press ENTER.

9 At the Width prompt, type 1.5 and press ENTER.

Box
Look for this button.
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10 At the Height prompt, type .25 and press ENTER.

11 From the Solid menu, click Box, then click Corner to Corner, Height.  Make sure your cursor is in the Right
viewport.

12 At the First corner of box prompt, type -.75,3.5,-1.25 and press ENTER.

13 At the Other corner or length prompt, type 1.5 and press ENTER.

14 At the Width prompt, type 1 and press ENTER.

15 At the Height prompt, type .25 and press ENTER.

16 Select the last box you created.
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17 From the Transform menu, click Mirror. Make sure your cursor is in the Front viewport.

18 At the Start of mirror plane prompt, type 0,0 and press ENTER.

19 At the End of mirror plane prompt, toggle Ortho on and pick a point directly above 0,0.

The box is mirrored to the other part.

To create the cylinders:

1 Turn on End and Mid osnap.

2 From the Solid menu, click Cylinder.

Mirror
Look for this button.

Cylinder
Look for this button.
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3 At the Base of cylinder (Vertical) prompt, snap to the midpoint at the top of the last box you created.

4 At the Radius <0.75> (Diameter) prompt, snap to the endpoint of the left top edge of the same box.

5 At the End of cylinder prompt, snap to the other midpoint at the top of the same box.

6 Select the cylinder you just created.

7 From the Transform menu, click Copy.

8 At the Point to copy from (Vertical InPlace) prompt, snap to the midpoint at the top left edge of the box.

9 At the Point to copy to prompt, snap to the midpoint of the corresponding box at the other end of the part.

10 At the Point to copy to prompt, press ENTER.

Copy
Look for this button.
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11 Use the same procedure to make the cylinder at the bottom of the part.

To create the tube:

1 From the Solid menu, click Tube.

2 At the Base of tube (Vertical) prompt, move your cursor into the Front viewport and type 0,0,1 and press ENTER.

3 At the Radius <0.75> (Diameter) prompt, type D and press ENTER.

4 At the Diameter <1.5> (Radius) prompt, type .63 and press ENTER.

5 At the Diameter <2> (Radius) type 1 and press ENTER.

6 At the End of tube prompt, type 2 and press ENTER.

Tube
Look for this button.
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7 At the End of tube prompt, move your cursor into the Top viewport, toggle Ortho on and pick a point directly above
the previous point.

 
8 Save your model.

To join the parts:

1 From the Solid menu, click Union.

2 At the Select surface or polysurface prompt, select one of the parts you created.

3 At the Select surface or polysurface to union prompt, select an adjacent part.

Always save your model
before you do a boolean
operation.

Boolean Union
Look for this button.
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4 Continue to Union parts together until it becomes one piece.

To make the hole through the top part of the bracket:

1 From the Solid menu, click Cylinder.

2 At the Base of cylinder (Vertical) prompt, move your cursor into the Top viewport, type 2,0,4.5 and press ENTER.

3 At the Diameter <0.75> (Radius) prompt, type .63 and press ENTER.

4 At the End of cylinder prompt, toggle Ortho on and drag the cylinder to a point that passes through the object.

Cylinder
Look for this button.
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To subtract the cylinder to create the holes:

1 From the Solid menu, click Difference.

2 At the Select surface or polysurface prompt, select joined part.

3 At the Select surface or polysurface to subtract prompt, select the cylinder you just created.

 

Boolean Difference
Look for this button.
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Modeling a Flashlight
When this model is finished you will have three distinct parts—the flashlight body, the lens, and the switch.

You will learn how to use Rhino solids to create a simple model of a flashlight. While building the model you will create
the basic shape with a cylinder, and a truncated cone. A sphere is added to create the switch. To complete the model you
will add solids together and subtract other solids from your basic shapes.

The shaded view of the finished flashlight.

Exercise 51— Model a Flashlight

To draw the body:

1 Start a new model. Save as Flashlight.

2 From the Solid menu, click Cylinder.

3 Move your cursor to the Right viewport.

When you are in the middle of a command, you don’t have to click in the viewport, just move the cursor there to
make it active. The viewport title highlights in blue.

4 At the Base point ( Vertical ) prompt, type 0,0.

This sets the base point for the cylinder at the origin (0,0,0 point) of the coordinate system for the Right viewport.

Coordinates define points in space.

5 At the Radius ( Diameter ) prompt, type .75 and press ENTER.

Cylinder
Look for this button.
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6 At the End of cylinder prompt, type 5.5 and press ENTER.

7 Turn Ortho on.

8 At the next End of cylinder prompt, in the Front viewport, pick a point to show the rotation angle so the cylinder
points to the right.

.

9 From the View menu click Zoom, then click Extents All.

Or, right-click the Zoom Extents button.

10 Click in the Perspective viewport.

When you are not in the middle of a command, you have to click in a viewport to make it the active viewport.

11 From the Render menu, click Shade.

Zoom Extents
Look for this button.

Shade
Look for this button.
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Since you will be using Shade frequently, this might be a good opportunity to find the toolbar button for Shade. It is
in the toolbar that runs across the top of the viewports. The icon is a gray sphere.

To draw the flashlight reflector shield:

1 From the Solid menu, click Truncated Cone.

2 At the Base point of truncated cone ( Vertical ) prompt, snap to the center of the right end of the cylinder.

To turn on the Center object snap, on the status bar click Osnap, then check Cen.

It’s easiest to use the Perspective viewport for this.

Truncated Cone
Look for this button.
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3 At the  Radius <.75> ( Diameter ) prompt, type .875 and press ENTER.

A truncated cone has two radius values, the base and top.

4 At the next Radius <1.00> ( Diameter ) prompt, type 1 and press ENTER.

5 At the End of cone prompt, type 2 and press ENTER.

This sets the length of the cone.

6 At the next End of cone prompt, pick in the Front viewport to the right of the cylinder to rotate it into place.

You may have to zoom out a little to get some space in the Front viewport. Hold down CTRL and drag with the right
mouse button. You can do this right inside the command. The rotation angle won’t be entered until you click with the
left mouse button.

Being able to zoom and pan inside a command makes moving around in Rhino easy.

7 From the View menu, click Zoom, then click Extents All.
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8 Shade the Perspective view.

To create the cutting cone:

You will now copy the truncated cone to create another truncated cone that will be used to cut the inside shape of the
reflector shield.
1 Select the truncated cone.

2 From the Transform menu, click Copy.

3 At the Base point ( Vertical InPlace ) prompt, in the Front viewport pick any point. Copy
Look for this button.
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4 At the Offset point prompt, turn on Ortho and drag the cone to the right until the sides of the cone copy are inside
the first cone.

5 Pick a point to place the copy, and press ENTER.

We needed to move the truncated cone to the right so does not cut into the sides of the flashlight.

It may help at this point to turn off the Center object snap.

To add the two parts of the flashlight body together:

1 From the Solid menu, click  Union.

2 At the Select surface or polysurface prompt, select the cylinder.

You can’t select the object first when using boolean commands. Starting the command cancels your selection. You
can only select one object at each prompt.

3 At the Select surface or polysurface to union prompt, select the first truncated cone.

Not much appeared to happen, but the cylinder and the truncated cone are now one piece.

To cut the inside of the reflector shield:

1 From the Solid menu, click Difference.

2 At the Select surface or polysurface prompt, select the flashlight body.

3 At the Select surface or polysurface to subtract prompt, select the new truncated cone.

Boolean Union
Look for this button.

Boolean Difference
Look for this button.
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4 Shade the Perspective view.

5 Rotate the view a bit so you can see inside the flashlight.

To draw the cutting cylinder:

1 From the Solid menu, click Cylinder.

You will create a cylinder that will be subtracted from the inside of the flashlight.

2 At the Base point ( Vertical ) prompt, pick a point in the Perspective viewport that is at the center of the cylinder at
the flashlight base.

Cylinder
Look for this button.
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3 At the Radius ( Diameter ) prompt, type .625 and press ENTER.

4 At the End of cylinder prompt, pick a point in the Front viewport to the right of the reflection hood.

This sets both the length of the cylinder and the rotation angle at the same time.

To move the cylinder away from the base:

We need to move the cylinder away from the base a little so it won’t cut through the flashlight’s bottom.

You can move objects just by selecting and dragging them.

1 Select the cylinder you just created.

2 Turn Ortho on, if it is not already.

3 Turn off the Center object snap.

Sometimes having object snaps on interferes with your ability to click and drag freely.
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4 In the Front viewport, click near the right end of the cylinder and drag it a little bit to the right.

Ortho will keep it moving in a straight line.

5 From the View menu, click Zoom, then click Extents All.

6 Shade the Perspective view.

To cut out the interior of the flashlight:

1 From the Solid menu, click Difference.

2 At the Select surface or polysurface prompt, select the flashlight body.

Zoom Extents All Viewports
Look for this button.

Boolean Difference
Look for this button.
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3 At the Select surface or polysurface to subtract prompt, select the new cylinder.

4 Shade the Perspective view.

To draw the lens:

1 From the Solid menu, click Cylinder.

2 At the Base point ( Vertical ) prompt, snap to the center of the inside edge of the truncated cylinder.

3 At the Radius <0.625> ( Diameter ) prompt, type .625 and press ENTER.

4 At the Choose a point prompt, in the Front viewport pick a point slightly to the left of the center point.

Cylinder
Look for this button.
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It helps at this point to turn off the Center object snap. Otherwise, it’s hard to drag the cylinder a very small amount.

You are trying to make a thin piece of glass.

The glass won’t show much in your model, but later, when you render it, you can make the flashlight more realistic
by making this cylinder partially transparent.

To draw the switch button:

1 From the Solid menu, click  Sphere, and then click Center, Radius.

2 At the Center point prompt, in the Front viewport pick a point near the top of the cylinder. Sphere
Look for this button.
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3 At the Radius ( Diameter ) prompt, pick a radius.

You can type .4, or just drag out a size that looks good to you.

4 Shade the Perspective viewport.

Render the Flashlight

You can use Rhino to add color, texture, and lights to your model to make simple presentations. In this exercise you will
add only color to the flashlight parts and use Rhino’s rendering capability to create a more realistic picture.
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To render the model:

1 Click in the Perspective viewport.

2 From the Render menu, click Render.

A separate Display Window appears with the model rendered in default gray.

To set the color for the flashlight body:

1 Select the flashlight body.

2 From the Edit menu, click Object Properties.

3 In the Object Properties dialog box, under Render color, click the color swatch.

Render
Look for this button.
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4 In the Select Color dialog box, from the Named Colors list, select Red, and click OK.

 
5 In the Object Properties dialog box, check Highlight.

6 Move the Highlight slider to near the middle of the Small to Big range.

7 Click OK.

To set the lens to be transparent:

1 Select the lens.

2 From the Edit menu, click Object Properties.

3 In the Object Properties dialog box, drag the Transparency slider to the right.

Don’t move it all the way to the right or the lens will disappear completely. You want it to be a little opaque so you
can still see it.

Render
Look for this button.
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4 From the Render menu, click  Render.
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Modeling a Pull Toy
In the following exercise, you will create a wheeled pull toy.

Drawing the Pull Toy Body

This exercise uses x-, y-, and z-coordinates to accurately place points. When you are to type coordinates, type them just
as they are shown in the manual. The format is x,y,z. For example, type 1,1,4. You must type the commas. This sets your
cursor at x=1, y=1, and z=4 in the active viewport.

Whenever you type points, look in all viewports at where the point is placed so you can start getting an idea of how
coordinate entry works. The advantage this gives you is that you can enter your points without restricting them to the
construction plane.

The finished Pull Toy

Note Pay close attention to the viewport required in each instruction.

Exercise 52—Creating solids.

To start the model:

Start a new model. Save as Pull Toy.
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To create an ellipsoid:

1 Turn on Ortho.

2 From the Solid menu, click  Ellipsoid.

3 In the Top viewport, at the Center point prompt, type 0,0,6 and press ENTER.

This places the center point of the ellipsoid at x=0, y=0, and z=6. Look at the point in the perspective viewport.

4 At the End of first axis prompt, type 7 and press ENTER.

5 Drag the cursor to the right and pick to show the direction.

6 At the End of second axis prompt, type 4 and press ENTER.

This sets the width of the ellipsoid.

7 At the End of third axis prompt, type 4.5 and press ENTER.

You now have an egg shape that has different dimensions in all three directions.

8 Rotate the perspective viewport so you are looking along the x-axis as shown.

Ellipsoid
Look for this button.
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9 Shade the Perspective view.

Drawing the Axles and Wheel Hubs

The axles and wheel hubs are cylinders. The axles are long, thin cylinders, and the wheel hubs are short, fat cylinders.
You are going to make one axle and one complete wheel. You will then mirror the complete wheel to the other side. You
can then either mirror or copy the complete axle and wheel set to the front of the toy.

To create the axle:

1 From the Solid menu, click  Cylinder.

2 In the Front viewport, at the Base point (Vertical) prompt, type 4,3,5 and press ENTER.

Look at where this point is. It is four units in the x-direction, three units in the y-direction, and five units in the
z-direction of the active viewport.

3 At the Radius (Diameter) prompt, type .25 and press ENTER.

4 At the End of cylinder prompt, type 10 and press ENTER.

Cylinder
Look for this button.
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5 In the Top viewport drag the cylinder as shown to place the axle.

To create a wheel hub:

1 From the Solid menu, click Cylinder.

2 In the Front viewport, at the Base of cylinder (Vertical) prompt, type 4,3,4.5 and press ENTER.

3 At the Radius (Diameter) prompt, type 2 and press ENTER.

4 At the End of cylinder prompt, type 1 and press ENTER.

5 At the next End of cylinder prompt, pick in the Top viewport to place the hub.

Cylinder
Look for this button.
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6 Shade the Perspective viewport.

Draw the Lug Nuts

You will make the lug nuts by extruding a hexagonal polygon. Polygons are curves in Rhino.

To create the hexagon:

1 From the Curve menu, click  Polygon, and then click Center, Radius.

2 At the Center of polygon ( NumSides=4 Circumscribed ) prompt, type 6 and press ENTER.

3 In the Front viewport, at the Center of polygon ( NumSides=6 Circumscribed ) prompt, type 4,4,5.5 and press
ENTER.

This will place the polygon right on the surface of the wheel hub.

Polygon
Look for this button.
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4 At the Radius prompt, type .25 and press ENTER.

To make a solid from the polygon:

1 Select the hexagon you just created.

2 From the Solid menu, click Extrude Planar Curve.

3 At the Extrusion distance (Direction Cap=yes Bothsides Tapered) prompt, make sure Cap=yes.

If it does not, type C and press ENTER.

This is an example of a command option. Many commands have options. You will learn how to change and use them
as you learn to use the commands. Take a moment and look at the options available for the Extrude command.

Press F1 to look at the Help topic for this command. The Help topic explains the options.

4 At the Extrusion distance (Direction Cap=yes Bothsides Tapered) prompt, type .25 and press ENTER.

Notice the negative number. If you type a positive number at this point, the nuts will be buried in the wheel hub. You
want them to stick out.

Extrude
Look for this button.



M O D E L I N G  W I T H  S O L I D S

N o t e s :

Robert McNeel & Associates ❑ 251

5 Shade the Perspective viewport.

Assign Colors

Now that you have the basic parts built, you are going to assign render colors to them before we start copying them. If we
wait until we have all the parts, you will have to select 20 lug nuts separately. If we assign render colors now, the color
property will be copied when we copy the parts.

To assign render color to the parts:

1 Select the lug nut.

2 From the Edit menu, click Object Properties.

3 In the Object Properties dialog box, under Render color, click the color swatch as shown.
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4 In the Select Color dialog box, under Named Colors, click Black and click OK.

  
The Select Color dialog box.

5 In the Object Properties dialog box, click OK.

6 Follow steps 1 through 6 to set a render color for the toy body.

You will be assigning render colors to objects as we go along.
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7 Render the Perspective viewport.

Array the Lug Nuts

To create the lug nuts on the first wheel, you are going to use a polar (circular) array. An array is a set of copies of an
object. You control how the copies are made. A polar array copies the objects around a central point. They can be rotated
as they are copied.

To array the nuts:

1 Select the lug nut.

The hexagon is still there, so be sure you select the extruded lug nut. (The Select One Object dialog will list it as a
polysurface.)

2 From the Transform menu, click Array, and then click Polar.

3 At the Center point prompt, snap to the center of the hub.

4 At the Number of elements <1> prompt, type 5 and press ENTER.

5 At the Angle to fill <360> prompt, press ENTER.

Polar Array
Look for this button.
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6 Shade the Perspective viewport.

Draw the Tires

The tires are a solid form called a torus, which looks like a donut. When you are drawing a torus, the first radius is the
radius of a circle around which the “tube” is drawn. The second radius is the radius of the tube itself.

To draw the tires, you will draw the center of the torus tube a bit larger than the diameter of the wheel hub. The tube
itself is slightly larger than the hub. This makes it dip into the hub.

To create a torus for the tires:

1 From the Solid menu, click Torus.

2 In the Front viewport, at the Center point (Vertical AroundCurve) prompt, type 4,3,5 and press ENTER.

This places the center of the torus at the same point as the center of the wheel hub.

3 At the Radius (Diameter) prompt, type 2.5 and press ENTER.

This makes the radius of the torus 0.5 units larger than the wheel hub.

4 At the Second radius (Diameter) prompt, type .75 and press ENTER.

This makes the hole radius .25 units smaller than the wheel hub.

5 Set the render Color of the tire to Black.

Torus
Look for this button.
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6 Render the Perspective viewport.

Mirror the Wheels

Now that you have a whole wheel created, you can use Mirror to create the other three.

To mirror the wheel to the other side:

1 In the Top viewport, use a window to select the wheel, tire, and lug nuts as shown.

2 From the Transform menu, click Mirror.

3 At the Start of mirror plane prompt, type 0,0,0.

Mirror
Look for this button.
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4 In the Top viewport, with Ortho on, drag to the right as shown and click.

5 Shade the Top viewport.
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To mirror the front wheels and axle:

1 In the Top viewport, use a window to select the back wheels and axle as shown.

2 From the Transform menu, click Mirror.

3 At the Start of mirror plane prompt, type 0,0,0.

4 In the Top viewport, with Ortho on, drag down as shown and click.

Mirror
Look for this button.



M O D E L I N G  W I T H  S O L I D S

N o t e s :

Robert McNeel & Associates ❑ 258

5 Shade the Top viewport.

Draw the Eyes

While drawing the eyes, you are going to practice using elevator mode. You are going to start the center of the eye
spheres in the top viewport and use elevator mode to move them up.

To create an eye:

1 From the Solid menu, click  Sphere, and then click Center, Radius.

2 At the Center of sphere prompt, in the Top viewport hold CTRL and pick near the front edge of the ellipsoid. Sphere
Look for this button.
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This will start elevator mode.

3 Move your cursor to the Front viewport, drag the sphere near the top edge of the ellipsoid, and pick.

4 At the Radius ( Diameter ) prompt, type 1.5 and press ENTER.

5 Shade the Perspective viewport.

6 In the Top viewport, Mirror the sphere to the other side of the ellipsoid.

Use the same procedure you used to mirror the wheel hub.
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7 Shade the Perspective viewport.

8 Use the same technique to make two more small black pupils. Make one Sphere, move it if you have to. Change its
color to black and mirror it.

9 Render the Perspective viewport.

Make the Pull Cord

To make the cord, you are going to draw a freehand curve. When the curve is complete, you will use the Pipe command
to make it a thick solid.
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To create the pull cord at the front of the toy:

1 Zoom out in all the viewports, you are going to need some space to work.

2 From the Curve menu, click Freeform, and then click Control Points.

3 At the Start of curve prompt, in the Top viewport, snap Quad to the front end of the ellipsoid.

4 Continue picking points until you create a curve to represent the cord.

Curve
Look for this button.
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5 Draw an Ellipsoid to represent a handle at the end of the curve.

Make the cord fat:

1 From the Solid menu, click Pipe.

2 At the Select curve to create pipe around prompt, choose the curve you just created.

3 At the Starting radius <1> ( Diameter Cap=yes Thick=No ) prompt, type .125 and press ENTER.

4 At the End radius <1> ( Diameter ) prompt, press ENTER.

The pipe will be the same diameter for the full length of the curve.

5 Change the cord color to black and the handle color to any color you like.

Pipe
Look for this button
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6 Render the Perspective view.

Another example of a Pull Toy created with solids and surfaces.  We will learn more about surfaces in another
chapter.

 
Insect Pull Toy, modeled by Grant Lange.
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Making Solid Text
Creates two or three-dimensional text from True Type fonts, in the form of curves, surfaces, or solids.

To create text using 3-D solids:

1 Start a new model. Save as Text.

2 Click in the Top viewport.

3 From the Solid menu, click Text.

The Add Text dialog appears.

4 In the Add Text dialog box, in the Font box, select a font.

5 In the Font Style box, select a style.

6 In the Text box, type some new text.

7 Click Create Solids.

8 In the Height box, type the height of the text.

9 In the Extrude Depth box, type a thickness for your solid text, then click OK.

Text
Look for this button
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10 From the View menu, click Zoom, then click Extents All.

The text is inserted perpendicular to the active viewport, starting at 0,0.

 
11 From the Render menu, click Shade.
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10 Creating Surfaces

Surfaces
A Rhino surface is similar to a piece of stretchy fabric. It can take on many different shapes.

Surfaces are bounded by curves called edges.  To visualize the surface shape Rhino displays a grid of isoparms on the
surface.

Surfaces have an area, their shape can be changed by moving control points, and they can be meshed.

Button Command Description

SrfPt Creates a surface by picking three or four points in space for corners.

EdgeSrf Creates a surface by selecting two, three or four existing curves whose ends meet
exactly.

PlanarSrf Creates a surface from planar curves that enclose an area.

Patch Creates a surface that goes through a set of curves and/or point objects

Revolve Revolve a curve around an axis to create a surface.

Loft Creates a surface from shape curves; the normal option makes a surface with no
creases as it passes over the shape curves.
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Button Command Description

The Straight Sections option creates a surface with creases at each shape curve
and straight sections between the shapes curves.

Sweep1 Creates a surface from shape curves that follows along a rail curve. This command
controls one edge of the surface.

Sweep2 Creates a surface from shape curves that follows along two rail curves. The two-rail
sweep allows you to control the surface’s edges.

FilletSrf Creates a fillet or round between two surfaces.

FilletEdge Creates a fillet or round on the edge of a polysurface or solid.

BlendSrf Makes a smooth surface between two existing surfaces

RailRev Revolves a shape curve holding one end along a rail curve.  This command is very
useful for putting a smooth end cap on an irregularly shaped surface.

Extrude Extrudes a curve perpendicular to the construction plane with option to taper the
surface with a draft angle.

ExtrudeAlongCrv Extrudes a curve following along a second curve.

ExtrudeToPt Extrudes a curve to a point.

Plane Creates a rectangular planar surface parallel to the construction plane from two
diagonal points.

Plane3Pt Creates a rectangular planar surface from 3 points.

PlaneV Creates a rectangular planar surface from 3 points that is vertical to the
construction plane.
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Exercise 53—Basic techniques for making surfaces

♦ Start a new model. Save as Surfaces.
In this exercise we will model some simple surfaces.

To create a rectangular plane:

1 From the Surface menu, click Rectangle, then click Corner to Corner.

2 In the Top viewport, at the First corner of plane prompt, type 0,0 and press ENTER.

3 At the Other corner or length prompt, type 10 and press ENTER.

4 At the Width prompt, type 6 and press ENTER.

To create a vertical plane:

1 From the Surface menu, click Rectangle, then click Vertical.

2 At the Start of edge prompt, snap to the End point at the right side of the surface.

3 At the End of edge prompt, snap to the other End point at the right side of the surface.

Plane
Look for this button

Plane Vertical
Look for this button
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4 At the Height of rectangle prompt, type 5 and press ENTER.

To create a plane from 3 points:

1 From the Surface menu, click Rectangle, then click 3 Points.

2 At the Start of edge prompt, snap to the endpoint at the top of the second surface.

3 At the End of edge prompt, snap to the other endpoint at the top side of the second surface.

4 At the Width prompt, type 10 and press ENTER.

5 At the Width prompt, type <45 and press ENTER.

Plane 3 Points
Look for this button
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6 At the Width prompt, pick a point in the front viewport.

 

To create a plane from points:

1 From the Surface menu, click Corner Points.

2 At the First corner of surface prompt, snap to an End point at the left edge of the first surface.

3 At the Second corner of surface prompt, snap to the other End point at the left edge of the first surface.

4 At the Third corner of surface prompt, snap to an End point at the left edge of the third surface.

Surface from 3 or 4 Corner Points
Look for this button
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5 At the Fourth corner of surface prompt, snap to the other End point at the left edge of the third surface.

A surface will be created with corners at the points you selected.

 

To create a plane from curves:

1 Draw a curve between the two open corners in the Front viewport.

 
2 From the Surface menu, click Edge Curves.

3 At the Choose 2, 3, or 4 curves prompt, select the near edge of the first surface you created.

4 At the Choose 2, 3, or 4 curves prompt, select the of the curve you created.
Surface from 2, 3 or 4 Edge Curves
Look for this button
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5 At the Choose 2, 3, or 4 curves prompt, select another edge.

6 At the Choose 2, 3, or 4 curves prompt, select another edge.

A surface is created.

 
7 Repeat this process for the open end by picking four edges.
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To create a surface from a closed planar curve:

1 Draw a Curve from Control Points in the Top viewport.  Make sure it is closed.

2 Select the curve.

3 From the Surface menu, click From Planar Curves.

A surface is created.

Curve
Look for this button

Surface from Planar Curves
Look for this button
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Exercise 54—Extruding Surfaces

To create an extruded surface from a curve:

1 Open the Surface Extrude model.

2 Select the curve on the left.

3 From the Surface menu, click Extrude, then click Straight.

4 At the Extrusion distance (Direction BothSides Tapered) prompt, type 12 and press ENTER.

The curve is extruded straight up from the construction plane.

5 Press ESC to unselect the curve.

To create an extruded surface from a curve to a point:

1 From the Surface menu, click Extrude, then click To Point.

2 At the Select curve to extrude prompt, pick the next curve.

Extrude
Look for this button

Extrude To Point
Look for this button
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3 At the Point to extrude to prompt, pick a point in the front viewport above the x plane.

The curve is extruded to a point.

To extrude a curve along another curve:

1 From the Surface menu, click Extrude, then click Along Curve.

2 At the Select shape curve prompt, pick the next curve in the top view.

3 At the Select path curve prompt, pick the path curve near its bottom end in the Front viewport.

 

Extrude Along Curve
Look for this button

If you don’t get the answer you
expected, undo and try picking
near the other end of the path
curve.
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To extrude a curve with a taper (draft angle):

1 Select the closed curve on the right.

2 From the Surface menu, click Extrude, then click Straight.

3 At the Extrusion distance <12> (Direction Cap=no Bothsides Tapered) prompt, type t and press ENTER.

4 At the Draft angle <0> prompt, type 5 and press ENTER.

5 At the Extrusion distance <12> (Direction Cap=no) prompt, type 10 and press ENTER.

The curve is extrude with a ten degree draft angle.

Exercise 55—Lofted surfaces

To create a lofted surface:

1 Open the Loft model.

Extrude
Look for this button
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2 Window select all of the curves at the lower part of the Top viewport.

3 From the Surface menu, click Loft.

4 In the Loft Options dialog, OK. Loft
Look for this button
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A surface is fitted over the curves.

5 Mirror the surface to create the other half.
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6 From the Render menu, click Shade.

To create a lofted surface with straight sections:

1 Window select all of the curves at the top part of the Top viewport.

2 From the Surface menu, click Loft.

Loft
Look for this button
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3 In the Loft Options dialog, switch Style to Straight sections, then click OK.

A surface is fitted over the curves.
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4 Mirror the surface to create the other half.

5 From the Render menu, click Shade.

Exercise 56—Revolved surfaces

To create a revolved surface:

1 Open the Revolve model.
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2 From the Surface menu, click Revolve.

3 At the Select curve to revolve prompt, select the curve.

4 At the Start of revolve axis prompt, pick the end of the red vertical line.

5 At the End of revolve axis prompt, pick the other end of the red vertical line.

6 In the Revolve Options dialog, click OK.

Revolve
Look for this button
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A surface is revolved around the axis line.

Exercise 57—Using a rail revolve

There are times when you need to put a cap on the end of an irregular shaped object.  Revolve lets you revolve a profile
curve in a circular shape.  Rail revolve allows you to revolve around an axis and along a path curve.

To create a Rail Revolve:

1 Open the Rail Revolve model.

2 From the Surface menu, click Rail Revolve.

Rail Revolve
Look for this button.
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3 At the Select profile curve prompt, select the curve at the end of the object (1).

4 At the Select path curve prompt, select the end of the object (2).

5 At the Start of revolve axis prompt, select one end of the axis line (3).

6 At the End of revolve axis prompt, select the other end of the axis line (4).

A surface is revolved around the axis that follows along the curve at the end of the object.

 
7 Repeat this procedure for the other end of the object.
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Exercise 58—Using sweeps to create surfaces

To create a 1 Rail Sweep:

1 Open the 1 Rail Sweep model.

2 Select all of the curves.

3 From the Surface menu, click Sweep 1 Rail.

4 At the Select seam point to adjust, press Enter when done ( FlipDirection Automatic Natural ) prompt, press
ENTER.

Sweep along 1 Rail
Look for this button
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5 In the Sweep 1 Rail Options dialog,  then click OK.

The two cross section shapes are blended together to form the surface.

6 From the Render menu, click Shade.

Exercise 59—Using sweeps to create surfaces

To create a 2 Rail Sweep:

♦ Open the 2 Rail Sweep model.
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To create the base part:

1 Change to the Base Surface layer.

2 From the Surface menu, click Sweep 2 Rails.

3 At the Select 2 rail curves prompt, select the first rail curve (1).

4 At the Select 2 rail curves prompt, select the next rail curve (2).

5 At the Select cross-section curves ( Point ) prompt, select the cross-section curve (3).

6 At the Select cross-section curves ( Point ) prompt, press ENTER.

Sweep along 2 Rails
Look for this button
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7 In the Sweep 2 Rails Options dialog, click OK.

A surface is created that whose edges match the rail curves along the rail curves.

8 From the Render menu, click Shade.
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To create the housing:

1 From the Edit menu, click Layers, then click Edit.

2 On the Edit Layers dialog, turn the Housing Surface, Housing Curves, and Mirror layers on. Lock the Base
Curves and Base Surface layers.

3 Make the Housing Surface layer current.

4 Click OK.

5 From the Surface menu, click Sweep 2 Rails.

6 At the Select 2 rail curves prompt, select the first rail curve (1).

7 At the Select 2 rail curves prompt, select the next rail curve (2).

8 At the Select cross-section curves ( Point ) prompt, select the curve at the front of the cylinder (3).

Sweep along 2 Rails
Look for this button
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9 At the Select cross-section curves ( Point ) prompt, press enter.

10 In the Sweep 2 Rails Options dialog, click OK.

A surface is created that wraps around the rail curves and finished with a smooth end where the rail curves come
together.
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11 From the Render menu, click Shade.

To join the two parts:

1 From the Edit menu, click Layers, then click Edit.

2 In the Edit Layers dialog, make sure the Housing Surface, the Base Surface, and Mirror layers are on. All other
layers should be turned off.

3 From the Solid menu, click Union.

4 At the Select surface or polysurface prompt, select the base surface.
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5 At the Select surface or polysurface to union prompt, select the housing surface.

To make a fillet between the two surfaces:

1 From the Surface menu, click Fillet.

2 At the Select first surface to fillet ( Radius=1 Extend=Yes Trim=Yes )  prompt, type .25 and press ENTER.

3 At the Select first surface to fillet ( Radius=0.25 Extend=Yes Trim=Yes )  prompt, select the base surface (1).
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4 At the Select second surface to fillet ( Radius=0.25 Extend=Yes Trim=Yes ) prompt, select the housing surface
(2).

A fillet is created between the two surfaces.

 
5 Rotate the object in the perspective viewport.

6 From the Render menu, click Shade.

7 Rotate the object in the perspective viewport.

8 Join the base, the fillet, and the housing surfaces.
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9 From the Render menu, click Render.
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Modeling a Toy Hammer
Some models require more attention to detail.  This is an example of a model that requires precise modeling techniques.
This exercise also requires a number of different surface creation techniques. The technical drawing is included to help
you create a very precise model.
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Exercise 60— Creating a toy hammer:
1 Start a new model. Save as Hammer.

2 Create the following layers: Curve, Handle, Tang, Head, Claw.
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3 Draw the outlines for the hammer.

Drawing outlines helps while drawing the curves. You can either draw lines, polylines, or rectangles to create the
outlines.  Use the dimensions on the technical drawing to get accurate outlines.

To create the claw:

When modeling the shape of the claw you will use circles and arcs.  You can trim the circles and arcs and then join
them together to create the closed curve.

1 Change to the Curve layer

2 Draw a curve defining the shape of the claw in the top viewport.

You can use a freeform curve or use a combination of arcs and circles which are trimmed and joined to create the
curve. Following is a step by step approach to creating the curve for the claw part of the hammer.

Start by drawing two circles.
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3 From the Curve menu, click Circle, then click Tangent to 3 Curves.

4 At the Select first curve prompt, select the curve at point one.

5 At the Select second curve prompt, select the curve at point two.

6 At the Select third curve prompt, select the curve at point three.

The circle will be created tangent to all three curves you selected.

7 From the Curve menu, click Circle, then click Diameter.

8 At the Start of diameter (Vertical) prompt, snap to the midpoint of the upper claw construction line.

9 At the End of diameter prompt, type .5 and press ENTER.

Circle: Tangent, Tangent, Tangent
Look for this button.

Circle Diameter
Look for this button.
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10 At the End of diameter prompt, pick a point directly below the first point.

To create the tangent arcs:

1 From the Curve menu, click Arc, then click Tangent, Tangent, Radius.

2 At the Select first curve for ArcTTR prompt, select a circle near the right edge.

3 At the Select second curve for ArcTTR prompt, select the other circle near the right edge.

4 At the Radius <1> prompt, type 2 and press ENTER.

5 Delete the parts of the arcs that you don’t need.

6 From the Curve menu, click Arc, then click Tangent, Tangent, Radius.

7 At the First curve prompt, select a circle near the left edge.

8 At the Second curve prompt, select the other circle near the left edge.

9 At the Radius <1> prompt, type 3  and press ENTER.

Arc: Tangent, Tangent, Radius
Look for this button.



C R E A T I N G  S U R F A C E S

N o t e s :

Robert McNeel & Associates ❑ 301

10 Delete the parts of the arcs that you don’t need.

To trim the circles:

1 From the Edit menu, click Trim.

2 At the Select cutting edges (Options) prompt, select one of the arcs.

3 At the Select cutting edges (Options) prompt, select the other arc.

4 At the Select cutting edges (Options) prompt, press ENTER.

5 At the Select object to trim (Options) prompt, select the insides of the circles.

Trim
Look for this button.
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6 At the Select object to trim (Options) prompt, press ENTER to end the command.

7 Join the curve segments.

The command terminates when the curve closes.

To extrude the claw part of the hammer:

1 Change to the Claw layer.

2 Select the joined segments.

3 From the Surface menu, click Extrude, then click Straight.

4 At the Extrusion distance (Direction Cap=no Bothsides Tapered) prompt, type C and press ENTER.

This makes it a solid.

5 At the Extrusion distance (Direction Cap=yes Bothsides Tapered) prompt, type B and press ENTER.

This extends the  extrusion on both sides of the construction plane.

Extrude Straight
Look for this button.
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6 At the Extrusion distance (Direction Cap=yes) prompt, type .75 and press ENTER.

To create slot for the claw part of the hammer:

1 Change to the Curve layer.

2 Draw a Curve in the Right viewport, that starts in the middle of the extruded object, and extends to the right beyond
the extrusion.

3 Mirror the curve.
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4 Draw a Line between the end points, then Join the three curves.

5 Select the joined segments.

6 Change to the Claw layer.

7 From the Surface menu, click Extrude, then click Straight.

8 At the Extrusion distance <.75> (Direction Cap=yes Bothsides Tapered) prompt, type B and press ENTER. Extrude Straight
Look for this button.
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9 At the Extrusion distance (Direction Cap=yes) prompt, type 2 and press ENTER.

10 Rotate the slot in the Top viewport

 
11 Save your model.

To remove the slot from the claw:

1 From the Solid menu, click Difference.

2 At the Select surface or polysurface prompt, select the claw extrusion. Boolean Difference
Look for this button.
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 3 At the Select surface or polysurface to subtract prompt, select the Slot extrusion.

 

4 Save your model.

To make the fillets on the claw:

1 From the Solid menu, click Fillet Edge.

2 At the Select edges to fillet ( Radius=1 ) prompt, select the top edge of the claw.

3 At the Select edges to fillet ( Radius=1 ) prompt, select the bottom edge of the claw.

4 At the Select edges to fillet ( Radius=1 ) prompt, type .1 and press ENTER.

Fillet Edge
Look for this button.
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5 At the Select edges to fillet ( Radius=0.1 ) prompt, press ENTER.

The edges have a round on them.

6 Save your model.

To create the Head:

1 Change to the Curve layer.

2 Create the curve for the cross section of the head, using the Curve command.

 

Make sure the curve intersects the claw part.  This will make joining the two pieces easier.
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3 Change to the Head layer.

4 From the Surface menu, click Revolve.

5 At the Select curve to revolve prompt, choose the polyline for the cross-section of the head.

6 At the Start of revolve axis prompt, pick the end of the curve.

7 At the End of revolve axis prompt, toggle ortho on and pick a point above the first point.

Revolve
Look for this button.
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8 In the Revolve Options dialog, click OK.

A surface is created.

9 Save your model.

To join the head and the claw:

1 From the Solid menu, click Union.

2 At the Select surface or polysurface prompt, select the Head. Boolean Union
Look for this button.
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 3 At the Select surface or polysurface to union prompt, select the Claw.

 

4 Save your model.

To make the fillet where the head and the claw meet:

1 From the Solid menu, click Fillet Edge.

2 At the Select edges to fillet ( Radius=0.1 ) prompt, select the edge where the two parts join. Fillet Edge
Look for this button.
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3 At the Select edges to fillet ( Radius=0.1 ) prompt, press ENTER.

The edge has a round on it.

4 Save your model.

To create the Tang:

1 Change to the Curve layer.

2 Create one of the curves for the tang of the hammer.

Make sure that it intersects the claw.
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3 Mirror to create the other curve.

To create the shape curve for the tang and the handle:

Create the shape curve for the tang in the right viewport. This curve will also be used for the handle.

1 Turn on ortho.  Use the Lines command to create the curve for the tang cross-section curve.  This curve will also be
used for the handle

The height of the line is .375 and the width is .75.
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2 Fillet the corners with a radius of .25.

3 Join the curves

4 Select the joined curve.

5 From the Curve menu, click Edit Tools, then click Rebuild.

Rebuilding the curve eliminates any kinks, which will make a smooth surface with fewer potential problems later in
the modeling process.

6 In the Rebuild Curve dialog, click Preview. If the geometry matches the curve, then click OK. If the geometry
doesn’t match the curve, change the point count and click Preview.

To create the surface for the tang:

1 Change to the Tang layer.

Rebuild Curve
Look for this button.
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2 From the Surface menu, click Sweep 2 Rails.

3 At the Select 2 rail curves prompt, select one of the rail curves (1).

4 At the Select 2 rail curves prompt, select the other rail curve (2).

5 At the Select cross-section curves (Point) prompt, select the shape curve (3).

6 At the Select cross-section curves (Point) prompt, press ENTER.

7 In the Sweep 2 Rails Options dialog, click OK.

Sweep 2 Rails
Look for this button.
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A surface is created.

To finish the tang:

1 From the Transform menu, click Mirror.

2 At the Select objects to mirror prompt, choose the tang surface you created.

3 At the Start of mirror plane prompt, in the Front viewport snap to the endpoint at the lower left corner of the tang
surface.

4 At the End of mirror plane prompt, toggle ortho on and pick a point to the right in the Front viewport.

Mirror
Look for this button.
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5 Join the two surfaces together.

6 From the Solid menu, click Cap Planar Holes.

7 At the Select surfaces or polysurfaces to cap prompt, choose the tang.

8 At the Select surfaces or polysurfaces to cap prompt, press ENTER.

9 Save your model.

To join the tang and the claw:

1 From the Solid menu, click Union.

2 At the Select surface or polysurface prompt, select the tang.

Cap Planar Holes
Look for this button.

Boolean Union
Look for this button.
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 3 At the Select surface or polysurface to union prompt, select the claw.

 

4 Save your model.

To make the fillet where the tang and the claw meet:

1 From the Solid menu, click Fillet Edge.

2 At the Select edges to fillet ( Radius=0.1 ) prompt, select the edge where the two parts join.

3 At the Select edges to fillet ( Radius=0.1 ) prompt, press ENTER.

Fillet Edge
Look for this button.
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The edge has a round on it.

4 Save your model.

To create the Handle:

1 Change to the Curve layer.

2 Create one of the curves for the handle of the hammer.  Make it start at the endpoint of the tang profile curve and end
on the centerline.
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3 Mirror to create the other curve.

To create the surface for the handle:

1 Change to the Handle layer.

2 From the Surface menu, click Sweep 2 Rails.

3 At the Select 2 rail curves prompt, select one of the rail curves.

4 At the Select 2 rail curves prompt, select the other rail curve.

5 At the Select cross-section curves (Point) prompt, select small the curve you drew for the tang.

Sweep 2 Rails
Look for this button.
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This is the same curve you used to create the tang of the hammer.

6 At the Select cross-section curves (Point) prompt, press ENTER.

7 In the Sweep 2 Rails Options dialog, click OK.

A surface is created.

To finish the handle:

1 From the Transform menu, click Mirror.

2 At the Select objects to mirror prompt, choose the surface you created.

3 At the Start of mirror plane prompt, in the Front viewport snap to the one end of the handle edge.
Mirror
Look for this button.
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4 At the End of mirror plane prompt, toggle ortho on and pick a point to the right in the Front viewport.

5 Join the two surfaces together.

6 From the Solid menu, click Cap Planar Holes.

7 At the Select surfaces or polysurfaces to cap prompt, choose the handle.

8 At the Select surfaces or polysurfaces to cap prompt, press ENTER.

9 Save your model.

Cap Planar Holes
Look for this button.
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To create the hole for the handle:

1 Draw a Circle with the center .88 from the end of the handle.  You may have to draw a construction line to help you
position the circle.

2 From the Surface menu, click Extrude, then click Straight.

3 At the Extrusion distance <2.00> (Direction Cap=yes Bothsides Tapered) prompt, type B and press ENTER.

4 At the Extrusion distance (Direction Cap=yes) prompt, type 2 and press ENTER.

5 Use Difference to remove the cylinder from the handle.

6 Save your model.

Extrude Straight
Look for this button.
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To create the fillets for the hole:

1 From the Solid menu, click Fillet Edge.

2 At the Select edges to fillet ( Radius=0.1 ) prompt, type .1 and press ENTER.

3 At the Select edges to fillet ( Radius=0.1 ) prompt, select both edges of the hole.

4 At the Select edges to fillet ( Radius=0.1 ) prompt, press ENTER.

The edge has a round on them.

5 Save your model.

6 Click in the Perspective viewport.

Fillet Edge
Look for this button.
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7 From the Render menu, click Shade.

8 From the Render menu, click Render.

Shade
Look for this button.

Render
Look for this button.
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Modeling a Squeeze Bottle
Some models require more attention to detail.  This is an example of a model that requires precise modeling techniques.
This exercise also requires a number of different surface creation techniques.

The technical drawing is included to help you create a very precise model.

 

Exercise 61— Creating a squeeze bottle:

To start the model:

 1 Start a new model. Save as Bottle.

2 Make the following layers: Construction, Curve, Bottle, BottleTop, Threads, Cap1, Cap2, and CapTop.

3 Change to the Construction layer.
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Create the Bottle Shape

To create the bottle shape, you will draw curves that define the bottom and top edge, then draw a curve that represents the
side shape. You will then create a surface from these defining curves.

To draw a curve that defines the bottom of the bottle:

1 From the Curve menu, click Rectangle, then click Center, Corner.

2 At Center of rectangle (Rounded)  prompt, type R, and press ENTER.

3 At the Center of rectangle prompt, move your cursor into the Top viewport then type 0,0,.25 and press ENTER.

4 At the Corner or length prompt, type 2.25 and press ENTER.

5 At the Width prompt, type 1.25 and press ENTER.

6 At the Point for rounded corner to pass through ( Corner=Arc ) prompt, type .625  and press ENTER.

 

To draw a circle for the top of the bottle:

1 From the Curve menu, click Circle, then click Center, Radius.

2 To start the circle 7.25" above the construction plane, at the Center of circle (Vertical OnCurve) prompt, move your
cursor into the Top viewport, then type 0,0,7.25, and press ENTER.

Centered Rectangle
Look for this button.

Circle
Look for this button.
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3 At the Radius prompt, type .625 and press ENTER.

 

To draw a rectangle that approximates the overall dimension of the bottle:

1 From the Curve menu, click Rectangle, then click Corner, Corner.

2 In the Front view, at the First corner of rectangle (Rounded) prompt, type –2,0 and press ENTER.

3 At the Other corner or length  prompt, type 4 and press ENTER.

4 At Width  prompt, type 7.25 and press ENTER.

 

Rectangle
Look for this button.
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To draw the edge curve:

1 Change to the Curve layer.

2 Draw a curve by control points to define the edge of the bottle in the Front view.

3 Use the rectangle and object snaps to help you establish the correct size.

 
4 The curve will be used to create the surface of the bottle.

To create the surface for the bottle:

1 Change to the Bottle layer.

2 From the Surface menu, click Sweep 2 Rails.

Two-Rail Sweep
Look for this button.
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The curve you created will be the shape curve (3). The rounded rectangle (1) and the circle (2) will be the rails.

3 At the Select 2 rail curves prompt, select the rounded rectangle.

4 At the Select 2 rail curves prompt, select the circle.

5 At the Select cross-section curves (Point) prompt, select the curve.

6 At the Select cross-section curves (Point) prompt, press ENTER.

7 In the Sweep 2 Rails Options dialog, click OK.
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Cap the Top and Bottom

If you close the bottle, thereby creating a solid, Rhino can calculate the bottle’s volume. If you were creating this bottle in
real life, knowing the volume would be important. Normally, a bottle would have to be designed to hold a certain amount
of stuff.

If the edges of the remaining open surfaces are planar curves, you can use the Cap command to close them. The open
edges on the bottle are the top circle and the bottom rounded rectangle, and they are planar.

To cap the top and bottom:

1 From the Solid menu, click Cap Planar Holes.

2 At the Select surfaces or polysurfaces to cap prompt, choose the bottle.

3 At the Select surfaces or polysurfaces to cap prompt, press ENTER.

Flatten the Sides

You will notice that the bottle bulges too much in the Right view. We will create a custom surface to trim the bulge
away.

To create the trimming surface:

1 Change to the Curve layer.

2 In the Right view, draw to curves to approximate the shape at the edge of the bottle and the middle of the bottle.

Cap Planer Holes
Look for this button.
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3 The technical drawing gives dimensions for these curves, but for this exercise you can just approximate these. If you
would like to go further, try to figure out on your own how to draw the curves to the exact specifications.

4 In the Front viewport move the curve with the smaller radius just outside the edge of the bottle.
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5 Mirror the edge curve to the opposite side.

6 Select the three curves you just created.

7 To create a surface defined by the curves you created, from the Surface menu, click Loft.

Loft
Look for this button.



C R E A T I N G  S U R F A C E S

N o t e s :

Robert McNeel & Associates ❑ 333

8 In the Loft Options dialog, click OK.

A lofted surface intersects the bottle.
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9 Mirror the surface to the other side of the bottle.

10 Save your model.

To remove the surface from the bottle:

1 Change to the Bottle layer.

2 From the Solid menu, click Difference.

3 At the Select surface or polysurface prompt, select the bottle.

4 At the Select surface or polysurface to subtract prompt, select the lofted surface. Boolean Difference
Look for this button.

If Difference doesn’t work, try
Union, if Union doesn’t work
try Intersection.  If one boolean
operation doesn’t give you the
right answer, you can
generally try another one until
you get the right answer.
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5 Repeat this process for the other side of the bottle.

6 Shade the bottle to see what it looks like.

Round the Edges of the Shapes

The bottle is now a closed solid. We now want to round off the sharp edges by adding a smooth radius between the edges.

To fillet the edges:

1 From the Solid menu, click Fillet Edge.

2 At the Select edges to fillet (Radius=1.0) prompt, select an edge that was trimmed.
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3 At the Select edges to fillet (Radius=1.0) prompt, select the other edge that was trimmed.

4 At the Select edges to fillet (Radius=1.0) prompt, type .25 and press ENTER.

5 At the Select edges to fillet (Radius=0.25) prompt, press ENTER.

6 Shade the bottle to see the results.

Create the Bottle’s Top

To create the bottle throat, you are going to Revolve a profile curve to create surface, and then add threads.
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To create the profile curve:

1 Change to the Curve layer.

2 In the Front view, use the Line Segments command and an Arc to create a profile curve for the outside and the
inside of the top.

3 Begin the first point at .5,7.25 so it aligns with the profile on the edge of the bottle.

4 Use the technical drawing below to draw the correct dimensions.

Tip: When drawing line segments, you can use object snaps, the distance constraint and ortho to draw precisely. For
example, for the first line type .5,7.25 for the starting point, then simply type .25 to constrain the line to .25 units.
Turn ortho on and drag the line to the right. The line will stop at .25 units from the beginning of the line. For the
vertical line on the left, use the End object snap to pick the end of the first line, type .375 to constrain the distance,
and drag the line up.
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5 Join the segments together.

6 Change to the Bottle Top layer.

To create the top surface:

1 From the Surface menu, click Revolve.

2 At the Select curve to revolve prompt, select the profile curve.

3 At the Start of revolve axis prompt, snap to the center of the circle at the top of the bottle.

4 At the End of revolve axis prompt, pick a point directly above the previous point.
Revolve
Look for this button.
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5 In the Revolution Options dialog box, click Delete curve to revolve, and click OK

The top is created.

 

Adding the threads

To add the threads, you will Sweep a profile shape along a path drawn with the Helix command.

To create the path curve helix:

1 Change to the Curve layer.

2 From the Curve menu, click Helix.
Helix
Look for this button.
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3 At the Start of axis (Vertical AroundCurve) prompt, snap to the center point at the bottom of the area to be threaded.

4 At the End of axis prompt, snap to the center at the top of the area to be threaded..

5 To set the radius, at the Radius prompt, pick a point near the edge that is slightly smaller than the outside edge of the
area to be threaded.
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6 In the Helix / Spiral dialog, change the turns to 1.5, check Reverse twist, then click OK.

To draw the thread profile:

1 Draw a triangle using the Polygon command for the thread as shown below.

2 Select the triangle you created.

3 From the Transform menu, click Array, then click Along Curve.

4 At the Select path curve prompt, select the helix near the bottom.
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5 In the Array along curve options dialog box, in the Number of items box, type 5, under Style, click Roadlike, and
then click OK.

6 At the Click in a viewport to choose a Cplane, click in the Top viewport.

7 It might be a good idea at this point to change your perspective view so you can see the profile curves easier.

8 Delete the first and last profile curve.

9 The remaining profile curves will be used to create a surface.

To create the thread surface:

1 Change to the Bottle layer.

2 You can see the helix and profile curves easier if you Hide the bottle top at this point.
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Use the sweep along path command to create a surface that starts a point at one end of the helix, goes through each
profile and ends at a point at the other end of the helix.

3 From the Surface menu, click Sweep 1 Rail.

4 At the Select rail curve prompt, select the helix.

5 To start the surface at a point, at the Select cross-section curves (Point)  prompt, type p, and press ENTER.

6 At the Start of 1-rail sweep prompt, use the End object snap to pick one end of the helix (1).

7 At the Select cross-section curves (Point) prompt, select the first profile curve (2) along the helix.

8 At the Select cross-section curves (Point) prompt, select the next profile curve (3) along the helix.

9 At the Select cross-section curves (Point) prompt, select the next profile curve (4) along the helix.

10 To end the surface at a point, at the Select cross-section curves (Point) prompt, type p, and press ENTER.

11 At the End of 1-rail sweep prompt, use the End object snap to pick the other end of the helix (5).

Sweep Along One Rail
Look for this button.
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12 At the Matching seams and directions...Select seam point to adjust. Press Enter when done ( FlipDirection
Automatic Natural )prompt, press ENTER.

13 In the Sweep 1Rail Options dialog, change the Style to Roadlike - Top, then click OK.
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14 Shade the model.

15 Render the model.

Bottle Caps

If the class is not ready to move on, you can practice additional surface modeling techniques by creating the caps for the
model.  Use the technical drawing to help.
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Modeling an End Table
In this exercise you use one rail sweeps to make an end table with freeform tapered legs.

Exercise 62— Practice using One-Rail Sweeps:

♦ Open the Table model.

To create the legs:

1 From the Surface menu, click Sweep 1 Rail.

2 At the Select rail curve prompt, select the path curve (1) for the leg.

3 At the Select cross-section curves (Point) prompt, select the shape curve for both ends of the leg (2,3).

4 At the Select cross-section curves (Point) prompt, press ENTER.
Sweep along 1 Rail
Look for this button
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5 At the Matching seams and directions...

Select seam point to adjust. Press ENTER when done (FlipDirection Automatic Natural): prompt, press ENTER.
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6 In the Sweep 1 Rail Options dialog, click OK.

The table leg is created. Note the nice transition from one cross-section curve to the other.

To create the brace:

1 Change to the Braces layer.

2 From the Surface menu, click Sweep 1 Rail.

3 At the Select rail curve prompt, select the path curve (1) for the brace.

4 At the Select cross-section curves (Point) prompt, select the shape curve for both ends of the brace (2,3). Sweep along 1 Rail
Look for this button
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5 At the Select cross-section curves (Point) prompt, press ENTER.

6 At the Matching seams and directions...

Select seam point to adjust. Press ENTER when done (FlipDirection Automatic Natural): prompt, press ENTER.
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7 In the Sweep 1 Rail Options dialog, click OK.

The table brace is created.

To create the top:

1 Change to the TOP layer.

2 From the Surface menu, click Sweep 1 Rail.

3 At the Select rail curve prompt, select the ellipse.

4 At the Select cross-section curves (Point) prompt, select the shape curve for the top. Sweep Along Path
Look for this button.
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5 At the Select cross-section curves (Point) prompt, press ENTER.

6 In the Sweep 1 Rail Options dialog, click OK.
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The surface for the rim of top is created.

To finish the table:

1 Select all of the surfaces you created.

2 From the Solid menu, click Cap Planar Holes.

Six caps were created.
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3 Shade the Perspective viewport.

4 Polar array the brace and the leg to finish the model.  You will need to array them around 0,0 in the Top viewport.
Array six items, but you will only need four legs and braces. Delete the extras.
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5 Shade the Perspective viewport.

6 Render the Perspective viewport.

7 Save your model. We will use this in Exercise 63.
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11 
Importing and Exporting
Models

Rhino supports many different import and export formats, making it possible to model in Rhino and then export your
model to downstream processes. For a complete list of import and export options refer to Rhino Help Topic "Importing
and exporting Rhino file information."

Supported formats Description

3DS MAX Rhino has free plug-ins for 3DS MAX that will read Rhino mesh objects into 3DS MAX. The plug-
in for MAX2 will import some NURBS objects.

Rhino also writes 3DS files.

AutoCAD DWG/DXF Reads and writes R12, R13, and R14.

IGES IGES files contain NURBS geometry, object property, layer, and notes information.

Export options are included for CamSoft, Catia, FastSURF, Mastercam, HP ME30, Mechanical
Desktop, MicroStation, Pro/E NT, Pro/E UNIX, SCRC’s I-DEAS, SOFTIMAGE, Solid Edge,
SolidWorks, TekSoft, Unigraphics, and custom IGES types (click New Type).

Rhino's IGES importer will read all IGES files.

Adobe Illustrator Exports the curves as a 2-D snapshot from the current view.

Lightwave LWO

POV-Ray

All Rhino objects are exported as polygonal mesh objects.

Wavefront OBJ Supports meshes and NURBS.

RenderMan RIB Exports nurbs objects as RenderMan .rib files.
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Supported formats Description

STL Reads and writes STL files.

Windows Metafile A 2-D representation of the current viewport is exported to the WMF file.

Importing and exporting Rhino file information
When you export to a format like 3DS or DWG, Rhino has to convert from smooth NURBS surfaces to a polygon mesh
representation made of triangles. To do a good approximation of the curved surfaces, Rhino can sometimes use a lot of
polygons. The density of triangles can be adjusted when exporting.  You can create a mesh to export or Rhino can create
the mesh during the export process.

There are two methods to export models to other formats.  You can "Save As" and choose a specific export format to
export an entire model.  You can select some objects and "Export Selected" then choose a specific export format to
export a portion of the model.  In the following exercise both methods will be used.

Exercise 63— Exporting Models:

To export a model to AutoCAD:

1 Open the Table model.

2 From the File menu, click Save As.



I M P O R T I N G  A N D  E X P O R T I N G  M O D E L S

N o t e s :

Robert McNeel & Associates ❑ 357

3 In the Save As dialog, change the Save as type to AutoCAD DWG.

4 In the file name box type Table and click Save.

5 In the AutoCAD Export Options dialog, Write Surfaces as Meshes, Write Curves as Splines, Write Meshes as
Polyface Meshes, AutoCAD Version Release 14, check Use Simple Entities, and click OK.
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6 In the Create polygon mesh from NURBS object dialog, click Preview.

7 Adjust the slider all the way to the left for Fewer polygons and click Preview.

Note that the table top mesh is very angular, not a good approximation.

8 Move slider to the right and Preview until the mesh is good, then click OK.
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9 When this drawing is opened in AutoCAD it will be made up of meshes.

This would be useful for rendering with a third-party program like AccuRender®.

To export a model to IGES:

1 Select one of the table legs.

2 From the File menu, click Export Selected.

3 In the Export Selected Objects dialog, change the Save As Type to IGES, type LEG in the File Name window, then
click Save.

4 In the IGES Export dialog, select Mechanical Desktop as the IGES type, click Detailed Controls, the click OK.

Detailed controls allows the user more input.

5 Click Cancel to terminate, or OK to create the IGES file.
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Creating mesh objects
Although Rhino uses NURBS as its primary construction tool, you may want to turn some of your objects into triangle
meshes.

If you are exporting objects to another application that uses meshes like 3D Studio, it is often best to convert the object to
a mesh first so you have more control.

Button Command Description

Mesh from
NURBS
object

Creates approximating meshes from an NURBS objects.

Mesh Plane Creates a rectangular mesh plane.

Mesh Box Creates a rectangular mesh box.

Mesh
Cylinder

Creates a mesh cylinder.

Mesh Cone Creates a mesh cone.

Mesh Sphere Creates a mesh sphere.

Apply Mesh
to NURBS
Surface

Creates a morph target for animation programs. Creates a mesh from a surface.

Explode
Mesh

Explodes a mesh into component mesh surfaces.

Hide Control
Points

Hides part of a mesh by hiding selected control points.

Show Control
Points

Shows all hidden control points of a mesh.
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Exercise 64— Practice creating a mesh for export:

To Create a Mesh:

1 Select the Table Top.

2 From the Tools menu, click Polygon Mesh, then click From NURBS Object..

3 In the Create polygon mesh from NURBS object dialog, click OK.

The mesh can be exported. This gives you more direct control over the meshes you export to programs that require
meshes.

Mesh from NURBS object
Look for this button.
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Making a 2D drawing from a 3D model
Rhino has the ability to generate a two-dimensional drawing from a three-dimensional model, by projecting the geometry
to the world coordinate plane, and align the views.  Options for first angle projection or third angle projection are
available.  In addition to the three orthographic views, a two dimensional pictorial drawing is also generated. The
geometry may have duplicate segments and hidden lines will not be removed.

Options for creating 4 views: three parallel views and a perspective view, or single views of individual viewports are
supported.

Make2D creates a two-dimensional drawing from a model of one viewport.  Select the model in the viewport that
displays the view you want to make. Make2D4View makes a two-dimensional drawing for all four views.  Select the
model in the perspective viewport to get all four projections.  If you select the model in a parallel viewport, you will get
three views excluding the perspective view.

Exercise 65— Practice making a 2D drawing for export:

To create a 2D drawing from a 3D model:

1 Open the Vblock1 model.

2 From the Curve menu, click From Objects, then click 2-D Utilities, then click Make 2-D Drawing with 4 Views.

3 At the Select objects to draw ( ProjectionAngle=US ) prompt, select the V-Block in the perspective view.

4 At the Select objects to draw ( ProjectionAngle=US ) prompt, press ENTER.

The 2D drawings are created in the Top viewport near the origin on the World xy plane. View them in the Top
viewport.

5 Maximize the Top viewport.
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6 Zoom Extents.

To export the 2D drawing to AutoCAD:

1 From the Edit menu, click Select, then click All, click On Layer… , then click 2d drawing .

The 2D objects are highlighted.

2 From the File  menu, click Export Selected .

3 Change the Save as type  to AutoCAD  DWG, the File name  to Vblock1.dwg,  then click Save.
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4 In the AutoCAD Export Options dialog, Write Surfaces as Meshes, Write Curves as Splines, Write Meshes as
Polyface Meshes, AutoCAD Version Release 14, check Use Simple Entities, Simplify tolerance 0.007, click OK.
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5 Start AutoCAD and open the Vblock1.DWG. The drawing can be dimensioned, linetypes can be changed, and layers
can be added for plotting.
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12 Rendering

Rendering your model
Rendering is available for showing your model as if it was photographed. While the Rhino renderer may be good enough
for much of your work, use a separate rendering application for higher quality results.

There are two renderers in Rhino:

• A quick renderer, which does a gray-scale shaded preview image.

• A more sophisticated renderer, which uses color, uses spotlights, displays shadows and does anti-aliasing.  It also
allows the attachment of textures and bump maps. In this exercise we will focus on the full renderering capability.

Exercise 66— Practice rendering a model:

To render a model:

1 Open the Screwdriver1 model.

2 Click in the Perspective viewport.

Shade
Look for this button.
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3 From the Render menu, click Shade.

The viewport is render in gray tones.

4 From the Render menu, click Render.

A display window appears with the current viewport rendered in gray tones. You can close the Display Window
without disturbing your model.  Now we will place some lights, then add color and shine to the model.

To place a light:

We will start with a standard lighting scheme.  You can experiment to develop your own lighting schemes later.

Render
Look for this button.
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1 Zoom out in the Top and the Front viewport.

2 Change to the Light 1 layer.

3 From the Render menu, click Create Spotlight.

4 At the Base of cone (Vertical) prompt, pick a point near the center of the screwdriver and slightly above it in the
Front viewport.

5 At the Radius <1> (Diameter) prompt, pick a point so that the radius is larger than the entire screwdriver in the Top
viewport.

Spotlight
Look for this button.
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6 At the End of cone prompt, hold down the control key a pick a point below and to the left in the Top viewport.

This will start elevator mode.

7 At the End of cone prompt, click above the object in the Front viewport.

This will be your main light.

8 Click in the Perspective viewport.
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9 From the Render menu, click Render.

The image has some highlights and shadows.

To place a second light:

1 Zoom out in the Top and the Front viewport.

2 Change to the Light 1 layer.

3 From the Render menu, click Create Spotlight.

Spotlight
Look for this button.
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4 At the Base of cone (Vertical) prompt, pick a point to the right and slightly below the screwdriver and covers about
half of it in the Top viewport.

5 At the Radius <1> (Diameter) prompt, pick a point so that the radius is larger than the entire screwdriver in the Top
viewport.
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6 At the End of cone prompt, click to the right and slightly below the object in the Top viewport.

This will be your secondary (fill) light.

7 Click in the Perspective viewport.

8 From the Render menu, click Render.

The image is washed out on the front edge.  Next, we will tone down the fill light to fix this problem.

To assign a color to the light:

1 Select the secondary light cone.
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2 From the Edit menu, click Object Properties.

The Object Properties dialog appears.

Object Color
Look for this button.
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3 In the Object Properties dialog, click the Render color.

The Choose a Color dialog box appears.

4 Type a value of 160 and click OK.

5 In the Object Properties dialog, click OK.



R E N D E R I N G

N o t e s :

Robert McNeel & Associates ❑ 376

6 From the Render menu, click Render.

The image is not washed out. The lighting can be adjusted as necessary.

To assign a color to the handle:

1 Select the handle.
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2 From the Edit menu, click Object Properties.

The Object Properties dialog appears.

Object Color
Look for this button.
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3 In the Object Properties dialog, click the Render color swatch.

The Choose a Color dialog box appears.

4 Pick a color, like Yellow, then click OK.

5 To give the handle a highlight, check the Highlight box.  Start with a value of 20.

A highlight of 0 means that the object isn’t shiny at all and it won’t have a specular highlight. A low value of
highlight makes the shiny spot to be small, and the object will look more glossy. As highlight increases in value, the
shiny spot gets large - this makes the object look more like it is made out of a reflective material.

The shiny spot only appears when you are looking at an object at a certain angle relative to the angle of the light.

6 In the Object Properties dialog, click OK.
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7 From the Render menu, click Render.

The highlights should look better.

To assign a color to the blade:

1 Select the blade.
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2 From the Edit menu, click Object Properties.

The Object Properties dialog appears.

Object Color
Look for this button.
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3 In the Object Properties dialog, click the Render color.

The Choose a Color dialog box appears.

4 Pick a color, like Light Gray, then click OK.

5 To give the blade a highlight, check the Highlight box.  Start with a value of 40.

6 In the Object Properties dialog, click OK.
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7 From the Render menu, click Render.

The highlights should look better.

To add a bumpy surface to the handle:

1 Select the handle.
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2 From the Edit menu, click Object Properties.

The Object Properties dialog appears.

3 In the Object Properties dialog, click the Browse button next to Bump.

You can use any bitmap file for a bump. The bumps come from the pattern of light and dark in the bitmap image.

4 In the Open bitmap file dialog, select Pattern.jpg, then click Open.

5 Click OK to close the Object Properties dialog.

Object Color
Look for this button.
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6 From the Render menu, click Render.

The surface of the handle has a bumpy appearance.

To add a texture to the handle:

For this part we are going to change layers to view a different handle.
1 From the Edit menu, click Layers, then click Edit.

2 Make the Handle 2 layer current and turn off the Handle 1 layer, then click OK.

3 Select the new handle. Layer
Look for this button.
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4 From the Edit menu, click Object Properties.

The Object Properties dialog appears.

5 In the Object Properties dialog, set the Highlight to 20.

6 In the Object Properties dialog, click the Browse button next to Texture.

You can use any bitmap file. The color of the bitmap is rendered as applied to the object.

7 In the Open bitmap file dialog, select Wood009.jpg, then click Open.

8 Click OK to close the Object Properties dialog.

Object Color
Look for this button.
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9 From the Render menu, click Render.

The surface of the handle is textured with a wood grain texture.

To make the blade transparent:

1 Select the blade.
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2 From the Edit menu, click Object Properties.

The Object Properties dialog appears.

3 In the Object Properties dialog, set the Transparency to 60.

Transparent objects will look more like plastic than glass. Rhino does not have the kind of refraction capability
needed to make realistic glass. In addition, shadow color for transparent objects matches the ambient light color and
not the color of the transparent object.

4 Click OK to close the Object Properties dialog.

Object Color
Look for this button.
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5 From the Render menu, click Render.

The blade will appear transparent.
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13 Printing

Printing
Printing a wireframe image of your model directly from Rhino is supported. Options for scaling and printing in color are
available.  Images in the current viewport or all viewports can be printed. Rhino uses your windows printing device for
output. While printing to scale is supported, there is no utility for hidden line removal.

Exercise 67— Practice printing:

To print a wireframe image of the model:

1 Open the Swing Bracket1 model.

2 From the Tools menu, click Options.

3 In the Grid tab, uncheck Show Grid, Show Grid Axes, and World Axes Icon, then click OK.

4 From the File menu, click Print Setup.



P R I N T I N G

N o t e s :

Robert McNeel & Associates ❑ 390

5 In the Print Setup dialog, click Landscape, adjust any other options appropriate for your printer or plotter, then
click OK.

6 From the File menu, click Print.

7 In the Print dialog, check Print All Viewports, uncheck Print to scale and Print in color if necessary, then click OK.
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The wireframe images in all viewports will be printed.

To print a wireframe image of the current viewport to a scale:

1 Click in the Front viewport.

2 From the File menu, click Print.
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3 In the Print dialog, check Print Active Viewport and Print to scale, change the 1 Rhino unit = to 1, then click OK.

The Front view image is printed to a scale of 1=1.

To print a rendered image:

1 Click in the Perspective viewport.

2 From the Render menu, click Render.

3 In the Display Window, click File, the click Print.

The rendered image will be printed to your default Windows printing device, which may be different from what you
set in Print Setup.
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14 Rhino Options

Rhino Options
The Options dialog box shows most of the settings that affect your overall modeling environment. Use it to toggle them
or redefine them.

Exercise 68— Practice changing Options:

To access the Rhino Options dialog box:

1 From the Tools menu, click Options. The Options dialog box appears.

2 Click on the Modeling Aids tab.

The Modeling Aids tab controls,Grid Snap, Ortho, Planar mode, Object Snap and Trim/Extend Options.

The Options can be toggled on and off from the dialog or from the status bar.  To change the options for ortho or
object snap type new values in the boxes.  In an earlier exercise we changed the Ortho setting so that it snapped every
30 degrees.

In the object snap area, Project to Cplane projects the snap point to the construction plane even though the object
snap point might be in 3D space.

In the Trim/Extend area, Extend Lines extends cutting edges or boundary edges to intersect the object to trim or
extend. Use Apparent Intersections allows trim, extend and intersection object snap to work if visually intersecting
objects are not actually touching.

3 Click on the Appearance tab.
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The Appearance tab controls the appearance of the Rhino window.

4 Click on the Gray rectangle next to Viewport background and change it to a different color.

5 Check the Crosshairs box.

6 Click on the Shortcut Keys tab.

The Shortcut Keys tab sets up shortcut keys for Rhino commands.

7 Type Lockosnap in the box next to the F5 key.

This gives you a key that toggles your persistent object snaps between on and locked.

8 Click on the Aliases tab.

The command Aliases tab allows the user to create custom aliases for Rhino commands.
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9 Click New.

A cursor moves into the white area of the dialog.

10 Type L, then press the TAB key.

11 Type ! Lines.

The apostrophe acts as a cancel.

By typing L and pressing ENTER at the command line, you can begin the Lines command.

12 Click on the View tab.

The View tab has pan, zoom, rotate, and redraw controls.

13 Click on the General tab.

The General tab configures mouse selection methods, the number of undos retained in memory, startup commands,
recent command list limit, AutoSave control, and don’t repeat commands.
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14 Click on the Grid tab.

The Grid tab configures grid, grid axes, and axis icons. We changed the snap spacing in an earlier exercise.

15 Click on the Render tab.

The Render tab controls render options.

16 Click on the Units tab.

The Units tab controls the unit system and the tolerance settings.

17 Click on the Files tab.

The Files tab sets the location of template files and the autosave files.

18 Click OK to close the Options dialog.

19 Try the Lines alias and the Lockosnap toggle. Note how your cursor has changed.
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15 
Creating Custom Toolbar
Layouts

The Toolbar Layout
The toolbar layout is the arrangement of toolbars containing command buttons on the screen. The toolbar layout is stored
in a workspace file, that you can open and save. Rhino comes with a default toolbar layout, and automatically saves the
active toolbar layout before closing. You can create your own custom layouts and save them for later use.

You must use an external file manager to delete a toolbar layout file.

Exercise 69— Customizing a Toolbar Layout:

To create a custom toolbar layout:

1 Begin a new model.

2 From the Tools menu, click Toolbar Layout, then Save As.

3 In the Save Workspace As dialog, type Level 1 in the File name box, and click OK.

A new toolbar layout file has been created.  Toolbar layouts are saved with a .ws extension.  We will use this new
toolbar layout to do some customization.
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To show another toolbar:

1 From the Tools menu, click Toolbar Layout, then click Edit.

The toolbars dialog appears.

2 In the Toolbars dialog, double click Curve Tools to show the toolbar.

3 In the Toolbars dialog, double click Curve Tools to hide the toolbar

4 Show the Curve Tools toolbar again, then click Close.
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5 Dock the Curve Tools toolbar at the right by dragging it to the right edge until it changes to a vertical shape, then
releasing your mouse button.
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To save your toolbar layout:

♦ From the Tools menu, click Toolbar Layout, then click Save.

To create a new toolbar:

1 From the Tools menu, click Toolbar Layout, then click Edit.

2 In the Toolbars dialog, click New Toolbar.

3 In the Toolbar Properties, type Test in the Name box, then click OK.

A new toolbar is created with one blank button in it.

 
4 In the Toolbars dialog, click Close.
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To edit the new button:

1 Hold down the SHIFT key and right click on the blank button.

2 In the Edit Button dialog, type Delete Selected Objects | Delete All Objects in the Tooltip box.

3 In the Edit Button dialog, type ! Delete in the Left Button Command box.

4 In the Edit Button dialog, type ! SelAll Delete in the Right Button Command box.

5 Click Edit Bitmap.
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6 In the Edit Bitmap dialog, make a picture to represent the button face image, then click OK.

7 In the Edit Button dialog, click OK.
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To copy a button from one toolbar to another:

1 From the Main toolbar, flyout the Curve toolbar, and tear it off.

2 While holding down the CTRL key, drag the Curve From Control Points button to the new toolbar and drop it.

To add a button to a toolbar:

1 From the Tools menu, click Toolbar Layout, then click Edit.

2 Highlight the Test toolbar in the list.

3 Click New Button.

A blank button is added to the Test toolbar.

4 Click Close to close the dialog.

To open the standard toolbar layout:

1 From the Tools menu, click Toolbar Layout, then click Open.

2 In the Save Changes dialog, click Yes.

3 Select Default.ws, then click Open.
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Command line history, 13
Construction planes, 56
Control point editing, 173
Coordinates, 48
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Delete, 43
Deleting objects, 43
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Drawing Circles, 73
Drawing Ellipses and Polygons, 94
Drawing Freeform Curves, 31, 99
Drawing in 3d Space, 59
Drawing Lines, 29
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Entering Commands, 12
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Export, 356, 359
Exporting models, 355
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Extending objects, 163
Extrude, 276, 277
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Layer colors, 39
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Lock, 40

Making a 2D drawing from a 3D
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Mirror, 138
Mirroring objects, 138
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Modeling Aids, 32
Moving objects, 132

Object Snaps, 64
Offseting objects, 151

Parallel vs. Perspective Projection, 111
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Placing lights, 215
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Polar Coordinates, 50
Printing, 389, 392

Rebuild, 192
Relative Coordinates, 49
Rendering, 212
Rendering your model, 367
Repeating commands, 13
Revolve, 282
Rhino Interface, 7
Rhino Settings, 395
Rotating objects, 137

Save, 36
Saving your work, 36
Scaling objects, 140
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Splitting objects, 160
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The Mouse, 12
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Toolbar, 402
Toolbar Layout, 399
Toolbars, 9
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Tooltips, 9
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