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Chapter 1: Looking at the Work Area

 

he Adobe Photoshop and Adobe 
ImageReady work area includes the 
command menus at the top of your screen 

and a variety of tools and palettes for editing and 
adding elements to your image. You can also add 
commands and filters to the menus by installing 
third-party software known as plug-in modules.

 

Using the toolbox

 

The first time you start the application, the 
toolbox appears on the left side of the screen. The 
tools in the toolbox let you select, paint, edit, and 
view images. These tools have options that appear 
in the options bar. (See “Using the options bar” on 
page 2.) Other controls choose foreground and 
background colors and change the slice or screen 
display mode. 

For more information on the foreground and 
background color controls, see “Choosing 
foreground and background colors” on page 195.

For an overview of each tool, see 
online help.

 

To show or hide the toolbox:

 

Choose Window > Show Tools or Window > Hide 
Tools.

 

To move the toolbox:

 

Drag the toolbox by its title bar.

 

Selecting tools

 

You select a tool by clicking its icon in the toolbox. 
A small triangle at the lower right of a tool icon 
indicates hidden tools.

 

To select a tool:

 

Do one of the following:

 

•

 

To select a visible tool, click its icon.

 

•

 

To select a hidden tool, position the pointer on 
the visible tool and hold down the mouse button 
until the tools list appears. Then, click the tool you 
want.

 

Use the following tool shortcuts: 

 

• 

 

To select a tool quickly, press its shortcut 
key on the keyboard. To display the shortcut key for 
a tool, place the pointer over the tool in the toolbox. 

 

• 

 

To cycle through a set of hidden tools, press Shift 
and press the visible tool’s shortcut key.

 

Using the tool pointers

 

When you select most tools, the mouse pointer 
matches the tool’s icon. The marquee pointer 
appears by default as cross-hairs, and the text tool 
pointer as an I-beam. 

Each default pointer has a different 

 

hot spot

 

, where 
an effect or action in the image begins. With all 
tools except the move tool and the type tool, you 
can switch to precise pointers, which appear as 
cross-hairs centered around the hot spot.

T
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To set the tool pointer appearance:

 

1

 

Do one of the following:

 

•

 

(Photoshop) Choose Edit > Preferences > 
Display & Cursors.

 

•

 

(ImageReady) Choose Edit > Preferences > 
Cursors.

 

2

 

Choose a tool pointer setting:

 

•

 

Click Standard under Painting Cursors, Other 
Cursors, or both to display pointers as tool icons.

 

•

 

Click Precise under Painting Cursors, Other 
Cursors, or both to display pointers as cross-hairs. 

 

•

 

Click Brush Size under Painting Cursors to 
display the painting tool cursors as brush shapes 
representing the size of the current brush. Brush 
Size cursors may not display for very large brushes.

 

3

 

Click OK.

The Painting Cursors options control the pointers 
for the following tools:

 

•

 

(Photoshop) Eraser, pencil, airbrush, paint-
brush, rubber stamp, pattern stamp, smudge, blur, 
sharpen, dodge, burn, and sponge tools.

 

•

 

(ImageReady) Paintbrush, pencil, and eraser 
tools. 

The Other Cursors options control the pointers 
for the following tools:

 

•

 

(Photoshop) Marquee, lasso, polygon lasso, 
magic wand, crop, slice, eyedropper, pen, gradient, 
line, paint bucket, magnetic lasso, magnetic pen, 
measure, and color sampler tools.

 

•

 

(ImageReady) Marquee, lasso, magic wand, 
eyedropper, paint bucket, and slice tools.

 

To toggle between standard and precise cursors 
in some tool pointers, press Caps Lock. Press 

Caps Lock again to return to your original setting.

 

Using the options bar

 

Most tools have options that are displayed in the 
options bar. Some settings in the options bar are 
common to several tools (such as painting modes 
and opacity), and some are specific to one tool 
(such as the Auto Erase setting for the pencil tool). 

You can move the options bar anywhere in the 
work area or dock it at the top or bottom of the 
screen. 

The options bar includes an area for docking other 
palettes, providing quick access to palettes that you 
reference briefly while using the application, such 
as Swatches and Actions. The docking area is only 
available when the options bar is docked at top or 
bottom of your screen, and when using a 
resolution of at least 800 pixels x 600 pixels.

 

To display the options bar:

 

Do one of the following:

 

•

 

Choose Window > Show Options. 

 

•

 

Double-click a tool in the toolbox (except the 
zoom or hand tool). 

 

Magic Wand options bar 

 

<<Art OK at 40%? or choose a 
shorter options bar?>>
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To return to a tool’s default settings:

 

Do one of the following:

 

•

 

Choose Reset Tool from the context menu 
located over the tool icon on the options bar or in 
the Windows menu. 

 

•

 

To return all the tools to their default settings, 
choose Reset All Tools from the context menu 
located over the tool icon on the options bar or in 
the Windows menu. 

 

To move the options bar:

 

Drag the title bar on the left edge of the options 
bar. The title bar will become a gripper bar when 
the options bar is docked at the top or bottom of 
the screen.

 

To dock other palettes in the options bar:

 

1

 

Drag the options bar to the top or bottom of the 
screen until the docking well appears.

 

2

 

Drag the desired palette’s tab into the docking 
well so that the docking well is highlighted.

Palettes are technically hidden when in the docked 
in the options bar. The Window menu item 
associated with a docked palette will say Show 
when it is docked. Showing a palette while it is in 
the well only shows the palette until you click 
outside the palette.

 

Note:

 

 If you undock the options bar while palettes 
are docked, palettes will no longer be visible. When 
you show the palette again, it will move to the upper 
right corner of the screen.

 

Using palettes

 

Palettes help you monitor and modify images. By 
default, these palettes appear stacked together in 
groups. You can display or hide them as you work. 

 

To show or hide palettes:

 

Do one of the following:

 

•

 

To show or hide all open palettes, the options 
bar, and the toolbox, press Tab. 

 

•

 

To show or hide all palettes and the options bar, 
press Shift+Tab.

 

To show or hide one palette:

 

Choose Window > Show to display the selected 
palette at the front of its group. Choose Window > 
Hide to conceal the entire group of which the 
selected palette is a part. 

 

Changing the palette display

 

You can rearrange your palettes to make better use 
of your work area by using the following 
techniques: 

 

•

 

To make a palette appear at the front of its group, 
click the palette’s tab, or choose Window > Show

 

•

 

To move an entire palette group, drag its title bar.

 

•

 

To rearrange or separate a palette group, drag a 
palette’s tab. Dragging a palette outside of an 
existing group creates a new group. 

 

•

 

To move a palette to another group, drag the 
palette’s tab to that group.
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•

 

To display a palette menu, position the pointer 
on the triangle ( ) in the upper right corner of 
the palette, and hold down the mouse button. 

 

•

 

To change the size of a palette, drag any corner of 
the palette (Windows) or drag the size box at its 
lower right corner (Mac OS). Not all palettes can 
be resized.

 

•

 

To collapse a group to palette titles only, click the 
Minimize/Maximize box (Windows) or the Zoom 
box (Mac OS). Or double-click a palette’s tab, if 
the palette is currently at minimum size. You can 
still access the menu of a collapsed palette.

 

Click to collapse or expand palette. 

 

A.

 

 Windows

 

B.

 

 Mac OS

 

•

 

(ImageReady) To show or hide options for 
palettes that include hidden options (the 
Optimize, Color, Type, Layer Options, and Slice 
palettes), click the Show Options button ( ) on 
the palette tab to cycle through palette displays, or 
choose Show Options or Hide Options from the 
palette menu.

 

Docking palettes together

 

Docking palettes together lets you view multiple 
palettes at the same time and move them as a 
group.

 

Note:

 

 You cannot dock palette groups together.

In Photoshop, you can also dock palettes in the 
options bar. (See “Using the options bar” on 

page 2.)

 

To dock palettes together:

 

Drag a palette’s tab to the bottom of another 
palette so that the bottom of the second palette 
is highlighted.

To move an entire docked group, drag its title bar.

 

Setting the positions of palettes and 
dialog boxes

 

The positions of all open palettes and moveable 
dialog boxes are saved when you exit the program. 
Alternatively, you can always start with default 
palette positions or restore default positions at any 
time.

 

To reset palettes to the default positions:

 

Do one of the following:

 

•

 

Choose Edit > Preferences > General, and click 
Reset Palette Locations to Default.

 

•

 

(ImageReady) Choose Window > Arrange > 
Reset Palettes.

 

To always start with the default palette and dialog 
box positions:

 

1

 

Choose Edit > Preferences > General. 

A

B
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Deselect Save Palette Locations. The change 
takes effect the next time you start the application.

 

Using pop-up sliders

 

A number of palettes and dialog boxes contain 
settings that use pop-up sliders (for example, the 
Opacity option in the Layers palette).

 

To use a pop-up slider:

 

Do one of the following:

 

•

 

Position the pointer over the triangle next to the 
setting, hold down the mouse, and drag the slider 
or angle radius to the desired value.

 

•

 

Click the triangle next to the setting to open the 
pop-up slider box, and drag the slider or angle 
radius to the desired value. Click outside the slider 
box or press Enter or Return to close the slider box. 
To cancel changes, press Esc.

 

To increase or decrease values in 10% incre-
ments when the pop-up slider box is open, hold 

down Shift and press the Up or Down arrow key.

 

Using the Info palette 

 

The Info palette displays information about the 
color values beneath the pointer and, depending 
on the tool in use, other useful measurements. 

 

To display the Info palette:

 

Choose Window > Show Info.

(Photoshop) The Info palette displays the 
following information:

 

•

 

When displaying CMYK values, the Info palette 
displays an exclamation point next to the CMYK 
values if the color beneath the pointer or color 
sampler is out of the printable CMYK color 
gamut. (See “Identifying out-of-gamut colors 
(Photoshop)” on page 94.)

 

•

 

When you use the marquee tool, the Info palette 
displays the 

 

x

 

- and 

 

y

 

-coordinates of your starting 
position and the width (W) and height (H) of the 
marquee as you drag. 

 

•

 

When you use the crop tool or zoom tool, the 
Info palette displays the width (W) and height (H) 
of the marquee as you drag. The palette also shows 
the angle of rotation of the crop marquee.

 

•

 

When you use the line tool, pen tool, or gradient 
tool or when you move a selection, the Info palette 
displays the 

 

x

 

- and 

 

y

 

-coordinates of your starting 
position, the change in X (DX), the change in 
Y (DY), the angle (A), and the distance (D) as 
you drag. 

 

•

 

When you use a two-dimensional transfor-
mation command, the Info palette displays the 
percentage change in width (W) and height (H), 
the angle of rotation (A), and the angle of 
horizontal skew (H) or vertical skew (V).

 

•

 

When you use any color adjustment dialog box 
(for example, Curves), the Info palette displays the 
before and after color values of the pixels beneath 
the pointer and beneath color samplers. 
(See “Previewing color values” on page 111.) 

 

<<X-ref destination?>>

 

(ImageReady) The Info palette displays the 
following information:
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• The RGB numeric values for the color beneath 
the pointer.

• The Opacity value for the pixels beneath the 
pointer.

• The hexadecimal value for the color beneath the 
pointer.

• The index color table position for the color 
beneath the pointer.

• The x- and y-coordinates of the pointer. 

• The x- and y-coordinates of your starting 
position (before you click in the image) and your 
ending position (as you drag in the image) when 
you use the marquee tool, the shape tools, the crop 
tool, and the slice tool. 

• The width (W) and height (H) of the selection as 
you drag when you use the crop tool, the shape 
tools, the slice tool, or the zoom tool.

• The percentage change in width (W) and height 
(H), the angle of rotation (A), and the angle of 
horizontal skew (H) or vertical skew (V) when you 
use a Transform or Free Transform command. 

Using context menus
In addition to the menus at the top of your screen, 
context-sensitive menus display commands 
relevant to the active tool, selection, or palette.

To display context menus:

1 Position the pointer over an image or palette 
item.

2 Click with the right mouse button (Windows) 
or hold down Control and press the mouse button 
(Mac OS).

Viewing images
The hand tool, the zoom tools, the Zoom 
commands, and the Navigator palette let you view 
different areas of an image at different magnifica-
tions. You can open additional windows to display 
several views at once (such as different magnifica-
tions) of an image. You can also change the screen 
display mode to change the appearance of the 
Photoshop or ImageReady work area.

Changing the screen display mode

The window controls let you change the screen 
display mode, including menu bar, title bar, and 
scroll bar options. 

To change the screen display mode:

Click a screen mode button in the toolbox:

• The left button ( ) displays the default window 
with a menu bar at the top and scroll bars on the 
sides. 

• The center button ( ) displays a full-screen 
window with a menu bar and a 50% gray 
background, but no title bar or scroll bars. 

• The right button ( ) displays a full-screen 
window with a black background, but no title bar, 
menu bar, or scroll bars. 

Using the document window

<<Still need to doc Uber hide in here.>>
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The document window is where your image 
appears. Depending on the screen display mode 
(see “Changing the screen display mode” on 
page 6), the document window may include a title 
bar and scroll bar.

In ImageReady, the document window allows you 
to switch easily between original and optimized 
views of an image using tabs, and to view the 
original image and multiple versions of an 
optimized image simultaneously. For information 
on changing the view in the document window, 
see “Viewing images during optimization” on 
page 338.

You can open multiple windows to display 
different views of the same file. A list of open 
windows appears in the Window menu. Available 
memory may limit the number of windows per 
image. 

To open multiple views of the same image:

Do one of the following:

• Choose View > New View. 

• (ImageReady) Drag any tab away from the 
document window.

To arrange multiple windows (Windows only):

Do one of the following:

• Choose Window > Cascade (Photoshop) or 
Window > Arrange > Cascade (ImageReady) to 
display windows stacked and cascading from the 
upper left to the lower right of the screen.

• Choose Window > Tile (Photoshop) or 
Window > Arrange > Tile (ImageReady)to display 
windows edge to edge.

• Choose Window > Arrange Icons (Photoshop) 
or Window > Arrange > Arrange Icons 
(ImageReady) to display image icons at the 
bottom of the ImageReady work area.

To close windows:

Choose a command:

• Choose File > Close to close the active window.

• (Windows) Choose Window > Close All to close 
all windows.

Navigating the view area

If the entire image is not visible in the document 
window, you can navigate to bring another area of 
the image into view.

In Photoshop, you can also use the Navigator 
palette to quickly change the view of an image.

To view another area of an image:

Do one of the following:

• Use the window scroll bars.

• Select the hand tool ( ) and drag to pan over 
the image.

To use the hand tool while another tool is 
selected, hold down the spacebar as you drag in 

the image.

To move the view of an image using the Navigator 
palette (Photoshop):

1 Choose Window > Show Navigator.

2 Do one of the following:
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• Drag the view box in the thumbnail of the image, 
which represents the boundaries of the image 
window.

• Click in the thumbnail of the image. The new 
view includes the area you click. 

To change the color of the Navigator palette view 
box (Photoshop):

1 Choose Palette Options from the Navigator 
palette menu.

2 Choose a color:

• To use a preset color, choose an option for Color.

• To specify a different color, click the color box, 
and choose a color as described in “Using the 
Adobe Color Picker” on page 198.

3 Click OK.

Magnifying and reducing the view

You can magnify or reduce your view using 
various methods. The window’s title bar displays 
the zoom percentage (unless the window is too 
small for the display to fit), as does the status bar at 
the bottom of the window. 

Note: The 100% view of an image displays an image 
as it will appear in a browser (based on the monitor 
resolution and the image resolution). See “About 
image size and resolution” on page 21.

To zoom in:

Do one of the following:

• Select the zoom tool ( ). The pointer becomes 
a magnifying glass with a plus sign in its center. 
Click the area you want to magnify. Each click 
magnifies the image to the next preset percentage, 
centering the display around the point you click. 
When the image has reached its maximum magni-
fication level of 6400%, the magnifying glass 
appears empty.

• Choose View > Zoom In to magnify to the next 
preset percentage. When the image has reached its 
maximum magnification level, the command is 
dimmed.

• (ImageReady) Click on the Zoom Level pop-up 
menu at the bottom left of the document window, 
and choose a zoom level.

• (Photoshop) Enter a magnification level in the 
Zoom text box at the lower left of the window.

To zoom out:

Do one of the following:

• Select the zoom tool. Hold down Alt (Windows) 
or Option (Mac OS) to activate the zoom-out tool. 
The pointer becomes a magnifying glass with a 
minus sign in its center. Click the center of the area 
of the image you want to reduce. Each click 
reduces the view to the previous preset percentage. 
When the file has reached its maximum reduction 
level of 3.13%, the magnifying glass appears 
empty.

• Choose View > Zoom Out to reduce to the 
previous preset percentage. When the image 
reaches its maximum reduction level, the 
command is dimmed.



9ADOBE PHOTOSHOP 6.0
User Guide

• (ImageReady) Click on the Zoom Level pop-up 
menu at the bottom left of the document window, 
and choose a zoom level.

• (Photoshop) Enter a reduction level in the Zoom 
text box at the lower left of the window.

To magnify by dragging:

1 Select the zoom tool.

2 Drag over the part of the image you want to 
magnify.

The area inside the zoom marquee is displayed at 
the highest possible magnification. To move the 
marquee around the artwork in Photoshop, begin 
dragging a marquee and then hold down the space 
bar while dragging the marquee to a new location.

To display an image at 100%:

Do one of the following:

• Double-click the zoom tool.

• Choose View > Actual Pixels (Photoshop) or 
View > Actual Size (ImageReady).

To change the view to fit the screen:

Do one of the following:

• Double-click the hand tool. 

• Choose View > Fit on Screen.

These options scale both the view and the window 
size to fit the available screen space. If the image is 
smaller than the monitor size, the image is 
displayed at 100%.

To automatically resize the window when magnifying 
or reducing the view:

With the Zoom tool active, select Resize Windows 
to Fit in the options bar. The window resizes when 
you magnify or reduce the view of the image.

When Resize Windows to Fit is deselected (the 
default), ImageReady maintains a constant 
window size regardless of the image’s magnifi-
cation. This can be helpful when using smaller 
monitors or working with tiled views.

Displaying status information
The status bar at the bottom of the program 
window displays useful information—such as the 
current magnification and file size of the active 
image, and brief instructions for using the active 
tool.

To show or hide the status bar (Windows only):

Choose Window > Show Status Bar or Window > 
Hide Status Bar.
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Displaying file and image 
information
Information about the current file size and other 
features of the image is displayed at the bottom of 
the document window.

Note: In ImageReady, if the document window is 
wide enough, two image information boxes appear, 
enabling you to view two different information 
options for the image at the same time. For more 
information about original and optimized images, 
see “Viewing images during optimization” on 
page 338.

You can also view copyright and authorship infor-
mation that has been added to the file. This infor-
mation includes standard file information and 
Digimarc watermarks. Photoshop automatically 
scans opened images for watermarks using the 
Digimarc Detect Watermark plug-in. If a 
watermark is detected, Photoshop displays a 
copyright symbol in the image window’s title bar 
and updates the Copyright & URL section of the 
File Info dialog box.

To display file information in the document window 
(Photoshop):

1 Click the triangle in the bottom border of the 
document window.

<<keep art?>>

2 Select a view option:

• Document Size to display information on the 
amount of data in the image. The number on the 
left represents the printing size of the image—
approximately the size of the saved, flattened file in 
Adobe Photoshop format. The number on the 
right indicates the file’s approximate size including 
layers and channels. For more information on how 
layers affect file size, see “Managing layered 
images” on page 247. 

• Document Profile to display the name of the 
color profile used by the image.
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• Scratch Sizes to display information on the 
amount of RAM used to process the image. The 
number on the left represents the amount of 
memory that is currently being used by the 
program to display all open images. The number 
on the right represents the total amount of RAM 
available for processing images.

• Efficiency to display the percentage of 
Photoshop operations being performed using 
RAM (as compared to using scratch disk space). If 
the value is below 100%, Photoshop is using the 
scratch disk and therefore is operating more 
slowly.

• Timing to display the amount of time it took to 
complete the last operation.

• Current Tool to view the name of the active tool.

To display image information in the document 
window (ImageReady):

1 Click an image information box at the bottom 
of the document window.

<<update source art?>>

2 Select a view option:

• Original/Optimized File Size to view the original 
and optimized file size images. The first value 
indicates the original image file size. The second 
value (present if the original image has been 
optimized) indicates the optimized image file size 
and file format based on the current settings in the 
Optimize palette. 

• Optimized Information to view the file format, 
file size, number of colors, and dither percentage 
for the optimized image.

• Image Dimensions to view the image’s pixel 
dimensions.
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• Watermark Strength to view the strength of 
the Digimarc® digital watermark in the optimized 
image, if present. For more information on 
using digital watermarks, see “Adding digital 
copyright information with the Digimarc filter” 
in online Help.

• Undo/Redo Status to view the number of undos 
and redos that are available for the image.

<<Reviewers—Please provide descriptions of 
Original in Bytes, Optimized in Bytes, and Opti-
mized Savings options.>>

• Size/Download Time (14.4Kbps/28.8Kbps/
56.6Kbps) to view the file size for the optimized 
image and estimated download time using the 
selected modem speed.

Note: Download times may vary based on Internet 
traffic and modem compression schemes. The value 
displayed is an approximation.

To view additional file information:

Do one of the following:

• (Photoshop) Choose File > File Info. For 
section, choose the attribute you want to view.

• (ImageReady) Choose File > Image Info.

To read a Digimarc watermark:

1 Choose Filter > Digimarc > Read Watermark. If 
the filter finds a watermark, a dialog box displays 
the Creator ID, copyright year (if present), and 
image attributes.

2 Click OK, or for more information choose from 
the following:

• If you have a Web browser installed, click Web 
Lookup to get more information about the owner 
of the image. This option launches the browser 
and displays the Digimarc Web site, where contact 
details appear for the given Creator ID.

• Call the phone number listed in the Watermark 
Information dialog box to get information faxed 
back to you.

<<conditionalize below “PrintOnly” for see 
online help?>>

For information on adding Digimarc water-
marks to images, see “Adding digital 

copyright information” on page 390.

Jumping between applications
You can jump between ImageReady and 
Photoshop to transfer an image between the two 
applications for editing without closing or exiting 
the originating application. In addition, you can 
jump from ImageReady to other graphics editing 
applications and HTML editing applications 
installed on your system.

Jumping to an application saves you from having 
to close the file in one application and reopen it in 
another application. 
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Jumping between Photoshop and 
ImageReady

You can easily jump between Photoshop and 
ImageReady to use features in both applications 
when preparing graphics for the Web or other 
purposes. Jumping between the applications 
allows you to use the full feature sets of both appli-
cations while maintaining a streamlined workflow.

To jump between ImageReady and Photoshop:

Do one of the following:

• Click the Jump To button ( ) in the toolbox.

• Choose File > Jump To > Photoshop.

<<Clarify and document dialog>>

Jumping to another application saves the original 
file.

Jumping to other applications 
(ImageReady)

You can jump to graphics-editing applications and 
HTML-editing applications from within 
ImageReady.

When you install ImageReady, Adobe graphics-
editing and HTML-editing applications currently 
on your system are added to the Jump To 
submenu. You can add more applications, 
including non-Adobe applications, to the Jump To 
submenu. You can also specify which application 
will be launched when using a keyboard shortcut.

When you jump to a graphics-editing application, 
the original file is opened in the destination appli-
cation. When you jump to an HTML editor, the 
optimized file and the HTML file are saved and 
opened in the destination application. If the image 
contains slices, all files for the full image are 
included.

To jump to another application from ImageReady:

1 Choose a method for jumping to the desti-
nation application:

• To launch a graphics-editing application, choose 
Ctrl+Shift+M (Windows) or Command+Shift+M 
(Mac OS). ImageReady launches the application 
you have specified. (See instructions in this section 
for specifying an application to be launched by the 
Jump To keyboard shortcut.) 

• Choose File > Jump To > Other Graphics Editor 
or File > Jump To > Other HTML Editor, and 
select an application from the submenu. 

2 If the file has been modified since the last save, 
choose an option in ImageReady for saving the file:

• Click Save, and save the file with its current 
name and location.

• Click Save As, and save the file with a new name, 
a new location, or both.

To add an application to the Jump To submenu:

1 Create a shortcut (Windows) or an alias 
(Mac OS) for the application you want to add 
to the menu.
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2 Drag the icon for the shortcut or alias into the 
Jump To Graphics Editor or the Jump To HTML 
Editor folder in the Helpers folder in the 
Photoshop folder.

3 Restart ImageReady to view the application in 
the Jump To submenu. 

To specify an application to be launched by the Jump 
To keyboard shortcut:

Place brackets ([]) around the name of the appli-
cation in the Jump To folder, located in the Helpers 
folder in the Photoshop folder. The bracketed 
application is launched when you press 
Ctrl+Shift+M (Windows) or Command+Shift+M 
(Mac OS). The brackets do not appear in the Jump 
To submenu. If no application is bracketed, the 
keyboard shortcut launches Photoshop.

Setting preferences 
Numerous program settings are stored in a prefer-
ences file, located in the registry (Windows) or the 
Preferences folder in your System Folder (Mac 
OS). Among the settings stored in this file are 
general display options, file-saving options, cursor 
options, transparency options, and options for 
plug-ins and scratch disks. Most of these options 
are set in dialog boxes that can be opened through 
the Preferences submenu in the Edit menu. 
Preference settings are saved each time you exit the 
application.

Unexpected behavior may indicate damaged 
preferences. You can restore preferences to their 
default settings to remove damaged preferences. 
Restoring default preferences deletes any custom 
preference settings you had applied. 

To open a preferences dialog box:

1 Choose the desired preference set from the 
Edit > Preferences submenu.

2 To switch to a different preference set, do one of 
the following:

• Choose the preference set from the menu at the 
top of the dialog box.

• Click Next to display the next preference set in 
the menu list; click Prev to display the previous 
preference set.

For information on a specific preference option, 
see the Index.

To restore all preferences to their default settings:

In Windows, press and hold Alt+Control+Shift 
immediately after launching Photoshop or 
ImageReady. Click Yes to restore preferences. 

In Mac OS, open the Preferences folder in the 
System Folder, and drag the following files to the 
Trash:

• (Photoshop) In the Adobe Photoshop 6 Settings 
folder, Adobe Photoshop 6 Prefs and Color 
Settings 

• (ImageReady) Adobe ImageReady 3.0 Prefs

<<reviewers—note inconsistency in file names. 
Please let us know if you make a change.>>
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A new Preferences file will be created the next time 
you start ImageReady.

Monitoring operations
A progress bar indicates that an operation is in 
process. You can interrupt the process or have the 
program notify you when it has finished. 

To cancel operations:

Hold down Esc until the operation in progress has 
stopped (Windows) or press Command+period 
(Mac OS).

To set notification for completion of operations:

1 Choose Edit > Preferences > General.

2 Do one of the following:

• (Photoshop) Select Beep When Done.

• (ImageReady) Select Notify When Done. and 
choose (Mac OS only): System Alert to use your 
system alert for notification or Text to Speech to 
use a spoken notification.

3 Click OK.

Using plug-in modules
<<Reviewers--Where best to describe function of 
Photoshop Only and ImageReady Only folders 
inside the Plug-ins folder?>>

Plug-in modules are software programs developed 
by Adobe Systems and by other software devel-
opers in conjunction with Adobe Systems to add 
features to Photoshop and ImageReady. A number 
of importing, exporting, and special-effects plug-
ins come with your program; they are automati-
cally installed in folders inside the Photoshop 
Plug-ins folder. 

You can select an additional plug-ins folder to use 
plug-ins stored with another application. You can 
also create a shortcut (Windows) or an alias (Mac 
OS) for a plug-in stored in another folder on your 
system. You can then add the shortcut or alias to 
the Plug-ins folder to use that plug-in with 
Photoshop and ImageReady.

Once installed, plug-in modules appear as options 
in the Import or Export menu; as file formats in 
the Open, Save As, and Export Original 
(ImageReady) dialog boxes; or as filters in the 
Filter submenus. Plug-ins may also add new items 
to command menus, new palettes, new toolbars, 
and other new interface features.

Note: <<Reviewers—Is this still true?>> If many 
plug-in modules are installed, Photoshop or 
ImageReady may not be able to list all the plug-ins in 
their appropriate menus. Newly installed plug-ins 
will appear in the Filter > Other submenu.

To install an Adobe Systems plug-in module:

Do one of the following:

• Use the plug-in installer, if provided.

• (Windows) Copy the module into the appro-
priate Plug-ins folder in the Photoshop folder.
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• (Mac OS) Option-drag a copy of the module to 
the appropriate Plug-ins folder inside the 
Photoshop folder. 

Note: When you copy or drag the plug-in files into 
the Plug-ins folder, make sure that the files are 
uncompressed.

To install a third-party plug-in module:

Follow the installation instructions that came with 
the plug-in module.

To select an additional plug-ins folder:

1 Choose Edit > Preferences > Plug-Ins & Scratch 
Disk. 

2 Select Additional Plug-ins Folder.

3 Click Choose, and select a folder or directory 
from the list. Make sure that you do not select a 
location inside the Plug-ins folder. To display the 
contents of a folder, double-click the directory 
(Windows) or click Open (Mac OS).

4 When you have highlighted the additional plug-
ins folder, click OK (Windows) or Select 
(Mac OS).

5 Restart Photoshop or ImageReady for the plug-
ins to take effect.

To view information about installed plug-ins:

Choose Help > About Plug-In and select a plug-in 
from the submenu.

Previewing an image in a 
browser (ImageReady)
You can open a browser while working in 
ImageReady and preview an optimized image in 
the browser. You can preview the image in any 
browser installed on your system. The browser 
displays the image with a caption listing the 
image’s file type, pixel dimensions, file size, and 
compression specifications in the first paragraph, 
and filename and other HTML information in the 
second paragraph. 

When you install ImageReady, all browsers 
currently on your system are added to the Preview 
In menu. You can add additional browsers to the 
menu, and specify which browser will be launched 
when using a keyboard shortcut.

To preview an optimized image in a browser:

Launch a browser:

• Press Ctrl+Alt+P (Windows) or Command+
Option+P (Mac OS). ImageReady launches the 
browser you have specified to be used for 
previewing or the first browser in the Preview In 
alphabetical submenu. 

• Select File > Preview In. Then choose a browser 
from the submenu, and click OK. (Choose Other 
to select a browser not listed in the submenu.)

To add a browser to the Preview In menu:

1 Create a shortcut (Windows) or an alias (Mac 
OS) for the browser you want to add to the menu.

2 Drag the icon for the shortcut or alias into the 
Preview In folder, located in the Helpers folder in 
the Photoshop program folder.
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3 Restart ImageReady to view the browser in the 
Preview In menu. 

To specify a browser to be launched by the Preview In 
keyboard shortcut:

Place brackets ([]) around the name of the browser 
in the Preview In folder, located in the Helpers 
folder in the Photoshop folder. The bracketed 
browser is launched when you press Ctrl+Alt+P 
(Windows) or Command+Option+P (Mac OS). 
The brackets do not appear in the Preview In 
submenu. If no browser is bracketed, the keyboard 
shortcut launches the first browser in the Preview 
In submenu. The shortcut specification takes 
effect the next time you launch ImageReady.

Closing files and quitting

To close a file:

1 Choose File > Close.

2 Choose whether to save the file:

• Click Yes (Windows) or Save (Mac OS) to save 
the file. 

• Click No (Windows) or Don’t Save (Mac OS) to 
close the file without saving it.

To exit Photoshop or ImageReady:

1 Choose File > Exit (Windows) or File > Quit 
(Mac OS).

2 Choose whether to save any open files:

• Click Yes (Windows) or Save (Mac OS) for each 
open file to save the file.

• Click No (Windows) or Don’t Save (Mac OS) for 
each open file to close the file without saving it.
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Chapter 2: Getting Images into 
Photoshop and ImageReady

ou can get digital images from a variety of 
sources—you can create new images, 
import them from another graphics appli-

cation, or capture them from video. Often you will 
begin by scanning a photograph, a slide, or an 
image. To create effective artwork, you must 
understand some basic concepts about how to 
work with digital images, how to produce high-
quality scans, how to work with a variety of file 
formats, and how to adjust the resolution and size 
of images.

About bitmap images and vector 
objects
Digital images fall into two main categories—
bitmap and vector. You can work with both types of 
images in Photoshop and ImageReady; moreover, 
a Photoshop file can contain both bitmap and 
vector data. Understanding the difference between 
the two categories will help as you create and edit 
images.

Bitmap images Bitmap images—also called raster 
images—use a grid of small squares known as 
pixels to represent images. Each pixel is assigned a 
specific location and color value. For example, a 
bicycle tire in a bitmap image is made up of a 
mosaic of pixels in that location. When working 
with bitmap images, you edit pixels rather than 
objects or shapes. 

A bitmap image is resolution-dependent—that is, 
it contains a fixed number of pixels to represent its 
image data. As a result, a bitmap image can lose 
detail and appear jagged if viewed at a high magni-
fication on-screen or printed at too low a 
resolution. Bitmap images are the best choice for 
representing subtle gradations of shades and 
color—in photographs or painted images, for 
example. 

Vector objects Vector graphics are made of lines 
and curves defined by mathematical objects called 
vectors. Vectors describe an image according to its 
geometric characteristics. For example, a bicycle 
tire in a vector graphic is made up of a mathe-
matical definition of a circle drawn with a certain 
radius, set at a specific location, and filled with a 
specific color. You can move, resize, or change the 
color of the tire without losing the quality of the 
graphic. 

A vector object is resolution-independent—that 
is, it can be scaled to any size and printed on any 
output device at any resolution without losing its 
detail or clarity. As a result, vector objects are the 
best choice for representing bold graphics that 
must retain crisp lines when scaled to various 
sizes—for example, logos. 

Y
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Because computer monitors represent images by 
displaying them on a grid, both vector and bitmap 
images are displayed as pixels on-screen.

BITMAP VS. VECTOR A bitmap image is 
composed of a grid of small squares known as 
pixels. A vector graphic is defined by mathe-
matical objects called vectors.

Bitmap images are good at reproducing subtle gradations 
of color, as in photographs. They can show jagged edges 
when printed at too large a size or displayed at too high a 
magnification.

Vector graphics are good at reproducing crisp outlines, as 
in logos or illustrations. They can be printed or displayed 
at any resolution without losing detail.

24:13:1

24:13:1
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About image size and resolution
In order to produce high-quality images, it is 
important to understand how the pixel data of 
images is measured and displayed.

Pixel dimensions The number of pixels along the 
height and width of a bitmap image constitutes the 
image’s pixel dimensions. The display size of an 
image on-screen is determined by the pixel dimen-
sions of the image plus the size and setting of the 
monitor. 

A typical 13-inch monitor displays 640 pixels 
horizontally and 480 vertically. An image with 
dimensions of 640 pixels by 480 pixels would fill 
this small screen. On a larger monitor with a 640-
pixels-by-480-pixels setting, the same image (with 
640-pixels-by-480-pixels dimensions) would still 
fill the screen, but each pixel would appear larger. 
Changing the setting of this larger monitor to 1152 
pixels by 870 pixels would display the image at a 
smaller size, occupying only part of the screen.
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When preparing an image for online display (for 
example, a Web page that will be viewed on a 
variety of monitors), pixel dimensions become 
especially important. Because your image may 
be viewed on a 13-inch monitor, you may want 
to limit the size of your image to 600 pixels by 
400 pixels to allow room for the Web browser 
window controls.
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Image resolution The number of pixels displayed 
per unit of printed length in an image, usually 
measured in pixels per inch (ppi). 

Important: You cannot change the resolution of an 
image in ImageReady. This is because the 
ImageReady application is tailored to creating 
images for online media, not print media. 

An image with a high resolution contains more, 
and therefore smaller, pixels than an image of the 
same printed dimensions with a low resolution. 
For example, a 1-inch-by-1-inch image with a 
resolution of 72 ppi contains a total of 5184 pixels 
(72 pixels wide x 72 pixels high = 5184). The same 
1-inch-by-1-inch image with a resolution of 
300 ppi would contain a total of 90,000 pixels. 

72-ppi and 300-ppi images; inset zoom 200% 

ON-SCREEN DISPLAY SIZE How large an image 
appears on-screen depends on a combination 
of factors––the pixel dimensions of the image, 
the monitor size, and the monitor resolution 
setting. 
The examples below show a 620 x 400 pixel 
image displayed on monitors of various sizes 
and resolutions.

640 x 480

13"

15"

20"

1024 x 768

640 x 480

640 x 480

832 x 624
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Because they use more pixels to represent each 
unit of area, higher-resolution images usually 
reproduce more detail and subtler color transi-
tions than lower-resolution images when printed. 
However, increasing the resolution of an image 
scanned or created at a lower resolution only 
spreads the original pixel information across a 
greater number of pixels; it rarely improves image 
quality. 

To determine the image resolution to use, consider 
the medium of final distribution for the image. If 
you’re producing an image for online display, the 
image resolution needs only to match the typical 
monitor resolution (72 or 96 ppi). However, using 
too low a resolution for a printed image results in 
pixelation—output with large, coarse-looking 
pixels. Using too high a resolution (pixels smaller 
than the output device can produce) increases the 
file size and slows the printing of the image; 
furthermore, the device will be unable to print the 
image at the high resolution.

Monitor resolution The number of pixels or dots 
displayed per unit of length on the monitor, 
usually measured in dots per inch (dpi). Monitor 
resolution depends on the size of the monitor plus 
its pixel setting. The typical resolution of a PC 
monitor is about 96 dpi, of a Mac OS monitor 
72 dpi. 

Understanding monitor resolution helps explain 
why the display size of an image on-screen often 
differs from its printed size. Image pixels are trans-
lated directly into monitor pixels. This means that 
when the image resolution is higher than the 
monitor resolution, the image appears larger on-
screen than its specified print dimensions. For 
example, when you display a 1-inch-by-1-inch, 
144-ppi image on a 72-dpi monitor, it appears in a 
2-inch-by-2-inch area on-screen. Because the 
monitor can display only 72 pixels per inch, it 
needs 2 inches to display the 144 pixels that make 
up one edge of the image. 

Printer resolution The number of ink dots per inch 
(dpi) produced by an imagesetter or laser printer. 
For best results, use an image resolution that is 
proportional to, but not the same as, printer 
resolution. Most laser printers have output resolu-
tions of 300 dpi to 600 dpi and produce good 
results with images from 72 ppi to 150 ppi.
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High-end imagesetters can print at 1200 dpi or 
higher and produce good results with images from 
200 ppi to 300 ppi.

Screen frequency The number of printer dots or 
halftone cells per inch used to print grayscale 
images or color separations. Also known as screen 
ruling or line screen, screen frequency is measured 
in lines per inch (lpi)—or lines of cells per inch in 
a halftone screen.

The relationship between image resolution and 
screen frequency determines the quality of detail 
in the printed image. To produce a halftone image 
of the highest quality, you generally use an image 
resolution that is from 1.5 to at most 2 times the 
screen frequency. But with some images and 
output devices, a lower resolution can produce 
good results.

Note: Some imagesetters and 600-dpi laser printers 
use screening technologies other than halftoning. If 
you are printing an image on a nonhalftone printer, 
consult your service provider or your printer 
documentation for the recommended image 
resolutions.

File size The digital size of an image, measured in 
kilobytes (K), megabytes (MB), or gigabytes (GB). 
File size is proportional to the pixel dimensions of 
the image. Images with more pixels may produce 
more detail at a given printed size, but they require 
more disk space to store and may be slower to edit 
and print. For instance, a 1-inch-by-1-inch 200-
ppi image contains four times as many pixels as a 
1-inch-by-1-inch 100-ppi image and so has four 
times the file size. Image resolution thus becomes 
a compromise between image quality (capturing 
all the data you need) and file size. 

IMAGE RESOLUTION AND SCREEN FREQUENCY 

To ensure high-quality output when printing 
with a halftone screen, you need to choose an 
image resolution based on the screen frequency 
of the printing device. In general, an image 
resolution from 1.5 to 2 times the screen 
frequency gives the best results.

65 lpi: Coarse screen 
typically used to print 
newsletters and gro-
cery coupons.

85 lpi: Average screen 
typically used to print 
newspapers.

133 lpi: High-quality 
screen typically used 
to print four-color 
magazines.

177 lpi: Very fine screen 
typically used for annual 
reports and images in art 
books.
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Another factor that affects file size is the file 
format. Due to varying compression methods 
used by GIF, JPEG, and PNG file formats, file sizes 
can vary considerably for the same pixel dimen-
sions. Image optimization thus becomes a 
compromise between image quality (capturing all 
the data you need) and file size. 

Photoshop supports a maximum file size of 2 GB 
and maximum pixel dimensions of 30,000 by 
30,000 pixels per image. This restriction places 
limits on the print size and resolution available to 
an image. For example, an image 100 by 100 inches 
can have a resolution of at most 300 ppi (30,000 
pixels / 100 inches = 300 ppi). 

Changing image size and 
resolution
Once you have scanned or imported an image, you 
may want to adjust its size. The Image Size 
command lets you adjust the pixel dimensions, 
print dimensions (Photoshop), and resolution 
(Photoshop) of an image.

For assistance with resizing and resampling 
images in Photoshop, choose Help > Resize 

Image. This interactive wizard helps you scale your 
images for printed or online display.

To display the current image size:

Do one of the following:

• (Photoshop) Press Alt (Windows) or Option 
(Mac OS), position the pointer over the file infor-
mation box at the bottom of the document 
window, and hold down the mouse button.The 
box displays the width and height of the image 
(both in pixels and in the unit of measurement 
currently selected for the rulers), the number of 
channels, and the image resolution.
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• (ImageReady) Click an image information box 
at the bottom of the document window, and select 
Image Dimensions from the pop-up menu. The 
box displays the width and height of the image in 
pixels.
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About resampling

Resampling refers to changing the pixel dimen-
sions (and therefore display size) of an image. 
When you downsample (or decrease the number of 
pixels), information is deleted from the image. 
When you resample up (or increase the number of 
pixels), new pixel information is added based on 
color values of existing pixels. You specify an inter-
polation method to determine how pixels are 
added or deleted. (See “Choosing an interpolation 
method” on page 29.)

A. Downsampled B. Original C. Resampled up 
(Selected pixels displayed for each image.)

Keep in mind that resampling can result in poorer 
image quality. For example, when you resample an 
image to smaller pixel dimensions, the image will 
lose some detail and sharpness. Applying the 
Unsharp Mask filter to a resampled image can help 
refocus the image’s details. (See “Sharpening an 
image” on page 112.)

You can avoid the need for resampling by scanning 
in or creating the image at a high enough 
resolution. If you want to preview the effects of 
changing pixel dimensions on-screen or print 
proofs at different resolutions, resample a 
duplicate of your file. 

RESOLUTION, FILE SIZE, AND OUTPUT The file 
size of an image refers to the total amount of 
pixel information in the image. For example, 
a 1-inch-by-2-inch high-resolution image has 
more pixels, and thus a larger file size, than a 
1-inch-by-2-inch low-resolution image. In print, 
a high-resolution image has more detail than the 
same image at low resolution. On-screen, 
a high-resolution image appears larger. 
(See “Image resolution” on page 23.) The 
enlarged on-screen display does not affect the 
dimensions of the printed image.

1 in. x 2 in. @ 72 ppi; 
file size 323K

100% view on-screen

1 in. x 2 in. @ 300 ppi; 
file size 5.47 MB

100% view on-screen

A CB
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Choosing an interpolation method 

When an image is resampled, an interpolation 
method is used to assign color values to any new 
pixels it creates, based on the color values of 
existing pixels in the image. The more sophisti-
cated the method, the more quality and detail 
from the original image are preserved. 

The General Preferences dialog box lets you 
specify a default interpolation method to use 
whenever images are resampled with the Image 
Size or transformation commands. The Image Size 
command also lets you specify an interpolation 
method other than the default.

To specify the default interpolation method: 

1 Choose Edit > Preferences > General.

2 For Interpolation, choose one of the 
following options:

• Nearest Neighbor (Jagged) for the fast but less 
precise method. This method is recommended for 
use with illustrations containing non-anti-aliased 
edges, to preserve hard edges and produce a 
smaller file. However, this method can result in 
jagged effects, which become apparent when 
distorting or scaling an image or performing 
multiple manipulations on a selection. 

• (Photoshop) Bilinear for a medium-quality 
method.

• Bicubic (Smooth) for the slow but most precise 
method, resulting in the smoothest tonal 
gradations.

Changing the pixel dimensions of an 
image

When preparing images for online distribution, 
it’s useful to specify image size in terms of the pixel 
dimensions. Keep in mind that changing pixel 
dimensions affects not only the size of an image 
on-screen but also its image quality and its printed 
characteristics—either its printed dimensions or 
its image resolution. (See “About image size and 
resolution” on page 21; “About resampling” on 
page 28.) 

To change the pixel dimensions of an image 
(Photoshop):

1 Choose Image > Image Size.

2 Make sure that Resample Image is selected, and 
choose an interpolation method. (See “Choosing 
an interpolation method” on page 29.)

3 To maintain the current proportions of pixel 
width to pixel height, select Constrain Propor-
tions. This option automatically updates the width 
as you change the height, and vice versa.

4 Under Pixel Dimensions, enter values for Width 
and Height. To enter values as percentages of the 
current dimensions, choose Percent as the unit of 
measurement.

The new file size for the image appears at the top 
of the Image Size dialog box, with the old file size 
in parentheses.
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5 Click OK to change the pixel dimensions and 
resample the image.

For best results in producing a smaller image, 
resample down and apply the Unsharp Mask 

filter. To produce a larger image, rescan the image at 
a higher resolution.

To change the pixel dimensions of an image 
(ImageReady):

1 Choose Image > Image Size.

2 To maintain the current proportions of 
pixel width to pixel height, select Constrain 
Proportions. 

3 Constrain the image proportions by selecting:

• Width to constrain proportions using the new 
width value.

• Height to constrain proportions using the new 
height value.

• Either to constrain proportions using either the 
new width value or the new height value. Use the 
Either option when resizing a batch of images of 
different sizes or proportions that need to fit into a 
standard new image size.

• Percent to constrain proportions while resizing 
the image by a percent value.

4 Under New Size, enter values for Width, Height, 
or Percent. 

The New Size text field displays the new file size for 
the image.

5 Select a resampling method from the Quality 
pop-up menu.

6 Select Do Not Enlarge to prevent images that are 
smaller than the new dimensions from being sized 
up. This option is useful when resizing a batch of 
irregularly sized images.

7 Click OK to change the pixel dimensions and 
resample the image.

Changing the print dimensions and 
resolution of an image (Photoshop)

When preparing images for print, it’s useful to 
specify image size in terms of the printed dimen-
sions and the image resolution. These two 
measurements determine the total pixel count and 
therefore the file size of the image. (See “About 
image size and resolution” on page 21.)

If you turn on resampling for the image, you can 
change print dimensions and resolution indepen-
dently. If you turn resampling off, you can change 
either the dimensions or the resolution—
Photoshop adjusts the other value automatically to 
preserve the total pixel count. For the highest print 
quality, it’s generally best to change the dimen-
sions and resolution first without resampling. 
Then resample only as necessary.

Note: If your image resolution is more than 2.5 times 
the screen ruling, an alert message appears when you 
try to print the image. This means that the image 
resolution is higher than necessary for the printer. 
Save a copy of the file, and then reduce the 
resolution. 

To change the print dimensions and resolution of 
an image:

1 Choose Image > Image Size.
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2 Change the print dimensions or image 
resolution or both:

• To change only the print dimensions or only the 
resolution and adjust the total number of pixels in 
the image proportionately, make sure that 
Resample Image is selected. Then choose an inter-
polation method, as described in “Choosing an 
interpolation method” on page 29.

• To change the print dimensions and resolution 
without changing the total number of pixels in the 
image, deselect Resample Image.

3 To maintain the current proportions of image 
width to image height, select Constrain Propor-
tions. This option automatically updates the width 
as you change the height, and vice versa.

4 Under Print Size, enter new values for the height 
and width. If desired, choose a new unit of 
measurement. Note that for Width, the Columns 
option uses the width and gutter sizes specified in 
the Units & Rulers preferences. (See “Using rulers, 
the measure tool, guides, and the grid” on 
page 149.)

5 For Resolution, enter a new value. If desired, 
choose a new unit of measurement.

6 Click OK.

To return to the original values displayed in the 
Image Size dialog box, hold down Alt 

(Windows) or Option (Mac OS), and click Reset. 

To view the print size on-screen:

Choose View > Print Size.

The magnification of the image is adjusted to 
display its approximate printed size, as specified in 
the Print Size section of the Image Size dialog box.

Determining a recommended resolution 
for an image (Photoshop)

If you plan to print your image using a halftone 
screen, the range of suitable image resolutions 
depends on the screen frequency of your output 
device. You can have Photoshop determine a 
recommended resolution for your image based on 
your device’s screen frequency. (See “About image 
size and resolution” on page 21.)

To determine a suggested resolution for an image:

1 Choose Image > Image Size.

2 Click Auto. 

3 For Screen, enter the screen frequency for the 
output device. If desired, choose a new unit of 
measurement. Note that the screen value is used 
only to calculate the image resolution, not to set 
the screen for printing.

Important: To specify the halftone screen ruling for 
printing, you must use the Halftone Screens dialog 
box, accessible through the Page Setup dialog box. 

4 For Quality, select an option:

• Draft to produce a resolution the same as the 
screen frequency (no lower than 72 pixels per 
inch).

• Good to produce a resolution 1.5 times the 
screen frequency.

• Best to produce a resolution 2 times the screen 
frequency.

5 Click OK.
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Scanning images
Before you scan an image, make sure that the 
software necessary for your scanner has been 
installed. To ensure a high-quality scan, you 
should predetermine the scanning resolution and 
dynamic range your image requires. These prepa-
ratory steps can also prevent unwanted colors casts 
from being introduced by your scan.

Scanner drivers are provided and supported by 
the manufacturers of the scanners, not Adobe 
Systems. If you have problems with scanning, 
make sure that you are using the latest version 
of the appropriate scanner driver.

Importing scanned images

You can import scanned images directly from any 
scanner that has an Adobe Photoshop-compatible 
plug-in module or that supports the TWAIN 
interface. To import the scan using a plug-in 
module, choose the scanner name from the File > 
Import submenu. See your scanner documen-
tation for instructions on installing the scanner 
plug-in. (See “Using plug-in modules” on page 15 
for general plug-in information.)

If your scanner does not have an Adobe 
Photoshop-compatible scanner driver, import the 
scanner using the TWAIN interface. (See 
“Importing an image using the TWAIN interface” 
on page 32.)

If you can’t import the scan using the TWAIN 
interface, use the scanner manufacturer’s software 
to scan your images, and save the images as TIFF, 
PICT, or BMP files. Then open the files in 
Photoshop or ImageReady.

Importing an image using the TWAIN 
interface 

TWAIN is a cross-platform interface for acquiring 
images captured by certain scanners, digital 
cameras, and frame grabbers. The manufacturer 
of the TWAIN device must provide a Source 
Manager and TWAIN Data source for your device 
to work with Photoshop and ImageReady. 

Photoshop and ImageReady support the current 
TWAIN_32 standard for scanning. However, the 
TWAIN software used with Windows 3.1 is not 
supported. Contact your scanner manufacturer 
for information on the availability of TWAIN_32 
source modules.

To import an image using the TWAIN interface:

1 If you’re using the TWAIN device for the first 
time with Photoshop or ImageReady, choose 
File > Import > Select TWAIN_32 Source 
(Windows) or TWAIN Select (Mac OS). Then 
select the device you’re using. You do not need to 
repeat this step for subsequent use of the TWAIN 
module.

If more than one TWAIN device is installed in 
your system and you want to switch devices, use 
the Select Source command. 

2 To import the image, choose File > Import > 
TWAIN _32 (Windows) or TWAIN Acquire (Mac 
OS).
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Scanning using the resolution setting 
(Photoshop)

You can determine the settings for your scan using 
the original and final image dimensions and the 
screen frequency of your output device to calculate 
a scan resolution to enter in the scanner settings. 
This scan resolution translates into image 
resolution when you open the scan. 

The quality of final output depends not only on 
the scan resolution but also on the resolution of 
your output device and the size of the original 
image compared with the final image. (See “About 
image size and resolution” on page 21.)

To estimate scan resolution:

1 Multiply the screen frequency by 2 (the typical 
ratio of image resolution to screen frequency 
needed to produce a high-quality image).

2 Multiply the result in step 1 by the ratio of final 
image dimensions to original dimensions to 
determine an estimated scan resolution.

For example, suppose you are scanning a 2-inch-
by-3-inch image, you want to produce a final 
6-inch-by-9-inch image, and you are using a 
screen frequency of 85 lpi. First multiply 85 (the 
screen frequency) by 2 to get 170. Then multiply 
170 by 3 (the ratio of final image dimensions to 
original ones) to get a scan resolution of 510 ppi. 

Different color separation procedures might 
require different ratios of image resolution to 
screen frequency. It’s a good idea to check with 
your service provider or print shop before you 
scan the image.

Scanning using the file size setting 
(Photoshop)

You can create a dummy file to predict the file size 
needed for the final output of your scan. 

To calculate the file size before scanning an image:

1 Open Adobe Photoshop, and choose 
File > New. 

2 Enter the width, height, and resolution for your 
final printed image. The resolution should be 1.5 
to 2 times the screen frequency you will use to 
print. Make sure that the mode you plan to scan in 
is selected. (See “About color modes and models 
(Photoshop)” on page 45.) The New dialog box 
then displays the file size.

For example, suppose you want the final image to 
be 4 inches wide and 5 inches high. You plan to 
print it with a 150-line screen using a 2:1 ratio, so 
you set the resolution to 300. The resulting file size 
is 5.15 megabytes.

To produce the scan, enter the resulting file size in 
your scanner settings. Don’t worry about 
resolution or image dimensions. After you have 
scanned the image and imported it into 
Photoshop, use the Image Size command to enter 
the correct width and height for the image.
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Optimizing the dynamic range of the scan 
(Photoshop)

Keep in mind that the human eye can detect a 
wider tonal range than can be printed. If your 
scanner allows, set the black and white points 
before scanning a file to produce the best tonal 
range and capture the widest dynamic range. Then 
use Photoshop’s color adjustment tools to set the 
white and black points for the scanned image. 
(See “Step 3: Set the highlight and shadow values” 
on page 118.) <<Xref destination?>>

Eliminating unwanted color casts 
(Photoshop)

If your scanned image contains an unwanted color 
cast, you can perform a simple test to determine 
whether the cast was introduced by your scanner. 
If it was, you can use the same test file to create a 
color-cast correction for all images scanned with 
the scanner. 

To identify and correct a color cast introduced by 
a scanner:

1 Make sure that your monitor has been 
calibrated. (See “Calibrating your monitor” on 
page 86.) <<Xref destination?>>

2 Open a new Photoshop file, and use the linear 
gradient tool ( ) to create a blend from pure 
black to pure white.

3 Choose Image > Adjust > Posterize, and 
posterize the blend using 11 levels.

4 Print the 11-step gray wedge on a black-and-
white printer, and then scan it into Photoshop.

Note: You can also perform this test using an 
18-percent neutral gray card or an 11-step gray 
wedge from a photography store.

5 Open the Info palette, and read the RGB values 
on-screen for each of the gray levels. Uneven R, G, 
and B values indicate a color cast. 

6 Use Levels or Curves to correct the color cast, 
and then save the dialog box settings. 

7 Open the scanned image you want to correct, 
reopen the dialog box you used to correct the cast 
in step 6, and load the saved settings.

Creating new images 
The New command lets you create a blank, 
untitled image. 

To create a new image:

1 Do one of the following:

• To base the image dimensions and resolution 
(Photoshop) on the Clipboard contents, choose 
File > New.

• (Photoshop) To base the image size on the 
default dimensions and resolution or the last 
entered settings, hold down Alt (Windows) or 
Option (Mac OS) as you choose File > New.

2 Type a name for the image, and if desired, set 
the width and height
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3 (Photoshop) Set the resolution and mode. 
(See “About image size and resolution” on page 21 
and  “About color modes and models 
(Photoshop)” on page 45.)

4 Select an option for the contents of the 
background layer (Photoshop) or first layer 
(ImageReady) of the image:

• White to fill the background or first layer with 
white, the default background color.

• Background Color to fill the background or first 
layer with the current background color. 
(See “Choosing foreground and background 
colors” on page 195.)

• Transparent to make the background or first 
layer transparent, with no color values. 

5 Click OK.

Opening files
You can open and import images in various file 
formats. The available formats appear in the Open 
dialog box, the Open As dialog box (Windows), or 
the Import submenu. (See “About file formats” on 
page 382.)

Note: Photoshop and ImageReady use plug-in 
modules to open and import many file formats. If a 
file format does not appear in the Open dialog box or 
in the File > Import submenu, you may need to 
install the format’s plug-in module. (See “Using 
plug-in modules” on page 15.) 

To open a file:

1 Choose File > Open.

2 Select the name of the file you want to open. You 
can change which types of files show by selecting 
an option from the Files of Type (Windows) or 
Show (Mac OS) pop-up menu.

3 In Mac OS, click Show Preview to preview the 
selected file. This option requires the Apple 
QuickTime extension.

Important: Previews are only available if they are 
saved with the file. In Photoshop, select Always Save 
for Image Previews in the Saving Files Preferences to 
save a preview. 

4 Click Open. In some cases, a dialog box appears, 
letting you set the open options. The formats 
requiring an open dialog box are described in the 
following sections.

Note: If the Profile Mismatch dialog box appears, 
specify whether to convert the file’s color profile. 
(See “Managing ICC profiles in files” on page 104.) 
<<Xref destination?>>

To open a recently used file:

Choose File > Open Recent, and select a file from 
the submenu.

To specify the file format in which to open a file 
(Photoshop):

Do one of the following:

• In Windows, choose File > Open As, select the 
desired format, and click Open.
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• In Mac OS, choose File > Open, select the 
desired file format from the Show pop-up menu, 
and click Open.

Note: If the file does not open, then the chosen 
format may not match the file’s true format, or the 
file may be damaged.

Opening PDF files

Portable Document Format (PDF) is a versatile file 
format that can represent both vector and bitmap 
graphics and can contain electronic document 
search and navigation features. PDF is the primary 
format for Adobe Illustrator 9.0 and Adobe 
Acrobat. For more information on PDF format, 
see “About file formats” on page 382.

Some PDF files contain a single image. Other PDF 
files (called Generic PDF files) may contain 
multiple pages and images. The distinction 
between images and pages in a PDF file is an 
important one—it will determine what method 
you use to open the file. 

• Use the Open command to open all types of PDF 
files. 

• Use the Import > PDF Image command to open 
one or all images in a multiple-image PDF file. 

• (Photoshop) Use the Automate > Multi-Page 
PDF to PSD command to open each page in a 
multiple-page PDF file and save them as separate 
Photoshop files.

You can also use the Place and Paste commands to 
bring PDF data into Photoshop or ImageReady. 
(See “Placing files” on page 39 and “Using drag 
and drop to copy between applications” on 
page 155.)

<<Documentation—Update Paste/Drag + Drop 
XREF.>>

To open a PDF file:

1 Choose File > Open.

2 Select the name of the file, and click Open. You 
can change which types of file show by selecting an 
option from the File of Types (Windows) or Show 
(Mac OS) pop-up menu.

3 If you are opening a Generic PDF file, do the 
following:

• If the file contains multiple pages, select the page 
you want to open, and click OK. 

• Indicate the desired dimensions, resolution, and 
mode.

• Select Constrain Proportions to maintain the 
same height-to-width ratio.

• Select Anti-aliased to minimize the jagged 
appearance of the artwork’s edges as it is 
rasterized.

• Click OK.

To import images from a PDF file:

1 Choose File > Import > PDF Image.

2 Select the file you want to import images from, 
and click Open.

3 Do one of the following:

• Select a specific image to open, and click OK. 
You can use the arrows to scroll through the 
images, or click Go to Image to enter an image 
number.
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• Click Import All Images to open each image as a 
separate file.

Press the Escape key to cancel the import 
operation before all images are imported.

To open a multiple-page PDF file as a separate files 
(Photoshop):

Choose File > Automate > Multi-Page PDF to 
PSD.

Opening Illustrator and EPS files

<<Reviewers—I’m still working on clarifying 
Illustrator workflow issues in terms of PDF-based 
.ai format and older .ai format. Any information 
you can provide is appreciated.>>

When you open an Adobe Illustrator or EPS 
(Encapsulated PostScript®) file containing vector 
art, it is rasterized—the mathematically defined 
lines and curves of the vector image are converted 
into the pixels or bits of a bitmap image.

You can also use the Place and Paste commands to 
bring Illustrator or EPS artwork into Photoshop or 
ImageReady. 

<<Documentation—Update Paste/Drag + Drop 
XREF.>>

To open an Adobe Illustrator or EPS file:

1 Choose File > Open. 

2 Select the file you want to open, and click Open. 

3 Indicate the desired dimensions, resolution, and 
mode. To maintain the same height-to-width 
ratio, select Constrain Proportions.

4 Select Anti-aliased to minimize the jagged 
appearance of the artwork’s edges as it is 
rasterized. 

5 Click OK.

Turning off anti-aliasing for PDF and EPS 
files

The Anti-alias PostScript option removes jagged 
edges from a pasted or placed selection by making 
a subtle transition between the edges of the 
selection and its surrounding pixels. Turning off 
this option helps maintain the hard edges of line 
art as it is rasterized. 

To turn off the Anti-alias Postscript option:

1 Choose Edit > Preferences > General.

2 Deselect Anti-alias PostScript. Clearing this 
option can decrease the time it takes to import 
the file.

Opening Photo CD files 

You can open Kodak® Photo CD™ files, including 
high-resolution files from Pro Photo CD discs, 
directly in Photoshop or ImageReady. 

Note: You cannot save files in the Photo CD format 
from Photoshop or ImageReady.

To open a Photo CD file:

1 Choose File > Open.

2 Select the file you want to open, and click Open. 

If the file does not appear, select the option for 
showing all files from the File of Types (Windows) 
or Show (Mac OS) pop-up menu.
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3 Choose a resolution.

4 Click Source. Choose a device profile and an 
attribute from the list, and then click Open.

The first time you open a Photo CD file, it opens 
using the default Source and Destination profiles. 
After you choose the profiles, they remain selected 
until you change them.

<<Documentation—Verify following two steps. 
Document choosing an image size and resolu-
tion.>>

5 Click Destination, and for Device, choose an 
RGB profile; then click Open. 

6 To display scanner information about the 
image, click Image Info; then click OK.

7 Click OK to open the image.

Opening Raw files (Photoshop)

The Raw format is designed to accommodate 
images saved in undocumented formats, such as 
those created by scientific applications. 
Compressed files, such as PICT, and GIF, cannot 
be opened using this format.

To open a file using the Raw format:

1 Choose File > Open As (Windows) or File > 
Open (Mac OS).

2 Choose Raw from the file format list, and 
click Open.

3 For Width and Height, enter values for the 
dimensions of the file.

4 To reverse the order of the width and height, 
click Swap.

5 Enter the number of channels.

6 Select Interleaved if the file was saved with an 
interlaced data option.

7 Select a color depth and, if necessary, a byte 
order.

8 For Header, enter a value.

9 If you are missing the dimensions or header 
value, you can have Photoshop estimate the 
parameters. Either enter the correct height and 
width values to estimate the header size, or enter 
the correct header size to estimate the height and 
width, and then click Guess.

10 To have Photoshop retain the header when you 
save the file, select Retain When Saving.

11 Click OK.

Importing anti-aliased PICT files (Mac OS)

Choose File > Import > Anti-aliased PICT to 
import object-oriented PICT files (such as those 
created with MacDraw and Canvas) as smooth-
edged, or anti-aliased, images. Because the entire 
PICT file must be held in memory for this module 
to operate, you may not be able to use the module 
with large PICT files. 

The Anti-aliased PICT dialog box indicates the 
current file size and dimensions. To change the 
image dimensions, enter new values for Width and 
Height. The file size is then updated. To maintain 
image proportions, select Constrain Proportions. 

You can choose grayscale or RGB color mode for 
an anti-aliased PICT.
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Importing PICT Resources (Mac OS)

The PICT Resource module lets you read PICT 
resources from a file—for example, from another 
application. To open a PICT resource, choose 
File > Import > PICT Resource.

To preview a resource, click Preview. Click the 
arrow buttons to step forward and backward 
through the resources. Note that the number 
displayed for Resource refers to the resource’s 
position in ascending order in the resource fork 
and not to the resource’s identification number.

Note: In Photoshop, you can also open a file in the 
PICT Resource file format by choosing File > Open 
and, for Format, choosing PICT Resource. However, 
the Open command automatically opens the first 
resource in the file and does not display any other 
PICT resources in the file.

Placing files
You can use the Place command to place images 
from other applications into a new layer in the 
existing image. In Photoshop, you can place PDF, 
Adobe Illustrator, and EPS files; in ImageReady, 
you can place files of any supported format, with 
the exception files containing CMYK images.

Note: When you place a PDF, Adobe Illustrator, or 
EPS file, it is rasterized. You will not be able to edit 
text or vector art.

To place a PDF, Adobe Illustrator, or EPS file 
(Photoshop):

1 Open the Photoshop image into which you 
want to place the artwork.

2 Choose File > Place, select the file you want to 
place, and click Open.

3 If you are placing a PDF file that contains 
multiple pages, select the page you want to place, 
and click OK. 

The placed artwork appears as a new layer inside a 
bounding box at the center of the Photoshop 
image. The artwork maintains its original aspect 
ratio.

4 Adjust the placed artwork:

• To move, position the pointer inside the 
bounding box, and drag. 

• To scale, drag one of the handles at the corners or 
sides of the bounding box. Hold down Shift as you 
drag to constrain the proportions. 

• To rotate, position the pointer outside the 
bounding box (the pointer turns into a curved 
arrow), and drag. To adjust the point around 
which the marquee is rotated, drag the circle at the 
center of the bounding box.

• To skew, hold down Ctrl (Windows) or 
Command (Mac OS) and drag a side handle of the 
bounding box.

5 To confirm the placement of the artwork, press 
Enter (Windows) or Return (Mac OS). To cancel 
the placement, press Esc.

To place a file (ImageReady):

1 Open the ImageReady image into which you 
want to place the image.

2 Choose File > Place.

3 Select offset options:
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• From the Horizontal pop-up menu, choose an 
option for placing the file horizontally with respect 
to the ImageReady image. In the Pixels text box, 
enter the number of pixels to offset the placed 
image horizontally.

• From the Vertical pop-up menu, choose an 
option for placing the file vertically with respect to 
the ImageReady image. In the Pixels text box, enter 
the number of pixels to offset the placed image 
vertically.

Note: To enter a negative number (and offset the 
placed file to the left or below the ImageReady 
image), type a hyphen (-) before the number.

4 Click Choose, and select the file you want to 
place. Then click Open.

5 Click OK.

6 If you are placing a PDF, Adobe Illustrator, or 
EPS file, choose Rasterize options:

• Enter Width and Height values for Image Size.

• Click Anti-alias to blend edges.

• Click Constrain Proportions to preserve image 
proportions when resizing.

7 Click OK.

Managing files with WebDAV
Photoshop and ImageReady offer support for a 
server technology known as Web Distributed 
Authoring and Versioning (WebDAV). You can 
easily connect to a WebDAV server, lock files so 
others cannot work on them at the same time as 
you are, download and upload files, and obtain 
information about files. Using a WebDAV server 
lets you work in a collaborative environment 
without fear that files will be accidentally 
overwritten or updates lost.

Getting started with WebDAV

To use WebDAV, you must have connection to a 
server with WebDAV capability. That includes:

• Microsoft IIS 5 (included with Windows 2000)

• Apache (with mod_dav module installed)

• Novell NetWare 5.1 (announced January 10, 
2000)

You can find detailed information and the latest 
news about WebDAV at www.webdav.org.

<<Reviewers—WebDAV information to be 
completed. Will provide this section for review on 
a separate schedule.>>

Cropping images
<<Reviewers—This section doesn’t reflect the 
new Photoshop crop tool functionality/workflow. 
Will provide this section for review on a separate 
schedule.>>

You can use the following methods to crop images:
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• Use the Crop command or the crop tool ( ) set 
to Delete to discard the area outside of a rectan-
gular selection.

• Use the Crop command or the crop tool ( ) set 
to Hidden or Hide to hide the area outside of a 
rectangular selection. Use this feature when 
creating animations with elements that move from 
offscreen into the live image area. 

An image with the Crop command applied using the 
Hidden option and repositioned using the move tool.

An image with the Crop command applied using the 
Delete option and repositioned using the move tool.

• Use the Trim command to discard a border area 
around the edge of the image, based on trans-
parency or edge color.

When using the crop tool, you can rotate the 
selected area before you perform the cropping 
operation. You can also specify a fixed size for the 
target image created from the cropped selection. 
(You cannot rotate the cropped selection when 
you use the Fixed Target Size option.)

To use the crop tool:

1 Select the crop tool ( ).

2 In the options bar, select an option to remove 
the cropped area:

• Delete to permanently discard the cropped area.

• Hide to hide the cropped area but preserve the 
area in the image file. 

3 Drag over the part of the image you want to 
keep.

When you release the mouse button, the crop 
marquee appears as a bounding box with handles 
at the corners and sides. 

4 Adjust the crop marquee:

• To move the marquee to another position, 
position the pointer inside the bounding box and 
drag. 

• To scale the marquee, drag a handle. To 
constrain the proportions, hold down Shift as you 
drag a corner handle.

• To rotate the marquee, position the pointer 
outside the bounding box (the pointer turns into a 
curved arrow), and drag. To adjust the point 
around which the marquee is rotated, drag the 
circle at the center of the bounding box.

Note: In Photoshop, you can’t rotate the crop tool 
marquee for an image in Bitmap mode.

5 To crop the image, press Enter (Windows) or 
Return (Mac OS). To cancel the cropping 
operation, press Esc. 

To specify the size of the cropped area:

1 Select the crop tool ( ).
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2 In the options bar, select Fixed Target Size.

3 To begin with the size values of the current 
image, click Front Image.

4 Enter values for the size you want for the 
cropped area. 

In Photoshop, you can also set the resolution you 
want for the cropped area. If you specify size but 
not resolution, the resolution changes automati-
cally to compensate for the size change. If you 
specify resolution but not size, the size changes 
automatically to compensate for the resolution 
change. 

5 Drag over the area you want to keep with the 
crop tool, and then press Enter (Windows) or 
Return (Mac OS). 

To crop an image using the Crop command:

1 Use the rectangle marquee tool ( ) to select the 
part of the image you want to keep. Make sure the 
Feather option in the options bar is set to 0 pixels. 
For more information about setting marquee 
options, see “Using the marquee tools” on 
page 115.

2 Choose Image > Crop.

3 Choose an option to hide or delete the cropped 
area:

• Select Hidden to hide the cropped areas of the 
image. The cropped areas are still in the image file 
and can be made visible by moving the layer with 
the move tool ( ).

• Select Deleted to delete the cropped areas. 

4 Click OK.

To crop an image using the Trim command:

1 Choose Image > Trim.

2 Crop the border:

• Select Transparent Pixels to remove an area of 
transparent pixels from the image.

• Select Top Left Pixel Color to remove an area the 
color of the upper left pixel from the image.

• Select Bottom Right Pixel Color to remove an 
area the color of the lower right pixel from the 
image.

3 Select one or more areas of the image to be 
trimmed: Top, Bottom, Left, or Right.

4 Click OK.

Changing the size of the work 
canvas
The Canvas Size command lets you add or remove 
work space around an existing image. You can crop 
an image by decreasing the canvas area. Added 
canvas appears in the same color or transparency 
as the background.

To change the size of the work canvas: 

1 Choose Image > Canvas Size.

2 In Photoshop, choose the units of measurement 
you want. The Columns option measures width in 
terms of the columns specified in the Rulers & 
Units preferences.

3 Enter the dimensions for Width and Height. A 
new file size appears.

4 In ImageReady, select the Relative option to 
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<<Reviewers—What is function of Relative 
option?>>

5 For Anchor, click a square to position the 
existing image on the new canvas. 

6 Click OK.
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Chapter 3: Working with Color Modes

amiliarity with color theory and termi-
nology can help you understand how color 
is measured and how Adobe Photoshop and 

Adobe ImageReady use this information to define, 
display, and print color values.

<<What is the default mode in ImageReady?>>

About color modes and models 
(Photoshop)
A color mode determines the color model used to 
display and print images. Photoshop bases its 
color modes on established models for describing 
and reproducing color. Common models include 
HSB (for hue, saturation, brightness); RGB (for 
red, green, blue); CMYK (for cyan, magenta, 
yellow, black); and CIE L*a*b. Photoshop also 
includes modes for specialized color output such 
as indexed color and duotones.

In addition to determining the number of colors 
that can be displayed in an image, color modes 
affect the number of channels and the file size of an 
image.

<<Move information on specific color modes to 
webstudio or help only.>>

Depending on how your Info palette is set up, 
you can select any tool, position the pointer over 

any part of an image, and determine the color value 
under the pointer. You can customize the Info palette 
and color samplers to express color values using the 
HSB, RGB, CMYK, Lab, or Grayscale modes 
without changing the mode of the image itself. For 
more information on measuring color with the Info 
palette and color samplers, see “Seeing the color 
values of pixels” on page 91 and the procedure to 
change Info palette options in “Using the Info 
palette” on page 5.

HSB model

Based on the human perception of color, the HSB 
model describes three fundamental characteristics 
of color:

• Hue is the color reflected from or transmitted 
through an object. It is measured as a location on 
the standard color wheel, expressed as a degree 
between 0∞ and 360∞. In common use, hue is 
identified by the name of the color such as red, 
orange, or green. 

• Saturation, sometimes called chroma, is the 
strength or purity of the color. Saturation repre-
sents the amount of gray in proportion to the hue, 
measured as a percentage from 0% (gray) to 100% 
(fully saturated). On the standard color wheel, 
saturation increases from the center to the edge.

F
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• Brightness is the relative lightness or darkness of 
the color, usually measured as a percentage from 
0% (black) to 100% (white).

Although you can use the HSB model in 
Photoshop to define a color in the Color palette or 
Color Picker dialog box, there is no HSB mode 
available for creating and editing images.

A. Saturation B. Hue C. Brightness D. All hues

RGB model

A large percentage of the visible spectrum can be 
represented by mixing red, green, and blue (RGB) 
colored light in various proportions and inten-
sities. Where the colors overlap, they create cyan, 
magenta, and yellow.

Because the RGB colors combine to create white, 
they are also called additive colors. Adding all 
colors together creates white—that is, all light is 
reflected back to the eye. Additive colors are used 
for lighting, video, and monitors. Your monitor, 
for example, creates color by emitting light 
through red, green, and blue phosphors.

 
Additive colors (RGB)

RGB mode

Photoshop’s RGB mode uses the RGB model, 
assigning an intensity value to each pixel ranging 
from 0 (black) to 255 (white) for each of the RGB 
components in a color image. For example, a 
bright red color might have an R value of 246, a 
G value of 20, and a B value of 50. When the values 
of all three components are equal, the result is a 
shade of gray. When the value of all components is 
255, the result is pure white; when the value is 0, 
pure black.

A
B

C
D
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RGB images use three colors to reproduce up to 
16.7 million colors on-screen. RGB images are 
three-channel images, so they contain 24 (8 x 3) 
bits per pixel. RGB is the default mode for new 
Photoshop images. Computer monitors always 
display colors using the RGB model. This means 
that when working in color modes other than 
RGB, such as CMYK, Photoshop temporarily 
converts data into RGB data for display on-screen. 

CMYK model

The CMYK model is based on the light-absorbing 
quality of ink printed on paper. As white light 
strikes translucent inks, part of the spectrum is 
absorbed and part is reflected back to your eyes. 

In theory, pure cyan (C), magenta (M), and yellow 
(Y) pigments should combine to absorb all color 
and produce black. For this reason these colors are 
called subtractive colors. Because all printing inks 
contain some impurities, these three inks actually 
produce a muddy brown and must be combined 
with black (K) ink to produce a true black. (K is 
used instead of B to avoid confusion with blue.) 
Combining these inks to reproduce color is called 
four-color process printing.

The subtractive (CMY) and additive (RGB) colors 
are complementary colors. Each pair of subtractive 
colors creates an additive color, and vice versa.

 
Subtractive colors (CMYK)

CMYK mode

In Photoshop’s CMYK mode, each pixel is 
assigned a percentage value for each of the process 
inks. The lightest (highlight) colors are assigned 
small percentages of process ink colors, the darker 
(shadow) colors higher percentages. For example, 
a bright red might contain 2% cyan, 93% magenta, 
90% yellow, and 0% black. In CMYK images, pure 
white is generated when all four components have 
values of 0%.

Use the CMYK mode when preparing an image to 
be printed using process colors. Converting an 
RGB image into CMYK creates a color separation. 
If you start with an RGB image, it’s best to edit first 
and then convert to CMYK. In RGB mode, you can 
use the Proof Setup commands to simulate the 
effects of the change without actually changing 
image data. (See “Previewing CMYK colors in 
RGB (Photoshop)” on page 93.) You can also use 
CMYK mode to work directly with CMYK images 
scanned or imported from high-end systems.
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L*a*b model

The L*a*b color model is based on the model 
proposed by the Commission Internationale 
d’Eclairage (CIE) in 1931 as an international 
standard for color measurement. In 1976, this 
model was refined and named CIE L*a*b.

L*a*b color is designed to be device independent; 
creating consistent color whatever the device (such 
as monitor, printer, computer, or scanner) used to 
create or output the image.

L*a*b color consists of a luminance or lightness 
component (L) and two chromatic components: 
the a component (from green to red) and the 
b component (from blue to yellow).

A. Luminance=100 (white)  
B. Green to red component  
C. Blue to yellow component  
D. Luminance=0 (black) to 
red component 

Lab mode

In Photoshop’s Lab mode (the asterisks are 
dropped from the name), the lightness component 
(L) can range from 0 to 100. The a component 
(green-red axis) and the b component (blue-
yellow axis) can range from +120 to –120.

You can use Lab mode to work with Photo CD 
images, edit the luminance and the color values in 
an image independently, move images between 
systems, and print to PostScript® Level 2 and Level 
3 printers. To print Lab images to other color 
PostScript devices, convert to CMYK first. 

Lab color is the internal color model Photoshop 
uses when converting from one color mode 
to another.

Specialized color modes

Photoshop also provides specialized color modes.

Bitmap mode Uses one of two color values (black 
or white) to represent the pixels in an image. 
Images in Bitmap mode are called bitmapped, or 
1-bit, images because they have a bit depth of 1. 
(See “About bit depth” on page 51.)

Grayscale mode Uses up to 256 shades of gray. 
Every pixel of a grayscale image has a brightness 
value ranging from 0 (black) to 255 (white). 
Grayscale values can also be measured as 
percentages of black ink coverage (0% is equal to 
white, 100% to black). Images produced using 
black-and-white or grayscale scanners typically are 
displayed in Grayscale mode. You can convert both 
Bitmap-mode and color images to grayscale. 

To convert a color image to a high-quality black-
and-white image, Photoshop discards all color 
information in the original image. The gray levels 
(shades) of the converted pixels represent the 
luminosity of the original pixels.

You can mix information from the color 
channels to create a custom grayscale channel 

by using the Channel Mixer command.
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When converting from grayscale to RGB, the color 
values for a pixel are based on its previous gray 
value. A grayscale image can also be converted to a 
CMYK image (for creating process-color 
quadtones without converting to Duotone mode) 
or to a Lab color image.

Duotone mode Creates duotone (two-color), 
tritone (three-color), and quadtone (four-color) 
grayscale images using two to four colored inks. 
(See “Using monotones, duotones, tritones, and 
quadtones” on page 425.) <<Xref destination?>>

Indexed color mode Uses at most 256 colors. When 
converting to indexed color, Photoshop builds a 
color lookup table (CLUT), which stores and 
indexes the colors in the image. If a color in the 
original image does not appear in the table, the 
program chooses the closest one or simulates the 
color using available colors. 

By limiting the palette of colors, indexed color can 
reduce file size while maintaining visual quality—
for example, for a multimedia animation appli-
cation or a Web page. Limited editing is available 
in this mode. For extensive editing you should 
convert temporarily to RGB mode. 
(See “Converting to indexed color (Photoshop)” 
on page 56.)

Multichannel mode Uses 256 levels of gray in each 
multiple channel. Multichannel images are useful 
for specialized printing—for example, converting 
a duotone for printing in Scitex CT format.

These guidelines apply to converting images to 
Multichannel mode:

• You can convert any image composed of more 
than one channel to a multichannel image. The 
original channels are converted to spot color 
channels.

• When converting a color image to multichannel, 
the new grayscale information is based on the 
color values of the pixels in each channel. 

• Converting a CMYK image to multichannel 
creates cyan, magenta, yellow, and black spot 
channels.

• Converting an RGB image to multichannel 
creates cyan, magenta, and yellow spot channels.

• Deleting a channel from an RGB, a CMYK, or a 
Lab image automatically converts the image to 
multichannel mode. See “Color channels 
(Photoshop)” on page 50 for more information on 
channels. 

Note: You cannot print a color composite from 
Multichannel mode. Also, most export file formats 
do not support multichannel mode images. 
However, you can export the file in Photoshop 
DCS 2.0 format.

Color gamuts (Photoshop)
<<To webstudio or help only.>>

A gamut is the range of colors that a color system 
can display or print. The spectrum of colors seen 
by the human eye is wider than the gamut available 
in any color model. 



CHAPTER 350
Working with Color Modes

Among the color models used in Photoshop, 
L*a*b has the largest gamut, encompassing all 
colors in the RGB and CMYK gamuts. Typically, 
the RGB gamut contains the subset of these colors 
that can be viewed on a computer or television 
monitor (which emits red, green, and blue light). 
Therefore, some colors, such as pure cyan or pure 
yellow, can’t be displayed accurately on a monitor.

The CMYK gamut is smaller, consisting only of 
colors that can be printed using process-color 
inks. When colors that cannot be printed are 
displayed on-screen, they are referred to as out-of-
gamut colors—that is, outside the CMYK gamut. 
(See “Identifying out-of-gamut colors 
(Photoshop)” on page 94.)

A. Lab color gamut B. RGB color gamut  
C. CMYK color gamut

Color channels (Photoshop)
<<To webstudio or help only.>>

Every Adobe Photoshop image has one or more 
channels, each storing information about color 
elements in the image. The number of default 
color channels in an image depends on its color 
mode. For example, a CMYK image has at least 
four channels, one each for cyan, magenta, yellow 
and black information. Think of a channel as 
analogous to a plate in the printing process, with a 
separate plate applying each layer of color. 

In addition to these default color channels, extra 
channels, called alpha channels, can be added to an 
image for storing and editing selections as masks; 
and spot color channels can be added, to add spot 
color plates for printing. (See “Storing masks in 
alpha channels” on page 217 and “Adding spot 
colors” on page 211.)

An image can have up to 24 channels. By default, 
Bitmap-mode, grayscale, duotone, and indexed-
color images have one channel; RGB and Lab 
images have three; and CMYK images have four. 
You can add channels to all image types except 
Bitmap-mode images. 

Adjusting the monitor display
Although the RGB color model used by computer 
monitors is capable of displaying much of the 
visible spectrum, the video system sending data to 
a given monitor often limits how many colors can 
be displayed at once. By understanding how color 
data is measured in digital files and on-screen, you 
can better adjust color display settings to offset the 
limitations of your video system.
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This understanding also will help you choose a file 
format for your images. For more information, 
see “Saving and Exporting Images” on page 375.

About bit depth

Bit depth—also called pixel depth or color depth—
measures how much color information is available 
to display or print pixels in an image. Greater bit 
depth (more bits of information per pixel) means 
more available colors and more accurate color 
representation in the digital image. For example, a 
pixel with a bit depth of 1 has two possible values: 
black and white. A pixel with a bit depth of 8 has 
28, or 256, possible values. And a pixel with a bit 
depth of 24 has 224, or roughly 16 million, possible 
values. Common values for bit depth range from 1 
to 64 bits per pixel.

Photoshop supports up to 16 bits per pixel for each 
channel in an image. A 24-bit RGB image, for 
example, would have 8 bits per pixel for each of the 
red, green, and blue channels.

Selecting a dither option for 8-bit color 
displays (Photoshop)

Each image mode in Adobe Photoshop uses a color 
lookup table, or color palette, to store the colors 
used in the image. When you’re working with a 
display system that supports 8-bit color (or fewer 
colors), the monitor displays only 256 different 
colors at a time. For example, a 24-bit RGB image 
can display 16.7 million colors in any image at a 
time. However, if the monitor can display only 256 
of the 16.7 million colors, Adobe Photoshop uses a 
technique called dithering to mix pixels of available 
colors and thus simulate colors not currently 
available.

By default, Adobe Photoshop uses pattern 
dithering, which can result in a distinctive pattern 
of darker or lighter areas in the image. In contrast, 
diffusion dithering eliminates this distinctive 
patterning by using the surrounding pixels in the 
mix of pixel color. But diffusion dithering can 
cause visual inconsistencies when only part of a 
screen is redrawn as you scroll, edit, or paint. Keep 
in mind that dithering effects only appear on-
screen, not in print. 

To select a color display option:

1 Choose Edit > Preferences > Display & Cursors.

2 Choose one or both of these display options:

• System Palette to use the system’s standard 
256-color palette.

<<Reviewers: Please confirm that the System 
palette option is no longer in Photoshop.>>

• Diffusion Dither to minimize dither patterns 
produced by dithering.
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Adjusting color display for cross-platform 
variations (ImageReady)

<<Reviewers: Please confirm this feature is IR 
only.>>

RGB color display on a computer monitor 
varies with the operating system used by the 
computer. For example, an image appears darker 
on a Windows system than on a Mac OS computer 
(because the standard RGB color space is darker in 
Windows than in Mac OS). The Preview 
commands in ImageReady enable you to 
compensate for cross-platform differences in RGB 
color display during image preview. 

RGB color display can also vary between 
Photoshop and ImageReady. In Photoshop, you 
can select from several RGB color spaces when 
editing images. As a result, images created in 
Photoshop may use an RGB color space that differs 
from the monitor RGB color space used by 
ImageReady. You can adjust the RGB color display 
during image preview to compensate for differ-
ences between Photoshop and ImageReady. (This 
ImageReady feature is available only when viewing 
Photoshop-format images which were created and 
color-space tagged in Photoshop.) 

To adjust RGB color display for cross-platform 
variations:

Choose View > Preview and choose an option for 
adjusting the color display:

• Uncompensated Color (the default option) to 
view the image with no color adjustment.

• Standard Macintosh Color (Windows) to view 
the image with color adjusted to simulate Mac OS 
color display. 

• Standard Windows Color (Mac OS) to view the 
image with color adjusted to simulate Mac OS 
color display. 

Note: These options adjust color display only. No 
changes are made to pixels in the image. 

To adjust RGB color display in ImageReady to match 
color display in Photoshop:

Choose View > Preview > Photoshop 
Compensation.

Note: In order to use the Photoshop Compensation 
option in ImageReady, you must save the original 
image in Photoshop, with the Embed Profiles option 
turned on (the default setting). 

Converting between bit depths 
(Photoshop)
In most cases, RGB, grayscale, and CMYK images 
contain 8 bits of data per color channel. With three 
channels in an RGB image, this translates to a 
24-bit RGB bit depth (8 bits x 3 channels), an 8-bit 
grayscale bit depth (8 bits x 1 channel), and a 
32-bit CMYK bit depth (8 bits x 4 channels). 
Photoshop can also read and import 48-bit RGB, 
64-bit CMYK, and 16-bit grayscale images (each 
with 16 bits of data per color channel). 

Note: A16-bit-per-channel image provides finer 
distinctions in color, but its file size is much larger 
than an 8-bit-per-channel image.
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Photoshop supports these tools and commands in 
16-bit-per-channel images: the marquee, lasso, 
crop, measure, zoom, hand, pen, eyedropper, 
color sampler, and rubber stamp tools; and the 
Duplicate, Feather, Modify, Levels, Auto Levels, 
Curves, Histogram, Hue/Saturation, 
Brightness/Contrast, Color Balance, Equalize, 
Invert, Channel Mixer, Image Size, Transform 
Selection, and Rotate Canvas commands. To take 
full advantage of Photoshop’s features, you can 
convert a 16-bit-per-channel image to an 8-bit-
channel image. 

To convert from 8 bits per channel to 16 bits per 
channel:

1 Flatten the image you want to convert. 
(See “Flattening all layers” on page 249.)

2 Choose Image > Mode > 16 Bits/Channel.

To convert from 16 bits per channel to 8 bits per 
channel:

Choose Image > Mode > 8 Bits/Channel.

Choosing a color mode 
(Photoshop)
When you choose a different color mode for an 
image, you permanently change the color values in 
the image. For example, when you convert an RGB 
image to CMYK mode, RGB color values outside 
the CMYK gamut are adjusted to fall within the 
CMYK gamut. Consequently, before converting 
images, it’s best to do the following:

• Do as much editing as possible in the image’s 
original mode (usually RGB from most scanners, 
or CMYK from traditional drum scanners or if 
imported from Adobe Illustrator or from a Scitex 
system). 

• Save a backup copy before converting. Be sure to 
save a copy of your image that includes all layers in 
order to edit the original version of the image after 
the conversion.

• Flatten the file before converting it. The inter-
action of colors between layer blending modes will 
change when the mode changes.

To convert an image to another mode:

Choose Image > Mode and the mode you want 
from the submenu. Modes not available for the 
active image appear dimmed in the menu. 

The following mode conversions flatten the image: 

• RGB to Indexed color or Multichannel mode.

• CMYK to Multichannel mode. 

• Lab to Multichannel, Bitmap, or Grayscale 
mode.

• Grayscale to Bitmap, Indexed, or Multichannel 
mode.

• Duotone to Bitmap, Indexed, or Multichannel 
mode.
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Converting between Grayscale 
mode and Bitmap mode 
(Photoshop)
Converting an image to Bitmap mode reduces the 
image to two colors, greatly simplifying the color 
information in the image and reducing its file size. 
To convert an image to Bitmap mode, you must 
first convert it to Grayscale mode. This removes 
the hue and saturation information from the 
pixels and leaves just the brightness values. 
However, because few editing options are available 
for Bitmap-mode images, it’s usually best to edit 
the image in Grayscale mode and then convert it. 

Keep in mind that a Bitmap-mode image edited in 
Grayscale mode may not look the same when 
converted back to Bitmap mode. For example, a 
pixel that is black in Bitmap mode and then edited 
in Grayscale mode may be converted to a shade of 
gray. If the pixel is light enough, it will be white 
when converted back to Bitmap mode.

To convert an image to Bitmap mode:

1 Do one of the following:

• If the image is in color, choose Image > Mode > 
Grayscale. Then choose Image > Mode > Bitmap.

• If the image is grayscale, choose Image > Mode > 
Bitmap.

2 For Output, enter a value for the output 
resolution of the Bitmap-mode image, and choose 
a unit of measurement. By default, the current 
image resolution appears as both the input and the 
output resolutions.

3 Select a bitmap conversion method, and click 
OK. If you choose Halftone Screen, see the 
following section. For other conversion methods, 
see “Additional bitmap conversion options” on 
page 55.

To convert a Bitmap-mode image to grayscale:

1 Choose Image > Mode > Grayscale.

2 Enter a value between 1 and 16 for the size ratio.

The size ratio is the factor for scaling down the 
image. For example, to reduce a grayscale image by 
50%, enter 2 for the size ratio. If you enter a 
number greater than 1, the program averages 
multiple pixels in the Bitmap-mode image to 
produce a single pixel in the grayscale image. This 
process lets you generate multiple shades of gray 
from an image scanned on a 1-bit scanner. 

Specifying a halftone screen for a Bitmap-
mode image

The Halftone Screen option in the Bitmap dialog 
box lets you convert a grayscale image to simulated 
halftone dots.

Important: The halftone screen becomes part of the 
image. If you print the image on a halftone printer, 
it will print with the halftone screen you choose here 
plus that of the printer. On some printers, the result 
probably will be a moiré pattern in the image.

To specify the halftone screen for a Bitmap-mode 
image: 

1 Choose Image > Mode > Bitmap.

2 Click Halftone Screen; then click OK.
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3 For Frequency, enter a value for the screen 
frequency, and choose a unit of measurement. 
Values can range from 1 to 999 for lines per inch 
and from 0.400 to 400 for lines per centimeter. You 
can enter decimal values. 

The screen frequency specifies the ruling of the 
halftone screen in lines per inch (lpi). The 
frequency depends on the paper stock and type of 
press used for printing. Newspapers commonly 
use an 85-line screen. Magazines use higher 
resolution screens, such as 133 lpi and 150 lpi. 
Check with your print shop for correct screen 
frequencies.

4 Enter a value for the screen angle in degrees 
from –180 to +180. 

The screen angle refers to the orientation of the 
screen. Continuous-tone and black-and-white 
halftone screens commonly use a 45° angle. 

5 For Shape, choose the dot shape you want.

6 Click OK.

Original grayscale image, and Halftone Screen conversion: 
53 lpi, 45° angle, round dot

You can save and reuse halftone screen settings by 
using the Save and Load buttons in the Halftone 
Screen dialog box.

Additional bitmap conversion options

Like the Halftone Screen option, the other bitmap 
conversion options determine the quality of the 
Bitmap-mode image.

50% Threshold Converts pixels with gray values 
above the middle gray level (128) to white and 
below to black. The result is a very high-contrast, 
black-and-white representation of the image.

Pattern Dither Converts an image by organizing 
the gray levels into geometric configurations of 
black-and-white dots.
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Diffusion Dither Converts an image by using an 
error-diffusion process, starting at the pixel in the 
upper left corner of the image. If the pixel’s value 
is above middle gray (128), the pixel is changed 
to white—if below, to black. Because the original 
pixel is rarely pure white or pure black, error is 
inevitably introduced. This error is transferred to 
surrounding pixels and diffused throughout the 
image, resulting in a grainy, filmlike texture. This 
option is useful for viewing images on a black-
and-white screen.

Original grayscale image, and 50% Threshold 
conversion method

Pattern Dither conversion method, and Diffusion Dither 
conversion method

Custom Pattern Simulates the effect of printing a 
grayscale image through a custom halftone screen. 
This method lets you apply a screen texture, such 
as a wood grain, to an image. To use this option, 
you must first define a pattern (see “Filling and 
stroking selections and layers” on page 191).

You can create a pattern representing the texture 
you want and then screen the grayscale image to 
apply the texture. To cover the entire image, the 
pattern must be as large as the image. Otherwise, 
the pattern will be tiled. For example, if you apply 
a 1-inch-by-1-inch pattern to a 4-inch-by-4-inch 
image, the pattern appears as 16 squares. Adobe 
Photoshop comes with several self-tiling patterns 
that can be used as halftone screen patterns 
(see the procedure to use a pattern from the 
PostScript Patterns folder in “Filling and stroking 
selections and layers” on page 191).

Because the Custom Pattern option simulates dark 
and light colors by making the halftone pattern 
thicker and thinner, it makes sense to choose a 
pattern that lends itself to thickness variations, 
typically one with a variety of gray shades. 

To prepare a black-and-white pattern for 
conversion, you can first convert the image to 

grayscale and then apply the Blur More filter several 
times. This blurring technique creates thick lines 
tapering from dark gray to white. 

Converting to indexed color 
(Photoshop)
<<Get new info from 5.5 Supplement, Chapter 2, 
“Converting to indexed color.”>>
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Converting to indexed color deletes all but 256 
colors from the image—the standard number of 
colors supported by many multimedia animation 
applications and Web pages. Converting an 
RGB image to indexed color lets you edit the 
image’s color table or export it to an application 
supporting only 8-bit color. The conversion also 
reduces the file size by deleting color information 
from the image.

To convert an RGB image to an indexed-color image:

1 Choose Image > Mode > Indexed Color.

Note: The image must be flattened first, or you will 
lose layers.

2 Select Preview to display a preview of the 
changes.

3 Specify conversion options as described in the 
following sections.

4 Click OK.

Specifying a palette 

A number of palette types are available for 
converting an image to indexed color. For the 
Perceptual, Selective, and Adaptive options, you 
can choose between using a local palette based on 
the current image’s colors or a master palette 
created in ImageReady. (See “Using master 
palettes” on page 356.)

Exact Creates a palette using the exact colors 
appearing in the RGB image—an option available 
only if the image uses 256 or fewer colors. Because 
the image’s palette contains all colors in the image, 
there is no dithering. 

System (Windows) Uses the Windows system’s 
default 8-bit palette, which is based on a uniform 
sampling of RGB colors. 

System (Mac OS) Uses the Mac OS default 8-bit 
palette, which is based on a uniform sampling of 
RGB colors. 

Web Uses the palette most often used by Web 
browsers to display 8-bit images. This palette is a 
subset of the Windows and Macintosh systems’ 
palettes.

Uniform Creates a palette by uniformly sampling 
colors from the spectrum. For example, if you 
choose an 8-bit color depth, Photoshop takes 6 
evenly spaced color levels each of red, green, and 
blue and calculates the combinations of these 
colors to produce a uniform palette of 216 colors 
(6 x 6 x 6 = 216). A lower bit depth creates a 
uniform palette composed of fewer colors. The 
total number of colors displayed in the image 
corresponds to the cube nearest the chosen bit 
depth (8, 27, 64, 125, or 216).

Perceptual Creates a custom palette by giving 
priority to colors for which the human eye has 
greater sensitivity.

Selective Creates a color table similar to the 
Perceptual color table, but favoring broad areas of 
color and the preservation of Web colors.

Adaptive Creates a palette by sampling the colors 
from the spectrum appearing most commonly in 
the image. For example, an RGB image with only 
the colors green and blue produces a palette made 
primarily of greens and blues. Most images 
concentrate colors in particular areas of the 
spectrum. 
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To control a palette more precisely, first select a 
part of the image containing the colors you want to 
emphasize. Photoshop weights the conversion 
toward these colors.

Custom Creates a custom palette using the Color 
Table dialog box. Either edit the color table and 
save it for later use or click Load to load a previ-
ously created color table. (See “Specifying color 
matching options” on page 59.) 

This option also displays the current adaptive 
palette, which is useful for previewing the colors 
most often used in the image.

Previous Uses the custom palette from the 
previous conversion, making it easy to convert 
several images with the same custom palette.

Specifying the bit depth

For the Uniform, Perceptual, Selective, or Adaptive 
palette, you can specify the bit depth of an 
indexed-color image—the number of bits of color 
information per pixel. Bit depth, also known as 
color depth, determines the number of colors used 
to display (or print) an image. For example, if you 
choose 4 bits per pixel, the image is composed of 
16 colors; 6 bits per pixel, 64 colors; 8 bits per pixel, 
256 colors. (The number of colors used is 
displayed in the Colors text box.) In addition, you 
can specify the exact number of colors to be 
displayed (up to 256) by choosing Other for Color 
Depth and entering a value for Colors. 

The options in the Indexed Color dialog box 
control only how the indexed color table is created. 
Adobe Photoshop still treats the image as an 8-bit, 
256-color image.

Forcing the inclusion of colors

You can choose an option from the Forced menu 
to force the inclusion of certain colors in the color 
table. The Black and White option adds a pure 
black and a pure white to the color table; the 
Primaries option adds red, green, blue, cyan, 
magenta, yellow, black, and white; the Web option 
adds the 216 web-safe colors; and the Custom 
option lets you define custom colors to add.

Specifying transparency

Select the Transparency option to preserve trans-
parent areas of the image during conversion. 
Deselecting Transparency fills transparent areas 
with the matte color, or with white if no matte 
color is chosen.

Choosing a matte color

Choose a matte option to fill partially transparent 
areas with a color. If Transparency is selected, the 
matte is applied to partially transparent edge areas 
to help blend the edges with the background. If 
Transparency is deselected, the matte is applied to 
both partially and fully transparent areas. 
Choosing None for the matte creates hard-edged 
transparency if Transparency is selected; 
otherwise, all partially and fully transparent areas 
are filled with 100% white.
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Specifying dither options

Unless you’re using the Exact color table option, 
the color table may not contain all the colors used 
in the image. To simulate colors not in the color 
table, you can dither the colors. Dithering mixes 
the pixels of the available colors to simulate the 
missing colors. 

Choose a dither option from the menu, and enter 
a value for the dither amount. A higher amount 
dithers more colors, but may increase file size. To 
protect colors in the color table from being 
dithered, select Preserve Exact Colors. You can 
choose from the following dither options:

None Does not dither colors but instead uses the 
color closest to the missing color. This tends to 
result in sharp transitions between shades of color 
in the image, creating a posterized effect.

Diffusion Uses an error-diffusion method that 
produces a less structured dither than the Pattern 
option.

Pattern Uses a halftone-like square pattern to 
simulate any colors not in the color table. This 
option is available only when you’re using the 
System (Mac OS) palette, the Web palette, or the 
Uniform (216 colors) palette.

Noise Helps to reduce seam patterns along the 
edges of image slices. Choose this option if you 
plan to slice the image for placement in an HTML 
table. The Noise option helps to reduce seam 
patterns along sliced edges.

Specifying color matching options

You can choose from three options to match colors 
in the original image when dithering:

Best Finds the best possible match for each pixel. 
Although this option takes longer to process, it can 
provide a better image. This option is only 
available if you choose None or Diffusion for the 
dithering option.

Faster Takes less time than Best, but may not find 
the best color match for each pixel. This option is 
only available if you choose None or Diffusion for 
the dithering option.

Preserve Exact Colors Prevents colors that are 
already in the chosen palette from being dithered. 
This is useful for preserving fine lines and text for 
Web images. This option is only available if you 
choose Diffusion for the dithering option.

Manipulating the color table

You can change one or more colors in the color 
table of an indexed-color image, assign trans-
parency to a single color, edit colors to produce 
special effects, model the colors after a predefined 
color table, and save a color table for reuse with 
other indexed-color images. 
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Another type of image with fewer than 256 colors 
is a pseudocolor image—a grayscale image 
displaying variations in gray levels with color 
rather than shades of gray, and often used in scien-
tific and medical applications. The color table-
editing features are particularly useful with 
pseudocolor images, but can also produce special 
effects with indexed-color images having a limited 
number of colors.

Note: Simply to change colors in an image, choose 
Image > Adjust, and use the color adjustment 
commands in the submenu. For a summary 
description of these commands, see “Basic steps for 
correcting images” on page 85.

To edit colors in the color table:

1 Open the indexed-color image.

2 Choose Image > Mode > Color Table.

3 Click or drag in the table to choose the color or 
range of colors you want to change. 

4 Choose the color you want, as explained in 
“Using the Adobe Color Picker” on page 198, and 
click OK. 

If you are changing a range of colors, Photoshop 
creates a gradient in the color table between the 
starting and ending colors. The first color you 
choose in the Color Picker is the beginning color 
for the range. When you click OK, the Color Picker 
reappears so that you can choose the last color in 
the range.

The colors you selected in the Color Picker are 
placed in the range you selected in the Color Table 
dialog box.

5 Click OK in the Color Table dialog box to apply 
the new colors to the indexed-color image.

To assign transparency using the color table:

1 Choose Image > Mode > Color Table.

2 Select the eyedropper, and click the desired 
color in the table. The sampled color is replaced 
with transparency in the image.

3 Click OK to close the color table. 

Choosing a color-table option

Your indexed color table can be modeled after 
predefined color tables, which you select from the 
Table menu in the Color Table dialog box. 

Custom Creates a palette you specify.

Black Body Displays a palette based on the 
different colors a blackbody radiator emits as it is 
heated—from black to red, orange, yellow, and 
white. 

Grayscale Displays a palette based on 256 levels of 
gray—from black to white. 

Spectrum Displays a palette based on the colors 
produced as white light passes through a prism— 
from violet, blue, and green to yellow, orange, 
and red. 

System (Windows) Displays the standard Windows 
256-color system palette. 

System (Mac OS) Displays the standard Mac OS 
256-color system palette.
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Saving and loading a color table 

You use the Save and Load buttons in the Color 
Table dialog box to save your indexed color tables 
for use with other Adobe Photoshop images. Once 
you load a color table into an image, the colors in 
the image change to reflect the color positions they 
reference in the new color table. 

Note: You can also load saved color tables into the 
Swatches palette. See the procedure to save and reuse 
custom swatch sets in “Using the Swatches palette” 
on page 197.
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Chapter 4: Producing Consistent Color

hen your document must meet color 
standards set by clients and designers, 
viewing and editing color consistently 

becomes critical, all the way from scanning source 
images to creating final output. A color 
management system reconciles color differences 
among devices so that you can be reasonably 
certain of the colors your system ultimately 
produces.

Why colors sometimes 
don’t match
No device in a publishing system is capable of 
reproducing the full range of colors viewable to the 
human eye. Each device operates within a specific 
color space which can produce a certain range, or 
gamut, of colors.

The RGB (red, green, blue) and CMYK (cyan, 
magenta, yellow, and black) color models 
represent two main categories of color spaces. The 
gamuts of the RGB and CMYK spaces are very 
different; while the RGB gamut is generally larger 
(that is, capable of representing more colors) than 
CMYK, some CMYK colors still fall outside the 
RGB gamut (see “Color gamuts (Photoshop)” on 
page 49 for an illustration). In addition, different 
devices produce slightly different gamuts within 
the same color model. For example, a variety of 
RGB spaces can exist among scanners and 
monitors, and a variety of CMYK spaces can exist 
among printing presses.

Because of these varying color spaces, colors can 
shift in appearance as you transfer documents 
between different devices. Color variations can 
result from different image sources (scanners and 
software produce art using different color spaces), 
differences in brands of computer monitors, 
differences in the way software applications define 
color, differences in print media (newsprint paper 
reproduces a smaller gamut than magazine-
quality paper), and other natural variations, such 
as manufacturing differences in monitors or 
monitor age.

About color management
Because color-matching problems result from 
various devices and software using different color 
spaces, one solution is to have a system that inter-
prets and translates color accurately between 
devices. A color management system (CMS) 
compares the color space in which a color was 
created to the color space in which the same color 
will be output, and makes the necessary adjust-
ments to represent the color as consistently as 
possible among different devices.

The following components are integral to a color-
managed workflow:

W
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Device-independent color space To successfully 
compare different device gamuts and make adjust-
ments, a color management system must use a 
reference color space—an objective way of 
defining color. Most CMSs use the internal CIE 
(Commission Internationale d’Eclairage) LAB 
color model, which exists independently of any 
device and is large enough to reproduce any color 
visible to the human eye. For this reason, CIE LAB 
is considered device-independent.

Color management engine Different companies 
have developed various ways to manage color. To 
provide you with a choice, a color management 
system lets you choose a color management engine 
that represents the approach you want to use. 
Sometimes called the color management module 
(CMM), the color management engine is the part 
of the CMS that does the work of reading and 
translating colors between different color spaces. 

Color profiles The CMS translates colors with the 
help of color profiles. A profile is a mathematical 
description of a device’s color space, that is, how 
the reference CIE values of each color in the color 
space map to the visual appearance produced by 
the device. For example, a scanner profile tells a 
CMS how your scanner “sees” colors so that an 
image from your scanner can be translated into the 
CIE color space accurately. From the CIE space, 
the colors can then be translated accurately again, 
via another profile, to the color space of an output 
device. Photoshop uses ICC profiles, a format 
defined by the International Color Consortium 
(ICC) as a cross-platform standard.

Rendering intents No single color translation 
method can manage color correctly for all types of 
graphics. For example, a color translation method 
that preserves correct relationships among colors 
in a wildlife photograph may alter the colors in a 
logo containing flat tints of color. Color 
management engines provide a choice of rendering 
intents, or translation methods, so that you can 
apply a method appropriate to a particular 
graphical element. For descriptions of the 
rendering intents available to Photoshop, 
see “Specifying a rendering intent” on page 74.

Note: Don’t confuse color management with color 
correction. A CMS won’t correct an image that was 
saved with tonal or color balance problems. It 
provides an environment where you can evaluate 
images reliably in the context of your final output.

Creating a viewing environment 
for color management
Your work environment influences how you see 
color on your monitor and on printed output. For 
best results, control the colors and light in your 
work environment by doing the following:

• View your documents in an environment that 
provides a consistent light level and color temper-
ature. For example, the color characteristics of 
sunlight change throughout the day and alter the 
way colors appear on your screen, so keep shades 
closed or work in a windowless room. To eliminate 
the blue-green cast from fluorescent lighting, 
consider installing D50 (5000 degree Kelvin) 
lighting. Ideally, view printed documents using a 
D50 lightbox.
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• View your document in a room with neutral-
colored walls and ceiling. A room’s color can affect 
the perception of both monitor color and printed 
color. The best color for a viewing room is 
polychromatic gray. Also, the color of your 
clothing reflecting off the glass of your monitor 
may affect the appearance of colors on-screen.

• Match the light intensity in the room or lightbox 
to the light intensity of your monitor. View 
continuous-tone art, printed output, and images 
on-screen under the same intensity of light.

• Remove colorful background patterns on your 
monitor desktop. Busy or bright patterns 
surrounding a document interfere with accurate 
color perception. Set your desktop to display 
neutral grays only.

• View document proofs in the real-world condi-
tions under which your audience will see the final 
piece. For example, you might want to see how a 
housewares catalog looks under the incandescent 
light bulbs used in homes, or view an office 
furniture catalog under the fluorescent lighting 
used in offices. However, always make final color 
judgements under the lighting conditions 
specified by the legal requirements for contract 
proofs in your country.

Setting up color management
Photoshop simplifies the task of setting up a color-
managed workflow by gathering most color 
management controls in a single Color Settings 
dialog box. Rather than adjusting each control 
manually, you can choose from a list of predefined 
color management settings. Each predefined 
configuration includes a set of color management 
options designed to produce consistent color for a 
common publishing workflow, such as prepa-
ration for Web or domestic prepress output. These 
predefined configurations can also serve as 
starting points for customizing your own 
workflow-specific configurations.

Photoshop also uses color management policies, 
which determine how to handle color data that 
does not immediately match your current color 
management workflow. Policies are designed to 
clarify the color management decisions that you 
need to make when you open a document or 
import color data into an active document.

Keep in mind that you must specify color 
management settings before opening or creating 
files in order for the settings to take effect in 
those files.

To open the Color Settings dialog box:

Choose Edit > Color Settings.

To display helpful descriptions of the terminology 
and options in the dialog box, position the mouse 
over a section heading or menu item. These 
descriptions appear in the lower area of the 
dialog box. 
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Using predefined color management 
settings

Photoshop offers a collection of predefined color 
management settings, each with corresponding 
color profile and conversion options designed to 
preserve consistent color for a particular 
publishing workflow under typical conditions. In 
most cases, the predefined settings will provide 
sufficient color management for your needs.

Use the following guidelines to determine whether 
or not you need to use color management:

• You might not need color management if your 
production process is tightly controlled for one 
medium only. For example, you or your prepress 
service provider may prefer to tailor CMYK 
images and specify color values for a known, 
specific set of printing conditions. 

• You can benefit from color management when 
you have more variables in your production 
process. Color management is recommended if 
you anticipate reusing color graphics for print and 
online media, using various kinds of devices 
within a single medium (such as different printing 
presses), if you manage multiple workstations, or 
if you plan to print to different domestic and inter-
national presses. If you decide to use color 
management, consult with your production 
partners—such as graphic artists and prepress 
service providers—to ensure that all aspects of 
your color management workflow integrate 
seamlessly with theirs.

To choose a predefined color management setting:

1 Choose Edit > Color Settings.

2 For Settings, choose a configuration option: 

Color Management Off Uses minimal color 
management settings to emulate the behavior of 
applications that do not support color 
management. Use this option for content that will 
be output on video or as onscreen presentations.

Emulate Photoshop 4 Emulates the color workflow 
used by Adobe Photoshop 4.0 and earlier.

U.S. Prepress Defaults Manages color for content 
that will be output under common press condi-
tions in the U.S.

Europe Prepress Defaults Manages color for 
content that will be output under common press 
conditions in Europe.

Japan Prepress Defaults Manages color for content 
that will be output under common press condi-
tions in Japan.

Web Graphics Defaults Manages color for content 
that will be published on the World Wide Web.

ColorSync Workflow (Mac OS only) Manages color 
using the ColorSync 3.0 CMS with the profiles 
chosen in the ColorSync control panel. This color 
management configuration is not recognized by 
Windows systems, or by earlier versions of 
ColorSync.

When you choose a predefined configuration, the 
Color Settings dialog box updates to display the 
specific color management settings associated 
with the configuration.
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About working spaces

Among other options, predefined color 
management settings specify the default color 
profiles to be associated with the RGB and CMYK 
color models. Central to the color management 
workflow, these default profiles are known as the 
RGB and CMYK working spaces, respectively. The 
working spaces specified by predefined settings 
represent the color profiles that will produce the 
best color fidelity for several common output 
conditions. For example, the U.S. Prepress 
Defaults setting uses a CMYK working space that 
is designed to preserve color consistency under 
standard Specifications for Web Offset Publica-
tions (SWOP) press conditions.

A working space acts as the default color profile for 
newly created documents that use the associated 
color model. For example, if Adobe RGB (1998) is 
the current RGB working space, each new RGB 
document that you create will use colors within 
the Adobe RGB (1998) gamut. Working spaces 
also define the destination gamut of documents 
converted to the RGB or CMYK color model.

Using color management policies

When you specify a predefined color management 
setting, Photoshop sets up a color management 
workflow that will be used as the standard for all 
documents and color data that you open or 
import. For a newly created document, the color 
workflow operates relatively seamlessly: the 
document uses the working space profile 
associated with its color model for creating and 
editing colors, and the profile is usually embedded 
in the saved document to provide color translation 
information for the destination output device.

However, some existing documents may not use 
the working space that you have specified, and 
some existing documents may not be color-
managed. It is common to encounter the following 
exceptions to your color-managed workflow:

• You might open a document or import color 
data from a document that has not been color-
managed and lacks a profile altogether. This is 
often the case when you open a document created 
in an application that either does not support 
color management or has color management 
turned off.

• You might open a document or import color 
data from a document that contains a color profile 
different from the current working space. This 
may be the case when you open a document that 
has been created using different color 
management settings, or a document that has been 
scanned and assigned with a scanner profile.
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In either case, Photoshop must decide how to 
handle the color data in the document. A color 
management policy looks for the color profile 
associated with an opened document or imported 
color data, and compares the profile (or lack of 
profile) with the current working space to make 
default color management decisions. If the profile 
matches the working space, the colors are 
automatically brought into the color management 
workflow that you have specified, using the 
working space profile. If the profile is missing or 
does not match the working space, Photoshop 
displays a message that alerts you to the mismatch 
situation and, in many cases, lets you specify how 
to handle the colors in question. 

The following table provides a summary of the 
policy decisions you may be prompted to consider 
when opening or importing mismatched 
color data:

The predefined color management workflows are 
set to display warning or option messages when a 
default color management policy is about to be 
implemented. Although you can disable the 
repeated display of some of the messages, it is 
highly recommended that you continue to display 
all policy messages, to ensure the appropriate color 
management of documents on a case-by-case 
basis. You should only turn off message displays if 
you are very confident that you understand the 
default policy decision and are willing to accept it 
for all documents that you open. You cannot undo 
the results of a default policy decision once a 
document has been saved.

To turn off the display of a policy message:

In the message dialog box, select the Don’t Show 
Again option if it is available.

To reset the display of policy messages that have 
been disabled:

1 Choose Edit > Preferences > General.

2 Click Reset All Warning Dialogs, and click OK.

Mismatch situation Policy options that may be available

Opening non-color-
managed document 
without color profile

• Use working space for editing 
but not saving; do not color-manage 
document. 

• Use working space for editing, and 
save working space with document.

• Use another color profile for edit-
ing, and save profile with document.

Opening document 
with color profile that 
does not match work-
ing space

• Use profile (instead of working 
space) for editing, and save profile 
with document.

• Convert colors to working space, 
and save working space with 
document.

• Discard profile, and do not color-
manage document.

Importing color data 
into destination 
document

• Import and convert numeric values 
of source colors to color space of des-
tination document in order to pre-
serve color appearances.

• Import and preserve numeric 
values of source colors.

Mismatch situation Policy options that may be available
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Customizing color management 
settings
Although the predefined settings should provide 
sufficient color management for most publishing 
workflows, you may sometimes want to customize 
individual options in a configuration. For 
example, you might want to change the CMYK 
working space to a profile that matches the 
proofing system used by your service bureau.

It’s important to save your custom configurations 
so that you can reuse and share them with other 
users who use the same color management 
workflows; for more information, see “Saving and 
loading custom color management settings” on 
page 75. The color management settings that you 
customize in the Color Settings dialog box have an 
associated preferences file called AI Color Settings, 
located inside the Photoshop folder (Windows) 
or in the Preferences folder in your System 
Folder (Mac OS)

To customize color management settings:

1 Choose Edit > Color Settings.

2 To use a preset color management configuration 
as the starting point for your customization, 
choose that configuration from the Settings menu.

3 Specify the desired color settings. (As you make 
adjustments, the Settings menu option changes to 
Custom by default.) Refer to the following sections 
for detailed customization instructions. 
<<Editorial: I need a better way to refer to these 
sections that will work for online Help.>>

4 When you have finished specifying custom 
settings, click OK.

Specifying working spaces
In a color-managed workflow, each color model 
must have a working space associated with it. At 
times you may want to customize the RGB or 
CMYK working space to reflect a workflow that 
uses a particular output or display device. For 
more information, see “About working spaces” on 
page 67. 

Photoshop ships with a standard set of color 
profiles that have been recommended and tested 
by Adobe Systems for most color management 
workflows. By default, only these profiles appear 
under the working space menus. To display 
additional color profiles that you have customized 
or installed on your system, select Advanced Mode 
at the top of the Color Settings dialog box. To 
appear under a working space menu, a color 
profile must be bi-directional, that is, contain 
specifications for translating both into and out of 
color spaces. For information on installing color 
profiles, see “Adding device profiles to the color 
management system” on page 80.

<<TBD: Advanced mode also allows users to 
make custom working spaces. The documenta-
tion for these custom dialogs basically amounts to 
repeating much of the information in the old 
Photoshop 5.0 color management documenta-
tion. This information will be adapted to reflect 
the new 6.0 functionality in a future draft.>> 

Specifying RGB working spaces

For the RGB color model, the following standard 
working space options are available. 
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Adobe RGB (1998) Provides a fairly large gamut 
(range) of colors and is well-suited for documents 
that will be converted to CMYK. Use this space if 
you need to do print production work with a 
broad range of colors.

sRGB IEC61966-2.1 Reflects the characteristics of 
the average PC monitor. This standard space is 
endorsed by many hardware and software 
manufacturers, and is becoming the default color 
space for many scanners, low-end printers, and 
software applications. This space is recommended 
for Web work but not for prepress work (because 
of its limited color gamut).

Apple RGB Reflects the characteristics of the Apple 
Standard 13-inch monitor, and is used by a variety 
of desktop publishing applications, including 
Adobe Photoshop 4.0 and earlier. Use this space 
for files that you plan to display on Mac OS 
monitors, or for working with legacy (older) 
desktop publishing files.

ColorMatch RGB Matches the native color space of 
Radius Pressview monitors. This space provides a 
smaller gamut alternative to Adobe RGB (1998) 
for print production work.

Monitor RGB Sets the RGB working space to the 
current color profile of your monitor. Use this 
setting if other applications in your workflow do 
not support color management. If a color 
management configuration that specifies Monitor 
RGB is shared with another user working on a 
different system, the configuration uses that 
system’s monitor profile as the working space.

ColorSync RGB (Mac OS only) Matches the RGB 
space specified in the control panel for Apple 
ColorSync 3.0 or later. If a color management 
configuration specifying this setting is shared with 
another user working on a different system, the 
configuration uses that system’s ColorSync RGB 
space as the working space.

Specifying CMYK working spaces

For the CMYK color model, the following 
standard working space options are available. 

Euroscale (Coated) Uses specifications designed to 
produce quality separations using Euroscale inks 
under the following printing conditions: 350% 
total area of ink coverage, positive plate, bright 
white coated stock.

Euroscale (Uncoated) Uses specifications designed 
to produce quality separations using Euroscale 
inks under the following printing conditions: 
260% total area of ink coverage, positive plate, 
uncoated white offset stock.

Japan Standard Uses specifications designed to 
produce quality separations using Japan Standard 
inks under the following printing conditions: 
300% total area of ink coverage, positive plate, 
coated publication-grade stock.

U.S. Sheetfed Coated Uses specifications designed 
to produce quality separations using U.S. inks 
under the following printing conditions: 350% 
total area of ink coverage, negative plate, bright 
white coated stock.



71ADOBE PHOTOSHOP 6.0
User Guide

U.S. Sheetfed Uncoated Uses specifications 
designed to produce quality separations using U.S. 
inks under the following printing conditions: 
260% total area of ink coverage, negative plate, 
uncoated white offset stock.

U.S. Web Coated (SWOP) Uses specifications 
designed to produce quality separations using U.S. 
inks under the following printing conditions: 
300% total area of ink coverage, negative plate, 
coated publication-grade stock. This profile was 
created using the TR001 characterization data.

U.S. Web Uncoated Uses specifications designed to 
produce quality separations using U.S. inks under 
the following printing conditions: 260% total area 
of ink coverage, negative plate, uncoated white 
offset stock.

ColorSync CMYK (Mac OS only) Matches the CMYK 
space specified in the control panel for Apple 
ColorSync 3.0 or later. If a color management 
configuration specifying this setting is shared with 
another user working on a different system, the 
configuration uses that system’s ColorSync CMYK 
space as the working space.

Specifying grayscale working spaces

The standard grayscale working spaces are based 
on the grayscale characteristics of preset dot gain 
percentages or monitor gamma settings. With 
Advanced Mode selected, you also have the option 
of creating a grayscale working space based on a 
custom dot gain or gamma. 

Dot gain or loss occurs when a printer’s halftone 
dots change as the ink spreads and is absorbed by 
paper. Photoshop calculates dot gain as the 
amount by which the expected dot increases or 
decreases. For example, a 50% halftone screen may 
produce an actual density of 60% on the printed 
page, exhibiting a dot gain of 10%. The Dot Gain 
10% option represents the color space that reflects 
the grayscale characteristics of this particular dot 
gain.

Proof (no dot gain), and printed image (with dot gain)

A monitor’s gamma setting determines the 
brightness of midtones displayed by the monitor. 
The Gray Gamma 1.8 option matches the default 
grayscale display of Mac OS computers and is also 
the default grayscale space for Photoshop 4.0 and 
earlier. The Gray Gamma 2.2 option matches the 
default grayscale display of Windows computers.

Specifying spot-color working spaces

The standard Spot working spaces are based on the 
spot-color characteristics of preset dot gain 
percentages. For an explanation of dot gain, 
see “Specifying grayscale working spaces” on 
page 71. With Advanced Mode selected, you also 
have the option of creating a spot-color working 
space based on a custom dot gain percentage.
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Specifying color management 
policies
Each predefined color management configuration 
sets up a color management policy for the RGB, 
CMYK, and grayscale color models and displays 
warning messages to let you override the default 
policy behavior on a case-by-case basis. If desired, 
you can change the default policy behavior to 
reflect a color management workflow that you use 
more often. For more information on policies, 
see “Using color management policies” on 
page 67. 

To customize color management policies:

1 In the Color Settings dialog box, under Policies, 
choose one of the following to set the default color 
management policy for each color model:

• Off if you do not want to color-manage 
imported or opened color data.

• Preserve Embedded Profiles if you anticipate 
working with a mix of color-managed and non-
color-managed documents, or with documents 
that use different profiles within the same 
color model.

• Convert to Working Space if you want to 
color-manage all documents using the current 
working spaces.

For detailed descriptions of the default behaviors 
associated with each policy option, see the table 
following this procedure.

2 For Profile Mismatches, select either, both, or 
neither of the following:

• Ask When Opening to display a message 
whenever the embedded color profile in a newly 
opened document does not match the current 
working space. You will be given the option to 
override the policy’s default behavior.

• Ask When Pasting to display a message whenever 
color profile mismatches occur as colors are 
imported into a document (via pasting, drag-and-
drop, placing, and so on). You will be given the 
option to override the policy’s default behavior.

3 For Missing Profiles, select Ask When Opening 
to display a message whenever a newly opened 
document does not have a color profile. You will be 
given the option to override the policy’s default 
behavior.

It is strongly recommended that you keep the Ask 
When Opening and Ask When Pasting options 
selected. Deselecting the options causes 
Photoshop to implement default policy behavior 
without notification.

Policy option Default color management behavior

Off • No profiles are saved with new 
documents.

• If opened document’s profile does not 
match current working space, profile is 
discarded and not saved with document.

• If opened document’s profile matches 
current working space, profile is preserved 
and saved with document.

• For color data imported into same color 
model, numeric values of colors are 
preserved.

• For color data imported into different 
color model, colors are converted to desti-
nation document’s color space.
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Customizing advanced color 
management settings
When you select Advanced Mode at the top of 
the Color Settings dialog box, you have the option 
of further customizing settings used for color 
management.

Specifying a color management engine

The color management engine specifies the system 
and color-matching method used to convert colors 
between color spaces. For more information, 
see “About color management” on page 63.

The following standard engine options are 
available. If you have installed additional color 
management engines, they may also appear
as options.

Adobe (ACE) Uses the Adobe color management 
system and color engine. This is the default setting 
for most preset color configurations.

Apple ColorSync Uses the color management 
system provided by Apple Computer, Inc. for Mac 
OS computers.

Microsoft ICM Uses the color management system 
provided by Microsoft Corporation for Windows 
98 and Windows 2000 computers.

Preserve Embed-
ded Profiles

• Working space profile is saved with new 
documents.

• If opened document’s profile does not 
match current working space, profile is 
preserved and saved with document. 

• If opened document does not contain a 
profile, working space is used for editing 
but not saved with document. 

• For color data imported within same 
color model between either a non-color-
managed source or destination, or from a 
CMYK document into a CMYK document, 
numeric color values are preserved.

• For all other import cases, colors are con-
verted to destination document’s color 
space.

Convert to 
Working Space

• Working space profile is saved with new 
documents.

• If opened document’s profile does not 
match current working space, document is 
converted to working space; working 
space is saved with document.

• If opened document does not contain a 
profile, working space is used for editing 
but not saved with document.

• For color data imported within same 
color model between either a non-color-
managed source or destination, numeric 
color values are preserved.

• For all other import cases, colors are con-
verted to destination document’s color 
space.

Policy option Default color management behavior
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Specifying a rendering intent

Translating colors to a different color space usually 
involves an adjustment of the colors to accom-
modate the gamut of the destination color space. 
Different translation methods use different rules 
to determine how the source colors are adjusted; 
for example, colors that fall inside the destination 
gamut may remain unchanged, or they may be 
adjusted to preserve the original range of visual 
relationships as translated to a smaller destination 
gamut. These translation methods are known 
as rendering intents because each technique is 
optimized for a different intended use of 
color graphics.

Note: The result of choosing a rendering intent 
depends on the graphical content of documents and 
on the profiles used to specify color spaces. Some 
profiles produce identical results for different 
rendering intents. Differences between rendering 
intents are apparent only when you print a 
document or convert it to a different working space.

The following rendering intent options are 
available:

Perceptual This intent aims to preserve the visual 
relationship between colors in a way that is 
perceived as natural to the human eye, although 
the color values themselves may change.

Saturation Appropriate for office and presentation 
graphics, this intent aims to create vivid color at 
the expense of accurate color. It scales the source 
gamut to the destination gamut but preserves 
relative saturation instead of hue, so when scaling 
to a smaller gamut, hues may shift. This rendering 
intent is suitable for business graphics, where the 
exact relationship between colors is not as 
important as having bright saturated colors.

Absolute Colorimetric Leaves colors that fall inside 
the destination gamut unchanged. This intent 
aims to maintain color accuracy at the expense of 
preserving relationships between colors. When 
translating to a smaller gamut, two colors that are 
distinct in the source space may be mapped to the 
same color in the destination space. 

Relative Colorimetric This intent is identical to 
absolute colorimetric except for the following 
difference: relative colorimetric compares the 
white point (extreme highlight) of the source color 
space to that of the destination color space and 
shifts all colors accordingly. Relative colorimetric 
can be more accurate if the image’s profile contains 
correct white point information. This is the 
default rendering intent used by all predefined 
color management configurations.



75ADOBE PHOTOSHOP 6.0
User Guide

Using black-point compensation

The Use Black Point Compensation option 
controls whether to adjust for differences in black 
points when converting colors between color 
spaces. When this option is selected, the full 
dynamic range of the source space is mapped into 
the full dynamic range of the destination space. 
When deselected, the dynamic range of the source 
space is simulated in the destination space; 
although this mode can result in blocked or gray 
shadows, it can be useful when the black point of 
the source space is lower than that of the desti-
nation space.

The Use Black Point Compensation option is 
selected for all predefined color management 
configurations. It is highly recommended that you 
keep this option selected. 

Using dither

The Use Dither (8-bit/channel images) option 
controls whether to dither colors when converting 
8-bit-per-channel images between color spaces. 
When this option is selected, Photoshop mixes 
colors in the destination color space to simulate a 
missing color that existed in the source space. 
Although dithering helps to reduce the blocky or 
banded appearance of an image, it may also 
increase the file size.

Desaturating monitor colors

The Desaturate Monitor Colors By option controls 
whether to desaturate colors by the specified 
amount when displayed on the monitor. When 
selected, this option can aid in visualizing the full 
range of color spaces with gamuts larger than that 
of the monitor. However, this causes a mismatch 
between the monitor display and the printed 
output. 

Blending RGB colors

The Blend RGB Colors Using Gamma option 
controls the blending behavior of RGB colors. 
When the option is selected, RGB colors are 
blended using the specified gamma. A gamma of 
1.00 is considered “colorimetrically correct” and 
should result in the fewest edge artifacts. When the 
option is deselected, RGB colors are blended 
directly in the document’s color space, matching 
the behavior of most applications other than 
Photoshop. 

Saving and loading custom color 
management settings
When you create a custom color management 
configuration, you should name and save the 
configuration to ensure that it can be shared with 
other users and applications that use the Color 
Settings dialog box, such as Adobe Illustrator. You 
can also load previously saved color management 
configurations into the Color Settings dialog box.

To save a custom color management configuration:

1 In the Color Settings dialog box, click Save.
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2 Name your color settings file, and click Save. 

To ensure that the saved configuration appears in 
the Settings menu of the Color Settings dialog box, 
save the file in the Program Files/Common 
Files/Adobe/Color/Settings folder (Windows) or 
the System Folder/Application 
Support/Adobe/Color/Settings (Mac OS) folder.

3 Enter any comments that you want to associate 
with the configuration, and click OK.

The comments that you enter will appear in the 
Description area of the Color Settings dialog box 
when the configuration is chosen.

To load a color management configuration:

1 In the Color Settings dialog box, click Load.

2 Locate and select the desired color settings file, 
and click Load.

When you load a custom color settings file, it 
appears as the active choice in the Settings menu of 
the Color Settings dialog box. If you choose a 
different option from the Settings menu, you must 
reload the custom settings file in order to access
it again.

Synchronizing color 
management between 
applications
The Color Settings dialog box represents the 
common color management controls shared by 
several Adobe applications. If you make adjust-
ments to the Color Settings dialog box in any other 
Adobe application, you will be prompted to 
synchronize the common color settings upon 
starting Photoshop or upon reopening the Color 
Settings dialog box in Photoshop. Synchronizing 
the color settings helps to ensure that color is 
reproduced consistently between all Adobe appli-
cations that use the Color Settings dialog box.

Soft-proofing colors
In a traditional publishing workflow, you print a 
hard proof of your document to preview how the 
document’s colors will look when reproduced on a 
specific output device. In a color-managed 
workflow, you can use the precision of color 
profiles to soft-proof your document directly on 
the monitor. You can display an onscreen preview 
of how your document’s colors will look when 
reproduced on a particular output device.

Keep in mind that the reliability of the soft proof is 
highly dependent upon the quality of your 
monitor, your monitor profile, and the ambient 
lighting conditions of your work station. For 
information on creating a monitor profile, 
see “Creating an ICC monitor profile” on page 81.
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To display a soft proof:

1 Choose View > Proof Setup, and choose the 
output display that you want to simulate:

• Choose Custom to soft-proof colors as displayed 
on a specific output device. Then follow the 
instructions outlined in the next procedure to set 
up the custom proof.

• Choose Working CMYK to soft-proof colors 
using the current CMYK working space.

• Choose Working Cyan Plate, Working Magenta 
Plate, Working Yellow Plate, Working Black Plate, 
or Working CMY Plates to soft-proof specific 
CMYK ink colors using the current CMYK 
working space.

• Choose Macintosh RGB or Windows RGB to 
soft-proof colors using either a standard Mac OS 
or Windows monitor as the proof profile space 
that you want to simulate.

• Choose Monitor RGB to soft-proof colors using 
your current monitor color space as the proof 
profile space.

• Choose Simulate Paper White to preview the 
specific shade of white exhibited by the print 
medium. <<Reviewers: Which color profile is this 
preview based on, Working CMYK?>>

• Choose Simulate Ink Black to preview the 
amount of black pigment absorbed by the print 
medium. <<Reviewers: Which color profile is this 
preview based on, Working CMYK?>>

2 Choose View > Proof Colors to toggle the soft-
proof display on and off. When soft proofing is
on, a checkmark appears next to the Proof 
Colors command.

To create a custom proof:

1 Choose View > Proof Setup > Custom.

2 Select Preview to display a live preview of the 
proof settings in the document while the Proof 
Setup dialog box is open.

3 If you want to use a preset proof configuration 
as a starting point for your custom proof, choose 
an option from the Setup menu. If the desired 
proof preset does not appear in the menu, click 
Load to locate and load the desired preset.

4 For Profile, choose the color profile for the 
device for which you want to create the proof.

5 If you chose a proof profile using the 
document’s current color model, do one of
the following:

• Select Preserve Color Numbers to simulate how 
the document will appear without converting 
colors to the proof profile space.

• Deselect Preserve Color Numbers to simulate 
how the document will appear if colors are 
converted to the proof profile space in an effort to 
preserve the colors’ visual appearances. Then 
specify a rendering intent for the conversion; for 
more information, see “Specifying a rendering 
intent” on page 74.

6 Select one, both, or none of the following:

• Simulate Paper White to preview the specific 
shade of white exhibited by the print medium. 
Selecting this option automatically selects the 
Simulate Ink Black option. <<Reviewers: Which 
color profile is this preview based on, Working 
CMYK?>>
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• Simulate Ink Black to preview the amount of 
black pigment absorbed by the print medium. 
<<Reviewers: Which color profile is this preview 
based on, Working CMYK?>>

The availability of either option depends on the 
proof profile chosen. Not all profiles support both 
options.

7 To save your custom proof as a preset proof 
configuration, click Save. To ensure that the new 
preset appears in the View > Proof Setup menu, 
save the preset in the Program Files/Common 
Files/Adobe/Color/Proofing folder (Windows) or 
the System Folder/Application 
Support/Adobe/Color/Proofing (Mac OS) folder.

8 Click OK to close the Proof Setup dialog box.

Changing the color profile of a 
document
In some cases you may want to convert a 
document’s colors to a different color profile, 
assign a different color profile to a document 
without making color conversions, or remove the 
profile from a document altogether. For example, 
you may want to prepare the document for a 
different output destination, or you may want to 
correct a policy behavior that you no longer want 
implemented on the document. The Assign Profile 
and Convert to Profile commands are recom-
mended only for advanced users.

To reassign or discard the profile of a document:

1 Choose Image > Mode > Assign Profile.

2 Select one of the following:

• Don’t Color Manage This Document to remove 
the existing profile from the document. Select this 
option only if you are sure that you do not want to 
color-manage the document.

• Working <color model: working space> to assign 
the working space profile to a document that 
either uses no profile or a profile different from the 
working space. 

• Profile to reassign a different profile to a color-
managed document. Choose the desired profile 
from the menu. Photoshop assigns the new profile 
to the document without converting colors to the 
profile space.

3 To preview the effects of the new profile 
assignment in the document, select Preview.

4 Click OK.

To convert colors in a document to another profile:

1 Choose Image > Mode > Convert to Profile.

2 Under Destination Space, choose the color 
profile to which you want to convert the 
document’s colors. The document will be 
converted to and reassigned with this new profile.

3 Under Conversion Options, specify a color 
management engine, a rendering intent, and black 
point and dither options. (See “Customizing 
advanced color management settings” on 
page 73.)

4 To flatten all layers of the document onto a 
single layer upon conversion, select Flatten Image. 

5 To preview the effects of the conversion in the 
document, select Preview. This preview becomes 
more accurate if you select Flatten Image.
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6 Click OK.

Embedding profiles in saved 
documents
By default, a document for which you have 
specified color management will have its profile 
embedded upon saving in a file format that 
supports embedded ICC profiles. These formats 
include the native Photoshop format (.ai), PDF, 
JPEG, TIFF, and the native Photoshop format 
(.psd). Profiles are not saved by default with non-
color-managed documents. 

You can change the default behavior to embed or 
not to embed profiles as you save a document. 
Changing the default behavior, however, is recom-
mended only for advanced users who are very 
familiar with color management.

To change the embedding behavior of a profile in
a document:

1 Choose File > Save. Name the document, 
specify a file format, and click Save.

2 In the file format options dialog box that 
appears, select or deselect Embed Color Profile.

3 Click OK to save the document.

Obtaining, installing, and 
updating color profiles
Precise, consistent color management requires 
accurate ICC-compliant profiles of all of your 
color devices. For example, without an accurate 
scanner profile, a perfectly scanned image may 
appear incorrect in another program, simply due 
to any difference in gamuts between the scanner 
and the program displaying the image. This 
misleading representation may cause you to make 
unnecessary, time-wasting, and potentially 
damaging “corrections” to an already satisfactory 
image. With an accurate profile, a program 
importing the image can correct for any gamut 
differences and display a scan’s actual colors.

Once you obtain accurate profiles, they will work 
with all applications that are compatible with your 
color-management system. You can obtain profiles 
in the following ways, with the most precise 
methods listed first:

• Generate profiles customized for your specific 
devices using professional profiling equipment.

• Obtain a profile created by the manufacturer. 
Unfortunately, such profiles do not account for 
individual variations that naturally occur among 
machines (even identical models from the same 
manufacturer) or from age.
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• Substitute an available profile that may be 
appropriate given information you have about the 
device’s gamut. For example, many Mac OS 
scanners have been optimized for an Apple RGB 
monitor gamut, so you might try using an Apple 
monitor profile for these devices. Be sure to proof 
images created with the profile before using the 
profile in production. This workaround is unlikely 
to produce results suitable for professionally color-
managed work.

Adding device profiles to the color 
management system

The Photoshop installer lets you choose from 
manufacturer-supplied device profiles for some 
commonly used equipment. This is useful if you 
don’t have access to hardware-based calibration 
tools. It is not possible for the installer to supply 
profiles for all devices. If the installer did not 
install a profile for your device, create one or 
contact the device manufacturer to obtain one.

To minimize confusion when working with 
profiles, delete any profiles for devices not used by 
you or your workgroup.

In Mac OS, you can organize the ColorSync 
Profiles folder by creating additional folders 

within it, or adding aliases to other folders.

To add profiles to your system:

Do one of the following:

• In Windows NT or 2000, copy profiles into the 
WinNT\System32\Color folder.

• In Windows 98, copy profiles into the 
Windows\System\Color folder.

• In Mac OS, copy profiles into the ColorSync 
Profiles folder in the System Folder (ColorSync 2.5 
or later), or System Folder/Preferences/ 
ColorSync™ Profiles (ColorSync versions earlier 
than 2.5).

Note: If you use ColorSync 2.5 but have used earlier 
versions, some profiles may still be stored in System 
Folder/Preferences/ColorSync™ Profiles on your hard 
disk. For compatibility with ColorSync 2.5 or later, 
store profiles in the ColorSync Profiles folder in the 
System Folder.

Updating profiles

The color reproduction characteristics of a color 
device change as it ages, so recalibrate devices 
periodically and generate updated profiles. 
Profiles should be good for approximately a 
month depending on the device. Some monitors 
automatically compensate for phosphor aging.

Also, recalibrate a device when you change any of 
the factors that affect calibration. For example, 
recalibrate your monitor when you change the 
room lighting or the monitor brightness setting.
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Creating an ICC monitor profile
Your monitor will display color more reliably if 
you use color management and accurate ICC 
profiles. The Adobe Gamma utility, which is 
automatically installed into your Control Panels 
folder, lets you calibrate and characterize your 
monitor to a standard and then save the settings as 
an ICC-compliant profile available to any program 
that uses your color management system. This 
calibration helps you eliminate any color cast in 
your monitor, make your monitor grays as neutral 
as possible, and standardize image display across 
different monitors.

Although Adobe Gamma is an effective calibration 
and profiling utility, hardware-based utilities are 
more precise. If you have a hardware-based utility 
that can generate an ICC-compliant profile, you 
should use that instead of Adobe Gamma. 

Depending on your workflow scenario, an ICC 
monitor profile can be either a source profile, a 
destination profile, or both. 

Note: Adobe Gamma can characterize, but not 
calibrate, monitors used with Windows NT. In 
addition, the ICC profile you create with Adobe 
Gamma can be used as the system-level profile in 
Windows NT. Its ability to calibrate settings in 
Windows 98 depends on the video card and video 
driver software. In such cases, some calibration 
options documented here may not be available.

Calibrating versus characterizing a 
monitor

Profiling software such as Adobe Gamma can both 
characterize and calibrate your monitor. When 
you characterize your monitor, you create a profile 
that describes how the monitor is currently repro-
ducing color. When you calibrate your monitor, 
you bring it into compliance with a predefined 
standard; adjusting your monitor so that it 
displays color using the graphics arts standard 
white point color temperature of 5000 kelvin is an 
example of calibration.

Determine in advance the standard to which you 
are calibrating so that you can enter the set of 
values for that standard. Coordinate calibration 
with your workgroup and prepress service 
provider to make sure you’re all calibrating to the 
same standard.

About monitor calibration settings

Monitor calibration involves adjusting video 
settings, which may be unfamiliar to you. A 
monitor profile uses these settings to precisely 
describe how your monitor reproduces color.

Brightness and contrast The overall level and 
range, respectively, of display intensity. These 
parameters work just as they do on a television. 
Adobe Gamma helps you set an optimum 
brightness and contrast range for calibration.
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Gamma The brightness of the midtone values. The 
values produced by a monitor from black to white 
are nonlinear—if you graph the values, they form 
a curve, not a straight line. Gamma defines the 
value of that curve at halfway between black and 
white. Gamma adjustment compensates for the 
nonlinear tonal reproduction of output devices 
such as monitor tubes.

Phosphors The substance that monitors use to 
emit light. Different phosphors have different 
color characteristics.

White point The RGB coordinates at which red, 
green, and blue phosphors at full intensity 
create white.

Guidelines for creating an ICC monitor 
profile

The following guidelines can help you create an 
accurate monitor profile.

 You may find it helpful to have your monitor’s 
user guide handy while using Adobe Gamma.

• You don’t need to calibrate your monitor if 
you’ve already done so using an ICC-compliant 
calibration tool such as Adobe Gamma and haven’t 
changed your video card or monitor settings.

• If you have the Mac OS Gamma control panel 
(included with Adobe Photoshop 4.0 and earlier) 
or the Monitor Setup utility (included with 
PageMaker® 6.0) for Windows, remove it; it is 
obsolete. Use the latest Adobe Gamma utility 
instead.

• Make sure your monitor has been turned on for 
at least a half hour. This gives it sufficient time to 
warm up for a more accurate color reading.

• Make sure your monitor is displaying thousands 
of colors or more.

• Remove colorful background patterns on your 
monitor desktop. Busy or bright patterns 
surrounding a document interfere with accurate 
color perception. Set your desktop to display 
neutral grays only, using RGB values of 128. For 
more information, see the manual for your 
operating system.

• If your monitor has digital controls for choosing 
the white point of your monitor from a range of 
preset values, set those controls before starting 
Adobe Gamma. Later, in Adobe Gamma, you’ll set 
the white point to match your monitor’s current 
setting. Be sure to set the digital controls before 
you start Adobe Gamma. If you set them after you 
begin the calibration process in Adobe Gamma, 
you’ll need to begin the process again.

• Monitor performance changes and declines over 
time; recharacterize your monitor every month or 
so. If you find it difficult or impossible to calibrate 
your monitor to a standard, it may be too old 
and faded.

Calibrating with Adobe Gamma

The ICC profile you get using Adobe Gamma uses 
the calibration settings to describe how your 
monitor reproduces color. 

To use Adobe Gamma: 1 Do one of the following 
to start the Adobe Gamma utility:

• In Windows, double-click Adobe Gamma, 
located in the Program Files\Common Files 
\Adobe\Calibration folder on your hard drive.
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• In Mac OS, from the Apple menu, choose 
Control Panels > Adobe Gamma.

2 Do one of the following:

• To use a version of the utility that will guide you 
through each step, select Step by Step, and click 
OK. This version is recommended if you’re 
inexperienced. If you choose this option, follow 
the instructions described in the utility. Start from 
the default profile for your monitor if available.

• To use a compact version of the utility with all 
the controls in one place, select Control Panel, and 
click OK. This version is recommended if you have 
experience creating color profiles.

Any time while working in the Adobe Gamma 
control panel, you can click the Wizard 

(Windows) or Assistant (Mac OS) button to switch 
to the wizard for instructions that guide you through 
the same settings as in the control panel, one option 
at a time.
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Chapter 5: Making Color and Tonal 
Adjustments

hen you photograph, scan, or resample 
images, you can often introduce 
problems involving color quality and 

tonal range. Photoshop provides a comprehensive 
set of tools for making color and tonal corrections 
and sharpening the overall focus of an image. 
ImageReady provides many of the basic correction 
tools, including Levels, Brightness/Contrast, 
Hue/Saturation, Variations, and Unsharp Mask.

Basic steps for correcting images
Photoshop gives you a range of commands and 
features for adjusting the tonal quality and color 
balance of images. For quick and simple image 
correction, use one of the semi-automatic 
adjustment commands. (See “Making quick 
overall adjustments to an image” on page 108.) 
For more precise and flexible adjustments, use the 
color-correction workflow outlined in the 
following sections.

1. Calibrate your monitor.

In preparation for adjusting images, use the Adobe 
Gamma utility to calibrate your monitor to a 
color-display standard suited to your working 
needs. Otherwise, the image on your monitor may 
look very different from the same image when 
printed or when viewed on another monitor. 
See <<xref to section in new color chapter>>.

2. Check the scan quality and tonal range.

Before making adjustments, look at the image’s 
histogram to evaluate whether the image has suffi-
cient detail to produce high-quality output. The 
higher the number of pixels in an area, the greater 
the detail. Poor scans and photographs without 
much detail can be difficult if not impossible to 
correct. Too many color corrections can also result 
in a loss of pixel values and too little detail. 

The histogram also displays the overall distri-
bution of shadows, midtones, and highlights to 
help you determine which tonal corrections are 
needed. See “Checking scan quality and tonal 
range (Photoshop)” on page 87.

3. Adjust the tonal range.

Begin tonal corrections by adjusting the values of 
the extreme highlight and shadow pixels in the 
image, setting an overall tonal range that allows for 
the sharpest detail possible throughout the image. 
This process is known as setting the highlights and 
shadows or setting the white and black points.

Setting the highlights and shadows typically redis-
tributes the midtone pixels appropriately. When 
pixel values are concentrated at either end of the 
tonal range, however, you may need to adjust your 
midtones manually. It is not usually necessary to 
adjust midtones in images that already have a 
concentrated amount of midtone detail.

W
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There are several different ways to set an image’s 
tonal range:

• You can drag sliders along the histogram in the 
Levels dialog box. See “Using Levels to set 
highlights, shadows, and midtones” on page 95.

• You can adjust the shape of the graph in the 
Curves dialog box. This method lets you adjust any 
point along a 0-255 tonal scale and provides the 
greatest control over an image’s tonal quality. 
See “Using Curves to adjust tonal range 
(Photoshop)” on page 95. <<xref destination?>>

• You can assign target values to the highlight and 
shadow pixels using either the Levels or Curves 
dialog box. This can be a useful method for images 
intended for printing on a press. See “Using target 
values to set highlights and shadows (Photoshop)” 
on page 99.

• You can use the Gamma command to adjust the 
overall brightness of the image as displayed on a 
standard Windows or Mac OS monitor. 
See “Adjusting the gamma value of an image 
(ImageReady)” on page 102.

<<It’s possible to set midtones using target values 
as mentioned in the preceding para, but I don’t 
know if you’d want to set midtones that way. How 
would you reasonably choose a representative 
midtone in an image? We don’t describe how to do 
it in the subsection on target values, so we need to 
pin this down one way or the other.>>

4. Adjust the color balance.

After correcting the tonal range, you can adjust the 
image’s color balance to remove unwanted color 
casts or to correct oversaturated or undersaturated 
colors. Examine your image with reference to the 
color wheel to determine which color adjustments 
you need to make. (See “About the color wheel” on 
page 103.) You can choose from the following 
color adjustment methods:

• The Color Balance command changes the 
overall mixture of colors in an image. See “Using 
the Color Balance command (Photoshop)” on 
page 103.

• The Hue/Saturation command adjusts the hue, 
saturation, and lightness values of individual color 
components. See “Using the Hue/Saturation 
command” on page 104.

• The Replace Color command replaces specified 
colors in an image with new color values. 
See “Using the Replace Color command 
(Photoshop)” on page 106.

• The Selective Color command is a high-end 
color-correction method that adjusts the amount 
of process colors in individual color components. 
See “Using the Selective Color command 
(Photoshop)” on page 107.

• The Levels and Curves dialog boxes let you 
adjust color balance by setting the pixel distri-
bution for individual color channels. See “Using 
Levels to adjust color” on page 97 and “Using the 
Curves command to adjust color (Photoshop)” on 
page 98. <<xref destination?>>
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• The method of blending colors from different 
channels can also produce color adjustments. 
See “Mixing color channels” on page 210.

For finer control over color, convert your 
artwork to a 16-bit image. (See “Converting 

between bit depths (Photoshop)” on page 52.) When 
you finish making color adjustments, convert it back 
to an 8-bit image.

5. Make other special color adjustments.

Once you have corrected the overall color balance 
of your image, you can make optional adjustments 
to enhance colors or produce special effects. 
See “Applying special color effects to images” on 
page 110.

6. Sharpen the edges of the image.

As a final step, use the Unsharp Mask filter to 
sharpen the clarity of edges in the image. This step 
helps restore focus to images that have undergone 
resampling as a result of color adjustments. 
See “Sharpening an image” on page 112.

Checking scan quality and tonal 
range (Photoshop)
A histogram illustrates how pixels in an image are 
distributed by graphing the number of pixels at 
each color intensity level. This can show you 
whether the image contains enough detail in the 
shadows (shown in the left part of the histogram), 
midtones (shown in the middle), and highlights 
(shown in the right part) to make a good 
correction.
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The histogram also gives a quick picture of the 
tonal range of the image, or the image key type. A 
low-key image has detail concentrated in the 
shadows; a high-key image has detail concentrated 
in the highlights; and an average-key image has 
detail concentrated in the midtones. An image 
with full tonal range has a high number of pixels in 
all areas. Identifying the tonal range helps 
determine appropriate tonal corrections. <<Is this 
the correct definition of an average-key image?>>

Original with insufficient detail, and sufficient detail

Original, and corrected average-key image

Original, and corrected high-key image

Original, and corrected low-key image

To determine whether a scan has captured 
enough detail for high-quality output, also 

check the RGB values of your highlight and shadow 
areas in the Info palette—generally, 240 and 10, 
respectively. The scan must be free of large gaps 
within these ranges.

To display the histogram for an image: 

1 To display histogram data for a portion of the 
image, first select that portion. By default, the 
histogram displays the tonal range of the entire 
image.

2 Choose Image > Histogram. 

To include data from spot channels and alpha 
channels, hold down Alt (Windows) or Option 
(Mac OS) when you choose Image > Histogram. 

The horizontal axis of the histogram represents the 
intensity values, or levels, from darkest (0) at the 
far left to brightest (255) at the far right; the 
vertical axis represents the total number of pixels 
with a given value. 

Note: The histogram for an adjustment layer 
depends on the visibility of the layers beneath it.
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3 For RGB, CMYK, and indexed-color images, 
choose an option from the Channel menu. You can 
plot either the luminance of the composite 
channel (Luminosity) or the intensity values of an 
individual channel.

4 To view information about a specific point on 
the histogram, place the pointer there. To view 
information about a range of values, drag in the 
histogram to highlight the range.

The numerical values below the histogram display 
statistical information about the intensity values 
of the pixels:

Mean Represents the average intensity value. 

Standard deviation (Std Dev) Represents how 
widely intensity values vary. 

Median Shows the middle value in the range of 
intensity values. 

Pixels Represents the total number of pixels used 
to calculate the histogram.

Level Displays the intensity level of the area 
underneath the pointer. 

Count Shows the total number of pixels corre-
sponding to the intensity level underneath the 
pointer.

Percentile Displays the cumulative number of 
pixels at or below the level underneath the pointer. 
This value is expressed as a percentage of all the 
pixels in the image, from 0% at the far left to 100% 
at the far right.

Cache Level Shows the setting for the image cache. 
If the Use Cache for Histograms option is selected 
in the Memory & Image Cache Preferences dialog 
box, the histogram is based on a representative 
sampling of pixels in the image (based on the 
magnification), rather than on all of the pixels.

5 Click OK to close the histogram.

Using the color adjustment tools
All Adobe Photoshop and ImageReady color 
adjustment tools work essentially the same way: by 
mapping an existing range of pixel values to a new 
range of values. The difference between the tools is 
the amount of control you have. For an overview 
summary of the color adjustment tools, see “Basic 
steps for correcting images” on page 85.

Making color adjustments

When you open a color adjustment dialog box, 
you determine whether your corrections will be 
applied to a regular layer or (Photoshop) to an 
adjustment layer.

<<Are we still calling them “adjustment 
layers”?>>

If you make corrections to a regular layer, you 
permanently alter the pixels on that layer. 
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If you make corrections to an adjustment layer in 
Photoshop, your changes reside only in the 
adjustment layer and do not alter any pixels. The 
effect is as if you are viewing the visible layers 
through the adjustment layer above them. This lets 
you experiment with color and tonal adjustments 
without permanently altering pixels in the image. 
Adjustment layers are also the only way to affect 
multiple layers at once. (See “Using content layers 
(Photoshop)” on page 244 for more information.)

You can apply and edit adjustment layers only in 
Photoshop. When you transfer an image with 
adjustment layers to ImageReady, you can view the 
layers but not edit them.

To open a color adjustment dialog box:

1 If you want to make adjustments to just a 
portion of your image, select that part of the 
image. If you make no selection, the adjustment 
will be applied to the entire image.

2 Do one of the following:

• Choose Image > Adjust, and choose the 
command you want from the submenu. 

• Choose Layer > New Content Layer, and choose 
the desired type of adjustment layer from the 
submenu (Photoshop). For example, choose 
Levels Layer for a new adjustment layer with Levels 
corrections. Type a name for the layer, and click 
OK. The changes will be applied to the new 
adjustment layer.

• Double-click an existing adjustment layer in the 
Layers palette (Photoshop). The changes will be 
applied to that adjustment layer.

To cancel changes without closing a color 
adjustment dialog box, hold down Alt 

(Windows) or Option (Mac OS) to change the 
Cancel button to Reset; then click Reset. This resets 
the image to the default settings. 

Previewing color adjustments

If the Preview option is selected in a color 
adjustment dialog box, you can see your changes 
in the image before accepting them. Known as 
video table lookup, or color table animation, this 
process displays an immediate, but not always 
accurate, preview of changes. You can turn off 
color table animation to display an accurate 
preview of adjustments to the selected area only.

<<In 5.5 we had a Video LUT option in the 
display prefs; it’s no longer there, and I haven’t 
heard back from engineering on this. We’ll prob-
ably need to revise the following few paras and 
the second and third procedures.>>

The following guidelines apply when using color 
table animation:

• The Video LUT Animation option is off by 
default on Windows and is not available for most 
operations on Windows and Mac OS unless the 
monitor is set to 256 colors.

• For color table animation to work in 24-bit 
mode with Windows, you must install a color table 
animation extension, supplied by your video card 
manufacturer, in the Plug-Ins directory. 
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• The color table animation feature can cause 
problems in Mac OS if you are using a 24-bit 
or 32-bit video card for which certain color 
QuickDraw commands have not been properly 
implemented. If you have a problem, contact your 
video card manufacturer for ROM updates. You 
should also reset the video mode and turn off the 
Video LUT Animation option in the Display 
Preferences dialog box. 

To turn on previewing and deactivate color table 
animation:

Select Preview in any color adjustment dialog box. 

<<Huh? The old section intro (of which the new 
intro is a part) seems to imply that preview uses 
color table animation.>>

To turn off color table animation:

1 Choose Edit > Preferences > Display & Cursors.

2 Deselect Video LUT Animation, and click OK.

To reset the video mode in a Mac OS machine with a 
24-bit or 32-bit video card:

1 Choose Control Panel from the Apple menu, 
and double-click Monitors.

2 Click one of the other color display options 
(such as 256 Colors), and perform a preview to see 
the results.

3 Click your original color display option.

4 Close the Control Panel.

5 In Photoshop, choose Edit > Preferences > 
Display & Cursors, deselect Video LUT 
Animation, and click OK.

You can still preview changes by clicking the 
Preview option, but clicking Preview will not turn 
the color table animation off and on.

Seeing the color values of pixels

You can use the Info palette and the Color palette 
to see the color value of pixels as you make color 
corrections. 

When you work with a color adjustment dialog 
box, the Info palette displays two sets of color 
values for the pixels under the pointer. The value 
in the left column is the original color value. The 
value in the right column is the color value after 
the adjustment is made. <<Please confirm that 
this is Photoshop only.>>

You can view the color of a single area using the 
eyedropper tool, or you can use up to four color 
samplers to display color information for one or 
more locations in the image. These samplers are 
saved in the image, so you can refer to them 
repeatedly as you work, even if you close and 
reopen the image.

<<B. Smyth says we’re adding the color sampler 
to IR. It’s not there yet. Double-check this.>>
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<<ART: Circle the 2 sets of sampler values in the 
Info palette below.>>

Color samplers and Info palette

To use the Info palette and the eyedropper or color 
sampler tool to see color values:

<<Photoshop only?>>

1 Choose Window > Show Info to open the Info 
palette.

2 Select the eyedropper tool or color sampler tool, 
and choose what to sample from the pop-up menu 
in the eyedropper or color sampler tool options:

• Point Sample to read the value of a single pixel.

• 3 by 3 Average to read the average value of a 
3-by-3 pixel area.

• 5 by 5 Average to read the average value of a 
5-by-5 pixel area.

3 If you selected the color sampler tool, place up 
to four color samplers on the image. Click where 
you want to place a sampler.

4 Open a color adjustment dialog box. 
(See “Making color adjustments” on page 89.)

5 Make your adjustments in the dialog box, and 
before applying them, view the before and after 
color values in the Info palette:

• To view color values using the eyedropper tool, 
move the pointer over the area of the image you 
want to examine. Opening a color adjustment 
dialog box activates the eyedropper tool ( ) 
outside the dialog box. You still have access to the 
scroll controls and to the hand and zoom tools 
when using keyboard modifiers.

• To view the color values under the color 
samplers, look at the bottom half of the Info 
palette. 

To move or delete a color sampler:

• To move a color sampler, select the color sampler 
tool ( ), and drag the sampler to the new 
location. 

• To delete a color sampler, select the color 
sampler tool. Drag the sampler out of the 
document window, or hold down Alt (Windows) 
or Option (Mac OS) and click the sampler.

To change the display of color sampler information in 
the Info palette:

• To display or hide color sampler information in 
the Info palette, choose Show Color Samplers or 
Hide Color Samplers from the palette menu.

• To change the color space in which a color 
sampler displays values, move the pointer onto the 
color sampler icon in the Info palette, hold down 
the mouse button, and choose another color space 
from the menu.

To use the eyedropper tool and Color palette to see 
color values: 

1 Choose Window > Show Color to open the 
Color palette.
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2 Open a color adjustment dialog box. This 
activates the eyedropper tool ( ) outside the 
dialog box.

3 Click the pixel you want to check in the image.

4 Make the adjustments in the dialog box, and 
before applying them, view the adjusted color 
values in the Color palette.

Saving and reapplying settings

The Save and Load buttons in the Levels, Curves 
(Photoshop), Hue/Saturation (Photoshop), 
Replace Color (Photoshop), Selective Color 
(Photoshop), and Variations dialog boxes let you 
save your settings and apply them to other images.

To save and reapply settings: 

1 Click Save in the adjustment dialog box you are 
using, and name and save the settings.

2 Close the adjustment dialog box, and 
open the image to which you want to apply the 
adjustments. 

3 Reopen the adjustment dialog box, and click 
Load. Locate and open the saved adjustment file.

4 Click OK.

If you often apply the same adjustment, 
consider recording and running the adjustment 

as an action.

Comparing corrections in CMYK 
and RGB (Photoshop)
Even though you can perform all color and tonal 
corrections in either CMYK or RGB mode, you 
should choose a mode carefully.

Whenever possible, avoid multiple conversions 
between modes, because color values are rounded 
and lost with each conversion. If an RGB image is 
to be used on-screen, you needn’t convert it to 
CMYK mode. Conversely, if a CMYK scan is to be 
separated and printed, you needn’t perform 
corrections in RGB mode.

But if you must convert your image from one 
mode to another anyway, it makes sense to 
perform most of your tonal and color corrections 
in RGB mode and use CMYK mode for fine-
tuning. One advantage of working in RGB mode is 
that you can save memory and improve perfor-
mance. Another advantage is that you have more 
device independence, because RGB color spaces 
are not dependent on monitors or inks. Correc-
tions made to the image are preserved regardless of 
the monitor, computer, or output device used. 

Previewing CMYK colors in RGB 
(Photoshop)

When adjusting out-of-gamut colors or making 
color corrections in RGB mode, you can preview 
CMYK colors in an RGB image.
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To preview CMYK colors:

1 Choose View > Proof Setup > Working CMYK. 
To preview specific separation plates, choose 
View > Proof Setup > Working Cyan, Working 
Magenta, Working Yellow, Working Black, or 
Working CMY.

2 Choose View > Proof Colors. (A checkmark 
appears next to this command when it is enabled.)

CMYK equivalents for colors in the image are 
displayed using the current working CMYK space 
in the Color Settings dialog box, but no permanent 
changes are made.

Monitor CMYK colors as you edit in 
RGB mode by choosing View > New View to 

open a second window. Turn on Working CMYK in 
one window and leave it off in the other. 

Identifying out-of-gamut colors 
(Photoshop)

The gamut is the range of colors that a color system 
can display or print. A color that can be displayed 
in RGB or HSB models may be out-of-gamut, and 
therefore unprintable, for your CMYK setting. 
(See “Color gamuts (Photoshop)” on page 49.)

Photoshop automatically brings all colors into 
gamut when you convert an image to CMYK. But 
you might want to identify the out-of-gamut 
colors in an image or correct them manually 
before converting to CMYK. 

In RGB mode, you can identify out-of-gamut 
colors in the following ways:

• In the Info palette, an exclamation point appears 
next to the CMYK values whenever you move the 
pointer over an out-of-gamut color.

• In both the color picker and the Color palette, an 
alert triangle appears and the closest CMYK equiv-
alent is displayed whenever you select an out-of-
gamut color. To select the CMYK equivalent, click 
the triangle or the color patch. 

You can also quickly identify all out-of-gamut 
colors in an RGB image by using the Gamut 
Warning command. This command highlights 
pixels that are out of gamut in the image.

To turn on or off the highlighting of out-of-gamut 
colors:

Choose View > Gamut Warning. 

To change the gamut warning color:

1 Choose Edit > Preferences > Transparency & 
Gamut.

2 Under Gamut Warning, click the color box to 
display the color picker. Then choose a new 
warning color, and click OK. 
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3 Enter a value in the Opacity text box. Values can 
range from 0 to 100%. Use this setting to reveal 
more or less of the underlying image through the 
warning color. Then click OK. 

Original image, and preview of out-of-gamut colors 

Note: Because the gamut warning is generated using 
the current working CMYK space, be sure to fill in 
the Color Settings dialog box properly before 
following these out-of-gamut procedures. (See <<x-
ref to proper section in color management 
chapter>>.)

Using the Levels dialog box
The Levels dialog box lets you correct the tonal 
range and color balance of an image by adjusting 
intensity levels of the image’s shadows, midtones, 
and highlights. The Levels histogram serves as a 
visual guide for adjusting the image’s key tones.

Using Levels to set highlights, shadows, 
and midtones

You can set the highlights and shadows in an image 
by moving Input sliders to the first group of pixels 
on both ends of the Levels histogram. This maps 
these pixels—the darkest and lightest pixels in 
each channel—to black and white, increasing the 
tonal range of the image. The corresponding pixels 
in the other channels are adjusted proportionately 
to avoid altering the color balance.

You can use the middle Input slider to change the 
intensity values of the middle range of gray tones 
without dramatically altering the highlights and 
shadows.

Less exact than assigning target values or using the 
Curves dialog box, the Levels sliders often yield 
good results, especially if you want to maintain a 
color cast in the highlights and shadows. In many 
images, eliminating the color cast is useful. But in 
other images, using the Levels sliders to set the 
highlights and shadows may produce better results 
precisely because it does not affect the color balance.

To adjust tonal range using Levels:

1 Open the Levels dialog box. (See “Making color 
adjustments” on page 89.)

2 To adjust tones for a specific color channel, 
choose an option from the Channel menu.
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To edit a combination of color channels at the 
same time, Shift-select the channels in the 
Channels palette before choosing the Levels 
command. The Channel menu then displays the 
abbreviations for the target channels—for 
example, CM for cyan and magenta. The menu 
also contains the individual channels for the 
selected combination.

3 To adjust the shadows and highlights, do one of 
the following:

• Drag the black and white Input Levels sliders to 
the edge of the first group of pixels on either end of 
the histogram. You can also enter values directly 
into the first and third Input Levels text boxes.

• Drag the black and white Output Levels sliders 
to define new shadow and highlight values.You 
can also enter values directly in the Output Levels 
text boxes.

For example, suppose you want to increase the 
contrast in an image with pixels that currently 
cover a range of only 0–233. If you drag the Input 
Levels white triangle to 233, pixels with intensity 
values of 233 and higher (in each channel of the 
image) are mapped to 255; pixels with lower 
intensity values are mapped to corresponding 
lighter values. This remapping lightens the image, 
increasing the contrast in highlight areas.

Original

Resulting histogram



97ADOBE PHOTOSHOP 6.0
User Guide

Suppose instead you want to decrease the contrast 
in the image. If you drag the Output Levels white 
triangle to 220, pixels with intensity values of 255 
are remapped to 220, and pixels with lower 
intensity values are mapped to corresponding 
darker values. This darkens the image, decreasing 
the contrast in highlight areas.

Note: You can click Auto to move the highlight and 
shadow sliders automatically to the brightest and 
darkest points. This is the same as using the Auto 
Levels command and may be adequate for an 
average-key image. See “Using the Auto Levels 
command” on page 108. 

4 If your image needs midtone corrections, use 
the gray Input Levels slider. Drag the slider to the 
right to darken the midtones; drag it to the left to 
lighten the midtones. You can also enter values 
directly in the middle Input Levels text box.

5 Click OK.

6 To view the adjusted histogram, reopen the 
Levels dialog box. 

The gaps in the adjusted histogram do not indicate 
a perceptible problem in the image unless they are 
large or accompanied by a low pixel count.

Using Levels to adjust color

<<We may want to have a section on Levels here. 
We never explained how to use Levels for color 
correction in the old UGs (though it was hinted 
at), so we need to investigate. It seems that you 
can select a color channel and drag the middle 
Input slider to adjust color. It may work like the 
Hue slider in H/S, with a move around the wheel 
from the pixel’s original color.>>

<<Is this where the eyedropper tools in the Levels 
dialog come into play? Or the Channels menu?>>

Using the Curves dialog box 
(Photoshop)
Like the Levels dialog box, the Curves dialog box 
lets you adjust the entire tonal range of an image. 
But instead of making adjustments using only 
three variables (highlights, shadows, midtones), 
with Curves you can adjust any point along a 
0–255 scale while keeping up to 15 other values 
constant. You can also use Curves to make precise 
adjustments to individual color channels in an 
image.

To adjust tonal range and color balance using Curves:

1 Open the Curves dialog box. (See “Making color 
adjustments” on page 89.)

A. Highlights B. Midtones C. Shadows

A

B

C
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The horizontal axis of the graph represents the 
original intensity values of the pixels (Input 
levels); the vertical axis represents the new color 
values (Output levels). In the default diagonal line, 
all pixels have identical Input and Output values.

Note: For RGB images, Curves displays intensity 
values from 0 to 255, with shadows (0) on the left. 
For CMYK images, Curves displays percentages from 
0 to 100, with highlights (0) on the left. To reverse the 
display of shadows and highlights at any time, click 
the double arrow below the curve.

2 To adjust the color balance of the image, choose 
the channel (or channels) you want to adjust from 
the Channel menu.

To edit a combination of color channels at the 
same time, Shift-select the channels in the 
Channels palette before choosing Curves. The 
Channel menu then displays the abbreviations for 
the target channels—for example, CM for cyan 
and magenta. The menu also contains the 
individual channels for the selected combination. 

3 To make the Curves grid finer, hold down Alt 
(Windows) or Option (Mac OS), and click the 
grid. Alt/Option-click again to make the grid 
larger.

Clicking in the image displays the intensity values and 
location on the curve.

4 Click any points on the curve that you want to 
remain fixed. For example, if you want to adjust 
the midtones while minimizing the effect on the 
highlights and shadows, click the quarter and 
three-quarter points on the curve.

You can add up to 14 control points to the curve, 
locking those values. To remove a control point, 
drag it off the graph; select it and press Delete; or 
Ctrl-click (Windows) or Command-click 
(Mac OS) it. You cannot delete the endpoints of 
the curve.

Drag through the image to determine the 
lightest and darkest areas in the image. This is 

particularly useful in Windows when the Threshold 
function in Levels is unavailable.

<<What is the status of Threshold in the Levels 
dialog?>>

5 Do any of the following to adjust the curve:
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• Drag the curve until the image looks the way you 
want it. 

• Click a point on the curve, and enter Input and 
Output values for the point. 

• Select the pencil at the bottom of the dialog box, 
and drag to draw a new curve. You can hold down 
Shift to constrain the curve to a straight line, and 
click to define endpoints. When you’re finished, 
click Smooth if you want to smooth the curve.

The following shortcuts work with the Curves 
dialog box:

• Ctrl-click (Windows) or Command-click 
(Mac OS) in the image to set a point on the curve 
for the selected color in the composite channel 
(but not in the component channels).

• Shift+Ctrl-click (Windows) or 
Shift+Command-click (Mac OS) in the image to 
set a point on the curve for the selected color in 
each color component channel (but not in the 
composite channel).

• Shift-click to select multiple points. Selected 
points appear filled with black.

• Ctrl-click (Windows) or Command-click 
(Mac OS) in the grid, or press Ctrl-D (Windows) 
or Command-D (Mac OS) to deselect all points on 
the curve. <<It seems like you can just click in 
grid without a modifier key; is this true?>>

• Press arrow keys to move selected points on the 
curve.

• Press Ctrl+Tab (Windows) or Command+Tab 
(Mac OS) to move forward through control points 
on the curve. <<This does not seem to be working. 
Is the function still available?>>

• Press Shift+Ctrl+Tab (Windows) or 
Shift+Command+Tab (Mac OS) to move 
backward through control points on the curve.

The following examples show common tonal 
problems along with the Curves adjustment 
needed to correct the problem.

<<ART: Please adapt the color figure from p. 231 
in the 5.0 UG. But change caption headings to 
average key, high key, low key.>>

The following examples show common color 
balance problems along with the Curves 
adjustment needed to correct the problem.

<<ART: Please adapt the color figure here from p. 
232 in the 5.0 UG.>>

Using target values to set 
highlights and shadows 
(Photoshop)
<<Levels in IR currently doesn’t have this capa-
bility. Verify that we won’t be adding it.>>

Professional color technicians typically set the 
highlights and shadows in an image by assigning 
their lightest and darkest CMYK ink values to the 
lightest and darkest areas of detail in the image.
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When identifying the lightest and darkest areas of 
an image, it’s important to identify representative 
highlights and shadows. Otherwise the tonal range 
may be expanded unnecessarily to include extreme 
pixel values that don’t give the image detail. A 
highlight area must be a printable highlight, not 
specular white. Specular white has no detail, and so 
no ink is printed on the paper. For example, a spot 
of glare is specular white, not a printable highlight.

To use target values to set highlights and shadows:

1 Select the eyedropper tool, and choose 3 by 3 
Average from the Sample Size menu in the 
eyedropper tool options. This ensures a represen-
tative sample of an area rather than the value of a 
single screen pixel.

2 Open the Levels or Curves dialog box. 
(See “Making color adjustments” on page 89.)

Opening Levels or Curves activates the eyedropper 
tool ( ) outside the dialog box. You still have 
access to the scroll controls and to the hand and 
zoom tools when using keyboard modifiers.

3 Do one of the following to identify areas of 
representative highlights and shadows in the 
image:

• Move the pointer around the image, and look at 
the Info palette to find the lightest and darkest 
areas. (See “Seeing the color values of pixels” on 
page 91.) 

• Turn on Threshold mode in the Levels dialog 
box to identify the lightest and darkest areas. 
<<Will Threshold mode be in the product?>>

• Drag the pointer in the image, and look at the 
Curves dialog box to find the lightest and darkest 
points in the range of values.

4 Double-click the white eyedropper tool in the 
Levels or Curves dialog box to display the color 
picker. Enter the color values you want to assign to 
the lightest area in the image, and click OK. Follow 
these guidelines: 

• In most situations when you are printing on 
white paper, you can achieve a good highlight in 
an average-key image using CMYK values of 5, 3, 
3, and 0, respectively. 

• The RGB equivalent is 244, 244, 244.

• The grayscale equivalent is a 4% dot. 

• You can reproduce these target values quickly by 
entering 96 in the Brightness (B) text box. 

• With a low-key image, you might want to set the 
highlight to a lower value to avoid too much 
contrast. Experiment with Brightness values 
between 96 and 80.

<<ART: Insert top 3 illos of the color figure from 
p. 230 in the 5.0 UG.>>

5 In the image, click the highlight you identified 
in step 3. If you accidentally click the wrong 
highlight, hold down Alt (Windows) or Option 
(Mac OS), and click Reset in the Levels or Curves 
dialog box.

The pixel values throughout the image are 
adjusted proportionately to the new highlight 
values. Any pixels lighter than the area you clicked 
become specular white. The Info palette shows the 
values both before and after the color adjustment.
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6 Double-click the black eyedropper tool in the 
Levels or Curves dialog box to open the color 
picker. Enter the values you want to assign to the 
darkest area in the image, and click OK. Follow 
these guidelines:

• In most situations when you’re printing on 
white paper, you can achieve a good shadow in an 
average-key image using CMYK values of 65, 53, 
51, and 95. 

• The RGB equivalent is 10, 10, 10.

• The grayscale equivalent is a 96% dot.

• You can reproduce these same values quickly by 
entering 4 in the Brightness (B) text box.

• With a high-key image, you might want to set 
the shadow to a higher value to maintain detail in 
the highlights. Experiment with Brightness values 
between 4 and 20.

<<ART: Insert bottom 3 illos of the color figure 
from p. 230 in the 5.0 UG.>>

7 In the image, click the shadow you identified in 
step 3. 

8 Click OK.

To use Threshold mode to identify the lightest and 
darkest areas in an image:

1 Open the Levels dialog box. Make sure the 
Preview option is deselected.

Note: On most systems running Windows, 
Threshold mode works only if the monitor is set to 
256 colors. The Video LUT Animation option in the 
Display & Cursors Preferences dialog box must be on 
for Threshold mode to work. (See “Previewing color 
adjustments” on page 90.)

<<Check the status of Video LUT Animation. It’s 
currently not in display prefs, and I haven’t been 
able to get any info on it.>>

2 Hold down Alt (Windows) or Option 
(Mac OS), and drag the white or black Input 
Levels triangle.

The image changes to Threshold mode, and a 
high-contrast preview image appears. The visible 
areas of the image indicate the lightest parts of the 
image if you are dragging the white slider, and the 
darkest parts if you are dragging the black slider. If 
a color channel is selected in the Levels dialog box, 
the black area indicates where none of the given 
color component exists.
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3 Slowly drag the slider to the center of the 
histogram to identify the light or dark areas in the 
image. Use these pixels for targeting the black 
point and white point in your image.

Adjusting the gamma value of an 
image (ImageReady)
<<Will this feature be in Photoshop?>>

Gamma measures a monitor’s brightness range 
that is used for the darker tones in an image. A 
higher gamma value yields an overall darker 
image. Windows systems use a higher gamma 
value than Mac OS systems, with the result that the 
same image is noticeably darker on a Windows 
system than on a Mac OS system. 

<<ART: Insert the color figure from “Adjusting 
gamma” in IR2 help.>>

Designers, particularly those who use Mac OS 
systems to create images that will be viewed 
primarily on Windows systems, must consider the 
issue of cross-platform gamma.

You can adjust the gamma value of an image 
automatically so that it will display correctly on 
the alternative platform, or you can set custom 
gamma values for the image. 

Note: The Gamma dialog box modifies the pixel 
values in an image. By contrast, the Preview options 
adjust the appearance of the image on your monitor 
but do not change the image’s pixel values. 
<<Where in UG are the IR Preview commands 
covered?>>

To adjust the gamma value automatically:

1 Choose Image > Adjust > Gamma.

2 Select Preview to preview the adjustment in the 
image.

3 Adjust the gamma:

• Select Windows to Macintosh to adjust gamma 
for display in Mac OS.

• Select Macintosh to Windows to adjust gamma 
for display in Windows.

4 Click OK.

Note: Images created in Photoshop 4.0 or earlier use 
Mac OS gamma value by default and should be 
adjusted for display in Windows (unless gamma was 
adjusted when the image was created). Images 
created in Photoshop 5.0 or later use Windows 
gamma value by default and will be at the correct 
gamma for display in Windows with no adjustment.

To adjust the gamma value manually:

1 Choose Image > Adjust > Gamma.

2 Select Preview to preview the adjustment in the 
image.

3 Drag the Gamma slider, or enter a value in the 
text box between 0.1 and 9.99. The Gamma slider 
measures the amount of change from the current 
gamma value. (The slider does not indicate the 
actual gamma value.)

4 Click OK.



103ADOBE PHOTOSHOP 6.0
User Guide

About the color wheel
Because there are numerous ways to achieve 
similar results in color balance, it’s useful to 
consider the type of image you have and the effect 
you want to produce. If you’re new to adjusting 
color components, it helps to keep a diagram of 
the color wheel on hand. You can use the color 
wheel to predict how a change in one color 
component affects other colors and also how 
changes translate between RGB and CMYK color 
models. 

A. Green B. Yellow C. Red
D. Magenta E. Blue F. Cyan

For example, you can decrease the amount of any 
color in an image by increasing the amount of its 
opposite on the color wheel—and vice versa. 
Similarly, you can increase and decrease a color by 
adjusting the two adjacent colors on the wheel, or 
even by adjusting the two colors adjacent to its 
opposite. 

In a CMYK image, you can decrease magenta 
either by decreasing the amount of magenta or its 
proportion (by adding cyan and yellow). You can 
even combine these two corrections, minimizing 
their effect on overall lightness. In an RGB image, 
you can decrease magenta by removing red and 
blue or by adding green. All of these adjustments 
result in an overall color balance containing less 
magenta.

Using the Color Balance 
command (Photoshop)
The Color Balance command changes the overall 
mixture of colors in an image for generalized color 
correction. 

To use the Color Balance command: 

1 Make sure the composite channel is selected in 
the Channels palette. This command is available 
only when you’re viewing the composite channel.

2 Open the Color Balance dialog box. 
(See “Making color adjustments” on page 89.)

3 Select Shadows, Midtones, or Highlights to 
select the tonal range on which you want to focus 
the changes. 

4 With RGB images, select Preserve Luminosity to 
prevent changing the luminosity values in the 
image while changing the color. This option 
maintains the tonal balance in the image.

<<What, technically, is the difference between 
lightness, brightness, luminosity?>>

E

C

BA

F

D
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5 Drag a slider toward a color you want to 
increase in the image; drag a slider away from a 
color you want to decrease in the image.

The values above the color bars show the color 
changes for the red, green, and blue channels. (For 
Lab images, the values are for the a and b 
channels.) Values can range from –100 to +100.

6 Click OK.

Using the Hue/Saturation 
command
The Hue/Saturation command lets you adjust the 
hue, saturation, and lightness of individual color 
components in an image. Adjusting the hue, or 
color, represents a move around the color wheel. 
Adjusting the saturation, or purity of the color, 
represents a move across its radius. 

A. Saturation B. Hue C. Brightness D. All hues

You can also use the Colorize option to add color 
to a grayscale image converted to RGB, or to an 
RGB image—for example, to make it look like a 
duotone by reducing its color values to one hue.

To use the Hue/Saturation command: 

1 Open the Hue/Saturation dialog box. 
(See “Making color adjustments” on page 89.)

The two color bars in the dialog box represent the 
colors in their order on the color wheel. The upper 
color bar shows the color before the adjustment; 
the lower bar shows how the adjustment affects all 
of the hues at full saturation.

2 Choose which colors to adjust:

<<The Edit menu is missing in IR. Please confirm 
that this is the final behavior.>>

• Choose Master from the Edit menu in the dialog 
box to adjust all colors at once. 

• Choose one of the other preset color ranges 
listed for the color you want to adjust. An 
adjustment slider appears between the color bars, 
which you can use to edit any range of hues. (For 
information on how to modify the slider’s range, 
see the instructions later in this section.)

3 For Hue, enter a value or drag the slider until the 
colors appear as you want. A

B

C
D
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The values displayed in the text box reflect the 
number of degrees of rotation around the wheel 
from the pixel’s original color. A positive value 
indicates clockwise rotation, a negative value 
counterclockwise rotation. Values can range from 
–180 to +180.

Original image, and with cyan hue adjusted

4 For Saturation, enter a value or drag the slider to 
the right to increase the saturation or to the left to 
decrease it. 

The color shifts away from or toward the center of 
the wheel, relative to the beginning color values of 
the selected pixels. Values can range from –100 to 
+100.

Original image, and with decreased saturation
(Saturation: –40)

5 For Lightness, enter a value or drag the slider to 
the right to increase the lightness or to the left to 
decrease it. Values can range from –100 to +100.

6 Click OK.

To modify the range of an adjustment slider 
(Photoshop):

<<Please confirm this behavior is in Photoshop 
only>>

1 Choose an individual color from the Edit menu 
in the dialog box:

2 Do any of the following to the adjustment slider:

• Drag one of the white triangles to adjust the 
amount of color fall-off without affecting the 
range.

• Drag one of the light gray bars to adjust the 
range without affecting the amount of fall-off.

• Drag the dark gray center part to move the entire 
adjustment slider, selecting a different color area.

• Drag one of the vertical white bars next to the 
dark gray center part to adjust the range of the 
color component. Increasing the range decreases 
the fall-off, and vice versa.

• Ctrl-drag (Windows) or Command-drag 
(Mac OS) the color bar so that a different color is 
in the center of the bar.

A. Adjusts fall-off without affecting range B. Adjusts range 
without affecting fall-off C. Moves entire slider D. Adjusts 
range of color component

A B C D
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If you modify the adjustment slider so that it falls 
into a different color range, the name changes to 
reflect this. For example, if you choose Yellow and 
alter its range so that it falls in the red part of the 
color bar, the name changes to Red 2. You can 
convert up to six of the individual color ranges to 
varieties of the same color range (for example, Red 
through Red 6).

Note: By default, the range of color selected when 
you choose a color component is 30° wide, with 30° 
of fall-off on either side. Setting the fall-off too low 
can produce dithering in the image.

3 To edit the range by choosing colors from the 
image, select the eyedropper tool ( ) in the dialog 
box and click in the image. Use the eyedropper + 
tool to add to the range; use the eyedropper – tool 
to subtract from the range. 

While the eyedropper tool is selected, you can also 
press Shift to add to the range or Alt (Windows) or 
Option (Mac OS) to subtract from it.

To colorize a grayscale image or create a monotone 
effect: 

1 If you are colorizing a grayscale image, choose 
Image > Mode > RGB (Photoshop) to convert the 
image to RGB.

2 Open the Hue/Saturation dialog box. 
(See “Making color adjustments” on page 89.)

3 Select Colorize. The image is converted to the 
hue of the current foreground color. The lightness 
value of each pixel does not change.

4 Use the Hue slider to select a new color if 
desired. Use the Saturation and Lightness sliders to 
adjust the saturation and lightness of the pixels.

5 Click OK.

Using the Replace Color 
command (Photoshop)
The Replace Color command lets you create a 
mask around specific colors and then replace those 
colors in the image. You can set the hue, 
saturation, and lightness of the area identified by 
the mask. The mask is temporary. 

To use the Replace Color command:

1 Choose Image > Adjust > Replace Color.

2 Select a display option:

• Selection to display the mask in the preview box. 
Masked areas are black and unmasked areas are 
white. Partially masked areas (areas covered with a 
semitransparent mask) appear as varying levels of 
gray according to their opacity. For more infor-
mation, see “About masks” on page 214.

• Image to display the image in the preview box. 
This option is useful when you are working with a 
magnified image or have limited screen space.
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3 Click in the image or in the preview box to select 
the areas exposed by the mask. Shift-click or use 
the eyedropper + button to add areas; Alt-click 
(Windows), Option-click (Mac OS), or use the 
eyedropper – button to remove areas.

Color changed to mask

4 Adjust the tolerance of the mask by dragging the 
Fuzziness slider or entering a value. This controls 
the degree to which related colors are included in 
the selection.

5 Drag the Hue, Saturation, and Lightness sliders 
(or enter values in the text boxes) to change the 
color of the selected areas. 

6 Click OK.

Using the Selective Color 
command (Photoshop)
Selective color correction is a technique used by 
high-end scanners and separation programs to 
increase and decrease the amount of process colors 
in each of the additive and subtractive primary 
color components in an image. 

Selective color correction is based on a table that 
shows the amount of each process ink used to 
create each primary color. By increasing and 
decreasing the amount of a process ink in relation 
to the other process inks, you can modify the 
amount of a process color in any primary color 
selectively—without affecting any other primary 
colors. For example, you can use selective color 
correction to dramatically decrease the cyan in the 
green component of an image while leaving the 
cyan in the blue component unaltered.

Even though Selective Color uses CMYK colors to 
correct an image, you can use it on RGB images as 
well as on images that will be printed.

To use the Selective Color command:

1 Make sure the composite channel is selected in 
the Channels palette. This command is available 
only when you’re viewing the composite channel.

2 Open the Selective Color dialog box. 
(See “Making color adjustments” on page 89.)

3 Choose the color you want to adjust from the 
Colors menu at the top of the dialog box. Color 
sets consist of the primary additive and subtractive 
colors plus whites, neutrals, and blacks.

4 For Method, select an option:

• Relative to change the existing amount of cyan, 
magenta, yellow, or black by its percentage of the 
total. For example, if you start with a pixel that is 
50% magenta and add 10%, 5% is added to the 
magenta (10% of 50% = 5%) for a total of 55% 
magenta. (This option cannot adjust pure specular 
white, which contains no color components.) 
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• Absolute to adjust the color in absolute values. 
For example, if you start with a pixel that is 50% 
magenta and add 10%, the magenta ink is set to a 
total of 60%. 

Note: The adjustment is based on how close a color 
is to one of the indicated correction points. For 
example, a pixel that contains 50% magenta is not at 
any exact correction point, and so will get a mix of 
corrections. 

<<What is meant here by an “exact correction 
point”?>>

5 Drag the sliders to increase or decrease the 
components in the selected color.

Use the Info palette to see the before and after 
color values.

6 Click OK.

Making quick overall 
adjustments to an image
The Brightness/Contrast, Auto Levels, Auto 
Contrast, and Variations commands change colors 
or tonal values in an image but are not as precise 
or flexible as the high-end color adjustment tools. 
They provide a simple way to make overall adjust-
ments quickly.

Using the Brightness/Contrast command

The Brightness/Contrast command lets you make 
simple adjustments to the tonal range of an image. 
Unlike Curves and Levels, this command makes 
the same adjustment to every pixel in the image. 
The Brightness/Contrast command does not work 
with individual channels and is not recommended 
for high-end output.

To use the Brightness/Contrast command: 

1 Open the Brightness/Contrast dialog box. 
(See “Making color adjustments” on page 89.)

2 Drag the sliders to adjust the brightness and 
contrast.

Dragging to the left decreases the level and to the 
right increases it. The number at the right of each 
slider value displays the brightness or contrast 
value. Values can range from –100 to +100. 

3 Click OK.

Using the Auto Levels command

The Auto Levels command moves the Levels 
sliders automatically to set highlights and 
shadows. It defines the lightest and darkest pixels 
in each color channel as white and black and then 
redistributes intermediate pixel values propor-
tionately. Because Auto Levels adjusts each color 
channel individually, it may introduce color casts.

By default, this feature clips the white and black 
pixels by 0.5%—that is, it ignores the first 0.5% of 
either extreme when identifying the lightest and 
darkest pixels in the image. This ensures that white 
and black values are based on representative rather 
than extreme pixel values.



109ADOBE PHOTOSHOP 6.0
User Guide

Auto Levels gives good results when an image with 
an average distribution of pixel values needs a 
simple contrast adjustment. However, adjusting 
the Levels or Curves (Photoshop) controls 
manually is more precise. 

To use the Auto Levels command:

Do one of the following:

• Choose Image > Adjust > Auto Levels.

• Open the Levels or Curves (Photoshop) dialog 
box, click Auto, and click OK.

To change the amount of white and black values 
clipped:

1 Hold down Alt (Windows) or Option 
(Mac OS), and click Options in the Levels or 
Curves (Photoshop) dialog box. 

2 In the Auto Range dialog box, enter the 
percentage of extreme highlight and shadow pixels 
to ignore, and click OK. A value between 0.5% and 
1% is recommended.

Using the Auto Contrast command

The Auto Contrast command adjusts the overall 
contrast and mixture of colors in an image 
automatically. It maps the lightest and darkest 
pixels in the image to white and black, which 
makes highlights appear lighter and shadows 
appear darker. 

When identifying the lightest and darkest pixels in 
an image, Auto Contrast clips the white and black 
pixels by 0.5%–that is, it ignores the first 0.5% of 
either extreme. This ensures that white and black 
values are based on representative rather than 
extreme pixel values.

Auto Contrast can improve the appearance of 
many photographic or continuous-tone images. It 
does not improve flat-color images.

To use the Auto Contrast command:

Choose Image > Adjust > Auto Contrast.

<<ART: Insert the figure from this section in the 
IR2 help.>>

Using the Variations command

The Variations command lets you adjust the color 
balance, contrast, and saturation of an image by 
showing you thumbnails of alternatives. 

This command is most useful for average-key 
images that don’t require precise color adjust-
ments. It does not work on indexed-color images 
(Photoshop).

To use the Variations command:

1 Open the Variations dialog box. (See “Making 
color adjustments” on page 89.)

Note: If the Variations command does not appear in 
the Adjust submenu, the Variations plug-in module 
may not have been installed. (See “Using plug-in 
modules” on page 15.)
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The two thumbnails at the top of the dialog box 
show the original selection (Original) and the 
selection with its currently selected adjustments 
(Current Pick). When you first open the dialog 
box, these two images are the same. As you make 
adjustments, the Current Pick image changes to 
reflect your choices.

2 Select Show Clipping if you want to display a 
neon preview of areas in the image that will be 
clipped by the adjustment—that is, converted to 
pure white or pure black. Clipping does not occur 
when you adjust midtones. 

Note: Clipping is not the same as out-of-gamut 
colors.

3 Select what to adjust in the image:

• Shadows, Midtones, or Highlights to indicate 
whether you want to adjust the dark, middle, or 
light areas.

• Saturation to change the degree of hue in the 
image. If Show Clipping is selected, the image may 
show clipping after an adjustment. This means 
you have exceeded maximum saturation for the 
color.

4 Drag the Fine/Coarse slider to determine the 
amount of each adjustment. Moving the slider one 
tick mark doubles the adjustment amount. 

5 Adjust the color and brightness:

• To add a color to the image, click the appropriate 
color thumbnail. 

• To subtract a color, click the thumbnail for its 
opposite color. (See “About the color wheel” on 
page 103.) For example, to subtract cyan, click the 
More Red thumbnail.

• To adjust brightness, click a thumbnail on the 
right side of the dialog box.

Each time you click a thumbnail, other thumbnails 
change. The center thumbnail always reflects the 
current choices.

6 Click OK.

Applying special color effects to 
images
The Desaturate, Invert, Equalize (Photoshop), 
Threshold (Photoshop), and Posterize 
(Photoshop) commands change colors or 
brightness values in an image but are typically 
used for enhancing color and producing special 
effects, rather than for correcting color. 

Note: You can also make color adjustments by 
blending colors from different channels. See “Mixing 
color channels” on page 210.

Using the Desaturate command 

The Desaturate command removes all color values 
from a color image, converting it to a grayscale 
image in the same color mode. The lightness value 
of each pixel does not change.

This command has the same effect as setting 
Saturation to –100 in the Hue/Saturation dialog 
box.

Note: If you are working with a multilayer image, 
Desaturate converts the selected layer only.

To use the Desaturate command:

Choose Image > Adjust > Desaturate.
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<<ART: Create a figure with the two windows for 
this? We have a comparison figure for all other 
commands in this section.>

Using the Invert command 

The Invert command inverts the colors in an 
image. You might use this command to make a 
positive black-and-white image negative or to 
make a positive from a scanned black-and-white 
negative. 

Note: Because color film contains an orange mask in 
its base, the Invert command cannot make negatives 
and positives from scanned color film.

When you invert an image, the brightness value of 
each pixel in the channels is converted to the 
inverse value on the 256-step color-values scale. 
For example, a pixel in a positive image with a 
value of 255 is changed to 0, and a pixel with a 
value of 5 to 250.

To use the Invert command:

Choose Image > Adjust > Invert, or choose 
Layer > New Content Layer > Invert (Photoshop). 

Using the Equalize command (Photoshop)

The Equalize command redistributes the 
brightness values of the pixels in an image so that 
they more evenly represent the entire range of 
brightness levels. When you apply this command, 
Photoshop finds the brightest and darkest values 
in the image and remaps them so that the brightest 
value represents white and the darkest value repre-
sents black. Photoshop then attempts to equalize 
the brightness—that is, to distribute the interme-
diate pixel values evenly throughout the grayscale. 

You might use the Equalize command when a 
scanned image appears darker than the original 
and you want to balance the values to produce a 
lighter image. Using Equalize together with the 
Histogram command lets you see before-and-after 
brightness comparisons.

To use the Equalize command: 

1 Choose Image > Adjust > Equalize. 

2 If you selected an area of the image, select what 
to equalize in the dialog box, and click OK:

• Equalize Selected Area Only to evenly distribute 
only the selection’s pixels.

• Equalize Entire Image Based on Selected Area to 
evenly distribute all image pixels based on those in 
the selection. 



CHAPTER 5112
Making Color and Tonal Adjustments

Using the Threshold command 
(Photoshop)

The Threshold command converts grayscale or 
color images to high-contrast, black-and-white 
images. You can specify a certain level as a 
threshold. All pixels lighter than the threshold are 
converted to white; all pixels darker are converted 
to black.

To use the Threshold command: 

1 Open the Threshold dialog box. (See “Making 
color adjustments” on page 89.)

The Threshold dialog box displays a histogram of 
the luminance levels of the pixels in the current 
selection.

2 Drag the slider below the histogram until the 
threshold level you want appears at the top of the 
dialog box, and click OK. As you drag, the image 
changes to reflect the new threshold setting.

Using the Posterize command 
(Photoshop)

The Posterize command lets you specify the 
number of tonal levels (or brightness values) for 
each channel in an image and then maps pixels to 
the closest matching level. For example, choosing 
two tonal levels in an RGB image gives six colors, 
two for red, two for green, and two for blue.

This command is useful for creating special effects, 
such as large, flat areas in a photograph. Its effects 
are most evident when you reduce the number of 
gray levels in a grayscale image. But it also 
produces interesting effects in color images.

If you want a specific number of colors in your 
image, convert the image to grayscale and 

specify the number of levels you want. Then convert 
the image back to the previous color mode, and 
replace the various gray tones with the colors you 
want.

To use the Posterize command:

1 Open the Posterize dialog box. (See “Making 
color adjustments” on page 89.)

2 Enter the number of tonal levels you want, and 
click OK.

Sharpening an image
Unsharp masking, or USM, is a traditional film 
compositing technique used to sharpen edges in 
an image. The Unsharp Mask filter corrects 
blurring introduced during photographing, 
scanning, resampling, or printing. It is useful for 
images intended for both print and online.

Unsharp Mask locates pixels that differ from 
surrounding pixels by the threshold you specify 
and increases the pixels’ contrast by the amount 
you specify. In addition, you specify the radius of 
the region to which each pixel is compared.
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The effects of the Unsharp Mask filter are far more 
pronounced on-screen than in high-resolution 
output. If your final destination is print, exper-
iment to determine what settings work best for 
your image.

For information on other filters for sharpening 
images, see “Sharpen filters” on page 272.

To use Unsharp Mask to sharpen an image: 

1 Choose Filter > Sharpen > Unsharp Mask. 
Make sure the Preview option is selected.

Press on the image in the preview window to see 
how the image looks without the sharpening. 

Drag in the preview window to see different parts of 
the image, and click the + or – to zoom in or out.

2 Sharpen the image:

• Drag the Amount slider or enter a value to 
determine how much to increase the contrast of 
pixels. For high-resolution printed images, an 
amount between 150% and 200% is usually 
recommended. 

• Drag the Radius slider or enter a value to 
determine the number of pixels surrounding the 
edge pixels that affect the sharpening. For high-
resolution images, a Radius between 1 and 2 is 
usually recommended.

A lower value sharpens only the edge pixels, 
whereas a higher value sharpens a wider band of 
pixels. This effect is much less noticeable in print 
than on-screen, because a 2-pixel radius represents 
a smaller area in a high-resolution printed image. 

• Drag the Threshold slider or enter a value to 
determine how different the sharpened pixels 
must be from the surrounding area before they are 
considered edge pixels and sharpened by the filter. 
To avoid introducing noise (in images with flesh-
tones, for example), experiment with Threshold 
values between 2 and 20. The default Threshold 
value (0) sharpens all pixels in the image.

If applying Unsharp Mask makes already 
bright colors appear overly saturated, convert 

the image to Lab mode and apply the filter to the L 
channel only. This sharpens the image without 
affecting the color components.

3 Click OK.
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Chapter 6: Selecting

o modify part of an image in Adobe 
Photoshop or ImageReady, you first select 
the area you want to edit. A selected area is 

indicated by a dotted selection border, also called a 
selection marquee. The area outside the selection 
border is protected while you move, copy, paint, or 
apply special effects to the isolated area.

You can choose from a variety of specialized tools 
for creating selection borders. You can also create 
selections using the pen or shape tools, which 
produce precise outlines called paths. You can 
make more sophisticated selections using masks. 
(See “Using Channels and Masks (Photoshop)” on 
page 205.) For information on editing selections, 
see “Editing and Retouching” on page 143.

About selections
Since there are two different types of data in 
your image, rasterized and vector, you need to 
use separate sets of tools to make each type of 
selection. You can select pixels or make non-
pixel selections. When you select pixels, you are 
selecting resolution dependent information in 
the image. 

<<xref to earlier chapter general discussion bout 
rasterized vs vector information, may add more 
here>>

Additionally, you can also select resolution 
independent paths and vector objects (or layer 
masks) in an image using the vector selection 
tools. (See “Selecting paths and vector objects 
(Photoshop)” on page 125.)

Making pixel selections
You can select pixels in an image by dragging with 
the marquee tools or lasso tools, or by targeting 
color areas with the magic wand tool or (in 
Photoshop) the Color Range command. Making a 
new selection replaces the existing one.

To select all pixels on a layer within the canvas 
boundaries:

1 Select the layer in the Layers palette.

2 Choose Select > All. 

To deselect selections:

Do one of the following:

• Choose Select > Deselect.

• If you are using the rectangle marquee, rounded 
rectangle marquee (ImageReady), elliptical 
marquee, or lasso tool, click anywhere in the image 
outside the selected area.

To reselect the most recent selection:

Choose Select > Reselect.

Using the marquee tools

The marquee tools let you select rectangles, 
ellipses, rounded rectangles (ImageReady), and 
1-pixel rows and columns. By default, the selection 
border is dragged from its corner.

T
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To use the marquee tools:

1 Select one of the following tools:

• Rectangle marquee ( ) to make a rectangular 
selection. 

• Rounded rectangle marquee ( ) to select a 
rounded rectangle such as a Web-page button 
(ImageReady).

• Elliptical marquee ( ) to make an elliptical 
selection.

• Single row ( ) or single column ( ) marquee to 
define the border as a 1-pixel-wide row or column. 

2 In the options bar, specify a selection option. 
(See “Adjusting selections manually” on 
page 122.)

3 In the options bar, specify a feathering setting. 
Turn anti-aliasing on or off for the rounded 
rectangle or elliptical marquee. (See “Softening 
the edges of a selection” on page 124.)

4 For the rectangle, rounded rectangle, or ellip-
tical marquee, choose a style in the options bar:

• Normal to determine marquee proportions by 
dragging. 

• Constrained Aspect Ratio to set a height-to-
width ratio. Enter the values (including decimal 
values) for the aspect ratio. For example, to draw a 
marquee twice as wide as it is high, enter 2 for the 
width and 1 for the height. 

• Fixed Size to specify set values for the marquee’s 
height and width. Enter pixel values in whole 
numbers. Keep in mind that the number of pixels 
needed to create a 1-inch selection depends on the 
resolution of the image. (See “About image size 
and resolution” on page 21.)

5 Do one of the following to make a selection:

• With the rectangle, rounded rectangle, or ellip-
tical marquee, drag over the area you want to 
select. Hold down Shift as you drag to constrain 
the marquee to a square or circle. To drag a 
marquee from its center, hold down Alt 
(Windows) or Option (Mac OS) after you begin 
dragging.

• With the single row or single column marquee, 
click near the area you want to select, and then 
drag the marquee to the exact location. If no 
marquee is visible, increase the magnification of 
your image view.

To reposition a rectangle, rounded rectangle, or 
elliptical marquee, first drag to create the 

border, keeping the mouse button depressed; then 
hold down the spacebar and continue to drag. If you 
have finished drawing the border, drag from inside 
the selection.

Using the lasso, polygon lasso, and 
magnetic lasso tools

The lasso and polygon lasso tools let you draw 
both straight-edged and freehand segments of a 
selection border. With the magnetic lasso tool 
(Photoshop), the border snaps to the edges of 
defined areas in the image. 

The magnetic lasso tool is especially useful for 
quickly selecting objects with complex edges set 

against high-contrast backgrounds.
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To use the lasso tool:

1 Select the lasso tool ( ), and select options. 
(See “Setting options for the lasso tools” on 
page 118.)

2 Drag to draw a freehand selection border. 

3 To draw a straight-edged selection border, hold 
down Alt (Windows) or Option (Mac OS), and 
click where segments should begin and end. You 
can switch between drawing freehand and 
straight-edged segments. 

4 To erase recently drawn segments, hold down 
Delete until you’ve erased the desired segment.

5 To close the selection border, release the mouse 
without holding down Alt (Windows) or Option 
(Mac OS).

To use the polygon lasso tool:

1 Select the polygon lasso tool ( ), and select 
options. (See “Setting options for the lasso tools” 
on page 118.)

2 Click in the image to set the starting point.

3 To draw a straight segment, position the pointer 
where you want the first straight segment to end, 
and click. Continue clicking to set endpoints for 
subsequent segments.

4 To draw a freehand segment, hold down Alt 
(Windows) or Option (Mac OS), and drag. 
When finished, release Alt (Windows) or Option 
(Mac OS) and the mouse button.

5 To erase recently drawn straight segments, 
press Delete. To erase freehand segments, hold 
down Delete.

6 Continue to click and Alt-drag (Windows) or 
Option-drag (Mac OS) to finish selecting. 

7 Close the selection border:

• Position the polygon lasso tool pointer over the 
starting point (a closed circle appears next to the 
pointer), and click.

• If the pointer is not over the starting point, 
double-click the polygon lasso tool pointer, 
or Ctrl-click (Windows) or Command-click 
(Mac OS).

To use the magnetic lasso tool (Photoshop):

1 Select the magnetic lasso tool ( ), and select 
options. (See “Setting options for the lasso tools” 
on page 118.)

2 Click in the image to set the first fastening point. 
Fastening points anchor the selection border in 
place.

3 To draw a freehand segment, move the pointer 
along the edge you want to trace. (You can also 
drag with the mouse button depressed.) 

The most recent segment of the selection border 
remains active. As you move the pointer, the active 
segment snaps to the strongest edge in the image. 
Periodically, the magnetic lasso tool adds fastening 
points to the selection border to anchor previous 
segments.

4 If the border doesn’t snap to the desired edge, 
click once to add a fastening point manually. 
Continue to trace the edge and add fastening 
points as needed.

5 To switch temporarily to the other lasso tools, 
do one of the following:
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• To activate the lasso tool, hold down Alt 
(Windows) or Option (Mac OS), and drag with 
the mouse button depressed.

• To activate the polygon lasso tool, hold down Alt 
(Windows) or Option (Mac OS), and click.

6 To erase recently drawn segments and fastening 
points, press Delete. 

7 Close the selection border:

• To close the border with a freehand magnetic 
segment, double-click, or press Enter or Return.

• To close the border with a a straight segment, 
hold down Alt (Windows) or Option (Mac OS), 
and double-click.

Setting options for the lasso tools

The lasso tool options let you customize how the 
different lasso tools detect and select edges.

To set options for the lasso tools:

1 If needed, select the tool.

2 In the options bar, specify a selection option. 
(See “Adjusting selections manually” on 
page 122.) <<ED: xrefs in this section are sending 
people to a third jump away for the answer. Any 
suggestions?>>

3 Specify feather and anti-aliasing options. 
(See “Softening the edges of a selection” on 
page 124.)

4 For the magnetic lasso tool (Photoshop), set any 
of these options:

• To specify a detection width, enter a pixel value 
between 1 and 40 for Width. The magnetic lasso 
only detects edges within the specified distance 
from the pointer.

• To specify the lasso’s sensitivity to edges in the 
image, enter a value between 1% and 100% for 
Edge Contrast. A higher value detects only edges 
that contrast sharply with their surroundings; a 
lower value detects lower-contrast edges.

• To specify the rate at which the lasso sets 
fastening points, enter a value between 0 and 100 
for Frequency. A higher value anchors the 
selection border in place more quickly. 

On an image with well-defined edges, try a higher 
tolerance and higher edge contrast, and trace the 
border roughly. On an image with softer edges, try 
a lower tolerance and lower edge contrast, and 
trace the border more precisely.

• To change the magnetic lasso cursor to indicate 
the lasso Width value in the options bar, press the 
Caps Lock key on the keyboard.

• If you are working with a stylus tablet, select or 
deselect the Stylus Pressure option. When the 
option is selected, an increase in stylus pressure 
will cause the edge tolerance to narrow. 

While creating a selection, you can press [to 
decrease the magnetic lasso edge tolerance by 

1 pixel; press] to increase the tolerance by 1 pixel.
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Using the magic wand tool

The magic wand tool lets you select a consistently 
colored area (for example, a red flower) without 
having to trace its outline. You specify the color 
range, or tolerance, for the magic wand tool’s 
selection.

Note: You cannot use the magic wand tool on an 
image in Bitmap mode.

To use the magic wand tool:

1 Select the magic wand tool ( ).

2 In the options bar, specify a selection option. 
You can create a new selection, add to, subtract 
from, or restrict the selection. The magic wand 
cursor changes indicating which option is selected.

3 For Tolerance, enter a value in pixels, ranging 
from 0 to 255. Enter a low value to select colors 
very similar to the pixel you click or a higher value 
to select a broader range of colors. 

4 To define a smooth edge, select Anti-aliased. 
(See “Softening the edges of a selection” on 
page 124.)

5 To select all areas using the same colors, select 
Contiguous. Otherwise only the adjacent pixels 
will be selected.

6 To select colors using data from all the visible 
layers, select Use All Layers. Otherwise, the magic 
wand tool selects colors from the active layer only. 

7 In the image, click the color you want to select. 
All adjacent pixels within the tolerance range are 
selected.

Using the Color Range command 
(Photoshop)

The Color Range command selects a specified 
color or color subset within an existing selection 
or an entire image. If you want to replace a 
selection, be sure to deselect everything before 
applying this command. 

To refine an existing selection, use the Color Range 
command repeatedly to select a subset of colors. 
For example, to select the green areas in a cyan 
selection, select Cyans in the Color Range dialog 
box, and click OK. Then reopen the Color Range 
dialog box, and select Greens. (The results are 
subtle because the technique selects parts of colors 
within a color mix.) 

To select a color range using sampled colors:

1 Choose Select > Color Range. 

2 For Select, choose the eyedropper tool ( ).

3 Select one of the display options:

• Selection to preview only the selection as you 
build it.

• Image to preview the entire image. For example, 
you might want to sample from a part of the image 
that isn’t on-screen.

To toggle between the Image and Selection 
previews in the Color Range dialog box, press 

Ctrl (Windows) or Command (Mac OS). 

4 Position the pointer over the image or preview 
area, and click to sample the colors you want 
included. 
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<<ART: keep; check UI>>

Sampling color

5 Adjust the range of colors by using the Fuzziness 
slider or entering a value. To decrease the range of 
colors selected, decrease the value. The Fuzziness 
option partially selects pixels by controlling the 
degree to which related colors are included in the 
selection (similar to the Tolerance option for the 
magic wand and paint bucket options). 

<<ART: keep; check UI>>

Increasing Fuzziness expands selection

6 Adjust the selection:

• To add colors, select the plus eyedropper, and 
click in the preview area or image.

• To remove colors, select the minus eyedropper, 
and click in the preview area or image.

To activate the plus eyedropper temporarily, 
hold down Shift. Hold down Alt (Windows) or 

Option (Mac OS) to activate the minus eyedropper.

7 To preview the selection in the image window, 
choose an option for Selection Preview:

• None to display no preview in the image 
window.

• Grayscale to display the selection as it would 
appear in a grayscale channel. 

• Black Matte to display the selection in color 
against a black background. 

• White Matte to display the selection in color 
against a white background.

• Quick Mask to display the selection using the 
current quick mask settings. (See “Creating 
temporary masks in Quick Mask mode” on 
page 215.)

8 To revert to the original selection, hold down 
Alt (Windows) or Option (Mac OS), and click 
Reset.

9 Click OK to make the selection.

To select a range using preset colors:

1 Choose Select > Color Range. 
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2 For Select, choose a color or tonal range. The 
Out-of-Gamut option works only on RGB and 
Lab images. (An out-of-gamut color is an RGB 
or Lab color that cannot be printed using process 
color printing. See “Color gamuts (Photoshop)” 
on page 49.)

3 Click Selection to display the selected areas in 
the preview area. 

4 To preview the selection in the image window, 
choose an option for Selection Preview:

• None to display no preview in the image 
window.

• Grayscale to display the selection as it would 
appear in a grayscale channel. 

• Black Matte to display the selection in color 
against a black background. 

• White Matte to display the selection in color 
against a white background.

• Quick Mask to display the selection using the 
current quick mask settings. (See “Creating 
temporary masks in Quick Mask mode” on 
page 215.)

5 To revert to the original selection, hold down 
Alt (Windows) or Option (Mac OS), and click 
Reset.

6 Click OK to make the selection.

Note: If a message appears stating “No pixels are 
more than 50% selected,” the selection border will 
not be visible. You may have selected a color, such as 
red, when the image didn’t contain the fully 
saturated color.

To save and load color range settings: 

Use the Save and Load buttons in the Color Range 
dialog box to save and reuse the current settings.

Creating selections from slices 
(ImageReady)

In ImageReady, you can convert a slice into a 
selection.

To create a selection from a slice:

1 Create a slice. (See “Creating and viewing slices” 
on page 300.)

2 Choose Select > Create Selection from Slice.

Adjusting pixel selections
You can adjust and refine your pixel selections 
using the selection tools and a variety of 
commands in the Select menu. 

In addition, you can apply geometric transforma-
tions to change the shape of a selection border. 
(See “Transforming objects in two dimensions” on 
page 161.)

Moving, hiding, or inverting a selection

You can move a selection border around the 
image, hide a selection border, and invert a 
selection so that the unselected part of the image is 
selected instead.

To move a selection border: 

1 Using any selection tool, position the pointer 
inside the selection border.
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2 Drag the border to enclose a different area of the 
image. You can drag a selection border beyond the 
canvas boundaries. When you drag it back, the 
original border reappears intact. You can also drag 
the selection border to another image window.

To control the movement of a selection: 

• To constrain the direction to a multiple of 45°, 
begin dragging, and then hold down Shift as you 
continue to drag. 

• To move the selection in 1-pixel increments, use 
an arrow key. 

• To move the selection in 10-pixel increments, 
hold down Shift, and use an arrow key.

To hide or show a selection border:

Choose View > Show Selection. This affects the 
current selection only. The selection border 
reappears when you make another selection.

To select the unselected parts of an image:

Choose Select > Inverse. 

You might use this option to select an object 
placed against a solid-colored background. For 

example, you could first select the background using 
the magic wand tool and then invert the selection. 

Adjusting selections manually

You can use the selection tools to add to or 
subtract from existing pixel selections. 

Before manually adding to or subtracting from a 
selection, set the feather and anti-aliased values in 
the options bar to the same settings used for the 
original selection. (See “Softening the edges of a 
selection” on page 124.)

To add to a selection or select an additional area:

1 Make a selection.

2 Using any selection tool, do one of the 
following:

• Hold down Shift (a plus sign appears next to the 
pointer), and drag to add another selection.

• Select the Add to Selection option (icon) in the 
options bar, and drag.

To subtract from a selection:

1 Make a selection.

2 Using any selection tool, do one of the 
following:

• Hold down Alt (Windows) or Option (Mac OS) 
(a minus sign appears next to the pointer), and 
drag to add another selection.

• Select the Subtract from Selection option (icon) 
in the options bar, and drag.

To select only an area intersected by other selections:

1 Make a selection.

2 Using any selection tool, do one of the 
following:

• Hold down Alt+Shift (Windows) or 
Option+Shift (Mac OS) (a cross appears next to 
the pointer), and drag over the portion of the 
original selection that you want to select.
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• Select the Restrict Selection option (icon) in the 
options bar, and drag.

Adjusting selections numerically

You can use commands in the Select menu to 
increase or decrease the pixels in an existing 
selection and to clean up stray pixels left inside or 
outside a color-based selection.

To expand or contract a selection by a specific 
number of pixels:

1 Choose Select > Modify > Expand or Contract. 

2 For Expand By or Contract By, enter a pixel 
value between 1 and 16, and click OK.

The border is increased or decreased by the 
specified number of pixels. Any portion of the 
selection border running along the image’s edge is 
unaffected.

To frame an existing selection with a new selection:

1 Use a selection tool to make a selection.

2 Choose Select > Modify > Border. 

3 Enter a value between 1 and 64 pixels for the 
border width of the new selection, and click OK. 

The new selection frames the original selected 
area.

The Border command always creates an anti-
aliased selection. (See “Softening the edges of a 
selection” on page 124.) To paint a hard-edged 
border around a selection, use the Stroke 
command. (See “Filling and stroking selections 
and layers” on page 191.)

To expand a selection to include areas with similar 
color:

Do one of the following:

• (Photoshop) Choose Select > Grow to include 
adjacent pixels falling within the tolerance range 
specified in the magic wand options. 

• Choose Select > Similar to include pixels 
throughout the image, not just adjacent ones, 
falling within the tolerance range. 

To increase the selection in increments, choose 
either command more than once.

Note: You cannot use the Grow and Similar 
commands on images that are in bitmap mode.

To clean up stray pixels left inside or outside a color-
based selection:

1 Choose Select > Modify > Smooth. 

2 For Sample Radius, enter a pixel value between 
1 and 16, and click OK. 

Photoshop or ImageReady checks around each 
selected pixel to find any unselected pixels falling 
within the specified range. For example, if you 
enter 16 for the sample radius, the program uses 
each pixel as the center of a 33-by-33-pixel area (16 
pixels in the horizontal and vertical directions). If 
most pixels in the range are selected, any 
unselected pixels are added to the selection. If 
most pixels are unselected, any selected pixels are 
removed from the selection.

Note: The relationship between physical distance 
and pixel distance depends on the resolution of the 
image. For example, 5 pixels is a longer distance in a 
72-ppi image than in a 300-ppi image. (See “About 
image size and resolution” on page 21.)
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Softening the edges of a 
selection
You can smooth the hard edges of a selection by 
anti-aliasing and by feathering.

Anti-aliasing Smooths the jagged edges of a 
selection by softening the color transition between 
edge pixels and background pixels. Since only the 
edge pixels change, no detail is lost. Anti-aliasing is 
useful when cutting, copying, and pasting selec-
tions to create composite images. 

Anti-aliasing is available for the lasso, polygon 
lasso, magnetic lasso, rounded rectangle marquee, 
elliptical marquee, and magic wand tools. (Select a 
tool to display its options bar.) You must specify 
this option before using these tools. Once a 
selection is made, you cannot add anti-aliasing. 

Feathering Blurs edges by building a transition 
boundary between the selection and its 
surrounding pixels. This blurring can cause some 
loss of detail at the edge of the selection.

You can define feathering for the marquee, lasso, 
polygon lasso, or magnetic lasso tool as you use the 
tool, or you can add feathering to an existing 
selection. Feathering effects become apparent 
when you move, cut, or copy the selection.

To use anti-aliasing:

1 Select the lasso, polygon lasso, magnetic lasso, 
rounded rectangle marquee, elliptical marquee, or 
magic wand tool.

2 Select Anti-aliased in the options bar. 

To define a feathered edge for a selection tool:

1 Select any of the lasso or marquee tools.

2 Enter a Feather value in the options bar. This 
value defines the width of the feathered edge and 
can range from 1 to 250 pixels.

To define a feathered edge for an existing selection:

1 Choose Select > Feather.

2 Enter a value for the Feather Radius, and 
click OK.

Note: A small selection made with a large feather 
radius may be so faint its edges are invisible and thus 
not selectable. If a message appears stating “No pixels 
are more than 50% selected,” either decrease the 
feather radius or increase the selection’s size.

A. Original selection B. Feather: 0 C. Feather: 10
D. Feather: 30

A

C

B

D
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Selecting paths and vector 
objects (Photoshop)
You can select paths and vector objects by clicking 
with the path component selection tool or the 
direct selection tool. <<may need to add something 
about layer clipping path, the proposed new name 
for vector mask>>

Selecting a path or segment displays all of the 
anchor points on the selected portion, including 
any direction lines and direction points if the 
selected segment is curved. Direction points 
appear as filled circles, selected anchor points as 
filled squares, and unselected anchor points as 
hollow squares.

To select a path or vector object:

1 Select the path name in the Paths palette, or 
select the layer containing the vector object in the 
Layers palette. 

2 Do one of the following:

• To select the entire path or subpath, select the 
path component selection tool (icon), and click 
anywhere inside the path. If the path consists of 
several subpaths, only the subpath under the 
pointer is selected.

To display the bounding box along with the 
selected path, select Show Bounding Box in the 
options bar.

• To select a segment of the path, select the direct 
selection tool ( ), and click one of the segment’s 
anchor points or drag a marquee over part of the 
segment. <<Currently you have click where an 
anchor point is, even though you can’t see it. I 
hope this will change. (You used to be able to click 
anywhere on the segment.) Check again after 
112.>>

Marquee-drag to select segments.

When the direct selection tool is selected, you 
can select the entire path or subpath by holding 

down Alt (Windows) or Option (Mac OS) and 
clicking inside the path.

3 To add selections, select the path component 
selection tool or the direct selection tool, then hold 
down Shift while selecting additional paths or 
segments.

To activate the direct selection tool when any 
other tool is selected, position the pointer over 

an anchor point, and press Ctrl (Windows) or 
Command (Mac OS).
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To add, subtract, restrict, or invert the filled areas in 
selections:

1 Using the path component selection tool, 
choose one of the following options in the options 
bar, then drag a marquee to select existing path 
areas. <<verify later than bld 112: effects fill of selec-
tions, rather than which anchor pts or objects are 
selected. ED: leave with caps or change to 
lowercase?>>

• Add to Path Area adds the area in the new 
selection.

• Subtract from Path Area removes the 
overlapping area in a new selection from the 
existing path selection.

• Restrict Path Area, restricts the area to the 
overlapped range of the new selection and the 
existing path selection.

• Invert Path Area, inverts the overlap area of the 
new path selection within the new selection.

Drawing paths for precise 
selections (Photoshop)
A path is any line or shape you draw using the pen, 
magnetic pen, freeform pen or the shape tools (the 
rectangle, ellipse, polygon, line, or custom shape 
tool). Paths provide an effective way to draw 
precise selection borders. Unlike the bitmap 
shapes drawn by the pencil or other painting tools, 
paths are vector objects that contain no pixels. As 
a result, with the exception of clipping paths, paths 
remain separate from the bitmap image and do 
not print. (See “About bitmap images and vector 
objects” on page 19.) You can also use the pen 
tools to create a vector mask. (See “Adding layer 
masks” on page 239.)

The pen tool lets you create straight lines and 
smooth flowing curves with greater precision 

than is possible with the freeform pen or magnetic 
pen tool. For most users, the pen tool provides the 
best control and greatest accuracy for drawing.

Once you have created a path, you can save it in the 
Paths palette, convert it to a selection border, or fill 
or stroke the path outline with color. In addition, 
you can convert a selection to a path. 

Because they take up less disk space than pixel-
based data, paths can be used for long-term 
storage of simple masks. Paths can also be used to 
clip sections of your image for export to an illus-
tration or page-layout application. (See “Using 
clipping paths” on page 395.)
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Using the Paths palette

The Paths palette lists the name of each saved path 
and displays a thumbnail of its contents. 
Decreasing the size of thumbnails or turning them 
off lets you view more paths at one time in the 
palette and can improve performance. To view a 
path, you must first select the path name in the 
Paths palette.

To display the Paths palette:

Choose Windows > Show Paths.

<<ART keep; Reshoot UI>>

A. Selected path B. Fill Path C. Stroke Path 
D. Make Selection E. Make Work Path F. New Path

To select or deselect a path in the palette:

Do one of the following:

• To select a path, click the path name in the Paths 
palette. Only one path can be selected at a time.

• To deselect a path, click in the blank area of the 
Paths palette, or choose Turn Off Path from the 
Paths palette menu.

To change the size of path thumbnails:

1 Choose Palette Options from the Paths 
palette menu.

2 Select a size, or select None to turn off the 
display of thumbnails. 

To change a path’s stacking order:

1 Select the path in the Paths palette.

2 Drag the path up or down in the Paths palette. 
When the solid line appears in the desired 
location, release the mouse button.

To show or hide a path:

Select the path name in the Paths palette, and 
choose View > Show Path or View > Hide Path to 
toggle the command.

Creating, saving, and deleting paths

Paths can be created in two ways:

• You can create a new path in the Paths palette 
and then begin drawing. The path contents are 
saved automatically. 

• You can select a pen or shape tool, choose the 
path option in the options bar and begin drawing. 
If no path name is selected, the new path appears 
as a temporary work path in the Paths palette. You 
must save the work path to avoid losing its 
contents. If you deselect the work path without 
saving and then start drawing again, a new work 
path will replace the first one. 

BA C D E F
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Paths saved with an image appear when you open 
it again. In Windows, the Photoshop, JPEG, DCS, 
EPS, PDF, and TIFF formats support paths. In Mac 
OS, all available file formats (except GIF89a 
Export) support paths.

To create a new path in the Paths palette:

Do one of the following:

• To create a path without naming it, click the New 
Path button ( ) at the bottom of the Paths palette. 

• To create and name a path, make sure no work 
path is selected. Choose New Path from the Paths 
palette menu, or Alt-click (Windows) or Option-
click (Mac OS) the New Path button ( ) at the 
bottom of the palette. Enter a name for the path in 
the New Path dialog box, and click OK.

To save a work path:

Do one of the following:

• To save without renaming, drag the Work Path 
name to the New Path button at the bottom of the 
Paths palette.

• To save and rename, choose Save Path from the 
Paths palette menu, enter a new path name, and 
click OK.

To rename a saved path:

1 Double-click the path’s name in the Paths 
palette. 

2 Enter a new name in the Rename Path dialog 
box, and click OK.

To delete a path:

1 Select the path name in the Paths palette.

2 Do one of the following:

• Drag the path to the trash button at the bottom 
of the Paths palette.

• Choose Delete Path from the Paths palette 
menu.

• Click the trash button at the bottom of the Paths 
palette, and click Yes. 

To delete a path without being asked to 
confirm, Alt-click (Windows) or Option-click 

(Mac OS) the trash button at the bottom of the Paths 
palette.

About anchor points, direction lines, and 
direction points

A path consists of one or more straight or curved 
segments. Anchor points mark the endpoints of the 
path segments. On curved segments, each selected 
anchor point displays one or two direction lines, 
ending in direction points. The positions of 
direction lines and points determine the size and 
shape of a curved segment. Moving these elements 
reshapes the curves in a path.

A. Curved segment B. Direction point
C. Anchor point D. Direction line

B

C

D

A
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A path can be closed, with no beginning or end (for 
example, a circle), or open, with distinct endpoints 
(for example, a wavy line). 

Closed and open paths 
A. Selected line segment B. Unselected anchor point 
C. Selected anchor point D. Selected endpoint

Smooth curves are connected by anchor points 
called smooth points. Sharply curved paths are 
connected by corner points. 

Smooth point and corner point

When you move a direction line on a smooth 
point, the curved segments on both sides of the 
point adjust simultaneously. By comparison, when 
you move a direction line on a corner point, only 
the curve on the same side of the point as the 
direction line is adjusted. 

Adjusting smooth point and corner point

About subpaths

A path does not have to be all one connected series 
of segments. It can contain more than one distinct 
and separate subpath.

<<ART keep; reshoot UI, reword caption>>

Original path, and with subpath added

A B C D
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Drawing with the freeform pen tool

The freeform pen tool lets you create paths or 
vector masks as if you were drawing with a pencil 
on paper. Anchor points are added to the path 
automatically as you draw. You do not determine 
where the points are positioned, though you can 
adjust them once the path is complete. 
(See “Adjusting paths (Photoshop)” on page 135.) 

To draw with the freeform pen tool:

1 Select the freeform pen tool ( ).

2 In the options bar, select shape layer (icon) to 
create a vector mask or work path (icon) to create 
a path. (See “Creating shape layers or paths” on 
page 134.) <<xref destination?>>

3 For Curve Tolerance, enter a value between 0.5 
and 10.0. This option controls how sensitive the 
final path is to the movement of your mouse or 
stylus. A higher Curve Tolerance value results in a 
simpler path with fewer anchor points.

4 Drag the pointer in the image. As you drag, a 
path trails behind the pointer. When you release 
the mouse, a work path is created.

5 To continue the existing freehand path, position 
the freeform pen pointer on an endpoint of the 
path, and drag.

6 To complete the path, release the mouse. To 
create a closed path, drag over the initial point of 
the path (a circle appears next to the pointer when 
it is aligned), and release the mouse.

See “About anchor points, direction lines, and 
direction points” on page 128 for more on closed 
and open paths.

Drawing with the magnetic pen tool

The magnetic pen tool lets you draw a path that 
snaps to the edges of defined areas in your image. 
You can define the range and sensitivity of the 
snapping behavior, as well as the complexity of the 
resulting path. The magnetic pen and magnetic 
lasso tools share many of the same options.

To draw with the magnetic pen tool:

1 Select the magnetic pen tool ( ).

2 Specify tool options. (See “Specifying options 
for the magnetic pen tool” on page 131.)

3 Click in the image to set the first fastening point.

4 To draw a freehand segment, move the pointer 
along the edge you want to trace. (You can also 
drag with the mouse button depressed.) 

The most recent segment of the border remains 
active. As you move the pointer, the active segment 
snaps to the strongest edge in the image, 
connecting the pointer to the last fastening point. 
Periodically, the magnetic pen tool adds fastening 
points to the border to anchor previous sections.

5 If the border doesn’t snap to the desired edge, 
click once to add a fastening point manually, to 
keep the border from moving. Continue to trace 
the edge and add fastening points as needed.

6 To turn off magnetic properties temporarily, do 
one of the following:

• Hold down Alt (Windows) or Option (Mac OS), 
and drag with the mouse button depressed to draw 
a freehand path.

• Hold down Alt (Windows) or Option (Mac OS), 
and click to draw straight segments.
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7 Complete the path:

• Press Enter or Return to end an open path.

• Double-click to close the path with a magnetic 
segment.

• Hold down Alt (Windows) or Option (Mac OS), 
and double-click to close the path with a straight 
segment.

8 As you continue to draw, in the options bar, 
specify a path area option. You can create a new 
path, add to, subtract from, or restrict the path 
area.

See “About anchor points, direction lines, and 
direction points” on page 128 for more on closed 
and open paths.

Creating a shape or a path on a layer

Before you start drawing, you need to specify 
whether you are creating a rasterized shape on the 
current layer, a new layer with a vector mask, or a 
new path. You use the pen tool, magnetic pen tool, 
freeform pen tool or the shape tools (rectangle, 
ellipse, polygon, line, or custom shape tool) to 
create either a new layer with a vector shape or a 
path. The pen tools, along with the shape tools, 
can then be used to edit the vector shape or path. 
You can also use the shape tools to create a 
rasterized shape on the current layer.

<<ED: perhaps move this elsewhere? Add fill 
region to head?>>

To specify a fill region, vector layer or path:

1 If needed, select the pen tool ( ), magnetic pen 
tool ( ), freeform pen tool ( ), rectangle tool 
(icon), ellipse tool (icon), polygon tool (icon), line 
tool (icon) or custom shape tool (icon).

2 To create a vector shape, select shape layer 
(icon) in the options bar. The new layer is created 
above the currently selected layer once you click to 
start creating the vector shape.

3 To create a path, select work path (icon) in the 
options bar. The path is created in the current 
layer.

4 To create a rasterized shape using the shape 
tools, select fill region (icon) in the options bar. A 
rasterized shape is created in the current layer. 

5 When you are finished creating the shape or 
path, click Dismiss or press Enter or Return to 
dismiss the editing tools.

Specifying options for the magnetic pen 
tool

You can specify how the magnetic pen tool 
responds to movements of the mouse or stylus, 
how frequently anchor points are set, and whether 
you are creating a shape layer or editing a path.

To specify magnetic pen tool options:

1 If needed, select the magnetic pen tool.

2 Select the shape layer (icon) to create a layer, or 
select the work path (icon) to create a path. 
(See “Creating shape layers or paths” on 
page 134.) <<xref destination?>>
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3 For Curve Tolerance, enter a value between 0.5 
and 10.0. This option controls how sensitive the 
final path is to the movement of your mouse or 
stylus. A higher tolerance results in a simpler path 
with fewer anchor points.

4 To specify a detection width, enter a pixel value 
between 1 and 40 for Edge Tolerance. The 
magnetic pen only detects edges within the 
specified distance from the pointer.

While creating a path, press [to decrease the 
magnetic pen width by 1 pixel; press] to 

increase the pen width by 1 pixel.

5 To specify the rate at which the pen sets anchor 
points, enter a value between 0 and 100 for 
Frequency. A higher value anchors the path in 
place more quickly. 

6 If you are working with a stylus tablet, select or 
deselect the Stylus Pressure option. When the 
option is selected, an increase in stylus pressure 
will cause the edge tolerance to narrow.

7 To automatically add or delete anchor points 
while you are creating a path, select or deselect the 
Auto Add/Delete option. 

8 If you are creating a shape layer, specify a mode 
for the layer. (See “Specifying layer blending 
modes” on page 236.)

Drawing straight paths with the pen tool

The pen tool lets you draw paths with greater 
precision that you can with the freehand or 
magnetic pen tool. The simplest path you can 
draw with the pen tool is a straight line, made by 
clicking to create anchor points. You can draw a 
path or draw straight lines used to create a vector 
mask.

To draw straight paths with the pen tool: 

1 Select the pen tool ( ). 

2 Select shape layer (icon) to create a layer, or 
select work path (icon) to create a path. 
(See “Creating shape layers or paths” on 
page 134.) <<xref destination?>>

3 If you want to preview path segments as you 
draw, select Rubber Band in the options bar. After 
you define at least one anchor point for a path, 
Photoshop will display the next proposed segment 
as you move the pointer in the image. The segment 
won’t become permanent until you click.

4 Position the pen pointer where you want the 
straight line to begin, and click to define the first 
anchor point. The anchor point remains selected 
(solid) until you define the next point.

5 Click again where you want the first segment of 
the straight line path to end. Hold down Shift as 
you click to constrain the angle of the segment to a 
multiple of 45°.

6 Continue clicking to set anchor points for 
additional straight segments. The last anchor 
point is always a solid square, indicating it is 
selected. Previously defined anchor points become 
hollow squares as you add further anchor points.
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7 Complete the path:

• To end an open path, click the pen tool in the 
toolbox. Or hold down the Ctrl key (Windows) or 
Command key (Mac OS), and then click anywhere 
away from the path.

• To close a path, position the pen pointer over the 
first anchor point. A small loop appears next to the 
pen tip when it is positioned correctly. Click to 
close the path.

See “About anchor points, direction lines, and 
direction points” on page 128 for more on closed 
and open paths.

Drawing curved paths

You create curves by dragging the pen tool in the 
direction you want the curve to go.

Note: Before you draw curves with the pen tool, it is 
important to understand how paths are constructed. 
(See “About anchor points, direction lines, and 
direction points” on page 128.)

To draw a curved path: 

1 Select the pen tool ( ).

2 Specify whether you are creating a layer or a 
path. (See “Creating a shape or a path on a layer” 
on page 131.)

3 If you want to preview path segments as you 
draw, select Rubber Band in the options bar. After 
you define at least one anchor point for a path, 
Photoshop will display the next proposed segment 
as you move the pointer in the image. The segment 
won’t become permanent until you click.

4 Position the pointer where you want the curve 
to begin. Hold down the mouse button. The first 
anchor point appears, and the pointer changes to 
an arrowhead.

5 Drag in the direction you want the curve 
segment to be drawn. As you drag, the pointer 
leads one of two direction points. Hold down the 
Shift key to constrain the tool to multiples of 45°. 

The length and slope of the direction line 
determine the shape of the curve segment. You can 
adjust one or both sides of the direction line later.

Drag in direction of curve to set first anchor point. Drag in the 
opposite direction to complete the curve segment.

6 Position the pointer where you want the curve 
segment to end, press the mouse button, and drag 
in the opposite direction to complete the segment. 

7 Do one of the following:
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• To draw the next segment of a smooth curve, 
position the pointer where you want the next 
segment to end, and drag away from the curve.

Drag away from curve to 
create the next segment.

• To change the direction of the curve sharply, 
release the mouse button, press Alt (Windows) or 
Option (Mac OS), and then drag the direction 
point in the direction of the curve. Release Alt 
(Windows) or Option (Mac OS) and the mouse 
button, reposition the pointer where you want the 
segment to end, and drag in the opposite direction 
to complete the curve segment.

Press Alt/Option, and drag direction point toward 
the curve. Release the key, and drag in opposite direction.

8 Complete the path:

• To end an open path, click the pen tool in the 
toolbox. Or hold down the Ctrl key (Windows) or 
Command key (Mac OS), and then click anywhere 
away from the path.

• To close the path, position the pointer over the 
first anchor point. A small loop appears next to the 
pointer when it is positioned correctly. Click or 
drag to close the path.

See “About anchor points, direction lines, and 
direction points” on page 128 for more on closed 
and open paths.

Tips for drawing curves

<<This section could be subordinate to the 
section on drawing curves.>>

Keep these guidelines in mind when drawing 
curves:

• Always drag the first direction point in the 
direction of the bump of the curve, and drag the 
second direction point in the opposite direction to 
create a single curve. Dragging both direction 
points in the same direction creates an “S” curve.

Drag in opposite direction to create a smooth curve. Drag in 
same direction to create an “S” curve. 

• When drawing a series of smooth curves, draw 
one curve at a time, placing anchor points at the 
beginning and end of each curve, not at the tip of 
the curve. Use as few anchor points as possible, 
placing them as far apart as possible.
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Adjusting paths (Photoshop)
After you have drawn a path, you can move, 
reshape, or erase individual segments in it, and 
you can add or delete anchor points to change the 
configuration of segments. 

Note: You can also apply a transformation, such as 
scaling, rotating, flipping, or distorting, to a path or 
segment. See “Applying a transformation” on 
page 162.

<<Might want to refer to earlier section on 
selecting paths and vectors.>>

Moving, reshaping, and deleting 
segments

You can move, reshape, or delete one or more 
segments on a path.

To move a straight segment:

1 Select the direct selection tool ( ), and select the 
segment you want to adjust. To adjust the angle or 
length of the segment, select an anchor point.

2 Drag the selected segment to its new position.

To move a curved segment:

1 Select the direct selection tool ( ), and select the 
points or segments you want to move. Be sure to 
select both points anchoring the segment.

2 Drag the selected anchor points or segments to 
new positions. Hold down Shift as you drag to 
constrain the movement to multiples of 45°.

Select points anchoring curve. Then drag to move curve.

To reshape a curved segment:

1 Select the direct selection tool ( ), and select the 
curved segment you want to adjust. Direction lines 
appear for that segment.

2 Adjust the curve:

• To adjust the position of the segment, drag the 
segment.

Click to select curve segment. Then drag to adjust.
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• To adjust the shape of the segment on either side 
of a selected anchor point, drag the anchor point 
or the direction point. Hold down Shift as you 
drag to constrain movement to multiples of 45°.

Drag the anchor point, or drag the direction point.

To delete a segment:

1 Select the direct selection tool ( ), and select the 
segment you want to delete.

2 Press Backspace (Windows) or Delete (Mac OS) 
to delete the selected segment. Pressing Backspace 
or Delete again erases the rest of the subpath. 

<<The way this tool works now, you can’t select a 
single segment--only the whole path. So this 
deletes the path, which can’t be right. Check 
back.>>

Moving, reshaping, copying, and deleting 
paths

You can reposition a path anywhere within an 
image. You can copy paths within an image or 
between two Photoshop images. Using the path 
component selection tool, you can merge 
overlapping paths into a single path.

You can also use the Copy and Paste commands to 
duplicate paths, between a Photoshop image and 
an image in another application, such as Adobe 
Illustrator, Adobe Streamline™, or Adobe Dimen-
sions®. 

To move a path:

1 Select the path name in the Paths palette, and 
use the direct selection tool ( ) to select the path 
in the image. 

2 Drag the path to its new location.

If you move any part of a path beyond the canvas 
boundaries, the hidden part of the path is still 
available.

Note: If you drag a path so that the move pointer is 
over another open image, the path will be copied to 
that image.

To reshape a path:

1 Select the path name in the Paths palette, and 
use the direct selection tool to select an anchor 
point in the path. 

2 Drag the point or its handles to a new location. 
See “Adding, deleting, and converting anchor 
points” on page 138.

To merge overlapping paths:

1 Using the path component selection tool 
(<<icon>>), marquee-drag to select the 
overlapping paths you want to merge.

2 Click Simplify in the options bar to create a 
single shape from the overlapping shapes.
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To copy a path:

Do any of the following:

• To copy a path as you move it, select the path 
name in the Paths palette, and use the direct 
selection tool to select the path in the image. Hold 
down Alt (Windows) or Option (Mac OS) as you 
drag the path. 

• To copy a path without renaming, drag the path 
in the Paths palette to the New Path button ( ) at 
the bottom of the palette.

• To copy and rename a path, Alt-drag (Windows) 
or Option-drag (Mac OS) the path in the Paths 
palette to the New Path button at the 
bottom of the palette. Or select the path to copy, 
and choose Duplicate Path from the Paths palette 
menu. Enter a new name for the path, and 
click OK.

To copy paths between two Adobe Photoshop files:

1 Open both images. 

2 Use the direct selection tool to select the path in 
the source image you want to copy.

3 Copy the path:

• Drag the path from the source image to the 
destination image. The path is copied to the active 
path in the Paths palette.

• Drag the path from the source image’s Paths 
palette into the destination image. The path is 
copied to the active path in the Paths palette. 

• In the source image, choose Edit > Copy to copy 
the path, and in the destination image choose 
Edit > Paste. 

Aligning and distributing paths and 
vector objects

You can both align and distribute paths and vector 
objects. For example, you can align the left edges 
of several vector objects or paths and distribute 
their horizontal centers. 

To align or distribute paths or vector objects:

1 Using the path component selection tool (icon), 
marquee-drag to select the paths or vector objects 
you want to align, then select one of the alignment 
options from the options bar.

• Top to align the top edges on the selected objects.

• Vertical Center to align the vertical centers of the 
selected objects.

• Bottom to align the bottom edges on the selected 
objects.

• Left to align the left edges on the selected objects.

• Horizontal Center to align the horizontal centers 
of the selected objects.

• Right to align the right edges on the selected 
objects.

2 Select the paths or objects you want to 
distribute, then select one of the distribute options 
from the options bar.

• Top to distribute the top edges on the selected 
objects.

• Vertical Center to distribute the vertical centers 
of the selected objects.

• Bottom to distribute the bottom edges on the 
selected objects.
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• Left to distribute the left edges on the selected 
objects.

• Horizontal Center to distribute the horizontal 
centers of the selected objects.

• Right to align the right edges on the selected 
objects.

Adding, deleting, and converting anchor 
points

The add anchor point and delete anchor point 
tools let you add and delete anchor points from a 
path. The convert direction point tool lets you 
convert a smooth curve to a sharp curve or to a 
straight segment, and vice versa. 

To add an anchor point:

1 Select the add anchor point tool ( ), and 
position the pointer on the path where you want 
the anchor point added (a plus sign appears next 
to the pointer).

2 Do one of the following:

• Click to add an anchor point without changing 
the shape of the segment. 

• To add an anchor point and change the shape of 
the segment, drag to define direction lines for the 
anchor point.

To delete an anchor point:

1 Select the delete anchor point tool ( ), and 
position the pointer on the anchor point you want 
deleted (a minus sign appears next to the pointer).

2 Delete the anchor point:

• Click the anchor point to delete it and to reshape 
the path to fit the remaining anchor points.

• Drag the anchor point to delete it and to change 
the shape of the segment.

To convert between a smooth point and a corner 
point:

1 Select the convert anchor point tool ( ), and 
position the pointer over the anchor point you 
want changed. 

To activate the convert anchor point 
tool while the direct selection tool is selected, 

position the pointer over an anchor point and press 
Ctrl+Alt (Windows) or Command+Option (Mac 
OS).

2 Convert the point:

• To convert a smooth point to a corner point 
without direction lines, click the smooth anchor 
point. 

• To convert a smooth point to a corner point with 
direction lines, make sure the direction lines are 
visible. Then drag a direction point to break the 
pair of direction lines.

Drag direction point to break direction lines.
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• To convert a corner point to a smooth point, 
drag away from the corner point to make direction 
lines appear.

Click to create a corner point. Drag to create a 
smooth point.

Adding color to paths
You can add color values to a path by filling or 
stroking it. 

Filling paths with color

The Fill Path command lets you fill a path with a 
specified color, a state of the image, or a pattern. 

Important: When you fill a path, the color values 
appear on the active layer. Make sure the layer you 
want is active before beginning.

To fill a path using the current Fill Path settings:

1 Select the path in the Paths palette.

2 Click the Fill Path button ( ) at the bottom of 
the Paths palette. 

To fill a path and specify options:

1 Select the path in the Paths palette.

2 Fill the path:

• Alt-click (Windows) or Option-click (Mac OS) 
the Fill Path button at the bottom of the Paths 
palette.

• Choose Fill Path from the Paths palette menu. If 
the selected path is a subpath, this command 
changes to Fill Subpath.

3 For Use, choose the contents for the fill. 
(See “Filling and stroking selections and layers” on 
page 191.)

4 Specify an opacity for the fill. To make the fill 
more transparent, use a low percentage. A setting 
of 100% makes the fill opaque.

5 Choose a blending mode for the fill. 
(See “Selecting a blending mode” on page 188.)

The Mode list includes a Clear mode that lets you 
erase to transparency. You must be working in a 
layer other than the background to use this option.

6 Select Preserve Transparency to limit the fill to 
layer areas that contain pixels. (See “Preserving a 
layer’s transparency” on page 232.)

7 Select a Rendering option:

• Feather Radius to define how far inside and 
outside the selection border the feather edge 
extends. Enter a value in pixels.

• Anti-aliased to create a finer transition between 
the pixels in the selection and the surrounding 
pixels by partially filling the edge pixels of the 
selection. 

See “Softening the edges of a selection” on 
page 124 for more on these options.

8 Click OK.
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Stroking to paint a path border

The Fill Path command lets you paint the border 
of a path. 

Important: When you stroke a path, the color values 
appear on the active layer. Make sure the layer you 
want is active before beginning.

To stroke a path using the current Stroke Path 
settings:

1 Select the path in the Paths palette.

2 Click the Stroke Path button ( ) at the bottom 
of the Paths palette. Each click of the Stroke Path 
button builds up the thickness of the stroke.

To stroke a path and specify options:

1 Select the path in the Paths palette. 

2 Select the painting or editing tool you want 
to use to stroke the path. Set the tool options, and 
specify a brush. You must specify the tool’s settings 
before opening the Stroke Path dialog 
box.(See “Retouching images” on page 169, 
and “Using the painting tools” on page 173, for 
information on specific tool settings.) 

3 Stroke the path:

• Alt-click (Windows) or Option-click (Mac OS) 
the Stroke Path button ( ) at the bottom of the 
Paths palette.

• Choose Stroke Path from the Paths palette 
menu. If the selected path is a subpath, this 
command changes to Stroke Subpath.

4 If you did not select a tool in step 2, choose a 
tool from the Stroke Path dialog box. 

5 Click OK. 

Converting between paths and 
selection borders
Because of their smooth outlines, paths can be 
converted into precise selection borders. You also 
can convert selection borders into paths, using the 
direct selection tool for fine-tuning. 

Converting paths to selection borders

You can define any closed path as a selection 
border. A closed path that overlaps a selected area 
can be added to, subtracted from, or combined 
with the current selection. 

To convert a path to a selection border using the 
current Make Selection settings:

1 Select the path in the Paths palette.

2 Convert the path:

• Click the Make Selection button ( ) at the 
bottom of the Paths palette.

• Ctrl-click (Windows) or Command-click 
(Mac OS) the path thumbnail in the Paths palette.

To convert a path to a selection border and specify 
settings:

1 To combine the path with a selection, first make 
the selection using a selection tool.

2 Select the path in the Paths palette.

3 Start converting the path:

• Alt-click (Windows) or Option-click (Mac OS) 
the Make Selection button ( ) at the bottom of 
the Paths palette.

• Choose Make Selection from the Paths 
palette menu. 
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4 Select a Rendering option:

• Feather Radius to define how far inside and 
outside the selection border the feather edge 
extends. Enter a value in pixels. 

• Anti-aliased to create a finer transition between 
the pixels in the selection and the surrounding 
pixels. Make sure the Feather Radius is set to 0. 

See “Softening the edges of a selection” on 
page 124 for more on these options.

5 Select an Operation option:

• New Selection to select only the area defined by 
the path.

• Add to Selection to add the area defined by the 
path to the original selection. 

• Subtract from Selection to remove the area 
defined by the path from the original selection. 

• Intersect with Selection to select the area 
common to both the path and the original 
selection. If the path and selection do not overlap, 
nothing is selected. 

6 Click OK.

Converting selection borders to paths

Any selection made with a selection tool can be 
defined as a path. 

The Make Work Path command eliminates any 
feathering applied to the selection. It can also alter 
the shape of the selection, depending on the 
complexity of the path and the tolerance value you 
choose in the Make Work Path dialog box.

To convert a selection to a path using the current 
Make Work Path tolerance:

1 Select the path in the Paths palette.

2 Click the Make Work Path ( ) button at the 
bottom of the Paths palette.

To convert a selection to a path and specify tolerance:

1 Make the selection.

2 Start converting the selection:

• Alt-click (Windows) or Option-click (Mac OS) 
the Make Work Path ( ) button at the bottom 
of the Paths palette. 

• Choose Make Work Path from the Paths 
palette menu. 

3 Enter a Tolerance value.

Tolerance values can range from 0.5 to 10 pixels 
and determine how sensitive the Make Work Path 
command is to slight changes in the selection 
shape. The higher the tolerance value, the fewer 
the anchor points used to draw the path and the 
smoother the path. If you have problems printing 
the image, use a higher tolerance value. 
(See “Printing clipping paths” on page 396.)

4 Click OK. The converted selection appears as a 
work path at the bottom of the Paths palette.
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Chapter 7: Editing and Retouching

ou can edit and retouch images in many 
ways. For example, you can move and 
copy selections within and between 

images; scale, rotate, or flip selections or images; 
and sample part of an image and paint with it. You 
can use the History feature to go back to a previous 
state.

Keep in mind that pixels beyond the borders of the 
visible canvas cannot be edited or retouched. 
However, you can use the move tool or selection 
arrows to move these pixels back onto the visible 
canvas, you can modify or reposition them using 
any of the Transform commands, or you can 
increase the canvas size to incorporate them. 

Correcting mistakes
Most operations can be undone if you make a 
mistake. Alternatively, you can restore all or part of 
an image to its last saved version. But available 
memory may limit your ability to use these 
options.

For information on how to restore your image to 
how it looked during any point in the current work 
session, see “Reverting to any state of an image” on 
page 144.

To undo the last performed operation:

Choose Edit > Undo. 

If an operation can’t be undone, the command is 
dimmed and changes to Can’t Undo.

To free memory used by the Undo command, the 
History palette, or the Clipboard:

Choose Edit > Purge, and choose the item type or 
buffer you want to clear. If already empty, the item 
type or buffer is dimmed. 

Important: The Purge command permanently 
clears from memory the operation stored by the 
command or buffer, and cannot be undone. For 
example, choosing Edit > Purge > Histories deletes 
all history states from the History palette. Use the 
Purge command when information held in memory 
is so large, Photoshop cannot perform the next 
operation.

To reverse all changes made to the image since it was 
last saved:

Choose File > Revert.

To restore part of an image to its previously saved 
version (Photoshop):

Do one of the following:

• Use the history brush tool ( ) to paint with the 
selected state or snapshot on the History palette. 
(See “Painting with a state or snapshot of an image 
(Photoshop)” on page 148.)

• Use the eraser tool ( ) with the Erase to History 
option selected. (See “Using the eraser tool” on 
page 176.)

Y
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• Select the area you want to restore, and choose 
Edit > Fill. For Use, choose History, and click OK. 
(See “Filling and stroking selections and layers” on 
page 191.)

Note: To restore the image with a snapshot of the 
initial state of the document, make sure that the 
Automatically Create First Snapshot option is on.

Reverting to any state of an 
image
The History palette lets you jump to any recent 
state of the image created during the current 
working session. Each time you apply a change to 
an image, the new state of that image is added to 
the palette.

For example, if you select, paint, and rotate part of 
an image, each of those states is listed separately in 
the palette. You can then select any of these states, 
and the image will revert to how it looked when 
that change was first applied. You can then work 
from that state.

About the History palette

Note the following guidelines when using the 
History palette:

• Program-wide changes, such as changes to 
palettes, color settings, actions, and preferences, 
are not changes to a particular image and so are 
not added to the History palette.

• By default, the History palette lists the previous 
20 states. Older states are automatically deleted to 
free more memory for Photoshop. To keep a 
particular state throughout your work session, 
make a snapshot of the state. 

For more information on making snapshots, 
see “Making a snapshot of an image (Photoshop)” 
on page 147.

• Once you close and reopen the document, all 
states and snapshots from the last working session 
are cleared from the palette.

• By default, a snapshot of the initial state of the 
document is displayed at the top of the palette. 

• States are added from the top down. That is, the 
oldest state is at the top of the list, the most recent 
one at the bottom.

• Each state is listed with the name of the tool or 
command used to change the image.

• By default, selecting a state dims those below. 
This way you can easily see which changes will be 
discarded if you continue working from the 
selected state. (See the procedure on specifying 
history options “Setting history options 
(Photoshop)” on page 146.)

• By default, selecting a state and then changing 
the image eliminates all states that come after.

• If you select a state and then change the image, 
eliminating the states that came after, you can use 
the Undo command to undo the last change and 
restore the eliminated states. (See “Correcting 
mistakes” on page 143.)
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• By default, deleting a state deletes that state and 
those that came after it. If you choose the Allow 
Non-Linear History option, deleting a state deletes 
just that state.

<<Art: Reshoot UI>>

A. Sets the source for the history brush
B. Thumbnail of a snapshot
C. History state D. History state slider 
E. Create new document from current state button
F. Create new snapshot button G. trash button

Using the History palette

You can use the History palette to revert to a 
previous state of an image, to delete an image’s 
states, and in Photoshop, to create a document 
from a state or snapshot.

To display the History palette:

Choose Window > Show History.

To revert to a previous state of an image:

Do any of the following:

• Click the name of the state.

• Drag the slider at the left of the state up or down 
to a different state.

• (Photoshop) Choose Step Forward or Step 
Backward from the palette menu to move to the 
next or previous state.

• (Photoshop) Press Shift+Ctrl+Z (Windows) or 
Shift+Command+Z (Mac OS) to move to the 
next state.

• (Photoshop) Press Alt+Ctrl+Z (Windows) or 
Option+Command+Z (Mac OS) to move to the 
previous state.

To delete one or more states of the image 
(Photoshop):

Do one of the following:

• Click the name of the state, and choose Delete 
from the History palette menu to delete that 
change and those that came after it.

• Drag the state to the trash button ( ) to delete 
that change and those that came after it.

• Choose Clear History from the palette menu to 
delete the list of states from the History palette, 
without changing the image.

• Hold down Alt (Windows) or Option (Mac OS) 
and choose Clear History from the palette menu to 
purge the list of states from the History palette 
without changing the image. If you get a message 
that Photoshop is low on memory, purging states 
is useful, since the command deletes the states 
from the Undo buffer and frees up memory. This 
action cannot be undone.

• Choose Edit > Purge > Histories to purge the list 
of states from the History palette for all open 
documents. This action cannot be undone.

A
B

C

D

E F G
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To delete all of an image’s states (ImageReady):

Choose Clear Undo/Redo History from the 
History palette menu. This action cannot be 
undone.

To create a new document from the selected state or 
snapshot of the image (Photoshop):

Do one of the following:

• Drag a state or snapshot onto the New 
Document button ( ).

• Select a state or snapshot, and click the New 
Document button ( ).

• Select a state or snapshot, and choose New 
Document from the History palette menu.

The history list for the newly created document 
will be empty.

To save one or more snapshots or image states 
for use in a later editing session, create a new 

file for each state you’ll save and save each in a 
separate file. When you reopen your original file, also 
open the other saved files. You can drag each file’s 
initial snapshot to the original image and thus access 
the snapshots again from the original image’s 
History palette.

To replace an existing document with a selected state 
(Photoshop):

Drag the state onto the other document.

Setting history options (Photoshop)

You can specify the maximum number of items to 
include in the History palette and set other options 
that customize the way you work with the palette.

To set history options:

1 Choose History Options from the History 
palette menu.

2 Specify the options:

• For Maximum History Items, enter the 
maximum number of states that can be listed on 
the History palette.

Note: This number is also limited by the size of the 
image, the type of changes you make to it, and the 
amount of memory available to Photoshop.

• Select Automatically Create First Snapshot to 
automatically create a snapshot of the initial state 
of the image when the document is opened.

• Select Allow Non-Linear History to make 
changes to a selected state without deleting the 
states that come after. Normally, when you select a 
state and change the image, all states that come 
after the selected one are deleted. This enables the 
History palette to display a list of the editing steps 
in the order you made them. By recording states in 
a non-linear way you can select a state, make a 
change to the image, and delete just that state. 
The change will be inserted into the list of states, 
without deleting the states after it. This gives 
greater flexibility, but is less clearly organized.

3 Click OK.
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Making a snapshot of an image 
(Photoshop)

The Snapshot command lets you make a 
temporary copy (or snapshot) of any state of the 
image. The new snapshot is added to the list of 
snapshots at the top of the History palette. 
Selecting a snapshot lets you work from that 
version of the image. 

Important: Snapshots are not saved with the 
image—closing an image deletes its snapshots. Also, 
unless you select the Allow Non-Linear History 
option, selecting a snapshot and changing the image 
deletes all of the states currently listed in the History 
palette.

Snapshots let you do the following:

• Switch repeatedly between several states. By 
taking a temporary snapshot of a state, you can 
keep that state for the entire work session, even if 
the original state is deleted from the list of states in 
the History palette.

• Give a unique name to states to make them 
easier to identify.

• Experiment more freely. For example, you may 
want to compare two different techniques for 
achieving a similar effect. You can take a snapshot 
before and after trying the first technique. You can 
then select the first snapshot, try the second 
technique on it, and then compare snapshots of 
each technique.

• Take a snapshot before creating or applying an 
action. Then you can recover your work more 
easily if you decide later you don’t like the action. 
Each step in an action is added to the list of states 
on the History palette. An action with many steps 
could scroll the current states off the palette, so 
that you could not return to any of them. Using the 
Undo command let’s you undo only one step and 
state. By making a snapshot first, you can select 
and redisplay the pre-action image.

To create a snapshot:

1 Select a state.

2 Click the New Snapshot button ( ) on the 
History palette, or choose New Snapshot from the 
History palette menu.

3 Enter the name of the Snapshot in the Name 
text box.

4 For From, select the snapshot contents:

• Full Document to make a snapshot of all layers 
in the image at that state.

• Merged Layers to make a snapshot that merges 
all layers in the image at that state.

• Current Layer to make a snapshot of only the 
currently selected layer at that state.

5 Click OK.

To select a snapshot:

Do any of the following:

• Click the name of the snapshot.

• Drag the slider at the left of the snapshot up or 
down to a different snapshot.
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To delete a snapshot:

Do one of the following:

• Select the snapshot, and choose Delete from the 
palette menu.

• Select the snapshot, and click the trash 
button ( ).

• Drag the snapshot to the trash button ( ).

Painting with a state or snapshot of an 
image (Photoshop)

The history brush tool lets you paint a copy of one 
state or snapshot of an image into the current 
image window. This tool makes a copy, or sample, 
of the image and then paints with it.

For example, you might make a snapshot of a 
change you made with a painting tool or filter. 
After undoing the change to the image, you could 
use the history brush tool to apply the change 
selectively to areas of the image. Unless you select 
a merged snapshot, the history brush tool paints 
from a layer in the selected state to the same layer 
in another state.

The history brush tool works similarly to the clone 
stamp tool, but on any state or snapshot of the 
image, not just the current one. (See “Painting 
with a sample of an image” on page 167.)

To paint with a state or snapshot of an image:

1 Select the history brush tool ( ).

2 Specify the opacity and blending mode. (See 
“Setting options for painting and editing” on 
page 188.)

3 Choose a brush size. (See “Customizing the 
brushes set” on page 185.)

4 If desired, select Impressionist to paint with an 
“impressionistic” copy of the source state or 
snapshot. This option drags and smears the pixels 
as you paint.

5 In the History palette, click the left column of 
the state or snapshot to use as the source for the 
history brush tool.

6 Drag to paint with the history brush tool.

Duplicating images
You can duplicate an entire image (including all 
layers, layer masks, and channels) into available 
memory without saving to disk. In ImageReady, 
you can also duplicate optimized versions of an 
image.

Using duplicates in ImageReady lets you exper-
iment and then compare several versions of the 

optimized image to the original.

To duplicate an image (Photoshop):

1 Open the image you want to copy.

2 Choose Image > Duplicate.

3 Enter a name for the duplicated image.

4 To duplicate the image without layers, select 
Merged Layers Only.

5 Click OK.

To duplicate an image in Photoshop and 
automatically append the name “copy” to its 

filename, hold down Alt (Windows) or Option 
(Mac OS) when you choose Image > Duplicate.



149ADOBE PHOTOSHOP 6.0
User Guide

To duplicate an image (ImageReady):

1 Open the image you want to copy.

2 Do one of the following:

• To duplicate an original image, select the 
Original tab at the top of the image window. Hold 
down Alt (Windows) or Option (Mac OS) and 
drag the Original tab from the image window; or 
choose Image > Duplicate, name the duplicate, 
specify whether to flatten the layers, and click OK.

• To duplicate an optimized image, select the 
Optimized tab at the top of the image window. 
Then hold down Alt (Windows) or Option (Mac 
OS) and drag the Optimized tab from the image 
window; or choose Image > Duplicate Optimized, 
name the duplicate, and click OK.

Note: When you duplicate an image in Optimized, 
2-Up, or 4-Up view, the duplicate image appears in 
the Original view in the duplicate image window. If 
you want a duplicate optimized image to appear in 
the Optimized, 2-Up, or 4-Up view, duplicate the 
original image, and then select the Optimized, 2-Up, 
or 4-Up tab in the duplicate image window.

Using rulers, the measure tool, 
guides, and the grid
Rulers, the measure tool, guides, and the grid help 
you position images or elements precisely across 
the width or length of an image. <<monitor uber 
hide/show feature, may need to adjust this section>>

Note: You can also align and distribute parts of an 
image using the Layers palette. (See “Moving the 
contents of layers” on page 230.)

Using rulers

When visible, rulers appear along the top and left 
side of the active window. Markers in the ruler 
display the pointer’s position when you move it. 
Changing the ruler origin (the 0, 0 mark on the top 
and left rulers) lets you measure from a specific 
point on the image.The ruler origin also deter-
mines the grid’s point of origin.

To display or hide rulers:

Choose View > Show Rulers or Hide Rulers.

To change the rulers’ zero origin:

1 To snap the ruler origin to guidelines or 
gridlines (Photoshop), choose View > Show Rulers 
or View > Snap to Grid.

2 Position the pointer over the intersection of the 
rulers in the upper left corner of the window, and 
drag diagonally down onto the image. A set of 
cross hairs appears, marking the new origin on the 
rulers.

To make the ruler origin snap to the ruler ticks 
(Photoshop), hold down Shift as you drag. A set of 
cross hairs appears while you drag, marking the 
new origin on the rulers.

Note: To reset the ruler origin to its default value, 
double-click the upper left corner of the rulers.

To change the rulers’ settings (Photoshop):

1 Do one of the following:

• Double-click a ruler. 

• Choose Edit > Preferences > Units & Rulers.
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2 For Units, choose a unit of measurement.

Note: Changing the units on the Info palette changes 
the units on the rulers to match them.

3 For Width and Gutter, enter values for the 
column size. You also can change the units.

Some layout programs use the column width 
setting to specify the display of an image across 
columns. The Image Size and Canvas Size 
commands also use this setting. (See “Changing 
the print dimensions and resolution of an image 
(Photoshop)” on page 30 and “Changing the size 
of the work canvas” on page 42.)

4 For Point/Pica Size, choose from the following 
options:

• PostScript (72 points per inch) if you are 
printing to a PostScript device.

• Traditional to use printer’s 72.27 points per inch.

5 Click OK.

Using the measure tool (Photoshop)

The measure tool calculates the distance between 
any two points in the work area. When you 
measure from one point to another, a non-
printing line is drawn and the Info palette shows 
the following information:

• The starting location (X and Y).

• The horizontal (W) and vertical (H) distances 
traveled from the x and y axes.

• The total distance traveled (D).

• The angle measured relative to the axis (A).

• Optionally, set a second measuring line to create 
a protractor. This lets you measure angles 
separated from the x and y axes, and view two 
distances traveled (D1 and D2).

All measurements except the angle are calculated 
in the unit of measure currently set in the Units & 
Rulers preference dialog box. For information on 
setting the unit of measure, see “Using rulers” on 
page 149. For information on applying the values 
made by the measure tool to the Numeric 
Transform dialog box, see “Transforming numeri-
cally” on page 164.

To display an existing measuring line:

Select the measure tool ( ).

To measure between two points:

1 Select the measure tool ( ).

2 Drag from the starting point to the ending 
point. Hold down the Shift key to constrain the 
tool to multiples of 45°.

3 To create a protractor from an existing 
measuring line, Alt-drag (Windows) or Option-
drag (Mac OS) at an angle from one end of the 
measuring line. Hold down the Shift key to 
constrain the tool to multiples of 45°.

To edit a measuring line or protractor:

1 Select the measure tool ( ).

2 Do one of the following:

• To resize the line, drag one end of an existing 
measuring line. 

• To move the line, place the pointer on the line 
away from either endpoint and drag the line.
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• To remove the line, place the pointer on the line 
away from either endpoint and drag the line out of 
the image.

Using guides and the grid

Guides appear as lines that float over the entire 
image and do not print. You can move, remove, or 
lock a guide to avoid accidentally moving it. 

In Photoshop, a grid appears by default as 
nonprinting lines but can also be displayed as dots. 
The grid is useful for laying out elements symmet-
rically. 

<<monitor uber hide/show feature add xref to 
primary discussion>>

Guides and grids behave in similar ways:

• Selections, selection borders, and tools snap to a 
guide or the grid when dragged within 8 screen 
(not image) pixels. Guides also snap to the grid 
when moved. You can turn this feature on and off. 

• Guide spacing, along with guide and grid 
visibility and snapping, is specific to an image.

• Grid spacing, along with guide and grid color 
and style, is the same for all images. 

To show or hide guides:

Choose View > Show Guides.

To show or hide the grid (Photoshop):

Choose View > Show Grid.

<<uber hide xref here to chapter 1?>>

To place a guide:

1 If the rulers are not visible, choose View > Show 
Rulers.

Note: For the most accurate readings, view the image 
at 100% magnification or use the Info palette.

2 Create a guide:

• Drag from the horizontal ruler to create a 
horizontal guide.

• Hold down Alt (Windows) or Option (Mac OS), 
and drag from the vertical ruler to create a 
horizontal guide.

• Drag from the vertical ruler to create a vertical 
guide.

• Hold down Alt (Windows) or Option (Mac OS), 
and drag from the horizontal ruler to create a 
vertical guide.

The pointer changes to a double-headed arrow 
(icon) when you drag a guide.

To move a guide:

1 Select the move tool ( ), or hold down Ctrl 
(Windows) or Command (Mac OS) to activate the 
move tool.

2 Position the pointer over the guide (the pointer 
turns into a double-headed arrow).

3 Move the guide:

• Drag the guide to move it. 

• Change the guide from horizontal to vertical, or 
vice versa, by holding down Alt (Windows) or 
Option (Mac OS) as you click or drag the guide.
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• (Photoshop) Align the guide with the ruler ticks 
by holding down Shift as you drag the guide. The 
guide will snap to the grid if the grid is visible and 
View > Snap to Grid is selected.

To lock all guides:

Choose View > Lock Guides.

To remove guides from the image:

Do one of the following:

• To remove a single guide, drag the guide outside 
the image window.

• To remove all guides, choose View > Clear 
Guides.

To turn snapping to guides on or off:

Choose View > Snap to Guides.

To turn snapping to the grid on or off (Photoshop):

Choose View > Snap to Grid.

To set guide and grid preferences (Photoshop):

1 Choose Edit > Preferences > Guides & Grid.

2 For Color, choose a color for the guides, the 
grid, or both. If you choose Custom, click the color 
box, choose a color as described in “Using the 
Color palette” on page 196, and click OK.

3 For Style, choose a display option for guides or 
the grid, or both.

4 For Gridline Every, enter a value for the grid 
spacing. For Subdivisions, enter a value to 
subdivide the grid. 

If desired, change the units for this option. The 
Percent option creates a grid that divides the image 
up into even sections. For example, choosing 25 
for the Percent option creates an evenly divided 
4 by 4 grid.

5 Click OK.

Moving, copying, and pasting 
selections and layers
You can move or copy selections and layers within 
or between images—and also between images in 
other applications.

Moving selections and layers within an 
image

The move tool lets you drag a selection or layer to 
a new location in the image. With the Info palette 
open, you can track the exact distance of the move.

To specify move tool options:

1 Select the move tool ( ).

2 Select any of the following:

• Pixel Doubling (Photoshop) to speed the 
preview of the move tool’s effect by temporarily 
doubling the size of the pixels (halving the 
resolution) in the preview. This option has no 
effect on the pixels in the file; it simply provides 
faster previews with the tool.

• Auto Select Layer to select the topmost layer that 
has pixels under the move tool, rather than the 
selected layer.
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To move a selection or layer:

1 Select the move tool ( ). 

To activate the move tool when another tool is 
selected, hold down Ctrl (Windows) or Command 
(Mac OS). (This technique does not work with the 
pen tool ( ), direct-selection tool ( ), hand tool 
( ), magnifying glass tool ( ), or anchor-point 
tools ( ) ( ) ( ).)

2 Do one of the following:

• Move the pointer inside the selection border, 
and drag the selection to a new position. If you 
have selected multiple areas, all move as you drag.

• Select the layer you want to move. Then drag the 
layer to a new position.

Copying selections or layers

You can use the move tool to copy selections as you 
drag them within or between images, or you can 
copy and move selections using the Copy, Copy 
Merged, Cut, and Paste commands. Dragging with 
the move tool saves memory because the 
Clipboard is not used as it is with the Copy, Copy 
Merged, Cut, and Paste commands.

Keep in mind that when a selection or layer is 
pasted between images with different resolutions, 
the pasted data retains its pixel dimensions. This 
can make the pasted portion appear out of 
proportion to the new image. Use the Image Size 
command to make the source and destination 
images the same resolution before copying and 
pasting. (See “Determining a recommended 
resolution for an image (Photoshop)” on page 31.) 

These are the copy and paste commands you can 
use:

• The Copy command copies the selected area on 
the active layer.

• The Copy Merged command makes a merged 
copy of all the visible layers in the selected area.

• The Paste command pastes a cut or copied 
selection into another part of the image or into 
another image as a new layer. 

• (Photoshop) The Paste Into command pastes a 
cut or copied selection inside another selection in 
the same image or different image. The source 
selection is pasted onto a new layer, and the desti-
nation selection border is converted into a layer 
mask. (See “Using layer masks” on page 239.)

To copy a selection:

1 Select the area you want to copy.

2 Choose Edit > Copy or Edit Copy Merged.

To copy a selection while dragging: 

1 Select the move tool ( ), or hold down Ctrl 
(Windows) or Command (Mac OS) to activate the 
move tool. 

2 Hold down Alt (Windows) or Option 
(Mac OS), and drag the selection you want to copy 
and move. 

When copying between images, drag the selection 
from the active image window into the destination 
image window. If nothing is selected, the entire 
active layer is copied. As you drag the selection 
over another image window, a border highlights 
the window if you can drop the selection into it.
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To create multiple copies of a selection within an 
image: 

1 Select the move tool ( ), or hold down Ctrl 
(Windows) or Command (Mac OS) to activate the 
move tool.

2 Copy the selection:

• Hold down Alt (Windows) or Option (Mac OS), 
and drag the selection.

• To copy the selection and offset the duplicate by 
1 pixel, hold down Alt (Windows) or Option 
(Mac OS), and press an arrow key.

• To copy the selection and offset the duplicate by 
10 pixels, press Alt+Shift (Windows) 
Option+Shift (Mac OS), and press an arrow key.

As long as you hold down Alt (Windows) or 
Option (Mac OS), each press of an arrow key 
creates a copy of the selection and offsets it by the 
specified distance from the last duplicate. 

To paste one selection into another (Photoshop): 

1 Cut or copy the part of the image you want 
to paste. 

2 Select the part of the image into which you want 
to paste the selection. The source selection and the 
destination selection can be in the same image or 
in two different Photoshop images.

3 Choose Edit > Paste Into. The contents of the 
source selection appear masked by the destination 
selection. 

In the Layers palette, the layer thumbnail for the 
source selection appears next to the layer mask 
thumbnail for the destination selection. The layer 
and layer mask are unlinked—that is, you can 
move each one independently.

<<ART: keep, reshoot UI>>

Source selection pasted into destination selection

For more information on editing layer masks, 
see “Applying and discarding layer masks” on 
page 243.

4 Select the move tool ( ), or hold down the Ctrl 
(Windows) or Command (Mac OS) key to activate 
the move tool. Then drag the source contents until 
the part you want appears through the mask.

5 To reveal more or less of the image underlying 
the layer, click the layer mask thumbnail in 
the Layers palette, select a painting tool, and edit 
the mask:

• To hide more of the image underlying the layer, 
paint the mask with black.

• To reveal more of the image underlying the layer, 
paint the mask with white.

• To partially reveal the image underlying the 
layer, paint the mask with gray.

6 If you are satisfied with your results, you can 
choose Layer > Merge Down to merge the new 
layer and layer mask with the underlying layer and 
make the changes permanent.
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Using drag and drop to copy between 
applications

The drag-and-drop feature lets you copy and 
move artwork between Photoshop or ImageReady 
and other applications.

In Windows, the application must be OLE-
compliant. To duplicate an entire image by 
dragging and dropping, use the move tool to drag 
the image. To copy an OLE object that contains 
.psd data, use the OLE Clipboard. (See your 
Windows documentation.) 

In Mac OS, the application must support Mac OS 
Drag Manager, and you must be running System 
7.0 or higher. For versions earlier than System 7.5, 
you must also be running the Drag Manager 
Extension.

Dragging vector artwork from Adobe Illustrator or 
from other applications that use the Illustrator 
Clipboard converts the artwork to a bitmap image 
(also called raster format). To copy the artwork as 
a path in Photoshop, hold down Ctrl as you drag.

Using the Clipboard to copy between 
applications

You can often use the Cut or Copy command to 
copy selections between Photoshop or 
ImageReady and other applications. The cut or 
copied selection remains on the Clipboard until 
you cut or copy another selection. 

In some cases, the contents of the Clipboard are 
converted to a bitmap image (also called raster 
format), or rasterized. Photoshop prompts you 
when vector artwork will be rasterized. <<need 
reviewers to confirm this is always true.>>

Note: Rasterizing resizes your image based on an 
image size of 96 dpi for Windows and 72 dpi for 
Mac OS.

<<Double-check this note. It‘s from the 5.5 
UG.>>

To change the Export Clipboard preference 
(Photoshop):

1 Choose Edit > Preferences > General. 

2 Select Export Clipboard to save any Photoshop 
contents on the Clipboard when you exit from 
Photoshop. If you leave this deselected, the 
contents are deleted when you exit from the 
program.

3 Click OK.

To paste PostScript artwork from another 
application:

1 In the supporting application, select your 
artwork, and choose Edit > Copy. Applications 
that produce PostScript artwork include 
Adobe Illustrator (version 5.0 and later), 
Adobe Dimensions, and Adobe Streamline. 
(See “About file formats” on page 382.)

2 In Photoshop or ImageReady, make active the 
image into which you’ll paste the selection.

3 Choose Edit > Paste.

4 In the dialog box that appears (Photoshop), 
select from the following options: 
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• Paste as Pixels to have the artwork rasterized as it 
is pasted. Rasterizing converts mathematically 
defined vector artwork to pixels. 

• Paste as Paths to paste the copy as a path in the 
Paths palette.

5 If you chose Paste as Pixels in the previous step, 
do one of the following:

• Keep Anti-aliasing selected to make a smooth 
transition between the edges of the selection and 
the surrounding pixels. (See “Softening the edges 
of a selection” on page 124.)

• Deselect Anti-aliasing if you want the selection 
to have a crisp edge. 

Note: If anti-aliasing causes ghosting, you can also 
use the Matting commands. (See “Removing fringe 
pixels from a selection (Photoshop)” on page 156.)

6 Click OK (Photoshop).

Deleting selections
To delete a selection, choose Edit > Clear or press 
Backspace (Windows) or Delete (Mac OS). To cut 
a selection to the Clipboard, choose Edit > Cut.

Deleting a selection on a background or on a layer 
with Lock Transparency replaces the original 
location with the background color. Deleting a 
selection on a layer without Lock Transparency 
replaces the original area with the layer trans-
parency.

Removing fringe pixels from a 
selection (Photoshop)
When you move or paste an anti-aliased 
selection, some of the pixels surrounding the 
selection border are included with the selection. 
This can result in a fringe or halo around the edges 
of the pasted selection. These Matting commands 
let you edit unwanted edge pixels: 

• Defringe replaces the color of any fringe pixels 
with the colors of nearby pixels containing pure 
colors (those without background color). For 
example, if you select a yellow object on a blue 
background and then move the selection, some of 
the blue background is selected and moved with 
the object. Defringe replaces the blue pixels with 
yellow ones.

• Remove Black Matte and Remove White Matte 
are useful when you want to paste a selection anti-
aliased against a white or black background onto a 
different background. For example, anti-aliased 
black text on a white background has gray pixels at 
the edges, which are visible against a colored 
background.

You can also remove fringe areas by using the 
sliders in the Layer Styles dialog box to remove, 

or make transparent, areas from the layer. In this 
case, you would make the black or white areas trans-
parent.

To decrease a fringe on a selection: 

1 Choose Layer > Matting > Defringe.

2 Enter a value in the Width text box for the 
distance to search for replacement pixels. In most 
cases, a distance of 1 or 2 pixels is enough.
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3 Click OK.

To remove a matte from a selection:

Choose Layer > Matting > Remove Black Matte or 
Remove White Matte.

Warping images
You can use the Liquify command to make pixels 
appear to flow within a preview image. Special 
tools make it easy to warp, twirl, expand, contract, 
shift, reflect, and copy areas under the pointer. An 
optional warp mesh shows distortions from the 
original image.

The preview image shows all layers or a selected 
layer. <<Can’t select layer sets now; will this work 
in later builds?>> You can “freeze” areas of the 
preview image to protect them from further 
changes, and “thaw” frozen areas, making them 
editable. You can also use several reconstruction 
modes to fully or partially reverse the distor-
tions—or to extend the distortions or redo them 
in new areas. When you’re finished, you can apply 
the changes to the actual image.

Note: You can’t use the Liquify command in Indexed 
Color, Bitmap, or Multichannel image mode.

Distorting images

Several tools in the Liquify dialog box distort the 
area under the pointer when you hold down the 
mouse button or drag. The effects intensify as you 
continue to hold down the mouse button or 
repeatedly drag over an area.

To distort an image:

1 If you want to change only one area of an image 
or selected layer, select that area. You can also 
create an alpha channel to use as a mask that 
defines frozen areas.

You can use a selection to zoom in on an area to 
be displayed in the preview image. You can’t 

zoom within the preview.

2 Choose Image > Liquify. A dialog box displays 
the preview image, tools for editing the image, and 
tool and view options.

Note: If a type layer is selected, you must render the 
layer before proceeding, making the type uneditable. 
To warp type without rendering the type layer, use 
the Warp options for the type tool.

3 Adjust the brush size and pressure of the tools as 
needed and set up the display. (See “Setting tool 
and view options” on page 160.)

4 Define any areas in the preview image that will 
remain fully or partially unchanged. (See 
“Freezing and thawing areas” on page 158.) You 
can freeze or thaw areas at any time.

5 Use any of the following tools to distort the 
preview image:

• The warp tool (<<art>>) pushes pixels under 
the pointer forward as you drag. 

• The twirl clockwise tool (<<art>>) rotates 
pixels under the pointer clockwise as you hold 
down the mouse button or drag. Pixels at the outer 
edge of the brush rotate at a faster rate than pixels 
toward the center.
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• The twirl counterclockwise tool (<<art>>) 
rotates pixels under the pointer counterclockwise 
as you hold down the mouse button or drag. Pixels 
at the outer edge of the brush rotate at a faster rate 
than pixels toward the center.

• The pucker tool (<<art>>) moves pixels toward 
the center of the brush area as you hold down the 
mouse button or drag. 

• The bloat tool (<<art>>) moves pixels away 
from the center of the brush area as you hold down 
the mouse button or drag.

• The shift pixels tool (<<art>>) moves pixels in 
a direction perpendicular to the direction in which 
you move the pointer. You drag to move pixels to 
the left, and Alt-drag (Windows) or Option-drag 
(Mac OS) to move pixels to the right.

• The reflection <<change to “reflect”?>> tool 
(<<art>>) copies pixels from the area perpen-
dicular to the direction in which you drag, creating 
a reflection. 

TIP: To create a slightly distorted mirror image 
similar to a reflection in water, freeze the area to be 
copied. Then repeatedly Alt-drag (Windows) or 
Option-drag (Mac OS) the reflect tool from the edge 
between the frozen and unfrozen areas into the 
unfrozen area, using overlapping strokes perpen-
dicular to the edge.

6 After distorting the preview image, you can use 
the reconstruct tool (<<art>>) or other controls 
to fully or partially restore the image to its 
previous state. (See “Reconstructing an image” on 
page 159.) You can use the tool in some recon-
struction modes to further change the image.

7 Click OK to apply the changes in the preview 
image to the actual image.

Freezing and thawing areas

You can use tools or alpha channels to freeze areas 
of the preview image to protect them from further 
changes, or to thaw the frozen areas. When you 
select an area of the image before using the Liquify 
command, the unselected areas are initially frozen 
in the preview image.

Certain reconstruction modes change unfrozen 
areas in relation to frozen areas. (See “Recon-
structing an image” on page 159.) You can hide or 
show the mask for frozen areas, change the mask 
color, and use a Brush Pressure option to create 
partial freezes and thaws. (See “Setting tool and 
view options” on page 160.)

To define which areas can be edited:

Do any of the following:

• To use the freeze tool (<<art>>) to protect an 
area in the preview image from further editing, 
select the tool and drag over the area. The degree 
of freezing depends on the current brush pressure. 
If the frozen areas mask is displayed, the tint of the 
mask indicates the degree of freezing. If the brush 
pressure is less than 100%, you can fully freeze an 
area by dragging more than once. 

You can use other tools to distort and reconstruct 
partially frozen areas, but their effects are propor-
tionate to the degree of freezing. For example, if 
you drag the warp tool over an area that is 50% 
frozen and continue dragging over an unfrozen 
area, the frozen area shows half the distortion that 
occurs in the unfrozen area.
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• To use an alpha channel to define a frozen area, 
choose it from the Channel menu.

• To make a frozen area editable, select the thaw 
tool (<<art>>) and drag over the area. Brush 
pressure has the same effect on the thaw tool as it 
has on the freeze tool.

• To make all frozen areas editable, click Thaw All.

• To make all frozen areas editable and freeze the 
remaining areas, click Invert.

Reconstructing an image

After you change the preview image, you can use a 
variety of controls and reconstruction modes to 
reverse changes or redo the changes in new ways. 
Reconstruction modes include reverting to the 
original state; extending distortions in frozen areas 
into unfrozen areas; and displacing, rotating, 
scaling, or skewing areas to match changes at 
selected points.

To restore a preview image to a previous state:

After distorting the preview image, do one of the 
following:

• To undo or redo the previous change, use the 
undo or redo command for your system.

• To change an unfrozen area of the preview image 
back to its state when you opened the Liquify 
dialog box, choose the Revert reconstruction 
mode from the Mode menu. Then select the 
reconstruct tool (<<art>>) and hold down the 
mouse button or drag over the area. The resto-
ration occurs more quickly at the brush center.

• To restore all unfrozen areas to their state when 
you opened the dialog box, click Revert. <<from 
spec; currently restores frozen areas, too>>

• To restore the preview image (including frozen 
areas) and all settings to their state when you 
opened the dialog box, Alt-click Cancel.

To extend distortions in frozen areas into unfrozen 
areas:

1 Freeze all or part of areas you have changed. 
(The image borders are also treated as if they are 
frozen.)

2 Choose one of these reconstruction modes from 
the Mode menu:

• Rigid maintains right angles in the pixel grid (as 
shown by the warp mesh) at the edges between 
frozen and unfrozen areas, sometimes producing 
near-discontinuities at the edges. This restores the 
unfrozen areas to something close to their 
appearance in the original. (To restore them 
completely, use Revert reconstruction mode.)

• Stiff acts like a weak magnetic field. At the edges 
between frozen and unfrozen areas, the unfrozen 
areas continue the distortions in the frozen areas. 
As the distance from frozen areas increases, the 
distortions lessen.

• Smooth propagates the distortions in frozen 
areas throughout unfrozen areas, with smoothly 
continuous distortions.

• Loose produces effects similar to Smooth, with 
even greater continuity between distortions in 
frozen and unfrozen areas.

<<Show effects of these reconstruction modes 
with warp mesh visible in 4-up art. (If we need to 
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show original, do 5-up art or don’t show either 
Smooth or Loose.)>>

3 Reconstruct the unfrozen areas:

• To reconstruct one or more unfrozen areas, 
select the reconstruct tool and hold down the 
mouse button or drag over the area. Pixels move 
more quickly at the brush center.

• To reconstruct all unfrozen areas, click Recon-
struct. The image changes until reconstruction in 
the current mode is complete. To partially recon-
struct the unfrozen areas, use the interrupt 
command for your system during reconstruction.

To reconstruct areas to match distortions at selected 
points:

1 After distorting the preview image, choose one 
of these reconstruction modes from the Mode 
menu:

• Displace moves pixels in unfrozen areas to 
match the displacement at the reference point 
<<what to call this? center point?>> for the recon-
struction. You can use Displace to move all or part 
of the preview image to a different location.

• Amplitwist moves pixels in unfrozen areas to 
match the displacement, rotation, and scaling 
applied at the reference point. You can use this 
reconstruction mode to duplicate areas in the 
image. 

• Affine moves pixels in unfrozen areas to match 
all distortions applied at the reference point, 
including displacement, rotation, scaling, and 
skew.

<<Show original and effects of these three 
reconstruction modes with warp mesh visible in 4-
up art. >>

2 Click in any location where distortions have 
occurred to set the reference point.

3 Select the reconstruct tool and hold down the 
mouse button or drag over the area. Pixels move 
more quickly at the brush center. You can click and 
use the reconstruct tool repeatedly to create a 
variety of effects.

Note: The Reconstruct button is not available in 
Displace, Amplitwist, and Affine reconstruction 
modes.

Setting tool and view options

You can adjust the brush size and brush pressure of 
the tools. You can also specify the display of frozen 
areas, the preview image, and the warp mesh.

To specify the brush size and pressure:

Do any of the following:

• To change the brush size for the tools, enter a 
Brush Size value or drag the slider. The brush size 
can range from 1 to 100 pixels.

• To change the brush pressure for the tools, enter 
a Brush Pressure value or drag the slider. Brush 
pressure can range from 1% to 100%.

A low brush pressure makes changes occur more 
slowly, so it’s easier to stop them at exactly the 

right time.

• To use pressure readings from a stylus tablet, 
select Stylus. This option is available only when 
you are working with a stylus tablet. When Stylus 
is selected, the brush pressure for the tools is the 
stylus pressure multiplied by the Brush Pressure 
value.
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To set view options:

Select an option to define the display of the 
preview image:

• Show Frozen Areas, Show Image, and Show 
Mesh display the frozen areas mask, the preview 
image, and the warp mesh.

• Mesh Size lets you choose a small, medium, or 
large mesh grid.

• Mesh Color and Freeze Color let you choose 
colors for the mesh and the frozen areas mask.

Transforming objects in two 
dimensions
You can scale, rotate, skew, distort, and apply 
perspective to selected parts of an image, entire 
layers, paths, and selection borders. You can also 
rotate and flip part or all of a layer, an entire image, 
path, or selection border. 

About 2D transformations

Use the following guidelines when applying trans-
formations:

• You can transform a linked layer. The transfor-
mation affects all the layers in the linking group. 

• (Photoshop) You cannot apply transformations 
to the background as a layer; nor can you apply 
transformations on 16 bit-per-channel images. 
You can, however, transform selections on the 
background.

• (Photoshop) You can apply transformations to 
an alpha channel by first selecting it in the 
Channels palette. (See “Storing masks in alpha 
channels” on page 217.)

• You can apply transformations to a layer mask 
by first selecting its thumbnail in the Layers 
palette. (See “Using layer masks” on page 239.)

• Pixels are added or deleted during transforma-
tions. To calculate the color values of these pixels, 
Photoshop and ImageReady use the interpolation 
method selected in the General Preferences dialog 
box. This option directly affects the speed and 
quality of the transformation. Bicubic interpo-
lation, the default, is slowest but yields the best 
results. (See “Choosing an interpolation method” 
on page 29.)

Specifying what to transform

You can apply a transformation to a selection or an 
entire layer. In Photoshop, you can also apply a 
transformation to a path or selection border.

To specify what to transform:

Do one of the following:

• To transform part of a layer, select the layer, 
and then select part of the image on that layer. 
(See “Using the Layers palette” on page 224 and 
“Selecting” on page 115)

• To transform an entire layer, make the layer 
active, and make sure nothing is selected. 
(See “Using the Layers palette” on page 224.)
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• (Photoshop) To transform a path, choose a path 
tool or select part or all of the path. If you select 
one or more points on a path, only those path 
segments connected to the points are transformed. 
(See “Selecting paths and vector objects 
(Photoshop)” on page 125.)

• (Photoshop) To transform a selection border, 
make or load a selection. (See “Selecting” on 
page 115)

To move the center point for the transformation:

Drag the center point. The center point can be 
outside the part of the image, the path, or the 
selection you want to transform.

Rotating and flipping entire images

The Rotate Canvas commands let you rotate or flip 
an entire image. The commands do not work on 
individual layers or parts of layers, paths, or 
selection borders.

To rotate or flip an entire image:

Choose Image > Rotate Canvas, and choose one of 
the following commands from the submenu:

• 180° to rotate the image by a half-turn.

• 90° CW to rotate the image clockwise by a 
quarter-turn.

• 90° CCW to rotate the image counterclockwise 
by a quarter-turn.

• Arbitrary to rotate the image by the angle you 
specify. If you choose this option, enter an angle 
between -359.99 and 359.99 in the angle text box, 
and then select CW or CCW to rotate clockwise or 
counterclockwise. Click OK.

• Flip Horizontal to flip the image horizontally, 
along the vertical axis.

• Flip Vertical to flip the image vertically, along the 
horizontal axis.

Applying a transformation

The commands under the Transform submenu let 
you apply specific transformations to a selection, 
layer, path, or selection border. Photoshop 
previews the effect and surrounds the selected area 
with a bounding border that lets you manipulate 
the selection, layer, or path.

You can apply several commands in succession 
before applying the cumulative transformation. 
For example, you can choose Scale, drag a handle 
to scale, and then choose Distort, drag a handle to 
distort, and press Enter or Return to apply both 
transformations.

To scale, rotate, skew, distort, or apply perspective:

1 Do one of the following:

• To transform part or all of a layer, select it. Then 
choose Edit > Transform > Scale, Rotate, Skew, 
Distort, or Perspective.

• (Photoshop) To transform part or all of a path, 
select it. Then choose Edit > Transform Points or 
Transform Path > Scale, Rotate, Skew, Distort, 
or Perspective.

Note: Distort and Perspective are available only 
when transforming entire paths.
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• (Photoshop) To transform a selection border, 
make or load a selection. Choose Select > 
Transform Selection. Then choose Edit > 
Transform > Scale, Rotate, Skew, Distort, or 
Perspective.

To scale or skew around the center point, press 
Alt (Windows) or Option (Mac OS) when 

choosing the Scale or Skew command.

2 Drag the handles to achieve the desired effect.

3 To apply additional transformations, repeat 
steps 1 and 2.

4 Press Enter or Return to apply the cumulative 
transformation. Press Esc to cancel the transfor-
mation.

To flip or rotate precisely:

1 Do one of the following:

• To flip or rotate part or all of a layer, select it.

• (Photoshop) To flip or rotate part or all of a 
path, select it. 

• (Photoshop) To transform a selection border, 
make or load a selection. Then choose Select > 
Transform Selection.

2 Choose Edit > Transform, Transform Points, or 
Transform Path (Photoshop), and choose one of 
the following commands from the submenu:

• Rotate 180° to rotate by a half-turn.

• Rotate 90° CW to rotate clockwise by a
quarter-turn.

• Rotate 90° CCW to rotate counterclockwise by a 
quarter-turn.

• Flip Horizontal to flip horizontally, along the 
vertical axis.

• Flip Vertical to flip vertically, along the 
horizontal axis.

To repeat a transformation:

Do one of the following:

• To repeat a transformation on a selection or 
layer, choose Edit > Transform > Again. 

• (Photoshop) To repeat a transformation on a 
path, choose Edit > Transform Points > Again, or 
Transform Path > Again.

To duplicate an item when transforming it 
(Photoshop):

Press Ctrl+Alt+T (Windows) or 
Command+Option+T (Mac OS), or hold down 
Alt (Windows) or Option (Mac OS) when 
selecting the Transform command.

Freely transforming and previewing 
effects

The Free Transform command lets you use the 
Scale, Rotate, Skew, Distort, and Perspective 
commands without having to select them from the 
menu. To apply these transformations, you use 
different shortcut keys as you drag the handles of 
the transform bounding box.

To freely transform:

1 Specify what to transform:

• To transform part or all of a layer, select it. Then 
choose Edit > Free Transform. 
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• (Photoshop) To transform part or all of a path, 
select it. Then choose Edit > Free Transform 
Points or Free Transform Path. 

• (Photoshop) To transform a selection border, 
create or load a selection. Then choose Select > 
Transform Selection.

2 Do one or more of the following:

• To scale, drag a handle. Press Shift as you drag a 
corner handle to scale proportionately. When 
positioned over a handle, the pointer turns into a 
double arrow.

<<ART: to place free transform icons (Editorial: 
Pls indicate where.) 

• To rotate, move the pointer outside of the 
bounding border (it turns into a curved, two-sided 
arrow), and then drag. Press Shift to constrain the 
rotation to 15° increments. 

• To rotate around a point other than the center of 
the selection, drag the center point to a new 
position in the selection before rotating.

• To distort relative to the center point of the 
bounding border, press Alt (Windows) or Option 
(Mac OS), and drag a handle.

• To distort relative to a point other than the 
center of the selection, drag the center point to a 
new position in the selection before distorting.

• To distort freely, press Ctrl (Windows) or 
Command (Mac OS), and drag a handle.

• To skew, press Ctrl+Shift (Windows) or 
Command+Shift (Mac OS), and drag a side 
handle. When positioned over a side handle, the 
pointer turns into a white arrowhead with a small 
double arrow.

• To apply perspective, press Ctrl+Alt+Shift 
(Windows) or Command+Option+Shift 
(Mac OS), and drag a corner handle. When 
positioned over a corner handle, the pointer turns 
into a gray arrowhead.

To undo the last handle adjustment, choose 
Edit > Undo.

3 Press Enter (Windows) or Return (Mac OS) to 
apply the transformation. To cancel the transfor-
mation, press Esc.

Transforming numerically

The Numeric command lets you scale, rotate, 
skew, or move part of an image, a layer, a path, or 
a selection border precisely, by entering specific 
numeric values for the transformation.

To transform a layer or path numerically:

1 Specify what to transform:

• To transform part or all of an image on a layer, 
select it. Then choose Edit > Transform > 
Numeric.

• (Photoshop) To transform part or all of a path, 
select it. Then choose Edit > Transform Points > 
Numeric or Transform Path > Numeric.

• (Photoshop) To transform a selection border, 
make or load one. Choose Select > Transform 
Selection. Then choose Edit > Transform > 
Numeric.

2 Deselect any transformation option in the 
dialog box to turn it off.

3 Do one or more of the following:
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• To move, select Position. Choose the unit of 
measurement from the menus; then enter a 
horizontal distance in the X text box and a vertical 
distance in the Y text box. To move relative to the 
existing image, layer, or path, select Relative. 
Otherwise, the movement is relative to the top left 
corner of the image.

• To resize, select Scale. Choose the unit of 
measurement from the menus; then enter values 
for the Width and Height. Select Constrain 
Proportions to scale proportionally.

• To skew, select Skew. Then enter values for the 
Horizontal and Vertical angles of slant.

• To rotate, select Rotate. Then enter a value for 
Angle, or drag the radius inside the circle to the 
desired angle of rotation.

4 Click OK.

Transforming objects in three 
dimensions 
The 3D Transform filter lets you manipulate a flat, 
two-dimensional image as if it were a solid, three-
dimensional object. Take, for example, a 
perspective photograph of a cereal box. You specify 
the corners of the box using a wire frame, and you 
can then manipulate the box as if it were a three-
dimensional object. You can reposition the box, 
turn or rotate it, shrink or enlarge it, and change 
its field of view.

Transforming and manipulating objects

You can transform a two-dimensional object into 
a cube, sphere, or cylinder and manipulate it using 
wire frames based on that shape. Cylinders can 
include anything from simple objects, such as a 
can of soup, to shapes whose sides are lathed, such 
as a bottle or a lamp.

You can create and manipulate any grouping of 
cubes, spheres, and cylinders in the same image. 
For example, you can create and rotate a box, two 
balls, and a bottle together in the same image.

To transform and manipulate an object in three 
dimensions:

1 Choose Filter > Render > 3D Transform.

2 Select one of these tools in the dialog box:

• Cube ( ) to map the image (such as a file 
cabinet) to a cubic surface.

• Sphere ( ) to map the image (such as a globe or 
ball) to a spherical surface.

• Cylinder ( ) to map the image (such as a can or 
bottle) to a cylindrical surface.

3 Drag to create a cubic, cylindrical, or spherical 
wire frame over the image.

4 Move or reshape the wire frame as described in 
this section. The anchor points should line up with 
the corners of the box, or the top and bottom of 
the sphere or cylinder you want to manipulate.

5 Manipulate the object in three dimensions as 
described in this section.

6 Click OK.
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To move or reshape the wire frame:

1 Select the selection tool ( ) or direct-selection 
tool ( ) in the dialog box.

2 Do either of the following:

• Drag an edge of the wire frame to move the 
entire frame.

• With the direct-selection tool, drag an anchor 
point on the wire frame to move that anchor 
point.

Note: The wire frame turns red if you try to make a 
wire frame that would be impossible to re-create in 
three dimensions.

3 If you are creating a complex cylinder, do any of 
the following:

• To add an anchor point to a cylinder, select the 
add-anchor-point tool ( ) in the dialog box, and 
click the right side of the wire frame. For example, 
you can add an anchor point to more closely fit the 
cylindrical wire frame to a picture of a bottle.

• To change an added anchor point from a smooth 
anchor point to a corner anchor point and vice 
versa, select the convert-anchor-point tool ( ), 
and click the point. A smooth anchor point creates 
a gentle curve when you adjust it; a corner anchor 
point creates a sharp corner.

• To delete an added anchor point, select the 
delete-anchor-point tool ( ), and click the point.

4 For Field of View, enter a value between 1 and 
130 or drag the slider to the left to increase the 
apparent field of view, right to decrease it.This can 
make the wire frame fit the image better. If you 
know the field of view angle used to photograph 
the image, you can enter it here.

To delete a wire frame:

Select the selection tool ( ) in the dialog box.

1 Select the wire frame, and press Delete.

To manipulate the object in three dimensions:

Do any of the following:

• To move the object, click the pan camera tool 
(icon) in the dialog box, and drag the object.

• To rotate the object in any direction, click the 
trackball tool (icon), and drag the object.

• For Dolly Camera (icon), enter a value between 
0 and 100, or drag the slider to the left to magnify 
the transformed object, right to shrink it. This has 
the same effect as if you were dollying, or moving, 
the camera further from or closer to the image.

• For Field of View, enter a value between 1 and 
130, or drag the slider to the left to increase the 
apparent field of view, right to decrease it.

The 3D Transform dialog box previews only the 
active layer. As you manipulate an object in 

three dimensions, you can align it with the contents 
of underlying layers. Duplicate the layer to align to, 
and place it directly under the layer to be trans-
formed in the layer stacking order. Merge the layer to 
be transformed with the duplicated layer. With the 
Display Background option enabled in the 
3D Transform options, manipulate the object on the 
layer. When the layer is aligned, disable the Display 
Background option, and click OK.
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Modifying the preview image

Use the zoom and hand tools in the 3D Transform 
dialog box to change your preview of an image. 
These actions do not modify the transformation 
itself, only your view of it.

To magnify or shrink the preview image:

1 Select the zoom tool ( ) in the dialog box.

2 Click the image to Zoom in, or Alt-click 
(Windows) or Option-click (Mac OS) to 
zoom out.

To move the view of the preview image:

Select the hand tool ( ) in the dialog box, and 
drag the hand to drag the preview image. This 
works only if you are zoomed in on the image.

Setting 3D rendering options

You can set the resolution and anti-aliasing of 
rendered images and specify whether to show the 
background from the original image in the 3D 
preview.

To set 3D rendering options:

1 Click Options in the 3D Transform dialog box.

2 Do any of the following:

• For Resolution, choose the quality of the 
rendered image. The setting has little effect on the 
image quality of cubes, but will produce smoother 
curved surfaces in cylinders and spheres.

• For Anti-aliasing, choose the level of anti-
aliasing to apply to the rendered image.

• Select Display Background to include the 
portions of the original image outside of the wire 
frame in the preview and with the rendered image. 
Turn this option off to separate the transformed 
object from the original background.

3 Click OK.

Painting with a sample of an 
image
The clone stamp and pattern stamp tools let you 
sample part of an image and then paint with the 
sample.

For information on restoring painted areas to their 
previous state, see “Painting with a state or 
snapshot of an image (Photoshop)” on page 148. 

Using the clone stamp tool

The clone stamp tool takes a sample of an image, 
which you can then apply over another image or 
part of the same image. Each stroke of the tool 
paints on more of the sample. Cross hairs mark the 
original sampling point. 

To use the clone stamp tool:

1 Select the clone stamp tool ( ).

2 Choose a size for the brush from the brushes 
menu in the options bar.

If a brush is too large to fit in the menu, it appears 
as a smaller brush with a number indicating the 
actual diameter in pixels.
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3 Specify a blending mode and opacity 
(see“Setting options for painting and editing” on 
page 188).

4 Select Aligned to apply the entire sampled area 
once, regardless of how many times you stop and 
resume painting. This option is useful when you 
want to use different sized brushes to paint an 
image. You can also use the Aligned option to 
duplicate two halves of a single image and place 
them at different locations. 

If Aligned is deselected, the sampled area is applied 
from the initial sampling point each time you stop 
and resume painting. Because the clone stamp tool 
samples the entire image, this option is useful for 
applying multiple copies of the same part of an 
image to different images. 

5 Select Use All Layers to sample data from all 
visible layers. If this is deselected, the tool samples 
only from the active layer.

6 If you are using a pressure-sensitive drawing 
tablet, specify the effects of stylus pressure. 
(See “Specifying the effect of stylus pressure” on 
page 191.)

7 Position the pointer on the part of any open 
image you want to sample, and Alt-click 
(Windows) or Option-click (Mac OS). This 
sample point is the location from which the image 
is duplicated as you paint. 

Note: If you are sampling from one image and 
applying to another, both images must be in the same 
color mode.

8 Drag to paint with the tool.

Using the pattern stamp tool

The pattern stamp tool lets you select part of an 
image and paint with the selection as a pattern.

To use the pattern stamp tool:

1 Select the pattern stamp tool ( ).

2 Choose a size for the brush from the brushes 
menu in the options bar.

If a brush is too large to fit in the menu, it appears 
as a smaller brush with a number indicating the 
actual diameter in pixels.

3 Specify a blending mode and opacity 
(see “Setting options for painting and editing” on 
page 188).

4 Select Aligned to repeat the pattern as 
contiguous, uniform tiles, when you stop and 
resume painting in different parts of the image. 
The pattern is aligned from one paint area to the 
next.

If Aligned is deselected, the pattern is centered on 
the pointer each time you stop and resume 
painting. 

5 Select Use All Layers to sample data from all 
visible layers. If this is deselected, the tool samples 
from only the active layer.

6 If you are using a pressure-sensitive drawing 
tablet, specify the effects of stylus pressure 
(see “Specifying the effect of stylus pressure” on 
page 191).
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7 Use the rectangle marquee tool ( ) on any 
open image to select an area to use as a pattern. 
Then choose Edit > Define Pattern. Reselect the 
pattern stamp tool.

Note: If you are using a pattern from one image and 
applying it to another, both images must be in the 
same color mode.

8 Drag to paint with the tool.

Retouching images
You can retouch images using the smudge, focus, 
toning, and sponge tools. 

Note: These tools cannot be used with Bitmap or 
Indexed color mode images.

Using the smudge tool

The smudge tool simulates the actions of dragging 
a finger through wet paint. The tool picks up color 
where the stroke begins and pushes it in the 
direction you drag. 

To use the smudge tool:

1 Select the smudge tool ( ).

2 Choose a size for the brush from the brushes 
menu in the options bar.

If a brush is too large to fit in the menu, it appears 
as a smaller brush with a number indicating the 
actual diameter in pixels.

3 Specify a blending mode and pressure 
(see “Setting options for painting and editing” on 
page 188).

4 Select Use All Layers to smudge using color data 
from all visible layers. If this is deselected, the 
smudge tool uses colors from only the active layer.

5 Select Finger Painting to smudge using the 
foreground color at the beginning of each stroke. 
If this is deselected, the smudge tool uses the color 
under the pointer at the beginning of each stroke.

6 If you are using a pressure-sensitive drawing 
tablet, specify the effects of stylus pressure. 
(See “Specifying the effect of stylus pressure” on 
page 191.)

7 Drag in the image to smudge color.

Press Alt (Windows) or Option (Mac OS) as 
you drag with the smudge tool to use the Finger 

Painting option.

Using the focus tools

The focus tools consist of the blur tool and the 
sharpen tool. The blur tool softens hard edges or 
areas in an image to reduce detail. The sharpen 
tool focuses soft edges to increase clarity or focus. 
For information on other ways to adjust 
sharpness, see “Sharpening an image” on page 112 
or “Improving performance with filters” on 
page 262.

To use the blur or sharpen tool:

1 Select the blur tool ( ) or sharpen tool ( ). 

2 Choose a size for the brush from the brushes 
menu in the options bar.

If a brush is too large to fit in the menu, it appears 
as a smaller brush with a number indicating the 
actual diameter in pixels.
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3 Specify a blending mode and pressure. 
(See“Setting options for painting and editing” on 
page 188.)

4 Select Use All Layers to blur or sharpen using 
data from all visible layers. If this is deselected, the 
tool uses data from only the active layer.

5 If you are using a pressure-sensitive drawing 
tablet, specify the effects of stylus pressure. 
(See “Specifying the effect of stylus pressure” on 
page 191.)

6 Drag over the part of the image you want to blur 
or sharpen.

Using the toning tools

The toning tools consist of the dodge tool and the 
burn tool. Used to lighten or darken areas of the 
image, the dodge and burn tools are based on a 
traditional photographer’s technique for 
regulating exposure on specific areas of a print. 
Photographers hold back light to lighten an area 
on the print (dodging) or increase the exposure to 
darken areas on a print (burning). 

To use the dodge or burn tool:

1 Select the dodge tool ( ) or burn tool ( ).

2 Choose a size for the brush from the brushes 
menu in the options bar.

If a brush is too large to fit in the menu, it appears 
as a smaller brush with a number indicating the 
actual diameter in pixels.

3 Select what to change in the image:

• Midtones to change the middle range of grays.

• Shadows to change the dark areas.

• Highlights to change the light areas. 

4 Specify the exposure for the tool. (See “Speci-
fying opacity, pressure, or exposure” on page 190.)

5 If you are using a pressure-sensitive drawing 
tablet, specify the effects of stylus pressure. 
(See “Specifying the effect of stylus pressure” on 
page 191.)

6 Drag over the part of the image you want to 
modify.

Using the sponge tool

The sponge tool subtly changes the color 
saturation of an area. In Grayscale mode, the tool 
increases or decreases contrast by moving gray 
levels away from or toward the middle gray.

To use the sponge tool:

1 Select the sponge tool ( ). 

2 Choose a size for the brush from the brushes 
menu in the options bar.

If a brush is too large to fit in the menu, it appears 
as a smaller brush with a number indicating the 
actual diameter in pixels.

3 Select how to change the color:

• Saturate to intensify the color’s saturation.

• Desaturate to dilute the color’s saturation.

4 Specify the pressure for the tool. (See “Speci-
fying opacity, pressure, or exposure” on page 190.)

5 If you are using a pressure-sensitive drawing 
tablet, specify the effects of stylus pressure. 
(See “Specifying the effect of stylus pressure” on 
page 191.)
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6 Drag over the part of the image you want to 
modify.

Annotating images (Photoshop)
You can attach note annotations (notes) and audio 
annotations to an image in Photoshop. This is 
useful for associating review comments, 
production notes, or other information with the 
image. You can create the annotations or import 
them from other <<Photoshop?>> documents.

Notes and audio annotations appear as small 
nonprintable icons on the image. They are 
associated with a location on the image rather than 
with a layer. You can hide and show annotations, 
open notes to view or edit their contents, and play 
audio annotations. You can also add audio annota-
tions to actions. (See <<insert cross-ref to section 
of chapter 18 when text is added>>.)

Adding notes and audio annotations

You can add notes and audio annotations 
anywhere on a Photoshop image canvas. When 
you create a note, a resizable window appears for 
entering text. When you record an audio 
annotation, you must have a microphone plugged 
into the audio-in port of your computer. You can 
add both kinds of annotations by importing them.

You can use a color option to identify annota-
tions that are created by different people or used 

for different purposes.

To create a note:

1 Select the notes tool (<<art>>).

2 Set options as needed:

• Enter an author name. The name appears in the 
title bar of the notes window. 

• Choose a font and size for the note text.

• Select a color for the note icon and the title bar 
of note windows.

3 Click where you want to place the note, or drag 
to create a custom-sized window. 

4 Click inside the window, and type the text. You 
can use the standard editing commands for your 
system. If you type more text than fits in the note 
window, the scroll bar becomes active.

5 To close the note to an icon, click the close box.

To to create an audio annotation:

1 Select the audio annotation tool (<<art>>).

2 Set options as needed:

• Enter an author name. 

• Select a color for the audio annotation icon.

3 Click where you want to place the annotation 
icon.

4 Click Record, and speak into the microphone. 
You can click Pause to temporarily stop the 
recording, and then click Record to resume.

5 Click Stop when you’re finished, and then click 
Save. 

To import annotations:

1 Choose File > Import > Annotations.

2 Select the file that contains the annotations, and 
then click Open. <<Couldn’t test; what happens 
next?>>
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Opening and editing annotations

A note or audio annotation icon marks the 
location of an annotation on an image. When you 
move the pointer over an annotation icon and 
pause, a message displays the author name and 
modification date and time. For notes, the 
message also shows the beginning of the note text; 
for audio annotations, the message also shows the 
audio duration. <<from spec; will tool tips be 
implemented?>>

You use the icons to open notes or play audio 
annotations. You can show, hide, or move the 
icons, and edit the annotations.

To open a note or play an audio annotation:

Double-click the icon:

• If you are opening a note, a window appears, 
displaying the note text. 

• If you are playing an audio annotation and have 
a sound card installed, the audio file begins to play. 
<<Will there be pause and stop options?>>

To hide or show annotation icons:

Choose View > Show > Notes. <<Will this change 
to Show > Annotations?>>

To edit annotations:

Do any of the following:

• To move an annotation icon, move the pointer 
over the icon until it turns into an arrow, and then 
drag the icon. You can do this with any tool 
selected. <<This is how it works now; spec says 
hand, not arrow.>> Moving a note icon does not 
move its note window.

• To move a note window, drag it by the title bar.

• To cut, copy, or paste an annotation, select the 
annotation icon and use the cut, copy, or paste 
command for your system. <<from spec; will this 
be implemented?>>

• To edit the contents of a note, open the note, 
change any options, and add, delete, or change the 
text.

<<Can you edit the contents of an audio annota-
tion file?>>

• To delete a selected annotation, press Backspace 
or Delete. <<In spec; can’t do now. If this function 
isn’t added, describe deleting from context 
menu.>>

• To delete all annotations of the same type, right-
click (Windows) or Control-click (Mac OS) an 
annotation icon to display the context menu, and 
choose Delete All Notes or Delete All Audio 
Annotations. 
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Chapter 8: Painting and Drawing

he painting tools and fill commands let you 
change the color of pixels to modify and 
create colored areas in an image. 

<<To come: intro that explains painting with 
pixels vs drawing with vectors>

Using the painting tools
You can use the paintbrush, pencil, or airbrush to 
paint the current foreground color on an image. 
The three tools create different effects:

• The paintbrush tool creates soft strokes of color. 

• The pencil tool creates hard-edged freehand 
lines.

• The airbrush tool applies gradual tones 
(including sprays of color) to an image, simulating 
traditional airbrush techniques. The edges of the 
stroke are more diffused than those created with 
the paintbrush tool. The pressure setting for the 
airbrush tool controls how quickly the spray of 
paint is applied. If you hold down the mouse 
button without dragging, you can build up color.

To use a painting tool:

1 Specify a foreground color. (See “Choosing 
foreground and background colors” on page 195.)

2 Select the paintbrush tool ( ), pencil tool ( ), 
or airbrush tool ( ).

3 Choose a size for the brush from the brush 
menu in the options bar.

If a brush is too large to fit in the menu, it appears 
as a smaller brush with a number indicating the 
actual diameter in pixels.

4 Specify a blending mode to control how 
painting affects existing pixels in the image. 
(See “Selecting a blending mode” on page 188.)

5 Specify opacity for the paintbrush or pencil 
tool, or pressure for the airbrush tool. (See “Speci-
fying opacity, pressure, or exposure” on page 190.)

6 Set additional options:

• For the paintbrush tool, select Wet Edges to 
paint with a watercolor effect. The paint builds up 
along the edges of the brush stroke.

• For the pencil tool, select Auto Erase to paint the 
background color over areas containing the 
foreground color.

7 Specify the rate at which a brush stroke fades 
dynamically. (See “Specifying a paint fade-out rate 
(Photoshop)” on page 190.)

8 Drag in the image to paint.

To draw a straight line with one of the painting 
tools, click a starting point in the image. Then 

hold down Shift, and click an ending point.

T
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Using the drawing tools
You can draw lines, rectangles, rounded 
rectangles, and ellipses on an image. In Photoshop 
you can also draw polygons and custom shapes. 
(Photoshop does not have a rounded rectangle 
tool, but you can specify rounded corners with the 
rectangle tool.)

Note the following difference in behavior:

• In Photoshop, you can reshape vector objects 
freely after drawing them. 

• In ImageReady, you can only draw and move 
vector objects. You can modify them only from 
Photoshop.

• In Photoshop, you can specify that a line or 
shape is created as a rasterized object.

<<Track: any other differences? follow up. 
ED: There were more differences earlier. If this is 
all, I’ll rework it.>>

Drawing lines and shapes

You can create many objects in Photoshop by 
starting with basic lines and shapes. The tools in 
Photoshop let you easily create rectangles, ellipses, 
polygons, stars, and custom shapes.

To draw with the line tool: 

1 Specify a foreground color. (See “Choosing 
foreground and background colors” on page 195.)

2 Select the line tool ( ).

3 To create a new line, select the fill region, shape 
layer, or work path option in the options bar. 
(See “Creating a shape or a path on a layer” on 
page 131.)

4 To edit a line, select the add, subtract, restrict, or 
invert option in the options bar (Photoshop). 
(See “Setting options for drawing lines and 
shapes” on page 175.)

5 Specify a blending mode and opacity for the 
line. (See “Setting options for painting and 
editing” on page 188.)

6 Enter a line width in Size.

7 To include arrowheads, select Start, End, or 
both to specify where you want arrowheads. To 
edit the appearance of arrowheads, click Shape, 
and do the following:

• For the width of the arrowhead, enter a value 
from 10% to 1000% of the line width. 

• For the length of the arrowhead, enter a value 
from 10% to 5000% of the line width. 

• For the concavity of the arrowhead, enter a value 
from –50% to +50%. The concavity value defines 
the amount of curvature on the widest part of the 
arrowhead, where the arrowhead meets the line.

In Photoshop, you can edit an arrowhead directly 
using the vector selection and drawing tools.

8 Drag in the image to draw the line. To constrain 
the line angle to a multiple of 45°, hold down Shift 
as you drag. 

To draw with a shape tool:

1 Specify a foreground color. (See “Choosing 
foreground and background colors” on page 195.)

2 Select the rectangle tool (ART), ellipse tool 
(ART), polygon tool (ART), custom shape tool 
(ART), or rounded rectangle tool (ART).
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If you are using the custom shape tool, you must 
first define and select a custom shape. 

3 To create a new shape, select the shape layer, 
work path, or fill region option in the options bar. 
(See “Creating a shape or a path on a layer” on 
page 131.) 

4 To edit a shape, select the add, subtract, restrict, 
or invert option in the options bar (Photoshop). 
(See “Setting options for drawing lines and 
shapes” on page 175.)

5 To create a shape of a particular size, select Fixed 
Size (ImageReady), and enter values in Width and 
Height. <<Photoshop spec says Use Fixed Size. But 
it is not in bld 114. Currently Photoshop Width and 
Height options are set in the next step. >>

6 Click a shape in the options bar, then click the 
arrow (icon) to display its options dialog box 
(Photoshop). Set additional options for specific 
shapes:

• Width or Height to specify the width or height of 
the shape. <<monitor with regards to step 5>>

• Corner Radius to specify the roundness of 
corners in a rounded rectangle. A larger value 
creates rounder corners. A smaller value creates 
sharper corners.

• Sides to specify the number of sides in a polygon.

• Star to render a polygon as a star. Enter a 
percentage in the text box to specify the fullness of 
the points on the star. A larger value creates 
sharper, thinner points. A smaller value creates 
fuller points.

7 Specify a blending mode and opacity for the 
shape. (See “Setting options for painting and 
editing” on page 188.)

8 To create a shape using a predefined style, select 
a style from the list. (See “Grouping layer effects 
into styles” on page 253.)

9 Drag in the image to draw the shape. Hold down 
Shift as you drag to constrain a rectangle or 
rounded rectangle to a square or to constrain an 
ellipse to a circle. Hold down Alt (Windows) or 
Option (Mac OS), and drag to draw from the 
center of the object. Hold down the spacebar to 
move the object without changing its size or shape.

To create and select a custom shape (Photoshop):

1 Create a shape using the other shape tools, or 
select the path containing the shape you want to 
use.

2 Choose Edit > Define Custom Shape and enter 
a name for the new custom shape.

3 To select that custom shape, choose it from the 
Shape list in the options bar.

4 To restrict a shape to the original size, select 
Fixed Size in the options bar. 

Setting options for drawing lines and 
shapes

Once you start drawing lines or shapes, you can 
specify the behaviors of overlapping shapes.

To specify how overlapping shapes interact:

1 If needed, select the line tool (icon) the 
rectangle tool (icon) ellipse tool (icon), polygon 
tool (icon) or custom shape tool (icon).

2 Set any of these options in the options bar:
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• Add to path area to add a shape on top of any 
existing shapes.

• Subtract from path area to subtract the inter-
section of shapes.

• Restrict path area to restrict the fill to the 
overlapping area.

• Invert path area to invert the fill of the 
overlapping objects and the background.

3 Draw with the selected tool. 

Manipulating lines and shapes 
(Photoshop)

You use the path component selection tool and the 
direct selection tool to move and reshape lines and 
vector shapes. <<monitor, add layer clipping groups 
too?>>

To move or resize lines and shapes:

1 Select all or part of the line or shape you want to 
modify. (See “Selecting paths and vector objects 
(Photoshop)” on page 125.)

2 To move the shape, do one of the following:

• Select the path component selection tool 
(<<icon>>), and drag the shape.

• Select the direct selection tool (<<icon>>), then 
Alt-click (Windows) or Option-click (Mac OS), 
and drag the shape.

3 To reshape the shape, select one of the handles 
with the direct selection tool, and drag to reshape 
the object.

Erasing
The eraser and magic eraser tools let you erase 
areas of an image to transparency or to the 
background color. The background eraser tool 
(Photoshop) lets you erase to transparency on a 
layer.

You can also use the Auto Erase option with the 
pencil tool to erase the foreground color to the 
background color as you paint. 

Using the eraser tool

The eraser tool changes pixels in the image as you 
drag through them. If you’re working in the back-
ground or in a layer with locked transparency, the 
pixels change to the background color; otherwise, 
the pixels are erased to transparency.

You can also use the eraser to return the affected 
area to a state selected in the History palette.

To use the eraser tool:

1 Select the eraser tool (icon).

2 Choose a size for the brush from the brush 
menu in the options bar.

If a brush is too large to fit in the menu, it appears 
as a smaller brush with a number indicating the 
actual diameter in pixels.

3 Choose the tool type you want to use as an 
eraser—paintbrush, airbrush, pencil, or block. 

4 Specify an opacity to define the strength of the 
erasure. An opacity of 100% erases pixels to 
complete transparency. A lower opacity erases 
pixels to partial transparency.
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5 If you’re using the paintbrush eraser, select Wet 
Edges to paint with a watercolor effect. When this 
is selected, the erased effect builds up along the 
edges of the brush stroke.

6 To erase to a saved state or snapshot of the 
image, select Erase to History. (See “Painting with 
a state or snapshot of an image (Photoshop)” on 
page 148.)

To use the eraser tool in Erase to History mode, 
hold down Alt (Windows) or Option (Mac OS) 

as you drag in the image.

7 Specify how a brush strokes fades dynamically. 
(See “Specifying a paint fade-out rate 
(Photoshop)” on page 190.)

8 Drag through the area you want to erase.

Using the magic eraser tool

When you click in a layer with the magic eraser 
tool, the tool automatically changes all similar 
pixels. If you’re working in the background, or in a 
layer with locked transparency, the pixels change 
to the background color; otherwise, the pixels are 
erased to transparency. You can choose to erase 
contiguous pixels only or all similar pixels on the 
current layer.

Erasing similar pixels

To use the magic eraser tool:

1 Select the magic eraser tool ( ).

2 Enter a tolerance value. This defines the range of 
colors that can be erased. A low tolerance erases 
pixels within a range of color values very similar to 
the pixel you click. A high tolerance erases pixels 
within a broader range.

3 Specify an opacity to define the strength of the 
erasure. An opacity of 100% erases pixels to 
complete transparency. A lower opacity erases 
pixels to partial transparency.

4 Select Anti-aliased to smooth the edges of the 
area you erase.
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5 Select Contiguous to erase only pixels 
contiguous to the one you click, or leave 
unselected to erase all similar pixels in the image.

6 Select Use All Layers to sample the erased color 
using combined data from all visible layers.

7 Click in the part of the layer you want to erase.

Using the background eraser tool 
(Photoshop)

The background eraser tool lets you erase pixels on 
a layer to transparency as you drag. By specifying 
different sampling and tolerance options, you can 
control the range of the transparency and the 
sharpness of the boundaries.

To use the background eraser tool:

1 In the Layers palette, select the layer containing 
the areas you want to erase.

2 Select the background eraser tool ( ).

3 Choose a size for the brush from the brush 
menu in the options bar.

If a brush is too large to fit in the menu, it appears 
as a smaller brush with a number indicating the 
actual diameter in pixels.

4 Choose an erasing mode:

• Discontinuous to erase the sampled color 
wherever it occurs in the layer.

• Contiguous to erase areas that contain the 
sampled color and are connected to one another.

• Find Edges to erase connected areas containing 
the sampled color, while better preserving the 
sharpness of object edges.

5 For Tolerance, enter a value or drag the slider. A 
low tolerance limits erasure to areas that are very 
similar to the sampled color. A high tolerance 
erases a broader range of colors.

6 Choose a sampling option:

• Continuous to sample colors continuously as 
you drag. Use this option to erase adjacent areas 
that are different in color.

• Once to erase only areas containing the color 
that you first click. Use this option to erase a solid-
colored area.

• Background Swatch to erase only areas 
containing the current background color.

7 Select Protect Foreground Color to prevent the 
erasure of areas that match the foreground color in 
the toolbox.

8 Specify the rate at which a brush stroke fades 
dynamically. (See “Specifying a paint fade-out rate 
(Photoshop)” on page 190.)

9 Drag through the area you want to erase. The 
background eraser tool pointer appears as a brush 
shape with a cross-hair indicating the tool’s hot 
spot.

Using the Auto Erase option

The Auto Erase option for the pencil tool lets you 
paint the background color over areas containing 
the foreground color.

To use the Auto Erase option:

1 Specify foreground and background colors. 
(See “Choosing foreground and background 
colors” on page 195.)
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2 Select the pencil tool ( ).

3 Select Auto Erase.

4 Drag over the image. 

If you begin dragging over the foreground color, 
the area is erased to the background color. If you 
begin dragging from an area that doesn’t contain 
the foreground color, the area is painted with the 
foreground color. 

Using the art history brush tool 
(Photoshop)
The art history brush tool lets you paint with 
stylized strokes, using the source data from a 
specified history state or snapshot. By experi-
menting with different paint style, fidelity, size, 
and tolerance options, you can simulate the 
texture of painting with different colors and 
artistic styles.

Like the history brush, the art history brush uses a 
specified history state or snapshot as the source 
data. The history brush, however, paints by recre-
ating the specified source data, while the art 
history brush uses that data along with the options 
you set to create different colors and artistic styles. 
For more information on the history brush, 
see “Painting with a state or snapshot of an image 
(Photoshop)” on page 148.

For a variety of visual effects, experiment with 
applying filters or filling an image with a solid 

color before painting with the art history brush tool. 
For example, set the source history state to the 
original image, fill the image with white, and use the 
art history brush tool to paint. You can also exper-
iment with custom, non-circular brushes in the 
brush display.

A. Original B. White fill C. Large brush D. Small brush

To use the art history brush tool:

1 In the History palette, click the left column of 
the state or snapshot to use as the source for the art 
history brush tool. A brush icon appears next to 
the source history state.

A B

C D
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2 Select the art history brush tool ( ).

3 Choose a size for the brush from the brush 
menu in the options bar.

If a brush is too large to fit in the menu, it appears 
as a smaller brush with a number indicating the 
actual diameter in pixels.

4 Specify a blending mode and opacity for the 
paint. (See “Setting options for painting and 
editing” on page 188.)

5 Choose an option from the Style menu to 
control the shape of the paint stroke.

6 For Fidelity, enter a value or drag the slider to 
control how much the paint color deviates from 
the color in the source state or snapshot. The lower 
the fidelity, the more the color will vary from the 
source.

7 For Area, enter a value to specify the area 
covered by the paint strokes. The greater the size, 
the larger the covered area and more numerous the 
strokes. 

8 For Tolerance, enter a value or drag the slider to 
limit the regions where paint strokes may be 
applied. A low tolerance lets you paint unlimited 
strokes anywhere in the image. A high tolerance 
limits paint strokes to areas that differ consid-
erably from the color in the source state or 
snapshot.

9 If you are using a pressure-sensitive tablet, set 
any of the following Brush Dynamic options in the 
options bar to Stylus: 

• Size to have increased pressure result in a larger 
area covered by the paint. (Size refers to the area of 
coverage, not the brush size.)

• Opacity to have increased pressure result in 
more opaque paint.

10 Drag in the image to paint.

Using the paint bucket tool
The paint bucket tool fills adjacent pixels that are 
similar in color value to the pixels you click. 

Note: The paint bucket tool cannot be used with 
images in Bitmap mode. 

<<ED: A LOT of xrefs in some of these procedures. 
We need to look at this issue. >>

To use the paint bucket tool: 

1 Specify a foreground color. (See “Choosing 
foreground and background colors” on page 195.)

2 Select the paint bucket tool ( ).

3 Specify whether to fill the selection with the 
foreground color or with a pattern. (See “Filling 
and stroking selections and layers” on page 191.)

4 Specify a blending mode and opacity for the 
paint. (See “Setting options for painting and 
editing” on page 188.)

5 Enter the tolerance for the fill.

The tolerance defines how similar in color a pixel 
must be to be filled. Values can range from 0 to 
255. A low tolerance fills pixels within a range of 
color values very similar to the pixel you click. A 
high tolerance fills pixels within a broader range.

6 To smooth the edges of the filled selection, select 
Anti-aliased. (See “Softening the edges of a 
selection” on page 124.)
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7 To fill pixels based on the merged color data 
from all visible layers, select Use All Layers. 
(See “Sampling from all layers” on page 233.)

8 To fill only pixels contiguous to the one you 
click, select Contiguous; leave unselected to fill all 
similar pixels in the image.

9 Click the part of the image you want to fill. All 
adjacent pixels within the specified tolerance are 
filled with the foreground color or pattern.

If you’re working on a layer and don’t want to 
fill transparent areas, make sure that the layer’s 
transparency is locked in the Layers palette. 
(See “Preserving a layer’s transparency” on 
page 232.)

Using the gradient tools 
(Photoshop)
The gradient tools create a gradual blend between 
multiple colors. You can choose from existing 
gradient fills or create your own. 

Applying a gradient fill

You fill an area with a gradient by dragging in the 
image. The starting point (where the mouse is 
pressed) and ending point (where the mouse is 
released) affect the gradient appearance 
depending on the gradient tool used.

These are the gradient tools:

Linear gradient ( ) Shades from the starting 
point to the ending point in a straight line.

Radial gradient ( ) Shades from the starting 
point to the ending point in a circular pattern.

Angular gradient ( ) Shades in a counter-
clockwise sweep around the starting point. 

Reflected gradient ( ) Shades using symmetric 
linear gradients on either side of the starting point.

Diamond gradient ( ) Shades from the starting 
point outward in a diamond pattern. The ending 
point defines one corner of the diamond.

Note: The gradient tools cannot be used with images 
in Bitmap or indexed-color mode.

To apply a gradient fill: 

1 To fill part of the image, select the desired area. 
Otherwise, the gradient fill is applied to the entire 
active layer. 

2 Select one of the gradient tools.

3 To change the gradient fill, click in the gradient 
sample in the options bar, and choose a fill from 
the gradient display.

4 Specify a blending mode and opacity for the 
paint. (See “Setting options for painting and 
editing” on page 188.)

5 To use a transparency mask for the gradient fill, 
select Transparency. (See “Editing the gradient 
transparency” on page 183.)

6 To reverse the order of colors in the gradient fill, 
select Reverse.

7 To create a smoother blend with less banding, 
select Dither.

8 Position the pointer in the image where you 
want to set the starting point of the gradient, and 
drag to define the ending point. To constrain the 
line angle to a multiple of 45°, hold down Shift as 
you drag.
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Creating and editing gradient fills

The Gradient Editor dialog box lets you define a 
new gradient or modify an existing one. You can 
also add intermediate colors to a gradient, creating 
a blend between more than two colors.

<<ART: Reshoot UI and add callouts for gradient 
stops>>

A. Starting color stop B. Colorselectionbox C. Preview bar
D. Foreground and background selection boxes
E. Color swatch F. Midpoint G. Gradient bar 
H. Ending color stop

To create or edit a gradient:

1 Select a gradient tool. 

2 Click in the gradient sample in the options bar, 
and choose Edit.

3 Do one of the following:

• To create a new gradient, choose New Gradient 
from the pop-up menu. Enter a name for the 
gradient, and click OK.

• To base your gradient on an existing gradient, 
select a gradient from the list, and then choose 
New Gradient. 

• To edit an existing gradient, select it from the 
list.

4 To define the starting color of the gradient, click 
the left color stop under the gradient bar. The 
triangle above the stop turns black, indicating that 
the starting color is being edited.

5 To choose a color, do one of the following:

• Double-click the color stop, or click the color 
swatch below the gradient bar. Choose a color, and 
click OK. 

• Choose foreground from the color pop-up 
menu to use the current foreground color.

• Choose background from the color pop-up 
menu to use the current background color.

• Position the pointer over the gradient bar (the 
pointer turns into the eyedropper), and click to 
sample a color.

6 To define the ending color, click the right color 
stop under the gradient bar. Then choose a color as 
described in step 5.

7 To adjust the location of the starting point or 
ending point, do one of the following:

• Drag the corresponding color stop left or right to 
the location you want. 

• Click the corresponding color stop, and enter a 
value for Location. A value of 0% places the point 
at the far left end of the gradient bar, a value of 
100% at the far right end.

A

B

C

D E G HF
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8 To adjust the location of the midpoint (where 
the gradient displays an even mix of the starting 
and ending colors), drag the diamond below the 
gradient bar to the left or right, or click the 
diamond and enter a value for Location.

9 To set the smoothness for the entire gradient, 
enter a value or drag the slider.

10 Click OK to add the new gradient fill to the list 
or to update the edited gradient fill. 

To add intermediate colors to a gradient:

In the Gradient Editor dialog box, click below the 
gradient bar to define another color stop. Specify 
the color and adjust the location and midpoint for 
the intermediate point as you would for a starting 
or ending point. To remove an intermediate color, 
drag the color stop down and off the gradient bar.

Editing the gradient transparency

Each gradient fill contains settings that control the 
opacity of the fill at different locations on the 
gradient. For example, you can set the starting 
color to 100% opacity and have the fill gradually 
blend into an ending color with 50% opacity. The 
checkerboard pattern indicates the amount of 
transparency in the gradient preview.

To edit the gradient transparency:

1 Select a gradient tool.

2 Click in the gradient sample in the options bar, 
and choose Edit.

3 Select a gradient to edit its opacity settings.

4 To adjust the starting opacity, click the 
left opacity stop above the gradient bar.

5 Set the Opacity by doing one of the following:

• Enter a value between 0 (fully transparent) and 
100% (fully opaque), or drag the Opacity slider. 

• Select an opacity from the gradient preview.

6 To adjust the opacity of the endpoint, click the 
right transparency stop above the gradient bar. 
Then set the opacity as described in step 5. 

7 To adjust the location of the starting or ending 
opacity, do one of the following:

• Drag the corresponding opacity stop to the left 
or right.

• Select the corresponding opacity stop, and enter 
a value for Location. 

8 To adjust the location of the midpoint opacity 
(the point midway between the starting and 
ending opacities), do one of the following:

• Drag the diamond above the gradient bar to the 
left or right.

• Select the diamond and enter a value for 
Location.

9 To add an intermediate opacity to the mask, 
click above the gradient bar to define a new opacity 
stop. You can then adjust and move this opacity as 
you would for a starting or ending opacity. To 
remove an intermediate opacity, drag its trans-
parency stop up and off the gradient bar.

10 Click OK.
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Creating and editing noise gradient fills

In addition to creating smooth gradients, the 
Gradient Editor dialog box lets you define a new 
noise gradient or modify an existing one. A noise 
gradient is a gradient that contains random 
components along with the deterministic ones 
that create the gradient.

<<ART: show Noise options in Gradient Editor 
dialog box? (#pa_04)>>

To create or edit a noise gradient:

1 Select a gradient tool. 

2 Click in the gradient sample in the options bar, 
and choose Edit.

3 Do one of the following:

• To create a new noise gradient, choose New 
Gradient from the pop-up menu. Enter a name for 
the gradient, and click OK. Then change Gradient 
Type to Noise.

• To base your noise gradient on an existing one, 
select a gradient from the list and then choose New 
Gradient. Make sure Gradient Type is set to Noise.

• To edit an existing noise gradient, select it from 
the list.

4 To define the color model, select a color model 
from the list.

5 To adjust the colors, drag the sliders.

6 Set the options to saturate colors or to add 
transparency.

7 To randomize the color settings, click the 
Randomize button until you find a setting you 
like.

8 To set the roughness for the entire gradient, 
enter a value, or drag the slider.

9 Click OK to add the new noise gradient fill to 
the list or to update the edited noise gradient fill. 

Loading, saving, and deleting gradients

By saving and loading sets of gradients, you can 
customize the gradient list that appears in the 
gradient options bar and the Gradient Editor 
dialog box. A gradient is not added to the preset 
group until the gradient preset group is explicitly 
saved, but instead it is saved with the Preferences 
file. Gradients can be loaded, saved, or reset using 
the Gradient Editor dialog box or the Preset 
Manager. See “Defining preset colors, patterns, 
and shapes” on page 194.

<<ART: NEW show gradient display, gradient 
menu, and where to click in the options bar for 
Reset Tool. (#pa_05)>>

To customize the gradient list:

Do one of the following:

• To delete a gradient, select the gradient in the 
Gradient Editor dialog box, and click Delete.

• To append gradients that have been stored in a 
file to the current list, click Load in the Gradient 
Editor dialog box.

• To save gradients in a separate file for later use, 
select the desired gradients in the Gradient Editor 
dialog box (Shift-click to select multiple 
gradients). Then click Save. <<Reviewers: please 
verify: I can’t choose multiple gradients with shift-
click in the Gradient Editor dialog box (bld 112), 
only the Preset Mgr>>
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• To return to the default gradient list, choose 
Reset Tool from the menu in the options bar. Or, 
you can choose Reset Gradients from the pop-up 
menu in the Gradient Editor dialog box. You can 
either replace the current list or append the default 
gradients to the current list. <<verify, Reset Tool 
didn’t work in bld 112.>>

Customizing the brushes set
The brush sizes and shapes available for painting 
and editing appear in the brush menu in the 
options bar for painting and editing tools. You can 
customize the brushes and settings for each of the 
painting tools (airbrush, paintbrush, eraser, 
pencil) and editing tools (history brush, clone 
stamp, smudge, focus, toning). 

You can create new brushes or sets of brushes and 
save or reload them using the Preset Manager. 
(See “Defining preset colors, patterns, and shapes” 
on page 194.)

Creating and editing brushes

You can create new brushesand delete brushes you 
no longer need, and you can use part of an image 
to create a custom brush. 

<<ART: NEW show brush display, with pop-up 
menu selected. Callout brush display in options 
bar and brush menu. Show here or after step 1. 
(#pa_06)>>

To create a brush:

1 Click the brush display in the options bar, and 
choose New Brush from the brush menu.

The preview box in the lower right corner of the 
New Brush dialog box shows the current brush tip. 
The box in the lower left corner shows the current 
brush angle and roundness. As you enter new 
options, the brushes in these boxes update. 

2 Set the brush options as described in“Setting 
brush options” on page 186.

3 Click OK. New brushes are added at the bottom 
of the display. 

To delete a brush:

Do one of the following:

• Press Ctrl (Windows) or Command (Mac OS), 
and click the brush you want to delete.

• Click the brush in the brush display, and choose 
Delete Brush from the brush menu.

• Choose Edit > Preset Manager, select Brushes 
from the Preset Type list, select the brush in the 
brush display, and click Delete. <<ED: delete from 
here or replace with xref to Preset Manager?>>

To create a custom brush shape: 

1 Select part of an image to use as a custom brush.

The brush shape can be up to 1000 pixels by 1000 
pixels in size. To be most effective, the shape 
should appear on a solid white background. If you 
want to define brushes with soft edges, select brush 
shapes composed of pixels with gray values. 
(Colored brush shapes appear as gray values.)

2 Choose Define Brush from the brush menu. 

3 Double-click the newly created brush in the 
brush display to open the Brush Options 
dialog box.
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4 Specify Spacing as described in the next section.

5 To make the brush placement more accurate, 
make sure that Anti-aliased is selected. 

6 Click OK.

See “Softening the edges of a selection” on 
page 124 for information on anti-aliasing. 

Note: The Anti-aliased option is not available for 
large brushes.

Pear painted with custom 
brush shown in inset

Setting brush options

You can define a number of options for the default 
brushes and any brushes you create. For custom 
brushes, only the spacing and anti-aliased options 
can be changed.

To set brush options:

1 Do one of the following:

• To edit the current brush, click the brush sample 
in the options bar, or choose Brush Options from 
the brush menu.

• To edit a different brush, double-click the brush 
you want in the brush menu.

2 Set the options for Diameter, Hardness, 
Spacing, Angle, and Roundness. Then click OK. 

Diameter Controls the size of the brush. Enter a 
value in pixels or drag the slider.

<<cut but put all 5 pairs in gallery?>>

Brush strokes with different diameter values

Hardness Controls the size of the brush’s hard 
center. Type a number, or use the slider to enter a 
value that is a percentage of the brush diameter.

Brush strokes with different hardness values
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Spacing Controls the distance between the brush 
marks in a stroke. To change the spacing, type a 
number, or use the slider to enter a value that is a 
percentage of the brush diameter. To paint strokes 
without defined spacing, deselect this option.

Increasing the spacing makes the brush skip.

Angle Specifies the angle by which an elliptical 
brush’s long axis is offset from horizontal. Type a 
value in degrees, or drag the horizontal axis in the 
left preview box.

Angled brushes create a chiseled stroke.

Roundness Specifies the ratio between the brush’s 
short and long axes. Enter a percentage value, or 
drag the points in the left preview box. A value of 
100% indicates a circular brush, a value of 0% 
indicates a linear brush, and intermediate values 
indicate elliptical brushes.

Adjusting roundness affects shape of brush tip.

Saving, loading, and replacing brushes

The brush display can hold as many brushes as you 
want. Creating sets of brushes can help you group 
related or special brushes and manage palette size. 
The Adobe Photoshop program folder includes 
files containing various brush sets. 

To save and use custom brush sets:

Choose one of the following commands from the 
brush menu:

• Reset Brushes to return to the default brushes. 
You can replace the current brush set or append 
the default brushes to the current set.

• Load Brushes to add brushes stored in a file to 
the current palette. 

• Replace Brushes to replace the current brush set 
with brushes stored in a file.
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• Save Brushes to save a brush set in a file (and in 
Windows, append an .abr extension to the 
filename). 

You can also load or save brushes using the Preset 
Manager. (See “Defining preset colors, patterns, 
and shapes” on page 194.)

Exiting Photoshop saves the current brush display 
in the Preferences file. 

Setting options for painting and 
editing
You set options for a painting or editing tool in the 
options bar for that tool.

Selecting a blending mode

The blending mode specified in the options bar 
controls how pixels in the image are affected by a 
painting or editing tool. It’s helpful to think in 
terms of the following colors when visualizing a 
blending mode’s effect: 

• The base color is the original color in the image. 

• The blend color is the color being applied with 
the painting or editing tool.

• The result color is the color resulting from the 
blend.

To select a blending mode for a tool:

Choose from the Mode menu in the options bar.

<<ART: make a gallery from the color gallery 
from p. 233 in the 5.0 UG? Or the similar color 
series in the 5.0 help? Note here as a reminder to 
do so.>>

Normal Edits or paints each pixel to make it the 
result color. This is the default mode. (Normal 
mode is called Threshold when you’re working 
with a bitmapped or indexed-color image.)

Dissolve Edits or paints each pixel to make it the 
result color. However, the result color is a random 
replacement of the pixels with the base color or the 
blend color, depending on the opacity at any pixel 
location. This mode works best with the paint-
brush or airbrush tool and a large brush.

Behind Edits or paints only on the transparent 
part of a layer. This mode works only in layers with 
Preserve Transparency off and is analogous to 
painting on the back of transparent areas in a sheet 
of acetate.

Clear Edits or paints each pixel and makes it trans-
parent. This mode is available for the line tool ( ), 
the paint bucket tool ( ), the Fill command, and 
the Stroke command. You must be in a layer with 
Preserve Transparency off to use this mode. 

Multiply Looks at the color information in each 
channel and multiplies the base color by the blend 
color. The result color is always a darker color. 
Multiplying any color with black produces black. 
Multiplying any color with white leaves the color 
unchanged. When you’re painting with a color 
other than black or white, successive strokes with a 
painting tool produce progressively darker colors. 
The effect is similar to drawing on the image with 
multiple magic markers. 
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Screen Looks at each channel’s color information 
and multiplies the inverse of the blend and base 
colors. The result color is always a lighter color. 
Screening with black leaves the color unchanged. 
Screening with white produces white. The effect is 
similar to projecting multiple photographic slides 
on top of each other. 

Overlay Multiplies or screens the colors, 
depending on the base color. Patterns or colors 
overlay the existing pixels while preserving the 
highlights and shadows of the base color. The base 
color is not replaced but is mixed with the blend 
color to reflect the lightness or darkness of the 
original color. 

Soft Light Darkens or lightens the colors, 
depending on the blend color. The effect is similar 
to shining a diffused spotlight on the image. 

If the blend color (light source) is lighter than 
50% gray, the image is lightened, as if it were 
dodged. If the blend color is darker than 50% 
gray, the image is darkened, as if it were burned in. 
Painting with pure black or white produces a 
distinctly darker or lighter area but does not result 
in pure black or white. 

Hard Light Multiplies or screens the colors, 
depending on the blend color. The effect is similar 
to shining a harsh spotlight on the image. 

If the blend color (light source) is lighter than 
50% gray, the image is lightened, as if it were 
screened. This is useful for adding highlights to 
an image. If the blend color is darker than 50% 
gray, the image is darkened, as if it were multiplied. 
This is useful for adding shadows to an image. 
Painting with pure black or white results in pure 
black or white.

Color Dodge Looks at the color information in 
each channel and brightens the base color to 
reflect the blend color. Blending with black 
produces no change.

Color Burn Looks at the color information in each 
channel and darkens the base color to reflect the 
blend color. Blending with white produces no 
change.

Darken Looks at the color information in each 
channel and selects the base or blend color—
whichever is darker—as the result color. Pixels 
lighter than the blend color are replaced, and 
pixels darker than the blend color do not change. 

Lighten Looks at the color information in each 
channel and selects the base or blend color—
whichever is lighter—as the result color. Pixels 
darker than the blend color are replaced, and 
pixels lighter than the blend color do not change. 

Difference Looks at the color information in each 
channel and subtracts either the blend color from 
the base color or the base color from the blend 
color, depending on which has the greater 
brightness value. Blending with white inverts the 
base color values; blending with black produces no 
change.

Exclusion Creates an effect similar to but lower in 
contrast than the Difference mode. Blending with 
white inverts the base color values. Blending with 
black produces no change.

Hue Creates a result color with the luminance and 
saturation of the base color and the hue of the 
blend color. 



CHAPTER 8190
Painting and Drawing

Saturation Creates a result color with the 
luminance and hue of the base color and the 
saturation of the blend color. Painting with this 
mode in an area with no (0) saturation (gray) 
causes no change. 

Color Creates a result color with the luminance of 
the base color and the hue and saturation of the 
blend color. This preserves the gray levels in the 
image and is useful for coloring monochrome 
images and for tinting color images.

Luminosity Creates a result color with the hue and 
saturation of the base color and the luminance of 
the blend color. This mode creates an inverse effect 
from that of the Color mode.

Specifying opacity, pressure, or exposure

You can specify opacity, pressure, or exposure for 
these tools: 

• Opacity used by the gradient fill, pencil, paint-
brush, clone stamp, pattern stamp, history brush, 
and art history brush tools

• Pressure of action applied by the airbrush, 
smudge, blur, sharpen, and sponge tools

• Amount of exposure used by the dodge and 
burn tools

To specify opacity, pressure, or exposure:

Enter a value or drag the slider for Opacity, 
Pressure, or Exposure in the options bar.

Opacity, pressure, or exposure can range from 1% 
to 100%. For transparent paint or a weak effect, 
specify a low percentage value; for more opaque 
paint or a strong effect, specify a high value. 

Specifying a paint fade-out rate 
(Photoshop)

To simulate actual brush strokes, you can set the 
rate at which the pencil, paintbrush, airbrush, and 
eraser fade out from their beginning strokes. You 
can specify which options dynamically change 
over the course of a brush stroke: opacity, size, and 
color can all be individually set.

To specify a paint fade-out rate:

1 Click the brush dynamics button (icon) in the 
options bar, and set the following fade options:

• Size to decrease the brush stroke size over the 
length of a brush stroke.

• Opacity to reduce the opacity over the length of 
a stroke.

• Color to cause the color to fade in intensity over 
the length of a stroke.

2 Enter a value for Steps. The value represents the 
number of steps in the fade. A smaller value causes 
the stroke to fade quickly.

Each step is equal to one mark of the brush tip. The 
value can range from 1 to 9999. For example, 
entering 10 steps produces a fade in 10 increments. 
You may want to set a value of 25 or larger. If 
strokes fade too quickly, increase the values.
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<< ART: keep but reshoot>>

Fade-out showing setting of 
40, 60, and 80 steps

Specifying the effect of stylus pressure

Photoshop is compatible with most pressure-
sensitive digitizing tablets such as the Wacom® 
tablets. With Control Panel software for your 
tablet installed, you can specify the type of effect 
that results when you vary stylus pressure. 

These stylus pressure options affect the magnetic 
lasso, magnetic pen, pencil, paintbrush, airbrush, 
eraser, clone stamp, pattern stamp, history brush, 
art history brush, smudge, blur, sharpen, dodge, 
burn, and sponge tools. 

To specify the effect of stylus pressure:

Click the brush dynamics button (icon) in the 
options bar, and choose stylus for each of the 
options you want to set:

• Size to have increased pressure create a broader 
brush stroke.

• Opacity/Pressure to have increased pressure 
make the paint more opaque or more intense.

• Color if you want light pressure to paint with the 
background color, making a transition to the 
foreground color as the pressure increases.

Note: If the highest pressure of your stylus does not 
reach 100%, contact your tablet vendor. This 
problem is caused by the driver software, not 
Photoshop. 

Filling and stroking selections 
and layers
Photoshop provides a variety of ways to fill a 
selection or a layer with colors and patterns. You 
can also paint a border around a selection or a 
layer. 

To increase the contrast between your image and 
the surrounding work canvas, you can fill the 
canvas with a color. 

Filling a selection or layer with colors or 
patterns

You can fill a selection or layer with the foreground 
color, the background color, or a pattern. You can 
use a pattern from the PostScript Patterns folder. 

To fill a selection or a layer: 

1 Specify a foreground or background color. 
(See “Choosing foreground and background 
colors” on page 195.)

2 Select the area you want to fill. To fill an entire 
layer, select the layer in the Layers palette.
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3 Choose Edit > Fill to fill the selection or layer. 

To display the Fill dialog box, press 
Shift+Backspace (Windows) or Shift+Delete 

(Mac OS). 

4 For Use, choose an option:

• Foreground Color, Background Color, Black, 
50% Gray, or White to fill the selection with the 
specified color.

• Pattern to fill the selection with a pattern.

• History to restore the selected area to a state or 
snapshot of the image. (See “Painting with a state 
or snapshot of an image (Photoshop)” on 
page 148.)

Note: If you fill a CMYK image using the Black 
option, Photoshop fills all the channels with 
100% black. This may result in more ink than is 
allowable by the printer. For best results when filling 
a CMYK image, use the Foreground option with the 
foreground color
set to an appropriate black.

5 Specify the blending mode and opacity for the 
paint. (See “Setting options for painting and 
editing” on page 188.)

6 If you’re working in a layer and want to fill only 
areas containing pixels, choose Transparency from 
the Lock menu in the Layers palette.

7 Click OK to fill the selection.

To fill a selection or layer using shortcuts: 

1 Specify a foreground or background color.

2 Select the area or layer you want to fill.

3 Apply the fill:

• To fill with the foreground color, press 
Alt+Backspace (Windows) or Option+Delete 
(Mac OS).

• To apply a foreground color fill only to the areas 
that contain pixels, press Alt+Shift+Backspace 
(Windows) or Option+Shift+Delete (Mac OS). 
This preserves the transparency of the layer.

• To fill with the background color, press 
Ctrl+Backspace (Windows) or Command+Delete 
(Mac OS). 

• To apply a background color fill only to the areas 
that contain pixels, press Ctrl+Shift+Backspace 
(Windows) or Command+Shift+Delete 
(Mac OS).

To fill the work canvas:

1 Set the foreground color you want to use for the 
canvas.

2 Select the paint bucket tool (icon).

3 In the options bar, set Fill to Foreground. 

4 Hold down Shift, and click in the work canvas 
area surrounding the image.

To fill a selection with a pattern: 

1 Make a rectangular selection around the part of 
the image you want to use as the pattern.

2 Choose Edit > Define Pattern. 

3 Enter a name for the pattern.

4 Select the part of the image you want to fill.

5 Do one of the following:

• Choose Edit > Fill. For Use, choose Pattern and 
click OK. 
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• Select the paint bucket tool (icon). In the 
options bar, set Fill to Pattern. Then click to fill the 
selected area with the pattern.

The pattern you defined is repeated as tiles within 
the selection. Each new pattern replaces the 
current pattern. If you want to reuse patterns, save 
a file of swatches for defining patterns. You can 
create and load sets of swatches using the Preset 
Manager. (See “Defining preset colors, patterns, 
and shapes” on page 194.) You can also use the 
pattern stamp tool to paint with a pattern. 
(See “Using the pattern stamp tool” on page 168).

To use a pattern from the PostScript Patterns folder:

1 Choose File > Open. Each file in the PostScript 
Patterns folder (which comes with Photoshop) 
contains a single pattern in the Adobe Illustrator 
format. You can scale and render these patterns at 
any resolution.

2 Select the pattern file you want to use, and 
click Open. 

3 Select any rasterizing options. (See“Importing 
Adobe Illustrator, PDF, and EPS files 
(Photoshop)” on page 36 <<xref destination?>> 
for these options.)

4 Click OK.

5 Make a rectangular selection around the 
pattern, or choose Select > All.

6 Choose Edit > Define Pattern. The pattern is 
defined as an Adobe Photoshop pattern.

7 Enter a name for the pattern.

8 Open an image, and select the part you want 
to fill.

9 Choose Edit > Fill.

10 Choose Pattern from the Use menu, and click 
OK.

Stroking a selection or layer with color

You can use the Stroke command to paint a 
colored border around a selection or layer.

To stroke a selection or layer:

1 Specify a foreground color. (See “Choosing 
foreground and background colors” on page 195.)

2 Select the area or layer you want to stroke. 

3 Choose Edit > Stroke. 

4 Specify the width of the hard-edged border. 
Values can range from 1 to 16 pixels. 

5 For Location, specify whether to place the 
border inside, outside, or directly over the 
selection or layer boundaries.

6 Specify an opacity and a blending mode. 
(See “Setting options for painting and editing” on 
page 188.) 

7 If you’re working in a layer and want to stroke 
only areas containing pixels, select the Preserve 
Transparency option. (See “Preserving a layer’s 
transparency” on page 232.) 

8 Click OK to stroke the selection or layer.
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Defining preset colors, patterns, 
and shapes
You can use the Preset Manager to create, save, 
load, or delete sets of brushes, swatches, gradients, 
styles, patterns, shape curves <<contours>>, and 
custom shapes. The Preset Manager allows you to 
easily reuse or share preset sets. Each type of set 
has its own file extension and default folder. The 
default brushes, swatches, and so on, can’t be 
removed or overwritten using the Preset Manager, 
but you can reset to the default presets.

When you create a new brush, swatch, and so on, 
it displays in the Preset Manager but it is not 
automatically saved as part of the current preset 
file. Instead it is saved in the Preferences file so it 
persists between editing sessions. <<Reviewers: 
please verify this part:>> However, it is lost when 
you modify it or when a new set of that type 
replaces rather than appends to the existing set. To 
permanently save it, you need to select it and save 
it in the Preset Manager; or you can save brushes, 
swatches, gradients, styles, and shape curves in the 
dialog boxes where you create and edit them.

<<ART: NEW show the preset manager dialog box 
with callout to the pop-up menu. (#pa_09)>>

<<ED: should there be separate procedures for 
each option here (create, load, save, and delete? 
Or, change the heading to To manage preset 
sets?>>

To create, load, save, or delete preset sets:

1 Choose Edit > Preset Manager.

2 Select the type of preset from the Preset Types 
list.

3 Shift-click to add or remove contiguous items, 
or Ctrl-click to add or remove non-adjacent items.

4 Choose one of the following:

• Save Set, then enter a name for the set. If you 
want to save it to a folder other than the default, 
navigate to the new folder. You can’t use Save Set to 
overwrite the default preset files. 

• Load, then select a set from the list. If you want 
to load a preset located in another folder, navigate 
to that folder, then select the preset. Or select a set 
from the pop-up menu.

• Rename, then enter a new name for the set.

• Delete to delete the selected items in the set. You 
can’t delete the default items.

To reset or replace sets:

1 Select the type of preset you want to reset or 
replace in the Preset Types list. If there are unsaved 
items displayed in the list, they will be lost. You 
may want to save the current set before you 
continue.

2 To reset to the default set for that type, choose 
Reset from the pop-up menu.

3 To replace the current set, choose Replace from 
the pop-up menu.

<<Double check this later than bld 112. Will you 
be able to move items within a set or between 
sets?>>

To save a subset of a preset set:

1 Choose Edit > Preset Manager.

2 Select the type of preset from the Preset Types 
list.
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3 Shift-click to select contiguous items, or Ctrl-
click to select non-adjacent items.

4 Choose Save Set, then enter a name for the set. 
If you want to save it to a folder other than the 
default, navigate to the new folder. You can’t use 
Save Set to overwrite the default preset files. 

Choosing foreground and 
background colors
Photoshop uses the foreground color to paint, fill, 
and stroke selections and the background color to 
make gradient fills and fill in the erased areas of an 
image. 

You can designate a new foreground or 
background color using the eyedropper tool, the 
Color palette, the Swatches palette, or the Adobe 
Color Picker.

The default foreground color is black, and the 
default background color is white. (In an alpha 
channel, the default foreground is white, and the 
background is black.)

Using color settings in the toolbox

The current foreground color appears in the top 
color selection box in the toolbox; the current 
background color appears in the lower box.

<<ART: substitute with actual UI?>>

A. Foreground color B. Default Colors 
C. Switch Colors D. Background color

The Info palette, the Color palette, and the Adobe 
Color Picker let you display color values using a 
number of color models. (See “About color modes 
and models (Photoshop)” on page 45.)

To change the foreground or background color:

1 Do one of the following:

• To change the foreground color, click the top 
color selection box in the toolbox.

• To change the background color, click the lower 
color selection box in the toolbox.

2 Choose a color in the Adobe Color Picker. 
(See “Using the Adobe Color Picker” on 
page 198.)

To switch between the foreground and 
background colors, press X on the keyboard.

To reverse the foreground and background colors:

Click the Switch Colors icon (<<icon>>) in the 
toolbox. 

To return to the default foreground and background 
colors:

Click the Default Colors icon (<<icon>>) in the 
toolbox.

C

D

A

B
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Using the eyedropper tool

The eyedropper tool ( ) samples color from an 
image to designate a new foreground or 
background color. You can sample from the active 
image or from another image. (When you’re using 
the eyedropper, you can click in a background 
window without making it the active window.)

You can also specify the area sampled by the 
eyedropper tool. For example, you can set the 
eyedropper to sample the color values of a 
3-by-3-pixel area under the pointer. Modifying the 
sample size of the eyedropper affects the color 
readouts displayed in the Info palette. 

To select the foreground or background color:

1 Select the eyedropper tool ( ).

2 To change the sample size of the eyedropper, 
choose an option from the Sample Size menu:

• Point Sample to read the precise value of the 
pixel you click.

• 3 by 3 Average or 5 by 5 Average to read the 
average value of the specified number of pixels 
within the area you click.

3 Select a color:

• To select a new foreground color from an image, 
click the color you want.

•  To select a new background color from an 
image, Alt-click (Windows) or Option-click (Mac 
OS) the color you want.

As you drag the eyedropper tool, the foreground 
color selection box changes dynamically. Alt-drag 
(Windows) or Option-drag (Mac OS) to activate 
the background color selection box. Release the 
mouse button to pick the new color.

To use the eyedropper tool temporarily while 
using any painting tool, hold down Alt 

(Windows) or Option (Mac OS). 

Using the Color palette 

The Color palette displays the color values for the 
current foreground and background colors. Using 
the sliders in the Color palette, you can edit the 
foreground and background colors according to 
several different color models. You can also choose 
a foreground or background color from the 
spectrum of colors displayed in the color bar.

<<ART: keep parts>>

A. Foreground color B. Background color C. Slider
D. Color bar E. Color palette menu

To display the Color palette:

Choose Window > Show Color.

A
B

C

ED
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To select the foreground or background color: 

1 From the Color palette menu, choose the color 
model you want to use for color readout values. 
(See “About color modes and models 
(Photoshop)” on page 45 for a discussion of these 
models.)

2 To edit the foreground or background color, 
make sure that its color selection box is active or 
outlined. To make the foreground or background 
color selection box active, click the box. 

3 To specify a new color:

• Drag the color sliders.

By default, the slider colors change as you drag. If 
you want to turn off this preview feature to 
improve performance, choose Edit > Preferences > 
General, and deselect Dynamic Color Sliders.

• Enter values next to the color sliders. 

• Click the color selection box, choose a color as 
described in “Using the Adobe Color Picker” on 
page 198, and click OK. 

Note: An exclamation point inside a triangle in the 
Color palette indicates an out-of-gamut color, that 
is, a color that cannot be printed using CMYK inks. 
The closest CMYK equivalent appears next to the 
triangle. Click the alert triangle to use the CMYK 
equivalent. (See “Identifying out-of-gamut colors 
(Photoshop)” on page 94.)

To sample colors from the color bar:

1 To edit the foreground or background color, 
make sure that its color selection box is active 
(outlined in black). To make the foreground or 
background color selection box active, click 
the box. 

2 Position the pointer over the color bar (the 
pointer turns into the eyedropper), and click to 
sample a color.

To change the display of the color bar:

Choose a color model from the Color palette 
menu. The Current Colors style displays a 
transition from the current foreground color to 
the current background color. 

To change the display style of the color bar 
quickly, Shift-click in the color bar until you see 

the style you want.

Using the Swatches palette

You can choose a foreground or background color 
from the Swatches palette, or you can add or delete 
colors to create a custom swatch set. You can also 
save a set of swatches and reload them for use in 
another image. Although you can add colors to the 
Swatches palette, you should manage its size and 
organization.

To display the Swatches palette:

Choose Window > Show Swatches.

To select the foreground or background color:

Do one of the following:

• To choose a foreground color, click a color in the 
Swatches palette. 

• To choose a background color, Alt-click 
(Windows) or Option-click (Mac OS) a color in 
the Swatches palette.
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To add a color to the Swatches palette: 

1 Use the eyedropper tool ( ), the Color palette, 
or the Adobe Color Picker to select the color you 
want to add. 

2 Position the pointer over an empty space in the 
bottom row of the Swatches palette (the pointer 
turns into the paint bucket tool), and click to add 
the color.

To replace or insert a color in the Swatches palette:

1 Use the eyedropper tool, the Color palette, or 
the Adobe Color Picker to select the color you 
want to add. 

2 Add a swatch:

• To replace an existing swatch, hold down Shift, 
position the pointer over a swatch (the pointer 
turns into a paint bucket), and click the swatch. 

• To insert a new swatch, press Shift+Alt 
(Windows) or Shift+Option (Mac OS), and click 
a swatch.

To delete a color from the Swatches palette:

Hold down Ctrl (Windows) or Command 
(Mac OS), position the pointer over a swatch 
(the pointer turns into scissors), and click.

To return to the default Swatches palette:

1 Choose Reset Swatches from the Swatches 
palette menu. You can also choose Edit > Preset 
Manager, select Swatches from the Preset Type list, 
then select Reset Swatches from the palette menu.

2 Return to the default palette:

• Click OK to replace the current swatches with 
the default set.

• Click Append to attach the default swatches to 
the end of the current set.

To save and use custom swatch sets:

Choose a command from the Swatches 
palette menu:

• Reset Swatches to use the default set of swatches. 
You can either replace the current swatch set or 
append the default swatches to the current set.

• Load Swatches to append the swatches stored in 
a file to the current set of swatches. Files 
containing different swatch sets are included in the 
Adobe Photoshop program folder.

• Replace Swatches to replace the current swatch 
set with the swatches stored in a file.

• Save Swatches to save the current swatches in 
a file. 

You can also use the Preset Manager to load or save 
swatches. (See “Defining preset colors, patterns, 
and shapes” on page 194.)

Exiting the program saves the current Swatches 
palette in the Adobe Photoshop preferences file.

Using the Adobe Color Picker 
You can use the Adobe Color Picker to select the 
foreground or background color by choosing from 
a color spectrum or by defining colors numeri-
cally. In addition, you can select colors based on 
the HSB, RGB, Lab, and CMYK color models and 
choose from several custom color systems. 
(See “About color modes and models 
(Photoshop)” on page 45.) By default, the 
program uses the Adobe Color Picker.
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<<I changed Photoshop Color Picker everywhere 
to Adobe Color Picker. Hope that’s OK. The pref-
erences command for it is now called Adobe 
(rather than Photoshop) in ImageReady but 
Photoshop in Photoshop in bld 112. Follow up on 
this.>>

To display the Adobe Color Picker:

Do one of the following:

• Click the foreground or background color 
selection box in the toolbox.

• Click the active color selection box in the 
Color palette. 

Specifying a color using the color field 
and color slider

With the HSB, RGB, and Lab color modes, you 
can use the color field and the color slider in the 
Color Picker dialog box to select a color. The color 
slider displays the range of color levels available 
for the selected color component (for example, 
R, G, or B). The color field displays the range for 
the remaining two components—one on the 
horizontal axis, one on the vertical.

For example, if the current color is black and you 
click the red component (R) using the RGB color 
model, the color slider displays the range of color 
for red (0 is at the bottom of the slider and 255 is 
at the top). The color field displays the values for 
blue along its horizontal axis, for green along its 
vertical axis. 

To specify a color using the color field and color slide:

1 Click a component next to the HSB, RGB, or 
Lab values.

2 Select a color:

• Drag the white triangles along the slider.

• Click inside the color slider.

• Click inside the color field. 

When you click in the color field, a circular marker 
indicates the color’s position in the field. 

As you adjust the color using the color field and 
color slider, the numerical values change to reflect 
the new color. The color rectangle to the right of 
the color slider displays the new color in the top 
section of the rectangle. The original color appears 
at the bottom of the rectangle.

Specifying a color using numeric values

In the Adobe Color Picker, you can select a color in 
any of the four color models by specifying numeric 
values for each color component. 

To specify a color using numeric values:

Do one of the following:

• In CMYK color mode (this is the mode 
PostScript printers use), specify each component 
value as a percentage of cyan, magenta, yellow, and 
black. 

• In RGB color mode (this is the mode your 
monitor uses), specify component values from 
0 to 255 (0 is black, and 255 is the pure color). 
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• In HSB color mode, specify saturation and 
brightness as percentages; specify hue as an angle, 
from 0° to 360°, that corresponds to a location on 
the color wheel. (See “About color modes and 
models (Photoshop)” on page 45 for information 
on the color wheel.)

• In Lab mode, enter a lightness value (L) from 
0 to 100, and a axis (green to magenta) and b axis 
(blue to yellow) values from –128 to +127. 

Recognizing non-Web colors

The Web-safe colors are the 216 colors common to 
the Windows® and Mac OS 8-bit color palettes. By 
working only with these colors, you can be sure 
that art you prepare for the Web will not dither on 
a system set to display in 256 colors.

To identify Web-safe colors in the Adobe Color Picker:

• Click the Only Web Colors option in the lower 
left corner of the color picker, and then choose any 
color in the color picker. Any color you pick with 
this option selected is Web-safe.

• Choose a color in the color picker. If you choose 
a non-Web color, an alert cube (<<icon>>) 
appears next to the color rectangle in the color 
picker. Click the alert cube to select the closest Web 
color. (If no alert cube appears, the color you chose 
is Web-safe.)

To select a Web-safe color using the Color palette:

1 Click the Color palette tab or choose Window > 
Show Color to view the Color palette.

2 Choose an option for selecting a Web-safe color:

• Choose Make Ramp Web Safe from the Color 
palette menu. With this option selected, any color 
you choose in the Color palette is Web-safe.

• Choose Web Color Sliders from the Color 
palette menu. By default, Web Color Sliders snap 
to Web-safe colors (indicated by tick marks) when 
you drag them. (To override Web-safe color 
selection, Alt-drag (Windows) or Option-drag 
(Mac OS) the sliders.)

• Choose Web Color Sliders from the Color 
palette menu (Photoshop), or choose any Slider 
option from the Color palette menu 
(ImageReady). Choose a color in the Color palette. 
If you choose a non-Web color, an alert cube 
(<<icon from int:c15:m04_29>>) appears above 
the color ramp on the left side of the Color palette. 
Click the alert cube to select the closest Web color. 
In ImageReady, drag around the alert icon to select 
other close Web colors. (If no alert cube appears, 
the color you chose is Web-safe.)

Note: In Photoshop, you must choose Web Color 
Sliders from the Color palette menu in order to view 
the Web-safe alert cube. In ImageReady, you can 
view the alert cube with any color slider option.
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Recognizing nonprintable colors 
(Photoshop)

Some colors in the RGB, HSB, and Lab color 
models, such as neon colors, cannot be printed, 
because they have no equivalents in the CMYK 
model. When you select a nonprintable color, an 
alert triangle with an exclamation point (<<icon 
from int:c08:w09_12>>) appears in the Color 
Picker dialog box and in the Color palette. The 
closest CMYK equivalent is displayed below the 
triangle. (See “Identifying out-of-gamut colors 
(Photoshop)” on page 94.)

Printable colors are determined by the printing 
values you enter for the selected ink set in the 
CMYK Setup dialog box.

To select the closest CMYK equivalent for a 
nonprintable color:

Click the alert triangle (<<icon>>) that appears in 
the Color Picker dialog box or the Color palette.

Choosing custom colors (Photoshop)

The Adobe Color Picker lets you choose custom 
colors from the PANTONE® MATCHING 
SYSTEM®, the TRUMATCH® SWATCHING 
SYSTEM™, the FOCOLTONE® COLOUR 
SYSTEM, the TOYO Color Finder™ 1050 system, 
the ANPA-COLOR™ system, and the DIC Color 
Guide. 

To ensure that the final printed output is the color 
you want, consult your printer or service bureau 
and choose your custom color based on a printed 
color swatch. Manufacturers recommend that you 
get a new swatch book each year to compensate for 
fading inks and other damage. 

Important: Photoshop prints custom colors to 
CMYK, or process color, plates in every image mode 
except Duotone. To print true spot color plates, 
create spot color channels. (See “Adding spot colors” 
on page 211.)

To choose a custom color:

1 Open the Adobe Color Picker, and click 
Custom.

The Custom Colors dialog box displays the color 
closest to the color currently selected in the Color 
Picker.

2 For Book, choose a color system. 
(See “Choosing a custom color system 
(Photoshop)” on page 201.)

3 Locate the color you want by entering the ink 
number or by dragging the triangles along the 
scroll bar.

4 Click the desired color patch in the list.

5 Click OK.

Choosing a custom color system 
(Photoshop)

The Adobe Color Picker supports various color 
systems:
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PANTONE® Used for printing inks. Each 
PANTONE color has a specified CMYK equiv-
alent. To select a PANTONE color, first determine 
the ink color you want, using either the PANTONE 
Color Formula Guide 747XR or an ink chart 
obtained from your printer. PANTONE books are 
available from printers and graphic arts supply 
stores.

You can select from PANTONE Coated, 
PANTONE Uncoated, PANTONE Process, 
and PANTONE ProSim custom colors. (Contact 
PANTONE, Inc. in Carlstadt, New Jersey, U.S.A.)

TRUMATCH Provides predictable CMYK color 
matching with more than 2000 achievable, 
computer-generated colors. TRUMATCH colors 
cover the visible spectrum of the CMYK gamut in 
even steps. The TRUMATCHCOLORFINDER 
displays up to 40 tints and shades of each hue, each 
originally created in four-color process and each 
reproducible in four colors on electronic image-
setters. In addition, four-color grays using 
different hues are included. (Contact 
TRUMATCH Inc. in New York, New York, U.S.A.)

FOCOLTONE Consists of 763 CMYK colors. 
FOCOLTONE colors help avoid prepress trapping 
and registration problems by showing the 
overprints that make up the colors. 

A swatch book with specifications for process and 
spot colors, overprint charts, and a chip book for 
marking up layouts are available from 
FOCOLTONE. (Contact FOCOLTONE INTER-
NATIONAL, Ltd. in Stafford, United Kingdom.)

TOYO Color Finder 1050 Consists of more than 
1000 colors based on the most common printing 
inks used in Japan. The TOYO Color Finder 1050 
Book contains printed samples of Toyo colors and 
is available from printers and graphic arts supply 
stores. (Contact Toyo Ink Manufacturing Co., Ltd. 
in Tokyo, Japan.)

ANPA-COLOR Commonly used for newspaper 
applications. The ANPA-COLOR ROP Newspaper 
Color Ink Book contains samples of the ANPA 
colors. (Contact the Newspaper Association of 
America in Reston, Virginia, U.S.A.) 

DIC Color Guide Commonly used for printing 
projects in Japan. (Contact Dainippon Ink and 
Chemicals, Inc. in Tokyo, Japan.)

Using other color pickers
In addition to the default Adobe Color Picker, you 
can use the built-in color pickers on your system 
or a plug-in color picker to select colors. Any 
plug-in color pickers you install appear under 
Color Picker in the General Preferences dialog 
box. For information on installing and using a 
plug-in color picker, see the documentation that 
came with the plug-in.

<<In bld 102, this changed from Adobe to 
Photoshop>>

To use the Windows Color Picker: 

1 Choose Edit > Preferences > General. 

2 Choose Windows from the Color Picker menu, 
and click OK.
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3 Click the foreground or background color 
selection box in the toolbox. 

The Windows Color Picker lets you select colors 
from an array of basic colors or define up to 16 
custom colors based on the HSB or the RGB color 
model, but it does not alert you to nonprintable 
colors.

4 To choose a color from the Basic Colors palette, 
click the color you want.

5 To specify a custom color, click Define Custom 
Colors to open the Custom Color Selector. This 
dialog box functions similarly to the Adobe Color 
Picker. Specify a color by using the color field and 
color slider or by entering numerical values for 
each color component. 

The new color is displayed on the left side of the 
Color/Solid box. The right side of this box displays 
the solid color closest to the color you have 
specified. (You can choose the displayed solid 
color by double-clicking the right side of the box.)

6 When you are satisfied with the color, click Add 
to Custom Colors to add it to the Custom Colors 
palette.

7 To choose a custom color from the Windows 
Color Picker, click the color you want.

8 Click OK.

(See your Windows documentation.)

To use the Apple Color Picker: 

1 Choose File > Preferences > General.

2 For Color Picker, choose Apple, and click OK.

3 Click the foreground or background color 
selection box in the toolbox. 

4 Select a color model from the list at the left of 
the dialog box.

The Apple Color Picker lets you select colors based 
on a number of different color models but does 
not alert you to nonprintable colors.

5 Drag the color sliders, click in the color wheel, 
click a crayon, or enter numeric values to specify 
a color.

6 Click OK.

The exact appearance of the Apple Color Picker 
varies between different system software versions. 
For more information, see your Mac OS 
documentation.

To return to the Adobe Color Picker after using 
another color picker:

1 Choose Edit > Preferences > General.

2 Choose Photoshop (Photoshop) or Adobe 
(ImageReady) from the Color Picker menu, and 
click OK.
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Chapter 9: Using Channels and Masks 
(Photoshop)

ach image in Photoshop has channels that 
store information about the image’s color. 
You can create additional channels to store 

spot colors for printing with special inks and to 
store masks for sophisticated selections.

About channels
Photoshop uses special grayscale channels to store 
an image’s color information and information 
about spot color. If an image has multiple layers, 
each layer has its own set of color channels.

Color information channels are created automati-
cally when you open a new image. The image’s 
color mode (and not its number of layers) deter-
mines the number of color channels created. For 
example, an RGB image has four default channels: 
one for each of the red, green, and blue colors plus 
a composite channel used for editing the image.

You can create alpha channels to store selections as 
8-bit grayscale images. You use alpha channels to 
create and store masks, which let you manipulate, 
isolate, and protect specific parts of an image.

In addition, you can create spot color channels to 
specify additional plates for printing with spot 
color inks. An image can have up to 24 channels, 
including all color and alpha channels.

The file size required for a channel depends on the 
pixel information in the channel. For example, if 
the image has no alpha channels, duplicating a 
color channel in an RGB image increases the file 
size by about one-third, in a CMYK image by 
about one-fourth. Each alpha channel and spot 
color channel also adds to the file size. 

Certain file formats compress channel infor-
mation and can save space, including the TIFF and 
Photoshop formats. (See “Managing channels” on 
page 207.) The size of a file, including alpha 
channels and layers, appears as the second (right) 
value in the status bar at the bottom of the window 
when the Document Size command is chosen 
from the pop-up menu. (See “About image size 
and resolution” on page 21.)

Note: As long as you save a file in a format 
supporting the image’s color mode, the color 
channels are preserved. But alpha channels are 
automatically kept only when you save a file in the 
Adobe Photoshop, Adobe Photoshop 2.0 (Mac OS 
only), DCS 2.0, PICT, TIFF, or Raw formats. Saving 
in other formats may cause channel information to 
be discarded. (See “About file formats” on page 382.)

<<Reviewers--Do we still want to include info on 
Photoshop 2.0, as in the preceding note?>>

E
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Using the Channels palette
The Channels palette lets you create and manage 
channels and monitor the effects of editing. The 
palette lists all channels in the image—a composite 
channel first (for RGB, CMYK, and Lab images), 
then individual color channels, spot color 
channels, and finally alpha channels. A thumbnail 
of the channel’s contents appears to the left of the 
channel name; the thumbnail automatically 
updates as you edit the channel.

Viewing channels

You can view any combination of individual 
channels in the palette. For example, view an alpha 
channel and the composite channel together to see 
how changes made in the alpha channel relate to 
the entire image. By default, individual channels 
are displayed in grayscale.

To display the Channels palette:

1 Choose Windows > Show Channels.

<<cut art?>>

A. Show/Hide B. Load Selection
C. Save Selection D. New Channel E. Trash

2 Use the scroll bars or resize the palette to see 
additional channels.

When a channel is visible in the image, an eye icon 
<<icon>> appears to its left in the palette. 

To show or hide a channel: 

Click in the eye column next to the channel to 
show or hide that channel. (Click the composite 
channel to view all default color channels. The 
composite channel is displayed whenever all the 
color channels are visible.)

To show or hide multiple channels, 
drag through the eye column in the 

Channels palette. 

These guidelines apply to channels you display:

• In RGB, CMYK, or Lab images, you can view the 
individual channels in color. (In Lab images, only 
the a and b channels appear in color.)

A B C D E
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• If more than one channel is active, the channels 
always appear in color.

• In alpha channels, selected pixels appear as white 
(partially selected pixels are gray) by default.

• If you display an alpha channel at the same time 
as color channels, the alpha channel appears as a 
transparent color overlay, analogous to a printer’s 
rubylith or a sheet of acetate. To change the color 
of this overlay or set other alpha channel options, 
see “Creating alpha channels” on page 217.

Changing the display of the palette

You can show the individual color channels in 
color (rather than grayscale) in the Channels 
palette and specify the size of the thumbnails. 
Using thumbnails is the most convenient way of 
tracking channel contents; however, turning off 
the display of thumbnails can improve perfor-
mance.

To show color channels in color:

1 Choose Edit > Preferences > Display & Cursors.

2 Select Color Channels in Color, and click OK.

To resize or hide channel thumbnails:

1 Choose Palette Options from the Channels 
palette menu.

2 Select a display option:

• Click a thumbnail size. Smaller thumbnails 
reduce the space required by the palette—helpful 
when you’re working on smaller monitors.

• Click None to turn off the display of thumbnails. 

3 Click OK.

Selecting and editing channels

You can select one or more individual channels in 
the Channels palette. The names of all selected, or 
active, channels are highlighted. Any editing 
changes you make apply to the active channels.

To select a channel:

Click the channel name. Shift-click to select (or 
deselect) multiple channels. 

To edit a channel:

Use a painting or editing tool to paint in the image. 
Paint with white to add to the channel; paint with 
black to remove from the channel; paint with a 
lower opacity or a color to add to the channel with 
lower opacities. 

Managing channels
You can rearrange channels, duplicate a channel 
within or between images, split a channel into 
separate images, merge channels from separate 
images into one new image, and delete alpha and 
spot channels when you’re finished with them.

Changing the order of channels

The default color channels normally appear at the 
top of the Channels palette, followed by the spot 
color channels, and then the alpha channels. You 
cannot move the default channels, but you can 
rearrange spot and alpha channels to suit the way 
you work. 

Spot colors are overprinted in the order they 
appear in the Channels palette.
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To change the order of alpha or spot channels:

Drag the channel up or down. When the heavy 
black line appears in the position you want, release 
the mouse button.

Note: You can move spot channels above the default 
color channels only if the image is in Multichannel 
mode. You cannot move alpha channels above color 
channels.

Duplicating channels

You may want to duplicate an image’s channel to 
make a backup before editing the channel. Or you 
might duplicate alpha channels to a new image to 
create a library of selections to load into the 
current image one by one—thus keeping the file 
smaller. 

If you are duplicating alpha channels between 
images, the channels must have identical pixel 
dimensions. (See “Creating new images” on 
page 34.)

Note: You cannot duplicate a channel to a Bitmap-
mode image.

To duplicate a channel using the Duplicate command:

1 In the Channels palette, select the channel to 
duplicate.

2 Choose Duplicate Channel from the Channels 
palette menu.

3 Type a name for the duplicate channel.

4 For Document, do one of the following:

• Choose a destination. Only images with pixel 
dimensions the same as the current image are 
available. To duplicate the channel in the same file, 
select the channel’s current file. 

• Choose New to copy the channel to a new image, 
creating a multichannel image containing a single 
channel. Type a name for the new image. 

5 To reverse the selected and masked areas in the 
duplicate channel, select Invert. 

6 Click OK.

To duplicate a channel by dragging:

1 In the Channels palette, select the channel you 
want to duplicate.

2 Do one of the following:

• To duplicate a channel within an image, drag the 
channel into the image window or onto the New 
Channel button ( ) at the bottom of the palette.

• To duplicate a channel to another image, make 
sure that the destination image is open. Then drag 
the channel into the destination image window.
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Splitting channels into separate images

You can split the channels of a flattened image into 
separate images. The original file is closed, and the 
individual channels appear in separate grayscale 
image windows. The title bars in the new windows 
show the original filename plus the channel abbre-
viation (Windows) or full name (Mac OS). Any 
changes since the last save are retained in the new 
images and lost in the original.

Splitting channels is useful when you want to 
retain individual channel information in a file 

format that doesn’t preserve channels.

Note: Only flattened images can be split. 
(See “Flattening all layers” on page 249).)

To split channels into separate images:

Choose Split Channels from the Channels palette 
menu.

Merging channels

Multiple grayscale images can be combined into a 
single image. Some grayscale scanners let you scan 
a color image through a red filter, a green filter, and 
a blue filter to generate red, green, and blue 
images. Merging lets you combine the separate 
scans into a single, color image.

Note: You can also blend the data in one or more 
channels into an existing or new channel. 
(See “Mixing color channels” on page 210.)

The images you want to merge must be in 
Grayscale mode, have the same pixel dimensions, 
and be open. (See “Changing the pixel dimensions 
of an image” on page 29.) The number of grayscale 
images you have open determines the color modes 
available when merging channels. For example, 
you can’t merge the split channels from an RGB 
image into a CMYK image, because CMYK 
requires four channels and RGB requires only 
three. 

Note: If you are working with DCS files that have 
accidentally lost their links (and so cannot be 
opened, placed, or printed), open the channel files, 
and merge them into a CMYK image. Then resave 
the file as a DCS EPS file. 

To merge channels: 

1 Open the grayscale images containing the 
channels you want to merge, and make one of the 
images active. 

2 Choose Merge Channels from the Channels 
palette menu.

3 For Mode, choose the color mode you want to 
create. If an image mode is unavailable, it is 
dimmed. The number of channels appropriate for 
the mode appears in the Channels text box. 

4 If necessary, enter a number in the Channels 
text box. 

If you enter a number that is incompatible with the 
selected mode, Multichannel mode is automati-
cally selected. This creates a a multichannel image 
with two or more channels.

5 Click OK.
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6 For each channel, make sure the image you want 
is open. If you change your mind about image 
type, click Mode to return to the Merge Channels 
dialog box. 

7 If merging into a multichannel image, click 
Next, and repeat step 6 to select the remaining 
channels. 

Note: All channels of a multichannel image are 
alpha channels.

8 When finished selecting channels, click OK. 

The selected channels are merged into a new 
image of the specified type, and the original 
images closed without any changes. The new 
image appears in an untitled window. 

Note: You cannot split and recombine (merge) 
an image with spot color channels. The spot color 
channel will be added as an alpha channel.

Deleting channels

You may want to delete spot or alpha channels you 
no longer need before saving an image. Complex 
alpha channels can substantially increase the disk 
space required for an image. 

To delete a channel with no confirmation:

1 Select the channel in the Channels palette.

2 Do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) 
the trash button.

• Drag the channel name in the palette to the trash 
button.

• Choose Delete Channel from the Channels 
palette menu.

To delete a channel with confirmation:

1 Select the channel in the Channels palette.

2 Click the trash button at the bottom of the 
palette. Then click Yes.

When deleting a channel from a file with layers, 
regardless of the method you use, Photoshop 
prompts you first to flatten the visible layers and 
discard hidden layers (if any) before deleting the 
channel. This is necessary because removing a 
color channel converts the image to Multichannel 
mode, which does not support layers.

Mixing color channels
The Channel Mixer command lets you modify a 
color channel using a mix of the current color 
channels. With this command, you can do the 
following:

• Make creative color adjustments not easily done 
with the other color adjustment tools.

• Create high-quality grayscale images by 
choosing the percentage contribution from each 
color channel.

• Create high-quality sepia-tone or other tinted 
images.

• Convert images to and from some alternative 
color spaces, such as YCrCb.

• Swap or duplicate channels.



211ADOBE PHOTOSHOP 6.0
User Guide

To mix color channels:

1 In the Channels palette, select the composite 
color channel.

2 Choose Image > Adjust > Channel Mixer.

3 For Output Channel, choose the channel in 
which to blend one or more existing (or source) 
channels.

4 Drag any source channel’s slider to the left to 
decrease the channel’s contribution to the output 
channel, to the right to increase it, or enter a value 
between –200% and +200% in the text box. Using 
a negative value inverts the source channel before 
adding it to the output channel. 

5 If desired, drag the slider or enter a value for the 
Constant option. This option adds a channel of 
varying opacity to the output channel: negative 
values act as a black channel, positive values act as 
a white channel.

6 If desired, select Monochrome to apply the same 
settings to all the output channels, creating a color 
image that contains only gray values. 

Selecting Monochrome is useful for images you 
plan to convert to grayscale. If you select and then 
deselect this option, you can modify the blend of 
each channel separately, creating a handtinted 
appearance.

7 Click OK.

Adding spot colors
Spot colors are special premixed inks used instead 
of, or in addition to, the process color (CMYK) 
inks. Each spot color requires its own plate on the 
press. (Because a varnish also requires a separate 
plate on press, it is considered a spot color, too.) 
For information on printing spot color plates, 
see “Printing color separations” on page 413.

If you are planning to print an image with spot 
colors, you need to create spot channels to store 
the colors.

Note: To export spot channels, save the file in DCS 
2.0 format. (See “Saving files in Photoshop EPS or 
DCS format (Photoshop)” on page 377.) <<Still 
true?>>

About spot colors

Note the following when working with spot colors:

• If you need spot color graphics that have crisp 
edges and knock out the underlying image, 
consider creating the additional artwork in a page-
layout or illustration application.

• If you need to apply spot color as a tint 
throughout an image, convert the image to 
Duotone mode and apply the spot color to one of 
the duotone plates. You can use up to four spot 
colors, one per plate. (See “Using monotones, 
duotones, tritones, and quadtones” on page 425.) 
<<xref destination?>>

• The names of the spot colors print on the 
separations.
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• Spot colors are overprinted on top of the fully 
composited image. Each spot color is overprinted 
in the order it appears in the Channels palette.

• You cannot move spot colors above a default 
channel in the Channels palette except in Multi-
channel mode.

• Spot colors cannot be applied to individual 
layers.

• If you print an image that includes spot color 
channels to a composite printer, the spot colors 
print out as extra pages.

• You can merge spot channels with color 
channels, splitting the spot color into its color 
channel components. Merging spot channels lets 
you print a single-page proof of your spot color 
image on a desktop printer.

Creating spot channels

You can create a new spot channel or convert an 
existing alpha channel to a spot channel.

To create a new spot channel:

1 Choose Window > Show Channels to display 
the Channels palette.

2 To fill a selected area with a spot color, make or 
load a selection.

3 Do one of the following to create a channel:

• Ctrl-click (Windows) or Command-click 
(Mac OS) the New Channel button ( ) in the 
Channels palette.

• Choose New Spot Channel from the Channels 
palette menu.

If you made a selection, that area is filled with the 
currently specified spot color.

4 Click the color box, and choose a color. 
(See “Using the Adobe Color Picker” on 
page 198.)

If you select a custom color, your print service can 
more easily provide the proper ink to reproduce 
the image. For more information, see “Choosing 
custom colors (Photoshop)” on page 201.

5 For Solidity, enter a value between 0% 
and 100%. 

This option lets you simulate on-screen the 
solidity of the printed spot color. A value of 100% 
simulates an ink that completely covers the inks 
beneath (such as a metallic ink); 0% simulates a 
transparent ink that completely reveals the inks 
beneath (such as a clear varnish). You can also use 
this option to see where an otherwise transparent 
spot color (such as a varnish) will appear.

Note: The Solidity option affects only the on-screen 
preview. It has no effect on the printed output.

6 If desired, enter a name for the spot channel. 
If you chose a custom color in step 4, the channel 
automatically takes the name of that color.

Remember that it’s important to name spot colors 
so they’ll be recognized by other applications 
reading your file. Otherwise the file might not 
print correctly—or print at all.

7 Click OK.

To convert an alpha channel to a spot channel:

1 Double-click the alpha channel in the Channels 
palette.
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2 If needed, rename the channel.

3 Select Spot Color.

4 Click the color box, and choose a color. 
(See “Using the Adobe Color Picker” on 
page 198.)

5 Click OK.

The areas of the channel containing grayscale 
values are converted to spot color.

6 If desired, choose Image > Adjust > Invert to 
apply the color to the selected area of the channel. 

Modifying spot channels

You can edit a spot channel to add or remove color 
in it, change a spot channel’s color or on-screen 
color solidity, and merge a spot channel with the 
image’s color channels.

For information on rearranging, duplicating, or 
deleting spot channels, see “Managing channels” 
on page 207.

To edit a spot channel:

1 Select the spot channel in the Channels palette.

2 Use a painting or editing tool to paint in the 
image. Paint with black to add more spot color at 
100% opacity; paint with gray to add spot color 
with lower opacity.

Note: Unlike the Solidity option in the Spot Channel 
Options dialog box, the Opacity option in the 
painting or editing tool’s options determines the 
actual density of ink used in the printed output.

To change a spot channel’s options:

1 Do one of the following:

• Double-click the spot channel name in the 
Channels palette.

• Select the spot channel in the Channels 
palette, and choose Channel Options from the 
palette menu.

2 Click the color box, and choose a color. 
(See “Using the Adobe Color Picker” on 
page 198.) 

By selecting a custom color, your print service can 
more easily provide the proper ink to reproduce 
the image. For more information, see “Choosing 
custom colors (Photoshop)” on page 201.

3 For Solidity, enter a value between 0% 
and 100%. 

This option lets you simulate on-screen the 
solidity of the printed spot color. A value of 100% 
simulates an ink that completely covers the inks 
beneath (such as a metallic ink); 0% simulates a 
transparent ink that completely reveals the inks 
beneath (such as a clear varnish). You can also use 
this option to see where an otherwise transparent 
spot color (such as a varnish) will appear.

Note: The Solidity option affects only the on-screen 
preview. It has no effect on the printed output.

4 Click OK.

To merge spot channels:

1 Select the spot channel in the Channels palette.

2 Choose Merge Spot Channel from the 
palette menu.

The spot color is converted to and merged with the 
color channels. The spot channel is deleted from 
the palette.
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Merging spot channels flattens layered images. 
The merged composite reflects the preview spot 
color information, including the Solidity settings. 
For example, a spot channel with a solidity of 50% 
will produce different merged results from the 
same channel with a solidity of 100%.

In addition, the resulting merged spot channels 
usually won’t reproduce the same colors as the 
original spot channels, because CMYK inks can’t 
represent the range of colors available from spot 
color inks.

Adjusting overlapping spot colors 

To prevent overlapping spot colors from printing 
over, or knocking out, the underlying spot color, 
remove one of the spot colors where they overlap. 
To help you predict how colors will look when 
printed, use a printed sample of the overprinted 
inks to adjust your screen display.

Note: In some cases, you may want colors to 
overprint, such as in varnishes and bump plates.

To adjust overlapping spot colors:

1 In the Channels palette, select the spot channel 
with the color you want to print.

2 Choose Select > Load Selection.

To quickly select an image in a channel, hold 
down Ctrl (Windows) or Command 

(Mac OS), and click the channel in the Channels 
palette.

3 For Channel, choose the spot channel from 
step 1 and click OK.

4 To create trap when knocking out the under-
lying color, choose Select > Modify > Expand or 
Contract depending on whether the overlapping 
spot color is darker or lighter than the spot color 
beneath it. For more information on trapping, 
see “Creating color traps” on page 408.

5 In the Channels palette, select the underlying 
spot channel that contains areas you want to 
knock out. Press Delete.

This method can be used to knock out areas 
from any channels under a spot color, such as 

the CMYK channels.

6 If a spot color in one channel overlaps more 
than one other spot color, repeat this process for 
each channel that contains areas you want 
removed. 

About masks
Masks let you isolate and protect areas of an image 
as you apply color changes, filters, or other effects 
to the rest of the image. When you select part of an 
image, the area that is not selected is “masked” or 
protected from editing. You can also use masks for 
complex image editing such as gradually applying 
color or filter effects to an image.

In addition, masks let you save and reuse time-
consuming selections as alpha channels. (Alpha 
channels can be converted to selections and then 
used for image editing.) Because masks are stored 
as 8-bit grayscale channels, you can refine and 
edit them using the full array of painting and 
editing tools.
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When a mask channel is selected in the Channels 
palette, foreground and background colors appear 
as grayscale values. (See “Creating temporary 
masks in Quick Mask mode” on page 215.)

A. Opaque mask used to protect the background and color the 
shell. B. Opaque mask used to protect the shell and color the 
background. C. Semitransparent mask used to color the back-
ground and part of the shell.

In Photoshop, you can create masks, all stored 
at least temporarily as grayscale channels, in 
three ways:

• Quick Mask mode lets you create and view a 
temporary mask for an image. Temporary masks 
are useful when you don’t want to save the mask 
for later use. (See “Creating temporary masks in 
Quick Mask mode” on page 215.)

• Alpha channels let you save and load a selection 
to be used as a mask (See “Storing masks in alpha 
channels” on page 217).

• Layer masks let you control how different areas 
within a layer are covered or revealed. By making 
changes to the layer mask, you can apply a variety 
of special effects. (See “Using layer masks” on 
page 239.)

Creating temporary masks in 
Quick Mask mode
Quick Mask mode lets you edit any selection as a 
mask without using the Channels palette and 
while viewing your image. The advantage of 
editing your selection as a mask is that you can use 
almost any Photoshop tool or filter to modify the 
mask. For example, if you create a rectangular 
selection with the marquee tool, you can enter 
Quick Mask mode and use the paintbrush to 
extend or contract the selection, or use a filter to 
distort the edges of the selection. You can also use 
selection tools, because the quick mask is not a 
selection.

Start with a selected area and use Quick Mask 
mode to add to or subtract from it to make the 
mask, or create the mask entirely in Quick Mask 
mode. Color differentiates the protected and 
unprotected areas. When you leave Quick Mask 
mode, the unprotected areas become a selection.

A temporary Quick Mask channel appears in the 
Channels palette while you work in Quick Mask 
mode. However, you do all mask editing in the 
image window. 

To create a temporary mask:

1 Using any selection tool, select the part of the 
image you want to change.

2 Click the Quick Mask mode button ( ) in the 
toolbox.

A B C
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<<keep this piece?>>

Selected area, and Quick Mask mode applied

A color overlay (similar to a piece of rubylith) 
covers and protects the area outside the selection. 
The original selection is left unprotected by this 
mask. By default, Quick Mask mode colors the 
protected area using a red, 50% opaque overlay. 

3 To edit the mask, select a painting or editing 
tool from the toolbox, or select a filter or 
adjustment command from the menu bar. By 
default, painting with black adds to the mask, 
shrinking the selection. Painting with white 
removes areas from the mask, expanding the 
selection. Painting with gray or another color 
creates a semitransparent area, useful for feath-
ering or anti-aliased effects.

4 Click the Standard mode button ( ) in the 
toolbox to turn off the quick mask and return to 
your original image. A selection border now 
surrounds the unprotected area of the quick mask.

The selection boundary indicates where 50% of 
the pixels are selected. That is, if a feathered mask 
is converted into a selection, the boundary line 
runs halfway between the black pixels and the 
white pixels of the mask gradient.

5 Apply the desired changes to the image. 
Changes affect only the selected area.

6 Choose Select > Deselect to deselect the 
selection, or save the selection as described in the 
saving procedures on page 15. <<X-ref to which 
procedure?>>

To change the Quick Mask options:

1 Double-click the Quick Mask mode button 
( ) in the toolbox.

2 Choose from the following display options:

• Masked Areas (the default) to have masked 
(protected or unselected) areas appear black 
(opaque), and to have selected areas appear white 
(transparent). Painting with black increases the 
masked, protected area; painting with white 
increases the selected area.

With this option, the Quick Mask button in the 
toolbox appears as a white circle on a gray 
background ( ).

• Selected Areas to have masked or protected areas 
appear white (transparent) and to have selected 
areas appear black (opaque). Painting with white 
increases the masked, protected area; painting 
with black increases the selected area.

With this option, the Quick Mask button in the 
toolbox appears as a gray circle on a white 
background ( ).

To toggle between the Masked Areas and 
Selected Areas options for quick masks, Alt-click 

(Windows) or Option-click (Mac OS) the Quick 
Mask mode button.

3 To choose a new mask color, click the color box 
and choose a new color. (See “Using the Adobe 
Color Picker” on page 198.)
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4 To change the opacity, enter a value between 0% 
and 100%. 

Both the color and opacity settings affect only the 
appearance of the mask and have no effect on how 
underlying areas are protected. Changing these 
settings may make the mask more easily visible 
against the colors in the image.

5 Click OK.

Storing masks in alpha channels
In addition to the temporary masks of Quick Mask 
mode, you can create more permanent masks by 
storing them in alpha channels. This allows you to 
use the masks again in the same image or in a 
different image.

You can either create an alpha channel and then 
add a mask to it or save an existing selection as an 
alpha channel.

About alpha channels

An alpha channel has these properties:

• Each image can contain up to 24 channels, 
including all color and alpha channels.

• All channels are 8-bit grayscale images, capable 
of displaying 256 levels of gray.

• You can specify a name, color, mask option, and 
opacity for each channel. (The opacity affects the 
preview of the channel, not the image.)

• All new channels have the same dimensions and 
number of pixels as the original image.

• You can edit the mask in an alpha channel using 
the painting and editing tools.

Creating alpha channels

You can create a new alpha channel and then use 
painting or editing or tools to add the mask to it.

To create an alpha channel using current options:

1 Click the New Channel button ( ) at the 
bottom of the Channels palette. The new channel 
is named according to the sequence in which it was 
created.

2 Use a painting or editing tool to paint in the 
image. Paint with black to add to the channel; 
paint with white to remove from the channel; 
paint with a lower opacity or a color to add to the 
channel with lower opacities. 

To create an alpha channel and specify options:

1 Do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) 
the New Channel button ( ) at the bottom of the 
palette. 

• Choose New Channel from the Channels 
palette menu.

2 Type a name for the channel. 

3 Select display options for the channel, as 
described in steps 2 through 4 of the procedure on 
Quick Mask options in “Creating temporary 
masks in Quick Mask mode” on page 215. Alpha 
channel options are identical to Quick Mask 
options. 

4 Click OK. A new channel appears at the bottom 
of the Channels palette and is the only channel 
visible in the image window.
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5 Use a painting or editing tool to paint in the 
image. Paint with black to add to the channel; 
paint with white to remove from the channel; 
paint with a lower opacity or a color to add to the 
channel with lower opacities. 

Saving a mask selection

You can save any selection as a mask in a new or 
existing alpha channel.

To save a selection to a new channel with default 
options:

1 Select the area or areas of the image that you 
want to isolate.

2 Click the Save Selection button ( ) at the 
bottom of the Channels palette. A new channel 
appears, named according to the sequence in 
which it was created.

To save a selection to a new or existing channel:

1 Select the area or areas of the image that you 
want to isolate. 

2 Choose Select > Save Selection.

3 For Document, choose a destination image for 
the selection.

By default, the selection is placed in a channel in 
your active image. You can choose to save the 
selection to a channel in another open image with 
the same pixel dimensions or to a new image.

4 Choose a destination channel for the selection. 

By default, the selection is saved in a new channel. 
You can choose to save the selection to any existing 
channel in the selected image or to a layer mask if 
the image contains layers. 

5 If you’re saving the selection to an existing 
channel, select how to combine the selections: 

• Replace Channel to replace the current selection 
in the channel.

• Add to Channel to add the selection to the 
current channel contents.

• Subtract from Channel to delete the selection 
from the channel contents.

• Intersect with Channel to keep the areas of the 
new selection that intersect with the channel 
contents.

6 Click OK.

Select the channel in the Channels palette to see 
the saved selection displayed in grayscale.

Modifying alpha channels

You can edit an alpha channel to add or remove 
color in it, and you can specify settings for the 
masking colors and opacity.

For information on rearranging, duplicating, or 
deleting alpha channels, see “Managing channels” 
on page 207.

To edit an alpha channel:

Use a painting or editing tool to paint in the image. 
Paint with black to add to the channel; paint with 
white to remove from the channel; paint with a 
lower opacity or a color to add to the channel with 
lower opacities. 
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To change an alpha channel’s options:

1 Do one of the following:

• Select the channel in the Channels palette, and 
choose Channel Options from the palette menu.

• Double-click the channel name in the Channels 
palette.

2 Enter a new name for the channel.

3 Choose display options, as explained in steps 2 
through 4 of the procedure on Quick Mask 
options in “Creating temporary masks in Quick 
Mask mode” on page 215.

See “Modifying spot channels” on page 213 for 
information on changing Spot Color channel 
options.

Note: You cannot modify options for the default color 
channels. 

Loading a selection into an image

When you have finished modifying an alpha 
channel or simply want to use a previously saved 
selection, you can load the selection into the 
image.

To load a saved selection using shortcuts:

Do one of the following in the Channels palette:

• Select the alpha channel, click the Load Selection 
button ( ) at the bottom of the palette, and then 
click the composite color channel near the top of 
the palette.

• Ctrl-click (Windows) or Command-click 
(Mac OS) the channel containing the selection you 
want to load.

• To add the mask to an existing selection, press 
Ctrl+Shift (Windows) or Command+Shift 
(Mac OS), and click the channel.

• To subtract the mask from an existing selection, 
press Ctrl+Alt (Windows) or Command+Option 
(Mac OS), and click the channel.

• To load the intersection of the saved selection 
and an existing selection, press Ctrl+Alt+Shift 
(Windows) or Command+Option+Shift 
(Mac OS), and select the channel.

To load a saved selection into an image:

1 Choose Select > Load Selection. For Document, 
the active filename is selected.

2 For Channel, choose the channel containing the 
selection you want to load.

3 Click Invert to make the nonselected areas 
selected and vice versa.

4 If the destination image already has a selection, 
indicate how to combine the selections. (For infor-
mation on these options, see step 5 of the 
procedure on saving a selection to a new or 
existing channel in “Creating alpha channels” on 
page 217.)

5 Click OK to load the selection.

To load a selection from another image:

1 Open the two images you want to use. 

Note: The images must have identical pixel dimen-
sions. See “Changing the pixel dimensions of an 
image” on page 29.

2 Make the destination image active, and choose 
Select > Load Selection.
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3 For Document, choose the source image.

4 For Channel, choose the channel containing the 
selection you want to use as a mask.

5 Click Invert if you want to make the nonselected 
areas selected and vice versa.

6 If the destination image already has a selection, 
indicate how to combine the selections. (For 
information on these options, see step 5 of the 
procedure on saving a selection to a new or 
existing channel in “Creating alpha channels” on 
page 217.)

7 Click OK.

Extracting objects from their 
background (Photoshop)
The Extract command provides a sophisticated 
way to isolate a foreground object from its 
background. Even objects with wispy, intricate, or 
undefinable edges may now be clipped from their 
backgrounds with a minimum of manual work. 
You must be working in a layer to use the 
Extract command.

To extract an object, you use tools in the Extract 
dialog box to highlight the edges of the object. 
Then you define the object’s interior and preview 
the extraction. You can refine and preview the 
extraction as many times as you wish. When you 
are ready to perform the extraction, Photoshop 
erases the background to transparency, leaving just 
the extracted object.

<<May reorganize procedure in next draft>>

To extract an object from its background:

1 In the Layers palette, select the layer containing 
the object you want to extract. 

To avoid losing the original image information, 
duplicate the layer or make a snapshot of the 
original image state. For information on 
snapshots, see “Making a snapshot of an image 
(Photoshop)” on page 147. 

<<You can also select an area of the image before 
you extract, but it doesn’t look like there’s much 
advantage in doing that. Mention?>>

2 Choose Image > Extract.

The Extract dialog box appears. You use the tools 
in this dialog box to specify which part of the 
image to extract. If necessary, resize the dialog box 
by dragging its lower right corner.

3 Specify options for tools in the dialog box:

• For Brush Size, enter a value or drag the slider to 
specify the width of tools used to define an 
extraction boundary.

• For Highlight, choose a preset color option, or 
choose Other to specify a custom color for the 
highlight.

• For Fill, choose a preset color option, or choose 
Other to specify a custom color for the area 
covered by the fill tool.

• If you are highlighting a well-defined edge, select 
Smart Highlighting. This option helps you keep 
the highlight on the edge. 

Smart Highlighting can greatly improve results 
when you are tracing a sharp edge between a 

foreground and background that have similar colors 
or that are have texture. 



221ADOBE PHOTOSHOP 6.0
User Guide

4 Select the edge highlighter tool ( ) in the dialog 
box, and drag in the preview to highlight the edge 
of the object you want to extract.

Use the following techniques to enhance the effec-
tiveness of your highlight:

• Draw the highlight so that it slightly overlaps 
both the foreground and background regions 
around the edge. For fuzzy edges, such as hair or 
fur, cover areas where the foreground blends into 
the background.

• Use a smaller brush to highlight sharper edges 
more precisely. Use a larger brush to highlight 
wispy, intricate edges such as hair or trees, loosely 
covering the entire “question” area of edges.

• To base the highlight on a selection saved in an 
alpha channel, choose the alpha channel from the 
Channel menu. The alpha channel should be 
based on a selection of the edge boundary, rather 
than the object itself. If you modify a highlight 
based on a channel, the channel name in the menu 
changes to Custom.

• To turn Smart Highlighting on or off while you 
drag, press Ctrl (Windows) or Command 
(Mac OS). 

• If the object has a well-defined interior, make 
sure that the highlight forms a complete enclosure. 
You do not need to highlight areas where the 
object touches the image boundaries.

• To erase the highlight, select the eraser tool ( ) 
in the dialog box, and drag over the highlight. This 
tool is available when a highlight exists. You can 
completely erase the highlight by pressing 
Alt+Backspace (Windows) or Option+Delete 
(Mac OS).

• To switch between the edge highlighter tool and 
the eraser tool while you drag, press Alt 
(Windows) or Option (Mac OS).

• To magnify the preview, select the zoom tool 
( ) in the dialog box, and click in the preview. 
To zoom out, hold down Alt (Windows) or Option 
(Mac OS), and click with the zoom tool in 
the preview.

• To view a different part of the preview, select 
the hand tool in the dialog box and drag in the 
preview.

5 If the object has a well-defined interior, select 
the fill tool ( ) in the dialog box. This tool is 
available when a highlight exists. Click inside the 
object to fill its interior, and then skip to step 8.

6 If the object is especially intricate or lacks a clear 
interior, make sure that the highlight covers the 
entire object. To highlight the entire object, press 
Ctrl+Backspace (Windows) or Command+Delete 
(Mac OS). Then select Force Foreground. 

This technique works best with objects that 
contain tones of a single color. 

7 Select the eyedropper tool ( ) in the dialog box, 
and then click inside the object to sample the color 
to be treated as the foreground. You can also click 
in the Color text box and use a color picker to 
select the foreground color.

8 Click Preview to preview the extracted object.

Use the following techniques to view and refine 
the extraction:

• Use the Show menu to switch between previews 
of the original and extracted images.
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• Use the Display menu to preview the extracted 
object against a colored matte background or as a 
grayscale mask. To display a transparent 
background, choose None.

• Select the Show Highlight or Show Fill option to 
display the object’s extraction boundaries. 

• Use the cleanup tool (<<icon>>) to edit the 
extracted area. The tool, which is available when 
you show the extracted object, subtracts opacity 
and has a cumulative effect. Drag it over an area to 
erase to transparency. Hold down Alt (Windows) 
or Option (Mac OS) while dragging to add back 
opacity. 

You can also use the eraser and fill tools to edit the 
extracted area. Clicking a filled area with the fill 
tool removes the fill. If needed, you can change the 
colors of the highlight and fill to view them more 
clearly.

• Use the edge touchup tool (<<icon>>) to edit 
the extraction boundaries. The tool, which is 
available when you show the extracted object, 
sharpens edges and has a cumulative effect. If there 
is no clear edge, the edge touchup tool adds 
opacity to the object or subtracts opacity from the 
background. <<How does it distinguish these?>>

You can also use the edge highlighter and eraser 
tools to edit the extraction boundaries.

• Drag the Smooth slider or enter a value to help 
remove stray artifacts in the extraction.

When you are finished editing, click Preview again 
to view the edited extraction. You can edit and 
preview the extraction repeatedly until you 
achieve the desired result.

9 Click OK to apply the final extraction. All pixels 
on the layer outside the extracted object are erased 
to transparency. 

10 If necessary, use the background eraser and 
history brush tools to clean up any stray edges in 
the image.
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Chapter 10: Using Layers

hen you create, import, or scan an 
image in Photoshop or ImageReady, 
the image consists of a single layer. You 

can add more layers to the image, allowing you to 
organize your work into distinct levels.

About layers
A new image in Photoshop or ImageReady has a 
single layer. This layer is called the background 
layer and is analogous to the base layer of a 
painting. You cannot change the stacking order of 
a background layer or apply a blending mode or 
opacity to it (unless you convert it to a normal 
layer. 

You can add more layers for any changes you want 
to make to an image. For example, you might store 
photographs on separate layers and then combine 
them into one composite image. Think of the 
layers as sheets of acetate stacked one of top of the 
other. Where there is no image on a layer (that is, 
in places where the layer is transparent), you can 
see through to the layers below. All layers in a file 
share the same resolution, the same number of 
channels, and the same image mode (RGB, 
CMYK, or Grayscale).

<<ART: reshoot UI and keep both>>

Zebra is on topmost layer.

Transparent areas on a layer let you see through to the layers 
below.

W
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You can draw, edit, paste, and reposition elements 
on one layer without disturbing the others. Until 
you combine, or merge, the layers, each layer 
remains independent of the others in the image. 
This means you can experiment freely with 
graphics, type, opacities, and blending modes. In 
addition, special features such as layer masks, layer 
styles, and (in Photoshop) content layers <<name 
to change in product, name change will be tracked 
and text will be updated. Possibly will be called 
dynamic fill layers>> let you experiment with and 
apply sophisticated effects to layers. In 
ImageReady, you can also use layers to create 
rollover states and animations.

When you transfer a layered image between 
Photoshop and ImageReady, all layers, layer 
masks, layer styles, and content layers are 
preserved. (Content layers can be applied and 
edited only in Photoshop but can be viewed in 
ImageReady.)

<R1>: About layer sets
Layer sets help you organize and manage layers. 
You can expand a layer set to display the layers it 
contains or collapse it to reduce clutter. Only 
contiguous layers can be part of a layer set, 
however you can’t create or move one layer set 
within another. You can also use layer sets to apply 
masks to groups of layers.

Layer sets function like layers; you can view, select, 
duplicate, move, or change the stacking order of 
layer sets the same way you do layers. You can 
easily move layers into and out of layer sets, or 
create new layers within a layer set.

Using the Layers palette
The Layers palette lists all layers and layer sets in an 
image, starting with the topmost layer. A 
thumbnail of layer contents appears to the left of 
the layer name. It is updated as you edit. Use the 
scroll bars or resize the palette to see additional 
layers. Click the arrow (icon) to expand or collapse 
layer sets and layer effects.

<<These new layer features need to be included in 
this description of the palette: layer effects UI, 
clipping group UI, text layer UI, vector masks. 
ED: There are more than 2 paragraphs here, 
check to edit or remove last paragraph?>>

You use the Layers palette to create, hide, display, 
copy, merge, lock, and delete layers. (Additional 
commands appear in the menu.) Changes to an 
image affect only the highlighted or active layer. 
You select a layer to make it active, and only one 
layer can be active at a time. The active layer’s 
name appears in the image window’s title bar, and 
a paintbrush icon appears next to the layer in the 
Layers palette, indicating that the layer can be 
modified. A lock (icon) appears when the layer is 
locked and tools are not available when you try to 
use them on a locked layer.

You also use the Layers palette to apply layer masks 
(raster) and vector masks to a layer, layer styles, or 
content layers (formerly known as adjustment 
layers). You can use a clipping group to act as a 
mask for a group of layers or to specify a blending 
mode for group of layers. 
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<<ART: Keep and update the fig of the palette. 
Show expanded layer set, both kinds of locks, 
layer effects, various mask types, Text layer, clip-
ping group>>

A. Show/Hide B. Paintbrush icon  
C. Link/Unlink D. New Layer Mask  
E. New Layer F. Trash G. Thumbnail 
H. Highlighted layer is active layer.

To display the Layers palette:

Choose Window > Show Layers.

Viewing and selecting layers

With the Layers palette, you can control whether a 
layer or layer set is visible, whether a preview or 
thumbnail of a layer’s contents is displayed, and 
also how transparency is displayed. Turning off 
thumbnails or reducing their size can speed 
performance and save monitor space.

To show or hide a layer:

Do one of the following:

• In the Layers palette, click the eye icon next to a 
layer to hide that layer. Click in the column again 
to redisplay the layer. 

• Drag through the eye column to show or hide 
multiple layers.

• Alt-click (Windows) or Option-click (Mac OS) 
the eye icon for a layer to display just that layer. 
Alt-click (Windows) or Option-click (Mac OS) in 
the eye column again to redisplay all the layers. 

Only visible layers are printed. Making layers 
temporarily invisible can speed performance.

Note: You can make the active layer invisible. 
Keep in mind, however, that changes still affect 
the hidden, active layer.

To select a layer:

Do one of the following:

• In the Layers palette, click a layer to make 
it active.

• Select the move tool, right-click (Windows) or 
Control-click (Mac OS) in the image, and choose 
the layer you want from the context menu. The 
context menu lists all the layers that contain pixels 
under the current pointer location.

You can also select layers interactively as you use 
the move tool. (See “Moving selections and layers 
within an image” on page 152.)

To change the display of layer thumbnails:

1 Choose Palette Options from the Layers 
palette menu.

2 Click a size or click None to turn off the thumb-
nails, and click OK.
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Layer sets do not have thumbnails.

To display a layer in color in the palette:

1 Select the layer, and choose Layer Options from 
the Layers palette menu.

2 Choose a color from the menu, and click OK.

To change the transparency display:

1 Choose Edit > Preferences > Transparency & 
Gamut. By default, the transparent areas of a 
document appear as a checkerboard pattern.

2 For Grid Size, select a new size for the pattern. If 
you choose None, transparent areas in the layer 
appear white. 

3 For Grid Colors, select an option:

• Light, Medium, or Dark to specify a gray 
pattern. 

• Any other color from the list to display the 
checkerboard in that color.

• Custom to choose a color that does not appear in 
the list. Then click either of the color selection 
boxes to specify a custom color.

4 Click OK.

Changing the stacking order of layers

The stacking order determines whether a layer or 
layer set appears in front of or behind other layers. 
See “Grouping layers into sets” on page 230 to 
learn more about the stacking order within layer 
sets.

To change the order of a layer:

1 In the Layers palette, select the layer that you 
want to move.

2 Choose Layer > Arrange, and choose an option 
from the submenu to arrange the layer:

• Bring to Front to make the layer the topmost 
layer.

• Bring Forward to move the layer one level up in 
the stacking order.

• Send Backward to move the layer one level down 
in the stacking order.

• Send to Back to make the layer the bottommost 
layer in the image (except for the background).

To move a selected layer one level up in the 
Layers palette, press Ctrl+] (Windows) or 

Command+] (Mac OS). To move one level down, 
press Ctrl+[ or Command+[. To move to the 
topmost level, press Ctrl+Shift+] or 
Command+Shift+]. To move to the bottommost 
level (above the background), press Ctrl+Shift+[ or 
Command+Shift+[.

To change the order of layers by dragging:

1 In the Layers palette, select the layer or the layer 
set name you want to move.

2 Drag the layer up or down in the Layers palette. 
When the highlighted line appears in the desired 
position, release the mouse button. 

Note: By default, the background cannot be moved 
from the bottom of the layer list. To move the 
background, first convert it to a layer as described in 
the procedure to convert a background into a layer 
on page 235.
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Linking layers

By linking two or more layers, you can move their 
contents together. Layers within a layer set are 
implicitly linked but you can also link the layer set. 
You can link layers within layer sets, or link layers 
outside of a layer set to a layer set. You can also 
perform the following tasks on linked layers:

• Apply transformations. (See “Transforming 
objects in two dimensions” on page 161.)

• Align layer contents. (See “Moving the contents 
of layers” on page 230.)

• Merge layers. (See “Merging layers” on 
page 248.)

• Create clipping groups. (See “Creating clipping 
groups” on page 237.)

To link layers:

1 Select a layer in the Layers palette.

2 Click in the column immediately to the left of 
any layers you want to link to the selected layer. A 
link icon (<<icon>>) appears in the column. 

To unlink layers:

In the Layers palette, click the link icons to 
remove them.

Creating a layered image
You create up to 8000 layers in an image, each with 
its own blending mode and opacity. However, the 
amount of memory in your system may put a 
lower limit on the number of layers possible in a 
single image. 

Note: Images created using the Transparent option 
in the New dialog box are created without a 
background. Images with no background, as well as 
images with layers, can be saved only in the 
Photoshop format.

Adding layers

Newly added layers and layer sets appear above the 
selected layer in the Layers palette. You can add 
layers to an image in a variety of ways:

• By creating new layers or turning selections into 
layers. 

• By converting a background to a regular layer or 
adding a background to an image. 

• By pasting selections into the image. 
(See “Copying selections or layers” on page 153.)

• By creating type using the horizontal type tool or 
vertical type tool. (See “Creating type” on 
page 281.) 

To create a new layer using default options:

Click the New Layer button ( ) or New Layer Set 
button (icon) at the bottom of the Layers palette. 
The layer uses Normal mode with 100% opacity 
and is named according to its order of creation. 
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To add a new layer and specify options:

1 Do one of the following:

• Choose Layer > New > Layer or Layer > New > 
Layer Set.

• Choose New Layer or New Layer Set from the 
Layers palette menu.

• Alt-click (Windows) or Option-click (Mac OS) 
the New Layer button or New Layer Set button at 
the bottom of the Layers palette.

2 Name the layer, and select mode, opacity, and 
fill options as described in “Specifying layer 
options” on page 234. Then click OK.

To turn a selection into a new layer: 

1 Make a selection. 

2 Choose Layer > New, and choose a command 
from the submenu:

• To copy the selection into a new layer, choose 
Layer Via Copy.

• To cut the selection and paste it into a new layer, 
choose Layer > New > Layer Via Cut. 

The selection contents appear in the same position 
relative to the image boundaries.

To convert a background into a layer:

1 Double-click Background in the Layers palette. 

2 Enter a name, opacity, and mode for the layer. 
(See “Specifying layer options” on page 234.)

3 Click OK.

To add a background to an image:

Choose Layer > New > Background to create a 
Background layer filled with the current 
background color. (See “Choosing foreground and 
background colors” on page 195.)

You cannot change the stacking order of a 
background or apply a blending mode or opacity. 

Duplicating layers 

You can duplicate any layer (including the 
background) or any layer set within the same 
image. And you can copy any layer (including the 
background) or layer set from one image to 
another. 

When copying layers between images, keep in 
mind that the printed size of the copied layer 
depends on the resolution of the destination 
image. For example, if the source image has a 
lower resolution than the destination image, the 
copied layer will appear smaller in the destination 
image when printed. (See “About image size and 
resolution” on page 21.)

To duplicate a layer in an image:

1 Select the layer in the Layers palette. 

2 Duplicate the layer:

• To duplicate and rename the layer, choose 
Layer > Duplicate Layer (or Layer >Duplicate 
Layer Set) or choose Duplicate Layer (or Duplicate 
> Layer Set) from the Layers palette menu. Name 
the duplicate layer, and click OK.
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• To duplicate without naming, drag the layer 
name in the Layers palette to the New Layer button 
( ) or New Layer Set button (icon) at the bottom 
of the palette. The new layer is named according to 
its order of creation.

To copy a layer between images:

1 Open the two images you want to use.

2 In the Layers palette of the source image, select 
the name of the layer that you want to copy.

3 Copy the layer:

• Choose Select > All to select all of the pixels on 
the layer that fall inside the canvas boundaries, and 
choose Edit > Copy. Make the destination image 
active, and choose Edit > Paste. 

• Drag the layer’s name from the Layers palette 
into the destination image.

• Use the move tool ( ) to drag the layer from the 
source image to the destination image. The copied 
layer appears in the destination image where you 
release the mouse button (and above the active 
layer in the Layers palette). If the layer you’re 
dragging is larger than the destination image, only 
part of the layer is visible, but its contents remain 
available. Use the move tool to drag other sections 
of the layer into view. 

Hold down Shift as you drag a layer to copy it 
in the same position it occupied in the source 

image (if the source and destination images have the 
same pixel dimensions) or to the center of the desti-
nation image (if the source and destination images 
have different pixel dimensions).

To copy multiple layers into another image:

1 Make sure that both the source and destination 
images are open, and select one of the layers you 
want to copy.

2 In the Layers palette, click in the column 
immediately to the left of any additional layers you 
want to move. The link icon appears in the 
column. 

3 Use the move tool ( ) to drag the linked layers 
from the source image to the destination image.

To duplicate a layer into another image or a new 
image:

1 If you plan to copy a layer to an existing image, 
open both the source and destination images.

2 In the source document’s Layers palette, select 
the name of the layer you want to duplicate.

3 Duplicate the layer:

• Choose Layer > Duplicate Layer or Layer > 
Duplicate Layer Set.

• Choose Duplicate Layer or Duplicate Layer Set 
from the Layers palette menu. 

4 Type a name for the duplicate layer.

5 For Document, choose a destination for the 
layer. To create a new document for the layer, 
choose New, and type a name for the new 
document. 

6 Click OK.

An image created by duplicating a layer has no 
background. 
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Grouping layers into sets
You group layers into layer sets in the palette. Layer 
sets allow you to easily move the layers as a group, 
apply attributes or a mask to the group, or collapse 
the group to reduce clutter.

<<ED: Most of this information is woven into 
earlier tasks, remove it from there and centralize 
it here, or remove it from here? Should we remove 
this entire section? If so, note to self, check for 
xrefs.>>

To create a new layer set:

Do one of the following:

• In the Layers palette, click the New Layer Set 
button (icon) at the bottom of the palette. The new 
layer set appears above the currently selected layer 
or layer set.

• Choose Layer > New Layer Set.

• Choose New Layer Set from the Layers palette 
menu.

• Choose Layer > New Layer Set From Linked, if 
you have linked layers.

To drag layers into a set:

• If the layer set is collapsed, drag the layer to the 
layer set folder (icon) or the layer set name. When 
the arrow appears in the layer set, release the 
mouse button. The layer is placed at the bottom of 
the layer set.

• If the layer set is expanded, you can drag the 
layer to the desired location within the layer set. 
When the highlighted line appears in the desired 
location, release the mouse button.

To drag layers out of a set:

• Drag the layer up or down in the Layers palette. 
When the highlighted line appears in the desired 
location, release the mouse button.

To collapse or expand a layer set:

• Click the triangle (icon) to expand the layer set 
and display the layers.

• Click the down triangle (icon) to collapse the 
layer set and display only the layer set name.

Moving the contents of layers
Repositioning a layer or layer set moves its 
contents on the image. You can reposition a layer 
manually using the move tool, or you can align 
and distribute a linked group of layers.

You can also lock a layer to prevent the contents 
from being moved on the image. However, a 
locked layer can be moved above or below other 
layers. (See “Locking layers” on page 233 to learn 
about all of the lock options.)

Repositioning layers

You can reposition the contents of individual 
layers layer sets, or linked layers within the image’s 
boundaries, unless move (<<icon>>) in the 
Layers palette is selected. If a layer set is locked, 
none of the layers contained in the set can be 
moved.

To reposition a layer in an image:

1 In the Layers palette, select the layer that you 
want to move.
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2 Select the move tool ( ). To activate the move 
tool when any other tool is selected, hold down 
Ctrl (Windows) or Command (Mac OS).

3 Drag anywhere in the image to move the 
selected layer into the desired position. To 
constrain the direction of movement to a multiple 
of 45°, hold down Shift as you drag.

To reposition the layer in 1-pixel increments 
when the move tool is selected, press the arrow 

keys on the keyboard. To move the layer in 10-pixel 
increments (or to move one frame if you’re editing a 
filmstrip file), press Shift and an arrow key.

To reposition multiple layers:

1 In the Layers palette, link the layers you want to 
move. (See “Linking layers” on page 227.)

2 Use the move tool ( ) to move the linked layers 
in the image window.

<<ART: reshoot UI and keep>>

Lion and zebra layers linked and moved

Aligning and distributing linked layers

The Align Linked commands let you align the 
contents of linked layers to the contents of the 
active layer or to a selection border. The Distribute 
Linked commands let you position the contents of 
linked layers at evenly spaced intervals.

You can’t align a layer set. You need to link all of the 
layers within the set, then align them.

To align or distribute linked layers:

1 To align layers to a selection border, make a 
selection.

2 In the Layers palette, specify the layers you want 
to align or distribute:

• To align a single layer to a selection, make the 
layer active.

• To align multiple layers to a selection or to the 
active layer, link together two or more layers.

• To distribute multiple layers, link together three 
or more layers.

For more information, see “Linking layers” on 
page 227.

3 To align layers, choose Layer > Align Linked (or 
Align To Selection if you made a selection), and 
choose an option from the submenu:

• Top to align the topmost pixel on the linked 
layers to the topmost pixel on the active layer or 
the topmost edge of the selection border.

• Vertical Center to align the vertical centermost 
pixel on the linked layers to the vertical centermost 
pixel on the active layer or the vertical center of the 
selection border.
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• Bottom to align the bottommost pixel on the 
linked layers to the bottommost pixel on the active 
layer or the bottommost edge of the selection 
border.

• Left to align the leftmost pixel on the linked 
layers to the leftmost pixel on the active layer or the 
leftmost edge of the selection border.

• Horizontal Center to align the horizontal 
centermost pixel on the linked layers to the 
horizontal centermost pixel on the active layer or 
the horizontal center of the selection border.

• Right to align the rightmost pixel on the linked 
layers to the rightmost pixel on the active layer or 
the rightmost edge of the selection border.

4 To distribute layers, choose Layer > Distribute 
Linked, and choose an option from the submenu:

• Top to space the linked layers evenly starting 
from the top pixel on each layer.

• Vertical Center to space the linked layers evenly 
starting from the vertical centermost pixel on each 
layer.

• Bottom to space the linked layers evenly starting 
from the bottom pixel on each layer.

• Left to space the linked layers evenly starting 
from the leftmost pixel on each layer.

• Horizontal Center to space the linked layers 
evenly starting from the horizontal centermost 
pixel on each layer.

• Right to space the linked layers evenly starting 
from the rightmost pixel on each layer.

Note: Photoshop aligns and distributes only those 
layers whose pixels have greater than 50% opacity. 
For example, the Align Linked > Top command 
aligns to the topmost pixel on the active layer that is 
more than 50% opaque.

Editing layers
A newly created layer or layer set is transparent. 
You can add color values to the layer using the 
painting and editing tools, and then apply a layer 
style, filters, or use special effects to modify the 
layer. All painting and editing occurs on the active 
layer (and in the active channel).

Preserving a layer’s transparency

You can confine your painting and editing to those 
areas of a layer already containing pixels. For 
example, you may want to edit an object (adding 
special effects, changing color) without adding 
pixels to the transparent area outside the object.

To confine editing to the opaque portions of a layer:

1 Select the layer in the Layers palette.

2 Select Preserve Transparency in the Layers 
palette.

Note: For type layers, Preserve Transparency is on by 
default and cannot be turned off.
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Sampling from all layers

By default, when working with the magic wand, 
smudge, blur, sharpen, rubber stamp, or pattern 
stamp tool, you are applying color sampled only 
from pixels on the active layer. This means you can 
smudge or sample in a single layer even when 
other layers are visible, and you can sample from 
one layer and paint in another one. 

Alternatively, you can choose to paint using 
sampled data from all the visible layers. For 
example, you can use the rubber stamp tool to 
clone an area containing pixels from all the visible 
layers and layer sets.

To sample from all visible layers:

1 Double-click the magic wand tool ( ), smudge 
tool ( ), blur tool ( ), sharpen tool ( ), rubber 
stamp tool ( ), or pattern stamp tool ( ) to 
display its options bar.

2 Select Use All Layers in the options bar.

Note: Unless you are using the rubber stamp tool, 
painting or editing in a new layer produces the best 
results when Use All Layers is selected.

Filling a new layer with a neutral color

Some layer effects (such as the Lighting Effects 
filter) cannot be applied to layers with no pixels. 
Selecting Fill with Neutral Color in the New Layer 
dialog box resolves this problem by first filling the 
layer with a preset, neutral color. If no effect is 
applied, filling with a neutral color has no effect on 
the remaining layers. The Fill with Neutral Color 
option is not available for layers that use the 
Normal, Dissolve, Hue, Saturation, Color, or 
Luminosity modes. (See “Adding layers” on 
page 227.)

Note: Not all filters produce a visible effect when 
applied to a layer filled with a neutral color.

Locking layers

You lock layers or layer sets to make certain 
properties of a layer unchangeable. When a layer is 
locked, a lock displays to the right of the layer 
name. The lock is solid (icon) when no properties 
can be changed and is hollow (icon) when only the 
transparency and layer masks are locked. You can 
also lock the image so it can’t be moved with the 
move tool. Locked layers can still be moved to a 
different location within the Layers palette, but 
they can’t be deleted. 

To lock layers:

1 Select the layer, then do one of the following:

• Click the Lock button (icon) in the Layers 
palette.

• Choose Lock All Layers in Set from the Layers 
palette menu.

• Choose Layers > Lock All Layers in Set.
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2 Select one of the following Preserve options:

• None to make all properties editable.

• Transparency to lock the opacity and blending 
mode setting for the layer.

• Image to lock the image data but the opacity and 
blending modes can be adjusted.

3 To prevent a layer from moving, do one of the 
following:

• Click move (icon) in the Layers palette to disable 
the move tool and prevent the layer from being 
moved.

To lock linked layers:

Select the linked layer, then do the following:

• Click the Lock button (icon) in the Layers 
palette.

• Choose Lock All Linked Layers from the Layers 
palette menu.

• Choose Layers > Lock All Linked Layers.

Specifying layer options
The layer options let you change a layer or layer 
set’s name and its color in the palette, and the 
blending options let you change its opacity and 
blending with the pixels underneath. It’s 
important to remember that the opacity and 
blending modes chosen for a specific layer interact 
with the opacity and mode settings for the tools 
you use to paint and edit the pixels on the layer. 

<<Track: layer options name may change for 
Photoshop>>

<<I think the new RGB checkboxes restrict 
blending into a subset of composite channels. Talk 
about that in the section on using channel calcs to 
blend layers (later in the chapter)?>>

For example, suppose you are working on a layer 
that uses the Dissolve mode and an opacity of 
50%. If you paint on this layer using the paint-
brush tool set to Normal mode with an opacity of 
100%, the paint will appear in Dissolve mode with 
a 50% opacity because this is the maximum the 
layer can display.

On the other hand, suppose you are working on a 
layer created using Normal mode and 100% 
opacity. If you use the eraser tool with an opacity 
of 50%, only 50% of the paint will disappear as you 
erase. For more information on painting blending 
modes, see “Selecting a blending mode” on 
page 188.

To choose options for a layer:

1 Do one of the following:

• Double-click the layer’s name in the Layers 
palette. (This method does not apply to most 
content layers in Photoshop.)

• Select the layer in the Layers palette, and choose 
Layer > Layer Options.

• Select the layer in the Layers palette, and choose 
Layer Options from the palette menu.

2 To change the name of the layer as it appears in 
the Layers palette, type a new name.

3 To change the color of the layer in the palette, 
choose a color from the menu. 
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4 (ImageReady) To group this layer with the 
previous layer, select Group With Previous Layer.

5 (ImageReady) Set one of the following Preserve 
options:

• None to allow the layer to be edited.

• Transparency to lock the opacity and blending 
mode settings for the layer.

• Image to lock all image data for the layer.

6 To lock the position of the image on the layer, 
select Lock Position. 

7 To prevent the layer from being edited, select 
Lock Layer. 

To choose opacity and blending options for a layer:

1 To change the blending mode and opacity of 
layers but not layer sets, select the layer in the 
Layers palette, and do one of the following:

• (ImageReady) Choose Layers > Layer Options.

• (ImageReady) Choose Layer Options from the 
palette menu.

• (Photoshop) Choose Layers > Layer Style > 
Blending Options.

• (Photoshop) Choose Blending Options from the 
palette menu.

2 To set blending modes, select a Mode 
(ImageReady) or Blend Mode (Photoshop). 
(See “Specifying layer blending modes” on 
page 236.)

3 To set opacity or fill opacity, drag the slider. 
(See “Specifying opacity” on page 235.)

4 To specify which layers get knocked out within a 
layer set, select a Knockout option. (See “Speci-
fying advanced blending options” on page 236.)

5 To restrict blending into composite channels 
deselect one or more Channel options. <<To come, 
RGB section need to explain/ add xref here>>

6 <<To come: add blend interior effects as a group 
and blend clipped layers as a group steps here, need 
to explain/xref>>

7 (Photoshop) To turn off previewing as you 
choose layer options, deselect Preview in the 
Blending Options dialog box.

8 Click OK. 

Specifying opacity

You can change the opacity of each layer or layer 
set using either the Opacity option in the Layer 
Options dialog box (ImageReady), Blending 
Options dialog box (Photoshop), or the Opacity 
slider in the Layers palette. A layer with 1% opacity 
appears nearly transparent, one with 100% 
opacity completely opaque.

You cannot change the opacity of an image that 
has only a background, a locked layer, or a layer 
set.

Fill opacity affects only the fill of an object rather 
than the entire layer. 

To specify opacity for a layer:

Do one of the following:

• In the Layers palette, enter a value for Opacity or 
drag the slider.
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• In the Layer Options dialog box (ImageReady) 
or the Blending Options dialog box (Photoshop), 
enter a value for Opacity.

• To specify fill opacity for a layer, In the Layer 
Options dialog box (ImageReady) or the Blending 
Options dialog box (Photoshop), enter a value for 
Fill Opacity.

If you have selected a tool without an opacity 
option in its Options palette, use the following 

shortcuts to change the opacity of the active layer: 
• Press a number key to set the opacity in multiples 
of 10% (pressing 1 sets to 10%, pressing 0 sets to 
100%). 
• To specify an exact opacity, type the desired value.

Specifying layer blending modes

You use layer blending modes to determine how 
the pixels in a layer are blended with underlying 
pixels on other layers. By applying modes to 
individual layers, you can create a variety of special 
effects. You can’t set a blending mode for a layer 
set, only the individual layers.

Note: There is no Clear blending mode for layers. In 
addition, the Color Dodge, Color Burn, Darken, 
Lighten, Difference, and Exclusion modes are 
unavailable for Lab images.

To specify a blending mode for a layer:

Do one of the following:

• In the Layers palette, choose an option from the 
mode menu.

• (ImageReady) In the Layer Options dialog box, 
choose a Mode option.

• (Photoshop) In the Blending Options dialog 
box, choose a Blend Mode option.

Specifying advanced blending options

<<Intro to be updated, once I determine whether 
RGB options are discussed here or elsewhere>>

The knockout options allow you to specify which 
layers are “punched through” to reveal content 
from other subsequent layers. If you are using a 
layer set, you can knockout to the bottom layer in 
the layer set, or you can knockout all of the way to 
the background layer. You can knockout a content 
layer that adjusts the color of an image to reveal a 
portion of the image using the original colors.

<<Need to add Advanced blending options: blend 
interior effects/clipped layers as a group
Should RGB channels be described here or much 
later?>>

To specify a knockout mode:

1 Display the Advanced Blending options by 
doing the following:

• (Photoshop) Choose Layer > Layer Style > 
Blending Options.

• (ImageReady) Choose Layer > Layer Options.

2 Choose one of the following Knockout options:

• None to knockout no layers.

• Shallow to knockout to the bottom of a layer set. 
<<or clipping group?>>

• Deep to knockout to the background layer. If 
there is no background layer, it knocks out to 
transparency.
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<<ART: NEW show layers that create knockout 
effect with image.>> 

Specifying a range for blending layers 
(Photoshop)

The sliders in the Blending Options dialog box let 
you control which pixels from the active layer and 
which from the underlying visible layers blend and 
appear in the final image. For example, you can 
drop dark pixels out of the active layer or force 
bright pixels from the underlying layers to show 
through. You can also define a range of partially 
blended pixels to produce a smooth transition 
between blended and unblended areas. 

To define a range for the blending operation: 

1 In the Blending Options dialog box, select a 
Blend If option:

• Gray to specify a blending range for all channels. 

• An individual color channel (for example, red, 
green, or blue in an RGB image) to specify 
blending in that channel. (See “Color channels 
(Photoshop)” on page 50.)

2 Use the This Layer and Underlying sliders to set 
the brightness range of the blended pixels—
measured on a scale from 0 (black) to 255 (white). 
Drag the white slider to set the high value of the 
range. Drag the black slider to set the low value of 
the range. 

3 To define a range of partially blended pixels, 
hold down Alt (Windows) or Option (Mac OS), 
and drag one half of a slider triangle. The two 
values that appear above the divided slider indicate 
the partial blending range. 

Keep the following guidelines in mind when speci-
fying blending ranges:

• Use the This Layer sliders to specify the range of 
pixels on the active layer that will blend and 
therefore appear in the final image. For example, if 
you drag the white slider to 235, pixels with 
brightness values higher than 235 will remain 
unblended and be excluded from the final image. 

• Use the Underlying sliders to specify the range of 
pixels in the underlying visible layers that will 
blend in the final image. Blended pixels are 
combined with pixels in the active layer to produce 
composite pixels, while unblended pixels show 
through overlying areas of the active layer. For 
example, if you drag the black slider to 19, pixels 
with brightness values lower than 19 will remain 
unblended and show through the active layer in 
the final image.

Creating clipping groups
In a clipping group, the bottommost layer, or base 
layer, acts as a mask for the entire group. For 
example, you might have a shape on one layer, a 
texture on the overlying layer, and some text on the 
topmost layer. If you define all three layers as a 
clipping group, the texture and the text appear 
only through the shape on the base layer and take 
on the opacity of the base layer.

In a clipping group, you are creating only a path. 
In a vector mask <<possibly called layer clipping 
path>> you are also creating a path but the layer 
has its own characteristics such as fill, opacity, 
blending mode, and so on.
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<<We need to talk about how these compare and 
interact with layer sets. Also, there will probably 
be a new icon identifying clipping groups in the 
palette. Do any Advanced Blending options 
including knockout/blend clipped effects as group 
need to be discussed here? >>

Note that only successive layers can be included in 
a clipping group. When you create a clipping 
group, dotted lines appear between the grouped 
layers in the Layers palette. The name of the base 
layer in the group is underlined, and the thumb-
nails for the overlying layers are indented. 
Applying a blending mode to an indented layer 
affects only the blending of the layers within the 
group. Applying a blending mode to the base layer 
determines how the entire clipping group blends 
with the underlying layers. 

<<ART: Keep. Update this with the new 
palette.>>

Clipping group with Layer 1 and lion layers

To create a clipping group:

1 Do one of the following:

• Hold down Alt (Windows) or Option (Mac OS), 
position the pointer over the solid line dividing 
two layers in the Layers palette (the pointer 
changes to two overlapping circles), and click.

• Select a layer in the Layers palette and choose 
Layer > Group with Previous.

• Link together the desired layers in the Layers 
palette, as described in “Linking layers” on 
page 227. Then choose Layer > Group Linked.

The clipping group is assigned the opacity and 
mode attributes of the bottommost layer in the 
group. 

To remove a layer from a clipping group:

Do one of the following:

• Hold down Alt (Windows) or Option (Mac OS), 
position the pointer over the dotted line 
separating two grouped layers in the Layers palette 
(the pointer changes to two overlapping circles), 
and click.

• In the Layers palette, select a layer in the clipping 
group, and choose Layer > Ungroup. This 
command removes the selected layer and any 
layers above it from the clipping group.

To ungroup all layers in a clipping group:

1 In the Layers palette, select the base layer in the 
clipping group.

2 Choose Layer > Ungroup.
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Using layer masks 
You can create a layer mask to control how 
different areas within a layer or layer set are hidden 
and revealed. By making changes to the layer 
mask, you can apply a variety of special effects to 
the layer without actually affecting the pixels on 
that layer. You can then apply the mask and make 
the changes permanent or remove the mask 
without applying the changes. You can save all 
layer masks with a layered document.

There are two types of masks: layer masks (or 
raster masks), and layer clipping paths (or vector 
masks). <<This section needs rework pending name 
change of vector mask to layer clipping paths.>> You 
can use one or both types of mask on a single layer 
or layer set. A layer mask is resolution dependent 
and is created using the painting or selection tools 
while a layer clipping path allows you to clip a layer 
using resolution-independent hard edges created 
by the pen or shape tools. 

In the Layers palette, both types of mask appear as 
an additional thumbnail to the right of the layer 
thumbnail. For the layer mask, this thumbnail 
represents the grayscale (alpha) channel created 
when you add the layer mask. (See “Storing masks 
in alpha channels” on page 217.)

<<ART: Keep: Merge info from next two and 
update this with the new palette to show both 
layer and vector masks.>>

A. Layer mask selected B. Mask link icon
C. Layer mask D. New Layer Mask

Adding layer masks

You can mask an entire layer or layer set, or just a 
selected part of it. 

To add a mask that shows or hides the entire layer:

1 If needed, choose Select > Deselect to clear any 
selection borders in the image.

2 In the Layers palette, select the layer to which 
you want to add a mask.

3 Do one of the following:

• To create a mask that reveals the entire layer, 
click the New Layer Mask ( ) button at the 
bottom of the Layers palette, choose Layer > Add 
Layer Mask > Reveal All, or choose Layer > Add 
Layer Clipping Path > Reveal All.

A DCB
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• To create a mask that hides the entire layer, 
Alt click (Windows) or Option-click (Mac OS) 
the New Layer Mask button, choose Layer > Add 
Layer Mask > Hide All, or choose Layer > Add 
Layer Clipping Path > Hide All 

To add a mask that shows or hides a selection:

1 In the Layers palette, select the layer to which 
you want to add a mask.

2 Select the desired area in the image.

3 To create a mask that reveals the selected area 
and hides the remaining portion of the layer, do 
one of the following:

• Click the New Layer Mask button ( ), or 
choose Layer > Add Layer Mask > Reveal 
Selection.

• Choose > Add Layer Clipping Path> Current 
Path. Then draw a path using the pen or vector 
shape tools. When you close the path, the interior 
of the path is revealed.

To create a mask that hides the selected area and 
reveals the remaining portion of the layer, do the 
following:

• Alt-click (Windows) or Option-click (Mac OS) 
the New Layer Mask button, or choose Layer > 
Add Layer Clipping Path > Hide Selection.

• Choose the pen (icon), freeform pen (icon) or 
one of the shape tools: rectangle (icon), ellipse 
(icon), polygon (icon), line (icon), or custom 
shape tool (icon), then select shape layer on the 
options bar. Drag or marquee-drag to create a 
shape. <<ED: list all pen and shape tools with their 
icons, or can we group them into pen and shape 
tools?>> 

<<ART: cut both but merge this info with prior, 
adding vector example.>>

Selection

Layer mask revealing selection

For information on viewing the contents of the 
layer mask channel, see “Viewing layer masks” on 
page 242.

Editing a layer mask

You edit a layer mask by adding to or subtracting 
from the masked region.

To edit a layer mask:

1 Click the layer mask thumbnail in the Layers 
palette to make it active (the mask icon appears to 
the left of the layer thumbnail).
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2 Select any of the editing or painting tools.

Because the layer mask is a grayscale alpha 
channel, the foreground and background colors 
default to grayscale values when the mask is active. 
As you edit, the mask thumbnail displays the 
changes. 

3 Do one of the following:

• To hide the layer and add to the mask, paint the 
mask with black.

<<ART: cut 2, keep “neck painted with gray”, 
combine info from all but improve>>

Head and background painted with black

• To reveal the layer and subtract from the mask, 
paint the mask with white.

Head painted with white

• To make the layer partially visible, paint the 
mask with gray.

Neck painted with gray

To edit the layer instead of the layer mask, make 
the layer active by clicking its thumbnail in the 
Layers palette. The paintbrush icon appears to 
the left of the thumbnail to indicate that you are 
editing the layer.

To paste a selection into a layer mask, 
Alt-click (Windows) or Option-click (Mac OS) 

the layer mask thumbnail in the Layers palette to 
select and display the mask channel. Choose Edit > 
Paste, drag the selection in the image to produce the 
desired masking effect, and choose Select > Deselect. 
Click the layer thumbnail in the Layers palette to 
deselect the mask channel.

Editing a vector mask (Photoshop)

You edit a vector mask by changing the vector 
object. To edit a vector mask, see “Adjusting paths 
(Photoshop)” on page 135. <<ED: May want to 
change this section title, I replaced most of section 
with xref at last moment, due to likely name 
change to layer clipping path>>
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You can also convert a vector mask into a layer 
mask. Once the vector object has been rasterized, 
it can not be changed back into a vector object. 

To remove a vector mask;

1 Click the vector mask in the Layers palette to 
make it active.

2 Do one of the following;

• Drag the vector mask to the trash.

• Choose Layers > Remove Vector Mask > 
Discard.

To convert a vector mask to a layer mask:

1 Click the vector mask in the Layers palette to 
make it active.

2 Choose Layers > Remove Vector Mask > 
Rasterize.

Unlinking layers and layer masks

By default, a layer is linked to its layer mask or 
masks, as indicated by the link icon between the 
thumbnails in the Layers palette. The layer and its 
layer masks move together in the image when you 
move either one with the move tool.

You can unlink the layer from its layer masks by 
clicking the link icon. Unlinking them lets 
you move them independently and shift the mask 
boundaries separately from the layer. To re-
establish the link, click between the layer and 
layer mask thumbnails.

Viewing layer masks

By default, the layer mask channel does not appear 
in the image. You can view and edit the contents of 
the mask or temporarily turn off its effects. You 
can also change the display options for the mask.

To select and display the layer mask channel:

Do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) 
the layer mask thumbnail to view only the 
grayscale mask. The eye icons in the Layers palette 
are dimmed because all layers are hidden. To 
redisplay the layers, again Alt/Option-click the 
layer mask thumbnail, or click an eye icon.

• Hold down Alt+Shift (Windows) or 
Option+Shift (Mac OS), and click the layer mask 
thumbnail to view the mask on top of the layer 
in a rubylith masking color. Hold down 
Alt+Shift/Option+Shift and click the thumbnail 
again to turn off the color display.

To turn off the layer mask temporarily:

1 Do one of the following:

• Press Shift and click the layer mask thumbnail in 
the Layers palette. 

• Choose Layer > Disable Layer Mask.

A red X appears over the layer mask thumbnail in 
the Layers palette, and the entire underlying layer 
appears without masking effects. 

2 To turn on the mask, do one of the following:

• Click the layer mask thumbnail in the Layers 
palette.

• Choose Layer > Enable Layer Mask.
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To change the rubylith display for a layer mask:

1 Do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) 
the layer mask thumbnail to select the layer mask 
channel; then double-click the layer mask 
thumbnail. 

• Double-click the layer mask channel in the 
Channels palette.

2 To choose a new mask color, click the color 
swatch and choose a new color. (See “Using the 
Adobe Color Picker” on page 198.)

3 To change the opacity, enter a value between 0% 
and 100%.

Both the color and opacity settings affect only the 
appearance of the mask and have no effect on how 
underlying areas are protected. For example, 
changing these settings might make the mask 
more easily visible against the colors in the image.

4 Click OK.

Applying and discarding layer masks

When you have finished creating a layer mask, you 
can either apply the mask and make the changes 
permanent or discard the mask without applying 
changes. Because layer masks are stored as alpha 
channels, applying and discarding layer masks 
may help reduce file size. For more information, 
see “About channels” on page 205. 

To apply or discard a layer mask:

1 Click the layer mask thumbnail in the Layers 
palette.

2 To remove the layer mask and make changes 
permanent, do one of the following:

• Click the Trash button at the bottom of the 
Layers palette, then click Apply. 

• Choose Layer > Remove Layer Mask > Apply.

3 To remove the layer mask without applying the 
changes, do one of the following:

• Click the Trash button at the bottom of the 
Layers palette, then click Discard. 

• Choose Layer > Remove Layer Mask > Discard.

Selecting opaque areas on a 
layer
By loading a transparency mask, you can quickly 
select all the opaque areas on a layer—that is, the 
areas within the layer boundaries. This is useful 
when you want to exclude transparent areas from 
a selection. You can also load the boundaries of a 
layer mask as a selection.

To load a layer or layer mask’s boundaries as a 
selection:

Do one of the following:

• In the Layers palette, Ctrl-click (Windows) or 
Command-click (Mac OS) the layer or layer mask 
thumbnail.

• To add the pixels to an existing selection, press 
Ctrl+Shift/Command+Shift, and click the layer or 
layer mask thumbnail in the Layers palette.

• To subtract the pixels from an existing selection, 
press Ctrl+Alt/Command+Option, and click the 
layer or layer mask thumbnail in the Layers palette.
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• To load the intersection of the pixels 
and an existing selection, press 
Ctrl+Alt+Shift/Command+Option+Shift, 
and click the layer or layer mask thumbnail in 
the Layers palette.

To move all the contents of a layer, you 
can use the move tool without loading a trans-

parency mask.

Using content layers 
(Photoshop)
A content layer lets you experiment with color and 
tonal adjustments to an image without perma-
nently modifying the pixels in the image. The color 
and tonal changes reside within the adjustment 
layer, which acts as a veil through which the under-
lying image layers appear.

<<name will change, track the name, then 
change. Current suggestion “content layer” or 
“dynamic fill layer” apparently, can’t place on a 
layer set.>>

When you create a content layer, its effect appears 
on all the layers below it. This lets you correct 
multiple layers by making a single adjustment, 
rather than making the adjustment 
to each layer separately. 

Note: Content layers can be applied and edited only 
in Photoshop, but they can be viewed in 
ImageReady. Also, you can’t apply a content layer to 
a layer set, instead, Photoshop creates a new layer 
above the layer set. 

<<In Mark Hamburg’s 4/99 white paper on layer 
enhancements, there’s a note that we plan to 
allow adjustment layers at the base of clipping 
groups. I haven’t checked into this.>>

To confine the effects of a content layer to the 
layers immediately below it, create a clipping 

group consisting of these layers. (See “Creating 
clipping groups” on page 237.)
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<<ART: reshoot UI combine into one>>

Original

Levels adjustment applied to image

Levels adjustment clipped to zebra layer

Creating a content layer

Content layers have the same opacity and blending 
mode options as image layers and can be 
rearranged in order, deleted, hidden, and dupli-
cated in the same manner as well. However, you 
also specify a color adjustment type for a content 
layer. Depending on your choice, the dialog box 
for the selected adjustment command may appear. 
(See “Making Color and Tonal Adjustments” on 
page 85.) The content layer takes the name of the 
adjustment type and is indicated in the Layers 
palette by a partially filled circle (icon) to the right 
of the name. <<Most changes bars here are due to 
name change.>>

Content layers are also layer masks, as indicated by 
the mask icon to the left of the layer thumbnail. 
When a content layer is active, the foreground and 
background colors default to grayscale values. By 
painting the content layer, you can apply the 
content to just portions of the underlying layers. 

To create a content layer:

1 To confine the effects of the content layer to a 
selected area, first make a selection.

2 Do one of the following:

• Ctrl-click (Windows) or Command-click 
(Mac OS) the New Adjustment Layer button ( ) 
at the bottom of the Layers palette. <<track this 
with name change, icon here may need to change 
too>>

• Choose Layer > New Content Layer. <<track this 
with name change>>

3 Choose the adjustment you want to make. 
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4 Choose layer options as desired, and then 
click OK. (See “Specifying layer options” on 
page 234.)

5 If needed, make the desired adjustments and 
click OK. (See “Making Color and Tonal Adjust-
ments” on page 85.)

To edit a content layer:

1 Do one of the following:

• Double-click the content layer’s name in the 
Layers palette.

• Select the content layer’s name, and then choose 
Layer > Change Content. <<track this with name 
change>>

2 Make the desired adjustments, and click OK.

Note: If a content layer has no associated adjustment 
dialog box (for example, Invert Layer), double-
clicking the layer’s name opens the Layer Options 
dialog box.

To edit a content layer mask:

1 Select the content layer in the Layers palette.

2 Select any painting or editing tool.

3 Edit the content layer mask:

• To remove the adjustment effect, paint the 
content layer with black.

• To display the full effect of the adjustment over 
the image layers beneath, paint the content layer 
with white.

• To partially remove the adjustment effect, paint 
the content layer with gray.

4 Use the following methods to view the content 
layer mask:

• Alt-click (Windows) or Option-click (Mac OS) 
the adjustment layer thumbnail to view only the 
grayscale mask. Alt/Option-click the thumbnail 
again to redisplay the other layers.

• Hold down Alt+Shift (Windows) or 
Option+Shift (Mac OS), and click the content 
layer thumbnail to view the mask in a rubylith 
masking color. Hold down 
Alt+Shift/Option+Shift and click the thumbnail 
again to turn off the rubylith display.

• Shift-click the content layer thumbnail to turn 
off the masking effects temporarily; click the 
thumbnail again to turn on the mask.

Note: If you paint the content layer mask with black 
or gray, you can modify the boundaries and effects of 
the mask (by applying a filter, for example). Content 
layer masks that contain only white values are 
unaffected by most filters. 

Merging content layers

You can merge a content layer with the image layer 
below it, the layers in its clipping or linking group, 
or all other visible layers in the image. You cannot, 
however, merge a content layer exclusively with 
another content layer. When you merge a content 
layer with the layer below it, the adjustments 
become permanent and apply only within the 
merged layer. (See “Merging layers” on page 248.) 

Content layers whose masks contain only white 
values do not add significantly to the file size. As a 
result, it is not necessary to merge these content 
layers in an effort to conserve file space.
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Managing layered images
Adding nontransparent layers to an image 
increases its file size. To conserve disk space, you 
can delete layers or layer sets, merge two or more 
layers, or flatten all layers in an image into one 
layer. 

<<Most of these change bars are from moving this 
from an earlier place in the chapter.>>

Tracking file size

File size is proportional to the pixel dimensions of 
an image. Images with more pixels may produce 
more detail at a given printed size, but they require 
more disk space to store and may be slower to edit 
and print. You should keep track of your file sizes 
to make sure the files are not becoming too 
cumbersome.

To track file size:

Check the values in the Document Sizes box at the 
lower left corner of the screen (Windows) or the 
image window (Mac OS). For more information 
on displaying file size, see “Changing image size 
and resolution” on page 26.

The first (left) value indicates the size of the file if 
flattened. The second (right) value shows the 
estimated file size of the unflattened file, including 
any layers and channels.

To track the use of the Photoshop scratch disk 
(temporary disk space used for storing data 

when RAM is insufficient), position the pointer over 
the triangle at the bottom of the image window, hold 
down the mouse button, and choose Scratch Sizes. 
(See Using RAM, scratch disks, and system virtual 
memory.)<<xref destination?>>

Deleting a layer

Delete layers and layer sets you no longer need to 
reduce the size of your image file.

To delete a layer:

1 Select the layer in the Layers palette.

2 Delete the layer:

• Click the trash button at the bottom of the 
Layers palette, and click Yes. 

• Choose Layer > Delete Layer or Layer > Delete 
Layer Set.

• Choose Delete Layer or Delete Layer Set from 
the Layers palette menu. 

• Drag the layer name in the Layers palette to the 
trash button.

To delete a selected layer automatically, Alt-
click (Windows) or Option-click (Mac OS) the 

trash button at the bottom of the Layers palette. 
When you Ctrl-click (Windows) or Command-click 
(Mac OS) a layer set, only the layer set, not its 
contents are deleted. 
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Merging layers

Merging layers or layer sets combines several layers 
into one and keeps file size manageable. When 
you’ve finalized the characteristics and positioning 
of a layer’s contents, you can merge the layer with 
one or more layers to create partial versions of 
your composite image. The intersection of all 
transparent areas in the merged layers remains 
transparent. You can also merge the layers in a 
linked group or clipping group. (See “Creating 
clipping groups” on page 237.) 

For information on merging content layers, 
see “Merging content layers” on page 246.

To merge a layer with the layer below it:

1 Make sure that the two layers you want to merge 
are visible. Select the top layer of the pair in the 
Layers palette.

2 Merge the layer:

• Choose Layer > Merge Down or Layer > Merge 
Layer Set.

• Choose Merge Down or Merge Layer Set from 
the Layers palette menu.

To merge all visible linked layers:

1 Make visible all layers you want to merge, and 
link them together, as described in “Linking 
layers” on page 227. 

2 Do one of the following:

• Choose Layer > Merge Linked.

• Choose Merged Linked from the Layers palette 
menu.

To merge a clipping group:

1 Make visible all the layers in the group that you 
want to merge (any hidden layers in the group are 
discarded when you merge). 

2 Select the base layer in the group.

3 Do one of the following:

• Choose Layer > Merge Group.

• Choose Merge Group from the Layers palette 
menu.

To merge all the visible layers in an image:

1 Hide any layers you do not want to merge. Make 
sure that no layers are linked.

2 Do one of the following:

• Choose Layer > Merge Visible.

• Choose Merge Visible from the Layers 
palette menu.

To merge all visible layers into a new layer, 
create a new empty layer, hold down Alt 

(Windows) or Option (Mac OS), and choose 
Layer > Merge Visible.
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Flattening all layers

In a flattened image, all visible layers are merged 
into the background, greatly reducing file size. 
Flattening an image discards all hidden layers and 
fills the remaining transparent areas with white. In 
most cases, you won’t want to flatten a file until 
you have finished editing individual layers. 

Note: Converting an image between some color 
modes flattens the file. Be sure to save a copy of your 
file that includes all layers if you want to edit the 
original image after the conversion.

To flatten an image:

1 Make sure that all the layers you want to keep 
are visible.

2 Flatten the image:

• Choose Layer > Flatten Image.

• Choose Flatten Image from the Layers 
palette menu.

<<ART: reshoot UI and create before/after 
example>>

Layered file, and flattened file

Saving layered documents

You may want to save two versions of your file—a 
flattened version for final use and a second version 
with layers intact for future edits. 

The Save a Copy command makes it possible to 
save a copy to your disk (in this case a flattened 
copy) without replacing the active window. For 
more information on saving documents and 
determining file formats, see “Saving and 
Exporting Images” on page 375.

Using layer effects
You can apply a number of automated effects 
layers, including drop shadows, glows, bevelling, 
and embossing. When you apply a layer effect, an 
“f” icon ( ) appears to the right of the layer’s 
name in the Layers palette. Layer effects are linked 
to the layer contents. When you move or edit the 
contents on the layer, the effects are modified 
correspondingly. Layer effects are especially useful 
for enhancing type layers. Once effects have been 
applied to a layer, they become a layer style, and 
can be saved or edited. (See “Grouping layer effects 
into styles” on page 253.)

<<Monitor: We may need to reword the relation-
ship between individual effects and a layer 
style.>>

Note: You cannot apply layer effects to a background 
or to a layer set.

To hide or show all layer effects in the image:

Choose Layer > Layer Style> Hide All Layer Styles 
or Show All Layer Styles.
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Adding layer effects

You can apply effects in any combination to a layer.

• The Drop Shadow effect lets you add a shadow 
that falls behind the contents on the layer. 

• The Inner Shadow effect lets you add a shadow 
that falls just inside the edges of the layer contents, 
giving the layer a recessed appearance.

• The Outer Glow and Inner Glow effects let you 
add glows that emanate from the outside or inside 
edges of the layer contents.

• The Bevel and Emboss effect lets you add various 
combinations of highlights and shadows to a layer.

• The Satin effect lets you create a satiny finish on 
a layer.

• (Photoshop) The Overlay effects lets you overlay 
a color, gradient, or pattern on a layer. (This 
option corresponds to the Color Fill, Gradient Fill, 
and Pattern Fill options in ImageReady.)

• (ImageReady) The Fill effects allow you to fill a 
layer with a color, gradient, or pattern, and corre-
spond to the Overlay options in Photoshop.

• The Stroke effect lets you outline the object on 
the current layer using color, a gradient, or a 
pattern.

To apply a drop shadow or inner shadow:

1 Select the layer you want to use, and choose 
Layer > Layer Style > Drop Shadow or Inner 
Shadow. Or, click the effects button (<<icon>>) at 
the bottom of the Layers palette, and select a 
shadow effect from the list.

2 Specify blending mode, opacity, color, lighting 
angle, blur, and intensity options. (See “Specifying 
options for layer styles” on page 254.)

3 Specify the displacement of the shadow from 
the layer contents:

• For Distance, enter a value or drag the slider. 

• Drag the shadow in the image to reposition it. 
The distance and lighting angle values update as 
you drag. 

4 Click OK.

To apply an outer or inner glow:

1 Select the layer you want to use, and choose 
Layer > Layer Style > Outer Glow or Inner Glow. 
Or, click the effects button at the bottom of the 
Layers palette, and select a glow effect from the list.

2 Specify blending mode, opacity, color, blur, and 
intensity options, as described in “Specifying 
options for layer styles” on page 254.

3 If you are applying an inner glow, select a glow 
source option:

• Center to apply a glow that emanates from the 
center of the layer contents.

• Edge to apply a glow that emanates from the 
inside edges of the layer contents.

4 Click OK.

To apply bevelling or embossing:

1 Select the layer you want to use, and choose 
Layer > Layer Style > Bevel and Emboss. Or, click 
the effects button at the bottom of the Layers 
palette, and select Bevel and Emboss from the list.
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2 Specify blending mode, opacity, and color 
options for the highlight and shadow, as described 
in “Specifying options for layer styles” on 
page 254.

3 For Style, choose one of the following:

• Outer Bevel to create bevelling along the outside 
edges of the layer contents.

• Inner Bevel to create bevelling along the inside 
edges of the layer contents.

• Emboss to create the effect of embossing the 
layer contents against the underlying layers.

• Pillow Emboss to create the effect of stamping 
the edges of the layer contents into the underlying 
layers.

4 Specify lighting angle and blur options, as 
described in “Specifying options for layer styles” 
on page 254.

5 For Depth, enter a value or drag the slider. A 
higher value results in a more accentuated bevel.

6 Select Up or Down to indicate the position of 
the highlight in relation to the layer contents.

7 Click OK.

To apply a color, gradient, or pattern to a layer:

1 Select the layer you want to use and do one of 
the following:

• (Photoshop) Choose Layer > Layer Style > and 
select Color, Gradient, or Fill Overlay. Or choose 
Layer > Layer Style > Blending Options and 
choose Overlay. Then select an overlay fill type. Or, 
click the effects button at the bottom of the Layers 
palette, and select Color, Gradient, or Patter-
nOverlay. 

• (ImageReady) Choose Layer > Layer Style, and 
select Color, Gradient, or Pattern Fill. Or, click the 
effects button at the bottom of the Layers palette, 
and select Color, Gradient, or Pattern Fill.

2 Specify blending mode, opacity, color, blur, and 
intensity options, as described in “Specifying 
options for layer styles” on page 254.

To apply a satin effect to a layer:

1 Select the layer you want to use, and choose 
Layer > Layer Style > Satin Or, click the effects 
button at the bottom of the Layers palette, and 
select Satin from the list.

2 Specify blending mode, opacity, color, blur, and 
intensity options, as described in “Specifying 
options for layer styles” on page 254.

3 To customize the satin effect, <<add xref to 
Curves/Contour editor here>>

To apply a stroke effect to a layer:

1 Select the layer you want to use, and choose 
Layer > Layer Style > Stroke Or, click the effects 
button at the bottom of the Layers palette, and 
select Stroke from the list.

2 Specify blending mode, opacity, color, blur, and 
intensity options, as described in “Specifying 
options for layer styles” on page 254.

<<Note: monitoring menu name because menu 
name is under discussion.>>

To apply additional layer effects:

1 Do one of the following:
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• Choose another layer effect from the Layer Style 
dialog box, or click Prev or Next to cycle through 
the effects list. Select Apply, and specify options as 
described in the previous procedures.

• Choose another layer effect from the Layer > 
Layer Style submenu.

• Click the effects button in the Layers palette.

2 Specify options as described in the previous 
procedures.

Removing layer effects

You can remove an effect that you have applied to 
a layer.

To remove a layer effect:

1 In the Layers palette, select the layer containing 
the effect you want to remove.

2 Do one of the following:

• Choose the desired layer effect in the layers 
palette and drag it to the trash button.

• Hold down Alt (Windows) or Option (Mac OS) 
and select the layer effect you want to remove from 
the Layer > Layer Style menu. Applied effects have 
checkmarks next to their command names; 
removing a layer effect removes the checkmark. 

• (Photoshop) Choose Layers > Layer Style, and 
deselect the layer effect you want to remove. 

To remove all layer effects applied to a layer:

1 In the Layers palette, select the layer containing 
the effects you want to remove.

2 Do one of the following:

• In the Layers palette, drag the Effects bar to the 
trash button. <<ART: NEW show part of layers 
palette. Callout Effects bar.>>

• Choose Layer > Layer Style> Clear Layers.

Converting layer effects to layers 
(Photoshop)

To customize or fine-tune the appearance of layer 
effects, you can convert the effects to regular image 
layers. Once you have converted an effect to image 
layers, you can enhance the effect by painting or 
applying commands and filters. However, you can 
no longer edit the effect using the Layer Styles 
dialog box, and the effect will no longer update as 
you change the original image layer.

To convert a layer effect to image layers:

1 In the Layers palette, select the layer containing 
the effect you want to convert.

2 Choose Layer > Layer Style> Create Layer(s).

You can now modify and restack the new layers 
just like regular layers. Some effects (for example, 
inner glow) convert to layers within a clipping 
group. 
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Grouping layer effects into 
styles
Styles are sets of one or more layer effects and 
blending options that you can apply to any layer or 
vector object. You can apply predefined styles 
included with Photoshop and ImageReady, or you 
can define new styles by adding the effects you 
apply to a layer to the Styles palette. You can create, 
load, and save sets of styles using the Styles palette, 
the Style menu accessed from the options bar, or 
the Preset Manager. (See “Defining preset colors, 
patterns, and shapes” on page 194.)

Defining new styles

You define new styles by applying effects to a layer 
and adding those effects as a new style to the Styles 
palette. You can define a new style using a single 
effect or a group of effects.

To define a new style:

1 Apply effects to a layer. (See “Using layer effects” 
on page 249.)

2 Select a single effect or a group of effects:

• In the layers palette, click an individual effect 
name to select it. <<ART: NEW show part of layers 
palette. Callout Effects bar and which effect icon to 
click>>

• In the layers palette, click in the Effects bar in 
that layer or on the style icon (<<icon>>) next to 
the layer name to select all effects on a layer. 

• (Photoshop) Double-click an effect or the 
Effects bar. In the Layer Styles dialog box select 
additional effects if desired.

3 Create a new style:

• Drag the selected effect or style into the list in the 
Styles palette or onto the New Item button 
(<<icon>>) in the Styles palette. The effect or 
style is added as a new style (with a default name) 
in the Styles palette list.

• Click the New Item button (<<icon>>) at the 
bottom of the Styles palette, and give the style a 
name.

• Choose New Style from the Styles palette menu, 
and give the style a name.

• (Photoshop) In the Layer Styles dialog box, click 
New. Give the style a name and select Include 
Layer Effects or Include Layer Blending Options to 
include them in the new style.

If you create a new style using the New Item button 
or the New Style menu command, all effects on the 
current layer are included in the new style.

4 To rename a style you created by dragging, 
double-click the new style in the Styles palette, 
enter a name for the style, and then click OK.

Viewing styles

You can view styles in the Styles palette by name, 
by small swatch, or by large swatch.

To change the view of styles in the Styles palette:

Choose a view from the Styles palette menu:

• Select Name to view the styles as a list with small 
icons.

• Select Swatch to view the styles as swatches with 
no names.
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• Select Large Swatch to view the styles as a list, 
with a large swatch of the selected style displayed.

Styles are displayed in alphabetical order by name 
from top to bottom (and from left to right in 
Swatch view).

Applying styles to layers

You can apply styles to layers in any image. You can 
use a style to replace current effects applied to a 
layer, or add a style and preserve the existing effects.

To apply a style to a layer:

1 Select a method for applying the style:

• Double-click the style thumbnail to apply it to 
the currently selected layer in the active document.

• Drag the style thumbnail from the Styles palette 
onto a layer in the Layers palette. Press Shift while 
dragging to add the style while preserving effects 
on the destination layer that are not duplicated by 
the new style. (Any duplicated effects will be 
replaced by the new style.)

• Drag the style thumbnail from the Styles palette 
onto a document. The style is applied to the 
topmost layer where the style is dropped. Press 
Shift while dragging to preserve effects on the 
destination layer that are not duplicated by the 
new style. (Any duplicated effects will be replaced 
by the new style.) 

If a style is dragged onto a layer without pressing 
Shift, the style replaces any existing effects on the 
destination layer. 

To copy styles between layers:

1 In the Layers palette, select the source layer 
containing the style you want to copy.

2 Choose Layer > Layer Style > Copy Style.

3 Do one of the following:

• To paste into a single layer, select the destination 
layer in the palette and choose Layer > Layer Style 
> Paste Style.

• To paste into multiple layers, link the destination 
layers as described in “Linking layers” on page 227. 
Then choose Layer > Paste Layer Style to Linked.

The pasted effects will replace any existing effects 
on the destination layer or layers.

Editing layer styles

To edit the layer effects applied to a layer:

1 Double-click the layer effects icon ( ) in the 
Layers palette.

2 Choose Layer > Layer Style and select the 
desired layer effect from the Layer Styles dialog 
box, or click Prev or Next to cycle through the 
effects list. Edit options as described in “Adding 
layer effects” on page 250.

Specifying options for layer styles

When applying layer styles, you can specify a 
number of common options for each effect.

Preview Displays a preview of the layer style in the 
image as you change the layer effect settings.
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Mode (ImageReady) or Blend Mode (Photoshop) 
Determines how the layer style blends with the 
underlying layers, which may or may not include 
the active layer. For example, an inner shadow 
blends with the active layer because the effect is 
drawn on top of that layer, but a drop shadow 
blends only with the layers beneath the active layer. 
In most cases, the default mode for each effect 
produces the best results. (See “Specifying layer 
blending modes” on page 236.)

Opacity Sets the opacity of the layer effect as you 
enter a value or drag the slider.

Color Specifies the color of a shadow, glow, or 
highlight as you click the color box and choose a 
color. (See “Using the Adobe Color Picker” on 
page 198.)

Angle Determines the lighting angle at which the 
effect is applied to the layer. You can define a global 
angle that applies to all layer effects in the image; 
you can also assign a local angle that applies only 
to a specific layer effect. Using a global angle gives 
the appearance of a consistent light source shining 
on the image.

<<To come: Need to add more: distance, 
spread/choke, size, quality: shape, anti-aliased, 
noise, layer conceals drop shadow, and the rest 
common items in Layer Style dialog box; shape 
curve/Contour editor s/be xref ’d from here. 
Track: shape options different in IR and PS>>

To set a global lighting angle:

Do one of the following:

• In the Layer Style dialog box, select Use Global 
Light. For Angle, enter a value or drag the slider.

• Choose Layer > Layer Style> Global Light. Enter 
a value or drag the angle radius, and click OK.

The new lighting angle appears as the default for 
each layer effect that uses the global lighting angle.

To set a local lighting angle:

In the Layer Style dialog box, deselect Use Global 
Light. For Angle, enter a value or drag the angle 
radius.

Blur Creates a diffuse, softened effect as you enter 
a value or drag the slider.

Intensity Adjusts the strength of the effect as you 
enter a value or drag the slider. A higher value 
increases the strength of the effect.

<<add head2 for shape curve editor here? and 
xref to preset mgr for managing shape curves>>

Managing styles

Styles that appear in the Styles palette are located 
in the Styles folder in the Photoshop application 
folder. You can remove styles from the Styles 
palette by deleting them or by dragging them out 
of the Styles folder to store them in another 
location.

To delete styles from the Styles palette:

1 Select the style in the Styles palette.

2 Drag the style onto the trash button 
(<<icon>>) in the Styles palette. Or click the trash 
button, and click Delete to confirm the deletion.
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To remove styles from the Styles palette and store 
them in another location:

1 Open the Styles folder inside the application 
folder on your hard drive.

2 Locate the style or styles you wish to remove, 
and drag them to a new location on your 
computer. 

Styles removed from the Styles folder will be 
removed from the Styles palette after Photoshop is 
closed and reopened.

Using channel calculations to 
blend layers and channels 
(Photoshop)
You can use the blending effects associated with 
layers to combine channels within and between 
images into new images using the Calculations 
command (on single channels only) and the Apply 
Image command (on single and composite 
channels). These commands offer two additional 
blending modes not available in the Layers palette: 
Add and Subtract. Although it’s possible to 
combine channels into new combinations by 
copying channels into layers in the Layers palette, 
you may find it quicker to use the calculations 
commands to blend channel information. 

<<These change bars are from moving the section 
from an earlier place in the chapter.>>

<<Do the new RGB checkboxes in Blending 
Options apply to this?>>

The calculation commands perform mathematical 
operations on the corresponding pixels of two 
channels (the pixels with identical locations on the 
image) and then combine the results in a single 
channel. Two concepts are fundamental to under-
standing how the calculation commands work:

• Each pixel in a channel has a brightness value 
from 0 (off or black) to 255 (on or white). The 
Calculations and Apply Image commands manip-
ulate these values to produce the resulting 
composite pixels. 

• These commands overlay the pixels in two or 
more channels. Thus, the images used for calcula-
tions must have the same pixel dimensions. For 
information on adjusting an image’s pixel dimen-
sions, see “Changing image size and resolution” 
on page 26.

Using the Apply Image command

The Apply Image command lets you blend one 
image’s layer and channel (the source) with a layer 
and channel of the active image (the destination). 

To use the Apply Image command: 

1 Open the source and destination images, and 
make active the desired layer and channel in the 
destination image.

Pixel dimensions must match for the image names 
to appear in the Apply Image dialog box.

Note: If the color modes of the two images differ (for 
example, an RGB and a CMYK image), you can 
copy a single channel to another channel, but you 
cannot copy a composite channel to another image’s 
composite channel in another image. 
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2 Choose Image > Apply Image.

3 Choose the source image, layer, and channel you 
want to combine with the destination. To use all 
layers in the source image, select Merged for Layer. 

4 Select Preview to preview the results in the 
image window.

5 Select Invert to use the negative of the channel 
contents in the calculation.

6 For Blending, choose the blending option you 
want to apply.

Descriptions of the Add and Subtract options 
appear at the end of this section. Other blending 
options are the same ones listed in the options bar 
of the painting and editing tools and in the Layers 
palette. (See “Selecting a blending mode” on 
page 188.)

7 Enter an opacity for the effect’s strength. 

8 Select Preserve Transparency to apply the 
results only to opaque areas in the result layer.

9 Select Mask if you want to apply the blending 
through a mask. Then choose the image and layer 
containing the mask. For Channel, you can choose 
any color or alpha channel to use as the mask. You 
can also use a mask based on the active selection or 
the boundaries of the chosen layer (Transparency). 
Select Invert to reverse the masked and unmasked 
areas of the channel. (See “About masks” on 
page 214.)

10 Click OK to apply the blending effect.

Using the Calculations command

The Calculations command lets you blend two 
individual channels from one or more source 
images. You can then apply the results to a new 
image or to a new channel or selection in the active 
image. You cannot apply the Calculations 
command to composite channels.

To use the Calculations command:

1 Open the source image or images. The pixel 
dimensions of the images must match for image 
names to appear in the Calculations dialog box.

2 Choose Image > Calculations. 

3 To preview the calculation results in the image 
window, select Preview.

4 Choose the first source image, layer, and 
channel. To use all the layers in the source image, 
choose Merged for Layer. 

Select Invert to use the reversed contents, or 
negative, of the channel. For Channel, choose Gray 
to get the same effect as converting the image to a 
grayscale image.

5 Choose the second source image, layer, and 
channel, specifying further options as described in 
the previous step.

6 For Blending, choose the blending option you 
want to apply. 

A description of the Add and Subtract options 
appears at the end of this section. Other blending 
options are the same ones listed in the options bar 
of the painting and editing tools and in the Layers 
palette. (See “Selecting a blending mode” on 
page 188.)
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7 Enter an opacity for the effect’s strength. 

8 Select Mask if you want to apply the blending 
through a mask. Then choose the image and layer 
containing the mask. For Channel, you can choose 
any color or alpha channel to use as the mask. You 
can also use a mask based on the active selection or 
the boundaries of the chosen layer (Transparency). 
Select Invert to reverse the masked and unmasked 
areas of the channel. (See “About masks” on 
page 214.)

9 For Result, specify whether to place the 
blending results in a new image, or in a new 
channel or selection in the active image. 

10 Click OK to perform the calculation.

Calculations blending options

The Add and Subtract blending modes are 
available only with the Apply Image and Calcula-
tions commands. For a description of the 
remaining blending options. (See “Selecting a 
blending mode” on page 188.)

Add Adds the pixel values in two channels. This is 
a good way to combine nonoverlapping images in 
two channels.

Because higher pixel values represent lighter 
colors, adding channels with overlapping pixels 
lightens the image. Black areas in both channels 
remain black (0 + 0 = 0). White in either channel 
results in white (255 + any value = 255 or greater).

The Add option divides the sum of the pixel values 
by the Scale amount and then adds the Offset value 
to the sum. For example, if you wanted to find the 
average of the pixels in two channels, you would 
add them, divide by 2, and enter no Offset value.

The Scale factor may be any number between 
1.000 and 2.000. Entering a higher Scale value 
darkens the image. 

The Offset value lets you lighten or darken the 
pixels in the destination channel by any brightness 
value between +255 and –255. Negative values 
darken the image; positive values lighten the 
image. 

Subtract Subtracts the pixel values in the source 
channel from the corresponding pixels in the 
target channel. As with the Add option, the result 
is then divided by the Scale factor and added to the 
Offset value.

The Scale factor may be any number between 
1.000 and 2.000. The Offset value lets you lighten 
or darken the pixels in the destination channel by 
any brightness value between +255 and –255.
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Chapter 11: Applying Filters for 
Special Effects

ilters let you apply special effects to your 
images, such as impressionistic or mosaic 
effects, lighting effects, and distortions. You 

can also create your own effects using the Custom 
filter or the Filter Factory (included on the Adobe 
Photoshop CD-ROM).

About plug-in filters
You can install plug-in filters developed by non-
Adobe software developers. Once installed, the 
plug-in filters appear at the bottom of the Filter 
menu and work in the same way as built-in filters.

If you are interested in creating plug-in modules, 
contact Adobe Systems Developer Support. 
(See “Using plug-in modules” on page 15.)

Note: If you have problems or questions about third-
party plug-ins, contact the plug-in’s manufacturer 
for support.

Using filters
To use a filter, choose the appropriate submenu 
command from the Filter menu. These guidelines 
can help you in choosing filters:

• The last filter chosen appears at the top of 
the menu.

• Filters are applied to the active, visible layer.

• Filters cannot be applied to Bitmap-mode, 
indexed-color, or 16-bit per channel images.

• Some filters only work on RGB images.

• Some filters are processed entirely in RAM.

Previewing and applying filters

Applying filters—especially to large images—can 
be time-consuming. Some filters let you preview 
the effect before applying it.

To save time when trying various filters, exper-
iment on a small, representative part of your 

image or a low-resolution copy. 

To preview and apply a filter:

1 To apply a filter to an area of a layer, select that 
area. To apply a filter to the entire layer, leave the 
image unselected.

2 Choose a filter from the submenus in the 
Filter menu. If a filter name is followed by ellipses 
(…), a dialog box appears.

3 If a dialog box appears, enter values or select 
options.

To display the dialog box for the last filter you 
applied, press Ctrl+Alt+F (Windows) or 

Command+Option+F (Mac OS).

4 If the dialog box contains a preview window, use 
the following navigation methods to preview the 
effect:

F
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• Click in the image window to center a specific 
area of the image in the preview window. 

Note: This does not work with all preview windows.

• Drag in the preview window to center a specific 
area of the image in the window. 

• Use the + or – button under the preview window 
to zoom in or zoom out on the preview. 

A flashing line beneath the preview size indicates 
that the preview is still being rendered. 

5 If available, select the Preview option to preview 
the filter effect on the entire image.

6 Click OK to apply the filter. 

A progress indicator in the status bar (Windows) 
or progress bar (Mac OS) lets you gauge the time 
remaining until the filter is applied.

Blending filter effects (Photoshop)

The Fade command fades the effect of a filter, 
painting tool, or color adjustment. You choose a 
blending opacity and a mode to determine how 
pixels are modified. The blending modes available 
are a subset of those in the painting and editing 
tools options (excluding the Behind and Clear 
modes).

Applying the Fade command is similar to applying 
the filter effect on a separate layer and then using 
the layer opacity and blending mode controls. 
(See “Using content layers (Photoshop)” on 
page 244.)

Note: The Fade command can also be applied to 
Brush Strokes filters and any other painting tool.

To fade the effect of a filter, painting tool, or color 
adjustment:

1 Apply a filter or an Image > Adjust command to 
an image or selection.

2 With the affected area still selected, choose 
Filter > Fade.

3 Select the Preview option to preview the effect.

4 Drag the slider to adjust the opacity, from 0% 
(transparent) to 100%. (See “Specifying opacity, 
pressure, or exposure” on page 190.)

5 For Mode, choose a blending mode. 
(See “Selecting a blending mode” on page 188.)

Note: The Color Dodge, Color Burn, Lighten, 
Darken, Difference, and Exclusion modes do not 
work on Lab images.

6 Click OK. 

Loading images and textures

To produce their effects, some filters load and use 
other images, such as textures and displacement 
maps. These filters include the Conté Crayon, 
Displace, Glass, Lighting Effects, Rough Pastels, 
Texture Fill, Texturizer, Underpainting, and 
Custom filters.

Not all of these filters load images or textures in the 
same way. 

<<remove page references and change to online 
help reference.>>

<<icon>> For information on loading images and 
textures with Displace or Lighting Effects, see the 
Displace filter in “Distort filters” on page 267 or 
“Using a Lighting Effects texture” on page 280.
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To load images and textures:

1 Choose the filter you want from the appropriate 
submenu.

2 For Texture, choose Load Texture, and locate 
and open a texture image. 

All textures must be in the Photoshop format. 
Most filters use only the grayscale information of 
a color file.

3 Click OK.

Defining undistorted areas

The Displace, Shear, and Wave filters in the Distort 
submenu and the Offset filter in the Other 
submenu let you treat areas undefined by the filter 
in the following ways:

• Wrap Around fills the undefined space with 
content from the opposite edge of the image.

• Repeat Edge Pixels extends the colors of pixels 
along the image’s edge in the direction specified. 
Banding may result if the edge pixels are different 
colors.

• Set to Background (Offset filter only) fills the 
selected area with the current background color.

Using texture and glass surface controls

The Conté Crayon, Glass, Rough Pastels, 
Texturizer, and Underpainting filters have textur-
izing options. These options make images appear 
as if they were painted onto textures such as canvas 
and brick or viewed through glass blocks.

To use texture and glass surface controls:

1 From the Filter menu, choose Artistic > Rough 
Pastels, Artistic > Underpainting, Distort > Glass, 
Sketch > Conté Crayon, or Texture > Texturizer.

2 For Texture, choose a texture type or choose 
Load Texture to specify a Photoshop file.

3 Drag the Scaling slider to enlarge or reduce the 
effect on the image surface. 

4 Drag the Relief slider (if available) to adjust the 
depth of the texture’s surface.

5 Select Invert to reverse the surface’s light and 
dark colors.

6 For Light Direction, indicate the direction of the 
light source on the image.

7 Click OK.

Tips for creating special effects
Try the following techniques to create special 
effects with filters.

Create edge effects You can use various 
techniques to treat the edges of an effect applied to 
only part of an image. To leave a distinct edge, 
simply apply the filter. For a soft edge, feather the 
edge, and then apply the filter. For a transparent 
effect, apply the filter, and then use the Fade 
command to adjust the selection’s blending mode 
and opacity. (See “Blending filter effects 
(Photoshop)” on page 260.)
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Apply filters to layers You can apply filters to 
individual layers or to several layers in succession 
to build up an effect. For a filter to affect a layer, the 
layer must be visible and must contain pixels—for 
example, a neutral fill color. (See “Filling a new 
layer with a neutral color” on page 233.)

Apply filters to individual channels You can apply a 
filter to an individual channel, apply a different 
effect to each color channel, or apply the same 
filter but with different settings.

Create backgrounds By applying effects to solid-
color or grayscale shapes, you can generate a 
variety of backgrounds and textures. You might 
then blur these textures. Although some filters 
have little or no visible effect when applied to solid 
colors (for example, Glass), others produce inter-
esting effects. You might try Add Noise, Chalk & 
Charcoal, Clouds, Conté Crayon, Craquelure, 
Difference Clouds, Glass, Grain, Graphic Pen, 
Halftone Pattern, Mezzotint, Mosaic Tiles, Note 
Paper, Patchwork, Pointillize, Reticulation, Rough 
Pastels, Sponge, Stained Glass, Texture Fill, 
Texturizer, and Underpainting. 

Combine multiple effects with masks or with dupli-
cate images Using masks to create selection areas 
gives you more control over transitions from one 
effect to another. For example, you can filter the 
selection created with a mask. 

You can also use the history brush tool to paint a 
filter effect onto part of the image. First, apply the 
filter to an entire image. Next, step back in the 
History palette to the image state before the filter 
was applied, and set the history brush source to the 
filtered state. Then, paint the image. 
(See “Reverting to any state of an image” on 
page 144.)

Improve image quality and consistency You can 
disguise faults, alter or enhance, or make a series of 
images look related by applying the same effect to 
each. Use the Actions palette to record the 
process of modifying one image, and then use 
this action on the other images.(See “Automating 
Tasks” on page 415)

Improving performance with 
filters
Some filter effects can be memory intensive, 
especially when applied to a high-resolution 
image. You can use these techniques to improve 
performance:

• Try out filters and settings on a small portion of 
an image.

• Apply the effect to individual channels—for 
example, to each RGB channel—if the image is 
large and you’re having problems with insufficient 
memory. (With some filters, effects vary if applied 
to the individual channel rather than the 
composite channel, especially if the filter 
randomly modifies pixels.)
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• Experiment on a low-resolution copy of your 
file, and note the filters and settings used. Then 
apply the filters and setting to the high-resolution 
original.

• Free up memory before running the filter by 
using the Purge command. For more information, 
see “Correcting mistakes” on page 143.

• Allocate more RAM to Photoshop. If necessary, 
exit from other applications to make more 
memory available to Photoshop.

• Try changing settings to improve the speed of 
memory-intensive filters, such as Lighting Effects, 
Cutout, Stained Glass, Chrome, Ripple, Spatter, 
Sprayed Strokes, and Glass filters. (For example, 
with the Stained Glass filter, increase cell size. With 
the Cutout filter, increase Edge Simplicity, or 
decrease Edge Fidelity, or both.)

• If you plan to print to a grayscale printer, convert 
a copy of the image to grayscale before applying 
filters. However, applying a filter to a color image 
and then converting to grayscale may not have the 
same effect as applying the filter to a grayscale 
version of the image.

<<The following material is print only!>>

Choosing a filter effect
The built-in filters are grouped into 14 submenus. 
In addition, any third-party filters installed appear 
at the bottom of the Filter menu. 

For information on individual filters within 
these submenus, see online Help.

Artistic filters Achieve a painterly or special effect 
for a fine arts or commercial project. For example, 
use the Cutout filter for collages or type treatment. 
These filters replicate natural or traditional media 
effects. For information on the Rough Pastels and 
Underpainting filters, see “Using texture and glass 
surface controls” on page 261.

Blur filters Soften a selection or an image. Blur 
filters are useful for retouching. They smooth 
transitions by averaging the pixels next to the hard 
edges of defined lines and shaded areas in an 
image. 

Note: To apply a Blur filter to the edges of a layer, be 
sure to deselect the Preserve Transparency option in 
the Layers palette.

Brush Stroke filters Like the Artistic filters, the 
Brush Stroke filters give a painterly or fine-arts 
look using different brush and ink stroke effects. 
Some of the filters add grain, paint, noise, edge 
detail, or texture to an image for a pointillist effect. 

Distort filters Geometrically distort an image, 
creating 3D or other reshaping effects. Note that 
these filters can be very memory intensive. 
For more information about the Displace filter, 
see “Defining undistorted areas” on page 261 and 
online Help. For more on Glass filter controls, 
see “Using texture and glass surface controls” on 
page 261.
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Noise filters (Photoshop) Add or remove noise, or 
pixels with randomly distributed color levels. This 
helps to blend a selection into the surrounding 
pixels. Noise filters can create unusual textures or 
remove problem areas, such as dust and scratches, 
from an image. The Add Noise filter can be used to 
reduce banding in feathered selections or 
graduated fills or to give a more realistic look to 
heavily retouched areas.

For more on the Dust & Scratches filter, see 
online Help.

Pixelate filters Sharply define a selection by 
clumping pixels of similar color values in cells.

For more on the Color Halftone filter, see 
online Help.

Render filters Create 3D shapes, cloud patterns, 
refraction patterns, and simulated light reflections 
in an image. You can also manipulate objects in 3D 
space, create 3D objects (cubes, spheres, and 
cylinders), and create texture fills from grayscale 
files to produce 3D-like effects for lighting. For 
information on the 3D Transform filter, see 
“Transforming objects in three dimensions” on 
page 165.

For more information on the Lighting 
Effects filter, see online Help.

When using the Clouds filter, generate a more 
stark cloud pattern by holding down Alt 

(Windows) or Option (Mac OS) as you choose 
Filter> Render > Clouds.

Sharpen filters Focus blurry images by increasing 
the contrast of adjacent pixels. They include the 
Sharpen Edges (Photoshop) and Unsharp Mask 
filters, which find and sharpen areas where signif-
icant color changes occur (such as the edges). The 
Unsharp Mask filter is commonly used for high-
end color correction. (See “Sharpening an image” 
on page 112.)

Sketch filters Add texture to images, often for a 3D 
effect. The filters also are useful for creating a fine-
arts or hand-drawn look. Many of the Sketch 
filters use the foreground and background color as 
they redraw the image. For information on the 
Conté Crayon filter, see “Using texture and glass 
surface controls” on page 261.

For a truer effect, change the foreground color 
to one of the common Conté Crayon colors 

(black, sepia, sanguine) before applying the filter. 

Stylize filters Produce a painted or impressionistic 
effect on a selection by displacing pixels and by 
finding and heightening contrast in an image. 
After using filters such as Find Edges and Trace 
Contour (Photoshop) that highlight edges, you 
can apply the Invert command to outline the edges 
of a color image with colored lines or to outline the 
edges of a grayscale image with white lines. (See 
“Using the Invert command” on page 111.

For more on the Extrude filter, see online 
Help.

Texture filters Give images the appearance of 
depth or substance, or add an organic look. (See 
“Using texture and glass surface controls” on 
page 261.)
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Video filters Include the NTSC (National 
Television Standards Committee), which restricts 
the gamut of colors to those acceptable for 
television reproduction, and the De-Interlace 
filter, which smooths moving images captured on 
video. 

When creating images for use on television or 
video, use the Color Settings > RGB Setup 

command to set your RGB space to NTSC (1953).

Other filters Let you create your own filters, use 
filters to modify masks, offset a selection within an 
image, and make quick color adjustments. For 
more on the Offset filter, see “Defining undis-
torted areas” on page 261

For more information on the Custom filter, 
see online Help.

Digimarc filters Embed a digital watermark into an 
image to store copyright information.

For more information on Digimarc filters, 
see online Help.

<<The following material is help only!>>

<F>: Artistic filters
Choose a filter from the Artistic submenu to 
achieve a painterly or special effect for a fine arts or 
commercial project. For example, use the Cutout 
filter for collages or type treatment. These filters 
replicate natural or traditional media effects.

Colored Pencil Draws an image using colored 
pencils on a solid background. Important edges 
are retained and given a rough crosshatch 
appearance; the solid background color shows 
through the smoother areas.

For a parchment effect, change the background 
color just before applying the Colored Pencil 

filter to a selected area.

Cutout Portrays an image as though it were made 
from roughly cut-out pieces of colored paper. 
High-contrast images appear as if in silhouette, 
while colored images are built up from several 
layers of colored paper.

Dry Brush Paints the edges of the image using a dry 
brush technique (between oil and watercolor). 
The filter simplifies an image by reducing its range 
of colors to areas of common color.

Film Grain Applies an even pattern to the shadow 
tones and midtones of an image. A smoother, 
more saturated pattern is added to the image’s 
lighter areas. This filter is useful for eliminating 
banding in blends and visually unifying elements 
from various sources.

Fresco Paints an image in a coarse style using 
short, rounded, and hastily applied dabs.

Neon Glow Adds various types of glows to the 
objects in an image and is useful for colorizing an 
image while softening its look. To select a glow 
color, click the glow box and select a color from the 
color picker.

Paint Daubs Lets you choose from various brush 
sizes (from 1 to 50) and types for a painterly effect. 
Brush types include simple, light rough, light dark, 
wide sharp, wide blurry, and sparkle.
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Palette Knife Reduces detail in an image to give the 
effect of a thinly painted canvas that reveals the 
texture underneath.

Plastic Wrap Coats the image in shiny plastic, 
accentuating the surface detail.

Poster Edges Reduces the number of colors in an 
image (posterizes) according to the posterization 
option you set, and finds the edges of the image 
and draws black lines on them. Large broad areas 
of the image have simple shading while fine dark 
detail is distributed throughout the image.

Rough Pastels Makes an image appear as if stroked 
with colored pastel chalk on a textured 
background. In areas of bright color, the chalk 
appears thick with little texture; in darker areas, 
the chalk appears scraped off to reveal the texture. 
For more on the filter options, see “Using texture 
and glass surface controls” on page 261.

Smudge Stick Softens an image using short 
diagonal strokes to smudge or smear the darker 
areas of the images. Lighter areas become brighter 
and lose detail.

Sponge Creates images with highly textured areas 
of contrasting color, appearing to have been 
painted with a sponge.

Underpainting Paints the image on a textured 
background, and then paints the final image over 
it. For more on the filter options, see “Using 
texture and glass surface controls” on page 261.

Watercolor Paints the image in a watercolor style, 
simplifying details in an image using a medium 
brush loaded with water and color. Where signif-
icant tonal changes occur at edges, the filter 
saturates the color.

<F>: Blur filters
The blur filters soften a selection or an image, and 
are useful for retouching. They smooth transitions 
by averaging the pixels next to the hard edges of 
defined lines and shaded areas in an image. 

Note: To apply a Blur filter to the edges of a layer, be 
sure to deselect the Preserve Transparency option in 
the Layers palette.

Blur and Blur More (Photoshop) Eliminate noise 
where significant color transitions occur in an 
image. Blur filters smooth transitions by averaging 
the pixels next to the hard edges of defined lines 
and shaded areas. The Blur More filter produces an 
effect three or four times stronger than that of the 
Blur filter.

Gaussian Blur Quickly blurs a selection by an 
adjustable amount. Gaussian refers to the bell-
shaped curve that is generated when Adobe Photo-
shop applies a weighted average to the pixels. This 
filter adds low-frequency detail and can produce a 
hazy effect.

Motion Blur (Photoshop) Blurs in a particular 
direction (from –360º to +360º) and at a specific 
intensity (from 1 to 999). The filter’s effect is 
analogous to taking a picture of a moving object 
with a fixed exposure time.
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Radial Blur Simulates the blur of a zooming or 
rotating camera to produce a soft blur. Choose 
Spin, to blur along concentric circular lines, and 
then specify a degree of rotation; or Zoom to blur 
along radial lines, as if zooming in or out of the 
image, and specify an amount from 1 to 100. Blur 
quality ranges from Draft for the fastest but grainy 
results; or Good and Best for smoother results, 
which are indistinguishable except on a large 
selection. Specify the origin of the blur by dragging 
the pattern in the Blur Center box.

Smart Blur Precisely blurs an image. You can 
specify a radius, to determine how far the filter 
searches for dissimilar pixels to blur; a threshold, 
to determine how different the pixels’ values 
should be before they are eliminated; and a blur 
quality. You also can set a mode for the entire 
selection (Normal), or for the edges of color 
transitions (Edge Only and Overlay). Where 
significant contrast occurs, Edge Only applies 
black-and-white edges, and Overlay Edge applies 
white.

<F>: Brush Stroke filters
Like the Artistic filters, the Brush Stroke filters give 
a painterly or fine-arts look using different brush 
and ink stroke effects. Some of the filters add 
grain, paint, noise, edge detail, or texture to an 
image for a pointillist effect. 

Accented Edges Accentuates the edges of an image. 
When the edge brightness control is set to a high 
value, the accents resemble white chalk; when set 
to a low value, the accents resemble black ink.

Angled Strokes Repaints an image using diagonal 
strokes. The lighter areas of the image are painted 
in strokes going in one direction while the darker 
areas are painted in strokes going the opposite 
direction.

Crosshatch Preserves the details and features of the 
original image while adding texture and rough-
ening the edges of the colored areas in the image 
with simulated pencil hatching. The Strength 
option controls the number of hatching passes, 
from 1 to 3.

Dark Strokes Paints dark areas of an image closer 
to black with short, tight strokes, and paints lighter 
areas of the image with long, white strokes.

Ink Outlines Redraws an image with fine narrow 
lines over the original details, in pen-and-ink style.

Spatter Replicates the effect of a spatter airbrush. 
Increasing the options simplifies the overall effect.

Sprayed Strokes Repaints an image using its 
dominant colors with angled, sprayed strokes of 
color.

Sumi-e Paints an image in Japanese style, as if with 
a wet brush full of black ink on rice paper. The 
effect is soft blurry edges with rich blacks.

<F>: Distort filters
The Distort filters geometrically distort an image, 
creating 3D or other reshaping effects. Note that 
these filters can be very memory intensive.

Diffuse Glow Renders an image as though it were 
viewed through a soft diffusion filter. The filter 
adds see-through white noise to an image, with the 
glow fading from the center of a selection.
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Displace filter Uses an image, called a displacement 
map, to determine how to distort a selection. For 
example, using a parabola-shaped displacement 
map, you can create an image that appears to be 
printed on a cloth held at its corners.

Creates displacements maps using a flattened file 
saved in Adobe Photoshop format (except Bitmap 
mode images) or one that is saved with the Include 
Composite Image With Layered Files option 
selected in the Saving Files preferences. You can 
also use the files included with your software 
(search for the Dispmaps folder in Windows or the 
Displacement Maps folder in Mac OS). 

To use the Displace filter:

1 Choose Filter > Distort > Displace.

2 Enter the scale for the magnitude of the 
displacement.

When the horizontal and vertical scale are set to 
100%, the greatest displacement is 128 pixels 
(because middle gray produces no displacement).

3 If the displacement map is not the same size 
as the selection, choose how the map will fit the 
image—Stretch to Fit to resize the map, or Tile to 
fill the selection by repeating the map in a pattern.

4 Choose Wrap Around or Repeat Edge Pixels to 
determine how undistorted areas of the image will 
be treated. (See “Defining undistorted areas” on 
page 261.)

5 Click OK.

6 Select and open the displacement map. The 
distortion is applied to the image.

The Displace filter shifts a selection using a color 
value from the displacement map—0 is the 
maximum negative shift, 255 the maximum 
positive shift, and a gray value of 128 produces no 
displacement. If a map has one channel, the image 
shifts along a diagonal defined by the horizontal 
and vertical scale ratios. If the map has more than 
one channel, the first channel controls the 
horizontal displacement and the second channel 
controls the vertical displacement.

Glass Makes an image appear as if it is being 
viewed through different types of glass.You can 
choose a glass effect or create your own glass 
surface as a Photoshop file and apply it. You can 
adjust scaling, distortion, and smoothness 
settings. When using surface controls with a file, 
follow the instructions for the Displace filter. For 
more information about Glass filter controls, 
see “Using texture and glass surface controls” on 
page 261.

Ocean Ripple Adds randomly spaced ripples to the 
images surface, making the image look as if it were 
under water.

Pinch Squeezes a selection. A positive value up to 
100% shifts a selection toward its center; a negative 
value up to –100% shifts a selection outward.

Polar Coordinates Converts a selection from its 
rectangular to polar coordinates, and vice versa, 
according to selected option. You can use this filter 
to create a cylinder anamorphosis—art popular in 
the 18th century—in which the distorted image 
appears normal when viewed in a mirrored 
cylinder.
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Ripple Creates an undulating pattern on a 
selection, like ripples on the surface of a pond. For 
greater control, use the Wave filter. Options 
include the amount and size of ripples.

Shear Distorts an image along a curve. Specify the 
curve by dragging the line in the box to form a 
curve for the distortion. You can adjust any point 
along the curve. Click Default to return the curve 
to a straight line. In addition, you choose how to 
treat undistorted areas. For more information, 
see “Defining undistorted areas” on page 261.

Spherize Gives objects a 3D effect by wrapping a 
selection around a spherical shape, distorting the 
image and stretching it to fit the selected curve.

Twirl Rotates a selection more sharply in the 
center than at the edges. Specifying an angle 
produces a twirl pattern.

Wave Works in a similar way to the Ripple filter, 
but with greater control. Options include the 
number of wave generators, the wave-length 
(distance from one wave crest to the next), the 
height of the wave, and the wave type: Sine 
(rolling), Triangle, or Square. The Randomize 
option applies random values. You can also define 
undistorted areas. (See “Defining undistorted 
areas” on page 261 for more information.)

To replicate wave results on other selections, 
click Randomize, set the Number of Generators 

to 1, and set the minimum and maximum 
Wavelength and Amplitude parameters to the same 
value.

ZigZag Distorts a selection radially, depending on 
the radius of the pixels in your selection. The 
Ridges option sets the number of direction 
reversals of the zigzag from the center of the 
selection to its edge. You also choose how to 
displace the pixels: Pond Ripples displaces pixels to 
the upper left or lower right, Out From Center 
displaces pixels toward or away from the center of 
the selection, and Around Center rotates pixels 
around the center.

<F>: Noise filters (Photoshop)
The Noise filters add or remove noise, or pixels 
with randomly distributed color levels. This helps 
to blend a selection into the surrounding pixels. 
Noise filters can create unusual textures or remove 
problem areas, such as dust and scratches, from an 
image. 

Add Noise Applies random pixels to an image, 
simulating the effect of shooting pictures on high-
speed film. The Add Noise filter can also be used to 
reduce banding in feathered selections or 
graduated fills or to give a more realistic look to 
heavily retouched areas. Options include noise 
distribution: Uniform distributes color values of 
noise using random numbers between 0 and plus 
or minus the specified value for a subtle effect; and 
Gaussian distributes color values of noise along a 
bell-shaped curve for a speckled effect. The 
Monochromatic option applies the filter to only 
the tonal elements in the image without changing 
the colors.
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Despeckle Detects the edges in an image (areas 
where significant color changes occur) and blurs 
all of the selection except those edges. This blur-
ring removes noise while preserving detail.

Dust & Scratches Reduces noise by changing 
dissimilar pixels. To achieve a balance between 
sharpening the image and hiding defects, try 
various combinations of radius and threshold 
settings. Or apply the filter on selected areas in the 
image.

To use the Dust & Scratches filter:

1 Choose Filter > Noise > Dust & Scratches.

2 If necessary, adjust the preview zoom ratio until 
the area containing noise is visible. 

3 Drag the Threshold slider left to 0 to turn off the 
value, so that all pixels in the selection or image 
can be examined. 

The Threshold determines how different the 
pixels’ values should be before they are eliminated. 

Note: The Threshold slider gives greater control for 
values between 0 and 128—the most common range 
for images—than for values between 128 and 255.

4 Drag the Radius slider left or right, or enter a 
value in the text box from 1 to 16 pixels. The 
Radius determines how far the filter searches for 
differences among pixels. 

Adjusting the radius makes the image blurry. Stop 
at the smallest value that eliminates the defects.

5 Increase the threshold gradually by entering a 
value or by dragging the slider to the highest value 
possible that eliminates defects.

6 Click OK.

Median Reduces noise in an image by blending the 
brightness of pixels within a selection. The filter 
searches the radius of a pixel selection for pixels of 
similar brightness, discarding pixels that differ too 
much from adjacent pixels, and replaces the center 
pixel with the median brightness value of the 
searched pixels. This filter is useful for eliminating 
or reducing the effect of motion on an image.

<F>: Pixelate filters
The filters in the Pixelate submenu sharply define 
a selection by clumping pixels of similar color 
values in cells.

Color Halftone Simulates the effect of using an 
enlarged halftone screen on each channel of the 
image. For each channel, the filter divides the 
image into rectangles and replaces each rectangle 
with a circle. The circle size is proportional to the 
brightness of the rectangle. 

To use the Color Halftone filter:

1 Choose Filter > Pixelate > Color Halftone.

2 Enter a value in pixels for the maximum radius 
of a halftone dot, from 4 to 127.

3 Enter a screen-angle value (the angle of the dot 
from the true horizontal) for one or more 
channels:

• For Grayscale images use only channel 1. 

• For RGB images, use channels 1, 2, and 3, which 
correspond to the red, green, and blue channels. 

• For CMYK images, use all four channels, which 
correspond to the cyan, magenta, yellow, and 
black channels. 
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• Click Defaults to return all the screen angles to 
their default values. 

4 Click OK.

Crystallize Clumps pixels into a solid color in a 
polygon shape.

Facet (Photoshop) Clumps pixels of solid or similar 
colors into blocks of like-colored pixels. You can 
use this filter to make a scanned image look hand 
painted or to make a realistic image resemble an 
abstract painting.

Fragment (Photoshop) Creates four copies of the 
pixels in the selection, averages them, and offsets 
them from each other.

Mezzotint Converts an image to a random pattern 
of black-and-white areas or of fully saturated 
colors in a color image. To use the filter, choose a 
dot pattern from the Type pop-up menu in the 
Mezzotint dialog box.

Mosaic (Photoshop) Clumps pixels into square 
blocks. The pixels in a given block are the same 
color, and the colors of the blocks represent the 
colors in the selection.

Pointillize Breaks up the color in an image into 
randomly placed dots, as in a pointillist painting, 
and uses the background color as a canvas area 
between the dots.

<F>: Render filters
The Render filters create 3D shapes, cloud 
patterns, refraction patterns, and simulated light 
reflections in an image. You can also manipulate 
objects in 3D space, create 3D objects (cubes, 
spheres, and cylinders), and create texture fills 
from grayscale files to produce 3D-like effects for 
lighting. 

3D Transform Maps images to cubes, spheres, and 
cylinders, which you can then rotate in three 
dimensions. For more information, see “Trans-
forming objects in three dimensions” on page 165.

Clouds Generates a soft cloud pattern using 
random values that vary between the foreground 
and the background colors. To generate a more 
stark cloud pattern, hold down Alt (Windows) or 
Option (Mac OS) as you choose Filter> Render > 
Clouds.

Difference Clouds Uses randomly generated values 
that vary between the foreground and back-
ground color to produce a cloud pattern. The filter 
blends the cloud data with the existing pixels in the 
same way that the Difference mode blends colors. 
The first time you choose this filter, portions of the 
image are inverted in a cloud pattern. Applying the 
filter several times creates rib and vein patterns 
that resemble a marble texture.

Lens Flare Simulates the refraction caused by 
shining a bright light into the camera lens. Specify 
a location for the center of the flare by clicking 
anywhere inside the image thumbnail or by 
dragging its crosshair. 
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Lighting Effects Lets you produce myriad lighting 
effects on RGB images by varying 17 light styles, 3 
light types, and 4 sets of light properties. You can 
also use textures from grayscale files (called bump 
maps) to produce 3D-like effects and save your 
own styles for use in other images. 

Texture Fill Fills a selection with a grayscale file or 
part of a file. To add the texture to the document 
or selection, you open the grayscale document you 
want to use as the texture fill.

<F>: Sharpen filters
The Sharpen filters focus blurry images by 
increasing the contrast of adjacent pixels.

Sharpen and Sharpen More (Photoshop) Focus a 
selection and improve its clarity. The Sharpen 
More filter applies a stronger sharpening effect 
than does the Sharpen filter.

Sharpen Edges (Photoshop) and Unsharp Mask Find 
the areas in the image where significant color 
changes occur and sharpen them. The Sharpen 
Edges filter sharpens only edges while preserving 
the overall smoothness of the image. Use this filter 
to sharpen edges without specifying an amount. 
For professional color-correction, use the Unsharp 
Mask filter to adjust the contrast of edge detail and 
produce a lighter and darker line on each side of 
the edge, to emphasize the edge and create the 
illusion of a sharper image. (See “Sharpening an 
image” on page 112.)

<F>: Sketch filters
Filters in the Sketch submenu add texture to 
images, often for a 3-D effect. The filters also are 
useful for creating a fine-arts or hand-drawn look. 
Many of the Sketch filters use the foreground and 
background color as they redraw the image.

Bas Relief Transforms an image to appear carved 
in low relief and lit to accent the surface variations. 
Dark areas of the image take on the foreground 
color, light colors use the background color.

Chalk & Charcoal Redraws an image’s highlights 
and midtones with a solid midtone gray back-
ground drawn in coarse chalk. Shadow areas are 
replaced with black diagonal charcoal lines. The 
charcoal is drawn in the foreground color, the 
chalk in background color.

Charcoal Redraws an image to create a posterized, 
smudged effect. Major edges are boldly drawn 
while midtones are sketched using a diagonal 
stroke. Charcoal is the foreground color, and the 
paper is the background color.

Chrome Treats the image as if it were a polished 
chrome surface. Highlights are high points and 
shadows are low points in the reflecting surface. 
After applying the filter, use the Levels dialog box 
to add more contrast to the image.
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Conté Crayon Replicates the texture of dense dark 
and pure white Conté crayons on an image. The 
Conté Crayon filter uses the foreground color for 
dark areas and the background color for light 
areas. For a truer effect, change the foreground 
color to one of the common Conté Crayon colors 
(black, sepia, sanguine) before applying the filter. 
For a muted effect, change the background color 
to white with some foreground color added to it 
before applying the filter. (See “Using texture and 
glass surface controls” on page 261.)

Graphic Pen Uses fine, linear ink strokes to 
capture the details in the original image and is 
especially striking with scanned images. The filter 
replaces color in the original image using the 
foreground color for ink and background color for 
paper.

Halftone Pattern Simulates the effect of a halftone 
screen while maintaining the continuous range of 
tones. 

Note Paper Creates an image that appears to be 
constructed of handmade paper. The filter 
simplifies an image and combines the effects of the 
Texture > Emboss and Grain filters. Dark areas of 
the image appear as holes in the top layer of paper, 
revealing the background color.

Photocopy Simulates the effect of photocopying an 
image. Large areas of darkness tend to copy only 
around their edges and midtones fall away to 
either solid black or white.

Plaster Molds an image from 3D plaster, and then 
colorizes the result using the foreground and 
background color. Dark areas are raised, light 
areas are sunken (or reverse the effect by choosing 
the Invert option).

Reticulation Simulates the controlled shrinking 
and distorting of film emulsion, to create an image 
that appears clumped in the shadow areas and 
lightly grained in the highlights.

Stamp Is best used with black-and-white images. 
The filter simplifies the image to appear stamped 
with a rubber or wood stamp.

Torn Edges Is particularly useful for images 
consisting of text or high-contrast objects. The 
filter reconstructs the image as ragged, torn pieces 
of paper, and then colorizes the image using the 
foreground and background colors.

Water Paper Uses blotchy daubs that appear 
painted onto fibrous, damp paper, causing the 
colors to flow and blend.

<F>: Stylize filters
The Stylize filters produce a painted or impres-
sionistic effect on a selection by displacing pixels 
and by finding and heightening contrast in an 
image. After using filters like Find Edges and Trace 
Contour that highlight edges, you can apply the 
Invert command to outline the edges of a color 
image with colored lines or to outline the edges of 
a grayscale image with white lines. (See “Using the 
Invert command” on page 111.

Diffuse (Photoshop) Shuffles pixels in a selection to 
make the selection look less focused according to 
the selected option: Normal moves pixels 
randomly, ignoring color values; Darken Only 
replaces light pixels with darker pixels; and 
Lighten Only replaces dark pixels with lighter 
pixels.
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Emboss (Photoshop) Makes a selection appear 
raised or stamped by converting its fill color to 
gray and tracing the edges with the original fill 
color. Options include an embossing angle (from –
360˚ to lower (stamp) the surface to +360˚ to raise 
the surface to); height; and a percentage (1% to 
500%) for the amount of color within the 
selection. To retain color and detail when 
embossing, use the Fade command after applying 
the Emboss filter.

Extrude Gives a 3D texture to a selection or layer.

To use the Extrude filter:

1 Choose Filter > Stylize > Extrude. 

2 Choose a 3D object:

• Blocks creates objects with a square front face 
and four side faces. To fill the front face of each 
block with the average color of the block, select the 
Solid Front Faces option. To fill the front face with 
the image, keep deselected the Solid Front Faces 
option. 

• Pyramids creates objects with four triangular 
sides that meet at a point.

3 Enter a value in the Size text box to determine 
the length of any side of the object’s base, from 2 to 
255.

4 Enter a value in the Depth text box to indicate 
how far the tallest object appears to protrude from 
the screen, from 0 to 255.

5 Choose a depth option: 

• Random to give each block or pyramid an 
arbitrary depth

• Level-based to make each object’s depth corre-
spond to its brightness—bright protrudes more 
than dark.

6 Select Mask Incomplete Blocks to hide any 
object extending beyond the selection.

7 Click OK.

Find Edges (Photoshop) Identifies the areas of the 
image with significant transitions and emphasizes 
the edges. Like the Trace Counter filter, Find Edges 
outlines the edges of an image with dark lines 
against a white background and is useful for 
creating a border around an image. 

Glowing Edges Identifies the edges of color and 
adds a neon-like glow to them.

Solarize Blends a negative and a positive image—
similar to exposing a photographic print briefly to 
light during development.

Tiles Breaks up an image into a series of tiles, off-
setting the selection from its original position. You 
can choose with what to fill the area between the 
tiles: the background color; the foreground color; 
a reverse version of the image; or an unaltered 
version of the image, which puts the tiled version 
of the image on top of the original and reveals part 
of the original image underneath the tiled edges.

Trace Contour (Photoshop) Finds the transitions of 
major brightness areas and thinly outlines them 
for each color channel for an effect similar to the 
lines in a contour map.

To use the Trace Contour filter:

1 Choose Filter > Stylize > Trace Contour.
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2 Choose an Edge option to outline areas in the 
selection: Lower outlines where the color values of 
pixels fall below the specified level; and Upper 
outlines where the color values fall above. 

3 Enter a threshold (Level) for evaluating color 
values (tonal level), from 0 to 255. Experiment to 
see what values bring out the best detail in the 
image. 

Use the Info palette in Grayscale mode to identify 
a color value that you want traced. Then enter the 
value in the Level text box. (See “Using the Info 
palette” on page 5.)

4 Click OK.

Wind Creates tiny horizontal lines in the image to 
simulate a wind effect. Methods include Wind; 
Blast, for a more dramatic wind effect; and Stagger, 
which offsets the wind lines in the image.

<F>: Texture filters
Use the Texture filters to give an image the 
appearance of depth or substance, or to add an 
organic look. 

Craquelure Paints an image onto a high-relief 
plaster surface, producing a fine network of cracks 
that follow the contours of the image. Use this 
filter to create an embossing effect with images 
that contain a broad range of color or grayscale 
values.

Grain Adds texture to an image by simulating 
different kinds of grain—regular, soft, sprinkles, 
clumped, contrasty, enlarged, stippled, horizontal, 
vertical, and speckle.

Mosaic Tiles Draws the image as if it were made up 
of small chips or tiles and adds grout between the 
tiles. (In contrast, the Pixelate > Mosaic filter 
breaks up an image into blocks of different colored 
pixels.)

Patchwork Breaks up an image into squares filled 
with the predominant color in that area of the 
image. The filter randomly reduces or increases 
the tile depth to replicate the highlights and 
shadows.

Stained Glass Repaints an image as single-colored 
adjacent cells outlined in the foreground color. 

Texturizer Applies a texture you select or create to 
an image. (See “Using texture and glass surface 
controls” on page 261.)

<F>: Video filters
The Video submenu contains the De-Interlace and 
NTSC Colors filters. 

De-Interlace Smooths moving images captured 
on video by removing either the odd or even inter-
laced lines in a video image. You can choose to 
replace the discarded lines by duplication or inter-
polation.

NTSC Colors Restricts the gamut of colors to those 
acceptable for television reproduction to prevent 
oversaturated colors from bleeding across 
television scan lines.

When creating images for use on television or 
video, use the Color Settings > RGB Setup 

command to set your RGB space to NTSC (1953).
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<F>: Other filters
Filters in the Other submenu let you create your 
own filters, use filters to modify masks, offset a 
selection within an image, and make quick color 
adjustments.

Custom (Photoshop) Lets you design your own 
filter effect. With the Custom filter, you can change 
the brightness values of each pixel in the image 
according to a predefined mathematical operation 
known as convolution. Each pixel is reassigned a 
value based on the values of surrounding pixels. 
This operation is similar to the Add and Subtract 
calculations for channels. 

You can save the custom filters you create and use 
them with other Photoshop images. 

To create a Custom filter: 

1 Choose Filter > Other > Custom. 

2 Select the center text box, which represents the 
pixel being evaluated. Enter the value by which 
you want to multiply that pixel’s brightness value, 
from –999 to +999.

3 Select a text box representing an adjacent pixel. 
Enter the value by which you want the pixel in this 
position multiplied. 

For example, to multiply the brightness value of 
the pixel to the immediate right of the current 
pixel by 2, enter 2 in the text box to the immediate 
right of the center text box. 

4 Repeat steps 2 and 3 for all pixels to include in 
the operation. You don’t have to enter values in all 
the text boxes.

5 For Scale, enter the value by which to divide the 
sum of the brightness values of the pixels included 
in the calculation. 

6 For Offset, enter the value to be added to the 
result of the scale calculation. 

7 Click OK. The custom filter is applied to each 
pixel in the image, one at a time. 

Use the Save and Load buttons to save and reuse 
custom filters. 

DitherBox™ Creates a custom dither pattern for a 
selected RGB color. (See  ““Creating and applying 
custom dither patterns” on page 363”.)

High Pass (Photoshop) Retains edge details in the 
specified radius where sharp color transitions 
occur and suppresses the rest of the image (A 
radius of 0.1 pixel keeps only edge pixels.) The 
filter removes low-frequency detail in an image 
and has the opposite effect of the Gaussian Blur 
filter. 

It is helpful to apply the High Pass filter to a 
continuous-tone image before using the 
Threshold command or converting the image to 
Bitmap mode. The filter is useful for extracting 
line art and large black-and-white areas from 
scanned images.
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Minimum and Maximum (Photoshop) Are useful for 
modifying masks. The Minimum filter has the 
effect of applying a spread—spreading out black 
areas and shrinking white areas. The Maximum 
filter has the effect of applying a choke—spreading 
out white areas and choking in black areas. As does 
the Median filter, the Maximum and Minimum 
filters look at individual pixels in a selection. 
Within a specified radius, the Maximum and 
Minimum filters replace the current pixel’s 
brightness value with the greatest or least 
brightness value of the surrounding pixels.

Offset Moves a selection a specified horizontal or 
vertical amount, leaving an empty space at the 
selection’s original location. You can fill the empty 
area with the current background color, with 
another part of the image, or with your choice of 
fill if the selection is near the edge of an image. 
(See “Defining undistorted areas” on page 261.)

Tile Maker (ImageReady) Enables you to prepare an 
image for use as a tiled background. You can blend 
the edges of an image to create a seamless 
background. You can also create a kaleidoscopic 
background in which an image is flipped horizon-
tally and vertically to create an abstract design. 
(See “Creating background images” on page 372.)

<F>: Digimarc filters
The Digimarc filters embed a digital watermark 
into an image to store copyright information. For 
more information, see “Adding digital copyright 
information” on page 390.

<F>: Using the Lighting Effects 
filter
The Lighting Effects filter lets you produce myriad 
lighting effects on RGB images by varying light 
styles, light types, and sets of light properties. You 
can also use textures from grayscale files (called 
bump maps) to produce 3D-like effects and save 
your own styles for use in other images.

Note: The Lighting Effects filter works only on RGB 
images.

To use the Lighting Effects filter:

1 Choose Filter > Render > Lighting Effects. 

2 For Style, choose a style. Press Tab to cycle 
through the lights in a style. (See “Choosing a 
Lighting Effects style” on page 279.)

3 For Light Type, choose a type. If you’re using 
multiple lights, select and deselect On to turn 
individual lights on and off. (See “Choosing a 
Lighting Effects type” on page 278.)

4 To change the color of the light, click the color 
box in the Light Type section of the dialog box. 

The color picker chosen in the General Preferences 
dialog box opens. For information on choosing a 
color picker, see “Using the Adobe Color Picker” 
on page 198, or “Using other color pickers” on 
page 202.

5 To set light properties, drag the corresponding 
slider for the following options:

• Gloss determines how much the surface reflects 
light (as on the surface of a piece of photographic 
paper) from Matte (low reflectance) to Glossy 
(high reflectance). 
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• Material determines whether the light or the 
object on which the light is cast reflects more light. 
Plastic reflects the light’s color, Metallic reflects the 
object’s color.

• Exposure increases the light (positive values) or 
decreases the light (negative values). A value of 0 
has no effect.

• Ambience diffuses the light as if it were 
combined with other light in a room, such as 
sunlight or fluorescent light. Choose a value of 100 
to use only the light source, a value of –100 to 
remove the light source. To change the color of the 
ambient light, click the color box and use the color 
picker that appears.

To duplicate a light, Alt-drag (Windows) or Option-
drag (Mac OS) the light within the preview window.

6 To use a texture fill, choose a channel for Texture 
Channel. (See “Using a Lighting Effects texture” 
on page 280.)

7 Click OK to apply the filter.

<F>: Choosing a Lighting Effects type

You can choose from several light types.

• Omni shines light in all directions from directly 
above the image—like a light bulb over a piece of 
paper.

• Directional shines light from far away so that the 
light angle doesn’t change—like the sun.

• Spotlight casts an elliptical beam of light. The 
line in the preview window defines the light 
direction and angle, and the handles define the 
edges of the ellipse. 

To adjust an Omni light:

1 Choose Filter > Render > Lighting Effects. 

2 For Light Type, choose Omni.

3 Adjust the light:

• To move the light, drag the center circle. 

• To increase or decrease the size of the light (like 
a light moving closer or farther away), drag one of 
the handles defining the edges of the effect.

4 Click OK to apply the filter.

To adjust the angle and height of the directional light 
using the preview window:

1 Choose Filter > Render > Lighting Effects. 

2 For Light Type, choose Directional.

3 Adjust the light:

• To move the light, drag the center circle. 

• To change the direction of the light, drag the 
handle at the end of the line to rotate the light’s 
angle. Ctrl-drag (Windows) or Command-drag 
(Mac OS) to keep the light’s height (line length) 
constant.

• To change the light’s height, drag the square at 
the end of the line. Shorten the line for a bright 
light, lengthen it for a less intense one. A very short 
line produces pure white light, a very long one no 
light. Shift-drag to keep the angle constant and 
change the light’s height (line length).

4 Click OK to apply the filter.

To adjust the angle and height of the spotlight using 
the preview window:

1 Choose Filter > Render > Lighting Effects. 
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2 For Light Type, choose Spotlight.

3 Adjust the light:

• To move the light, drag the center circle. 

• To increase the light angle, drag the black square 
to shorten the line. To decrease the light angle, 
drag to lengthen the line.

• To stretch the ellipse or rotate the light, drag one 
of the handles. Shift-drag to keep the angle 
constant and change only the size of the ellipse. 
Ctrl-drag (Windows) or Command-drag (Mac 
OS) to keep the size constant and change the angle 
or direction of the spotlight.

• To set the light focus (or spotlight intensity) and 
control how much of an ellipse is filled with light, 
drag the Intensity slider: full intensity (a value of 
100) is brightest; normal intensity is about 50; 
negative intensity takes away light; and –100 
intensity produces no light. Use the Focus slider to 
control how much of the ellipse is filled with light.

4 Click OK to apply the filter.

<F>: Choosing a Lighting Effects style

Use the Style menu in the Lighting Effects dialog 
box to choose from 17 light styles. You can also 
create your own lighting style by adding lights to 
the Default setting. The Lighting Effects filter 
requires at least one light source. Only one light 
can be edited at a time, but all added lights will be 
used to create the effect.

2 o’clock Spotlight A yellow spotlight with 
medium (17) intensity and wide (91) focus.

Blue Omni A blue overhead omni light with full 
(85) intensity and no focus.

Circle of Light Four spotlights. White has full (100) 
intensity and a concentrated (8) focus. Yellow has 
strong intensity (88) and a concentrated focus (3). 
Red has medium (50) intensity and a concentrated 
(0) focus. Blue has full (100) intensity and 
medium (25) focus. 

Crossing A white spotlight with medium (35) 
intensity and a wide (69) focus.

Crossing Down Two white spotlights with medium 
(35) intensity and wide (100) focus.

Default A white spotlight with a medium intensity 
and a wide focus. 

Five Lights Down/Five Lights Up Five white 
spotlights down or up with full (100) intensity and 
wide (60) focus.

Flashlight An omni yellow light with medium (46) 
intensity.

Flood Light A white spotlight with medium (35) 
intensity and wide (69) focus.

Parallel Directional A directional blue light with 
full (98) intensity and no focus.

RGB Lights Red, blue, and green lights that 
produce a light of medium (60) intensity and wide 
(96) focus.

Soft Direct Lights Two unfocused white and blue 
directional lights. White has a soft (20) intensity. 
Blue has a medium (67) intensity.

Soft Omni A soft omni light of medium (50) 
intensity.

Soft Spotlight A white spotlight with full (98) 
intensity and white (100) focus.
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Three Down Three white spotlights with soft (35) 
intensity and wide (96) focus.

Triple Spotlight Three spotlights with slight (35) 
intensity and wide (100) focus.

To add a light: 

In the Lighting Effects dialog box, drag the light 
icon at the bottom of the dialog box into the 
preview area. Repeat as desired for a maximum of 
16 lights. 

To delete a light:

In the Lighting Effects dialog box, drag the light by 
its center circle to the trash button at the bottom 
right of the preview window.

To create a new style:

1 In the Lighting Effects dialog box, choose 
Default for Style. 

2 Drag the light icon at the bottom of the dialog 
box into the preview area. Repeat as desired for a 
maximum of 16 lights. 

To save a style:

1 In the Lighting Effects dialog box, click Save. 

2 Name the style, and click OK.

Saved styles include all of the settings for each light 
and appear in the Style menu whenever you open 
the image. 

To delete a style:

1 In the Lighting Effects dialog box, choose a style 
for Style. 

2 Click Delete.

<F>: Using a Lighting Effects texture

The Texture Channel in the Lighting Effects dialog 
box lets you use a grayscale texture such as paper 
or water to control how light reflects off an image. 
You can use any channel in your image (including 
a channel copied from a different image) as a 
texture, or you can create your own texture. For an 
embossed text effect, use a channel with white text 
on a black background, or vice versa.

To use the Texture Channel in the Lighting Effects 
dialog box:

1 If necessary, create an alpha channel in your 
image and add texture. To use a texture from 
another image, copy and paste the image into a 
new channel. (See “Creating alpha channels” on 
page 217.)

2 In the Lighting Effects dialog box, choose a 
channel from the Texture Channel menu: the 
image’s Red, Green, or Blue channel or any 
channel added to the image.

3 Select White is High to raise the white parts of 
the channel from the surface. Deselect this option 
to raise the dark parts.

4 Drag the Height slider to vary the texture from 
Flat (0) to Mountainous (100). 

5 Click OK.
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Chapter 12: Using Type

dobe Photoshop and Adobe ImageReady 
let you add type to an image and edit it 
directly in the document window. You 

can quickly change the font, style, size, and 
alignment of the type and specify more advanced 
characteristics such as leading, kerning, and 
tracking. You can also create type in double-byte 
fonts, enabling you to create designs that include 
Chinese, Japanese, and Korean text (if you have the 
correct system software installed on your 
computer).

About type
Graphics applications create two different kinds of 
type:

Outline type Consists of mathematically defined 
shapes and can be scaled to any size without losing 
its crisp, smooth edges.

Bitmap type Is composed of pixels. The sharpness 
of bitmap type depends on the type size and the 
resolution of the image. Zooming in or scaling up 
bitmap type shows jagged edges on the type.

Bitmap type and outline type; inset zoom 300%

By default, Photoshop type is bitmap type, while 
the ImageReady type is outline type. However, you 
can convert type in the following ways:

• In Photoshop, use the Type > Create Outline 
command to convert bitmap type into outline 
type. Once you convert a type layer to outline type, 
you can no longer edit its text, so use the Create 
Outline command only after the text is finalized.

• In ImageReady, type remains outline type until 
you save the optimized file or until you rasterize 
the type using the Layer > Type > Render Layer 
command. When you open a vector image (such as 
an Adobe Illustrator file) that contains outline 
type, ImageReady rasterizes the type into pixels or 
bitmap type (except for an image in Photoshop file 
format, in which outline type is preserved as 
outlines).

Creating type
You can create horizontal or vertical type 
anywhere in an image. Depending on how you use 
the type tool, you can enter text at a point or create 
a text flow inside a bounding box. Creating type at 
a point is a good for entering a single word or line 
of text. Creating a text flow inside a bounding box 
is useful when you want to enter and format the 
type as one or more paragraphs, such as for a 
brochure.

<<ART: Text entered at a point and in a 
bounding box>>

A
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When you create type, a new type layer is added to 
the Layers palette. In Photoshop, you can also 
create a selection border in the shape of the type. 

Note: In Photoshop, a type layer is not created for 
images in multichannel, Bitmap, or indexed-color 
mode, because these modes do not support layers. In 
these image modes, type appears on the background 
and cannot be edited. 

About using the type tool (Photoshop)

Clicking in an image with the type tool puts the 
type tool in edit mode. You can enter and edit text 
when the tool is in edit mode; however, you must 
commit changes to the type layer before you can 
perform other operations. For example, you 
cannot select a command from the Layers menu or 
use a painting tool while the text tool is in edit 
mode. To determine if the type tool is in edit 
mode, look in the options bar—if you see the OK 
and Cancel buttons, the type tool is in edit mode.

To commit text to a type layer:

Do one of the following:

• Click OK in the options bar.

• Press the Enter key on the keypad.

• <<Auto-commit options>>

<<Engineering reviewers—Which tools cause 
auto-commit when you select them?>>

Entering text at a point

When you enter type at a point, each line of text is 
independent—the length of text lines grows or 
shrinks as you edit them, but they don’t wrap to 
the next line. 

To enter text at a point:

1 Select the type tool ( ). 

2 (Photoshop) Select the filled type option 
<<ICON>> in the options bar.

3 Select an orientation option in the options bar:

• Horizontal <<ICON>> to enter text horizon-
tally.

• Vertical <<ICON>> to enter text vertically.

4 Select additional type options in the options 
bar, Character palette, and Paragraph palette. (See 
“Formatting characters” on page 287; “Formatting 
paragraphs” on page 293.)

5 Click in the image to set an insertion point for 
the text. The small line through the I-beam marks 
the position of the text baseline. For horizontal 
type, the baseline marks the line on which the text 
rests; for vertical type, the baseline marks the 
center axis of the type characters.

6 Enter the text you want. Press Enter (Windows) 
or Return (Mac OS) to begin a new line of text.

7 (Photoshop) Commit the text to the type layer. 
(See “About using the type tool (Photoshop)” on 
page 282.)

The text you entered appears in a new type layer.
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Entering text in a bounding box

When you enter text in a bounding box, the lines 
of text wrap to fit the bounding box dimensions. 
You can enter multiple paragraphs or text and 
select a paragraph justification option.

You can resize the bounding box, which causes the 
text to reflow within the adjusted shape. In 
Photoshop, you can adjust the bounding box while 
you’re entering text or after you create the type 
layer. You can also rotate, scale, and skew text using 
the bounding box.

To enter type in a bounding box:

1 Select the type tool ( ). 

2 (Photoshop) Select the filled type option 
<<ICON>> in the options bar.

3 Select an orientation option in the options bar:

• Horizontal <<ICON>> to enter text horizon-
tally.

• Vertical <<ICON>> to enter text vertically.

4 Select additional type options in the options 
bar, Character palette, and Paragraph palette. 
(See “Formatting characters” on page 287; 
“Formatting paragraphs” on page 293.)

5 Drag diagonally to define a bounding box for 
the text.

6 Enter the text you want. Press Enter (Windows) 
or Return (Mac OS) to begin a new paragraph.

7 (Photoshop) If desired, resize, rotate, or skew 
the bounding box. 

8 (Photoshop) Commit the text to the type layer. 
(See “About using the type tool (Photoshop)” on 
page 282.)

The text you entered appears in a new type layer.

To resize or transform a bounding box:

1 Display the bounding box handles:

• (Photoshop) With the type tool active, select the 
type layer (in the Layers palette), and click in the 
text flow.

• (ImageReady) With the type tool active, select 
the type layer.

2 Drag to achieve the desired effect.

• To resize the bounding box, position the cursor 
over a handle—it turns into a double arrow 
(<<ICON>>)—and drag. Shift-drag to maintain 
the proportion of the bounding box. 

• (Photoshop) To rotate the bounding box, 
position the cursor outside of the bounding 
border—it turns into a curved, two-sided arrow 
(<<ICON>>)—and drag. Shift-drag to constrain 
the rotation to 15º increments.

• (Photoshop) To skew the bounding box, hold 
down Ctrl+Shift (Windows) or Command+Shift 
(Mac OS) and drag a side handle. The pointer 
turns into an arrowhead with a small double arrow 
(<<ICON>>).

• (Photoshop) To scale the text as you resize the 
bounding box, hold down Ctrl (Windows) or 
Command (Mac OS) and drag a side handle. The 
pointer turns into an arrowhead (<<ICON>>).

<<Reviewers—Please verify accuracy of modifier 
descriptions. Are there additional modifiers to 
document for bounding box transforms?>>
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Creating a type selection border 
(Photoshop)

When you use the type tool with the mask type 
option selected, you create a selection in the shape 
of the type. Type selections appear on the active 
layer, and can be moved, copied, filled, or stroked 
just like any other selection.

To create a type selection border:

1 Select the layer on which you want the selection 
to appear.For best results, create the type selection 
border on a regular image layer, not a type layer.

2 Select the type tool ( ), and select the masked 
type option <<ICON>> in the options bar.

3 Select additional type options, and enter text at 
a point or in a bounding box (as described in the 
previous sections).

The type selection border appears in the image on 
the active layer.

Working with type layers
Once you create a type layer, you can edit its text 
and apply layer commands to it. You can change 
the orientation of the type; apply anti-aliasing; 
and, in Photoshop, convert between point text to 
box text. You can move, restack, copy, and change 
the layer options of a type layer as for a regular 
layer. You can also make the following changes to a 
type layer and still edit the text:

• Apply transformation commands from the Edit 
menu, except for Perspective and Distort. To apply 
the Perspective or Distort commands, or to 
transform just part of the type layer, you must 
convert the type layer to a regular layer.

• Use layer effects.

• Use fill shortcuts (see “Filling and stroking selec-
tions and layers” on page 191).

Editing text in type layers

You can insert new text, change existing text, and 
delete text in type layers.

To edit text in a type layer:

1 Select the type tool. 

2 Select the type layer in the Layers palette or click 
in the text to automatically select a type layer. In 
ImageReady, select Auto Select Layer in the 
options bar to use automatic layer selection.

3 Position the cursor in the text and do one of the 
following:

• Click to set the insertion point.

• Select one or more characters you want to edit.

4 Enter text as desired.

5 (Photoshop) Commit the changes to the type 
layer. (See “About using the type tool 
(Photoshop)” on page 282.)
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Rendering type layers

Some effects—such as those provided by filters—
are not available for type layers. You must render 
the type prior to applying the effect. Rendering 
converts the type layer to a regular layer and makes 
its contents uneditable as text. A warning message 
appears if you choose a command that requires a 
rendered layer; click OK to render the layer. 

To convert a type layer to a regular layer:

1 Select the type layer in the Layers palette.

2 Choose Layer > Type > Render Layer.

Changing type layer orientation

The orientation of a type layer determines the 
direction of text lines in relation to the document 
window (for point type) or bounding box (for box 
type). When a type layer is vertical, the text lines 
flow up and down; when a type layer is horizontal, 
the text line flow side to side. Don’t confuse the 
orientation of a type layer with the direction of 
characters in a text line. (See “Rotating vertical 
type” on page 292.)

To change the orientation of a type layer:

1 Select the type layer in the Layers palette

2 Choose Layer > Type > Horizontal or Vertical.

Specifying anti-aliasing

Anti-aliasing lets you produce smooth-edged type 
by partially filling the edge pixels. As a result, the 
edges of the type blend into the background. 

Anti-aliasing on, and off; inset zoom 200%.

When creating text for online use, anti-aliased 
edges greatly increase the number of colors in the 
original image, which limits how much you can 
reduce the number of colors with the Optimize 
palette. This, in turn, limits your ability to reduce 
the optimized file size and may cause stray colors 
to appear along the edges of the type. Thus, when 
limiting the number of colors and file size is most 
important, leaving type without anti-aliased edges 
may be preferable, despite the jagged edges. Also, 
consider using larger type than you would use for 
printed works. Larger type can be easier to view 
online and gives you more freedom in deciding 
whether to apply anti-aliasing to text.

Note: One problem that can occur with anti-aliasing 
is that of text being rendered inconsistently at small 
sizes and low resolution (such as for web graphics). 
Deselecting the Fractional Width option in the 
Character palette menu will correct this inconsis-
tency.
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To apply anti-aliasing to a type layer:

1 Select the type layer in the Layers palette.

2 Choose Layer > Type and choose an option 
from the submenu, or choose an option from the 
Anti-Aliasing menu (<<ICON>>) in the options 
bar:

• None to apply no anti-aliasing.

• Crisp to make type appear more sharp.

• Strong to make type appear heavier.

• Smooth to make type appear smoother.

<<Documentation—Verify final commands.>>

Converting between point text and box 
text (Photoshop)

The terms point text and box text refer to how the 
type was created—from a point or in a bounding 
box. You can convert point text to box text to 
adjust the flow of text within a bounding box. Or, 
you can convert box text to point text to make each 
line in the text flow independent from the others.

To convert between point text and box text:

1 Select the type layer in the Layers palette.

2 Choose Layer > Type > Convert to Point Text or 
Convert to Box Text.

Warping type layers (Photoshop)

Warping simulates the effect of entering type along 
a path; for example, you can warp text in the shape 
of an arc or a wave. The warp style you select is an 
attribute of the type layer—you can change a 
layer’s warp style at any time to change the overall 
shape of the warp. Warping options give you 
precise control over the orientation and 
perspective of the warp effect.

To warp text:

1 Select a type layer. 

2 Do one of the following:

• Select the type tool, and click the warp icon 
(<<ICON>>) in the options bar.

• Select Warp from the Layer > Type submenu.

3 Choose a warp style from the Style pop-up 
menu.

4 Select the orientation of the warp effect—either 
Horizontal or Vertical.

5 If desired, specify values for additional warping 
options:

• Bend to specify how much warp is applied to the 
layer. At 0%, no warp is applied to the layer. 
(Entering 0% is the same as choosing None for the 
warp style.)

• Horizontal Distortion and Vertical Distortion to 
apply perspective to the warp.

6 Click OK.
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Formatting characters
Photoshop and ImageReady give you precise 
control over individual characters in type layers, 
including font, size, color, leading, kerning, 
tracking, baseline shift, alignment, and rotation. 
You can set type attributes before you enter text or 
reset them to change the appearance of selected 
characters in a type layer. 

Selecting characters

Before you can format individual characters, you 
must select them. You can select one character, a 
range of characters, or all characters in a type layer. 

To select characters:

1 Select the type tool ( ). 

2 Select the type layer in the Layers palette or click 
in the text to automatically select a type layer. In 
ImageReady, select Auto Select Layer in the 
options bar to use automatic layer selection.

3 Position the cursor in the text and do one of the 
following:

• Drag to select one or more characters.

• Shift-click to select a range characters.

• Choose Edit > Select All to select all the 
characters in the layer.

• (Photoshop) To select a word, double-click it. To 
select a line of text, triple-click it. To select all 
characters in a bounding box, quadruple-click 
anywhere in the text.

Note: In Photoshop, selecting and formatting 
characters in a type layer puts the type tool into edit 
mode. You must commit the changes before you can 
perform other operations. (See “About using the type 
tool (Photoshop)” on page 282.)

Using the Character palette

The Character palette provides options for 
formatting characters. Some formatting options 
are also provided in the options bar.

To display the Character palette:

Do one of the following:

• Choose Window > Show Character.

• Click the Character palette tab.

• (Photoshop) With the type tool selected, click 
Palettes in the options bar.
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Choosing a font

A font is a complete set of characters—letters, 
numbers, and symbols—that share a common 
weight, width, and style. When you select a font, 
you can select the font family and its type style 
independently. The font family is a collection of 
fonts sharing an overall typeface design, for 
example, Times. A type style is a variant version of 
an individual font in the font family, for example, 
Regular, Bold, or Italic. The range of available type 
styles varies with each font. You can also apply faux 
type styles—simulated versions of Bold and Italic 
styles. 

<<Reviewers—In following note, what is the 
correct location for installing fonts locally? There 
is no Fonts folder in the application folder.>>

Note: In addition to the fonts installed on your 
system, Photoshop uses font files in the local Fonts 
folder, located inside the application folder. 
Installing a Type 1, TrueType, or CID font into the 
local Fonts folder causes the font to appear in the 
Photoshop application only.

To choose a font family and style:

1 Choose a font family from the font family pop-
up menu in the Character palette or options bar. 

You can choose a font family and style by typing 
the desired name in the text box. As you type, 

the name of the first font or style beginning with that 
letter appears. Continue typing until the correct font 
or style name appears.

2 Do one of the following:

• Choose a font style from the font style pop-up 
menu in the Character palette or options bar.

• If the font family you chose does not include the 
style you want set, you can choose Faux Bold or 
Faux Underline from the Character palette menu 
to apply a simulated style.

Choosing a type size

The type size determines how large the type 
appears in the image. Photoshop and ImageReady 
use different units to measure type size. 

• In Photoshop, type size is measured in points, 
with a default type size of 12 points. One 
PostScript point is equal to 1/72 of an inch in a 
72-ppi image. You can switch between using the 
PostScript and traditional definitions of point size.

• In ImageReady, pixels are the only unit of 
measurement, including for type size.

To choose a type size:

In the Character palette or options bar, enter or 
select a new value in the Size <<(ICON)>>.

To specify the point size definition (Photoshop only):

1 Choose File > Preferences > Units & Rulers.

2 Select an option for Point/Pica Size. Traditional 
points are slightly smaller than PostScript points.

Changing the type color

The type you enter gets its color from the current 
foreground color. You can change the color of type 
using the color selection box in the Character 
palette or the options bar (ImageReady only).

<<Documentation—verify ImageReady color 
selection methods>>
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To change the type color:

Do one of the following:

• Click the color selection box in and select a color 
using the color picker. In ImageReady, if the color 
selection box isn’t showing in the Character 
palette, choose Show Options from the Character 
palette menu or click the Show Options button on 
the palette tab ( ) to view it.

• (ImageReady) Select an option from the color 
selection box pop-up menu: Foreground Color, 
Background Color, Other (to use the color picker), 
or a color from the pop-up palette.

• (ImageReady) Click the foreground color 
selection box in the toolbox, and select a color 
using the color picker. Or, click a color in the Color 
palette, the Color Table palette, or the Swatches 
palette.

• (ImageReady) Drag a color from the toolbox 
foreground or background color selection box or 
from the Color palette, the Color Table palette, or 
the Swatches palette, and drop the color on the 
type layer.

• (ImageReady) Apply a color fill layer effect to the 
type layer. See “Using layer effects” on page 249.

• (ImageReady) Press Alt+Delete (Windows) or 
Option+Delete (Mac OS) to fill the text with the 
foreground color, or press Control+Delete 
(Windows) or Command+Delete (Mac OS) to fill 
the text with the background color. 

Specifying leading

The amount of vertical space between lines of type 
is called leading. Leading is measure from the 
baseline of a line of text to the baseline of the line 
above it. Baseline is the invisible line on which 
most text lies. You can apply more than one 
leading amount within the same paragraph; 
however, the largest leading value in a line of type 
determines the leading value for that line.

The default Auto-Leading option sets the leading 
at 120% of the type size (for example, 12-point 
leading for 10-point type). 

<<Art—Simplify and reduce size of graphic?>>

5-point type with 5-point leading and with 10-point leading

To change the leading:

In the Character palette, do one of the following:

• Choose the desired leading from the Leading 
menu <<(ICON)>>.

• Select the existing leading value and enter a new 
value.

To change the default auto leading percentage:

1 Display the Paragraph palette.
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2 Choose Justification from the palette menu.

3 For Auto Leading, specify a new default 
percentage.

Specifying kerning and tracking

Kerning is the process of adding or subtracting 
space between specific letter pairs. You can control 
kerning manually, or you can use auto-kerning to 
turn on the kerning built into the font by the font 
designer. Tracking is the process of creating an 
equal amount of spacing across a range of letters. 

Positive kerning or tracking values move 
characters apart (adding to the default spacing); 
negative values move characters closer together 
(reducing the default spacing). Kerning and 
tracking values are measured in units that are 
1/1000 of an em space. The width of an em space is 
relative to the current type size. In a 1-point font, 
1 em corresponds to 1 point; in a 10-point font, 
1 em corresponds to 10 points. Because kerning 
and tracking units are 1/1000 em, 100 units in a 
10-point font are equivalent to 1 point. 

<<Art—Simplify and reduce size of graphic?>>

Default, and tracking set to 350

To use a font’s built-in kerning information:

In the Character palette, select Metrics 
(Photoshop) or Auto (ImageReady) from the 
Kerning menu <<(ICON)>>.

<<Documentation—Verify Metrics/Auto options 
for final draft.>>

To adjust kerning manually:

1 Click with the type tool to set an insertion point 
between two characters.

Note: If a range of text is selected, you can’t manually 
kern the text. Instead, use tracking.

2 In the Character palette, enter or select a 
numeric value for Kerning <<(ICON)>>.

3 (Photoshop) Commit the changes to the type 
layer. (See “About using the type tool 
(Photoshop)” on page 282.)

To specify tracking:

In the Character palette, enter or select a numeric 
value for Tracking <<(ICON)>>.

Adjusting horizontal or vertical scale

Horizontal scale and vertical scale specify the 
proportion between the height and width of the 
type relative to the baseline. Unscaled characters 
have a value of 100%. You can adjust scale to 
compress or expand selected characters in both 
width and height.

<<Reviewers—The following information is 
from the InDesign doc. Is this planned function-
ality for Photoshop and ImageReady?>>
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Scaling type using a transformation tool affects the 
type’s horizontal scale as well as the type size, 
leading, indentation, and baseline shift. You can 
return type scaled using a transformation tool to 
its original horizontal scale by setting the 
horizontal scale to 100%.

<<Art—Add graphic?>>

Horizontal scale values with 9-point font 

Note: Depending on the value you enter when you 
use vertical type, the horizontal scale may make the 
text appear narrower, because it functions relative to 
the baseline. The opposite is true for vertical scale.

To adjust the horizontal or vertical scale of type:

In the Character palette, enter a new percentage 
for Horizontal Scale <<(ICON)>> or Vertical 
Scale <<(ICON)>>.

Specifying baseline shift

Baseline shift controls the distance that type 
appears from its baseline, either raising or 
lowering the selected type to create superscripts or 
subscripts. 

<<Art—Simplify and reduce size of graphic?>>

Default, and baseline shift of –10 points

To specify baseline shift:

In the Character palette, enter or select 
(ImageReady) a value for Baseline Shift 
<<(ICON)>>. A positive value moves horizontal 
type above and vertical type to the right of the 
baseline; a negative value moves type below or to 
the left of the baseline.

In ImageReady, if the Baseline shift option is not 
visible in the Character palette, choose Show 
Options from the palette menu or click the Cycle 
Options icon <<(ICON)>>.

Changing case

You can enter or format text as uppercase 
characters, either all caps or small caps. When you 
format text as small caps, Photoshop or 
ImageReady uses the small caps designed as part of 
the font, if available.

To change the case of text:

Choose All Caps or Small Caps from the Character 
palette menu. A check mark indicates that the 
option is selected. Selecting Small Caps will not 
change characters that were originally typed in 
uppercase.

<<Documentation—ImageReady has Normal 
Caps command, Photoshop doesn’t.>>
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Making characters superscript or 
subscript

You can enter or format text as superscript or 
subscript characters. Superscript characters are 
reduced in size and shifted above the text baseline; 
subscript characters are reduced in size and shifted 
below the text baseline.

To specify superscript or subscript characters:

Choose Superscript or Subscript from the 
Character palette menu. A check mark indicates 
that the option is selected.

Applying underline and strikethrough

You can apply a line under and through text; the 
line is always black, regardless of the text color.

<<Reviewers—What is color of under-
line/strikethrough—always black or the same 
color as the text?>>

To apply an underline or strikethrough:

Choose Underline or Strikethrough from the 
Character palette menu. A check mark indicates 
that the option is selected.

Using ligatures and old style numerals

When working with OpenType fonts, you can use 
ligatures and old style typographic numerals in 
your text, if the font provides them. Ligatures are 
typographic replacements for certain pairs of 
characters, such as “fi” and “fl.” Old style numerals 
are shorter than regular numerals, and some old 
style numerals descend below the text baseline.

<<Art—Add graphic>>

To use ligatures or old style numerals:

Choose Ligatures or Old Style from the Character 
palette menu. A check mark indicates that the 
option is selected.

Using fractional character widths

By default, type is displayed using fractional 
character widths. This means that the spacing 
between characters varies, with fractions of whole 
pixels between some characters. In most situa-
tions, fractional character widths provide the best 
spacing for type appearance and readability. 
However, for type in small sizes (less than 20 
points) displayed online, fractional character 
widths can cause type to run together, making it 
difficult to read.

You can turn off fractional character widths to fix 
type spacing in whole-pixel increments and 
prevent small type from running together. 

To turn fractional character widths on or off:

Choose Fractional Widths from the Character 
palette menu. A check mark indicates that the 
option is selected. 

Rotating vertical type

When working with vertical type, you can rotate 
the direction of characters by 90°. Unrotated 
characters flow perpendicular to the text line; 
rotated characters flow parallel to the text line. You 
cannot rotate double-byte characters.
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<<Art—Simplify and reduce size of graphic?>>

Original, and with vertical rotation 90˚

To rotate characters in vertical type:

Choose Rotate Character from the Character 
palette menu. A check mark indicates that the 
option is selected. 

Formatting paragraphs
A paragraph is any range of text with a carriage 
return at the end. You use the Paragraph palette to 
set options that apply to entire paragraphs, such as 
the alignment, indentation, and space between 
lines of text. When working with point text, each 
line of text is a separate paragraph; when working 
with box text, paragraphs can have multiple lines 
of text, depending on the dimensions of the 
bounding box.

Selecting paragraphs

You can set paragraph formatting options for a 
single paragraph, multiple paragraph, or all 
paragraphs in a type layer. 

To select paragraphs for formatting:

Do one of the following:

• Select the type tool ( ) and click in a paragraph 
to apply formatting to a single paragraph.

• Select the type tool ( ) and make a selection 
within a range of paragraphs to apply formatting 
to multiple paragraphs.

• Select the type layer in the Layer palette to apply 
formatting to all paragraphs in the layer.

Using the Paragraph palette

To display the Paragraph palette, choose 
Window > Show Paragraph or click the Paragraph 
palette tab.

Aligning and justifying text

You can align text to one edge of a paragraph (left, 
center, or right for horizontal type; top, center, or 
bottom for vertical type) and justify text to both 
edges of a paragraph. Alignment options are 
available for both point text and box text, while 
justification options are only available for box text.

To specify alignment:

In the Paragraph palette, click an alignment 
option. The options for horizontal text are: 

<<ICON>> Aligns text to the left, leaving the 
right edge of the paragraph ragged.

<<ICON>> Aligns text to the center, leaving both 
edges of the paragraph ragged.

<<ICON>> Aligns text to right, leaving the left 
edge of the paragraph ragged.
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The options for vertical text are:

<<ICON>> Aligns text to the top, leaving the 
bottom edge of the paragraph ragged.

<<ICON>> Aligns text to the center, leaving both 
edges of the paragraph ragged.

<<ICON>> Aligns text to bottom, leaving the top 
edge of the paragraph ragged.

To specify justification for box text:

In the Paragraph palette, click a justification 
option. The options for horizontal text are: 

<<ICON>> Justifies all lines except the last, which 
is left-aligned.

<<ICON>> Justifies all lines except the last, which 
is centered.

<<ICON>> Justifies all lines except the last, which 
is right-aligned.

<<ICON>> Justifies all lines including the last, 
which is force-justified.

The options for vertical text are:

<<ICON>> Justifies all lines except the last, which 
is top-aligned.

<<ICON>> Justifies all lines except the last, which 
is centered.

<<ICON>> Justifies all lines except the last, which 
is bottom-aligned.

<<ICON>> Justifies all lines including the last, 
which is force-justified.

Indenting paragraphs

Indentation specifies the amount of space between 
text and the bounding box or line that contains the 
text. Indentation affects only the selected 
paragraph or paragraphs, so you can easily set 
different indentations for paragraphs.

To specify paragraph indentation:

In the Paragraph palette, enter a value for an 
indentation option: 

• Left Indent <<(ICON)>> to indent from the left 
edge of the paragraph.

• Right Indent <<(ICON)>> to indent from the 
right edge of the paragraph.

• First Line Left Indent <<(ICON)>> to indent 
the first line of text in the paragraph. The first line 
indent is relative to the left indent. To create a first 
line hanging indentation, enter a negative value.

Changing space above or below 
paragraphs

You can control the space before and after 
paragraphs using the paragraph spacing options.

To specify paragraph spacing:

In the Paragraph palette, enter a value for Space 
Before <<(ICON)>> and Space After 
<<(ICON)>>.
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Specifying hanging punctuation

Hanging punctuation controls whether punctu-
ation marks fall inside or outside the margins. If 
hanging punctuation is turned on, the following 
characters appear outside the margins: periods, 
commas, single-quotation marks, double-
quotation marks, apostrophes, hyphens, 
em dashes, en dashes, colons, and semicolons. 

Punctuation hangs when text is aligned right, 
aligned left, centered, or justified. When a punctu-
ation character is followed by an end quotation 
mark, both characters hang. 

To use hanging punctuation:

Choose Roman Hanging Punctuation from the 
Paragraph palette menu. A check mark indicates 
that the option is selected.

Controlling hyphenation and 
justification
The settings you choose for hyphenation and justi-
fication affect the horizontal spacing of lines and 
the aesthetic appeal of text on a page. Hyphenation 
options determine whether words can be 
hyphenated and, if they can, what breaks are 
allowable. Justification options determine word, 
letter, and glyph spacing.

Adjusting hyphenation

You can hyphenate words manually or automati-
cally. 

To turn automatic hyphenation on or off:

In the Paragraph palette, select or deselect the 
Hyphenate option.

To set automatic hyphenation options:

1 Choose Hyphenation from the Paragraph 
palette menu.

2 Select the Hyphenate option, if necessary.

3 Enter values for the following options: 

• Words Longer than _ Letters to specify the 
minimum number of characters for hyphenated 
words.

• After First _ Letters and Before Last _ Letters to 
specify the minimum number of characters at the 
beginning or end of a word that can be broken by 
a hyphen. For example, by specifying 3 for these 
values, aromatic would be hyphenated as aro- 
matic instead of ar- omatic or aromat- ic.

• Hyphen Limit to specify the maximum number 
of hyphens that can appear on consecutive lines. 
Zero means unlimited hyphens

• Hyphenation Zone to specify the distance at the 
end of a line that will cause a word to break in 
unjustified text. This option applies only when 
using the single-line composer. (See “About 
composition methods” on page 296)

4 To prevent capitalized words from being 
hyphenated, deselect Hyphenate Capitalized 
Words. Then click OK.

Preventing unwanted word breaks

You can prevent words from breaking at the end of 
lines and keep multiple words from breaking.
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To prevent selected text from breaking:

Choose No Break from the Character palette 
menu.

Adjusting spacing

You can precisely control the way in which 
Photoshop and ImageReady space letters and 
words and scales characters. Adjusting spacing 
options is especially useful when working with 
justified text, although you can also adjust spacing 
for unjustified text.

Word spacing refers to the space between words 
that is created by pressing the spacebar. Letter 
spacing refers to the distance between letters and 
includes kerning or tracking values. Glyph spacing 
refers to the width of characters (a glyph is any font 
character).

Spacing options are always applied to an entire 
paragraph. To adjust the spacing in a few 
characters but not an entire paragraph, use the 
Tracking option.

To set justification options:

1 Choose Justification from the Paragraph palette 
menu.

2 Enter values for Word Spacing, Letter Spacing, 
and Glyph Spacing:

• For justified text only, enter values for Minimum 
and Maximum to define a range of acceptable 
spacing. 

• Enter a value for Desired to set the spacing for 
both justified and unjustified paragraphs. 

<<Reviewers—The following information is 
from In Design. Please verify for Photoshop and 
provide details about Glyph Spacing>>

Word Spacing values can range from 0% to 
1000%; at 100%, no additional space is added 
between words. Letter Spacing values can range 
from -100% to 500%; at 0%, no space is added 
between letters. Glyph Spacing values can range 
from <?> to <?>; at 100%, <?>.

3 Click OK

Working with composition
The appearance of text on the page depends on a 
complex interaction of processes called compo-
sition. Using the word spacing, letter spacing, 
glyph scaling, and hyphenation options you’ve 
selected, Photoshop and ImageReady evaluate 
possible line breaks and chooses the one that best 
supports the specified parameters.

About composition methods

Photoshop and ImageReady offer two compo-
sition methods: Adobe Every-line composer and 
Adobe Single-line composer. Both composition 
methods evaluate possible breaks, and choose the 
one that best supports the hyphenation and justi-
fication options you’ve specified for a given 
paragraph.
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The every-line composer Considers a network of 
break points for a range of lines, and thus can 
optimize earlier lines in the paragraph in order to 
eliminate especially unattractive breaks later on. 
Working with multiple lines of text results in more 
even spacing and fewer hyphens. The every-line 
composer is selected by default.

The every-line composer approaches composition 
by identifying possible breakpoints, evaluating 
them, and assigning a weighted penalty to them 
based on these principles:

• Highest importance is given to evenness of letter 
and word spacing. Possible breakpoints are 
evaluated and penalized according to how much 
they deviate from optimal spacing.

• Hyphenation is avoided when possible. Break-
points that require hyphenation are penalized 
more than those that create uneven spacing.

• Good breakpoints are preferred over bad break-
points. After breakpoint penalty values are 
identified for a range of lines, they are squared, 
magnifying the bad breakpoints. The composer 
then uses the good breakpoints.

The single-line composer Offers a traditional 
approach to composing text one line at a time. 
This option is useful if you prefer to have manual 
control over how lines break. The single-line 
composer uses the following principles when 
considering a breakpoint:

• Compressed or expanded word spacing is 
preferable to hyphenation.

• Hyphenation is preferable to compressed or 
expanded letter spacing.

• If spacing must be adjusted, compression is 
better than expansion.

Choosing a composition method

You use the Paragraph palette to choose a compo-
sition method for selected paragraphs.

To choose a composition method for a paragraph:

Choose Adobe Multi-line Composer or Adobe 
Single-line Composer from the Paragraph palette 
menu. A check mark indicates which option is 
selected.

Setting CJK options (Photoshop)
Photoshop provides a full range of options for 
working with Chinese, Japanese, and Korean 
(CJK) type.

Viewing CJK options

To view CJK options and commands in the 
Character and Paragraph palettes, choose Edit > 
Preferences > General and select Show CJK 
Features.

<<Reviewers—Will provide a draft of this section 
on a separate review schedule.>>
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Chapter 13: Designing Web Pages

dobe Photoshop and Adobe ImageReady 
provide you with a comprehensive 
environment for designing complex, 

image-rich Web pages. You can use the tools and 
techniques you’re already familiar with to design 
Web pages that include images, text, and links. 
Creating sophisticated effects—such as rollovers, 
image maps, and animations—is quick and easy. 
Best of all, you never have to view or edit the 
underlying HTML and Javascript. 

About designing Web pages with 
Photoshop and ImageReady
When designing Web pages using Adobe 
Photoshop and Adobe ImageReady, keep in mind 
the tools and features that are available in each 
application. 

• Photoshop provides tools for creating and 
manipulating images for use as Web pages. You can 
divide an image into slices, add links and HTML 
text, optimize the image, and save it as a Web page.

• ImageReady provides many of the same image-
editing tools as Photoshop. In addition, it includes 
tools and palettes for adding advanced Web 
features—such as rollovers, image maps, and 
animations—to images.

Using Web palettes (ImageReady)

ImageReady provides the following palettes for 
working with Web features: Rollover, Slice, or 
Image Map. 

To display the Rollover, Slice, or Image Map palette:

Do one of the following:

• Click the tab of the palette you want to display.

• Choose Window > Show Rollover, Window > 
Show Slice, or Window > Show Image Map.

Other factors to consider

When you save an image as a Web page, you can 
choose to generate an HTML file. This file contains 
information that tells a Web browser what to 
display when it loads the page. It can contain 
pointers to images (in the form of GIF, PNG, and 
JPEG files), HTML text, linking information, and 
code for creating rollover and animation effects. 

You can preview most Web effects directly in 
Photoshop or ImageReady. However, the 
appearance of an image on the Web depends on 
the computer platform, color display system, and 
browser used to display the image. Be sure to 
preview images in different browsers, on different 
platforms, and with different color bit depths. 
(See “Previewing an image in a browser 
(ImageReady)” on page 16.)

A
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Creating and viewing slices
Dividing an image into slices lets you add Web 
features to an image. A slice is a rectangular area of 
an image that you can use to create links, rollovers, 
and animations in the resulting Web page. You can 
also use slices to selectively optimize an image for 
Web viewing.

About slices

You use slices to divide a source image into 
functional areas. When you save the image as a 
Web page, each slice is saved as an independent file 
that contains its own settings, color palette, links, 
rollover effects, and animation effects. You can use 
slices to achieve faster download speeds and 
increased image quality when working with 
documents that contain different types of images, 
or text and images.

<<Art—Example of a Web page divided into 
functional areas with slices. See graphic on p 508 
of CIB.>>

Web page with slices displayed in browser

You set how the Photoshop or ImageReady appli-
cation generates HTML code for aligning slices—
either using tables or cascading style sheets—in 
the Document Settings dialog box. You can also set 
how slice files are named. (See “Setting output 
preferences and file information” on page 369.)

Photoshop and ImageReady provide the slice and 
slice select tools for creating and working with 
slices. In addition, ImageReady provides a Slices 
menu and Slice palette with commands for 
working with slices. 

Types of slices

Slices you create are called user-slices. When you 
create a new user-slice, additional auto-slices are 
generated to account for the remaining areas of the 
image. In other words, auto-slices fill the space in 
the image that is not defined by user-slices. Auto-
slices are regenerated every time you add or edit 
user-slices. 

A subslice is a type of auto-slice that is generated 
when you create overlapping user-slices. Subslices 
indicate how the image will be divided when you 
save the optimized file. You cannot select or edit 
subslices separately from the underlying slice. In 
ImageReady, subslices are regenerated every time 
you arrange the stacking order of slices.
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<<Art—Diagram of subslices. Following is a 
quick sketch>>

A. Underlying slice B. Subslice C. Top slice

User-slices, auto-slices, and subslices look 
different—user-slices are defined by a solid line, 
while auto-slices are defined by a dotted line. 
Subslices are indicated by a red dotted line in 
Photoshop and slice symbol (<<ICON>>) in 
ImageReady. 

Creating user-slices

You can create user-slices with the slice tool, from 
a layer, from a selection (ImageReady), or from 
guides (ImageReady). When you create a slice 
from a layer, the slice area encompasses all the 
pixel data in the layer. If you edit the layer’s 
content, the slice area automatically adjusts to 
encompass the new pixels.

When defining an area for use as a rollover, 
place the rollover element on a separate layer, 

and create a slice from that layer. If you apply an 
effect to the layer—such as a drop shadow or glow—
to create a rollover state, the slice automatically 
adjusts to encompass the new pixels. (See “Working 
with rollovers (ImageReady)” on page 318.)

To create a slice with the slice tool:

1 Select the slice tool ( ). Any existing slices 
automatically display in the document window. 

2 Choose a style setting in the options bar:

• Normal to determine slice proportions by 
dragging. 

• Constrained Aspect Ratio to set a height-to-
width ratio. Enter whole numbers or decimals for 
the aspect ratio. For example, to create a slice twice 
as wide as it is high, enter 2 for the width and 1 for 
the height. 

• Fixed Size to specify the slice’s height and width. 
Enter pixel values in whole numbers. 

3 Drag over the area where you want to create a 
slice. Hold down Shift as you drag to constrain the 
slice to a square. Hold down Alt (Windows) or 
Option (Mac OS) to draw from the center. 

In ImageReady, you can snap a new slice to a 
guide or another slice in the document using the 

Slices > Snap to Slices command. (See “Moving and 
resizing user-slices” on page 304.)

To create a slice from a layer:

1 Select a layer in the Layers palette. 

2 Do one of the following:

<<Reviewers—Will the following commands be 
the same in both apps?>>

• (Photoshop) Choose Layer > Make Slice From 
Layer.

• (ImageReady) Choose Layer > Create Slice From 
Layer.

A

CB
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To create a slice from a selection (ImageReady):

1 Select a portion of the image.

2 Choose Slices > Create Slice from Selection.

ImageReady creates a user-slice based on the 
selection marquee. If the selection is feathered, the 
slice covers the full selection (including the 
feathered edges). If the selection is nonrectangular, 
the slice covers a rectangular area large enough to 
cover the full selection. 

To create slices from guides (ImageReady):

In a document containing guides, choose Slices > 
Create Slices From Guides. All slices created from 
guides are user-slices. 

When you create slices from guides, any existing 
slices are deleted. 

Converting auto-slices to user-slices

You can move, duplicate, combine, divide, resize, 
delete, arrange, and align user-slices. You can also 
apply different optimization settings to user-slices. 
In contrast, all auto-slices in an image are linked 
and share the same optimization settings. This is 
because auto-slices are regenerated every time you 
create or edit a user-slice. 

Converting an auto-slice to a user-slice prevents it 
from being changed when regeneration occurs. 
Dividing, duplicating, combining, and setting 
options for auto-slices automatically converts 
them to user-slices.

To convert auto-slices to user-slices:

1 Select an auto-slice. In ImageReady, you can 
select multiple slices.

2 Do one of the following:

• (Photoshop) Click Promote to User Slice in the 
options bar.

• (ImageReady) Choose Slices > Promote To User-
slice(s).

Viewing slices

You can view slices in Photoshop, the Photoshop 
Save for Web dialog box (see “Optimizing images” 
on page 342), and ImageReady. The following 
characteristics can help you identify and differen-
tiate between slices:

Slice lines Define the boundary of the slice. Solid 
lines indicate that the slice is a user-slice; dotted 
lines indicate that the slice is an auto-slice. 

Slice colors Differentiate user-slices from auto-
slices. By default, user-slices have blue lines and 
symbols, while auto-slices have gray lines and 
symbols. 

In addition, ImageReady uses color adjustments to 
dim unselected slices. These adjustments are for 
display purposes only and do not affect the final 
document’s color. By default, the color adjustment 
for auto-slices is twice the amount of that for user-
slices.

Slice numbers (<<ICON>>) Slices are numbered 
from left to right and top to bottom, beginning in 
the upper left corner of the document. If you 
change the arrangement or total number of slices, 
slice numbers are updated to reflect the changes. 
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Slice symbols Indicate whether a slice is an Image 
(<<ICON>>) or No Image (<<ICON>>) slice; if 
the slice is a layer-based slice (<<ICON>>); and if 
the slice is linked (<<ICON>>). (See “Choosing a 
content type” on page 308 and “Linking slices 
(ImageReady)” on page 312.) 

To show or hide slices:

Do one of the following:

• (Photoshop) Choose View > Show > Slices.

• (Photoshop Save for Web dialog box and 
ImageReady) Click the Slices Visibility button 
( ).

To change the color of slice lines (ImageReady):

<<Documentation—In Photoshop x112, you can 
set line color in options bar. This approach is 
inconsistent with ImageReady—verify after UI 
frost.>>

1 Choose Edit > Preferences > Slices.

2 Under Slice Lines, choose a color from the Line 
Color pop-up menu.

Changing the color of slice lines automatically 
changes the color of selected slice lines to a 
contrasting color.

To change the display of slice numbers and slice 
symbol (ImageReady):

<<Documentation—Not in Photoshop x112. 
Verify after UI frost.>>

1 Choose Edit > Preferences > Slices.

2 Under Numbers and Symbols, select a size for 
display symbols:

• None to display no numbers or symbols.

• The small icon to display small numbers and 
symbols.

• The large icon to display large numbers and 
symbols.

3 For Opacity, enter a value or choose a value 
from the pop-up slider to change the opacity of the 
numbers and symbols display. 

To change slice color adjustments (ImageReady):

1 Choose Edit > Preferences > Slices.

2 Enter a value or choose a value from the Color 
Adjustments pop-up slider for User-slices, Auto-
slices, or both.

The value determines by how much the brightness 
and contrast of unselected slices are dimmed. 

To display slice lines only (ImageReady):

1 Choose Edit > Preferences > Slices.

2 Under Slice Lines, select Show Lines Only to 
display slice lines only and deselect color 
adjustment and numbers and symbols display.

Selecting and modifying slices
You can move, duplicate, combine, divide, resize, 
delete, arrange, and align user-slices. There are 
fewer options for modifying auto-slices because 
they are generated automatically. However, you 
can promote an auto-slice to a user-slice at any 
time.
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In Photoshop, you cannot divide, combine, or 
align slices. Jump to ImageReady for additional 
slice-editing capabilities.

Selecting slices

You select a slice with the slice select tool in order 
to apply modifications to it. In the Photoshop Save 
for Web dialog box and in ImageReady, you can 
select multiple slices. 

To select a slice:

1 Select the slice select tool ( ).

2 Click on a slice in the document.

Note: When working with overlapping slices, click 
the visible section of an underlying slice to select it. 

To select multiple slices (Photoshop Save for Web 
dialog box and ImageReady):

With the slice select tool ( ), do one of the 
following:

• Shift-click to add slices to the selection. 

• (Photoshop Save for Web dialog box) Drag 
across the slices you want to select in the image 
area.

• (ImageReady) Click in an auto-slice or outside 
the image area and drag across the slices you want 
to select. (Clicking in a user-slice and dragging 
moves the slice.)

In ImageReady, you can save, load, and delete slice 
selections. Use a slice selection to reselect specific 
slices quickly and accurately. 

To save a slice selection (ImageReady):

1 Select one or more slices.

2 Choose Slices > Save Slice Selection.

3 Enter a name in the Selection Name text box, 
and click OK.

To load a slice selection (ImageReady):

Choose Slices > Load Slice Selection, and select the 
the name of the slice selection you want to load 
from the sub menu.

To delete a slice selection (ImageReady):

Choose Slices > Delete Slice Selection, and select 
the name of the slice selection you want delete 
from the submenu.

Moving and resizing user-slices

You can move and resize user-slices in Photoshop 
and ImageReady, but not in the Photoshop Save 
for Web dialog box.

You can also move and resize a slice using numeric 
coordinates. (See “Resizing and moving a slice 
using numeric coordinates” on page 309)

To move or resize user-slices:

1 Select a user-slice. In ImageReady, you can 
select and move multiple slices.

2 Do one of the following:

• To move a slice, move the pointer inside the slice 
selection border, and drag the slice to a new 
position. Press Shift to restrict movement to 
multiples of 45 degrees. 
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• To resize a slice, grab a side or a corner handle of 
the slice and drag to resize the slice. In 
ImageReady, if you select and resize adjacent 
slices, common edges shared by the slices are 
resized together.

To snap slices to a guide or another user-slice:

1 Do one of the following:

• (Photoshop) Choose View > Snap to > Guides.

• (ImageReady) Choose Slices > Snap to Slices. 

A check mark indicates that the feature is turned 
on.

2 Move the selected slices as desired. When you 
release the mouse button, the slices snap to any 
guide or slice within 4 pixels.

Dividing slices (ImageReady)

In ImageReady, the Divide Slice dialog box lets you 
divide one or more slices horizontally, vertically, 
or both. 

To divide slices:

1 Select one or more slices.

2 Do one of the following:

• Choose Slices > Divide Slice(s).

• Choose Divide Slice(s) from the Slice palette 
menu.

3 Select Preview in the Divide Slice dialog box to 
preview the changes.

4 In the Divide Slice dialog box, select one or both 
of the following options:

• Divide Horizontally Into to divide the slice 
lengthwise.

• Divide Vertically Into to divide the slice width 
wise.

5 Define how you want to divide each selected 
slices:

• Select and enter a value for slices down or slices 
across to divide each slice evenly into the specified 
number of slices.

• Select and enter a value for pixels per slice to 
divide each slice based on the specified number of 
pixels. Any section of a slice that is left over is made 
into another slice. For example, if you divide a slice 
that is 100 pixels wide into three new slices each 30 
pixels wide, the remaining 10-pixel-wide area 
becomes a new slice.

6 Click OK.

Duplicating slices

You can create a duplicate slice with the same 
dimensions and optimization settings as the 
original. If the original slice is a linked user-slice, 
the duplicate is linked to the same set. Duplicate 
slices are always user-slices, regardless of whether 
the original is a user-slice or an auto-slice.

In ImageReady, you can also copy and paste slices 
within or between documents.

To duplicate slices:

1 Select a slice. In ImageReady, you can select 
multiple slices.

2 Do one of the following:



CHAPTER 13306
Designing Web Pages

• Alt-drag (Windows) or Option-drag (Mac OS) 
from inside the selection. (Dragging from the edge 
will resize the slice.)

• (ImageReady) Choose Slices > Duplicate 
Slice(s).

• (ImageReady) Choose Duplicate Slice(s) from 
the Slice palette menu.

The duplicate slices appears on top of the original 
(offset 10 pixels down and to the right) and can be 
moved, resized, or otherwise modified. 

To copy and paste slices (ImageReady):

1 Select one or more slices. 

2 Choose Copy from the Slice palette menu.

3 If you want to paste into another document, 
open and display that document.

4 Choose Paste from the Slice palette menu.

Combining slices (ImageReady)

In ImageReady, you can combine two or more 
slices into a single slice.The resulting slice takes its 
dimensions and position from the rectangle 
created by joining the outer edges of the combined 
slices. If the combined slices are not adjacent, or 
are of different proportions or alignments, the 
newly combined slice may overlap other slices. 

Optimization settings for the combined slice are 
those of the first slice selected before the Combine 
Slices operation. A combined slice is always a user-
slices, regardless of whether the original slices 
include auto-slices.

To combine slices:

1 Select two or more slices.

2 Choose Slices > Combine Slices.

Arranging user-slices

When user-slices overlap, the last slice you create is 
the top slice in the stacking order. You can change 
the stacking order to gain access to underlying 
user-slices. You can specify which user-slice is on 
the top and bottom of the stack and move user-
slices up or down in the stacking order.

Note: You cannot arrange the stacking order of auto-
slices.

To change the stacking order of user-slices:

1 Select a user-slice. In ImageReady, you can 
select multiple slices.

2 Select a stacking order option:

<<Documentation—Verify description of 
options bar icons is consistent with other chap-
ters.>>

• (Photoshop) With the slice select tool active, 
click a stacking order option (<<Full ICON>>) in 
the options bar.

• (ImageReady) Choose Slices > Arrange, and 
choose an option from the submenu; or choose an 
option from the Slice palette menu.

You can select the following stacking order 
options:

Bring to Front (<<ICON>>) to make the 
selection the topmost slice in the image.
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Bring Forward (<<ICON>>) to move the 
selection one level up in the stacking order.

Send Backward (<<ICON>>) to move the 
selection one level down in the stacking order.

Send to Back (<<ICON>>) to make the selection 
the bottommost slice in the image.

Aligning user-slices (ImageReady)

In ImageReady, you can align user-slices with the 
top, bottom, left, right, or middle. Aligning user-
slices can eliminate unneeded auto-slices and 
generate a smaller, more efficient HTML file.

To align user-slices:

1 Select the user-slices you want to align.

2 Choose Slices > Align, and choose an command 
from the submenu:

• Top to align the top edges of the selected slices to 
the top edge of the topmost slice selected.

• Vertical Center to align the vertical centers of the 
selected slices to the vertical midpoint of the 
selected slices.

• Bottom to align the bottom edges of the selected 
slices to the bottom edge of the bottommost slice 
selected.

• Left to align the left edges of the selected slices to 
the left edge of the leftmost slice selected.

• Horizontal Center to align the horizontal centers 
of the selected slices to the horizontal midpoint of 
the selected slices.

• Right to align the right edges of the selected 
slices to the right edge of the rightmost slice 
selected.

Deleting user-slices

When you delete a user-slice, auto-slices are regen-
erated to fill the document area. You cannot delete 
auto-slices. 

To delete user-slices:

1 Select a user-slice. In ImageReady, you can 
select multiple slices.

2 Do one of the following:

• Press Backspace or Delete.

• (ImageReady) Choose Slices > Delete Slice(s), or 
choose Delete Slice from the Slice palette menu.

To delete all user-slices:

Do one of the following:

• (Photoshop) Choose View > Clear Slices.

• (ImageReady) Choose Slices > Delete All.

Locking slices (Photoshop)

<<Reviewers—What is the purpose of locking 
slices?>>

To lock all slices:

Choose View > Lock Slices.

Specifying slice options
Setting slice options lets you specify how the slice 
data will appear in a Web browser. You specify slice 
options in the Slice Options dialog box 
(Photoshop) and the Slice palette (ImageReady). 
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The available options vary according to the appli-
cation and the slice type you select. You can only 
set options for one slice at a time.

Note: Setting options for an auto-slice promotes the 
slice to a user-slice.

Choosing a content type

Formatting and display options for a slice vary 
according to its content type. There are two types 
of slices:

• Image slices contain image data, including 
rollover states. This is the default content type.

• No Image slices contain a solid color or HTML 
text. Because No Image slices contain no image 
data, they download more quickly. Photoshop and 
ImageReady do not display No Image slice 
content. To view No Image slice content, preview 
the image in a browser. (See “Previewing an image 
in a browser (ImageReady)” on page 16.)

To specify a content type:

1 Select a slice.

2 (Photoshop Save for Web dialog box) Double-
click the slice with the slice select tool to display 
the Slice Options dialog box.

3 In the Slice Options dialog box (Photoshop) or 
the Slice palette (ImageReady), select a slice type 
from the Type pop-up menu. 

4 (Photoshop) Click OK.

Specifying a slice name

The Name option lets you change the default name 
of the slice. This option is only available for Image 
slices. You can also change the default naming 
pattern for slices. (See “Setting slice naming 
preferences” on page 371)

To change the name of a slice:

1 Select a slice.

2 (Photoshop Save for Web dialog box) Double-
click the slice with the slice select tool to display 
the Slice Options dialog box.

3 In the Slice Options dialog box (Photoshop) or 
the Slice palette (ImageReady), type a new name in 
the Name text box. 

4 (Photoshop) Click OK.

Specifying a slice background color

The background color option lets you select a 
color to fill the transparent area (for Image slices) 
or entire area (for No Image slices) of the slice. In 
Photoshop, this option is available only if you 
activate the Slice Options dialog box from within 
the Save for Web dialog box.

Photoshop and ImageReady do not display the 
selected background color—you must preview the 
image in a browser to view the effect of selecting a 
background color. (See “Previewing an image in a 
browser (ImageReady)” on page 16.)

To choose a background color:

1 Select a slice whose background color you want 
to change.
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2 (Photoshop Save for Web dialog box) Double-
click the slice with the slice select tool to display 
the Slice Options dialog box.

3 In the Slice Options dialog box (Photoshop) or 
the Slice palette (ImageReady), select a 
background color from the Background/BG pop-
up menu:

•  (Photoshop) Select None, Eyedropper (to use 
the color in the eyedropper sample box), White, 
Black, or Other (using the color picker).

• (ImageReady) Select None, Foreground Color, 
Background Color, or Other (to use the color 
picker), or select a color from the pop-up palette.

4 (Photoshop) Click OK.

Assigning a URL to an Image slice

Assigning a URL to a slice makes the entire slice 
area a hotspot in the resulting Web page. When a 
user clicks in the hotspot, the Web browser links to 
the specified URL and target frame. This option is 
only available for Image slices.

To assign link information to an Image slice:

1 Select a slice you want to assign a URL to.

2 (Photoshop) Double-click the slice with the 
slice select tool to display the Slice Options dialog 
box.

3 In the Slice Options dialog box (Photoshop) or 
the Slice palette (ImageReady), enter a URL in the 
URL text box, or choose a previously created URL 
from the pop-up menu. You can enter a relative 
URL or a full URL (including http://).

4 If desired, enter the name of a target frame in 
the Target text box, or choose an option from the 
pop-up menu. A frame name must match a frame 
previously defined in the HTML file for the 
document. When a user clicks the link, the 
specified file displays in the new frame:

• _blank to display the linked file in a new 
window, leaving the original browser window 
open. 

• _self to display the linked file in the same frame 
as the original file. 

• _parent to display the linked file in its own 
original parent frameset. Use this option if the 
HTML document contains frames and the current 
frame is a child. The linked file displays in the 
current parent frame.

• _top to replace the entire browser window with 
the linked file, removing all current frames. 

Note: For more information on frames, see an 
HTML reference (either printed or on the Web).

5 (Photoshop) Click OK.

Resizing and moving a slice using numeric 
coordinates

The Dimensions options let you set the exact 
position and dimensions of the slice in relation to 
the document window. This option is not available 
if you access the Slice Options dialog box through 
the Photoshop Save for Web dialog box.

In ImageReady, if the Dimensions options aren’t 
showing, choose Show Options from the Slice 
palette menu or click the Show Options button on 
the palette tab ( ) to view them.



CHAPTER 13310
Designing Web Pages

To resize and move a slice using numeric coordinates:

1 Select a slice.

2 (Photoshop) Double-click the slice with the 
slice select tool to display the Slice Options dialog 
box.

3 In the Dimensions area of the Slice Options 
dialog box (Photoshop) or the Slice palette 
(ImageReady), change one or more of the 
following options:

• X to specify the distance in pixels between the 
left edge of the slice and the origin point of the 
ruler in the document window. 

• Y to specify the distance in pixels between the 
top edge of the slice and the origin point of the 
ruler in the document window. 

Note: The default origin point of the ruler is the 
upper left corner of the document. (See XREF to 
Using Rulers in Editing and Retouching.) <<xref 
destination?>>

• W to specify the width of the slice.

• H to specify the height of the slice.

• Constrain Proportions to preserve the current 
proportions of the slice.

4 (Photoshop) Click OK.

Specifying browser messages

You can specify what messages appear in the 
browser using the Message and Alt options. These 
options are only available for Image slices.

Message Lets you change the default message in 
the browser’s status area for a selected slice or 
slices. By default the slice’s URL is displayed. 

Alt Lets you specify an Alt tag for a selected slice 
or slices. The Alt text appears in place of the slice 
image in nongraphical browsers. It also appears in 
place of the image while the image is downloading 
and as a tool tip in some browsers. 

In ImageReady, if the Message and Alt options 
aren’t showing, choose Show Options from the 
Slice palette menu or click the Show Options 
button on the palette tab ( ) to view them.

To specify browser messages:

1 Select a slice you want to specify browser 
messages for.

2 (Photoshop) Double-click the slice with the 
slice select tool to display the Slice Options dialog 
box.

3 In the Slice Options dialog box (Photoshop) or 
the Slice palette (ImageReady), type the desired 
text in the Message text box, Alt text box, or both.

4 (Photoshop) Click OK.

Adding HTML text to a slice

Choosing the No Image type for a slice lets you 
enter text that will appear in the slice area of the 
resulting Web page. This text is HTML text—you 
can format it using standard HTML tags. You can 
also select vertical and horizontal alignment 
options. For more information on specific HTML 
tags, see an HTML reference (either printed or on 
the Web).
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Photoshop and ImageReady do not display the 
HTML text in the document window—you can 
preview the text in a browser. (See “Previewing an 
image in a browser (ImageReady)” on page 16.) 
Keep in mind that the appearance of text is 
affected by the browser settings and computer 
platform it is viewed on. Be sure to preview HTML 
text in different browsers, with different browser 
setting, and on different platforms to see how text 
will appear on the Web.

To add HTML text to a slice:

1 Select a slice you want to add HTML text to.

2 (Photoshop) Double-click the slice with the 
slice select tool to display the Slice Options dialog 
box.

3 In the Slice Options dialog box (Photoshop) or 
the Slice palette (ImageReady), select No Image 
from the Type pop-up menu.

4 Type the desired text in the provided text box. 
You can use standard HTML tags to format the 
text.

5 (Photoshop Save for Web dialog box and 
ImageReady) If desired, select options in the Cell 
Alignment section of the dialog box.

Horizontal alignment options:

• Default to use the browser’s default for 
horizontal alignment.

• Left to align the text to the left side of the slice 
area.

• Center to align the text to the center of the slice 
area.

• Right to align the text to the right side of the slice 
area.

Vertical alignment options:

• Default to use the browser’s default for vertical 
alignment.

• Top to align the text to the top of the slice area.

• Baseline to set a common baseline for the first 
line of text in cells in the same row (of the resulting 
HTML table). Each cell in the row must use the 
Baseline option.

• Middle to center the text vertically in the slice 
area

• Bottom to align the text to the bottom of the 
slice area

6 (Photoshop) Click OK.

Optimizing slices

You can optimize Image slices using the Save for 
Web dialog box (Photoshop) or the Optimize 
palette (ImageReady). 

All Image slices use the optimization settings of the 
entire image until you apply new settings. If you 
select multiple slices with different optimization 
settings, only the controls that are relevant to the 
selected slices are visible. If settings for a control 
differ among slices, the control is blank. Any 
settings you choose are applied to all selected 
slices. 

In ImageReady, you can also copy optimization 
settings from one slice to another within a 
document, or from a slice in one view to a slice in 
another view in 2-Up or 4-Up view.
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To optimize slices:

Select one or more Image slices, and specify 
options in the Optimize panel/palette. 
(See “Optimizing images” on page 342.)

To copy optimization settings between slices 
(ImageReady):

1 Select the slice that uses the optimization 
settings you want to copy.

2 Drag the Droplet icon ( ) from the Optimize 
palette onto the slice to which you want to apply 
the Optimize palette settings. 

Linking slices (ImageReady)

Linking slices lets you share optimization settings 
between slices. You must use ImageReady to link 
slices; however, you can apply settings to linked 
slices in either the Save for Web dialog box 
(Photoshop) or the Optimize palette 
(ImageReady). When you apply optimization 
settings to a linked slice, all slices in the set are 
updated. 

Linked slices in GIF and PNG-8 format share a 
color palette and dither pattern. The dither pattern 
is applied across adjacent slice boundaries to 
prevent the appearance of seams between the 
slices. (See “Previewing and controlling dithering” 
on page 361.)

To link slices:

1 Select two or more slices you want to link. 

Note: If the first slice you select is a user-slice, any 
auto-slices you link to the first slice become user-
slices. If the first slice you select is an auto-slice, any 
user-slices you select are linked to the auto-slice 
group.

2 Choose Slices > Link Slices. 

Each linked set of user-slices is assigned a different 
color for the slice display graphics in the upper left 
corner of the slice. This helps to identify all the 
slices in one set. 

To unlink user-slices:

Do one of the following:

• To unlink a user-slice, select the slice, and then 
choose Slices > Unlink Slice.

• To unlink all user-slices in a set, select a slice in 
the set, and choose Slices > Unlink Set.

• To unlink all user-slices in a document, choose 
Slices > Unlink All.
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Creating and viewing image 
maps (ImageReady)
Image maps are similar to slices in that they enable 
you to link an area of an image to a URL. You can 
set up multiple linked areas—called hotspots—in 
an image, with links to text files; other images; 
audio, video, or multimedia files; other pages in 
the Web site; or other Web sites. You can also create 
rollovers effects in image maps. When you save the 
document as a Web page, the HTML file includes 
the coordinates for the hotspots and links in the 
image map. 

Image maps enable you to link circular, polygonal, 
or rectangular areas in an image, while slices 
enable you to link only rectangular areas. If you 
need to link only rectangular areas, using slices 
may be preferable to using an image map. Using 
slices enables you to apply different optimization 
settings to different areas of an image. 

Note: To avoid unexpected results, do not create 
image maps in slices that contain URL links—the 
image map links may cause slice links to be ignored 
in some browsers.

Creating image maps

You can create image maps using an image map 
tool or a layer. 

Tool-based image maps Are created using an image 
map tool—you drag in the document window to 
define a hotspot. You can view and set options for 
tool-based image maps in the Image Map palette. 

Layer-based image maps Are created from a 
layer—the layer’s content defines the shape of the 
hotspot. If you edit the layer’s content, the image 
map automatically adjusts to encompass the new 
pixels. Use layer-based image maps when defining 
an area for use as a rollover. You can convert a 
layer-based image map to a tool-based image map.

Image maps cannot extend beyond the edges of the 
image. If you overlap image maps, the topmost 
image map is the active hotspot in the overlapping 
areas.

To create an image map using an image map tool:

1 Select the rectangle image map tool 
(<<ICON>>), the circle image map tool 
(<<ICON>>), or the polygon image map tool 
(<<ICON>>) in the toolbox.

2 For the rectangle or circle image map tool, select 
Fixed Size to specify set values for the image map’s 
dimensions. Enter pixel values in whole numbers. 

3 Do one of the following to define the image 
map:

• With the rectangle or circle image map tool, drag 
over the area you want to define. Hold down Shift 
as you drag to constrain the image map to a square 
or circle. To drag an image map from its center, 
hold down Alt (Windows) or Option (Mac OS) 
after you begin dragging

• With the polygon image map tool, click in the 
image to set the starting point.Position the pointer 
where you want the first straight segment to end, 
and click. Continue clicking to set endpoints for 
subsequent segments. To close the border, position 
the pointer over the starting point (a closed circle 
appears next to the pointer), and click.
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4 In the Image Map palette, specify link infor-
mation for the image map. (See “Moving and 
resizing tool-based image maps” on page 315.)

To create an image map from a layer:

1 In the Layers palette, choose a layer from which 
to create an image map. (To use multiple layers in 
one hotspot, first merge the layers.)

2 Display the Layer Options palette or the Layer 
Options dialog box. (See “Specifying layer 
options” on page 234.)

3 Do one of the following:

• Select Image Map in the Layer Options palette.

• Select Use Layer as Image Map in the Layer 
Options dialog box.

4 Select Polygon, Rectangle, or Circle from the 
Shape pop-up menu to determine the shape of the 
image map. 

5 If you are using the Layer Options dialog box, 
click OK.

Converting layer-based image maps to 
tool-based image maps

Because a layer-based image map is tied to the 
pixel content of a layer, the only way to move, 
resize, or align it is to edit the layer. You can 
convert a layer-based image map to a tool-based 
image map to unlink it from the layer.

To convert a layer-based image map to a tool-based 
image map:

1 Select a layer-based image map using the image 
map selection tool (<<ICON>>). (See “Selecting 
image maps” on page 315).

2 Choose Promote Layer Based Image Map from 
the Image Map palette menu.

Viewing image maps

When you select the image map selection tool, 
image maps show automatically. You can also 
show or hide image maps using the Image Map 
Visibility button.

Image map preferences determine how image 
maps appear in the document window. You can set 
preferences for image map lines, line color, and 
color adjustments.

To show or hide image maps:

Click the Image Map Visibility button ( ) in the 
toolbox.

To set image map display preferences:

1 Choose Edit > Preferences > Image Maps.

2 To change the color of image map lines, choose 
a color from the Line Color pop-up menu. 
Changing the color of image map lines also 
changes the line color of selected image maps to a 
contrasting color.

3 To change the strength of image map color 
adjustments, enter a value or choose a value from 
the Image Map Overlay pop-up slider. The value 
determines the extent of color adjustments that 
dim the brightness and contrast of unselected hot 
spots. 

4 To display image map lines only and deselect 
color adjustment display, select Show Lines Only.

5 To show a bounding box for circular image 
maps, select Show Bounding Box.
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Selecting and modifying image 
maps (ImageReady)
How you select and modify an image map depends 
on whether it is a tool-based image map or a layer-
based image map. You can move, duplicate, 
arrange, and align tool-based image maps using 
the Image Map palette. In contrast, you use the 
Layers palette to modify layer-based image maps.

Selecting image maps

You select image maps with the image map 
selection tool. 

Note: You cannot select layer-based image maps 
with the image map selection tool. To edit options for 
a layer-based image map, select its layer in the Layers 
palette, and edit the options using the Layer Options 
palette or dialog box.

To select a tool-based image map:

1 Select the image map selection tool 
(<<ICON>>).

2 Click on an image map in the image. Shift-click 
to add image maps to the selection. 

You can also select multiple image maps by 
clicking outside an image map and dragging across 
the image maps you want to select.

Moving and resizing tool-based image 
maps

You can move and resize tool-based image maps 
by dragging. You can also move and resize rectan-
gular and circular image maps using numeric 
coordinates.

Note: To move or resize a layer-based image map, 
move or edit the layer.

To move tool-based image maps:

1 Select one or more image maps you want to 
move. 

2 Move the pointer inside the image map border, 
and drag it to a new position. Press Shift to restrict 
movement to multiples of 45 degrees. 

To resize a tool-based image map:

1 Select an image map you want to resize. 

2 Grab a handle on the image map border and 
drag to resize the image map.

To resize and move a tool-based image map using 
numeric coordinates:

1 Select a rectangular or circular image map.

2 In the Dimensions area of the Image Map 
palette, change one or more of the following 
options:

• X to specify the distance in pixels between the 
left edge or point of the image map and the origin 
point of the ruler in the document window. 
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• Y to specify the distance in pixels between the 
top edge or point of the image map and the origin 
point of the ruler in the document window. 

Note: The default origin point of the ruler is the 
upper left corner of the document. (See XREF to 
Using Rulers in Editing and Retouching.) <<xref 
destination?>>

• W to specify the width of a rectangular image 
map.

• H to specify the height of a rectangular image 
map.

• R to specify the radius of a circular image map. 

<<Reviewers—Will the Duplicate and Delete 
commands in the Image Map palette menu work 
for layer-based image maps? Not in x112>>

Duplicating image maps

<<Documentation—verify for layer-based image 
maps>>

You can create a duplicate image map with the 
same dimensions and settings as the original. 

To duplicate an image map:

1 Select one or more image maps. 

2 Do one of the following:

• Choose Duplicate Image Map(s) from the Image 
Map palette menu.

• Hold down Alt (Windows) or Option (Mac OS), 
and drag from inside the image map or image 
maps. 

The duplicate image map appears on top of the 
original (offset 10 pixels down and to the right) 
and can be moved, resized, or otherwise modified. 

Arranging image maps

When image maps overlap, the last image map you 
create is the top image map in the stacking order. 
You can specify which image map is on the top and 
bottom of the stack and move image maps up or 
down in the stacking order.

To change the stacking order of image maps:

1 Select one or more image maps you want to 
arrange.

2 Choose an option from the Image Map palette 
menu:

• Bring to Front to make the selection the topmost 
image map in the image.

• Bring Forward to move the selection one level up 
in the stacking order.

• Send Backward to move the selection one level 
down in the stacking order.

• Send to Back to make the selection the 
bottommost image map in the image.

Aligning tool-based image maps

You can align tool-based image maps to the top, 
bottom, left, right, and middle. 

Note: To align layer-based image maps, use the 
Layer > Align Linked command. 
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To align tool-based image maps:

1 Select the tool-based image maps you want to 
align.

2 Choose an option from the Image Map palette 
menu:

• Align Top to align the top edges or points of the 
selected image maps to the top edge or point of the 
topmost image map selected.

• Align Vertical Center to align the vertical centers 
of the selected image maps.

• Align Bottom to align the bottom edges or 
points of the selected image maps to the bottom 
edge or point of the bottommost image map 
selected.

• Align Left to align the left edges or points of the 
selected image maps to the left edge or point of the 
leftmost image map selected.

• Align Horizontal Center to align the horizontal 
centers of the selected image maps.

• Align Right to align the right edges or points of 
the selected image maps to the right edge or point 
of the rightmost image map selected.

Deleting image maps

<<Documentation—verify for layer-based image 
maps>>

You can delete selected image maps by pressing 
Backspace or Delete, or choosing Delete Image 
Map from the Image Map palette menu.

Specifying image map options 
(ImageReady)
You can specify a name, URL, target frame, and Alt 
text for an image map in the Image Map palette.

To change the name of an image map:

1 Select an image map whose name you want to 
change.

2 In Image Map palette, enter a new name in the 
Name text box.

To specify link options for an image map:

1 Select an image map whose link options you 
want to set.

2 In the Image Map palette, enter a URL for the 
link, or choose a previously created URL from the 
URL pop-up menu. You can enter a relative URL 
or a full URL (including http://). 

For layer-based image maps, you can also specify a 
URL in the Layer Options palette or the Layer 
Options dialog box. The URL you enter displays 
under the layer name in the Layers palette.

3 In the Image Map palette, enter the name of a 
target frame in the Target text box, or choose an 
option from the pop-up menu. A frame name 
must match a frame previously defined in the 
HTML file for the document. When a user clicks 
the link, the specified file displays in the new 
frame:

• _blank to display the linked file in a new 
window, leaving the original browser window 
open. 
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• _self to display the linked file in the same frame 
as the original file. 

• _parent to display the linked file in its own 
original parent frameset. Use this option if the 
HTML document contains frames and the current 
frame is a child. The linked file displays in the 
current parent frame.

• _top to replace the entire browser window with 
the linked file, removing all current frames. 

Note: For more information on frames, see an 
HTML reference (either printed or on the Web).

4 In the Image Map palette, enter text for an Alt 
tag in the Alt text box. The Alt text appears in place 
of the image map image in nongraphical browsers. 
In most browsers, it also appears if the user 
positions the mouse over the image map. 

Selecting an image map type 
(ImageReady)
ImageReady can create client-side and server-side 
image maps. In client-side image maps, the links 
are interpreted by the browser itself. In server-side 
image maps, the links are interpreted by the server. 
(Note that server-side image maps do not work 
with sliced images.) Because client-side image 
maps don’t need to contact the server to function, 
they are often significantly faster to navigate. By 
default, ImageReady saves image maps as client-
side image maps.

You select an image map type in the Document 
Settings dialog box. (See “Setting HTML prefer-
ences” on page 370.) If you select a server-side 
image map, ImageReady generates a separate map 
file based on the server option you select.

<<Reviewers—Is this deferred? If not, do we need 
to tell users to edit the HTML file to update the 
location of the map configuration file on the 
server? >>

Working with rollovers 
(ImageReady)
You use the Rollover palette, in conjunction with 
the Layers palette, to add rollover effects to a Web 
page. You can display an animation as a rollover 
state, or you can create secondary rollovers in 
which moving a mouse over one area causes an 
image change in another area. ImageReady adds 
JavaScript code to the resulting HTML file to 
specify rollover states.

Note: When working with rollovers, it is important 
to preview images in a Web browser to ensure your 
document will function correctly for Web users. Also 
remember that image appearance will be different 
on different platforms.

About rollovers

A rollover is a Web effect in which different states 
of an image appear when a viewer performs a 
mouse action—such as rolling or clicking—over 
an area of the Web page. Creating a rollover effect 
combines three components: slices or image maps, 
states, and layers.
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You use a slice or image map to define the active 
area for a rollover. By default, every slice or image 
map has one state—the Normal state. When you 
add a state to the rollover, you capture a snapshot 
of the slice or image map in the previous state. You 
can then use the Layers palette to make changes to 
the image in the new state. You can also add an 
animation to a rollover state. 

<<Art—Replace with before and after of rollover 
states. Retain Normal and Over.>>

How you work with layers is an essential part of 
creating rollovers. Placing the image content for a 
rollover on its own layer allows you to use Layers 
palette commands and options to create rollover 
effects. When creating rollovers or animations, 
some changes you make to a layer affect only the 
active state or frame, while others affect all states 
or frames. (See “Using layers to edit frames” on 
page 330.)

When creating a slice for a rollover, use a layer-
based slice. This is recommended because the 

dimensions of a layer’s content may change in the 
course of creating a rollover, and layer-based slices 
automatically adjust to encompass the new pixels. 
(See “Creating user-slices” on page 301.)

When you save an image with rollover states as a 
Web page, each rollover state is saved as a separate 
file. By default, rollover states are named using the 
corresponding slice name plus the mouse action 
that triggers the rollover state. When you change 
the name of a slice, rollover states in the slice are 
renamed. You can change the default naming 
pattern for slices and rollover states in Slices 
Preferences. (See XREF.)

Using the Rollover palette

You use the Rollover palette to create and set 
options for rollover states. The Rollover palette 
displays thumbnails for each state of a rollover. 
The first state in the Rollover palette is always the 
Normal state.

To change the thumbnail view of rollover states:

1 Choose Palette Options from the Rollover 
palette menu.

2 Select a thumbnail size.

3 Under Thumbnails Show, define the content of 
the thumbnail:

• Current Slice to show only the current slice in 
the thumbnail.

• Entire Document to show the entire image in the 
thumbnail.

4 Click OK.

To select a slice or image map in the Rollover palette:

Choose a slice or image map from the pop-up 
menu at the lower left corner of the Rollover 
palette.
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Creating rollover states

When you create a rollover state, you can select the 
mouse action which activates the state (except for 
the first state in a rollover, which is always the 
Normal state). 

To create a rollover state:

1 Select the slice or image map you want to add 
the rollover to. 

Note: When creating a slice or image map for a 
rollover, use a layer-based slice or a layer-based 
image map. This is recommended because the 
dimensions of a layer’s content may change in the 
course of creating a rollover.

2 In the Rollover palette, create a new state:

• Click the New State button ( ) at the bottom of 
the palette.

• Choose New State from the Rollover palette 
menu.

The new rollover state is identical to the state 
immediately preceding it, until you make modifi-
cations to the image.

3 Use the default rollover state assigned by 
ImageReady, or select a rollover state from the 
pop-up menu above the rollover thumbnail:

• Over to define the rollover state when the Web 
viewer rolls over the slice or image map with the 
mouse with the mouse button up. (Over is 
automatically selected for the second rollover 
state.)

• Down to define the rollover state when the Web 
viewer presses the mouse button on the slice or 
image map. (This state appears as long as the 
viewer keeps the mouse button pressed on the 
slice.)

• Click to define the rollover state when the Web 
viewer clicks the mouse on the slice or image map. 
(This state appears after the viewer clicks the 
mouse and remains until the viewer activates 
another rollover state.)

• Out to define the rollover state when the Web 
viewer rolls the mouse out of the slice or image 
map. (The Normal state usually serves this 
purpose.)

• Up to define the rollover state when the Web 
viewer releases the mouse button over the slice or 
image map. (The Over state usually serves this 
purpose.)

• Custom to define a new rollover state. (You must 
create JavaScript code and add it to the HTML file 
for the document in order for the Custom rollover 
option to function. See a JavaScript manual for 
more information.)

• None to preserve the current state of the image 
for later use as a rollover state. (A state designated 
as None will not be displayed on the Web page.)

The Rollover States pop-up menu displays only 
the rollover states that have not yet been used for 
the selected slice or image map (with the exception 
of the None and Custom states, which are always 
available and can be used repeatedly). You can 
redefine rollover states as you work (with the 
exception of the Normal state).
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4 Modify the image for the rollover state using the 
Layers palette and the ImageReady painting and 
image-editing features.

Previewing rollover states

You can preview rollover states directly in the 
ImageReady document window by switching to 
rollover preview mode. You can also preview 
rollovers in a browser. (See “Previewing an image 
in a browser (ImageReady)” on page 16.)

To use rollover preview mode:

1 Click the Rollover Preview button 
(<<ICON>>) in the toolbox.

2 In the document window, perform the action 
that activates the rollover state. For example, 
positions the mouse over the rollover slice or 
image map to preview the Over state; click the slice 
or image map to preview the Click state.

To exit rollover preview mode:

Click the Rollover Preview button in the toolbox.

Adding animation to rollover states

You use the Animation palette, in conjunction 
with the Rollover palette, to add an animation to a 
rollover state

To add an animation to a rollover state:

1 In the Rollover palette, create a new rollover 
state or select the thumbnail for a rollover state in 
which you want to display an animation.

2 In the Animation palette, create frames for the 
animation. (See “Creating animations” on 
page 325).

Matching layers across rollover states

When you use Layers palette commands to create 
effects for a rollover state, the changes apply only 
to the active state. However, you can use the 
Rollover palette to apply layer changes to all states 
in a rollover or all rollover states associated with an 
image. For more information about working with 
layers when creating rollovers, see “Using layers to 
edit frames” on page 330.

To match layer changes across rollover states:

1 In the Layers palette, select the layer containing 
the element you want to match across states.

2 In the Rollover palette, choose an option from 
the palette menu:

• Match Layer Across States to apply layer 
attributes for the selected state to all states in the 
current rollover.

• Match Layer Across All Rollovers to apply layer 
attributes for the selected state to all states in all 
rollovers associated with the current image.

Copying and pasting rollover states

You can copy a rollover state and paste it into 
another state in the current rollover or into a state 
in another rollover. Layers in the source state 
replace layers in the destination state.
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You can also copy frames from the Animation 
palette and paste them into the Rollover palette as 
states, or copy states from the Rollover palette and 
paste them into the Animation palette as frames. 

Note: Copy commands in the Animation palette and 
the Rollover palette use an internal clipboard 
available to these commands only. Copying frames or 
rollover states does not overwrite the primary 
ImageReady clipboard.

To copy and paste rollover states:

1 Select a rollover state, and choose Copy Rollover 
State from the Rollover palette menu.

2 Select a rollover state in which to paste the 
copied state:

• Select a state in the current rollover.

• Open or display another rollover, and select a 
state.

3 Choose Paste Rollover State from the Rollover 
palette menu.

Deleting rollover states

You can delete individual states or all states in a 
rollover.

To delete rollover states:

• To delete one state, select a rollover state, and 
either click the trash button ( ) on the Rollover 
palette or choose Delete State from the Rollover 
palette menu.

• To delete all states in a rollover, choose Delete 
Rollover from the Rollover palette menu.

Creating Web galleries 
(Photoshop)
You use the Web Photo Gallery command to 
automatically generate a Web site from a set of 
images —complete with a thumbnails index page, 
individual JPEG image pages, and navigable links. 
Photoshop processes the images and creates 
HTML code to simplify the task of publishing your 
images online.

To create a Web gallery:

1 Choose File > Automate > Web Photo Gallery.

2 Click Source to specify the folder containing the 
images you want to export. Select Include All 
Subdirectories to include images inside any 
subfolders of the chosen folder.

3 Click Destination to specify the destination 
folder for the exported HTML files.

4 Select a style for the gallery from the Styles pop-
up menu.

5 Choose Banner from the Options pop-up menu 
to enter information and set options for the 
banner of the gallery pages:

• For Site Name, enter the title of the Web site.

• For Photographer, enter the authorship credit.

• For Date, enter the date you want to appear on 
the Web site. By default, Photoshop uses the 
current date.

• For Font and Font Size, choose options for the 
banner text in the gallery.
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6 Choose Gallery Images from the Options pop-
up menu to set options for individual image pages 
(an individual image page loads when a user clicks 
on a thumbnail image):

• For Border Size, enter the width of the border 
around the image in pixels. 

• Select Resize Images to have Photoshop resize 
the source images for placement on individual 
image pages. Then specify resizing options—for 
Size, choose an option from the menu or enter a 
resize percentage; for Quality, choose an option 
from the menu, enter a value between 0 and 12, or 
drag the slider. A higher value results in better 
image quality but larger file size.

7 Choose Gallery Thumbnails from the Options 
pop-up menu to set options for the thumbnail 
index page:

• Select Use Filename to display the filename 
under each thumbnail.

• Select Use File Info Caption to display Caption 
text from the File Info dialog box under each 
thumbnail. (See “Adding file information 
(Photoshop)” on page 389.)

• For Font and Font Size, select options for the 
thumbnail text.

• For Size, select a size of thumbnails, or enter a 
pixel value for the width of thumbnails.

• For Columns and Rows, specify how many 
columns and rows will appear in the thumbnail 
index page.

• For Border Size, specify the width of the border 
around each thumbnail in pixels. 

8 Choose Customize Colors from the Options 
pop-up menu to set colors for gallery elements. 
Click a color swatch to select a new color using the 
Color Picker.

9 Click OK to create the HTML gallery pages.

Photoshop places the following HTML and JPEG 
files in your destination folder:

• A gallery homepage, index.htm. Open this file in 
any Web browser to preview your photo gallery.

• JPEG images, inside an images subfolder.

• HTML page files, inside a pages subfolder.

• JPEG thumbnail images, inside a thumbnails 
subfolder.
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Chapter 14: Creating Animations 
(ImageReady)

dobe ImageReady provides a powerful, 
easy way to create multiple-frame anima-
tions from a single document. 

Using the Animation and Layers palettes, you can 
create, edit, copy, paste, and rearrange frames in a 
sequence. You can use the powerful Tween feature 
to quickly create new frames that vary a layer’s 
opacity, position, or layer effects, and create the 
illusion of a single element in a frame moving or 
fading in or out. You can also optimize the 
animation, specify looping and repeat options for 
playback, and flatten frames into layers. The 
number of frames you can create is limited only by 
the amount of memory available to ImageReady 
on your system.

If you’re creating an animation as part of a Web 
page, you can use animation techniques in 
conjunction with the Web features. (See “Dividing 
images into slices” on page 1 <<xref desti-
nation?>> and “Working with rollovers 
(ImageReady)” on page 318.) You can also save 
animations as Photoshop files (for reediting) and 
export animations as QuickTime movies.

About animation
An animation is a sequence of images, or frames, 
that is displayed over time. Each frame varies 
slightly from the preceding frame, creating the 
illusion of movement when the frames are viewed 
in quick succession.

How you work with layers is an essential part of 
creating animations in ImageReady. Placing each 
element of an animation on its own layer enables 
you to change the position and appearance of the 
element across a series of frames using the Layers 
palette commands and options. 

<<ART—Show an element changing over 
time>>

Creating animations
You use the Animation palette, in conjunction 
with the Layers palette, to create animation frames 
from an original, multilayer image. You can assign 
a delay time to each frame, use the Tween 
command to generate new frames, and specify 
looping for the animation.

A
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Using the Animation palette

The Animation palette lets you create, view, and 
set options for the frames in an animation. You can 
change the thumbnail view of frames in the 
Animation palette—using smaller thumbnails 
reduces the space required by the palette and 
displays more frames in a given palette width.

To view the Animation palette:

Do one of the following:

• Choose Window > Show Animation.

• Click the Animation palette tab.

To change the thumbnail view of frames:

1 Select Palette Options from the Animation 
palette menu.

2 Select a thumbnail size, and click OK.

Adding frames

Adding frames is the first step in creating an 
animation. If you have an image open in 
ImageReady, the Animation palette displays the 
image as the first frame in a new animation. Each 
frame you add starts as a duplicate of the 
preceding frame. You then make changes to the 
frame using the Layers palette.

Note: Always create and edit frames in Original 
view. While you can view frames in an optimized 
view, the editing options are very limited.

To add a frame to an animation: 

In the Animation palette, do one of the following:

• Click the New Frame button ( ).

• Choose New Frame from the Animation palette 
menu.

Selecting frames

Before you can work with a frame, you must select 
it as the current frame. The contents of the current 
frame display in the document window.

You can select multiple frames, either contiguous 
or discontiguous, to edit them or apply commands 
to them as a group. When multiple frames are 
selected, only the current frame displays in the 
document window.

In the Animation palette, the current frame is 
indicated by a narrow border (inside the shaded 
selection highlight) around the frame thumbnail. 
Selected frames are indicated by a shaded highlight 
around the frame thumbnails. 

To select the current frame:

Do one of the following:

• In the Animation palette, click the thumbnail of 
the frame you want to select as the current frame.

• In the Animation palette or the Layers palette, 
click the Forward button <<(ICON)>> to select 
the next frame in the series as the current frame.

• In the Animation palette or the Layers palette, 
click the Backward button <<(ICON)>> to select 
the previous frame in the series as the current 
frame.

• In the Animation palette, click the Rewind 
button <<(ICON)>> to select the first frame in 
the series as the current frame.
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To select multiple frames:

In the Animation palette, do one of the following:

• To select contiguous multiple frames, Shift-click 
a second frame. The second frame and all frames 
between the first and second are added to the 
selection.

• To select discontiguous multiple frames, Ctrl-
click (Windows) or Command-click (Mac OS) 
additional frames to add those frames to the 
selection.

• To select all frames, choose Select All Frames 
from the Animation palette menu.

To deselect a frame in a multiframe selection:

Alt-click (Windows) or Command-click (Mac OS) 
a frame to deselect it.

Rearranging and deleting frames

You can change the position of frames in an 
animation and reverse the order of selected 
contiguous frames. You can also delete selected 
frames or the entire animation.

To change the position of a frame:

1 Select the frame you want to move. Ctrl-click 
(Windows) or Command-click (Mac OS) to add 
frames to the selection.

2 Drag the selection to the new position.

Note: If you drag multiple discontiguous frames, the 
frames are placed contiguously in the new position.

To reverse the order of contiguous frames:

1 Select the contiguous frames you want to 
reverse.

2 Choose Reverse Frames from the Animation 
palette menu.

To delete selected frames:

Do one of the following:

• Select Delete Frame from the Animation 
palette menu.

• Click the trash button in the Animation palette 
and click Yes to confirm the deletion.

• Drag the selected frame or frames onto the 
Trash button.

To delete an entire animation:

Select Delete Animation from the Animation 
palette menu.

Copying and pasting frames

To understand what happens when you copy and 
paste a frame, think of a frame as a container for 
the layers that make up an image. When you copy 
a frame, you copy all the layers in the frame; when 
you paste a frame, you add layers to the destination 
frame. The pasted layers are visible in the desti-
nation frame, but hidden in other frames of the 
animation.

You can paste layers into a frame in the same 
animation or another animation. You can also 
modify the paste operation to add new frames to 
an animation or replace frames in an animation.
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To copy and paste layers between frames:

1 Select one or more frames. 

2 Choose Copy Frame(s) from the Animation 
palette menu.

3 Select a destination frame in the current 
animation or another animation. If you are 
copying and pasting multiple frames, the first of 
the copied frames is pasted into the selected desti-
nation frame; subsequent copied frames are pasted 
into subsequent destination frames.

4 Do one of the following:

• Choose Paste Frame(s) from the Animation 
palette menu. Identical layers are not added to the 
destination frame.

• Hold down Alt (Windows) or Option (Mac OS), 
and choose Paste Frame(s) to paste all layers into 
the destination frame (regardless of whether 
copied layers are identical to destination layers).

<<Reviewers—Please verify accuracy of modifier 
description. Does Alt/Option work as 
described.>>

To paste new frames into an animation:

1 Select a frame after which to add the copied 
frames.

2 Hold down Shift, and choose Paste Frame(s) 
from the Animation palette menu. The pasted 
layers are visible in the new frame, but hidden in 
other frames.

To replace destination frames with copied frames:

1 Select a destination frame to be replaced by the 
copied frame. If you copied multiple frames, the 
first of the copied frames replaces the selected 
destination frame; subsequent copied frames 
replace subsequent destination frames.

2 Press Shift+Alt (Windows) or Shift+Option 
(Mac OS) and choose Paste Frame(s) from the 
Animation palette menu.

Tweening frames

You use the Tween command to automatically add 
or modify a series of frames between two existing 
frames—varying the layer attributes (position, 
opacity, or effect parameters) evenly between the 
new frames to create the appearance of movement. 
The term “tweening” is derived from “in 
betweening,” the traditional animation term used 
to describe this process. Tweening significantly 
reduces the time required to create animation 
effects such as fading in or fading out, or moving 
an element across a frame. You can edit tweened 
frames individually after you create them.

<<Art—Add graphic demonstrating tweening 
(possible Animation palette before and after 
tweening. Incorporate Layers palette if 
possible.>>
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When you apply the Tween command, 
ImageReady compares the attributes of the 
selected layers between the beginning and ending 
frames. The visual element you want to tween 
must be on the same layer in the beginning frame 
and the ending frame. For example, if you want to 
fade out a layer, set the opacity of the layer in the 
starting frame to 100%; then set the opacity of the 
same layer in the ending frame to 0%. When you 
tween between the two frames, the opacity of the 
layer is reduced evenly across the new frames. 

To create new frames using tweening:

1 To apply tweening to specific layers, select them 
in the Layers palette.

2 Select a single frame or multiple contiguous 
frames.

If you select a single frame, you choose whether to 
tween the frame with the previous frame or the 
next frame. If you select two contiguous frames, 
new frames are added between the frames. If you 
select more than two frames, existing frames 
between the first and last selected frames are 
altered by the tweening operation. If you select the 
first and last frames in an animation, these frames 
are treated as contiguous, and tweened frames are 
added after the last frame. (This tweening method 
is useful when the animation is set to loop multiple 
times.)

Note: You cannot select discontiguous frames for 
tweening.

3 Do one of the following:

• Click the Tween button (<<ICON>>) in the 
Animation palette.

• Choose Tween from the Animation palette 
menu.

4 Specify the layer or layers to be varied in the 
added frames:

• All Layers to vary all layers in the selected frame 
or frames. 

• Layer to vary only the currently selected layer in 
the selected frame or frames. 

5 Specify layer attributes to be varied:

• Position to vary the position of the layer’s 
content in the new frames evenly between the 
beginning and ending frames.

• Opacity to vary the opacity of the new frames 
evenly between the beginning and ending frames.

• Effects to vary the parameter settings of layer 
effects evenly between the beginning and ending 
frames.

6 If you selected a single frame in step 2, choose 
where to add frames from the Tween With menu:

• Next Frame to add frames between the selected 
frame and the following frame. 

• First Frame to add frames between the last frame 
and first frame. This option is only available if you 
select the last frame in the Animation palette.

• Previous Frame to add frames between the 
selected frame and the preceding frame.

7 Enter a value or use the Up or Down Arrow key 
to choose the number of frames to add. (This 
option is not available if you selected more than 
two frames. In this case, the tweening operation 
alters the existing frames between the first and last 
frames in the selection.)
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8 Click OK.

Specifying looping

You select a looping option to specify how many 
times the animation sequence repeats when 
played.

To specify looping:

<<Documentation—verify bug #12075 fixed. 
Otherwise, update procedure to select first frame 
in animation before selecting a looping 
option.>>

1 Click the looping option selection box at the 
lower left corner of the Animation palette.

2 Select a looping option: Once, Forever, or 
Other.

3 If you selected Other, enter a value in the Set 
Loop Count dialog box and click OK.

Specifying delay for frames

You can specify a delay—the time that a frame is 
displayed—for single frames or for multiple 
frames in an animation. Delay time is displayed in 
seconds. Fractions of a second are displayed as 
decimal values. For example, one-quarter second 
is specified as .25.

To specify a delay time:

1 Select one or more frames.

2 In the Animation palette, click on the Delay 
value below the selected frame to view the Delay 
pop-up menu.

3 Specify the delay:

• Choose a value from the pop-up menu. (The last 
value used appears at the bottom of the menu.)

•  Choose Other, enter a value in the Set Frame 
Delay dialog box, and click OK. 

If you selected multiple frames, specifying a delay 
value for one frame applies the value to all frames.

Note: Delay time may not be accurate when 
previewing an animation in ImageReady. For an 
accurate preview of delay time, preview animations 
in a browser. 

Working with layers in 
animations
Working with layers is the key to creating anima-
tions in ImageReady. Each new frame starts out as 
a duplicate of the preceding frame—you edit the 
frame by adjusting its layers.You can apply layer 
changes to a single frame, a group of frames, or the 
entire animation. 

Using layers to edit frames

Note: The following information applies to rollover 
states as well as animation frames.

When you work with layers in a frame, you can 
create or copy selections in the layer; adjust color 
and tone; change the layer’s opacity, blending 
mode, or position; add layer effects; and perform 
editing tasks as you would with layers in any 
image. Using layer attributes to create animation 
effects is very simple, and it allows you to save an 
animation file in Photoshop format for later 
reediting.
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Keep in mind that some changes you make to 
layers affect only the active frame, while others 
affect all frames:

Frame-specific changes Affect only the active frame 
in the animation. Changes you make to a layer 
using Layers palette commands and options—
including a layer’s opacity, blending mode, 
visibility, position, and layer effects—are frame-
specific. 

Global changes Affect all frames in an animation. 
Changes you make to the layer’s pixel values, using 
painting and editing tools, color and tone 
adjustment commands, filters, type, and other 
image-editing commands, affect every frame in 
which the layer is included. In addition, using a 
layer mask affects all frames.

Adding layers to frames

When you create a new layer, it is added to all 
frames in an animation, but is visible only in the 
active frame. For example, if you create a new layer 
in the second frame of a three frame animation, 
the new layer is added to all three frames, but is 
hidden in the first and third frames.

Showing and hiding layers in frames

When you show or hide a layer in a frame, the 
visibility of the layer changes for that frame only. 
For example, if you use a multilayer image to 
create a three-frame animation, and you hide the 
top layer in the second frame, that layer will still be 
visible in first and third frames.

Matching layers across frames

When you use Layers palette commands to edit a 
layer, the changes apply only to the selected frame. 
To apply layer changes to all frames in an 
animation use the Match Layer Across Frames 
command.

To match layer changes across frames:

1 In the Layers palette, select the layer containing 
the element you want to match across frames.

2 In the Animation palette, choose Match Layer 
Across Frames from the palette menu. The layer 
attributes for the selected frame are applied to all 
frames in the animation.
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Setting the frame disposal method 

The frame disposal method specifies whether to 
discard the current frame before displaying the 
next frame. You select a disposal method when 
working with animations that include background 
transparency in order to specify whether the 
current frame will be visible through the trans-
parent areas of the next frame. 

A. Frame with background transparency with Restore to Back-
ground option B. Frame with background transparency with 
Do Not Dispose option

<<Art—Redo icons in following paragraph.>>

The Disposal Method icon indicates whether the 
frame is set to Do Not Dispose ( ) or Restore to 
Background ( ). (No icon appears when disposal 
method is set to Automatic.) 

To choose a disposal method:

1 Select a frame or frames for which you want to 
choose a disposal method. 

2 Right-click (Windows) or Ctrl-click (Mac OS) 
the frame thumbnail to view the Disposal Method 
context menu.

3 Choose a disposal method:

• Automatic to determine a disposal method for 
the current frame automatically, discarding the 
current frame if the next frame contains layer 
transparency. For most animations, the Automatic 
option yields the desired results, and is therefore 
the default option. 

Note: Choose the Automatic disposal option when 
using the Redundant Pixel Removal optimization 
option, to enable ImageReady to preserve frames that 
include transparency. 

• Restore to Background to discard the current 
frame from the display before the next frame is 
displayed. Only a single frame is displayed at any 
time (and the current frame will not appear 
through the transparent areas of the next frame). 
To accurately preview an animation using the 
Restore to Background option, preview the 
animation in a browser.

• Do Not Dispose to preserve the current frame as 
the next frame is added to the display. The current 
frame (and preceding frames) may show through 
transparent areas of the next frame.

Flattening frames into layers

You can flatten animation frames into layers. A 
single, composite layer is created for each frame, 
containing all of the layers in the frame. The 
original layers in the frame are hidden but 
preserved (the original layers will be available if 
they are needed for another frame).

Note: If you save an animation as a GIF, the 
animation frames are flattened and the original 
layers are lost. You should save the original file in 
Photoshop file format to preserve layers for reediting.

A

B
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To flatten frames into layers:

In the Animation palette, choose Flatten Frames 
into Layers from the palette menu.

Viewing animations
Viewing an animation lets you preview the frames 
in timed sequence. You can use the Animation 
palette to preview an animation in ImageReady. 
You can also use the Preview In command to view 
the animation in a browser.

<<Documentation—Update with XREF to 
Chapter 1>>

To view an animation in ImageReady:

1 Click the Play button ( ) in the Animation 
palette. The animation is displayed in the 
document window. The animation repeats indefi-
nitely unless you specified another repeat value in 
the Play Options dialog box. (See “Specifying 
looping” on page 330.)

2 To stop the animation, click the Stop button 
( ).

3 To rewind the animation, click the Rewind 
button <<(ICON)>>.

To preview an animation in a browser:

1 Choose File > Preview In, and select a browser 
from the submenu.

2 Use the browser’s Stop and Reload commands 
to stop or replay the animation.

Optimizing animations
You can apply optimization settings to animated 
images just as you do to non animated images. 
(See “Optimizing images” on page 342.) You 
should always optimize an animation in GIF 
format because GIF is the only format that 
supports the display of animated images on the 
Web. 

Note: While you can optimize an animated image in 
JPEG or PNG format, ImageReady cannot generate 
HTML code for displaying the animation. The 
resulting Web page will display only the first frame of 
the animation.

In addition to the standard optimization options 
for GIF format, you can optimize frames to 
include only areas that change from frame to 
frame. (This greatly reduces the file size of the 
animated GIF.) ImageReady also applies a special 
dithering technique to animations to ensure that 
dither patterns are consistent across all frames and 
to prevent flickering during playback. Due to these 
additional optimization functions, ImageReady 
may require more time to optimize an animated 
GIF than to optimize a standard GIF.

To optimize an animated image:

1 Choose Optimize Animation from the 
Animation palette menu.

2 Set the following options:
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• Bounding Box to crop each frame to the area 
which has changed from the preceding frame. 
Animation files created using this option are 
smaller but are incompatible with GIF editors 
which do not support the option. (This option is 
selected by default and is recommended.)

• Redundant Pixel Removal to make all pixels in a 
frame which are unchanged from the preceding 
frame transparent. This option is selected by 
default, and is recommended. 

Important: Set the frame disposal method to 
Automatic when using the Redundant Pixel 
Removal option. (See “Setting the frame disposal 
method” on page 332.)

3 Click OK.

4 Apply optimization settings as described in 
“Optimizing images” on page 342.

When optimizing the colors in an animation, 
use the adaptive, perceptual, or selective 

palette. This insures that the colors are consistent 
across frames. (See “Selecting a palette option” on 
page 350.)

Saving animations
You can save an animation as a series of GIF files, 
a Photoshop file, or a QuickTime movie.

Saving animations as animated GIFs

Animations that you view in a Web browser are 
called animated GIFs. They are made up of a series 
of separate GIF files, one for each frame of the 
animation. The HTML file specifies where the 
animation appears on the Web page and attributes 
such as frame delay time and looping.

When you save an optimized document 
containing an animation, you can choose to 
generate an HTML file that contains code for 
displaying the animated GIF in a Web page. The 
resulting Web page can contain just the animated 
GIF or additional Web features, such as links and 
rollovers, depending the source document.

To save an animation as an animated GIF:

1 Optimize the animation as described in 
“Optimizing animations” on page 333.

2 Save the image as described in “Saving 
optimized images” on page 367

Saving animations as Photoshop files

Saving an animation as a Photoshop file preserves 
all the information about each frame. You can 
reopen the file in ImageReady and continue to 
work with the animation. You can also open and 
edit the file in Photoshop, but you cannot edit the 
animation frames separately or play the 
animation.
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When you open a file containing an animation in 
Photoshop, only the frame that was selected when 
you saved the file in ImageReady is displayed. If 
you add new layers to the file while in Photoshop, 
the layer is added to all frames of the animation. 
However, the new frame will only show in the 
selected frame when you reopen the file in 
ImageReady. If you change the stacking order of 
layers while in Photoshop, the stacking order of 
layer will be changed when you reopen the file in 
ImageReady.

To save an animation as a Photoshop file:

1 Select the frame of the animation you want to 
display when you open the file in Photoshop.

2 Save the file in PSD format. (See “Saving files” 
on page 375.)

Saving animations as QuickTime movies

You can save an animation as a QuickTime movie. 
The resulting file is viewable in the QuickTime 
player and can be opened in other applications 
that support QuickTime movie format.

To save an animation as a QuickTime movie:

1 Choose File > Export Original.

2 Select QuickTime Movie from the Format 
menu.

Note: On Windows, QuickTime Movie format is 
only available when QuickTime is installed on your 
computer.

<<UI—Label for file format text box is not 
consistent between Windows and Mac.>>

3 Type a filename, and choose a location for the 
file.

4 Click Save.

5 If desired, adjust the compression settings, and 
click OK. QuickTime selects compression settings 
for the file, based on the currently selected 
animation frame.

Opening and importing files as 
animations
You can use the animation features in ImageReady 
to edit animated GIFs, multilayered Photoshop 
files, and QuickTime movies.

Opening animated GIFs

You can open an existing animated GIF in 
ImageReady using the File > Open command. The 
file is opened as a stack of layers. Each layer corre-
sponds to one frame. In each frame, the layer for 
that frame is visible, and the layers for the other 
frames are hidden.

Opening existing animated GIF files in 
ImageReady is useful primarily for applying 
optimization settings to the files. The one-layer-
per-frame structure of imported animated GIF 
files may make it impractical to edit animation 
frames in other ways.

Opening Photoshop files as animations

You can easily create animated GIFs from existing 
one-layer-per-frame images in Adobe Photoshop 
file format or from a group of single-layer images.
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You can make each layer in a multilayer Photoshop 
file a separate frame in the Animation palette. The 
layers are placed in the Animation palette in their 
stacking order, with the bottom layer becoming 
the first frame. 

You can also import a folder of files and use each 
file as a frame in ImageReady. Files can be in any 
format that ImageReady supports. Each file 
becomes a frame in the Animation palette. The 
files are placed in the Animation palette in alpha-
betical order by image filename.

To open a multilayer Photoshop file as frames:

1 Choose File > Open, and select the Photoshop 
file to open.

2 Select Make Frames From Layers in the 
Animation palette menu.

Each layer in the image appears as a frame in the 
Animation palette. The bottom layer in the 
Photoshop image is frame 1 in the Animation 
palette.

To import a folder of files as frames:

1 Place the files to be used as frames into a folder. 
Make sure that the folder contains only those 
images that are to be used as frames. The resulting 
animation will display more successfully if all files 
are the same pixel dimensions. To have frames 
appear in the correct order in the animation, name 
the files in alphabetical or numeric order, with the 
file to be used as frame 1 the first in order. (You can 
also change the order of the frames in the 
Animation palette after you import the files.)

2 Choose File > Import > Import Folder As 
Frames, and choose the folder to be imported.

The files appear in the Animation palette as frames 
and in the Layers palette as layers, with each layer 
assigned to a separate frame. The image that is first 
alphabetically or numerically by filename is frame 
1 in the Animation palette and the bottom layer in 
the Layers palette.

Opening QuickTime movies as animations

You can open movies in MOV, AVI, FLIC, and 
PICT formats to view and edit in ImageReady. 

To open QuickTime-compatible movies:

1 Choose File > Open, and select the movie to 
open.

2 Select the range of frames to import:

• From Beginning to End to open the full file.

• Selected Range Only to open selected frames. 
Drag the slider below the movie thumbnail to 
specify the starting point for the range, then Shift-
drag to specify the ending point. (A black bar on 
the slider indicates the range you select.)

3 Select Limit to Every <number> Frame to 
specify which frames to include from the selected 
range. (You can use this option with either Range 
option.)

4 Click Open.
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Chapter 15: Optimizing Images for 
the Web

reating small graphics files is key to distrib-
uting images on the World Wide Web. With 
smaller files, Web servers can store and 

transmit images more efficiently, and viewers can 
download images more quickly. Likewise, when 
preparing images for CD-ROM or other multi-
media viewing, it’s important to make the image 
files as small as possible. This conserves file storage 
space and decreases the amount of RAM needed 
for image display.

Adobe Photoshop and Adobe ImageReady give 
you an effective range of controls for compressing 
the file size of an image while optimizing its online 
display quality. You can optimize images in the 
three major graphic file formats used on the Web: 
GIF (Graphics Interchange Format), JPEG (Joint 
Photographic Experts Group), and PNG-8 or 
PNG-24 (Portable Network Graphics, with 8-bit 
or 24-bit color).

While Photoshop contains a rich set of features for 
optimizing images for the Web, there may be times 
when you want more sophisticated Web capabil-
ities. ImageReady provides all of the image optimi-
zation features of Photoshop, as well as advanced 
capabilities such as animation and rollovers.

About optimization
Optimization is the process of fine tuning the 
display quality and file size of an image for use on 
the Web or other online media. There are two 
methods of optimizing images:

• For basic optimization, the Photoshop Save As 
command lets you save an image as a GIF, JPEG, or 
PNG file. Depending on the file format, you can 
specify image quality, background transparency or 
matting, color display, and downloading method. 
However, the Save As command does not preserve 
any Web features—such as links, animations, and 
rollovers—that you’ve added to a file.

For complete information on using the Save As 
command to save an image as a GIF, JPEG, or PNG 
file, see “Saving files” on page 375. 

• For precise optimization, you can use the 
optimization features in Photoshop or 
ImageReady to preview optimized images in 
different file formats and with different file 
attributes. You can view multiple versions of an 
image simultaneously and modify optimization 
settings as you preview the image to select the best 
combination of settings for your needs. You can 
also specify background transparency and 
matting, select options to control dithering, and 
resize the image to specified pixel dimensions or a 
specified percentage of the original size.

C



CHAPTER 15338
Optimizing Images for the Web

When you save an optimized file using the Save for 
Web (Photoshop) or Save Optimized 
(ImageReady) command, you can choose to 
generate an HTML file for the image. This file 
contains all the necessary code to display your 
image—as well as links, rollovers, and anima-
tions—in a Web browser.

In ImageReady, you can automate optimization by 
saving Optimize palette settings as a droplet, a 
small application that applies the settings to an 
image or batch of images when activated. 
(See “Using a droplet to automate optimization 
settings (ImageReady)” on page 366.)

Viewing images during 
optimization
View options in Photoshop and ImageReady 
enable you to switch easily between optimized and 
original (non-optimized) versions of an image and 
view up to four versions of an optimized image 
simultaneously.

In Photoshop, you must choose File > Save for 
Web to view and modify optimized images. In 
ImageReady, you can view and modify optimized 
images at any time in the document window.

Selecting a view

There are four options for viewing optimized 
images:

• Original to view the image with no optimi-
zation.

• Optimized to view the image with the current 
optimization settings applied. See “Optimizing 
images” on page 342 for more information on 
applying optimization settings.

• 2-Up to view two versions of the image side by 
side. By default, 2-Up view displays the original 
image and the optimized image with current 
optimization settings.

•  4-Up to view four versions of the image side by 
side. By default, 4-Up view displays the original 
image, the optimized image with current settings, 
and two smaller, lower-quality versions of the 
image based on modifications of the current 
optimization settings.

To select a view option:

1 (Photoshop) Choose File > Save for Web.

2 In the Save for Web dialog box (Photoshop) or 
the document window (ImageReady), click a tab at 
the top of the image display to select a view option. 

To select a view version when optimizing images:

Click the version you want to select. A black frame 
indicates the selected version.

Working in 2-Up and 4-Up view

When you choose 2-Up or 4-Up view, Photoshop 
or ImageReady determines a layout for the images, 
depending on the aspect ratio (width/height ratio) 
of the image, and whether annotations or rules are 
shown. Images can appear in vertical layout, 
horizontal layout, or 2 X 2 layout (two rows and 
two columns). 2 X 2 layout is available for 4-Up 
view only. 
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You can select a version of the image in 2-Up or 4-
Up view to apply new optimization settings. You 
can automatically repopulate 2-Up and 4-Up 
views—generate new optimized versions of the 
image based on the selected version.You can also 
revert an optimized version to the original version 
of the image. 

In ImageReady, you can change the default 
optimizations in Optimization Preferences. 
See “Setting optimization preferences 
(ImageReady)” on page 365.

To repopulate optimized versions of an image in 2-Up 
or 4-Up view:

1 Select an optimized version of the image in the 
2-Up or 4-Up view.

2 In the Optimize panel of the Save for Web dialog 
box (Photoshop) or the Optimize palette 
(ImageReady), select Repopulate Views from the 
menu.

Photoshop and ImageReady generate smaller 
optimized versions of the image based on the 
optimization settings of the selected version. The 
selected version and the original version, if 
present, are not altered during repopulation. For 
this reason, the Repopulate Views option works 
with 2-Up view only if the original version of the 
image is not present.

To restore an optimized version of an image to the 
original version:

1 Select an optimized version of the image in the 
2-Up or 4-Up view.

2 In the Optimize panel/palette, choose Original 
from the Settings pop-up menu.

Navigating in a view

If the entire image is not visible in the view area, 
you can navigate to bring another area of the 
image into view. This is particularly useful when 
working in 2-Up or 4-Up view.

To navigate in a view:

1 Do one of the following:

• Select the hand tool in the Save for Web dialog 
box (Photoshop) or the toolbox (ImageReady).

• Hold down the spacebar.

2 Drag in the view area to pan over the image.

Viewing annotations

In 2-Up and 4-Up view, an annotation area 
appears by default below each optimized image, 
showing its optimization settings. In Photoshop, 
the annotation always shows; in ImageReady, you 
can hide or show the annotation.

To hide or show annotations in 2-Up and 4-Up views 
(ImageReady):

Choose View > Hide/Show Optimization Info.
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Choosing a file format for 
optimization
The file format you choose for an optimized image 
is determined by the color, tonal, and graphic 
characteristics of the original image. In general, 
continuous-tone images such as photographs 
should be compressed as JPEG files. Illustrations 
with flat color or sharp edges and crisp detail, such 
as type, should be compressed as GIF or PNG-8 
files.

PNG-24 file format is suitable for continuous-tone 
images. However, PNG-24 files are often much 
larger than JPEG files of the same image. PNG-24 
format is recommended only when working with a 
continuous-tone image that includes multilevel 
transparency. (Multilevel transparency is 
supported by the PNG-24 format but not the JPEG 
format. See “Preserving multilevel transparency in 
PNG-24 images” on page 361.)

A photograph suitable for compression as a JPEG or 
PNG-24 image, and an illustration suitable for 
compression as a GIF or PNG-8 image

Choose a format that contains sufficient pixel 
depth to display the color information in the 
image. (See “About bit depth” on page 51.) PNG-8 
and GIF files support 8-bit color. JPEG and PNG-
24 files support 24-bit color. Depending on the 
format, you can specify image quality, background 
transparency or matting, color display, and 
downloading method. 

The appearance of an image on the Web also 
depends on the computer platform, color display 
system, operating system, and browser used to 
display the image. Preview images in different 
browsers on different platforms to see how the 
images will appear on the Web. 

About JPEG format

The JPEG format supports 24-bit color and 
preserves the broad range and subtle variations in 
brightness and hue found in photographs and 
other continuous-toned images. JPEG is 
supported by most browsers.

JPEG compresses file size by selectively discarding 
data. Because it discards data, JPEG compression 
is referred to as lossy. A higher quality setting 
results in less data being discarded, but the JPEG 
compression method can degrade sharp detail in 
an image, particularly in images containing type 
or vector art.

Note: Artifacts, such as wave-like patterns or blocky 
areas of banding, are added to a file each time you 
save the file as a JPEG. You should always save JPEG 
files from the original image, not from a previously 
saved JPEG.
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<<Art—Per Dean, combine following three 
graphics>>

Original image, and JPEG with Low quality setting

You can create a progressive JPEG file, in which a 
low-resolution version of the image appears in a 
browser while the full image is downloading. 

The JPEG format does not support transparency. 
When you save an image as a JPEG, transparent 
pixels are filled with the Matte color.(See “Making 
transparent and matted images” on page 358.) 
If you know the background color of the Web page 
where you will place the image, you can match the 
Matte color to the Web page background color to 
simulate the effect of background transparency. 
If your image contains transparency and you do 
not know the Web page background color, or if the 
background will be a pattern, you should use a 
format that supports transparency (GIF, PNG-8, 
or PNG-24).

About GIF format

The GIF format uses 8-bit color and efficiently 
compresses solid areas of color while preserving 
sharp detail, such as that in line art, logos, or 
illustrations with type. You also use the GIF 
format to create animated images. GIF is 
supported by most browsers.

The GIF format traditionally uses a lossless 
compression method, in which no data is 
discarded during compression. You can save a GIF 
file multiple times without discarding data. 
However, because GIF files are 8-bit color, 
optimizing an original 24-bit image as an 8-bit 
GIF will generally degrade image quality.

In addition, Photoshop and ImageReady allow you 
to create a lossy version of a GIF file. The lossy GIF 
format includes small compression artifacts 
(similar to those in JPEG files) but yields signifi-
cantly smaller files.

GIF image with Web color palette with 100% dither 
and with 0% dither

You can reduce the number of colors in a GIF 
image and choose options to control the way 
colors dither in the application or in a browser. 
GIF supports background transparency and 
background matting, in which you blend the edges 
of the image with a Web page background color.

About PNG-8 format

The PNG-8 format uses 8-bit color. Like the GIF 
format, PNG-8 efficiently compresses solid areas 
of color while preserving sharp detail, such as that 
in line art, logos, or illustrations with type. 
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Because PNG-8 is not supported by all browsers, it 
may be advisable to avoid this format for situa-
tions in which your image must be accessible to the 
widest possible Web viewing audience. For more 
information on browser support for PNG, see 
your browser’s documentation. 

The PNG-8 format uses a lossless compression 
method, in which no data is discarded during 
compression. However, because PNG-8 files are 
8-bit color, optimizing an original 24-bit image as 
a PNG-8 can degrade image quality. PNG-8 files 
use more advanced compression schemes than 
GIF, and can be 10–30% smaller than GIF files of 
the same image, depending on the image’s color 
patterns.

Note: With certain images, especially those with very 
few colors and very simple patterns, GIF 
compression may create a smaller file than PNG-8 
compression. View optimized images in GIF and 
PNG-8 format to compare file size.

As with the GIF format, you can reduce the 
number of colors in the image and choose options 
to control the way colors dither in the application 
or in the browser. The PNG-8 format supports 
background transparency and background 
matting, in which you blend the edges of the image 
with a Web page background color.

PNG-8 with 0% dither, and with 100% dither

About PNG-24 format

The PNG-24 format supports 24-bit color. Like 
the JPEG format, PNG-24 preserves the broad 
range and subtle variations in brightness and hue 
found in photographs. Like the GIF and PNG-8 
formats, PNG-24 preserves sharp detail, such as 
that in line art, logos, or illustrations with type.

The PNG-24 format uses the same lossless 
compression method as the PNG-8 format, in 
which no data is discarded. For that reason, 
PNG-24 files are usually larger than JPEG files 
of the same image. PNG-24 browser support is 
similar to that for PNG-8. 

Like the PNG-8 format, the PNG-24 format 
supports background transparency and 
background matting, in which you blend the edges 
of the image with a Web page background color. In 
addition, the PNG-24 format supports multilevel 
transparency, in which you can preserve up to 256 
levels of transparency to blend the edges of an 
image smoothly with any background color. 
However, multilevel transparency is not supported 
by all browsers.

Optimizing images
To optimize an image for the Web, you select a file 
format and other options in the Optimize panel 
(Photoshop) or the Optimize palette 
(ImageReady). You can apply different optimi-
zation settings to different slices in an image. The 
options in the Optimize panel/palette vary 
depending on the file format you select.
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You can optimize an image or slice to a specified 
file size and resize an image during optimization. 
In ImageReady, you can use channels to selectively 
optimize an image.

To view the Optimize panel/palette:

Do one of the following:

• (Photoshop) Choose File > Save for Web. The 
Optimize panel is displayed on the right side of the 
dialog box, beneath the Cancel button.

• (ImageReady) Choose Window > Show 
Optimize or click the Optimize palette tab. To 
show all the optimization options, click the Show 
Options control ( ) on the Optimize palette tab 
or choose Show Options from the Optimize 
palette menu

Using named optimization settings

You can save optimization settings as a named set 
and apply the settings when working with other 
images. Settings that you save appear in the 
Settings pop-up menu in the Optimize 
panel/palette. Photoshop and ImageReady also 
include several predefined named settings.

When you adjust optimization settings so that 
they no longer match a named set, the Settings 
menu displays the term “Unnamed.” In 
ImageReady, when you select multiple slices with 
different optimization settings, the Settings menu 
option is blank.

To save optimization settings:

1 Choose Save Settings from the Optimize 
panel/palette menu.

2 Name the settings and choose a location where 
they will be saved. By default, named settings are 
saved in the following location.

Windows Optimize folder in the Windows/
Application Data/Adobe/Photoshop/6.0 /
Adobe Photoshop Settings folder 

Mac OS Optimize folder in the System/
Preferences/Adobe Photoshop Settings folder

3 Click OK.

To apply named optimization settings to an image:

With an optimized image displayed, select a 
named set of optimization settings from the 
Settings pop-up menu.

To edit a named set of optimization settings:

1 Select the named set from the Settings pop-up 
menu.

2 Adjust the settings as desired in the Optimize 
panel /palette. 

(The Settings menu displays the term “Unnamed,” 
since the settings no longer match a named set.)

3 Choose Save Settings from the Optimize 
panel/palette menu, and save the settings with the 
name of the original set.

4 Click OK, and then click Replace.

To delete named optimization settings:

1 In the Optimize panel/palette, select a named 
set of optimization settings from the Settings pop-
up menu.

2 Choose Delete Settings from the Optimize 
panel/palette menu.
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Setting optimization options for JPEG 
format

JPEG is the standard format for compressing 
continuous-tone images, such as photographs. 
(See “About JPEG format” on page 340.) 

<<Art: Reshoot UI>>

ImageReady Optimize palette JPEG options, 
with hidden options shown:
A. File format B. Quality menu

To optimize an image in JPEG format:

1 Choose a view in which to apply the optimi-
zation setting. (See “Selecting a view” on 
page 338.)

2 Select the slice or slices you want to apply the 
optimization setting to. (See “Selecting slices” on 
page 304.)

3 In the Optimize panel/palette, choose JPEG 
from the file format menu.

4 Do one of the following to specify the image 
quality:

• Choose an option from the Quality menu.

• Drag the Quality pop-up slider.

• Enter a value in the Quality box.

A higher quality setting preserves more color 
information but results in larger file sizes. View the 
JPEG at several quality settings to determine the 
best balance of quality and file size.

5 To create an enhanced JPEG with a slightly 
smaller file size, select Optimized. 

Note: The Optimized JPEG format is recommended 
for maximum file compression. However, some older 
browsers do not support this feature.

6 Select Progressive to create an image that 
displays progressively in a Web browser. The image 
will display as a series of overlays, enabling viewers 
to see a low-resolution version of the image before 
it downloads completely. The Progressive option 
requires use of the Optimized JPEG format. 
Selecting Progressive automatically selects 
Optimized.

Progressive JPEGs require more RAM for viewing, 
and are not supported by some browsers.

7 To apply a blur to the image to smooth rough 
edges, enter a value for Blur or drag the pop-up 
slider.

This option blurs pattern artifacts created along 
sharp edges in the image and creates a smaller file 
size, but may also reduce image detail. A setting of 
0.1 to 0.5 is recommended.

The Blur option applies an effect identical to that 
of the Gaussian Blur filter.

8 To preserve the ICC profile of the image with 
the file, select ICC Profile. 

A

B
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(In ImageReady, click the Show Options control 
( ) on the Optimize palette tab or choose Show 
Options from the Optimize palette menu to view 
the ICC Profile option.)

ICC profiles are used by some browsers for color 
correction. The ICC profile option preserves ICC 
profiles embedded by Photoshop. The option is 
only available with images created in Photoshop, 
in Photoshop file format. For information on ICC 
profiles, see <<XREF>>.

9 If the original image contains transparency, 
select a Matte color to simulate the appearance of 
background transparency. (See “Making trans-
parent and matted images” on page 358.)

(In ImageReady, click the Show Options control 
( ) on the Optimize palette tab or choose Show 
Options from the Optimize palette menu to view 
the Matte option.)

Setting optimization options for GIF and 
PNG-8 formats

GIF is the standard format for compressing images 
with flat color and crisp detail, such as line art, 
logos, or illustrations with type. (See “About GIF 
format” on page 341.)

Like the GIF format, PNG-8 efficiently compresses 
solid areas of color while preserving sharp detail, 
however, not all Web browsers can display PNG-8 
files. (See “About PNG-8 format” on page 341.)

<<Art: Reshoot UI>>

ImageReady Optimize palette GIF options, 
with hidden options shown: 
A. File format B. Color Palette menu
C. Dither algorithm menu

To optimize an image in GIF or PNG-8 format:

1 Choose a view in which to apply the optimi-
zation setting. (See “Selecting a view” on 
page 338.)

2 Select the slice or slices you want to apply the 
optimization setting to. (See “Selecting slices” on 
page 304.)

3 In the Optimize panel/palette, choose GIF 
or PNG-8 from the file format menu.

4 For GIF format only: Drag the Lossy slider or 
enter a value to allow the compression process 
to remove pixels from the image (and reduce 
file size). 

A

B

C
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You can often apply a Lossy value of 5%–10%, and 
sometimes up to 50%, without degrading the 
image. File size can often be reduced 5%–40% 
using the Lossy option. See “Previewing and 
controlling application dither” on page 362.

Note: You cannot use the Lossy option with the Inter-
laced option, or with Noise or Pattern Dither 
algorithms.

5 Select a color palette, as described in “Selecting 
a palette option” on page 350.

6 To choose a specific number of colors, select a 
number from the Colors pop-up menu, enter a 
value in the number field, or use the arrows to 
change the number of colors. 

This option specifies the maximum number of 
colors. If the image contains fewer colors than the 
number specified, the color palette will contain 
only the number of colors in the image.

7 Select Interlaced to create an image that displays 
as low-resolution versions in a browser while the 
full image file is downloading. Interlacing can 
make downloading time seem shorter and assures 
viewers that downloading is in progress. However, 
interlacing also increases file size.

(In ImageReady, click the Show Options control 
( ) on the Optimize palette tab or choose Show 
Options from the Optimize palette menu to view 
the Interlaced option.)

8 Select a Dither option and amount. For infor-
mation on dither, see “Previewing and controlling 
dithering” on page 361.

9 If the image contains transparency, choose an 
option for preserving or filling transparent pixels:

• Select Transparency (the default setting) to 
preserve fully transparent pixels as transparent. 
(Partially transparent pixels are filled with the 
Matte color or converted to fully transparent or 
fully opaque pixels, depending on the Matte 
option you choose.)

• Deselect Transparency to fill fully and partially 
transparent pixels with the Matte color.

Note: The original image must contain transparent 
pixels in order for you to create transparency in the 
optimized image. You can use the magic eraser tool 
( ) to easily create transparency in a document. In 
Photoshop, you can also use the background eraser 
tool ( ).

(In ImageReady, click the Show Options control 
( ) on the Optimize palette tab or choose Show 
Options from the Optimize palette menu to view 
the Transparency option.)

For more information on setting transparency and 
Matte color, see “Making transparent and matted 
images” on page 358. 

10 To automatically shift colors to the closest Web 
palette equivalents (and prevent the colors from 
dithering in a browser), drag the Web Snap slider 
or enter a value to specify a tolerance level for 
colors to be shifted. A higher value shifts more 
colors. See “Previewing and controlling dithering” 
on page 361.

(In ImageReady, click the Show Options control 
( ) on the Optimize palette tab or choose Show 
Options from the Optimize palette menu to view 
the Web Snap option.)
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Setting optimization options for PNG-24 
format

PNG-24 format is suitable for compressing 
continuous-tone images. However, PNG-24 files 
are often much larger than JPEG files of the same 
image. PNG-24 format is recommended only 
when working with a continuous-tone image that 
includes multilevel transparency. (See “About 
PNG-24 format” on page 342.)

To optimize an image in PNG-24 format:

1 Choose a view in which to apply the optimi-
zation setting. (See “Selecting a view” on 
page 338.)

2 Select the slice or slices you want to apply the 
optimization setting to. (See “Selecting slices” on 
page 304.)

3 In the Optimize panel/palette, choose PNG-24 
from the file format menu in the Optimize 
panel/palette.

4 Select Interlaced to create an image that displays 
low-resolution versions in a browser while the full 
image file is downloading. Interlacing can make 
downloading time seem shorter, and assures 
viewers that downloading is in progress.

5 If the image contains transparency, choose an 
option for preserving or filling transparent pixels:

• Select Transparency (the default setting) to 
preserve transparent pixels as transparent.

• Deselect Transparency to fill transparent pixels 
with the Matte color.

Optimizing by file size

You can optimize an image or slice to match a 
specified file size. This feature enables you to 
quickly achieve a desired file size without having to 
test different optimization settings. 

To optimize a file according to a specified file size:

1 Select Optimize to File Size from the Optimize 
panel/palette menu.

2 Select a Start With option:

• Current Settings to use current optimization 
settings.

• Auto Select GIF/JPEG to automatically generate 
a GIF or JPEG. (Photoshop or ImageReady selects 
GIF or JPEG format, depending on an analysis of 
colors in the image.)

3 Select a Slices option:

• Current Slice to optimize the selected slice to the 
specified file size.

• All Slices Separately to optimize each slice in the 
document to the specified file size.

• All Slices Together to optimize the sum of the 
size of all slices to the specified file size.

<<Reviewers—Please verify information in Step 
3. This is new documentation.>>

4 Specify a value for Desired File Size.

5 Click OK.
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Using channels to apply optimization 
settings (ImageReady)

<<Reviewers—Zoned optimization information 
to be completed. Will provide this section for 
review on a separate schedule.>>

Resizing the image during optimization

You can resize the image to specified pixel dimen-
sions or to a percentage of the original size. In 
ImageReady, you can select options to resize irreg-
ularly sized images during batch processing.

Changing the pixel dimensions (and therefore 
display size) of an image is referred to as resam-
pling. When you downsample (or decrease the 
number of pixels), information is deleted from the 
image. When you resample up (or increase the 
number of pixels), new pixel information is added 
based on color values of existing pixels. You specify 
an interpolation method to determine how pixels 
are added or deleted. Keep in mind that changing 
pixel dimensions affects not only the size of an 
image on-screen, but also its image quality. 

To change the pixel dimensions of an image:

1 Choose a method to view Image Size 
commands:

• In Photoshop, choose File > Save for Web and 
click the Image Size tab.

• In ImageReady, choose Image > Image Size.

Note: In Photoshop, you can also resize an image by 
choosing Image > Image Size. However, to resize an 
optimized version of an image only (and not the 
original version), you must use the commands in the 
Save for Web dialog box.

2 To maintain the current proportions of 
pixel width to pixel height, select Constrain 
Proportions. 

3 Constrain the image proportions by selecting:

• Width to constrain proportions using the new 
width value.

• Height to constrain proportions using the new 
height value.

• Either (ImageReady) to constrain proportions 
using either the new width value or the new height 
value. Use the Either option when resizing a batch 
of images of different sizes or proportions that 
need to fit into a standard new image size. 

• Percent to constrain proportions while resizing 
the image by a percent value.

4 Under New Size, enter values for Width, Height, 
or Percent. 

The New Size text field displays the new file size for 
the image.

5 Under Quality, select an interpolation method:

• Jagged (Nearest Neighbor) for the faster, but less 
precise, method. This method is recommended for 
use with illustrations containing non-anti-aliased 
edges, to preserve hard edges and produce a 
smaller file.

• Smooth (Bicubic) for the slower, but more 
precise, method, resulting in smoother 
tonal gradations.

6 In ImageReady, select Do Not Enlarge to 
prevent images that are smaller than the new 
dimensions from being sized up. This option is 
useful when resizing a batch of irregularly 
sized images.
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7 Click Apply (Photoshop) or OK (ImageReady). 

Controlling optimization (ImageReady)

By default, Photoshop and ImageReady automati-
cally regenerate the optimized image when you 
click the Optimized, 2-Up, or 4-Up tab at the top 
of the document (if you have modified the image 
since the last optimization), when you change 
optimization settings with the optimized image 
displayed, or when you edit the original image.

In ImageReady, you can turn off auto-regener-
ation so that the last version of the optimized 
image remains in the image window until you 
manually reoptimize the image or reactivate auto-
regeneration. This feature is useful if you want to 
edit the image without pausing for reoptimization 
with each modification. You can also cancel 
optimization while it’s in progress, and preserve 
the previous image.

When auto-regeneration is turned off, the Regen-
erate button ( ) appears in the lower-right corner 
of each optimized image view. A regeneration alert 
symbol also appears in the Color Table palette if 
the optimized image is in GIF or PNG-8 format, 
indicating that the color table is out of date. 

To turn Auto Regenerate on or off:

In the Optimize palette, choose Auto Regenerate 
from the palette menu. A check mark indicates 
that the option is turned on.

To manually optimize an image:

Choose a method for optimizing:

• Click the Regenerate button ( ) in the lower-
right corner of the optimized image (if it appears).

• Choose Regenerate from the Optimize palette 
menu.

Note: Manually optimizing an image does not turn 
auto-regeneration on.

The Regenerate option is available only when the 
optimized image is out of date (when Auto Regen-
erate is turned off and the image or its optimi-
zation settings are modified, or when optimization 
has been cancelled).

To cancel optimization:

Click the Stop button next to the progress bar at 
the bottom of the image window. 

Optimizing colors in GIF and 
PNG-8 images
Decreasing the number of colors in an image is a 
key factor in optimizing GIF and PNG-8 images. A 
reduced range of colors will often preserve good 
image quality while dramatically reducing the file 
space required to store extra colors.

The color table gives you precise control over the 
colors in optimized GIF and PNG-8 images (as 
well as original images in indexed color mode). 
With a maximum of 256 colors, you can add and 
delete colors in the color table, shift selected colors 
to Web-safe colors, and lock selected colors to 
prevent them from being dropped from the 
palette.

<<Reviewers—please provide information about 
the Rebuild Color Table option.>>



CHAPTER 15350
Optimizing Images for the Web

If an image has multiple slices, the colors in the 
color table may vary between slices. If you select 
multiple slices that use different color tables, the 
color table is empty and its status bar displays the 
message “Mixed.” 

To view the color table:

1 (ImageReady) Choose Window > Show Color 
Table.

2 Select a slice that is optimized in GIF or PNG-8 
format. (See “Selecting slices” on page 304.) 

The color table for the slice appears in the Color 
Table panel in the Save for Web dialog box 
(Photoshop) or the Color Table palette 
(ImageReady).

Important: Be careful not to confuse the Color Table 
panel/palette with the Color palette or Swatches 
palette. 

Selecting a palette option

You can change the palette—or set of colors—in 
the color table by selecting a palette option in the 
Optimize panel/palette. There are three categories 
of palette options:

• Dynamic options use a color reduction 
algorithm to build a palette based on the colors in 
the image and the number of colors specified in 
the optimization setting. The colors in the palette 
are regenerated every time you change or 
reoptimize the image. Perceptual, Selective, 
Adaptive, and Neural Net (ImageReady) are 
dynamic options.

• Fixed options use a set palette of colors, 
regardless of the colors in the image. Web, Mac OS, 
Windows, and user-created tables are fixed 
options.

• The Custom option is a hybrid of the dynamic 
and fixed options. It uses the palette generated by 
a dynamic option to create a fixed palette.

To select a color reduction algorithm:

Choose an option from the palette pop-up menu 
(below the file format menu in the Optimize 
panel/palette):

Perceptual Creates a custom color table by giving 
priority to colors for which the human eye has 
greater sensitivity. 

Selective Creates a color table similar to the 
Perceptual color table, but favoring broad areas 
of color and the preservation of Web colors. 
This color table usually produces images with 
the greatest color integrity. Selective is the 
default option.

Adaptive Creates a custom color table by sampling 
colors from the spectrum appearing most 
commonly in the image. For example, an image 
with only the colors green and blue produces a 
color table made primarily of greens and blues. 
Most images concentrate colors in particular areas 
of the spectrum. 

Neural Net (ImageReady) 

<<Reviewers—please provide description of 
Neural Net option.>>
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Web Uses the standard 216-color color table 
common to the Windows and Mac OS 8-bit (256-
color) palettes. This option ensures that no 
browser dither is applied to colors when the image 
is displayed using 8-bit color. (This palette is also 
called the Web-safe palette.) If your image has 
fewer colors than the total number specified in the 
color palette, unused colors are removed.

Using the Web palette can create larger files, and is 
recommended only when avoiding browser dither 
is a high priority. See “Previewing and controlling 
dithering” on page 361. 

Custom Preserves the current perceptual, selective, 
or adaptive color table as a fixed palette that does 
not update with changes to the image.

Mac OS Uses the Mac OS system’s default 8-bit 
(256-color) color table, which is based on a 
uniform sampling of RGB colors. If your image 
has fewer colors than the total number specified in 
the color palette, unused colors are removed.

Windows Uses the Windows system’s default 8-bit 
(256-color) color table, which is based on a 
uniform sampling of RGB colors. If your image 
has fewer colors than the total number specified in 
the color palette, unused colors are removed.

Other color tables appear in the menu if you have 
saved them previously. See “Loading and saving 
color tables” on page 355.

Sorting the color table

You can sort colors in the color table by hue, 
luminance, or popularity, making it easier to see 
an image’s color range and locate particular colors.

To sort a color table:

Choose a sorting order from the Color Table 
palette menu. To view the menu, click the triangle 
in the upper right corner of the Color Table 
panel/palette.

• Unsorted. Restores the original sorting order.

• Sort By Hue. Neutral colors are assigned a hue of 
0, and located with the reds.

• Sort By Luminance, or by the lightness or 
brightness of a color.

• Sort By Popularity, or by the colors’ frequency of 
occurrence in the image.

Adding new colors to the color table

You can add colors that were left out in building 
the color table. However, the effect of adding a new 
color depends on the color palette type for the 
table. Adding a color to a dynamic table replaces 
the color in the palette closest to the new color. 
Adding a color to a fixed or Custom table adds an 
additional color to the palette. (See “Selecting a 
palette option” on page 350.)

Note: Adding a color changes a named optimization 
setting (see “Using named optimization settings” on 
page 343) back to [Unnamed].

To add a new color:

1 Deselect all colors in the color table 
(see “Selecting colors” on page 352).

2 Choose a color:
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• Click the color selection box in the Save for Web 
dialog box (Photoshop) or the toolbox 
(ImageReady). Choose a color from the Color 
Picker (see <<XREF>>).

• Select the eyedropper tool ( ) in the Save for 
Web dialog box (Photoshop) or the toolbox 
(ImageReady) and click in the image.

• (ImageReady) Select the eyedropper tool ( ), 
click in the image, hold the mouse down, and drag 
anywhere on the desktop. You can use this option 
to select a color displayed in another application, 
such as a color in a Web page displayed in a 
browser.

• (ImageReady) Choose a color from the Color 
palette or the Swatches palette (see <<XREF>>).

3 Do one of the following:

• Click the New Color button ( ) in the Color 
Table panel/palette. 

• Select New Color from the Color Table palette 
menu. 

The new color appears in the color table with a 
small white square in the lower right corner, 
indicating that the color is locked. (See “Locking 
colors in the color table” on page 354.)

Including transparency in a color table

The color table includes a transparency 
swatch ( ) only if the original image contains 
transparent pixels. You can preserve transparent 
pixels in the optimized image or use the matting 
option to fill them with a solid color. (See “Making 
transparent and matted images” on page 358.)

Including black and white in a color table 
(ImageReady)

You can add black and white to the color table 
when the image does not include these colors. 
Including black and white is useful when 
preparing files for multimedia authoring applica-
tions, such as Adobe AfterEffects®.

To add black or white to the color table for an image:

1 Choose black or white as the foreground color. 
(See “Choosing foreground and background 
colors” on page 195.)

2 Add the color to the color table as described in 
“Adding new colors to the color table” on 
page 351.

Selecting colors

You select colors directly in the optimized image 
or in the color table. 

To select a color from the optimized image:

1 Select the eyedropper tool ( ) in the Save for 
Web dialog box (Photoshop) or the toolbox 
(ImageReady).

2 Click a color in the image. A white border ( ) 
appears around that color in the color table. In 
ImageReady, Shift-click to select additional colors.

To select a color directly in the color table:

Click the color in the Color Table panel/palette.

To select a contiguous group of colors, press 
Shift and click another color. All colors in the 
rows between the first and second selected colors 
are selected.
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To select a discontiguous group of colors, press 
Ctrl (Windows) or Command (Mac OS) and click 
each color that you want to select.

To select colors based on a selection in the image 
(ImageReady):

1 Make a selection in the image using the 
selection tools ( , , ) or the Select 
menu commands.

2 Choose Select All From Selection from the 
Color Table palette menu.

To select all colors:

Choose Select All Colors from the Color Table 
palette menu. 

To select all Web-safe colors:

Choose Select All Web Safe Colors from the Color 
Table palette menu.

To select all non-Web-safe colors:

Choose Select All Non-Web Safe Colors from the 
Color Table palette menu.

To view selected colors in an image (ImageReady):

Click and hold a selected color in the Color Table 
palette to temporarily invert the color in the 
optimized image, enabling you to see which areas 
of the image contain the color. 

To view a contiguous group of colors, press Shift 
and click and hold another color. All colors in the 
rows between the first and second selected colors 
are inverted.

To view a discontiguous group of colors, press Ctrl 
(Windows) or Command (Mac OS) and click each 
color that you want to select, and hold the mouse 
button down on any color in the group.

To deselect all colors:

Choose Deselect All Colors from the Color Table 
palette menu.

Editing colors

You can change a selected color in the color table 
to any other RGB color value. When you regen-
erate the optimized image, the selected color 
changes to the new color wherever it appears in the 
image. 

To edit a color:

1 Double-click the color in the color table to 
display the default color picker.

2 Select a color.

A small black diamond ( ) appears in the center 
of each edited color. The edited color replaces the 
original color in the image.

Note: Editing a color also locks it—a white square 
appears in the lower right corner of the color. 
(See “Locking colors in the color table” on page 354)
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Shifting to Web-safe colors

To protect colors from dithering in a browser, you 
can shift the colors to their closest equivalents in 
the Web palette. This ensures that the colors won’t 
dither when displayed in browsers on either 
Windows or Macintosh operating systems capable 
of displaying at least 256 colors. (See “Previewing 
and controlling dithering” on page 361.)

To shift colors to the closest Web palette equivalent:

1 Select one or more colors in the optimized 
image or color table. (See “Selecting colors” on 
page 352.)

2 Do one of the following:

• Click the Web Shift button ( ) in the Color 
Table panel/palette. 

• Choose Web Shift/Unshift Selected Colors from 
the Color Table palette menu.

A small white diamond ( ) appears in the center 
of a Web-shifted color and in all Web-safe colors.

To revert Web-shifted colors to their original colors:

Do one of the following:

• Select a Web-shifted color in the color table and 
click the Web Shift button ( ) in the Color Table 
panel/palette.

• Choose Unshift All Colors from the Color Table 
palette menu.

To specify tolerance for shifting colors automatically 
to the closest Web palette equivalents:

In the Optimize panel/palette, enter a value for 
Web Snap or drag the pop-up slider. A higher 
value shifts more colors. See “Previewing and 
controlling dithering” on page 361.

(In ImageReady, click the Show Options control 
( ) on the Optimize palette tab or choose Show 
Options from the Optimize palette menu to view 
the Web Snap option.)

Locking colors in the color table

You can lock selected colors in the color table to 
prevent them from being dropped when the 
number of colors is reduced and to prevent them 
from dithering in the application.

Note: Locking colors does not prevent them from 
dithering in a browser. (See “Previewing and 
controlling dithering” on page 361.)

To lock a color:

1 Select one or more colors in the color table 
(see “Selecting colors” on page 352).

2 Lock the color:

• Click the Lock button ( ). 

• Choose Lock/Unlock Selected Colors from the 
Color Table palette menu. 

A white square ( ) appears in the lower right 
corner of each locked color. 

Note: If the selected colors include both locked and 
unlocked colors, all colors will be locked.
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To unlock a color:

1 Click the locked color to select it.

2 Unlock the color:

• Click the Lock button ( ).

• Choose Lock/Unlock Selected Colors from the 
Color Table palette menu. 

The white square disappears from the color 
swatch.

Deleting colors from the color table 

You can delete selected colors from the color table 
to decrease the image file size. When you delete a 
color, areas of the optimized image that previously 
included that color are rerendered using the 
closest color remaining in the palette.

When you delete a color, the color palette type 
automatically changes to Custom. This is because 
the Adaptive, Perceptual, and Selective palettes 
automatically add the deleted color back into the 
palette when you reoptimize the image—the 
Custom palette does not change when you 
reoptimize the image.

To delete selected colors:

1 Select one or more colors in the color table 
(see “Selecting colors” on page 352).

2 Delete the color:

• Click on the Trash button.

• Choose Delete Color from the Color Table 
palette menu. 

Loading and saving color tables

You can save color tables from optimized images to 
use with other images and load color tables created 
in other applications. Once you load a new color 
table into an image, the colors in the optimized 
image are changed to reflect the colors in the new 
color table.

To save a color table:

1 Select Save Color Table from the Color Table 
palette menu. 

2 Name the color table and choose a location 
where it will be saved. By default, the color table 
file is given the extension .act (for Adobe Color 
Table).

If you want to access the color table when selecting 
Optimization options for a GIF or PNG image, 
save the color table in the following location:

Windows Color Tables folder in the 
Windows/Application Data/Adobe/Photoshop/
6.0 /Adobe Photoshop Settings folder 

Mac OS Color Tables folder in the System/Prefer-
ences/Adobe Photoshop Settings folder

3 Click Save.

To load a color table:

1 Select Load Color Table from the Color Table 
palette menu.

2 Navigate to a file containing the color table you 
want to load—either an Adobe Color Table (.act) 
file, or a GIF file (to load the file’s embedded 
color table).

3 Click Open.
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Using master palettes

You can create a master palette to use with a group 
of GIF or PNG-8 images that will be placed on a 
CD-ROM or other multimedia storage medium. 
When you include the master palette with a batch 
of images, all images display using the same colors.

To build a master palette, you add colors from a set 
of images and then build and save the master 
palette. To create a master palette for a batch of 
images, you add colors to the palette from other 
optimized images. 

To create and apply a master palette:

1 With an image displayed, choose Image > 
Master Palette > Clear Master Palette (if available). 
Clearing the master palette ensures that colors 
from previous images are not included in the 
new palette.

2 Open an image whose colors you want to 
include in a master palette.

3 Choose Image > Master Palette > Add To Master 
Palette. All color information for the current 
image is added to the master palette.

4 Repeat steps 2 and 3 for all images whose colors 
you want to include in the master palette.

5 In the Optimize palette, select optimization 
settings for the master palette.

6 Choose Image > Master Palette > Build Master 
Palette to create a new color table from the color 
information of images used in steps 2, 3, and 4.

7 Choose Image > Master Palette > Save Master 
Palette. 

8 Name the master palette and choose a location 
where it will be saved. By default, the master 
palette file is given the extension .act (for Adobe 
Color Table).

If you want to access the color table when selecting 
Optimization options for a GIF or PNG image, 
save the master palette in the Color Tables folder, 
inside the Settings folder in the Adobe Photoshop 
folder.

9 Click Save.

10 To apply the master palette to the image or 
images for which it was created, open the image or 
images and select the master palette:

• If the master palette appears in the Color Palette 
menu in the Optimize palette, select the master 
palette from this menu. (The Color Palette menu 
includes all palettes saved in the Palettes folder, 
inside the Settings folder in the Adobe Photoshop 
folder.)

• Load the master palette, as described in 
“Loading and saving color tables” on page 355.

Working with hexadecimal 
values for color 
You can view colors as hexadecimal values in the 
Info palette. In addition, you can copy colors as 
hexadecimal values to the Clipboard and paste 
them into an HTML document.
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Viewing hexadecimal values for colors in 
the Info palette

In Photoshop, hexadecimal values for colors are 
displayed in the Info palette when you select Web 
Color Mode for one or both color readouts. In 
ImageReady, hexadecimal values for colors are 
displayed automatically in the right side of the Info 
palette, next to RGB color values. The Photoshop 
and ImageReady Info palettes also display other 
information, depending on the tool being used. 

To view hexadecimal color values in the Info palette:

1 Choose Window > Show Info or click the Info 
palette tab to view the palette.

2 (Photoshop) Choose Palette Options from the 
palette menu. Under First Color Readout, Second 
Color Readout, or both, choose Web Color from 
the Mode menu and click OK.

3 Position the pointer over the color you want to 
view hexadecimal values for.

Copying colors as hexadecimal values

You can copy colors as hexadecimal values from 
files in Photoshop or ImageReady, using the 
context menu with the eyedropper tool, or using 
menu commands. In Photoshop, you copy a color 
as a hexadecimal value while in the main work area 
(not the Save for Web dialog box). 

To copy a color as a hexadecimal value using the 
eyedropper tool:

1 Select the eyedropper tool ( ) in the toolbox.

2 Select a color to copy:

• (Photoshop) Right-click (Windows) or 
Control+click (Mac OS) a color in the image to 
select the color and view the eyedropper tool 
context menu. 

• (ImageReady) Click the color in the image which 
you want to copy. The color you click becomes the 
foreground color. With the eyedropper tool still 
over the image, right-click (Windows) or 
Control+click (Mac OS) to view the eyedropper 
tool context menu.

3 Choose Copy Color as HTML (Photoshop) or 
Copy Foreground Color as HTML (ImageReady) 
from the eyedropper tool context menu.

The selected color is copied to the Clipboard as a 
hexadecimal value. To paste the color into an 
HTML file, choose Edit > Paste with the HTML 
file displayed in the destination application.

To copy a color as a hexadecimal value using menu 
commands:

1 Select a color to copy.

2 Copy the color:

• (Photoshop) Choose Copy Color As HTML 
from the Color palette menu.

• (ImageReady) Choose Edit > Copy Foreground 
Color as HTML. 

The foreground color is copied to the Clipboard 
as a hexadecimal value. To paste the color into an 
HTML file, open a destination application and 
choose Copy > Paste with the HTML file 
displayed.
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To copy a color as a hexadecimal value by dragging 
(ImageReady):

Drag the Foreground Color from the toolbox or a 
selected color from the Color Table palette or the 
Swatches palette into the HTML file in the desti-
nation application.

Making transparent and matted 
images
Transparency makes it possible to place a non-
rectangular graphic object against the background 
of a Web page. Background transparency, 
supported by GIF and PNG formats, preserves 
transparent pixels in the image. These pixels blend 
with the Web page background in a browser. 

Background matting, supported by GIF, PNG, and 
JPEG formats, simulates transparency by filling or 
blending transparent pixels with a matte color 
which you choose to match the Web page 
background on which the image will be placed. 
Background matting works only if the Web page 
background will be a solid color, and if you know 
what that color will be.

The original image must contain transparent 
pixels in order for you to create background trans-
parency or background matting in the optimized 
image. You can create transparency when you 
create a new layer. 

Note: You can use the magic eraser tool to easily 
create transparency in a document. In Photoshop, 
you can also use the background eraser tool.

To create background transparency in a GIF or PNG 
image:

In the Optimize panel/palette, select Transparency. 
The option is selected by default.

Fully transparent pixels in the image are preserved 
as transparent. If the image is anti-aliased, you can 
matte partially transparent pixels to blend with a 
Web page background color. You can also create 
hard-edged transparency to prevent the halo effect 
that results if an anti-aliased image is matted on a 
color that differs from the image’s original 
background color. If the image contains alpha 
transparency, you can create multilevel trans-
parency to preserve up to 256 levels of trans-
parency (in PNG-24 format only).

Creating background matting in GIF and 
PNG images

When you know the Web page background color 
on which an image will be displayed, you can use 
the matting feature to fill or blend transparent 
pixels with a matte color that matches the Web 
page background. The Web page background must 
be a solid color, not a pattern.
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You can matte GIF and PNG images in two ways. 
You can choose to preserve fully transparent pixels 
as transparent, and matte only the partially trans-
parent pixels, such as those at the edge of an anti-
aliased image. When the image is placed on a Web 
page, the Web background shows through the 
transparent pixels, and the edges of the image 
blend with the background. This feature prevents 
the halo effect that results when an anti-aliased 
image is placed on a background color that differs 
from the image’s original background. This feature 
also prevents the jagged edges that result with GIF 
hard-edged transparency.

You can also deselect Transparency to fill all trans-
parent pixels with the matte color. Fully trans-
parent pixels are filled with the matte color, and 
partially transparent pixels are blended with the 
matte color. 

GIF with a Matte color Transparency option selected, and 
with Transparency option deselected

To create a matted GIF or PNG image:

1 Open or create an image that contains 
transparency. 

2 In the Optimize panel/palette, select GIF, PNG-
8, or PNG-24 from the format menu.

3 (ImageReady) For GIF or PNG-8 format, select 
Show Options from the Optimize palette menu.

4 Choose whether to preserve transparency:

• Select Transparency to preserve fully transparent 
pixels as transparent.

• Deselect Transparency to fill fully transparent 
pixels with the matte color.

5 Select a color from the Matte pop-up menu:

•  (Photoshop) Select None, Eyedropper (to use 
the color in the eyedropper sample box), White, 
Black, or Other (using the color picker).

• (ImageReady) Select None, Foreground Color, 
Background Color, or Other (using the color 
picker), or select a color from the Matte pop-up 
palette.

Creating hard-edged transparency in GIF 
and PNG-8 images

When you apply background matting to images 
that include anti-aliasing, a halo effect can result 
when the matte color is different from the original 
background color of the image. Anti-aliasing 
creates partially transparent pixels around the 
edges of the image to blend the image with the 
original background color.
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When working with GIF or PNG-8 files, you can 
create hard-edged transparency, in which all pixels 
that are more than 50% transparent in the original 
image are fully transparent in the optimized 
image, and all pixels that are more than 50% 
opaque in the original image are fully opaque in 
the optimized image. Hard-edged transparency 
prevents the halo effect. However, hard-edged 
transparency can cause jagged edges in the image. 
To prevent jagged edges, apply background 
matting to the image. See “Creating background 
matting in GIF and PNG images” on page 358.

GIF with hard-edged transparency, and displayed 
in browser (inset at 300% magnification)

To create hard-edged transparency in a GIF or PNG-8:

1 Open or create an image that contains 
transparency. 

2 In the Optimize panel/palette, select GIF or 
PNG-8 from the file format menu.

3 Select Transparency.

4 Select None from the Matte pop-up menu to 
make all pixels with greater than 50% trans-
parency into fully transparent pixels, and all 
pixels with 50% or less transparency into fully 
opaque pixels. 

Creating background matting in JPEG 
images

When creating a JPEG from an original image that 
contains layer transparency, you must matte the 
image against a matte color. Since the JPEG format 
does not support transparency, blending with a 
matte color is the only way to create the 
appearance of background transparency in a 
JPEG. Fully transparent pixels are filled with the 
matte color, and partially transparent pixels are 
blended with the matte color. When the JPEG is 
placed on a Web page with a background that 
matches the matte color, the image appears to 
blend with the Web page background. 

To create a matted JPEG image:

1 Open or create an image that contains 
transparency. 

2 In the Optimize panel/palette, select JPEG from 
the format menu.

3 Select a color from the Matte pop-up menu:

•  (Photoshop) Select None, Eyedropper (to use 
the color in the eyedropper sample box), White, 
Black, or Other (using the color picker).

• (ImageReady) Select None, Foreground Color, 
Background Color, or Other (using the color 
picker), or select a color from the Matte pop-up 
palette.
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Preserving multilevel transparency in 
PNG-24 images

When you create a PNG-24 image, you can 
preserve variable transparency, such as that in an 
anti-aliased image on a transparent layer, using a 
feature called alpha transparency. Alpha trans-
parency preserves up to 256 levels of transparency 
in a PNG image. When the PNG is displayed in a 
browser using a plug-in that supports alpha trans-
parency, the PNG displays multilevel trans-
parency, and the image’s edges will blend with any 
Web background.

To create variable transparency in a PNG-24 image:

1 Open or create an image that contains 
transparency. 

2 In the Optimize panel/palette, select PNG-24 
from the format menu.

3 Select Transparency.

4 Select None from the Matte menu.

Previewing and controlling 
dithering
Most images viewed on the Web are created using 
24-bit color displays (millions of colors mode), 
but many Web browsers are used on computers 
using only 8-bit color displays (256-color mode), 
so that Web images often contain colors not 
available to many Web browsers. Computers use a 
technique called dithering to simulate colors not 
available in the color display system. Dithering 
creates adjacent pixels of different colors to give 
the appearance of a third color. For example, a red 
color and a yellow color may dither in a mosaic 
pattern to produce the illusion of an orange color 
that does not appear in the color palette.

When optimizing images, keep in mind that two 
kinds of dithering can occur:

• Application dither occurs in GIF and PNG-8 
images when Photoshop or ImageReady attempts 
to simulate colors that appear in the original image 
but not in the color palette you specify for the 
optimized image. You can control the application 
dither that Photoshop or ImageReady applies by 
selecting a range of colors to be dithered.

You can choose a dithering pattern to be applied to 
the image. In addition, you can create customized 
dither patterns for GIF or PNG-8 images using the 
DitherBox filter. (See “Creating and applying 
custom dither patterns” on page 363.)

Note: Applying a dithering pattern is not recom-
mended for JPEG or PNG-24 images.
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• Browser dither occurs when a Web browser using 
an 8-bit color display (256-color mode) attempts 
to simulate colors that appear in an optimized 
image but not in the color palette used by the 
browser. Browser dither can occur with GIF, PNG, 
or JPEG images and can occur in addition to appli-
cation dither in GIF or PNG-8 images. You can 
control the amount of browser dither by shifting 
selected colors in the image to Web-safe colors. 
Options in the color picker, the Color palette in 
Photoshop or ImageReady, and the Color Table 
panel (Photoshop) or the Color Table palette 
(ImageReady) let you specify Web-safe colors 
when choosing a color.

Previewing and controlling application 
dither

You can preview application dither in GIF and 
PNG-8 images. The Dither Algorithm pop-up 
menu lets you choose a dithering method for the 
image. The Dither percentage slider lets you 
control the range of colors simulated by dithering. 
A higher dithering percentage creates the 
appearance of more colors and more detail in an 
image, but can also increase the file size. For 
optimal compression, use the lowest percentage of 
application dither that provides the color detail 
you require.

Images with primarily solid colors may work well 
with Dither set to none. Images with continuous-
tone color (especially color gradients) may require 
dithering to prevent color banding.

To choose a dithering method:

Select an option from the Dithering Algorithm 
pop-up menu: 

• No Dither applies no application dither to 
the image.

• Pattern applies a halftone-like square pattern to 
simulate any colors not in the color table.

• Diffusion applies a random pattern that is 
usually less noticeable than Pattern dither. The 
dither effects are diffused across adjacent pixels. In 
ImageReady, Diffusion dither may cause 
detectable seams to appear across slice boundaries. 
Linking slices diffuses the dither pattern across all 
linked slices, and eliminates the seams.

•  Noise applies a random pattern similar to the 
Diffusion dither method, but without diffusing 
the pattern across adjacent pixels. No seams 
appear with the Noise dither method. 

To specify the amount of application dither applied:

1 Choose a dithering method from the Dither 
algorithm menu. To specify no dithering for the 
image, select No Dither from the menu.

2 If you selected any option other than No Dither 
in step 1, drag the Dither slider or enter a value to 
select a dithering percentage.

Previewing browser dither 

You can preview browser dither directly in 
Photoshop or ImageReady, or in a browser that 
uses an 8-bit color display (256-color mode). 
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To preview browser dither:

With an optimized file displayed, preview dither in 
the respective application:

• (Photoshop) Choose Browser Dither from the 
document panel menu in the Save for Web dialog 
box. (To view the menu, click on the triangle by 
the upper right corner of the document panel.)

•  (ImageReady) Choose View > Preview > 
Browser Dither. A check mark next to the 
command indicates that it is turned on. Choose 
View > Preview > Browser Dither again to turn the 
command off.

To preview browser dither in a browser:

1 Set your computer’s color display to 8-bit color 
(256 colors). See your computer operating 
system’s documentation for information on 
changing the color display.

2 Do one of the following:

• Launch your browser and open an optimized 
image directly in the browser.

• (ImageReady) With an optimized image 
displayed, click the Preview in Browser button in 
the toolbox. (See “Previewing an image in a 
browser (ImageReady)” on page 16.)

Minimizing browser dither

Using colors in the Web palette ensures that colors 
won’t dither when displayed in browsers on either 
Windows or Macintosh operating systems capable 
of displaying at least 256 colors.

You have several options for choosing Web-safe 
colors:

• When creating an original image, you can use 
the Color Picker, Color palette, and Swatches 
palette to choose Web-safe colors. (See <<XREF to 
Painting chapter>>.)

• In optimized GIF and PNG-8 images, you can 
shift existing colors to Web-safe colors using the 
color table. (See “Shifting to Web-safe colors” on 
page 354.)

Creating and applying custom dither 
patterns

You can use the DitherBox filter to create a custom 
dither pattern for a selected RGB color. You can 
then fill a selection or a layer in an image with the 
dither pattern. 

You can save custom dither patterns in groups 
called collections, and use the dither patterns with 
other images.

DitherBox uses the current foreground color as 
the RGB color which will be simulated by the 
custom dither pattern. When working in the 
DitherBox filter, you can choose another RGB 
color on which to base the dither pattern. 
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To create and apply a custom dither pattern:

1 With an image displayed in the document 
window (Photoshop) or in Original view 
(ImageReady), use the eyedropper tool to select a 
foreground color which you want to simulate with 
a customized dither pattern. (The foreground 
color becomes the basis for the custom dither 
pattern in DitherBox.)

Note: In Photoshop, you create custom dither 
patterns while in the main Photoshop work area (not 
in the Save for Web dialog box). Make sure the image 
is in RGB color mode. See Photoshop online Help for 
information on color modes.

2 Use the selection tools ( , , ) or the Layers 
palette to select an area or a layer in the image that 
you want to fill with the custom dither pattern.

3 Choose Filter > Other > DitherBox.

The RGB swatch in the DitherBox dialog box 
displays the current foreground color in 
ImageReady. Double-click on the swatch to open 
the color picker and select another RGB color on 
which to base the custom dither pattern.

4 Choose one of the following from the color 
palette pop-up menu in the DitherBox dialog box:

• Web Safe Colors to create a dither pattern using 
colors from the Web palette.

• Load to load another color palette and create a 
dither pattern using those colors. Then navigate to 
the color palette and open it.

Note: If you use non-Web palette colors in a custom 
dither pattern, the colors will dither in a browser 
using an 8-bit color display. Using non-Web colors is 
recommended only for non-Web display.

By default, a new dither pattern you create is saved 
in the current dither pattern collection. 

5 Select a pixel pattern for the custom dither 
pattern from the pattern list, between 2 and 8 
pixels square.

6 Click the arrow button ( ) to display the dither 
pattern that most closely matches the selected RGB 
color in the Pattern preview box. If no dither 
patterns are currently saved in a collection in the 
DitherBox filter, the Pattern preview box displays 
the dither pattern that matches the RGB color. 

7 To edit the custom dither pattern, do one of 
the following:

• To add a color to the dither pattern, click a color 
in the color palette. Then select the pencil tool ( ) 
in the DitherBox dialog box and click in the dither 
pattern grid to add the color.

• To delete a color from the dither pattern, select 
the eraser tool ( ) in the DitherBox dialog box 
and click the color in the dither pattern grid.

The Pattern preview box displays the changes you 
make to the dither pattern.

8 When you are satisfied with the dither pattern, 
click Fill to fill the selected area or layer in the 
current image. 
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The custom dither pattern is applied to the image, 
and the DitherBox dialog box closes.

To apply a previously saved custom dither pattern to 
an image:

1 With an image displayed in Photoshop or 
ImageReady, select an area or a layer in the 
image that you want to fill with the custom 
dither pattern.

2 Choose Filter > Other > DitherBox.

3 Select the collection containing the dither 
pattern you want to use from the Collection 
pop-up menu.

4 Select the dither pattern you want to use from 
the Collection contents list.

5 Click Fill.

The dither pattern is applied to the image, and the 
DitherBox dialog box closes.

To edit dither pattern collections:

Do one of the following in the DitherBox 
dialog box:

• To rename a collection, select the collection from 
the Collection pop-up menu. Then select Rename 
from the Collection pop-up menu. Enter a new 
name for the collection, and click OK.

• To create a new collection, select New from the 
Collection pop-up menu. Enter a name for the 
collection, and click OK.

• To place a saved custom dither pattern in 
another collection, select the dither pattern in 
the Collection contents list. Choose Edit > Copy 
to place a copy of the pattern in another collection, 
or Edit > Cut to move the pattern to another 
collection. Then select the collection where 
you want to place the dither pattern, and choose 
Edit > Paste.

• To delete a collection and all of its contents, 
select the collection from the Collection pop-up 
menu, and then select Delete from the Collection 
pop-up menu.

Setting optimization 
preferences (ImageReady)
You can set preferences in ImageReady to 
determine the default optimization settings 
applied in the Optimized, 2-Up and 4-Up views.

To select the default optimization applied in 
Optimized view:

1 Choose File > Preferences > Optimization.

2 Choose an option in the Default Optimization 
section:

• Select Use the Previously Used Settings to 
automatically apply the last used optimization 
settings.

• Select Auto Select GIF/JPEG to automatically 
optimize the image as a GIF or JPEG. ImageReady 
selects GIF or JPEG based on an analysis of the 
image.
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• Select Use Named Setting and select an option 
from the Named Settings pop-up menu to apply 
that setting.

3 Select other Optimize preferences, or click OK.

To select the default optimization applied in 2-Up and 
4-Up views:

1 Choose File > Preferences > Optimization.

2 Under 2-Up Settings or 4-Up Settings, specify 
settings for the 1st, 2nd, 3rd, and 4th panes (3rd 
and 4th panes apply to 4-Up view only):

• Select Original to display the original image in 
the specified pane. (This option is available for the 
first pane only.)

• Select Current to display the image with current 
Optimize palette settings in the specified pane. 
(This option is available for all panes.)

• Select Auto to display a smaller optimized 
version of the image generated automatically by 
ImageReady, based on the current Optimize 
palette settings. (This option is available for the 
second, third, and fourth panes.)

• Select one of the twelve named settings to display 
the optimized image with those settings. (This 
option is available for the second, third, and fourth 
panes.)

3 Click OK.

Using a droplet to automate 
optimization settings 
(ImageReady)
You can save Optimize palette settings for use on 
individual images or batches of images by creating 
a droplet, a small application that applies the 
optimization settings to an image or batch of 
images that you drag over the droplet icon. You 
can drag a droplet to the desktop or save it to a 
location on disk. When you create the droplet you 
can choose where the images will be saved. When 
you drag an image over it, the droplet launches 
ImageReady if the program is not currently 
running. 

Note: You can also drag a droplet onto the 
ImageReady Actions palette to create an action step, 
or you can drag a droplet onto a slice to apply the 
optimization settings to the slice.

To create a droplet for automating 
Optimize palette settings:

1 With an image displayed in the image window, 
choose a compression format and desired 
compression options in the Optimize palette.

2 Create a droplet:

• Drag the droplet icon ( ) from the Optimize 
palette onto the desktop. 

The droplet is named with a brief description of 
the compression settings, including file format 
and color palette or quality setting information. 
You can rename the droplet as you do other 
desktop icons.
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• Click the droplet icon ( ) on the Optimize 
palette. Name the droplet, choose a location where 
the droplet will be saved, and click Save.

• Choose Create Droplet from the Optimize 
palette menu. Name the droplet, choose a location 
where the droplet will be saved, and click Save.

You can add a droplet to an action by dragging 
the droplet onto the Actions palette, to include 

the optimization settings as part of the action. 

To use a droplet:

1 Drag a single image or a folder of images onto 
the droplet icon.

As the images are processed, a progress 
bar appears.

2 Do any of the following to control 
the processing:

• To temporarily pause the processing, click Pause. 
You can then click Resume to continue the 
processing.

• To cancel the processing, click Stop.

• Let the process finish on its own.

Saving optimized images
There are several ways to save an optimized image 
for use on the Web:

HTML and Images You can generate all files 
required to use your image as a Web page. This 
includes an HTML file and separate image files for 
the slices in the source image. The HTML file 
includes code for any Web effects—such as 
hypertext links, image maps, rollovers, and anima-
tions—in the document. The image files have the 
format and options specified in the optimization 
setting.

Images only You can save your image with the 
format and options specified in the optimization 
setting. If the source image contains multiple 
slices, each slice is saved as a separate file. 

HTML only You can save the HTML code, but not 
the image data, for you image. In ImageReady, you 
can also create an HTML file using the Copy 
HTML command. This command lets you copy 
the HTML code for an optimized image to the 
Clipboard, and paste the HTML code into an 
HTML file. If you subsequently make changes to 
the source image, you can use the Update HTML 
command to update the HTML file.

When saving an optimized image with slices, you 
can choose to save all slices, or only the selected 
slices. 

To save an optimized image:

1 Do one of the following:

• (Photoshop) Choose File > Save for Web, 
optimize the image as desired, and click OK.
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• (ImageReady) Choose File > Save Optimized to 
save the file in its current state. If you previously 
saved the optimized file using the File > Save 
Optimized command, applying the command 
again saves the file with the filename and Save 
options specified in the first save operation. The 
Save dialog box does not appear.

• (ImageReady) Choose File > Save Optimized As 
to save an alternate version of the file with a 
different filename.

2 Type a filename, and choose a location for the 
resulting file or files. 

3 Select a Save As Type option:

• HTML and Images to generate an HTML file 
and save each slice as a separate file.

• Images Only to save each slice in the image as a 
separate file.

• HTML Only to generate an HTML file but not 
save any image files. 

4 To set preferences for saving image files and 
HTML files, click Output Settings. (See “Setting 
output preferences and file information” on 
page 369.)

5 (ImageReady) Select Include GoLive Code to 
reformat HTML and JavaScript code so that 
rollovers will be fully editable in Adobe GoLive™. 
Code is reformatted in the style used by GoLive 
(and may create a larger HTML file).

6 Select an option for slices:

• All Slices to save all slices in the image. 

• Selected Slices to save only the selected slices. If 
you select this option in conjunction with the 
HTML and Images option, ImageReady or 
Photoshop generates the HTML code based on the 
outermost bounds of the selected slices, and 
generates auto-slices as needed to create a 
complete HTML table.

Note: You must select the desired slices before 
starting this procedure. 

7 Click Save.

To copy HTML code to the Clipboard (ImageReady):

Choose Edit > Copy HTML Code, and choose an 
option for copying code from the submenu:

• Copy All Slices to copy HTML code for all slices 
in the document.

• Copy Selected Slices to copy HTML code for 
selected slices only.

• Copy Preloads to copy the JavaScript portion of 
the HTML code for slices in the document.

ImageReady generates and formats HTML code 
based on settings in the Output Options dialog 
box. Be sure to specify HTML options, such as 
whether to use tables or cascading style sheets, 
before you copy and paste HTML code. 
(See “Setting HTML preferences” on page 370.)

To paste the ImageReady HTML code into an 
HTML document, open the HTML document in 
the destination application and choose Edit > 
Paste.

To update HTML code for an image (ImageReady):

1 Choose File > Update HTML.
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2 Select the HTML file into which you pasted 
HTML code for the image.

3 Select Save Images to save the image file when 
you update the HTML code for the image.

4 Click Save.

Setting output preferences and 
file information
You can specify preferences for saving image files 
and HTML files in the Output Settings dialog box. 
In ImageReady, you can also save and load prefer-
ences.

To display the Output Settings dialog box:

Do one of the following:

• (Photoshop) Click Output Settings in the Save 
for Web dialog box. Use this method if you want to 
load and save preferences.

• (ImageReady) Choose the desired preferences 
set from the File > Output Settings submenu. Use 
this method if you want to load and save prefer-
ences.

• When you save an optimized image, click 
Output Settings in the Save Optimized As dialog 
box. 

To switch to a different preference set:

Do one of the following:

• Select the preference set from the menu at the 
top of the dialog box.

• Click Next to display the next preference set in 
the menu list; click Prev to display the previous 
preference set.

Setting file saving preferences

You can set the following options in the Saving 
Files preference set:

File Naming Select elements from the pop-up 
menus or enter text into the fields to be combined 
into the default names for all files. Elements 
include document name, slice name, rollover state, 
trigger slice, file creation date, slice number, 
punctuation, and file extension. Some options are 
relevant only if the file contains slices or rollover 
states.

The fields let you change the order and formatting 
of the filename parts (for example, letting you 
indicate rollover state by an abbreviation instead 
of the full word).

File Name Compatibility Select one or multiple 
options to make the filename compatible with 
Windows (permits longer filenames), Macintosh, 
and UNIX operating systems.

Copy Background Image When Saving To preserve a 
background image that has been specified in the 
Background preferences set. (See “Creating 
background images” on page 372.)

Put Images In Subfolder To specify a folder name 
where optimized images are saved (available only 
with documents containing multiple slices).

Embed Copyright To include copyright infor-
mation with the image. You add copyright infor-
mation for an image in the Image Info dialog box. 
See “Adding file information” on page 371.
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Setting HTML preferences

You can set the following options in the HTML 
preference set:

Tags Case Select the capitalization to be used for 
tags: all uppercase, initial cap, or all lowercase. 
Setting tags and attributes to all uppercase helps 
the code stand out in the file.

Attributes Case Select the capitalization to be used 
for tag attributes: all uppercase, initial cap, second 
initial cap, or all lowercase.

Indent Select a method for indenting lines of code: 
using the authoring application’s tab settings, 
using a specified number of spaces, or using no 
indentation.

Line Endings Select a platform for line ending 
compatibility.

Always Quote Attributes To place quotation marks 
around all tag attributes.Placing quotation marks 
around attributes is required for compatibility 
with certain early browsers and for strict HTML 
compliance. However, always quoting attributes is 
not recommended. Quotation marks are used 
when necessary to comply with most browsers, 
even if this option is deselected.

Include Comments To add explanatory comments 
to the HTML code.

Include GoLive Code To reformat HTML and 
JavaScript code so that rollovers will be fully 
editable in Adobe GoLive™. Code is reformatted in 
the style used by GoLive (and may create a larger 
HTML file).

Generate CSS To generate a Cascading Style Sheet.

Referenced Select an option for <<>>

• By ID to 

• Inline to

• By Class to 

<<Reviewers—Please provide information 
about CSS options>>

Generate Table To align slices using an HTML 
table. 

Empty Cells Select an option for filling empty table 
data cells (slices set to No Image). Select GIF, IMG 
W&H to use a one-pixel GIF with width and 
height values specified on the IMG tag. Select GIF, 
TD W&H to use a one-pixel GIF with width and 
height values specified on the TD tag. Select 
NoWrap, TD W&H to place a non-standard 
NoWrap attribute on the table data and also place 
width and height values specified on the TD tags.

TD W, H Select an option for including width and 
height attributes for table data: Always, Never, or 
Auto (the recommended setting).

Spacer Cells Select an option for adding one row 
and one column of empty spacer cells around the 
generated table: Always, Never, or Auto (the 
recommended setting). Adding spacer cells is 
necessary with table layouts in which slice bound-
aries do not align, to prevent the table from 
breaking apart in some browsers.

Image Map Type Select an option for generating 
image map code:

• Client-Side to include all required code for the 
image map in the image’s HTML file.

• NCSA Server-Side to create a separate .map file 
in addition to the HTML file, using NCSA specifi-
cations.
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• CERN Server-Side to create a separate .map file 
in addition to the HTML file, using CERN 
specifications.

• Client & NCSA to create both a client-side and 
server-side compatible image map, using NCSA 
specifications.

• Client & CERN to create both a client-side and 
server-side compatible image map, using CERN 
specifications.

Note: Contact your Internet Service Provider to find 
out whether to use NCSA or CERN specification for 
server-side image maps.

Image Map Placement Select a placement option:

• Top to

• Body to

• Bottom to

<<Reviewers—Please provide information 
about image map placement options>>

Setting slice naming preferences

You can specify the default naming pattern for 
slices in the Slices preference set. Select elements 
from the pop-up menus or enter text into the fields 
to be combined into the default names for all 
slices. Elements include document name, the word 
“slice,” numbers or letters designating slices or 
rollover states, slice creation date, punctuation, or 
“none.”

Saving and loading preferences

You can save the preferences you set in the Output 
Settings dialog box as a file and reload them to 
apply the same settings to a different file.

<<Reviewers—What is the default location for 
preference files?>>

To save document settings in a file:

1 Choose a preference set from the File > Output 
Settings submenu to open the Output Settings 
dialog box.

2 Set the preferences as desired and click Save.

3 Type a filename and choose a location for the 
saved file.

4 Click Save.

To load document settings:

1 Click Load in the Output Settings dialog box.

2 Select a *.irds file and click Open.

Adding file information

In ImageReady, you can add page title and 
copyright information to an image using the 
Image Info dialog box. 

 In Photoshop, you can add information to 
some files using the File Info dialog box.

You can choose to embed file information in the 
HTML file for an image. Copyright information is 
not displayed in a browser, but can be used in a 
case of copyright infringement to verify copyright. 

To enter information about an image:

1 Choose File > Image Info.

2 In the Page Title text field, type a title for the 
HTML file created for the image.
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3 In the Copyright text field, enter copyright 
information for the image.

4 Click OK.

To embed file information in an HTML file:

Select the Embed Copyright option in the Output 
Settings dialog box (as described in “Setting file 
saving preferences” on page 369).

Creating background images
Many Web pages contain tiled background images 
created from a single graphic repeated as needed to 
fill the entire page. In ImageReady, you can create 
an HTML file that will display the current image as 
a tiled background in a Web browser. You can also 
create an HTML file that will display another 
image or a solid color as a background behind the 
current image. ImageReady includes the <body 
background> tag for the background image and 
the <body bgcolor> tag for the background color 
in the HTML file. 

In addition, you can prepare an image to be used 
as a tiled background using the Tile Maker filter, 
which blends the edges of an image to create a 
seamless background. You can also use the Tile 
Maker filter to create a kaleidoscopic background, 
in which an image is flipped horizontally and 
vertically to create an abstract design.

<<Art—Per Dean, reconsider and improve.>>

Original image, and image prepared using Blend Edges 
displayed as tiled background

Original image, and image prepared using Kaleidoscope 
Tile displayed as tiled background

To specify the current image as a background image:

1 Open the Output Settings dialog box and select 
the Background preference set. (See “Setting 
output preferences and file information” on 
page 369.)

2 For View As, select Background.

3 To select a solid color background to be 
displayed while the background image is 
downloading, or to be displayed through any 
transparent areas in the background image, click 
the Color box and choose a color using the color 
picker. Alternatively, click the triangle next to the 
Color box and select None, Foreground Color, 
Background Color, or Other (using the color 
picker), or select a color from the pop-up palette.
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4 Click OK.

To specify a background to be used with the 
current image:

1 Open the Output Settings dialog box and select 
the Background preference set. (See “Setting 
output preferences and file information” on 
page 369.)

2 For View As, select Image.

3 Select a background:

• To select a background image, click Choose and 
select an image to be used as a background behind 
the current image. 

• To select a solid color background, click the 
Color box and choose a color using the color 
picker. Alternatively, click the triangle next to the 
Color box and select None, Foreground Color, 
Background Color, or Other (using the color 
picker), or select a color from the pop-up palette.

If you select a background image and a 
background color, the background color displays 
while the background image is downloading. It 
also displays through any transparent areas in the 
background image. 

To prepare an image for use as a tiled background 
image (ImageReady):

1 With an image displayed, use the marquee tool 
( ) to select an area in an image to be used as a 
tiled background.

2 Choose Filter > Other > Tile Maker.

3 Choose one of the following:

• Blend Edges to use the selection as a tiled 
background. Then enter a percent value in the 
Width text box to specify how much of the edge to 
blend, usually between 5% and 15%, with a 
maximum of 20%. 

Select Resize Tile to Fill Image to resize the blended 
tile to fill the original selection. Deselect this 
option to create a tile that is smaller than the 
original selection, reduced by the amount 
specified in Width.

• Kaleidoscope Tile to flip and duplicate the 
selection horizontally and vertically and blend the 
edges, to create an abstract design that will be tiled 
on a Web page background.

4 Click OK.

5 Choose Image > Crop > Delete to crop the 
image to the selected area. This is not required if 
you use the entire image to create a tile.
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Chapter 16: Saving and Exporting 
Images

dobe Photoshop and Adobe ImageReady 
support a variety of file formats to suit a 
wide range of output needs. You can save 

or export your image to any of these formats. You 
can also use special Photoshop features to add 
information to files, set up multiple page layouts, 
and place images in other applications.

The saving options that are available to you vary 
between Photoshop and ImageReady. Keep in 
mind that the primary focus of ImageReady is 
producing images for the Web. If ImageReady 
doesn’t provide the file format or option you need, 
you can jump back to Photoshop.

For information about optimizing and saving 
images for the Web, see “Optimizing images” on 
page 342 and “Saving optimized images” on 
page 367.

Saving files
You can save a file with its current filename, 
location, and format or with a different filename, 
location, format, and options. You can also save a 
copy of a file while leaving the current file open on 
your desktop.

Use these commands to save files:

• The Save command to save changes you’ve made 
to the current file. In Photoshop, the file is saved in 
the current format; in ImageReady, the Save 
command always saves to PSD format.

• The Save As command to save an image to a 
different location and filename. In ImageReady, 
the Save As command always saves to PSD format. 
In Photoshop, the Save As command lets you save 
an image in a different format and with different 
options. The available options vary depending on 
the format you choose. See to “Choosing a file 
format” on page 381 for more information on 
available formats.

• (ImageReady) The Export Original command to 
flatten the layers in a copy of the original image 
and save the copy in a variety of file formats. Some 
information (such as slices and optimization 
settings) is not preserved when an original image 
is saved to file formats other than Photoshop.

To save changes to the current file:

Choose File > Save. 

To save a file to a different name and location:

1 Choose File > Save As.

2 Type a filename, and choose a location for the 
file.

A
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3 (Photoshop) Select the As a Copy option to save 
a copy of the file while keeping the current file 
open on your desktop.

4 Click Save.

To save a file in a different file format (Photoshop)

1 Choose File > Save As.

2 Choose a format from the format pop-up 
menu. Unavailable formats are not visible 
(Windows) or dimmed (Mac OS).

3 Type a filename, and choose a location for the 
file.

4 To save a copy of the file while keeping the 
current file open on your desktop, select the As a 
Copy option.

5 Optionally, select one or more of the following 
options:

Note: The availability of options depends of the 
image you are saving and the selected file format. For 
example, if an image doesn’t contain multiple layers, 
or if the selected file format doesn’t support layers, 
the Layers option is dimmed.

• Embed Color Profile to create a color-managed 
document. (See “Embedding profiles in saved 
documents” on page 79.)

• Annotations to save annotations with the image. 
(See <<XREF>>.)

• Layers to preserve all layers in the image. If this 
option is disabled or unavailable, all visible layers 
are flattened. (See “Flattening all layers” on 
page 249.)

• Channel options—Transparency, Alpha, and 
Spot—to save channel information with the 
image. Disabling an option removes the channel 
information from the saved image. 

<<Reviewers—What does the Transparency 
option affect? All transparency or specific to 
channel?>>

• Image Previews options (Mac OS) or Thumbnail 
(Windows) to save thumbnail data for the file. 
Thumbnails display in the Open dialog box. On 
Mac OS, you can set the following image preview 
options: Icon to use the preview as a file icon on 
the desktop; Full Size to save a 72-ppi version of 
the file for use in applications that can only open 
low-resolution Photoshop images; Macintosh 
Thumbnail to display the preview in the Open 
dialog box, Windows Thumbnail to save a preview 
that can display on Windows systems.

To make thumbnail options available when you 
save an image, select Ask When Saving for the 
Image Previews option in the Preferences dialog 
box (see “Setting preferences for saving files 
(Photoshop)” on page 392). 

• File Extension options (Mac OS) or Use Lower 
Case Extensions (Windows) to specify the format 
for file extensions. On Mac OS, select Append to 
add the format’s extension to a filename and Use 
Lower Case to make the extension lower case.

6 Click Save. 
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With some image formats, a dialog box appears. 
The formats requiring a dialog box are described 
in the following sections.

To copy an image without saving it to your hard 
disk, use the Duplicate command (see “Dupli-

cating images” on page 148). To store a temporary 
version of the image in memory, use the History 
palette to create a snapshot (see “Making a snapshot 
of an image (Photoshop)” on page 147).

To save a copy of a file in a different file format 
(ImageReady):

1 Choose File > Export Original.

2 Type a filename, and choose a location for the 
file.

3 Select a file format from the format pop-up 
menu.

4 Click Save. 

To copy an image without saving it to your hard 
drive, use the Image > Duplicate command.

Saving files in Photoshop EPS or DCS 
format (Photoshop)

If you have a PostScript printer, you can use the 
Encapsulated PostScript (EPS) format to share 
Photoshop files effectively with many graphic, 
illustration, and page-layout programs. The 
Desktop Color Separations (DCS) format, a 
version of the standard EPS format, lets you save 
color separations of CMYK or multichannel files. 
You use the DCS 2.0 format to export images 
containing spot channels and single alpha 
channels.

To print EPS and DCS files, you must use a 
PostScript printer. For more information on the 
types of files supported by the EPS and DCS 
formats, see “About file formats” on page 382.

Note: If you plan to export an image to Adobe 
Illustrator or Adobe PageMaker for four-color 
process printing, convert the image to CMYK mode 
and save it in Photoshop EPS or TIFF format. Saving 
a CMYK file as TIFF lets you apply color 
management features to the placed image in 
Illustrator 7.0 or PageMaker 6.5.

To save a file in Photoshop EPS or DCS format:

1 Choose File > Save As and choose Photoshop 
EPS, Photoshop DCS 1.0, or Photoshop DCS 2.0 
from the format list.

2 For Preview, choose a low-resolution preview 
type. To share an EPS file between Windows and 
Macintosh systems, use a TIFF preview. An 8-bit 
preview option results in better display quality but 
higher file size than does a 1-bit preview option. 
You must save a preview of an EPS image in order 
to view the image in the destination application.

Note: To use the JPEG preview option in Mac OS, 
you must have QuickTime installed. 

3 If you are saving to the DCS format, follow these 
guidelines when choosing a DCS option:
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• The DCS 1.0 format creates five files: one for 
each color channel in the CMYK image and a fifth 
master file corresponding to the composite 
channel. You can choose to include a 72-ppi 
grayscale or color version of the composite image 
in the master file. By printing the low-resolution 
composite from the destination application, you 
can proof the image. If you plan to print directly to 
film or want to reduce file size, choose No 
Composite PostScript. To view the composite file, 
you must keep all five files in the same folder 
location.

• The DCS 2.0 format retains spot channels and a 
single alpha channel in the image. You can choose 
between saving color channel information as 
multiple files (as for DCS 1.0) or as a single file. 
The single-file option saves disk space. You can 
also include a 72-ppi grayscale or color composite 
with the image. 

4 Specify an encoding method when printing to a 
PostScript output device:

• ASCII to use the most generic encoding method. 
Use ASCII encoding if you’re printing from a 
Windows system, or if you experience printing 
errors or other difficulties.

• Binary to use a faster encoding method that 
produces a smaller output file and leaves the 
original data intact. Use Binary encoding if you’re 
printing from a Mac OS system. However, some 
page-layout applications and some commercial 
print spooling and network printing software may 
not support binary Photoshop EPS files.

• JPEG to use the fastest encoding method. JPEG 
encoding compresses the file by discarding some 
image data, thus reducing the quality of your 
printed output; for the best printed results, choose 
maximum quality compression. Files with JPEG 
encoding can be printed only on Level 2 (or later) 
PostScript printers and may not separate into 
individual plates.

5 Select Include Halftone Screen and Include 
Transfer Function to save the image’s halftone 
information (including the frequencies and angles 
of the screens) and transfer function information.

The PostScript language interpreter in some appli-
cations can use these screen settings when color 
separations are generated. You can also choose the 
Override Printer’s Default Functions option in the 
Transfer Functions dialog box. (See “Compen-
sating for dot gain in film using transfer functions” 
on page 100.) <<work with Pam to reassign 
XREF>>

6 To display white areas in the image as trans-
parent, select Transparent Whites. This option is 
available only for images in Bitmap mode. 

7 If you are printing to a PostScript printer, select 
PostScript Color Management to instruct the 
printer to convert the file data to the printer’s 
color. Select this option only if you have not 
already converted the file to the printer’s color 
space.

Note: Only PostScript Level 3 printers support 
PostScript Color Management for CMYK images. 
To print a CMYK image using PostScript Color 
Management on a Level 2 printer, convert the image 
to Lab mode before saving in EPS format.
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Saving files in GIF format (Photoshop)

You can use the Save As command to save RGB, 
indexed-color, grayscale, or Bitmap-mode image 
directly in GIF format. When saving an RGB 
image, Photoshop automatically displays the 
Indexed Color dialog box, letting you choose 
indexed-color conversion settings as the image is 
saved to GIF. For more information on GIF 
format, see “About file formats” on page 382.

You can also save an image as one or more GIF 
files using the Save for Web command. For more 

information on optimizing images in GIF format, 
see “About GIF format” on page 341 and “Setting 
optimization options for GIF and PNG-8 formats” 
on page 345.

To save a file in GIF format:

1 Choose File > Save As and choose 
CompuServe GIF from the format list.

2 For RGB images, the Index Color dialog box 
appears. Select a palette, color depth, and dither 
method as described in “Converting to indexed 
color (Photoshop)” on page 56 and click OK

3 Select a row order for the GIF file and click OK:

• Normal to create an image that displays in a 
browser only when it is fully downloaded.

• Interlaced to create an image that displays as 
low-resolution versions in a browser while the full 
image file is downloading. Interlacing can make 
downloading time seem shorter and assures 
viewers that downloading is in progress. However, 
interlacing also increases file size.

<<Reviewers—Should we mention that the 
GIF89a exporter is included as an optional plug-
in? Are there any benefits to using GIF 89a vs. 
CompuServe GIF? Should we include a text/PDF 
file containing the old GIF89a export procedures 
in the Plug-ins folder?>>

Saving files in JPEG format (Photoshop)

You can use the Save As command to save CMYK, 
RGB, and grayscale images in JPEG format. Unlike 
the GIF format, JPEG retains all color information 
in an RGB image but compresses file size by selec-
tively discarding data. For more information on 
JPEG format, see “About file formats” on page 382.

You can also save an image as one or more 
JPEG files using the Save for Web command. 

For more information on optimizing images in JPEG 
format, see “About JPEG format” on page 340 and 
“Setting optimization options for JPEG format” on 
page 344.

To save a file in JPEG format:

1 Choose File > Save As and choose JPEG from 
the format list.

2 Do one of the following to specify the image 
quality:

• Choose an option from the Quality menu.

• Drag the Quality pop-up slider.

• Enter a value between 1 and 12 in the Quality 
text box.

3 Select a format option:

• Baseline (“Standard”) to use a format recog-
nizable to most Web browsers. 
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• Baseline Optimized to optimize the color quality 
of the image and produce a slightly smaller file 
size. This option is not supported by all Web 
browsers. 

• Progressive to create an image that displays 
gradually as it is downloaded—in a series of scans 
(you specify how many) showing increasingly 
detailed versions of the entire image. Progressive 
JPEG images files are slightly larger in size, require 
more RAM for viewing, and are not supported by 
all applications and Web browsers. 

4 If the image contains transparency, select a 
Matte color to simulate the appearance of 
background transparency. (See “Making trans-
parent and matted images” on page 358.)

5 To view the estimated download time of the 
image, select a modem speed from the Size pop-up 
menu. (The Size preview is only available when 
Preview is selected.)

Note: Some applications may not be able to read a 
CMYK file saved in JPEG format. In addition, if you 
find that a Java application cannot read your JPEG 
file (in any color mode), try saving the file without a 
thumbnail preview.

Saving files in Photoshop PDF format 
(Photoshop)

You can use the Save As command to save RGB, 
indexed-color, CMYK, grayscale, Bitmap, and Lab 
color images in Photoshop PDF format. For more 
information on Photoshop PDF format, 
see “About file formats” on page 382.

To save a file in Photoshop PDF format:

1 Choose File > Save As and choose Photoshop 
PDF from the format list.

2 Select an encoding method:

• JPEG for continuous-tone images. For the best 
printed results, choose maximum quality 
compression. Files with JPEG encoding can be 
printed only on Level 2 (or later) PostScript 
printers and may not separate into individual 
plates.

• ZIP for images that contain large areas of a single 
color.

<<Reviewers—Any additional information 
about ZIP encoding?>>

Note: Bitmap images are automatically encoded 
using CCITT compression—the PDF Options dialog 
box does not appear.

3 For CMYK images, select Embed ICC Profiles to 
to create a color-managed document. 
(See “Embedding profiles in saved documents” on 
page 79.)

4 If the image contains vector graphics (such as 
shapes and type), select Include Vector Data to 
preserve vector data in the PDF file.

5 If the image contains type, select Embed Fonts 
to preserve font data in the PDF file.

6 Click OK.
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Choosing a file format
The following list describes the file formats 
available when you open, import, save, or export 
images. If a file format does not appear in the 
appropriate dialog box or submenu, you may need 
to install the format’s plug-in module—additional 
file formats may be available by installing optional 
plug-in modules. (See “Using plug-in modules” 
on page 15.) For more information on a specific 
file format, see “About file formats” on page 382.

File Format Photoshop Access ImageReady 
Access

Photoshop Open
Save As

Open
Export Original

Photoshop 2.0 
(Mac OS only)

Open
Export

Amiga IFF Open
Save As

Open
Export Original

AVI Open

BMP Open
Save As

Open
Export Original

CompuServe GIF Open
Save As

Open

Photoshop EPS

Photoshop DCS

Open
Save As

Open

EPS TIFF Preview

EPS PICT Preview 
(Mac OS only)

Open

Filmstrip Open Open

JPEG Open
Save As

Open

Generic PDF Open Open

Generic EPS Open Open

PCX Open
Save As

Open
Export Original

Photoshop PDF Open
Save As

Acrobat Image 
TouchUp

Open Open

PhotoCD Open Open

PICT File Open
Save As

Open
Export Original

PICT Resource 
(Mac OS only)

Import Import

Pixar Open
Save As

Open
Export Original

PNG Open
Save As

Open

QuicEPS Open

Quicktime Movie Open
Export Original

Raw Open
Save As

Scitex CT Open
Save As

Script Droplet Open

Targa Open
Save As

Open
Export Original

TIFF Open
Save As

Open
Export Original

File Format Photoshop Access ImageReady 
Access
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About file compression

Many image file formats use compression 
techniques to reduce the storage space required by 
bitmap image data. Compression techniques are 
distinguished by whether they remove detail and 
color from the image. Lossless techniques compress 
image data without removing detail; lossy 
techniques compress images by removing detail. 
The following are commonly used compression 
techniques:

• Run Length Encoding (RLE) is a lossless 
compression technique supported by the 
Photoshop and TIFF file formats and some 
common Windows file formats.

• Lemple-Zif-Welch (LZW) is a lossless 
compression technique supported by TIFF, PDF, 
GIF, and PostScript language file formats. This 
technique is most useful in compressing images 
that contain large areas of single color, such as 
screenshots or simple paint images.

• Joint Photographic Experts Group (JPEG) is a 
lossy compression technique supported by JPEG, 
PDF, and PostScript language file formats. JPEG 
compression provides the best results with 
continuous-tone images, such as photographs.

• CCITT encoding is a family of lossless 
compression techniques for black-and-white 
images that is supported by the PDF and 
PostScript language file formats. (CCITT is an 
abbreviation for the French spelling of Interna-
tional Telegraph and Telekeyed Consultive 
Committee.)

• ZIP encoding is a lossless compression 
technique supported by the PDF file format. Like 
LZW, ZIP compression is most effective for images 
that contain large areas of single color.

About file formats

Graphic file formats differ in the way they 
represent graphic information—either as vector 
drawings or as bitmap images. Some formats 
contain only vector drawings or bitmap images, 
but many include both in the same file. 
See “Opening files” on page 35 for information on 
opening files; see the beginning of this chapter for 
information on saving files.

Photoshop format The default file format for 
newly created images—and the only format 
supporting all available image modes (Bitmap, 
Grayscale, Duotone, Indexed Color, RGB, CMYK, 
Lab, and Multichannel), guides, alpha channels, 
spot channels, and layers (including adjustment 
layers, type layers, and layer effects).

You can save an image to a format that doesn’t 
support all features of the document (such as 
layers, slices, and optimization settings). However, 
you will be prompted to save the document in a 
format that supports all of its data. 

New versions of Photoshop provide features that 
are not supported in previous versions. If you edit 
or save a file using an earlier version of Photoshop, 
unsupported features are discarded. The following 
features are only supported in later versions of 
Photoshop:
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<<Reviewers—How far back should we docu-
ment version-specific features—is it necessary to 
document 5.0-specific features, or only 6.0-
specific features.? Please provide information 
about version-specific features for 5.5 and 6.0>>

Photoshop 2.0 format (Photoshop) Mac OS only. 
You can use this format to open a file in version 2.0 
or to export to an application supporting only 
Photoshop 2.0 files. Saving in Photoshop 2.0 
format flattens your file and discards layer infor-
mation.

AVI format (ImageReady) /Windows only. The 
Audio Video Interleave (AVI) format is the 
standard Windows format for audio/video data.

BMP format BMP is the standard Windows image 
format on DOS and Windows-compatible 
computers. The BMP format supports RGB, 
indexed-color, grayscale, and Bitmap color modes, 
and does not support alpha channels. You can 
specify either Microsoft® Windows or OS/2® 
format and a bit depth for the image. For 4-bit and 
8-bit images using Windows format, you can also 
specify RLE compression. 

Photoshop EPS or DCS format (Photoshop) The 
Encapsulated PostScript (EPS) language file 
format can contain both vector and bitmap 
graphics and is supported by virtually all graphic, 
illustration, and page-layout programs. The EPS 
format is used to transfer PostScript language 
artwork between applications. When you open an 
EPS file containing vector graphics created in 
another application, Photoshop rasterizes the file, 
converting the vector graphics to pixels 
(see “Importing Adobe Illustrator, PDF, and EPS 
files (Photoshop)” on page 37) <<xref desti-
nation?>>.

The EPS format supports Lab, CMYK, RGB, 
indexed-color, duotone, grayscale, and Bitmap 
color modes, and does not support alpha 
channels. EPS does support clipping paths. 

If you have a PostScript printer, you can use the 
Encapsulated PostScript (EPS) format to share 
Photoshop files effectively with many graphic, 
illustration, and page-layout programs. The 
Desktop Color Separations (DCS) format, a 
version of the standard EPS format, lets you save 
color separations of CMYK or multichannel files. 
You use the DCS 2.0 format to export images 
containing spot channels and single alpha 
channels.

Feature Supported in version:

6.0 5.5 5.0

Color samplers x x x

Editable type layers x x x

Layer effects x x x

Spot channels x x x

Embedded ICC profiles x x x

Adjustment layers using the 
Hue/Saturation or Channel Mixer 
type

x x x
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To print EPS and DCS files, you must use a 
PostScript printer. For more information on the 
types of files supported by the EPS and DCS 
formats, see “Choosing a file format” on page 381.

Note: If you plan to export an image to Adobe 
Illustrator or Adobe PageMaker for four-color 
process printing, convert the image to CMYK mode 
and save it in Photoshop EPS or TIFF format. Saving 
a CMYK file as TIFF lets you apply color 
management features to the placed image in 
Illustrator 7.0 or PageMaker 6.5.

EPS TIFF or EPS PICT Preview format (Photoshop)
These formats, which appear as options in the 
Open and Open As dialog boxes, let you open 
files saved in file formats that create previews but 
are not supported by Adobe Photoshop (such as 
QuarkXPress®). An opened preview file can be 
edited and used like any other low-resolution file. 
EPS PICT Preview is available only in Mac OS.

Filmstrip format The Filmstrip format is used for 
RGB animation or movie files created by Adobe 
Premiere®. If you resize, resample, remove alpha 
channels, or change the color mode or file format 
of a Filmstrip file in Photoshop, you won’t be able 
to save it back to Filmstrip format. For further 
guidelines, see the Adobe Premiere User Guide.

GIF format The Graphics Interchange Format 
(GIF) is the file format commonly used to display 
indexed-color graphics and images in hypertext 
markup language (HTML) documents over the 
World Wide Web and other online services. GIF is 
a LZW-compressed format designed to minimize 
file size and electronic transfer time. The GIF 
format preserves transparency in indexed-color 
images; however, it does not support alpha 
channels. 

You can save files in GIF format using one of the 
following methods:

• The optimization features in Photoshop and 
ImageReady let you set GIF options for an image 
and save it as one or more files using the File > Save 
for Web command (Photoshop) or File > Save 
Optimized command (ImageReady). For more 
information on optimizing images and saving 
optimized files, see “Optimizing Images for 
the Web” on page 337.

• (Photoshop) The File > Save As command lets 
you save an RGB, indexed-color, grayscale, or 
Bitmap-mode image in GIF format. The Save As 
command does not preserve any Web features—
such as links, animations, and rollovers—that 
you’ve added to a file. (See “Saving files in GIF 
format (Photoshop)” on page 379.)

<<Reviewers—Should we mention that the 
GIF89a exporter as an option?>>
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Amiga IFF format (Photoshop) The Amiga™ Inter-
change File Format (IFF) is used for working with 
Video Toaster and transferring files to and from 
the Commodore Amiga system. In addition, this 
format is supported by a number of paint 
programs on IBM®-compatible computers. IFF is 
the best export format to use with DeluxePaint 
from Electronic Arts. The IFF format supports 
RGB, indexed-color, grayscale, and Bitmap color 
modes, and does not support alpha channels.

JPEG format (Photoshop) The Joint Photographic 
Experts Group (JPEG) format is commonly used 
to display photographs and other continuous-tone 
images in hypertext markup language (HTML) 
documents over the World Wide Web and other 
online services. The JPEG format supports CMYK, 
RGB, and grayscale color modes, and does not 
support alpha channels. Unlike the GIF format, 
JPEG retains all color information in an RGB 
image but compresses file size by selectively 
discarding data. 

A JPEG image is automatically decompressed 
when opened. A higher level of compression 
results in lower image quality, and a lower level of 
compression results in better image quality. In 
most cases, the Maximum quality option produces 
a result indistinguishable from the original. 

You can save files in JPEG format using one of the 
following methods:

• The optimization features in Photoshop and 
ImageReady let you set JPEG options for an image 
and save it as one or more files using the File > Save 
for Web command (Photoshop) or File > Save 
Optimized command (ImageReady). For more 
information on optimizing images and saving 
optimized files, see “Optimizing Images for 
the Web” on page 337.

• (Photoshop) The File > Save As command lets 
you save an image as a single JPEG file. The Save As 
command does not preserve any Web features—
such as links, animations, and rollovers—that 
you’ve added to a file. (See “Saving files in JPEG 
format (Photoshop)” on page 379.)

PCX format The PCX format is commonly used by 
IBM PC-compatible computers. Most PC software 
supports version 5 of the PCX format. A standard 
VGA color palette is used with version 3 files, 
which do not support custom color palettes. 

The PCX format supports RGB, indexed-color, 
grayscale, and Bitmap color modes, and does not 
support alpha channels. PCX supports the RLE 
compression method. Images can have a bit depth 
of 1, 4, 8, or 24.

PDF format Portable Document Format (PDF) is a 
flexible, cross-platform, cross-application file 
format. Based on the PostScript imaging model, 
PDF files accurately display and preserve fonts, 
page layouts, and both vector and bitmap 
graphics. In addition, PDF files can contain 
electronic document search and navigation 
features such as electronic links.

There are several versions of the PDF format:
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• Photoshop PDF files are created using the 
Photoshop Save As command. Photoshop PDF 
files can contain only a single image. 

The Photoshop PDF format supports RGB, 
indexed-color, CMYK, grayscale, Bitmap, and Lab 
color modes, and does not support alpha 
channels. The format supports JPEG and ZIP 
compression, except for Bitmap-mode files, which 
use CCITT Group 4 compression. 

• Acrobat Single Image PDF files are created using 
the Adobe Acrobat TouchUp command and 
comprise only a single image.

• Generic PDF files are created using Adobe 
Acrobat and comprise multiple pages or images. 
PDF files created using Adobe Illustrator also fall 
into this category. When you open a generic PDF 
file, Photoshop rasterizes the image. For multiple-
page PDF files, you can open a single page or each 
page as a separate file.

You all types of PDF files in Photoshop 
(see “Opening PDF files” on page 36). However, 
you can only save images to Photoshop PDF 
format.

PICT File format The PICT format is widely used 
among Macintosh graphics and page-layout appli-
cations as an intermediary file format for trans-
ferring files between applications. The PICT 
format supports RGB files with a single alpha 
channel, and indexed-color, grayscale, and Bitmap 
files without alpha channels. The PICT format is 
especially effective at compressing images with 
large areas of solid color. This compression can be 
dramatic for alpha channels with their large areas 
of white and black. 

When saving an RGB image in PICT format, you 
can choose either a 16-bit or 32-bit pixel 
resolution. For a grayscale image, you can choose 
from 2, 4, or 8 bits per pixel. In Mac OS with 
QuickTime installed, four JPEG compression 
options are available.

PICT Resource format (Photoshop) Mac OS only. A 
PICT resource is a PICT file contained in a Mac OS 
file’s resource fork—for example, an applications’ 
splash screen or the contents of the Scrapbook. 
The PICT Resource format supports RGB files 
with a single alpha channel, and indexed-color, 
grayscale, and Bitmap files without alpha 
channels.

Open a PICT resource by choosing File>Import> 
PICT Resource. When saving a file as a PICT 
resource, you can specify the resource ID and 
resource name. As with other PICT files, you also 
specify bit depth and compression options. 

PIXAR format The PIXAR format is designed 
specifically for exchanging files with PIXAR image 
computers. PIXAR workstations are designed for 
high-end graphics applications, such as those used 
for three-dimensional images and animation. The 
PIXAR format supports RGB and grayscale files 
with a single alpha channel.
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PNG format (Photoshop) Developed as a patent-
free alternative to GIF, the Portable Network 
Graphics (PNG) format is used for losslessly 
compressing and displaying images on the World 
Wide Web. Unlike GIF, PNG supports 24-bit 
images and produces background transparency 
without jagged edges; however, some older 
versions of Web browsers may not support PNG 
images. The PNG format supports grayscale and 
RGB color modes with a single alpha channel, and 
indexed-color mode without alpha channels. In 
Mac OS, PNG also supports Bitmap mode. PNG 
uses the saved alpha channel to define trans-
parency in the file; be sure to delete all but the 
desired alpha channel from your image before 
saving as PNG. The PNG format preserves trans-
parency in indexed-color and RGB images.

When saving in PNG format, you can select 
Adam7 to display the image in increasing detail as 
it is downloaded. You can also run the image 
through a filtering algorithm that prepares the 
image data for optimal compression:

• None compresses the image without a filter, and 
is recommended for indexed-color and Bitmap-
mode images.

• Sub optimizes the compression of images with 
even horizontal patterns or blends.

• Up optimizes the compression of images with 
even vertical patterns.

• Average optimizes the compression of low-level 
noise by averaging the color values of adjacent 
pixels.

• Paeth optimizes the compression of low-level 
noise by reassigning adjacent color values.

• Adaptive applies the filter—Sub, Up, Average, or 
Paeth—best-suited for the image. Select Adaptive 
if you are unsure of which filter to use.

Quicktime Movie format (ImageReady) The 
QuickTime Movie format is a cross-platform 
format used for time-based data, such as video and 
audio. In ImageReady, you can save animations as 
Quicktime movies (see “Saving animations as 
QuickTime movies” on page 335). You can also 
open existing Quicktime movies as animations in 
order to optimize them for the Web (see “Opening 
QuickTime movies as animations” on page 336).

Raw format (Photoshop) The Raw format is a 
flexible file format for transferring files between 
applications and computer platforms. This format 
supports CMYK, RGB, and grayscale files with 
alpha channels, and multichannel, Lab, indexed-
color, and duotone files without alpha channels.

Raw format consists of a stream of bytes describing 
the color information in the file. Each pixel is 
described in binary format, with 0 equaling black 
and 255 white (for images with 16-bit channels, 
the white value is 65535). Adobe Photoshop desig-
nates the number of channels needed to describe 
the image, plus any additional channels in the file. 
You can specify the file extension (Windows), file 
type (Mac OS), file creator (Mac OS), and header 
information.

In Mac OS, the file type is generally a four-
character ID that identifies the file—for example, 
TEXT identifies the file as an ASCII text file. The 
file creator is also generally a four-character ID. 
Most Macintosh applications have a unique file 
creator ID that is registered with the Apple 
Computer Developer Services group. 
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The header parameter specifies how many bytes of 
information appear in the file before actual image 
information begins. This value determines the 
number of zeroes inserted at the beginning of the 
file as placeholders. By default, there is no header 
(header size = 0). You can enter a header when you 
open the file in the Raw format. You can also save 
the file without a header and then use a file-editing 
program, such as HEdit (Windows) or Norton 
Utilities® (Mac OS), to replace the zeros with 
header information.

You can save the image in an interleaved or nonin-
terleaved format. If you choose interleaved, the 
color values (red, green, and blue, for example) are 
stored sequentially. Your choice depends on 
requirements of the application that will open the 
file.

Scitex CT format (Photoshop) The Scitex 
Continuous Tone (CT) format is used for high-
end image processing on Scitex computers. 
Contact Scitex to obtain utilities for transferring 
files saved in the Scitex CT format to a Scitex 
system. The Scitex CT format supports CMYK, 
RGB, and grayscale files, and does not support 
alpha channels.

CMYK images saved in Scitex CT format often 
have extremely large file sizes. These files are 
generated for input using a Scitex scanner. Files 
saved in Scitex CT format are printed to film using 
a Scitex rasterizing unit, which produces separa-
tions using a patented Scitex halftoning system. 
This system produces very few moiré patterns and 
is often demanded in professional color work—for 
example, ads in magazines.

Targa format The TGA (Targa®) format is designed 
for systems using the Truevision® video board and 
is commonly supported by MS-DOS color appli-
cations. The Targa format supports 32-bit RGB 
files with a single alpha channel, and indexed-
color, grayscale, and 16-bit and 24-bit RGB files 
without alpha channels. When saving an RGB 
image in this format, you can choose a pixel depth. 

TIFF format The Tagged-Image File Format (TIFF) 
is used to exchange files between applications and 
computer platforms. TIFF is a flexible bitmap 
image format supported by virtually all paint, 
image-editing, and page-layout applications. Also, 
virtually all desktop scanners can produce TIFF 
images.

The TIFF format supports CMYK, RGB, and 
grayscale files with alpha channels, and Lab, 
indexed-color, and Bitmap files without alpha 
channels. TIFF also supports LZW compression.

When you save an Adobe Photoshop image in 
TIFF, you can choose to save in a format that can 
be read either by IBM PC-compatible or 
Macintosh computers. To compress the file 
automatically, click the LZW Compression check 
box; compressing a TIFF file decreases its file size 
but increases the time required to open and save 
the file. Adobe Photoshop also reads and saves 
captions in TIFF files. For information on using 
captions, see “Adding file information 
(Photoshop)” on page 389. 
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Adding file information 
(Photoshop)
Adobe Photoshop supports the information 
standard developed by the Newspaper Association 
of America (NAA) and the International Press 
Telecommunications Council (IPTC) to identify 
transmitted text and images. This standard 
includes entries for captions, keywords, categories, 
credits, and origins. The captions and keyword 
entries can also be searched by some third-party 
image browsers.

In Windows, you can add file information to files 
saved in the Photoshop, TIFF, JPEG, EPS, and PDF 
formats. In Mac OS, you can add file information 
to files in any format. 

To enter information about a file:

1 Choose File > File Info.

2 For Section, choose an attribute. You can choose 
the following sections:

• Caption provides headline text and special 
instructions for the image.

Note: To print the caption under an Adobe 
Photoshop image, choose File > Page Setup, and 
select Caption. Then print as usual. (See “Printing 
(Photoshop)” on page 399 for more information.)

• Keywords provides a way for some image 
browsers to categorize and search for an image. 
Type in the text box, and click Add to see your text 
in the keyword list. To replace a keyword, select the 
word in the list, type its replacement, and click 
Replace. To delete a keyword, select the word, and 
click Delete.

• Categories lets you enter an alphabetic category 
code of three characters. Where available, the local 
Associated Press regional registry maintains a 
list of categories. To include the image in supple-
mental categories, type the code and click Add. 
To replace a category, select the code, type 
its replacement, and click Replace. To delete a 
category, select the code, and click Delete. 

For Urgency, specify the editorial urgency of the 
image—not its handling priority. 

• Credits provides the correct credit for a 
copyrighted image. Type byline, credit, and source 
information. 

• Origin provides information on the history of 
the image. The Object Name field contains a short 
identification (for example, “Montgomery 
Street”). The date entry can be in any format. 
To enter the current date in a short text format (for 
example, Oct. 25, 1998), click Today.

• Copyright & URL provides copyright infor-
mation not included as part of the IPTC specifi-
cation. To display a copyright symbol in the image 
window’s title bar, select Mark as Copyrighted. 
Enter a copyright notice, and specify the URL if 
information about an image can be found on a 
Web site. If Photoshop detects a Digimarc 
watermark in the image, the Copyright & URL 
section is automatically updated.

3 Choose and fill in any additional sections. To 
move forward through the sections, click Next; to 
move backward, click Previous.

4 When you’ve finished, click OK.
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To load, save, or append file information:

In the File Info dialog box, do one of the following:

• Click Load to replace the current information 
with information stored in a File Info file.

• Click Save to save the current file information in 
a File Info file for later use.

• Click Append to add information stored in a File 
Info file to the current file information.

Adding digital copyright 
information
You can add copyright information to Photoshop 
images and notify users that an image is copyright-
protected via a digital watermark that uses 
Digimarc PictureMarc technology. The 
watermark—a digital code added as noise to the 
image—is generally imperceptible to the human 
eye. The watermark is durable in both digital and 
printed forms, surviving typical image edits and 
file format conversions—and is still detectable 
when the image is printed and then scanned back 
into a computer.

Embedding a digital watermark in an image lets 
viewers obtain complete contact information 
about the creator of the image. This feature is 
particularly valuable to image creators who license 
their work to others. Copying an image with an 
embedded watermark also copies the watermark 
and any information associated with it.

For more detailed information on embedding 
Digimarc watermarks, refer to the Digimarc 
Watermarking Guide, downloadable for free from 
the Digimarc Web site at www.digimarc.com.

Before adding a watermark

Keep in mind the following considerations before 
embedding a digital watermark in your image.

Color variation The image must contain some 
degree of variation or randomness in color to 
embed the watermark effectively and impercep-
tively. The image cannot consist mostly or entirely 
of a single flat color. 

Pixel dimensions The Digimarc technology 
requires a minimum number of pixels (but no 
maximum) to work. Digimarc recommends the 
following minimum pixel dimensions for the 
image to be watermarked:

• 100 pixels by 100 pixels if you don’t expect the 
image to be modified or compressed prior to its 
actual use. 

• 256 pixels by 256 pixels if you expect the image 
to be cropped, rotated, compressed, or otherwise 
modified after watermarking. 

• 750 pixels by 750 pixels, or 2.5 inches by 2.5 
inches, if you expect the image to appear 
ultimately in printed form at 300 dpi or greater. 

There is no upper limit on pixel dimensions for 
watermarking.

File compression In general, a Digimarc 
watermark will survive lossy compression 
methods such as JPEG, though it is advisable to 
favor image quality over file size (a JPEG 
compression setting of 4 or higher works best). In 
addition, the higher the Watermark Durability 
setting you choose when embedding the 
watermark (see “Using the Watermark Durability 
setting” on page 392), the better the chances that 
the watermark will survive compression. 
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Workflow Watermarking should be one of the very 
last tasks you perform, except for file compression. 
Use the following recommended workflow:

• Make all necessary modifications to your image 
until it has the desired final appearance (this 
includes resizing, color correction, etc.).

• Embed the watermark.

• If needed, compress the image by saving it in 
JPEG or GIF format.

• If the image is intended for printed output, 
perform the color separation.

• Read the watermark and use the signal strength 
meter to verify that the image contains a 
watermark of sufficient strength for your 
purposes.

• Publish the watermarked image.

Embedding digital watermarks

To embed a watermark, you must first register 
with Digimarc Corporation—which maintains a 
database of artists, designers, and photographers 
and their contact information—to get a unique 
creator ID. You can then embed the creator ID in 
your images, along with information such as the 
copyright year or a restricted-use identifier. 

To embed a watermark:

1 Open the image that you want to watermark. 
You can embed only one watermark per image. 
The Embed Watermark filter won’t work on an 
image that has been previously marked. 

If you’re working with a layered image, you should 
flatten the image before marking it; otherwise, the 
watermark will affect the active layer only.

Note: You can add a watermark to an indexed-color 
image by first converting the image to RGB mode, 
embedding the watermark, and then converting the 
image back to indexed-color mode. However, the 
results may be inconsistent. To make sure that the 
watermark was embedded, run the Read Watermark 
filter (see “Viewing copyright and file information” 
on page 41). <<xref destination?>>

2 Choose Filter > Digimarc > Embed Watermark. 

3 If you are using the filter for the first time, click 
the Personalize button. Get a Creator ID by 
clicking Register to launch your Web browser and 
visit the Digimarc Web site at www.digimarc.com, 
or by contacting Digimarc at the telephone 
number listed in the dialog box. Enter your PIN 
and ID number in the Creator ID text box, and 
click OK.

(Once you have entered a Creator ID, the Person-
alize button becomes a Change button, allowing 
you to enter a new Creator ID.)

4 Enter a copyright year for the image.

5 Select any of the following image attributes:

• Restricted Use to limit the use of the image.

• Adult Content to label the image contents as 
suitable for adults only. (Within Photoshop, this 
option does not limit access to adult-only images, 
but future versions of other applications may limit 
their display.)

6 For Target Output, specify whether the image is 
intended for monitor or print display.
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7 For Watermark Durability, drag the slider or 
enter a value, as described in the next section.

8 Select Verify to automatically assess the 
watermark’s durability after it is embedded 
(see “Using the signal strength meter” on 
page 392).

9 Click OK.

Using the Watermark Durability setting

The default Watermark Durability setting is 
designed to strike a balance between watermark 
durability and visibility in most images. However, 
you can adjust the Watermark Durability setting 
yourself to suit the needs of your images. Low 
values are less visible in an image, but less durable, 
and may be damaged by applying filters or by 
performing some image-editing operations, 
printing, and scanning operations. High values are 
more durable but may display some visible noise 
in the image.

Your setting should depend on the intended use of 
the image and on the goals you’ve set for your 
watermarks. For example, it may be quite 
acceptable to use a higher Watermark Durability 
setting with JPEG images posted on a Web site. 
The higher durability helps to assure the persis-
tence of the watermark, and the increased visibility 
often is not noticeable with medium-resolution 
JPEG images. Digimarc recommends experi-
menting with various settings as part of your 
testing process to determine which setting works 
best for the majority of your images.

Using the signal strength meter

The signal strength meter helps you determine 
whether a watermark is durable enough to survive 
the intended use of the image. The signal strength 
meter is available only for images containing 
watermarks that you yourself have embedded.

Digimarc recommends that you check the signal 
strength meter before publishing your images. For 
example, if you often compress watermarked 
images for inclusion in a Web site, check the meter 
before posting the images. You can also use the 
signal strength meter to gauge the effectiveness of 
different Watermark Durability settings that you 
are experimenting with.

To check the signal strength meter:

Choose Filter > Digimarc > Read Watermark. The 
signal strength meter appears at the bottom of the 
dialog box. 

You can also display the meter automatically by 
selecting Verify while embedding the watermark 
(see “Embedding digital watermarks” on 
page 391).

Setting preferences for saving 
files (Photoshop)
In Photoshop, the Saving Files Preferences dialog 
box lets you specify whether to include the 
following features when saving files:

• Thumbnail image previews appear in the Open 
dialog box. In Mac OS you can also save desktop 
icon and low-resolution previews. 
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• Three-character file extensions append to the 
names of files and indicate a file’s format (for 
example, .JPG or .jpg for a JPEG file). File exten-
sions are necessary for files that you want to use 
on or transfer to a Windows system.

• Composited image data refers to a flattened 
image version that is saved with a layered file. 
Including flattened data adds to the file size, but 
lets you open the file in applications that do not 
support Photoshop layers, such as 
Adobe Illustrator.

To set saving preferences in Windows:

1 Choose Edit > Preferences > Saving Files.

2 For Image Previews, choose an option:

• Never Save to save files without previews.

• Always Save to save files with specified previews.

• Ask When Saving to assign previews on a file-by-
file basis. 

3 For File Extension, choose an option:

• Use Upper Case to append file extensions using 
uppercase characters.

• Use Lower Case to append file extensions using 
lowercase characters.

4 To include a flattened version of the file, select 
Include Composited Image With Layered Files.

Selecting this option makes the file available to 
applications that can support only the Adobe 
Photoshop 2.5 file format.

5 Click OK.

To set saving preferences In Mac OS:

1 Choose Edit > Preferences > Saving Files.

2 For Image Previews, choose an option:

• Never Save to save files without previews.

• Always Save to save files with specified previews.

• Ask When Saving to assign previews on a file-by-
file basis. 

3 Select one or more of the following preview 
types:

• Icon to use the preview as a file icon on the 
desktop.

• Macintosh Thumbnail to display the preview in 
the Open dialog box.

• Windows Thumbnail to save a preview that can 
display on Windows systems.

• Full Size to save a 72-ppi version of the file for 
use in applications that can only open low-
resolution Photoshop images. For non-EPS files, 
this is a PICT preview. 

To speed the saving of files and minimize file size, 
select only the previews you need.

4 For Append File Extension, choose one of the 
following options:

• Never to save files without file extensions.

• Always to append file extensions to filenames.

• Ask When Saving to append file extensions on a 
file-by-file basis. 

5 To append file extensions using lowercase 
characters, select Use Lower Case.

6 To include a flattened version of the file, select 
Include Composited Image With Layered Files.



CHAPTER 16394
Saving and Exporting Images

Selecting this option makes the file available to 
applications that support only the Adobe 
Photoshop 2.5 (or earlier) file format.

7 Click OK.

In Mac OS, to append a file extension to the 
current file only, hold down Option as you 

choose a file format from the Save As or Save a Copy 
dialog box.

To display a preview file icon (Windows only):

1 Save the file in Photoshop format with a 
thumbnail preview.

2 Position the pointer on the filename in the file 
list, click the right mouse button, and choose 
Properties from the context menu that appears.

3 Click the Photoshop Image tab.

4 For Icon Thumbnails, select a preview icon, and 
click OK.

Preview icons appear on the desktop and in file 
lists (when the view is set to Large Icons).

Creating multiple-image layouts 
(Photoshop)
You can exporting multiple images automatically 
as contact sheets and picture packages using 
Automate commands.

Creating contact sheets

By displaying a series of thumbnail previews on a 
single page, contact sheets let you easily preview 
and catalog groups of images. You can automati-
cally create and place thumbnails on a page using 
the Contact Sheet II command.

Note: Make sure that the images are closed before 
applying this command.

To create a contact sheet:

1 Choose File > Automate > Contact Sheet II.

2 Click Choose to specify the folder containing 
the images you want to use. Select Include All 
Subdirectories to include images inside any 
subfolders of the chosen folder.

3 Under Document, specify the dimensions, 
resolution, and color mode for the contact sheet, 
using the menus to specify measurement units.

4 Under Thumbnails, specify layout options for 
the thumbnail previews:

• For Place, choose whether to arrange thumb-
nails horizontally (from left to right, then top to 
bottom) or vertically (from top to bottom, then 
left to right).

• Enter the number of columns and rows that you 
want per contact sheet. The maximum dimensions 
for each thumbnail are displayed to the right, 
along with a visual preview of the specified layout.

• Select Use Filename As Caption to label the 
thumbnails using their source image filenames. 
Use the menu to specify a caption font.

5 Click OK to create the contact sheet.
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Creating picture packages

With the Picture Package command, you can place 
multiple copies of a source image on a single page, 
similar to the photo packages traditionally sold by 
portrait studios. You can choose from a variety of 
size and placement options to customize your 
package layout.

To create a photo package from a single image:

1 Choose File > Automate > Picture Package.

2 Specify the source image you want to use:

• Click Choose to specify a saved image file as 
the source. 

• Select Use Frontmost Document to use the 
image currently active in Photoshop as the source.

3 For Layout, choose a preset layout option. 
Layout dimensions are measured in inches, and 
a preview of the chosen layout appears in the 
dialog box.

4 Enter a resolution value for the package layout, 
using the menu to specify resolution units.

5 Choose a color mode appropriate to the 
package layout.

6 Click OK to create the package layout.

Placing Photoshop images in 
other applications (Photoshop)
Photoshop provides a number of features to help 
you use images in other applications. You can use 
clipping paths to define transparent areas in 
images you place in page-layout applications. In 
addition, Mac OS users can embed Photoshop 
images in many word-processor files.

 For assistance with clipping paths, choose Help 
> Export Transparent Image. This interactive 

wizard helps you prepare images with transparency 
for export to a page-layout application.

Using clipping paths

When printing a Photoshop image or placing it in 
another application, you may want only part of the 
image to appear. For example, you may want to 
print or show a foreground object and exclude its 
rectangular background. A clipping path lets you 
isolate the foreground object and make everything 
outside the object transparent when the image is 
printed or placed in another application. This lets 
you place an image into another file without 
obscuring the other file’s background.

Image imported into Illustrator without clipping path, 
and with clipping path
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To save a path as a clipping path:

1 Draw and save a path or convert an existing 
selection into a path. For information on creating 
selections and paths, see “Selecting” on page 115.

2 Choose Clipping Path from the Paths 
palette menu.

3 For Path, choose the path you want to save.

4 For good results with most images, leave the 
flatness value blank to print the image using the 
printer’s default value. If you experience printing 
errors, enter a new flatness value. 

Values can range from 0.2 to 100. In general, a 
flatness setting from 8 to 10 is recommended for 
high-resolution printing (1200 dpi to 2400 dpi), 
a setting from 1 to 3 for low-resolution printing 
(300 dpi to 600 dpi).

The PostScript interpreter creates curved 
segments by linking a series of straight line 
segments. The flatness setting for a clipping path 
determines how closely the straight line segments 
approximate the curve. The lower the flatness 
value, the greater is the number of straight lines 
used to draw the curve and the more accurate 
the curve. 

5 Click OK.

If you plan to print the file using process colors, 
convert the file to CMYK mode. (See “Converting 
to CMYK” on page 102.) <<xref destination?>>

6 Save the file:

• To print the file using a PostScript printer, save 
in Photoshop EPS, DCS, or PDF format 
(see “Saving files in Photoshop EPS or DCS format 
(Photoshop)” on page 377; “Saving files in 
Photoshop PDF format (Photoshop)” on 
page 380). 

• To print the file using a non-PostScript printer, 
save in TIFF format and export to Adobe 
PageMaker 5.0 or higher.

Note: If you import an EPS or DCS file with a TIFF 
preview into applications such as Adobe Illustrator, 
the clipping path transparency will not display 
properly. This display affects the on-screen preview 
only; it does not affect the printing behavior of the 
clipping path on a PostScript printer.

Printing clipping paths

Sometimes an imagesetter has difficulty inter-
preting clipping paths, or a printer finds the 
clipping path too complex to print, resulting in a 
Limitcheck error or a general PostScript error. 
Sometimes you can print a complex path on a low-
resolution printer without difficulty but run into 
problems when printing the same path on a high-
resolution printer. This is because the lower-
resolution printer simplifies the path, using fewer 
line segments to describe curves than does the 
high-resolution printer. 

You can simplify a clipping path in the 
following ways:

• By manually reducing the number of anchor 
points on the path (see “Adding, deleting, and 
converting anchor points” on page 138). 
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• By increasing the tolerance setting used to create 
the path (see the following procedure).

To simplify a clipping path with the tolerance setting:

1 Select the path in the Paths palette, and click the 
Make Selection button at the bottom of the palette 
to convert the path to a selection.

2 Click the Trash button at the bottom of the 
palette to delete the original path.

3 Choose Make Work Path from the Paths palette 
menu, and increase the tolerance setting (4 to 6 
pixels is a good starting point).

4 Name and save the work path. Then choose 
Clipping Path from the Paths palette menu.

Exporting paths to Adobe Illustrator

The Paths to Illustrator command lets you export 
Photoshop paths as Adobe Illustrator files. This 
feature makes it easier to work with combined 
Photoshop and Illustrator artwork or to use 
Photoshop features on Illustrator artwork. For 
example, you may want to export a pen tool path 
and stroke it to use as a trap with a Photoshop 
clipping path you are printing in Illustrator. You 
can also use this feature to align Illustrator text or 
objects with Photoshop paths.

To use the Paths to Illustrator module:

1 In Adobe Photoshop, draw a path or convert an 
existing selection into a path; then save the path. 
(See “Drawing with the freeform pen tool” on 
page 130, “Drawing straight paths with the pen 
tool” on page 132, and “Converting between paths 
and selection borders” on page 140.)

2 Choose File > Export > Paths to Illustrator. 

3 Choose a location for the exported path. In 
Mac OS, for Write, choose the path you want to 
export. 

4 Click Save.

5 Open the path in Adobe Illustrator as a new file. 
You can now manipulate the path or use the path 
to align Adobe Illustrator objects. 

Note that the crop marks in Adobe Illustrator 
reflect the dimensions of the Adobe Photoshop 
image. The position of the path within the Adobe 
Photoshop image is maintained, provided you 
don’t change the crop marks or move the path.

Object linking and embedding (OLE) 
(Windows 95 and Windows NT 4.0 only)

<<Reviewers—Please provide updated compati-
bility information if applicable.>>

Photoshop is an OLE 2.0 server, which means it 
supports embedding or linking an image in an 
OLE container application (usually a word-
processor or page-layout program). For example, 
you can insert Adobe Photoshop files and selec-
tions into other OLE applications such as Adobe 
PageMaker 6.5 and Microsoft Word 7.0 using copy 
and paste or other methods.

• Linking lets you place a link in the OLE 
container file that refers to the Photoshop file on 
the hard drive.

• Embedding lets you insert the Photoshop file 
into the OLE container file.
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Once in the container application, an image can be 
double-clicked for editing in Photoshop. When 
closed in Photoshop, the image is updated in the 
container application.

To link or embed a selection or image in an OLE 
application:

Do one of the following:

• Copy a selection in Photoshop, and insert it in 
your OLE container application using the appli-
cation’s Paste Special command. Refer to your 
word-processing or page-layout application 
documentation for more instructions. Pasted 
selections can only be embedded, not linked.

• Use your OLE container application’s Insert 
Object command to insert a new Photoshop image 
or existing Photoshop file as an OLE-embedded or 
OLE-linked object. Refer to your word-processing 
or page-layout application documentation for 
instructions.

To insert an unlinked screen-resolution bitmap into 
an OLE application:

With the move tool ( ), use the left-mouse button 
to drag a selection to the OLE container appli-
cation. When you drop the object, it appears as a 
72-ppi bitmap, which cannot be automatically 
updated in Photoshop.

To modify and update a linked or embedded image in 
an OLE application:

1 Double-click the linked or embedded image in 
your word-processor or page-layout application to 
launch Adobe Photoshop (if it is not already 
running), and open the image for editing.

2 Modify the image as desired.

3 Do one of the following:

• For embedded images, close the file, or 
choose File > Update or File > Close & Return 
to <application name>.

• For linked images, save and close the file.

Note: You can also modify linked files without first 
opening the container document. The linked image 
will be updated the next time you open the document 
in its OLE container application.

Embedding Photoshop images in word-
processor applications (Mac OS only)

Adobe Photoshop supports the Edit Graphic 
Object (EGO) AppleEvent, which allows the 
embedding of Adobe Photoshop images in word-
processor files. EGO is a simple solution when a 
word-processor file has many small images that 
need updating. 

Word-processor applications that work with EGO 
include Full Write Professional™, Nisus, MacWrite 
Pro®, WordPerfect®, and Claris® Works™.

To use the Edit Graphic Object (EGO) AppleEvent to 
update images in word-processor files:

1 Paste the Photoshop image into your word-
processor file. 

2 Double-click the image in your word-processor 
application to launch Adobe Photoshop (if it is not 
already running), and open the image for editing. 

3 When you have finished making changes, close 
the Photoshop file to update the image in your 
word-processor application.



399

Chapter 17: Printing (Photoshop)

rinting is the process of sending your image 
to an output device. You can print on paper 
or film (positive or negative), to a printing 

plate, or directly to a digital printing press. 

Note: You cannot print images directly from 
ImageReady. If you have an image open in 
ImageReady and need to print it, use the Jump To 
command to open the image in Photoshop.

About printing
<<Online help only>>

Whether you are providing an image to an outside 
service bureau or just sending a quick proof to a 
desktop printer, knowing a few basics about 
printing will make the print job go more smoothly 
and help ensure that the finished image appears as 
intended.

Types of printing When you print a file, the Adobe 
Photoshop application sends your image to a 
printing device, either to be printed directly onto 
paper, to a digital printing press, or to be converted 
to a positive or negative image on film. In the latter 
case, the film can be used to create a master plate 
for printing by a mechanical press.

Types of images The simplest types of images, such 
as line art, use only one color in one level of gray. 
A more complex image is one whose color tones 
vary within the image. This type of image is 
known as a continuous-tone image.

Halftoning To create the illusion of continuous 
tone when printed, images are broken down into a 
series of dots. This process is called halftoning. 
Varying the sizes and densities of the dots in a 
halftone screen creates the optical illusion of varia-
tions of gray or continuous color in the image. In 
addition, you can use duotoning to increase the 
tonal range of grayscale images. 

Color separation Artwork that will be commer-
cially reproduced and that contains more than a 
single color must be printed on separate master 
plates, one for each color. This process is called 
color separation. In Photoshop, you can adjust how 
the various plates are generated and create traps. 

Quality of detail The detail in a printed image 
results from a combination of resolution and 
screen frequency. The higher an output device’s 
resolution, the finer (higher) a screen ruling you 
can use. 

A valuable resource for all aspects of print 
publishing, from early planning through prepress, 
is the Print Publishing Guide, an Adobe Press book. 
For information on purchasing Adobe Press 
books, visit the Adobe Web site at www.adobe.com 
or contact your local book distributor.

P
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Printing images
To print any type of image, you first select general 
printing options and then specify settings for a 
particular image type. You can preview how the 
image and selected options will appear on the 
printed page and adjust the position and scale of 
the image.

Photoshop provides three printing-related dialog 
boxes: Print Options, Page Setup, and Print. Some 
printing options may appear in multiple dialog 
boxes depending on your printer, print drivers, 
and operating system. For example, you may be 
able to access output options in both the Print 
Options and Page Setup dialog boxes. 

To print an image with its current print options:

Do one of the following:

• Choose File > Print, and click Print or OK.

• Hold down Alt (Windows) or Options (Mac OS) 
and choose File > Print One.

Note: By default, Adobe Photoshop prints a 
composite of all visible layers and channels. To print 
an individual layer or channel, make it the only 
visible layer or channel before choosing the Print 
command.

To select print options:

1 Choose File > Page Setup, and select an installed 
printer from the pop-up at the top of the dialog 
box. (You can also select a printer in the Print 
dialog box, or using the Chooser in Mac OS.)

2 Select a paper size and orientation in the Page 
Attributes section of the Page Setup dialog box. 
(You can also select a paper orientation in the 
Print Options dialog box.)

3 Choose File > Print Options to do the following:

• Adjust the position and scale of the image in 
relation to the selected paper size and orientation. 
(See “Positioning and scaling images” on 
page 401.)

• Set output options. (See “Setting output 
options” on page 401.)

• Select halftone screen attributes. (See “Selecting 
halftone screen attributes” on page 403.)

• Set other printing options. (See “Selecting other 
options” on page 7.) <<xref destination?>>

• Set color management options. (See “Using 
color management when printing” on page 406.)

4 Click OK to save the print options for the image, 
or click Print to print the image. Hold down Alt 
(Windows) or Options (Mac OS) and click Print 
to print the image without displaying the Print 
dialog box.

To preview the current image position and options:

Position the pointer over the file information box 
at the bottom of the document window and hold 
down the mouse button.
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Positioning and scaling images

You can adjust the position and scale of an image 
in the Print Options dialog box and preview how 
the image will be printed on the selected paper. 
The shaded border at the edge of the paper repre-
sents the margins of the selected paper; the 
printable area is white.

Scaling an image in the Print Options dialog box 
changes the size and resolution of the printed 
image, but not the size and resolution of the image 
file. For example, if you scale a 72 ppi image to 
50%, the image will print at 144 ppi. (See “About 
image size and resolution” on page 21.)

Note: Some printer drivers, such as AdobePS and 
LaserWriter, provide a Scale option in the Page Setup 
dialog box. The Print Options dialog box may not 
reflect accurate values for Scale, Height, and Width if 
you set a scaling percentage in the Page Setup dialog 
box. 

To reposition an image on the paper:

Do one of the following:

• Click Center Image to center the image in the 
printable area.

• Enter values for Top and Left to position the 
image numerically. 

• Drag the image in the preview area. 

To scale the print size of an image:

Do one of the following:

• Click Scale to Fit Media to fit the image within 
the printable area of the selected paper.

• Enter values for Height and Width to rescale the 
image numerically. 

• Select Show Bounding Box, and drag a bounding 
box handle in the preview area to achieve the 
desired scale.

Setting output options

You can select a variety of page marks and other 
output options in the Output section of the Print 
Options dialog box. Depending on your printer 
and print drivers, these options may also appear in 
the Page Setup dialog box. The advantage of using 
the Print Options dialog box is that you can 
preview the selected options prior to printing.

A. Black overprint color bar B. Label C. Registration marks
D. Progressive color bar E. Crop mark F. Gradient tint bar
G. Star target

C

M

Y

CM

MY

CY

CMY

K

Olé No Moire      177lpi   45o   1

cyan magenta yellow black

C DBA

GE F



CHAPTER 17402
Printing (Photoshop)

To view output options in the Print Options dialog 
box:

Select Show More Options, and choose Output 
from the pop-up menu.

Note: Options not supported by the designated 
printer are dimmed.

Photoshop provides the following output options:

Background Lets you select a background color to 
be printed on the page outside the image area. For 
example, a black or colored background may be 
desirable for slides printed to a film recorder. To 
use this option, click Background, and then select 
a color from the Color Picker dialog box. This is a 
printing option only; it does not affect the image 
itself.

Border Lets you print a black border around an 
image. Type in a number and a unit value to 
specify the width of the border.

Bleed Lets you print crop marks inside rather than 
outside the image. Use this option when you want 
to trim the image within the graphic.Type in a 
number and a unit value to specify the width of the 
border.

Screen Lets you set the screen frequency and dot 
shape for each screen used in the printing process. 
(See “Selecting halftone screen attributes” on 
page 403.)

Transfer Lets you adjust the transfer functions, 
traditionally used to compensate for dot gain or 
dot loss that may occur when an image is trans-
ferred to film. This option is recognized only when 
you print directly from Photoshop, or when you 
save the file as EPS and print to a PostScript 
printer. Generally, it’s best to adjust for dot gain 
using the settings in the CMYK Setup dialog box. 
Transfer functions are useful, however, for 
compensating for a poorly calibrated output 
device. (See “Compensating for dot gain in film 
using transfer functions” on page 100.) <<xref 
destination?>>

Interpolation Reduces the jagged appearance of a 
low-resolution image by automatically resampling 
up while printing. However, resampling may 
reduce the sharpness of the image quality. 
(See “About resampling” on page 28.) Some 
PostScript Level 2 (or higher) printers have inter-
polation capability. If your printer doesn’t, this 
option has no effect.

Calibration Bars Prints an 11-step grayscale, a 
transition in density from 0 to 100% in 10% incre-
ments. With a CMYK color separation, a gradient 
tint bar is printed to the left of each CMY plate, 
and a progressive color bar to the right.

Note: Calibration bars, registration marks, crop 
marks, and labels will print only if the paper size is 
larger than the printed image dimensions.

Registration Marks Prints registration marks on 
the image (including bull’s-eyes and star targets). 
These marks are used primarily for aligning color 
separations and duotones.
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Crop Marks Prints crop marks where the page is to 
be trimmed. You can print crop marks at the 
corners, at the center of each edge, or both.

Labels Prints the filename on the image.

Caption Lets you print any caption text entered in 
the File Info dialog box. (See “Adding file infor-
mation (Photoshop)” on page 389.) Caption text 
always prints as 9-point Helvetica plain type. 

Negative Prints an inverted version of the image. 
Unlike the Invert command in the Image menu, 
the Negative option converts the output, not the 
on-screen image, to a negative. If you print separa-
tions directly to film, you probably want a 
negative, although in many countries film 
positives are common. Check with your print shop 
to determine which is required. If printing to 
paper, print a positive. 

Emulsion Down Makes type readable when the 
emulsion is down—that is, when the photosen-
sitive layer on a piece of film or photographic 
paper is facing away from you. Normally, images 
printed on paper are printed with emulsion up, 
with type readable when the photosensitive 
layer faces you. Images printed on film are often 
printed down.

To determine the emulsion side, examine the film 
under a bright light after it has been developed. 
The dull side is the emulsion; the shiny side is the 
base. Check whether your print shop requires film 
with positive emulsion up, negative emulsion 
up, positive emulsion down, or negative 
emulsion down.

Selecting halftone screen attributes

Halftone screen attributes include the screen 
frequency and dot shape for each screen used in 
the printing process. For color separations, you 
must also specify an angle for each of the color 
screens. Setting the screens at different angles 
ensures that the dots placed by the four screens 
blend to look like continuous color and do not 
produce moiré patterns.

Halftone screens consist of dots that control how 
much ink is deposited at a specific location on-
press. Varying their size and density creates the 
illusion of variations of gray or continuous color. 
For a process color image, four halftone screens are 
used: cyan, magenta, yellow, and black—one for 
each ink used in the printing process.

Halftone screen with black ink

Halftone screens with process ink at different screen 
angles; correctly registered dots form rosettes
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In traditional print production, a halftone is 
produced by placing a halftone screen between a 
piece of film and the image and then exposing the 
film. In Photoshop, you specify the halftone screen 
attributes just before producing the film or paper 
output. For best results, your output device (a 
PostScript imagesetter, for example) should be set 
to the correct density limit, and your processor 
should be properly calibrated, otherwise results 
can be unpredictable. 

Before creating your halftone screens, check with 
your print shop for preferred frequency, angle, and 
dot settings. (Use the default angle settings unless 
your print shop specifies changes.) 

Note: Halftone screen attributes are recognized only 
when you print directly from Photoshop, or when 
you save the file as EPS and print to a PostScript 
printer.

<<Currently, you can only print halftone screens 
on Postscript 3 printers. This is documented in 
bug #91. Verify status of bug at final draft. Update 
information if not fixed.>>

To define the screen attributes: 

1 Choose File > Print Options.

2 Select Show More Options, choose Output from 
the pop-up menu, and click Screen. 

3 Choose whether to generate your own screen 
settings:

• Deselect Use Printer’s Default Screens to choose 
your own screen settings.

• Select Use Printer’s Default Screens to use the 
default halftone screen built into the printer. 
Photoshop then ignores the specifications in the 
Halftone Screens dialog box when it generates the 
halftone screens. 

4 For a grayscale halftone, enter a screen 
frequency from 1 to 999.999 for Frequency, and 
choose a unit of measurement. For Angle, enter a 
screen angle from –180 to +180 degrees.

5 For a color separation, choose from the 
following options:

• To manually enter the screen frequency and 
angle, choose a color of the screen for Ink, and 
enter the frequency and angle; repeat for each 
color separation. 

• To have Adobe Photoshop determine and enter 
the best frequencies and angles for each screen, 
click Auto. In the Auto Screens dialog box, enter 
the resolution of the output device and the screen 
frequency you intend to use; click OK. Photoshop 
enters the values in the Halftone Screens dialog 
box. Changing these values may result in moiré 
patterns.

• If you are using a PostScript Level 2 (or higher) 
printer or an imagesetter equipped with an 
Emerald controller, make sure that the Use 
Accurate Screens option is selected in the Auto 
Screens dialog box (or in the Halftone Screens 
dialog box if you’re entering the values manually). 
The Use Accurate Screen option lets the program 
access the correct angles and halftone screen 
frequencies for high-resolution output. If your 
output device is not a PostScript Level 2 (or 
higher) printer or is not equipped with an 
Emerald controller, this option has no effect.
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6 For Shape, choose the dot shape you want. If 
you want all four screens to have the same dot 
shape, select Use Same Shape For All Inks. 

Choosing Custom from the Shape menu displays 
the Custom Spot Function dialog box. You can 
define your own dot shapes by entering 
PostScript commands—useful for printing with 
nonstandard halftone algorithms. For information 
about using PostScript language commands, 
see the PostScript Language Reference published by 
Addison-Wesley, or consult the imagesetter’s 
manufacturer.

For optimal output on a PostScript printer, the 
image resolution should be 1.5 to 2 times the 
halftone screen frequency. If the resolution is more 
than 2.5 times the screen frequency, an alert 
message appears. (See “About image size and 
resolution” on page 21.) If you are printing line art 
or printing to a non-PostScript printer, see your 
printer documentation for the appropriate image 
resolutions to use.

7 To save your halftone screen settings for use 
with other Adobe Photoshop files, choose from the 
following options:

• To save the settings, click Save in the Halftone 
Screens dialog box. Name and save the settings.

• To save the new settings as the default, hold 
down Alt (Windows) or Option (Mac OS), and 
click the —> Default button. To return to the 
original default settings, hold down Alt 
(Windows) or Option (Mac OS), and click <—
Default. 

8 To load settings for use with another Photoshop 
file, click Load. Locate and select the settings.

Printing part of an image

You can use the Print Selected Area option to print 
a specific part of an image.

To print part of an image:

1 Use the rectangle marquee tool to select the part 
of an image you want to print. 

2 Choose File > Print Options, and select Print 
Selected Area. 

Choosing a print encoding method

By default, the printer driver transfers binary 
information to printers; however, you can choose 
to transfer image data using JPEG or ASCII 
encoding.

JPEG-encoded files are smaller than binary files, 
and therefore require less time to print. Only 
PostScript Level 2 (or higher) printers support 
JPEG encoding; sending a JPEG-encoded file to a 
PostScript Level 1 output device may result in 
PostScript language errors.

Some print spooler programs, computer 
networks, and third-party printer drivers don’t 
support files that are binary or JPEG-encoded, and 
some PostScript output devices accept binary and 
JPEG-encoded image data only through their 
AppleTalk and Ethernet ports, not their parallel or 
serial ports. In these situations, you can select the 
ASCII encoding method. However, ASCII files 
contain about twice as many characters and 
require about twice as much time to transfer as 
binary files.
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To change the encoding method:

Choose File > Print Options, and select an option 
from the Encoding pop-up menu.

Printing vector graphics 

If an image includes vector graphics, such as 
shapes and type, Photoshop can send the vector 
data to a Postscript printer. Because vector 
graphics are resolution-independent, you can 
print them at any resolution without losing detail 
or clarity. Keep in mind that including vector data 
can greatly increase the size of the printed file, 
especially if the vector objects overlap and use 
transparency.

To print vector data:

Choose File > Print Options, and select Include 
Vector Data.

Using color management when 
printing
Different devices operate within different color 
spaces—for example, your monitor operates in a 
different color space than your printer. To ensure 
that your color images on-screen match your 
printed color images, it’s important to make sure 
that your monitor is correctly calibrated. (See 
“Creating an ICC monitor profile” on page 81.) 
For more information about setting up a color-
managed workflow, see “Setting up color 
management” on page 65.

In a color-managed workflow, you can use soft-
proofing to preview of how colors will look 

when reproduced on a particular output device. (See 
“Soft-proofing colors” on page 76.)

The color management options in the Print 
Options dialog let you convert the color space of 
an image while printing. (Depending on the desig-
nated printer and print drivers on your computer, 
these options may also appear in the Print dialog 
box.) For example, suppose that your document 
currently uses a profile tailored for prepress 
output, but you want to proof the document 
colors on a desktop printer. You can convert the 
document’s colors to the color space of the desktop 
printer—the printer profile will be used instead of 
the current document profile when printing.
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When printing to a PostScript printer, you also 
have the option of using PostScript color 
management. In this workflow, Photoshop sends 
the document’s color data along with the 
document profile directly to the PostScript printer 
and lets the printer convert the document to the 
printer color space. The exact results of the color 
conversion can vary among printers. To use 
PostScript color management, you must have a 
PostScript Level 2 or higher printer; it is not 
necessary to install an ICC profile for the printer 
on your system.

To color-manage a document while printing:

1 Choose File > Print Options.

2 Select Show More Options and choose Color 
Management from the pop-up menu.

3 Select an option for Source Space:

• Select Document to use the profile currently 
assigned to the document.

• Select Proof to use the current proof profile. 
(See “Soft-proofing colors” on page 76.)

4 Choose an option for Profile:

• Choose Same As Source to print using the source 
space profile. No conversions will be performed on 
the colors of the document when it is printed.

• To print using a different destination profile, 
choose that profile from the list.

<<Reviewers—Does Photoshop provide Printer 
Color Management for non-postscript printers? 
Need to reconcile following two bullets.>>

• Choose PostScript Color Management to print 
to a PostScript printer and have colors managed at 
the level of the printer.

• Select Printer Color Management to instruct the 
printer to convert the file data to the printer’s color 
space; for PostScript printers, the option changes 
to PostScript Color Management. Select this 
option only if you are printing to an RGB-based 
printer or if you have not already converted the file 
to the printer’s color space.

Only PostScript 3 printers support PostScript 
Color Management for images using CMYK color 
space. To print a CMYK image using PostScript 
Color Management on a PostScript Level 2 printer, 
go back to step 2 and choose Lab Color. 

5 For Intent, select a rendering intent to use when 
converting colors to the destination profile space. 
(See “Specifying a rendering intent” on page 74.)
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Creating color traps
After you have converted an image to CMYK, you 
can adjust the color trap. Trap is the overlap 
needed to ensure that a slight misalignment or 
movement of the plates while printing does not 
affect the final appearance of the print job. If any 
distinctly different colors in your image touch, you 
may need to overprint them slightly to prevent 
tiny gaps from appearing when the image is 
printed. This technique is known as trapping. In 
most cases, your print shop will determine if 
trapping is needed and tell you what values to 
enter in the Trap dialog box.

Note: Trapping does not affect existing spot channels 
in the image.

Misregistration with no trap; misregistration with trap.

Keep in mind that trapping is intended to correct 
the misalignment of solid tints in CMYK images. 
In general, you should not create traps for 
continuous-tone images such as photographs. 
Excessive trapping may generate a keyline effect 
(or even cross-hair lines) in the C, M, and Y plates. 
These problems may not be visible in the 
composite channel and might show up only when 
you output to film. 

Trapping values determine how far overlapping 
colors are spread outward (not choked) to 
compensate for misregistration on the press. 
Adobe Photoshop uses standard rules for 
trapping: 

• All colors spread under black. 

• Lighter colors spread under darker colors.

• Yellow spreads under cyan, magenta, and black.

• Pure cyan and pure magenta spread under each 
other equally.

To create trap: 

1 Save a version of the file in RGB mode, in case 
you want to reconvert the image later. Then choose 
Image > Mode > CMYK Color to convert the 
image to CMYK mode. 

2 Choose Image > Trap.

3 For Width, enter the trapping value provided 
by your print shop. Then select a unit of 
measurement, and click OK. Consult your print 
shop to determine how much misregistration to 
expect.

A B
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Printing duotones
Photoshop lets you create monotones, duotones, 
tritones, and quadtones. Monotones are grayscale 
images printed with a single, nonblack ink. 
Duotones, tritones, and quadtones are grayscale 
images printed with two, three, and four inks. In 
these types of images, colored inks are used to 
reproduce tinted grays rather than different colors. 
This section uses the term duotone to refer to 
duotones, monotones, tritones, and quadtones.

About duotones

Duotones are used to increase the tonal range of a 
grayscale image. Although a grayscale repro-
duction can display up to 256 levels of gray, a 
printing press can reproduce only about 50 levels 
of gray per ink. This means that a grayscale image 
printed with only black ink can look significantly 
coarser than the same image printed with two, 
three, or four inks, each individual ink repro-
ducing up to 50 levels of gray. 

Sometimes duotones are printed using a black ink 
and a gray ink—the black for shadows and the gray 
for midtones and highlights. More frequently, 
duotones are printed using a colored ink for the 
highlight color. This technique produces an image 
with a slight tint to it and significantly increases 
the image’s dynamic range. Duotones are ideal for 
two-color print jobs with a spot color (such as a 
PANTONE ink) used for accent. 

Because duotones use different color inks to 
reproduce different gray levels, they are treated in 
Photoshop as single-channel, 8-bit, grayscale 
images. In Duotone mode, you do not have direct 
access to the individual image channels (as in RGB, 
CMYK, and Lab modes). Instead, you manipulate 
the channels through the curves in the Duotone 
Options dialog box.

To convert an image to duotone:

1 Convert the image to a grayscale image by 
choosing Image > Mode > Grayscale. Only 8-bit 
grayscale images can be converted to duotones. 

2 Choose Image > Mode > Duotone.

3 Select Preview to view the effects of the duotone 
settings on the image.

4 Specify the type of image, the ink colors, the 
duotone curves, and the overprint colors for the 
duotone image. 

5 Click OK.

To apply a duotone effect to only part of an 
image, convert the duotone image to Multi-

channel mode—this converts the duotone curves to 
spot channels. You can then erase part of the spot 
channel for areas that you want printed as standard 
grayscale. (See “Adding spot colors” on page 211.)

Specifying the duotone type and ink 
colors

The duotone type—monotone, duotone, tritone, 
or quadtone—determines how many ink controls 
are active. 
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To produce fully saturated colors, print darker inks 
before lighter inks. The order of inks in the 
duotone dialog boxes affects how Photoshop 
applies screens, so make sure that inks are specified 
in descending order—darkest at the top, lightest at 
the bottom. 

To specify the duotone type and its ink color:

1 In the Duotone Options dialog box, for Type 
specify monotone, duotone, tritone, or quadtone. 

2 Click the color box (the solid square) for an ink. 

3 Use the color picker or the Custom Colors 
dialog box to select the ink you want. When you 
close the dialog box, the ink color appears in the 
color box and the color name in the text box. 
(See “Using the Adobe Color Picker” on 
page 198.)

4 If the ink is to be separated on a process color 
plate, name it “cyan,” “magenta,” “yellow,” or 
“black.”

Modifying the duotone curve

A separate duotone curve specifies how each ink is 
distributed across the shadow and highlight areas 
of the image. This curve maps each grayscale value 
on the original image to the actual ink percentage 
that will be used when the image is printed. A 
diagonal curve indicates equal values and even 
distribution of ink. 

To modify the duotone curve for a given ink:

1 To preview any adjustments, select the Preview 
option.

2 Click the curve box next to the ink color box.

The default duotone curve, a straight diagonal line 
across the grid, indicates that you are mapping the 
current grayscale value of every pixel to the same 
percentage value of the printing ink. At this 
setting, a 50% midtone pixel prints with a 50% dot 
of the ink, a 100% shadow with a 100% dot of the 
ink, and so on.

3 Adjust the duotone curve for each ink by 
dragging a point on the graph or by entering 
values for the different ink percentages. 

The horizontal axis of the curve graph moves from 
highlights (at the left) to shadows (at the right). 
The density of the ink increases as you move up the 
vertical axis. You can specify up to 13 points on the 
curve. When you specify two values along the 
curve, Adobe Photoshop calculates intermediate 
values. As you adjust the curve, values are 
automatically entered in the percentage text boxes.

The value you type in a text box indicates the 
percentage of the ink color that will be used to 
print that percentage of the image. For example, if 
you enter 70 in the 100% text box, a 70% dot of 
that ink color will be used to print the 100% 
shadow areas of the image.

(See “Using the Curves command to adjust tonal 
range (Photoshop)” on page 95 <<xref desti-
nation?>> or “Using the Curves command to 
adjust color (Photoshop)” on page 105 <<xref 
destination?>> for more information on 
adjusting curves.)

4 Click Save in the Duotone Curve dialog box to 
save curves created with this dialog box. 
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5 Click Load to load these curves or curves 
created in the Curves dialog box, including curves 
created using the Arbitrary Map option. 
(See “Saving and loading duotone settings” on 
page 411.)

You can use the Info palette to display ink 
percentages when you’re working with duotone 
images. Set the readout mode to Actual Color to 
see the ink percentages that will be applied when 
the image is printed. These values reflect any 
changes you’ve entered in the Duotone Curve 
dialog box. 

Specifying overprint colors

Overprint colors are two unscreened inks printed 
on top of each other. For example, when a cyan ink 
prints over a yellow ink, the resulting overprint is 
a green color. The order in which inks are printed, 
as well as variations in the inks and paper, can 
significantly affect the final results. 

To help you predict how colors will look when 
printed, use a printed sample of the overprinted 
inks to adjust your screen display. Just remember 
that this adjustment affects only how the overprint 
colors appear on-screen, not when printed. Before 
adjusting these colors, make sure that you have 
calibrated your monitor following the instructions 
in “Creating an ICC monitor profile” on page 81.

To adjust the display of overprint colors:

1 Choose Image > Mode > Duotone.

2 Click Overprint Colors. The Overprint Colors 
dialog box displays the combinations that will 
result when the inks are printed.

3 Click the color swatch of the ink combination 
you want to adjust.

4 Select the color you want in the color picker, and 
click OK. 

5 Repeat steps 3 and 4 until the overprint inks 
appear as you want them. Then click OK. 

Saving and loading duotone settings

Use the Save and Load buttons in the Duotone 
Options dialog box to save a set of duotone curves, 
ink settings, and overprint colors. You can then 
apply these settings to other grayscale images.

In addition, the Adobe Photoshop program 
includes several sample sets of duotone, tritone, 
and quadtone curves. These sets include some of 
the more commonly used curves and colors and 
are useful as starting points for creating your own 
combinations. 

Viewing individual printing plates

Because duotones are single-channel images, your 
adjustments to individual printing inks are 
displayed as part of the final composite image. In 
some cases, you may want to view the individual 
“printing plates” to see how the individual colors 
will separate when printed (as you can with CMYK 
images). 

To view the individual colors of a duotone image:

1 After specifying your ink colors, choose Image > 
Mode > Multichannel.
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The image is converted to a multichannel image, 
with each channel represented as a spot-color 
channel that can be edited independently. The 
contents of each spot channel accurately reflect the 
duotone settings, but the on-screen composite 
preview may not be as accurate as the preview in 
Duotone mode.

Important: If you make any changes to the image in 
Multichannel mode, you will be unable to revert to 
the original duotone state. To adjust the distribution 
of ink and view its effect on the individual printing 
plates, make the adjustments in the Duotone Curves 
dialog box before converting to Multichannel mode. 

2 Select the channel you want to examine in the 
Channels palette. 

3 Choose Edit > Undo Multichannel to revert to 
Duotone mode.

Printing duotones

When creating duotones, keep in mind that both 
the order in which the inks are printed and the 
screen angles you use dramatically affect the final 
output. 

Click the Auto button in the Halftone Screens 
dialog box to set the optimal screen angles and 
frequencies. (See “Selecting halftone screen 
attributes” on page 403.) Make sure that you select 
Use Accurate Screens in the Auto Screens dialog 
box if you’re printing to a PostScript Level 2 (or 
higher) printer or an imagesetter equipped with 
an Emerald controller. 

Note: The recommended screen angles and 
frequencies for quadtones are based on the 
assumption that channel 1 is the darkest ink and 
channel 4 is the lightest ink. 

To print separations of a duotone image, choose 
File > Print. You do not have to convert duotone 
images to CMYK to create separations. Converting 
to CMYK mode converts any custom colors to 
their CMYK equivalents. 

Exporting duotone images to other 
applications

To prepare a duotone image for exporting to a 
page-layout application, save the image in EPS 
format. Keep in mind that it’s important to name 
custom colors so they’ll be recognized by the other 
application. Otherwise the image won’t print 
correctly—or might not print at all. 
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Printing color separations
Once you’ve applied spot colors to a duotone or 
CMYK image, you can print separations for color 
in the image. When you print an image containing 
spot channels on a composite printer, the spot 
channels are printed as separate pages. 
(See “Adding spot colors” on page 211 for more 
information.)

Note: If you are printing an image from another 
application and want to print spot channels to spot 
color plates, you must first save the file in DCS 2.0 
format. DCS 2.0 preserves spot channels and is 
supported by applications such as Adobe PageMaker 
and QuarkXPress. (See “Saving files in Photoshop 
EPS or DCS format (Photoshop)” on page 377.)

To print separations from Photoshop:

1 Choose File > Print Options.

2 Select Show More Options, and choose Color 
Management from the pop-up menu.

3 Select Separations from the Profile pop-up 
menu. 

Note: Depending on the designated printer and 
print drivers on your computer, these option may 
also appear in the Print dialog box.

4 Click Print. Separations are printed for each of 
the colors in the image. 

To prepare an image with spot channels for printing 
from another application:

1 In the General Preferences dialog box, select 
Short Pantone Names. (This step is not necessary 
if you are exporting to Adobe Illustrator 7.0 or 
Adobe PageMaker 6.5.)

2 If the image is a duotone, convert to Multi-
channel color mode.

3 Save the image in DCS 2.0 format. Be sure to 
deselect the Include Halftone Screen and the 
Include Transfer Function options. (See “Saving 
files in Photoshop EPS or DCS format 
(Photoshop)” on page 377.)

4 Open or import the image in the application 
you will be printing from, and set your screen 
angles. Make sure that you’ve communicated to 
the printer the spot color you want for each of 
the color plates.
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Chapter 18: Automating Tasks

utomating tasks can save you time and 
ensure consistent results for many types 
of operations. Adobe Photoshop and 

Adobe ImageReady provide a variety of ways to 
automate tasks—using actions, droplets, the Batch 
command, and task-specific Automate 
commands.

About actions
An action is a series of commands that you play 
back on a single file or a batch of files. For example, 
you can create an action that applies an Image Size 
command to change an image to a specific size in 
pixels, followed by an Unsharp Mask filter that 
resharpens the detail, and a Save command that 
saves the file in the desired format.

Most commands and tool operations are 
recordable in actions. Actions can include stops 
that let you perform tasks that cannot be recorded 
(for example, using a painting tool). Actions can 
also include modal controls that let you enter 
values in a dialog box while playing an action. 
Actions also form the basis for droplets, small 
applications that automatically process all files 
dragged onto their icon.

Action applied

A
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Both Photoshop and ImageReady ship with a 
number of predefined actions, although 
Photoshop has significantly more actions than 
ImageReady. You can use these actions as is, 
customize them to meet your needs, or create new 
actions.

Using the Actions palette
Before you apply an action, you must first create it. 
You use the Actions palette to record, play, edit, 
and delete individual actions. This palette also lets 
you save and load action files.

In Photoshop, actions are grouped into sets—you 
can create new sets to better organize your actions. 
(See “Organizing sets of actions (Photoshop)” on 
page 425.) In ImageReady, actions are at the same 
level in the Actions palette—you cannot group 
ImageReady actions into sets.

To display the Actions palette:

Choose Window > Show Actions, or click the 
Actions palette tab.

By default, the Actions palette displays actions in 
list mode—in Photoshop, you can expand and 
collapse sets, actions, and commands. In 
Photoshop, you can also choose to display actions 
in button mode (as buttons in the Actions palette). 
However, you cannot view individual commands 
or sets in button mode. 

To expand and collapse sets, actions, and commands:

Click the triangle (<<ICON>>) to the left of the 
set, action, or command in the Actions palette. 
Alt-click (Windows) or Option-click (Mac OS) to 
expand or collapse all actions in a set or all 
commands in an action.

To select actions:

Do one of the following:

• Click an action name to select a single action.

• Shift-click action names to select multiple, 
discontiguous actions.

• Ctrl-click (Windows) or Command-click (Mac 
OS) action names to select multiple, contiguous 
actions.

To display actions as buttons (Photoshop):

Choose Button Mode from the Actions palette 
menu. Choose Button Mode again to return to list 
mode.

Creating actions
You create an action to record the commands and 
tools you use, in the order you use them. Keep in 
mind the following guidelines when creating 
actions:

• You can record most—but not all—commands 
in an action. 
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• You can record operations that you perform 
with the marquee, move, polygon, lasso, magic 
wand, crop, slice, magic eraser, gradient, paint 
bucket, type, shape, line, notes, eyedropper, and 
color sampler tools—as well those that you 
perform in the Paths, Channels, Layers, and Styles 
palettes.

In ImageReady, you can drag a command from the 
History palette to the action in the Actions palette 
in which you want the command recorded. You 
cannot drag italicized commands from the History 
palette to the Actions palette. (Commands in 
italics are nonactionable.)

• Results depend on file and program setting 
variables, such as the active layer or the foreground 
color. For example, a 3-pixel Gaussian blur won’t 
create the same effect on a 72-ppi file as on a 144-
ppi file.  Nor will Color Balance work on a 
grayscale file.

• Modal operations and tools—as well as tools 
that record position—use the units currently 
specified for the ruler. A modal operation or tool is 
one that requires you to press Enter or Return to 
apply its effect, such as the transformation 
commands. Tools that record position include the 
marquee, slice, gradient, magic wand, lasso, path, 
and notes tools.

• You can record the Play command listed on the 
Actions palette menu to cause one action to play 
another. 

To create and record an action:

1 Open a file.

2 In the Actions palette, click the New Action 
button ( ), or choose New Action from the 
palette menu.

3 Enter a name for the action.

4 (Photoshop) Choose a set from the pop-up 
menu. 

5 If desired, set one or both of the following 
options:

• Assign a keyboard shortcut to the action. You 
can choose any combination of a Function key, the 
Ctrl key (Windows) or Command key (Mac OS), 
and the Shift key (for example, Ctrl+Shift+F3).

• (Photoshop) Assign a color for display in Button 
Mode.

6 Click Record. The Record button in the Actions 
palette turns red (<<ICON>>).

To guard against mistakes, record the Save As 
command at the beginning of the action. 

However, do not change the filename. If you enter a 
new filename, Photoshop records the filename and 
uses that filename each time you run the action. 
Before saving, if you navigate to a different folder, 
you can specify a different location without having to 
specify a filename.

7 Choose the commands, and perform the opera-
tions you want to record.

If a command you choose opens a dialog box, click 
OK to record the command; click Cancel to cancel 
recording.

When recording a command that includes 
setting options in the Save for Web dialog box, 

always click Close as part of the action. Otherwise, 
the action will save two copies of the file.
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8 To stop recording, click the Stop button, choose 
Stop Recording from the Actions palette menu, or 
press the Escape key. To resume recording in the 
same action, choose Start Recording from the 
Actions palette menu. 

9 To keep the action for use in future work 
sessions, save the action. (See “Managing actions 
in the Actions palette” on page 424.)

Recording paths (Photoshop)

The Insert Path command lets you include a path 
as part of an action. When the action is played 
back, the entire path is reproduced as part of the 
action. You can insert a path when recording an 
action or after it has been recorded

Note: Playing actions that insert complex paths may 
require significant amounts of memory. If you 
encounter problems, increase the amount of memory 
available to Photoshop.

To record a path:

1 Do one of the following:

• Start recording an action.

• Select an action’s name to record a path at the 
end of the action.

• Select a command to record a path after the 
command. 

2 Draw a path using any of the path tools, or select 
an existing path from the Paths palette.

3 Choose Insert Path from the Actions 
palette menu.

If you record multiple Insert Path commands in a 
single action, each path will replace the previous 
one in the target file. To add multiple paths, record 
a Save Path command using the Paths palette after 
recording each Insert Path command.

Inserting stops

You can include stops in your action that let you 
perform a task that cannot be recorded (for 
example, using a painting tool). Once you’ve 
completed the task, click the Play button in the 
Actions palette to complete the task. You can insert 
a stop when recording an action or after it has been 
recorded.

You can also display a short message when the 
action reaches the stop. For example, you can 
remind yourself what needs to be done before 
continuing with the action. A Continue button 
can be included in the message box. This lets you 
check for a certain condition in the file (for 
example, a selection) and continue if nothing 
needs to be done. 

To insert a stop:

1 Choose where to insert the stop:

• Select an action’s name to insert a stop at the end 
of the action.

• Select a command to insert a stop after the 
command. 

2 Choose Insert Stop from the Actions 
palette menu.

3 Type the message you want to appear. 

4 If you want the option to continue the action 
without stopping, select Allow Continue.
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5 Click OK. 

Setting modal controls

A modal control pauses an action so that you can 
specify values in a dialog box or use a modal tool. 
You can only set modal controls for actions that 
launch dialog boxes or activate modal tools. If you 
do not set a modal control, dialog boxes do not 
appear when you play the action, and you cannot 
change the recorded values.

A modal control is indicated by a dialog box icon 
(<<ICON>>) to the left of a command, action, or 
set in the Actions palette. Actions and sets in which 
some, but not all, available commands are modal 
display a red dialog box icon (<<ICON>>). In 
Photoshop, you must be in list mode—not button 
mode—to set a modal control.

To set a modal control:

Do one of the following:

• Click the box to the left of the command name to 
display the dialog box icon. Click again to remove 
the modal control.

• To turn on or disable modal controls for all 
commands in an action, click the box to the left of 
the action name.

• (Photoshop) To turn on or disable modal 
controls for all actions in a set, click the box to the 
left of the set name.

Excluding commands

You can exclude commands that you don’t want to 
be part of a recorded action or that you don’t want 
to play. In Photoshop, you must be in list mode—
not button mode—to exclude commands.

To exclude or include a command:

1 To expand the listing of commands in an action, 
click the triangle to the left of the action you want 
to work with.

2 Click the check mark to the left of the specific 
command you wish to exclude; click again to 
include the command.To exclude or include all 
commands in an action, click the check mark to 
the left of the action name. 

When you exclude a command, its check mark 
disappears. In addition, the check mark of the 
parent action turns red to indicate that some of the 
commands within the action are excluded.

Inserting nonrecordable commands 
(Photoshop)

The painting and toning tools, tool options, view 
commands, and window commands cannot be 
recorded. However, many commands that cannot 
be recorded can be inserted into an action using 
the Insert Menu Item command. 
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An inserted command is not executed until the 
action is played. No values for the command are 
recorded in the action, so the file remains 
unchanged when the command is inserted. If the 
command has a dialog box, the dialog box appears 
during playback, and the action pauses until you 
click OK or Cancel. You can insert a command 
when recording an action or after it has been 
recorded.

Note: When you use the Insert Menu Item command 
to insert a command that launches a dialog box, you 
cannot disable the modal control in the Actions 
palette.

To insert a menu item in an action:

1 Choose where to insert the menu item:

• Select an action’s name to insert the item at the 
end of the action.

• Select a command to insert the item at the end of 
the command. 

2 Choose Insert Menu Item from the Actions 
palette menu.

3 Choose a command from its menu.

4 Click OK.

Specifying an output folder (ImageReady)

You can specify the folder in which images are 
placed after actions are performed.

To specify an output folder:

1 Select the action for which you want to specify 
an output folder in the Actions palette.

2 Choose Insert Set Output Folder from the 
Actions palette menu.

3 Select a folder, and click OK.

Inserting optimization settings for 
selected slices (ImageReady)

When you record a Save Optimized action step, 
ImageReady includes optimization settings for the 
entire image. You can insert optimization settings 
for individual slices using the Insert Set Optimi-
zation Settings command.

To insert optimization settings in an action:

1 Select the slice or slices for which you want to 
record optimization settings. (See “Selecting 
slices” on page 304.)

2 Select the action in which you want to insert the 
optimization settings.

3 Do one of the following:

• Choose Insert Set Optimization Settings to 
current file format from the Actions palette menu. 
(The command indicates the optimization file 
format currently applied to the selected slice.)

• Drag the droplet icon ( ) from the Optimize 
palette onto the Actions palette.
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Playing actions
Playing an action executes the series of commands 
you recorded in the active document. You can 
exclude specific commands from an action or play 
a single command. If the action includes a modal 
control, you can specify values in a dialog box or 
reapply a modal tool when the action pauses. 

Note: In button mode, clicking a button executes the 
entire action—though commands previously 
excluded are not executed. 

To play an action or set on a file:

1 Open the file.

2 Do one of the following:

• To play an entire action, select the action name, 
and click the Play button (<<ICON>>) in the 
Actions palette, or choose Play from the palette 
menu. 

• If you assigned a key combination to the action, 
press that combination to play the action automat-
ically.

• To play part of an action, select the command 
from which you want to start playing, and click the 
Play button in the Actions palette, or choose Play 
from the palette menu.

To play a single command in an action:

1 Select the command you want to play.

2 Do one of the following:

• Ctrl-click (Windows) or Command-click (Mac 
OS) the Play button in the Actions palette.

• Hold down Ctrl or Command, and double-click 
the command.

• Choose Play from the Actions palette menu.

Note: Because an action is a series of commands, you 
can use the File > Undo command to can undo only 
the last command in an action. To undo an entire 
action, take a snapshot in the History palette before 
you play an action, and then select the snapshot to 
undo the action.

Slowing actions during playback 
(Photoshop)

Sometimes a long, complicated action does not 
play properly, but it is difficult to tell where the 
problem occurs. The Playback Options command 
gives you three speeds at which to play actions, 
so that you can watch each command as it is 
carried out.

To specify how fast actions should play:

1 Choose Playback Options from the pop-
up menu.

2 Specify a speed:

• Accelerated to play the action at normal speed 
(the default).

• Step by Step to complete each command and 
redraw the image before going on to the next 
command in the action.

• Pause and enter the amount of time Photoshop 
should pause between carrying out each 
command in the action.

3 Click OK.
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Editing actions
After you record an action, you can edit it in a 
variety of ways. You can rearrange actions and 
commands in the Actions palette; record 
additional commands in an action; rerecord, 
duplicate, and delete commands and actions; and 
change action options. 

Rearranging actions and commands

You can rearrange actions in the Actions palette 
and rearrange commands within an action to 
change their order of execution. 

To rearrange actions:

In the Actions palette, drag the action to its new 
location before or after another action. When the 
highlighted line appears in the desired position, 
release the mouse button.

To rearrange commands:

In the Actions palette, drag the command to its 
new location within the same or another action. 
When the highlighted line appears in the desired 
position, release the mouse button.

Recording additional commands

You can add additional commands to an action 
using the Record button or the Start Recording 
command in the Actions palette.

To record additional commands:

1 Do one of the following:

• Select the action name to insert a new command 
at the end of the action.

• Select a command in the action to insert a 
command after it.

2 Click the Record button, or choose Start 
Recording from the Actions palette menu.

3 Record the additional commands.

4 Click the Stop button to stop recording.

In ImageReady, you can drag a command from 
the History palette to the area in which you 

want the command recorded in the Actions palette; 
you do not use the Record button. 

Re-recording and duplicating actions and 
commands

Re-recording an action or command lets you set 
new values for it. Duplicating an action or 
command lets you make changes to it without 
losing the original version.

To record an action again:

1 Select an action, and choose Record Again from 
the Actions palette menu.

2 For a modal tool, do one of the following:

• Use the tool differently, and Press Enter 
(Windows) or Return (Mac OS) to change the 
tool’s effect.

• Press Cancel to retain the same settings.

3 For a dialog box, do one of the following:

• Change the values, and click OK to record them.

• Click Cancel to retain the same values. 
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To record a single command again:

1 In the Actions palette, double-click the 
command. 

2 Enter the new values, and click OK.

To duplicate an action or command:

Do one of the following:

• Alt-drag (Windows) or Option-drag (Mac OS) 
the action or command to a new location in the 
Actions palette. When the highlighted line appears 
in the desired location, release the mouse button.

• Select an action or command. Then choose 
Duplicate from the Actions palette menu. The 
copied action or command appears after the 
original.

• Drag an action or command to the New Action 
button at the bottom of the Actions palette. 
The copied action or command appears after 
the original.

In Photoshop, you can duplicate sets as well as 
actions and commands.

Deleting actions and commands

If you no longer need an action or command, you 
can delete it from the Actions palette.

To delete an action or command:

1 In the Actions palette, select the action or 
command you want to delete.

2 Delete the action or command:

• Click the trash button on the Actions palette. 
Click OK to delete the action or command. 

• Alt-click (Windows) or Option-click (Mac OS) 
the Trash button to delete the selected action or 
command without displaying a confirmation 
dialog box.

• Drag the action or command to the trash button 
on the Actions palette to delete the selected action 
or command without displaying a confirmation 
dialog box.

• Choose Delete from the Actions palette menu. 

• (Photoshop) Choose Clear All Actions from the 
Actions palette menu.

Changing action options

You can change the name, keyboard shortcut, and 
button color (Photoshop only) for an action in the 
Action Options dialog box.

To change action options:

1 Do one of the following:

• Double-click the action name.

• Select the action, and choose Action Options 
from the Actions palette menu.

2 Type a new name for the action, or change other 
options. For more information about action 
options, see “Creating actions” on page 416.

3 Click OK.



CHAPTER 18424
Automating Tasks

Managing actions in the Actions 
palette
By default, the Actions palette displays predefined 
actions (shipped with the application) and any 
actions you create. You can also load additional 
actions into the Actions palette.

Note: Photoshop actions are not compatible with 
ImageReady, and vice-versa. 

Saving and loading actions (Photoshop)

Actions are automatically saved to the following 
temporary file:

Mac OS Action Palette in the System Folder/
Preferences/Adobe Photoshop 6 Settings folder

Windows Actions Palette.psp in the Windows/
Application Data/Adobe/Photoshop/6.0/Adobe 
Photoshop 6 Settings folder

If this temporary file is lost or removed, the actions 
you created are lost. You can save your actions to a 
separate actions file so that you can recover them 
if necessary. You can also load a variety of action 
sets that are shipped with Photoshop. 

Note: In Photoshop, all actions must reside in a set. 
You can only save the entire contents of a set, not 
individual actions. (See “Organizing sets of actions 
(Photoshop)” on page 425.)

To save a set of actions:

1 Select a set.

2 Choose Save Actions from the Actions 
palette menu.

3 Type a name for the set, choose a location, and 
click Save. 

To load a set of actions:

1 Choose Load Actions from the Actions 
palette menu.

2 Locate and select the action set file. (In 
Windows, Photoshop action set files have the 
extension .atn.)

3 Click Open.

To load a preset action set:

Select an action set from the bottom section of the 
Actions palette menu. The name of the set 
indicates the type of actions it contains (for 
example, Buttons contains actions for creating 
buttons). 

For more information about the contents of preset 
action sets, see the PDF file in the following 
location:

Mac OS Adobe Photoshop 6.0/Presets/Photoshop 
Actions

Windows Program Files/Adobe/Photoshop 
6.0/Presets/Actions

To restore actions to the default set:

1 Choose Reset from the Actions palette menu.

2 Click Append to add the set of default actions to 
the current actions in the Actions palette, or click 
OK to replace the current actions in the Actions 
palette with the default set.
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Saving actions (ImageReady)

All actions you create are saved with the extension 
.isa in the following location:

Mac OS System Folder/Preferences/Adobe 
Photoshop 6 Settings/ImageReady Actions

Windows Windows/Application Data/Adobe/
Photoshop/6.0/Adobe Photoshop 6 Settings/
ImageReady Actions

ImageReady can only access actions that reside in 
the ImageReady Actions folder. You add actions to 
ImageReady by dragging actions into the 
ImageReady Actions folder on your computer. 
Because ImageReady does not include a Load 
Actions command, you must add files to the 
ImageReady Actions file manually. 

You can remove actions from ImageReady by 
dragging the actions out of the ImageReady 
Actions folder or by using the Delete Action 
command in the Actions palette menu. Actions 
you remove by dragging can be saved in another 
folder. Actions you remove by deleting are 
removed permanently.

If you add or remove files from the ImageReady 
Actions palette, you can direct ImageReady to scan 
the Actions folder for changes and update the 
Actions palette. (ImageReady scans the Actions 
folder and updates the Actions palette whenever 
you launch the application.)

To update the Actions folder:

1 Drag an action file into or out of the 
ImageReady Actions folder, located in the Settings 
folder inside the Adobe Photoshop folder on your 
hard drive.

2 Choose Rescan Actions Folder from the Actions 
palette menu.

Organizing sets of actions (Photoshop)

To help you organize your actions, you can create 
sets of actions and save the sets to disk. You can 
organize sets of actions for different types of 
work—such as print publishing and online 
publishing—and transfer sets to other computers. 

Although ImageReady doesn’t allow you to 
create sets, you can manually organize actions 

in the ImageReady Actions folder. For example, if the 
Actions palette contains too many actions, create a 
new folder inside the ImageReady Actions folder and 
move less used actions from the ImageReady Actions 
folder to this new folder. The relocated actions are 
removed from the palette until you return them to 
the ImageReady Actions folder.

To create a new set of actions:

1 In the Actions palette, click the New Set button 
(<<ICON>>), or choose New Set from the palette 
menu.

2 Enter the name of the set, and click OK.

To move an action to a different set:

In the Actions palette, drag the action to a different 
set. When the highlighted line appears in the 
desired position, release the mouse button.

To rename a set of actions:

1 In the Actions palette, choose Set Options from 
the pop-up menu.

2 Enter the name of the set, and click OK.
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Using the Batch command 
(Photoshop)
The Batch command lets you play an action on a 
folder of files and subfolders. If you have a digital 
camera or a scanner with a document feeder, you 
can also import and process multiple images with 
a single action. Your scanner or digital camera may 
need an acquire plug-in module that supports 
actions. (If the third-party plug-in wasn’t written 
to import multiple documents at a time, it may not 
work during batch-processing or if used as part of 
an action. Contact the plug-in’s manufacturer for 
further information.)

When batch-processing files, you can leave all the 
files open, close and save the changes to the 
original files, or save modified versions of the files 
to a new location (leaving the originals 
unchanged). If you are batch-processing a folder 
of files, copy all the desired files to the same level of 
a folder before starting the batch. If you are saving 
the processed files to a new location, you may want 
to create a new folder for the processed files before 
starting the batch.

For better batch performance, reduce the 
number of saved history states and deselect the 

Automatically Create First Snapshot option in the 
History palette.

To batch-process files using the Batch command:

1 Choose File > Automate > Batch.

2 Select the desired set and action from the Set 
and Action pop-up menus.

3 Select a source from the Source pop-up menu:

• Folder to play the action on files already stored 
on your computer. Click Choose to locate and 
select the folder. Select Override Action “Open” 
Commands to ensure that the files are opened 
from the specified folder and to ignore any Open 
commands that were recorded as part of the 
original action. Select Include All Subfolders to 
process files in subfolders. Select Suppress Color 
Profile Warnings to turn off display of color policy 
messages. 

• Import to import and play the action on images 
from a digital camera or scanner

• Opened Files to play the action on all open files.

4 Select a destination for the processed files from 
the Destination pop-up menu:

• None to leave the files open without saving 
changes (unless the action included a Save 
command).

• Save and Close to save the files in their current 
location. 

• Folder to save the processed files to another 
location. Click Choose to specify the destination 
folder. Select Override Action “Save In” 
Commands to ensure that the processed files are 
saved to the specified destination folder and not to 
a location recorded with the Save As or Save a 
Copy commands.

5 If you chose Folder as the destination, specify a 
file naming convention and select file compati-
bility options for the processed files:
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• For File Naming, select elements from the pop-
up menus or enter text into the fields to be 
combined into the default names for all files. 
Elements include document name, serial number 
or letter, file creation date, and file extension. 

The fields let you change the order and formatting 
of the filename parts.

• For File Name Compatibility, choose Windows 
to make filenames compatible with Windows 
operating systems, Mac OS to make filenames 
compatible with Macintosh operating systems, 
and UNIX to make filenames compatible with 
UNIX operating systems.

Saving files using the Batch command options 
always saves the files in the same format as the 

original files. To create a batch-process that saves files 
in a new format, record the Save As or Save a Copy 
command followed by the Close command as part of 
your original action. Then choose None for the 
Destination when setting up the batch process.

6 Select an option for error processing from the 
Errors pop-up menu:

• Stop for Errors to suspend the batch process 
until you confirm the error message.

• Log Errors to File to record each error in the file 
without stopping the batch process. If errors are 
logged to this file, a message appears after 
processing the files alerting you to review the error 
file. If you select this option, click Save As and 
name the error file. 

To batch-process using multiple actions, create 
a new action and record the Batch command 

for each action you want to use. This technique also 
lets you process multiple folders in a single batch. To 
batch-process multiple folders, create aliases within 
a folder to the other folders you want to process.

Using droplets
A droplet is a small application that applies an 
action to an image or batch of images that you 
drag onto the droplet icon. You can save a droplet 
on the desktop or to a location on disk. 

Creating a droplet from an action

Actions are the basis for creating droplets—you 
must create the desired action in the Actions 
palette prior to creating a droplet. (See “Creating 
actions” on page 416.)

In ImageReady, you can also create droplets with 
the Optimize palette, so that you can apply 
Optimize palette settings to single images or 
batches of images.

To create a droplet from an action (Photoshop):

1 Choose File > Automate > Create Droplet.
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2 Click Choose in the Save Droplet In section of 
the dialog box, and select a location to save the 
droplet.

3 Select the desired set and action from the Set 
and Action pop-up menus.

4 Set Play options for the droplet:

• Select Override Action “Open” Commands to 
ensure that the files are opened from the specified 
folder and to ignore any Open commands that 
were recorded as part of the original action. 

• Select Include All Subdirectories to process files 
in subdirectories.

• Select Suppress Color Profile Warnings to turn 
off display of color policy messages.

5 Select a destination for the processed files from 
the Destination pop-up menu:

• None to leave the files open without saving 
changes (unless the action included a Save 
command).

• Save and Close to save the files in their current 
location. 

• Folder to save the processed files to another 
location. Click Choose to specify the destination 
folder. Select Override Action “Save In” 
Commands to ensure that the processed files are 
saved to the specified destination folder and not to 
a location recorded with the Save As or Save a 
Copy commands.

6 If you chose Folder as the destination, specify a 
file naming convention and select file compati-
bility options for the processed files:

• For File Naming, select elements from the pop-
up menus or enter text into the fields to be 
combined into the default names for all files. 
Elements include document name, serial number 
or letter, file creation date, and file extension. 

• For File Name Compatibility, choose Windows 
to make filenames compatible with Windows 
operating systems, Mac OS to make filenames 
compatible with Macintosh operating systems, 
and UNIX to make filenames compatible with 
UNIX operating systems.

7 Select an option for error processing from the 
Errors pop-up menu:

• Stop for Errors to suspend the batch process 
until you confirm the error message.

• Log Errors to File to record each error in the file 
without stopping the batch process. If errors are 
logged to this file, a message appears after 
processing the files alerting you to review the error 
file. If you select this option, click Save As and 
name the error file. 

To create a droplet from an action (ImageReady):

1 For best results, make sure that the action 
contains at least one Set Optimization command. 
To add a Set Optimization command, adjust the 
settings in the Optimize palette, and then drag the 
droplet icon ( ) from the Optimize palette onto 
the part of the Actions palette where you want to 
add that command.

If you do not add a Set Optimization command to 
the droplet, ImageReady will batch-process files 
using the optimization settings in place at the time 
the droplet was created.
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2 Create the droplet:

• Drag the name of the action from the Actions 
palette onto the desktop. The droplet has the same 
name as the action it was created from. You can 
rename the droplet as you do other desktop icons.

• Select an Action, and choose Create Droplet 
from the Actions palette menu. Name the droplet, 
choose a location where the droplet will be saved, 
and click Save.

Using droplets to process files

To use a droplet, simply drag a file or folder onto 
the droplet icon (<<ICON>>).

<<Reviewers—Will Photoshop icon be the same 
as ImageReady?>>

If the application you used to create the droplet is 
not currently running, the droplet launches it. 

In ImageReady, you can control droplet 
processing in the following ways:

• To temporarily pause processing, click Pause. 
Click Resume to continue the processing.

• To cancel processing, click Stop.

Editing droplets (ImageReady)

In ImageReady, you can edit the commands in a 
droplet in the same ways you edit the commands 
in an action. You can also set batch options for a 
droplet before or after you create it. For example, 
you can set the droplet to operate in the 
background during execution, so that you can 
work in other applications while ImageReady 
processes images.

To edit a droplet:

1 Double-click the droplet to open the droplet 
window in ImageReady. The droplet window 
looks like a simplified version of the Actions 
palette.

2 Edit the droplet in the same way as you would 
edit an action:

• Change the order of commands by dragging 
them in the droplet list.

• Delete commands by dragging them to the Trash 
button ( ).

• Add a command by dragging a state from the 
History palette to the area in which you want the 
command recorded in the Actions palette.

To adjust droplet batch options:

1 Do one of the following:

• Before you create the droplet, select an action 
and choose Batch Options from the Actions 
palette menu.

• After you create the droplet, double-click the 
droplet to open the droplet window, and double-
click Batch Options at the top of the droplet list.

2 Select Original (same name and folder) to save 
the original file with the same name and in the 
same folder.

3 Select Optimized to save an optimized version 
of the file. Then do any of the following:

• For In, choose the location in which you want to 
save the optimized file.

• For If Duplicate File Name, choose how and 
whether to append numbers or letters to indicate 
the optimized file in cases of duplicate filenames.
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• For Modify File Name For, choose whether 
ImageReady appends or rewrites the filename 
using Windows, Mac OS, or UNIX file naming 
conventions.

4 Select playback options:

• Run In Background to hide ImageReady during 
droplet execution, so that you can work in other 
applications while processing takes place. When 
you select Run In Background, other playback 
options requiring user input during processing are 
turned off.

Note: ImageReady is not available for creating and 
modifying current images while background 
processing is taking place. 

• Display Image to show the images as they are 
being processed.

• Pause Before Save to stop the processing of each 
image before saving it.

5 Choose Error options from the Errors menu:

• Stop to suspend the process until you confirm 
the error message.

• Skip Step to not process steps in which errors are 
encountered.

• Skip File to not process files in which errors are 
encountered.

Note: You can also adjust batch options before 
creating the droplet by choosing Batch Options from 
the Actions palette menu.

Using droplets to automate optimization 
settings (ImageReady)

You can save Optimize palette settings for use on 
individual images or batches of images by creating 
a droplet for the settings. The droplet lets you 
apply the compression settings to an image or 
batch of images that you drag onto the droplet 
icon.

To create a droplet for automating Optimize palette 
settings:

1 With an image displayed in the image window, 
choose a compression format and desired 
compression options in the Optimize palette as 
described in “Optimizing images” on page 342

2 Create a droplet:

• Drag the droplet icon ( ) from the Optimize 
palette onto the desktop. 

The droplet is named with a brief description of 
the compression settings, including file format 
and color palette or quality setting information. 
You can rename the droplet as you do other 
desktop icons.

• Click the droplet icon ( ) on the Optimize 
palette. Name the droplet, choose a location where 
the droplet will be saved, and click Save.

• Choose Create Droplet from the Optimize 
palette menu. Name the droplet, choose a location 
where the droplet will be saved, and click Save.

You can add a droplet to an action by dragging 
the droplet icon in the Optimize palette to the 

Actions palette; this includes the optimization 
settings as part of the action. 
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Using the Automate commands 
(Photoshop)
The Automate commands simplify complex tasks 
by combining them into one or more dialog boxes. 
Photoshop includes the following commands 
(third-party companies may provide additional 
commands):

• Conditional Mode Change changes the color 
mode of a document to the mode you specify, 
based on the original mode of the document.

<<Documentation—Is this doced with color 
modes? Verify and add XREF.>>

By recording this command in an action, you 
can ensure that any actions that require an 

image to be in a specific color mode do not generate 
unwanted error messages.

• Contact Sheet produces a series of thumbnail 
previews on a single sheet from the files in the 
selected folder. (See “Creating contact sheets” on 
page 394.)

• Fit Image fits the current image to the width 
and height you specify, without changing its 
aspect ratio. (See <<XREF>>.)

Note: This will resample the image, changing the 
amount of data in the image.

• Multi-Page PDF to PSD converts each page of a 
PDF document you select to a separate Photoshop 
file. (See “Opening PDF files” on page 36.)

• Picture Package places multiple copies of a 
source image on a single page, similar to the photo 
packages traditionally sold by portrait studios. 
(See “Creating picture packages” on page 395.)

• Web Photo Gallery generates a Web site from a 
set of images —complete with a thumbnails index 
page, individual JPEG image pages, and navigable 
links. (See “Creating Web galleries (Photoshop)” 
on page 322.)

To use an automated command:

Choose File > Automate, and then choose any of 
the commands listed under it.

External automation
Photoshop supports some external automation 
using OLE Automation (Windows) or 
AppleScript (Mac OS). Using either of these 
methods lets you start Adobe Photoshop 
and execute actions externally.

Using external automation lets you perform such 
tasks as:

• Having another scriptable application generate a 
series of files, and having Photoshop batch-process 
them.

• Having Photoshop batch-process files and save 
them to your Web site.

• Writing a script that runs an action and then 
shuts down your computer late at night after 
you’ve gone home.

<<Documentation—Verify that the following 
source of information is still correct.>>

If you have further questions about OLE, contact 
Microsoft Corporation. For questions about 
AppleScript, see your Macintosh documentation 
or contact Apple Computer.
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