
14 Optimizing Images for 
the Web

Adobe Photoshop and Adobe ImageReady 

let you optimize the display and file size 

of your images for effective Web publish-

ing results. In general, the file size of an 

image should be small enough to allow 

reasonable download times from a Web 

server but large enough to represent 

desired colors and details in the image. 

ImageReady also lets you turn an image 

into an image map, creating Web-ready 

navigation elements from your art.
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In this lesson, you’ll learn how to do the following: 

• Optimize JPEG and GIF files, and adjust the optimization settings to achieve the 

desired balance between file size and image quality.

• Adjust the amount of dithering applied to an image.

• Define a transparent background for an image.

• Create a hypertext image map.

• Batch-process files to automate the optimization process.

This lesson will take about 45 minutes to complete. The lesson is designed to be done in 

Adobe Photoshop and Adobe ImageReady.

If needed, remove the previous lesson folder from your hard drive, and copy the Lesson14 

folder onto it. As you work on this lesson, you’ll overwrite the start files. If you need to 

restore the start files, copy them from the Adobe Photoshop Classroom in a Book CD.

Note: Windows users need to unlock the lesson files before using them. For information, 

see “Copying the Classroom in a Book files” on page 3.

Optimizing images using Photoshop or ImageReady
Adobe Photoshop and Adobe ImageReady give you an effective range of controls for 

compressing the file size of an image while optimizing its on-screen display quality. 

Compression options vary according to the file format used to save the image.

• The JPEG format is designed to preserve the broad color range and subtle brightness 

variations of continuous-tone images (photographs, images with gradients). This format 

can represent images using millions of colors.

• The GIF format is effective at compressing solid-color images and images with areas of 

repetitive color (line art, logos, illustrations with type). This format uses a palette of 

256 colors to represent the image, and supports background transparency.

• The PNG format is effective at compressing solid-color images and preserving sharp 

detail. The PNG-8 format uses a 256-color palette to represent an image; the PNG-24 

format supports 24-bit color (millions of colors). However, many older browser applica-

tions do not support PNG files.
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In this lesson, you’ll learn how to use Photoshop and ImageReady to optimize and save 

images in JPEG and GIF format for distribution on the World Wide Web. You’ll work with 

a set of images designed to be used on a fictitious Web site for a virtual zoo.

It is important to note that Photoshop and ImageReady share many of the same capabil-

ities when it comes to image optimization. Both Photoshop (through its Save For Web 

dialog box) and ImageReady let you view and compare different optimized versions of a 

file, select from a wide array of file formats and settings, and work with color palettes and 

individual colors to preserve color integrity as much as possible while creating small, 

efficient files.

For the Web: Compressing images

Because file size is important in electronic publishing, file compression is an absolute must. Two graphics 

formats in HTML—GIF and JPEG—include automatic compression. The Adobe Acrobat® family of PDF 

creation products also automatically apply compression. Uncompressed files have redundant information. 

For example, with 35 white pixels in a row, an uncompressed file repeats the “white pixel” command 

35 times. Each pixel contains one instruction.

The two basic types of compression are lossy and nonlossy (or lossless). Lossy compression loses data to make 

the file smaller. For example, if there are 30 white pixels followed by one gray pixel, and four more white 

pixels, a lossy compression converts the gray pixel to white and writes a code saying “35 white pixels here.” 

Nonlossy compression never eliminates detail but instead looks for more efficient ways to define the image 

(for example, “32 white pixels here, one gray pixel next, four white pixels after that”).

Common compression types are LZW, ZIP, CCITT, and JPEG. Your electronic publishing software will use 

whatever type is best for the image at hand. Only JPEG supports lossy compression, and lets you choose the 

level of compression so you can regulate fidelity versus image size. Low JPEG compression results in files that 

are almost identical to the original. Medium JPEG compression eliminates detail that may or may not be 

evident on-screen. High JPEG compression tends to blur images and degrade some of the detail, but on many 

images the result is still perfectly acceptable and worth the small file size you get in return.

Compression does not decrease resolution; it simply makes the file smaller. Compression lets you have 

high-resolution images that can be printed at decent quality without becoming too large. But compression is 

never a substitute for keeping resolution to the maximum needed. For online-only publications, keep the 

resolution of your images to 72 ppi. For dual-use publications, consider whether a higher image resolution of 

150–200 ppi is necessary if you want the images to look good in print too.

–From the Official Adobe Electronic Publishing Guide, Chapter 3, “Preparing Text and Graphics.”
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Getting started
Before beginning this lesson, restore the default application settings for Adobe Photoshop 

and Adobe ImageReady. See “Restoring default preferences” on page 4. 

Optimizing a JPEG image
In this lesson, you will optimize files in both JPEG and GIF format. You will use 

Photoshop to perform the JPEG compression and ImageReady for the GIF compression, 

although either application works equally well for either type of compression.

Optimizing and saving a file in Photoshop

With the Save For Web dialog box, Photoshop has all of the optimization capabilities of 

ImageReady built right in. You can compare two or more versions of a file as you work, 

allowing you to adjust optimization settings until you have the optimal combination of 

file size and image quality.

Now you’ll open the start file and begin the lesson by optimizing an image containing 

photographs in JPEG format and compare the results of different palette and dither 

settings.

1 Start Adobe Photoshop.

If a notice appears asking whether you want to customize your color settings, click No.

2 Choose File > Open, and open the file 14Start1.psd from the Lessons/Lesson14 folder. 

This file is a modified version of the zoo map you will be using later in this lesson. It has 

been enhanced with scanned photographs of animals, which have been further manipu-

lated in Photoshop. Currently, the file size is far too large for use on a Web site. You’ll 

compare different file compression formats to see which one gives you the most 

compression without sacrificing too much image quality.

3 Choose File > Save for Web.
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4 In the Save For Web dialog box, click the 4-Up tab to view four versions of the image.

By looking at four different file settings, you can get a good idea of which settings will best 

suit your purpose. Using either the 4-Up or 2-Up view, you can adjust optimization 

settings for each version of the image to select the best combination of settings.

5 In the lower-left corner of the Save For Web dialog box, choose 200% or greater from 

the Zoom Level menu so that you can see the details of the image.

6 Move the pointer over the version of the image in the upper-right corner of the dialog 

box. (This is the active version, as indicated by a dark border.) 

The pointer becomes a hand, indicating that you can drag to move the image. 

7 Drag to reposition the image so that the Tropical Rainforest text (in the center of the 

image, over the green parrot) is visible.
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8 Choose GIF 128 Dithered from the Settings menu.

Notice the dark group of pixels around the text and on the parrot’s beak. (You may need 

to scroll to the left to see the beak.) 

You’ll use the two bottom versions of the image to see how it would look as either a JPEG 

or a PNG file.

9 Click the lower-left version of the image to select it.

10 Choose JPEG Low from the Settings menu.

The image looks pretty choppy and the quality is unacceptably poor around the text. 

Now you will attempt to increase the image quality without an unacceptable increase 

in file size.

11 Choose JPEG High from the Settings menu.

JPEG Low JPEG High

This improves image quality but also results in a significant increase in the size of the file.
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12 Choose JPEG Medium from the Settings menu.

The image quality is now acceptable, while the file size is still significantly smaller than 

either the JPEG High version or the GIF version. 

13 If you want, experiment with different values in the Quality text box (click the triangle 

to display the Quality slider) and compare image quality to file size. (We used a value of 45 

for the Quality.)

14 Select the lower-right version of the image.

15 Choose PNG-8 128 Dithered from the Settings menu.

Although this results in a smaller file size than the original image, the image quality is not 

as good as the JPEG Medium version, which also has a smaller file size. Furthermore, 

many older browsers cannot read the PNG format. To make this image compatible with 

older browsers, you will use the JPEG Medium version.

16 Select the JPEG version in the lower-left corner of the dialog box.

17 Select the Progressive option, and click OK.

The Progressive option causes the image to download in several passes, each of which 

increases the image quality.

The Progressive JPEG download

18 In the Save Optimized As dialog box, use the default name 14Start1.jpg, and 

save the file in the same folder as the original Photoshop file.

19 Close the original Photoshop file 14Start1.psd without saving changes.
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Optimizing a GIF image
Now you’ll optimize a flat-color image in GIF format in ImageReady and compare the 

results of different palette and dither settings. 

Choosing optimization settings in ImageReady

The Optimize palette lets you specify the file format and compression settings for the 

optimized image. The optimized image is updated as you edit, letting you interactively 

preview the effects of different settings.

Using channels to modify JPEG quality

When you use an alpha channel to optimize the range of quality in a JPEG image, white areas of the mask 

yield the highest quality and black areas of the mask yield the lowest quality. You can adjust the maximum 

and minimum level of quality in the Modify Quality Setting dialog box.

To use a channel to modify JPEG quality:

1. In the Optimize panel/palette, choose a JPEG setting from the Settings menu, or choose JPEG from the file 

format menu.

2. Click the channel button to the right of the Quality text box. 

3. In the Modify Quality Setting dialog box, choose the desired channel from the Channel menu. In 

ImageReady, you can choose Save Selection to create a new alpha channel based on the current selection.

4. To preview the results of the weighted optimization, select the Preview option.

5. Define the quality range:

• To set the highest level of quality, drag the right (white) tab on the slider, enter a value in the Maximum 

text box, or use the arrows to change the current value. 

• To set the lowest level of quality, drag the left (black) tab on the slider, enter a value in the Minimum text 

box, or use the arrows to change the current value. 

6. Click OK.

–From Adobe Photoshop 6.0 online Help
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1 In Photoshop, click the Jump To ImageReady button ( ) at the bottom of the 

toolbox to switch from Photoshop to ImageReady.

Note: If you do not have enough memory to run both applications simultaneously, quit 

Photoshop and then start ImageReady.

2 In ImageReady, choose File > Open, and open the file 14Start2.psd from the 

Lessons/Lesson14 folder.

This image was created in Adobe Illustrator, and then rasterized into Photoshop format. 

The image contains many areas of solid color.

3 Click the 2-Up tab in the document window.

The optimized version of the image is selected on the right side of the window.
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4 In the Optimize palette, choose GIF 128 No Dither from the Settings menu. 

(If the Optimize palette is not visible, choose Window > Show Optimize to display it.)

5 Choose Perceptual from the Color Reduction Algorithm menu.

• Perceptual gives priority to colors that appear most commonly in the image and are 

more sensitive to the human eye. This palette usually produces images with the greatest 

color integrity.

• Selective creates a color table similar to the Perceptual color table, but favors broad areas 

of color and the preservation of Web colors.

• Adaptive samples colors from the portion of the RGB spectrum that appears most 

commonly in the image. For example, an image containing predominantly blue hues 

produces a palette consisting mostly of shades of blue.

• Web consists of the 216 colors that are shared in common by the Windows and Mac OS 

system palettes. When displaying images, a browser application will use a 16-bit or 24-bit 

color table (thousands or millions of colors) if the system display is set to one of these 

modes; otherwise, the browser will use the default 8-bit system palette. Although few Web 

designers use 8-bit color systems, many Web users do.

• Custom preserves the current perceptual, selective, or adaptive color table as a fixed 

palette that does not update with changes to the image.

• Mac OS or Windows uses the computer system’s default 8-bit (256-color) palette, 

which is based on a uniform sampling of RGB colors.
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The status bar at the bottom of the image window displays the view magnification and 

other useful information about the original and optimized versions of the image. You can 

display two sets of file values simultaneously. 

 

A.

 

 File size and download time of optimized image 

 

B.

 

 File sizes of original and optimized images

 

6

 

In the status bar, choose Image Dimensions from the second pop-up menu.

This option displays the size of the image in pixels, which is important when planning 

how to fit an image into a predesigned Web-page template.

 

7

 

If the Color Table palette is not displaying, choose Window > Show Color Table to 

display it. 

 

White diamonds indicate 
Web-safe colors.

A B
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This palette shows the colors that make up the Perceptual palette for the zoo map image. 

The white diamonds on certain colors indicate that those colors are Web-safe. The total 

number of colors appears at the bottom of the palette. You can resize the palette or use 

the scroll bar to view all the colors. You can also change how the colors are arranged in 

the palette.

8 Choose Sort By Hue from the Color Table palette menu.

Now you’ll observe how a different palette option affects the image. 

9 In the Optimize palette, choose Web from the Color Reduction Algorithm menu.

Notice that the color changes in the image and in the Color Table palette, which updates 

to reflect the Web palette.

10 Experiment with different optimize options and notice the effects on the image and 

on the Color Table palette.
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Reducing the color palette

To compress the file size further, you can decrease the total number of colors included in 

the Color Table palette. A reduced range of colors will often preserve good image quality 

while dramatically reducing the file space required to store extra colors.

1 In the Optimize palette, choose the Perceptual option.

2 In the document window, change the magnification to 200% or more so that you can 

see details in the image.

3 Select the optimized version of the image, hold down the spacebar, and drag the image 

to place the Tropical Rainforest text at the bottom center of the display.

4 Note the current file size of the optimized image. Then, in the Optimize palette, enter 

32 in the Colors text box. 

For the Web: Viewing hexadecimal values for colors in the Info palette

In Photoshop, hexadecimal values for colors are displayed in the Info palette when you select Web Color mode 

for one or both color readouts. In ImageReady, hexadecimal values for colors are displayed automatically in 

the right side of the Info palette, next to RGB color values. The Photoshop and ImageReady Info palettes also 

display other information, depending on the tool being used. 

To view hexadecimal color values in the Photoshop Info palette:

1. Choose Window > Show Info or click the Info palette tab to view the palette.

2. Choose Palette Options from the Palette menu.

3. Under First Color Readout, Second Color Readout, or both, choose Web Color from the Mode menu.

4. Click OK.

The Info palette displays the hexadecimal equivalents for the RGB values of the color beneath the pointer in 

the image.

–From Adobe Photoshop 6.0 online Help
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Notice that the new value represents a significant reduction in file size, but the quality of 

the image is lower. Specifically, the animal silhouettes have changed colors. For the 

African Savannah silhouettes, they have changed to a green-brown, and for the Northern 

Wilderness, the animal silhouettes have changed to the background color, making them 

invisible. 

5 Hold down the spacebar and drag within the active panel to move the image so that 

you can see the Northern Wilderness area, or simply change the magnification back 

to 100%. 

6 Change the number of colors back to 128.

This time, before reducing the color palette, you’ll lock several colors to ensure that these 

colors do not drop from the reduced palette.

7 Select the eyedropper tool ( ), and click in the camel silhouette in the African 

Savannah area to sample its color.

The dark brown color is selected in the Color Table palette.

8 Click the Lock button ( ) at the bottom of the Color Table palette to lock the selected 

color. 

A small square appears in the lower-right corner of the color swatch, indicating that the 

color is locked. (To unlock a color, select the locked color swatch and click again on the 

Lock button.)
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9 Repeat the procedure to lock the dark blue bear silhouette in the Northern 

Wilderness area. (You’ll probably need to hold down the spacebar and move the image up 

to see the Northern Wilderness portion.)

10 In the Optimize palette, reduce the number of colors to 32.

Notice that the locked colors remain in the palette after the reduction. However, new 

color-shift problems appear.

11 Change the number of colors back to 128.

12 Continue to select and lock the colors of all the animal silhouettes and the three 

shades of blue in the Northern Wilderness area. However, don’t lock the green 

background color of the Tropical Rainforest area for now. You will be working with that 

color later in this lesson.

Note that significant image degradation can occur when the palette is reduced below 32 

colors. In fact, for all but the simplest images, even 32 colors may be too drastic a 

reduction. For the best file compression of a GIF image, try to use the fewest number of 

colors that will still display the quality you need.

For an illustration of the image set to different palette values, see figure 14-1 in the 

color section.

13 When you have finished experimenting, set the colors to 32 in the Optimize palette 

and choose File > Save to save the file.

Controlling dither
You may have noticed that certain areas of the image appear mottled or spotty when 

optimized with different color palettes and numbers of colors. This spotty appearance 

results from dithering, the technique used to simulate the appearance of colors that are 

not included in the color palette. For example, a blue color and a yellow color may dither 

in a mosaic pattern to produce the illusion of a green color that does not appear in the 

color palette. You can select from three predefined dither patterns.

Note: To fine-tune and improve the appearance of dithered colors, you can create your own 

dither patterns using the Dither Box filter. 
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For information on creating custom dither patterns, see “Creating and Applying 

Custom Dither Patterns” and “Optimizing Images for the Web” in Adobe Photoshop 6.0 

online Help.

When optimizing images, keep in mind the two kinds of dithering that can occur:

• Application dither occurs when ImageReady or Photoshop attempts to simulate colors 

that appear in the original image but not in the optimized color palette you specify. You 

can control the amount of application dither by dragging the Dither slider in the 

Optimize palette.

• Browser dither occurs when a Web browser using an 8-bit (256-color) display simulates 

colors that appear in the optimized image’s color palette but not in the system palette used 

by the browser. Browser dither can occur in addition to application dither. You can 

control the amount of browser dither by shifting selected colors to Web-safe colors in the 

Color Table palette.

In ImageReady, you can view application dither directly in an optimized image. You can 

also preview the additional browser dither that will appear in the final image when viewed 

in a browser using an 8-bit display.

Controlling application dither

The Dither slider lets you control the range of colors that ImageReady simulates by 

dithering. Dithering creates the appearance of more colors and detail, but it can also 

increase the file size of the image. For optimal compression, use the lowest percentage 

of application dither that provides the color detail you require.

1 Open the file 14Start2.psd file if it’s not already open. 

2 Make sure that the optimized version of the image is selected, and that the Optimize 

palette is set to GIF format, Perceptual, and 32 colors.

3 In the Optimize palette, change the dithering algorithm from No Dither to Diffusion.
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4 Enter 100% in the Dither text box.

Using a combination of different colors, ImageReady tries to simulate the colors and 

tonalities that appear in the original image but not in the 32-color palette. Notice the 

speckled pattern that replaces the blocky drop shadows below the text. While not ideal, 

this pattern is a significant improvement and is acceptable. The dithered green 

background color for the Tropical Rainforest, however, is not acceptable.

5 Drag the Dither slider to 50%. Experiment with different dither amounts.

ImageReady minimizes the amount of dither in the image, but no percentage of dither 

will preserve the drop shadows without ruining the green background.

For an illustration of the effects of different dither percentages on an image, 

see figure 14-2 in the color section.

6 Set the dither back to 100%. 

7 Change the number of colors back to 128, lock the Tropical Rainforest green 

background color, and then switch back to 32 colors.

8 In the document window, change the magnification back to 100%.

The image is now acceptable.

Previewing and minimizing browser dither

As you learned earlier, images that include non-Web-safe colors undergo a process of 

dithering when displayed in a Web browser using an 8-bit display because the browser 

simulates colors that do not occur in the 8-bit system palette. ImageReady lets you 

preview how an optimized image will look when dithered in a Web browser. 
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To protect a color from browser dither, you can Web-shift the color, converting the color 

to its nearest equivalent in the Web palette. Because the Web palette includes the subset 

of colors that appear in both the Windows and the Mac OS system palettes, Web palette 

colors will display without dithering in browsers on either platform. 

1 With the optimized 14Start2.psd image open, choose View > Preview > Browser 

Dither. A check mark appears in the menu next to the command when it is active, letting 

you preview the effects of browser dithering on the optimized image.

Notice that browser dither occurs in the brown African Savannah background. If you 

don’t see the dithering right away, turn off the browser dither preview and then turn it 

back on to observe the effects. You can quickly toggle the browser dither preview off and 

on by pressing Ctrl+Shift+Y (Windows) or Command+Shift+Y (Mac OS). 

Next you’ll Web-shift one of the colors to reduce the amount of browser dither in 

the image.

2 Using the eyedropper tool ( ), click in the dithered brown area. The sampled color 

appears selected in the Color Table palette.

3 Click the Web-shift button ( ) at the bottom of the Color Table palette.

The swatch adjusts its position in the palette and a small diamond appears in the center 

of the swatch, indicating that it has been shifted to its nearest Web-palette equivalent.

By Web-shifting the brown background, you change its color to one that can be displayed 

without dithering by a Web browser on a 256-color system.
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4 Choose File > Save.

Specifying background transparency
Background transparency lets you place a nonrectangular graphic object against the 

background of a Web page; the areas outside the borders of the object are defined as trans-

parent, letting the Web page background color show through. You can specify 

background transparency for GIF and PNG images.

Creating transparency

An image must contain transparent pixels before you can create background trans-

parency. In this part of the lesson, you’ll use the magic eraser tool to quickly convert the 

background color of the zoo map to transparent pixels.

1 Select the Original tab at the top of the document window.

2 Choose Fit on Screen from the Zoom Level menu in the lower-left corner of the 

document window.

Before you can use the GIF file format’s ability to preserve transparency, you must create 

some transparency in your image. To do this, you’ll first convert the image background to 

a layer and then you’ll remove the white background pixels using the magic eraser tool.

3 In the Layers palette, double-click the Background to open the Layer Options dialog 

box. Use the default settings, including the name Layer 0, and click OK.

For the Web: Making transparent and matted images

Transparency makes it possible to place a nonrectangular graphic object against the background of a Web 

page. Background transparency, supported by GIF and PNG formats, preserves transparent pixels in the 

image. These pixels blend with the Web page background in a browser. 

Background matting, supported by GIF, PNG, and JPEG formats, simulates transparency by filling or 

blending transparent pixels with a matte color that you choose to match the Web page background on which 

the image will be placed. Background matting works only if the Web page background will be a solid color, 

and if you know what that color will be.

The original image must contain transparent pixels in order for you to create background transparency or 

background matting in the optimized image. You can create transparency when you create a new layer. 

–From Adobe Photoshop 6.0 online Help
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The magic eraser tool erases all pixels of a particular color with a single click. You’ll use 

this tool to erase all of the white pixels in the layer. However, you only want to erase the 

white pixels outside of the zoo map (not the white of the lettering), so you will first create 

a selection that excludes the interior portion of the image.

4 Select the marquee tool ( ).

5 Draw a rectangular selection marquee around the five regions of the zoo map, 

as shown.

6 Choose Select > Inverse to select everything outside of the rectangular selection 

marquee.

7 Select the magic eraser tool ( ) hidden under the eraser tool ( ).

8 In the tool options bar, deselect the Contiguous option so that all white pixels in the 

selection will be erased, including each isolated white section within the leaves.

9 Click the white background outside of the zoo map.

Now you will ensure that the transparent areas in the image are included as transparent 

pixels in the optimized GIF file.

10 In the Optimize palette, choose Show Options from the palette menu.
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11 Make sure the Transparency option is selected in the palette (a check mark must 

appear in the box).

Selecting Transparency converts areas in the original image with less than 50% opacity to 

background transparency in the optimized image.

12 Choose Select > Deselect.

13 Choose File > Save.

To view the transparency you’ve just defined, you’ll use ImageReady to preview the GIF 

image in a Web browser. Because ImageReady displays the image on a Web page with a 

white background, you’ll change the matte color of the image so you can see the trans-

parency you created.

14 Click the Matte text box in the Optimize palette to open the Color Picker dialog box. 

Select a color other than white, and click OK.

15 Choose File > Preview In, and choose the desired Web browser from the submenu.

Note: To use the Preview In command, you must have a Web browser installed on 

your system.

Creating background matting in GIF and PNG images

When you know the Web page background color on which an image will be displayed, you can use the 

matting feature to fill or blend transparent pixels with a matte color that matches the Web page background. 

The Web page background must be a solid color, not a pattern.

The results of matting GIF and PNG-8 images depend on the Transparency option. If you select 

Transparency, only the partially transparent pixels, such as those at the edge of an anti-aliased image, 

are matted. When the image is placed on a Web page, the Web background shows through the transparent 

pixels, and the edges of the image blend with the background. This feature prevents the halo effect that results 

when an anti-aliased image is placed on a background color that differs from the image’s original 

background. This feature also prevents the jagged edges that result with GIF hard-edged transparency.

If you deselect Transparency, fully transparent pixels are filled with the matte color, and partially transparent 

pixels are blended with the matte color. 

–From Adobe Photoshop 6.0 online Help
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If it is not already open, the browser first starts and then displays the optimized image in 

the upper-left corner of the browser window. In addition, the browser displays the pixel 

dimensions, file size, file format, and optimization settings for the image, along with the 

HTML code used to create the preview.

Transparency option selected Transparency option deselected

16 Quit your browser when you’re done previewing the image.

Trimming extra background areas

Although the background of the zoo map image now contains transparent pixels that do 

not display, these pixels still take up file space, adding to the size of the image. You can 

trim away unneeded background areas to improve the layout of the image and optimize 

the file size.

1 In ImageReady, choose Image > Trim.

The Trim command lets you crop your image, according to the transparency or pixel 

color of the extra border area.

2 In the Trim dialog box, select Transparent Pixels, and click OK.

ImageReady trims the extra transparent areas from the image.
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3 Choose File > Save Optimized As. 

4 In the Save Optimized As dialog box, use the default name (14Start2.gif), and click 

Save. 

5 In the Replace Files dialog box, click Replace.

6 Choose File > Close.

You will be prompted to save the 14Start2.psd file before closing. Since you are finished 

with this file for the lesson, there is no need to save the last changes.

Creating an image map
An image map is an image that contains multiple hypertext links to other files on the Web. 

Different areas, or hotspots, of the image map link to different files. Adobe ImageReady 

creates client-side image maps and server-side image maps.

Note: For information about slicing an image into multiple image files and linking each slice 

to another Web page, see Lesson 15, “Creating Web Graphics Using Slices and Rollovers.”

Creating and viewing image maps (ImageReady)

Image maps enable you to link an area of an image to a URL. You can set up multiple linked areas—called 

image map areas—in an image, with links to text files; other images; audio, video, or multimedia files; other 

pages in the Web site; or other Web sites. You can also create rollover effects in image map areas. 

The main difference between using image maps and using slices to create links is in how the source image is 

exported as a Web page. Using image maps keeps the exported image intact as a single file, while using slices 

causes the image to be exported as a separate file. Another difference between image maps and slices is that 

image maps enable you to link circular, polygonal, or rectangular areas in an image, while slices enable you 

to link only rectangular areas. If you need to link only rectangular areas, using slices may be preferable to 

using an image map. 

Note: To avoid unexpected results, do not create image map areas in slices that contain URL links—

either the image map links or the slice links may be ignored in some browsers.

–From Adobe Photoshop 6.0 online Help
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In this part of the lesson, you’ll create an image map in an existing image. You define 

hotspots using layers or one of the image map tools. You’ll use a version of the zoo map 

that has each geographic region on its own layer and convert each layer to an image map 

hotspot. By using layers to define the hotspots, you have more control over the shapes of 

the areas than you do with the rectangle, circle, or polygon image map tools. 

1 In ImageReady, choose File > Open, and open the file 14Start3.psd from the 

Lessons/Lesson14 folder.

Although this image looks similar to the previous zoo map, it is actually composed of 

several different layers. You’ll make this map image into a graphical table of contents 

linking to different areas of the zoo’s Web site. 

2 In the Optimize palette, choose GIF 64 Dithered from the Settings menu.

3 If the Layers palette is not already showing, choose Window > Show Layers.

Notice that the map pieces representing different sections of the zoo reside on 

separate layers.

4 In the Layers palette, select the African Savannah layer.

5 Choose Layer > New Layer Based Image Map Area.

6 Choose Window > Show Image Map to display the Image Map palette.

7 In the Image Map palette, choose Polygon from the Shape menu, and enter 90 in the 

Quality text box.

The Shape option determines the boundary of the hotspot area. The Quality value deter-

mines how closely the boundary line follows the shape of the area.
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The URL option lets you specify the target file for the hotspot link. You can link to another 

file in your Web site, or to a different location on the Web. For the purposes of this lesson, 

you’ll link your hotspots to fictitious URLs for the zoo.

8 Type http://www.adobe.com/african_savannah.html in the URL text box, and press 

Enter.

The URL you entered appears below the African Savannah layer name in the Layers 

palette.

9 Repeat steps 4 through 8 to create hotspots for the Exotic Asia, Tropical Rainforest, 

Himalayan Highlands, and Northern Wilderness layers. Use the same settings, but change 

the URL so that the last word matches the name of the layer you are working with.

10 Choose File > Save.

Previewing and adjusting the cross-platform gamma range

Now you’ll check to see if the brightness of your image is compatible across monitors on 

different platforms. Windows systems generally display a darker midtone brightness, 

or gamma, than do Mac OS systems. Be sure to preview and, if necessary, adjust the 

cross-platform brightness of your image before publishing it on the Web.

Note: Before starting this part of the lesson, be sure to calibrate your monitor so that it 

displays color accurately. For information, see Lesson 11, “Setting Up Your Monitor for Color 

Management.”

1 In the toolbox, click the Toggle Image Maps Visibility button ( ) to hide the polygon 

boundary lines of the image map areas.
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2 Choose View > Preview > Standard Macintosh® Color or View > Preview > Standard 

Windows Color to preview the image as it will appear on the designated platform.

An image created on a Windows system will appear lighter on a Mac OS system. An image 

created on a Mac OS system will appear darker on a Windows system. 

3 Choose Image > Adjust > Gamma.

The Gamma dialog box appears, letting you automatically correct the image’s gamma for 

cross-platform viewing.

4 Click the Windows to Macintosh button if you are working on the Windows platform 

and want to preview how the image would appear on the Mac OS platform. If you are 

working on the Mac OS platform, click the Macintosh to Windows button to preview the 

change from Mac OS to Windows. Then, click OK.

5 Choose File > Save Optimized As.

6 In the Save Optimized As dialog box, choose Images Only from the Format menu, 

use the default name 14Start3.gif, and click Save.

Now you’ll preview your image map in a Web browser.

7 Choose File > Preview In, and choose a browser application from the submenu.
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8 In the browser window, move the pointer over the different zoo regions, and notice 

that these elements contain hypertext links. If you had a modem and an Internet 

connection and if these were authentic URLs, you could click the hotspots to jump to the 

specified page of the zoo site. 

9 Quit your browser to return to Adobe ImageReady.

Creating the HTML file

When you save an image map in an HTML file, the basic HTML tags needed to display 

the image on a Web page are generated automatically. The easiest way to do this is simply 

to choose the HTML and Images Format option when you save the optimized image.

Once you have created the HTML file, it can be easily updated to reflect any changes, such 

as new or modified image map areas or URLs. 
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1 In ImageReady, choose File > Save Optimized As.

Note: In Photoshop, you create an HTML file in the Save Optimized As dialog box that 

appears after optimizing the image and clicking OK in the Save For Web dialog box.

2 In the Save Optimized As dialog box, choose HTML and Images from the Format 

menu (Mac OS) or from the Save As Type menu (Windows), use the default name 

14Start3.html, and click Save.

When you select the HTML and Images option, an HTML page containing the image is 

saved automatically, in addition to the graphic file. This HTML file will have the same 

name as the image, but with the .html extension.

3 In the Replace Files dialog box, click Replace.

Now you’ll use ImageReady to change one of the URL links and update the HTML file.

4 In the toolbox, select the Image Map Select tool ( ) hidden under the Rectangle Image 

Map tool ( ).

5 Click in the document window to select the African Savannah image map area.

6 In the Image Map palette, change the URL to http://www.adobe.com/newafrica.html.

7 Choose File > Update HTML.

8 In the Update HTML dialog box, select the 14Start3.html file, and click Open.

9 In the Replace Files dialog box, click Replace.

10 Click OK to dismiss the update message.

11 Choose File > Close to close the image. Don’t save changes, if prompted.
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If desired, you can use your Web browser to open and view 14Start3.html. You can also 

open the file in a text editor, word-processing, or HTML editing program to make your 

own revisions to the HTML code

Batch-processing file optimization
ImageReady supports batch-processing through the use of droplets—icons that contain 

actions for ImageReady to perform on one or more files. Droplets are easy to create and 

use. To create a droplet, you drag the droplet icon out of the Optimization palette and 

onto the desktop. To use a droplet, you drag a file or folder over the droplet icon on the 

desktop.

1 In ImageReady, choose File > Open, and open any file in the Lessons/Lesson14/Photos 

folder.

2 Experiment with different file formats and other settings in the Optimize palette as 

desired until you are satisfied with the result.

3 Drag the droplet icon ( ) out of the Optimize palette and drop it anywhere on your 

desktop. (If you are using Windows, you may have to resize the ImageReady window to 

make your desktop visible.)

For the Web: HTML File Naming Conventions

Use the UNIX® file-naming convention, because many network programs truncate (shorten) long filenames. 

This convention requires a filename of up to eight characters, followed by an extension. Use the .html or .htm 

extension. 

Do not use special characters such as question marks (?) or asterisks (*), or spaces between the letters in your 

filename—some browsers may not recognize the pathname. If you must use special characters or spaces in 

the filename, check with an HTML editing guide for the correct code to use. For example, to create spaces 

between letters you will need to replace the space with “%20”.
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4 Close the file (without saving it), and quit ImageReady.

5 From your desktop, drag the Photos folder from the Lessons/Lesson14 folder and drop 

it onto the droplet to batch-process the photographic images within the folder.

ImageReady optimizes each file and adds the Web image to the Photos folder.

6 Open any of the Web image files in the Photos folder. 

Notice that they have all been optimized according to the settings specified when the 

droplet was created.

7 Quit ImageReady when you are done.
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Review questions
1 For image optimization, what are the advantages of using ImageReady rather than 

Photoshop?

2 What is a color table?

3 When does browser dither occur, and how can you minimize the amount of browser 

dither in an image?

4 What is the purpose of assigning matte color to a GIF image?

5 Summarize the procedure for creating an image map.

Review answers
1 There aren’t really any advantages to using one application over the other for 

optimization. Both Photoshop and ImageReady can perform a wide range of image 

optimization tasks. ImageReady has many Web-specific features that you won’t find in 

Photoshop, but image optimization is not one of them.

2 A color table is a table that contains the colors used in an 8-bit image. You can select 

a color table for GIF and PNG-8 images, and add, delete, and modify colors in the 

color table.

3 Browser dither occurs when a Web browser simulates colors that appear in the image’s 

color palette but not in the browser’s display system. To protect a color from browser 

dither, you can select the color in the Color Table palette, and then click the Web-shift 

button at the bottom of the palette to shift the color to its closest equivalent in the Web 

palette. 

4 By specifying a matte color, you can blend partially transparent pixels in an image with 

the background color of your Web page. Matting lets you create GIF images with 

feathered or anti-aliased edges that blend smoothly into the background color of your 

Web page.

5 To create an image map, you define hotspot areas of the image using the image map 

tools or by selecting layers and choosing Layer > New Layer Based Image Map Area. Then 

you use the Image Map palette to define the shape of the hotspot and link each hotspot to 

a URL address.
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