
 

6

 

Working with Typography

 

Using InDesign tools, you can precisely 

control the type and formatting of your 

document. Palettes make it easy to change 

fonts and type styles, modify the align-

ment, add tabs and indents, and apply 

gradients and strokes to text. 
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Working with Typography

 

In this lesson, you’ll learn how to do the following:

 

•

 

Prepare and use a baseline grid

 

•

 

Change type spacing and appearance

 

•

 

Create special characters

 

•

 

Create a tabbed table with tab leaders and hanging indents

 

•

 

Export a file to Portable Document Format (PDF)

 

Note:

 

 To view the exported PDF file, you will need to have Adobe Acrobat Reader installed. 

You can install Acrobat Reader from the Adobe InDesign CD, or download it from the Adobe 

Web site (www.adobe.com).

 

Getting started

 

In this lesson, you’ll create an annual report for the Sonata Cycles company. Before you 

begin, you’ll need to restore the default preferences for Adobe InDesign. 

 

1

 

To ensure that the tools and palettes function exactly as described in this lesson, delete 

or deactivate (by renaming) the InDesign Defaults file and the InDesign SavedData file. 

See “Restoring default preferences” on page 2. 

 

2

 

Start Adobe InDesign.

To begin working, you’ll open an existing InDesign document.

 

3

 

Choose File > Open, and open the 06_a.indd file in the ID_06 folder, located inside the 

Lessons folder within the IDCIB folder on your hard disk. If an alert message appears that 

asks which dictionary file you want to use, click No (Windows) or Document (Mac OS).

 

4

 

Choose File > Save As, rename the file 

 

06_report.indd

 

, and save it in the ID_06 folder.
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If you want to see what the finished document will look like, open the 06_b.indd file in 

the same folder. You can leave this document open to act as a guide as you work. When 

you’re ready to resume working on the lesson document, choose its name from the 

Window menu.

For a color version of the finished document, see the color section.

 

Adjusting vertical spacing

 

InDesign provides several options for customizing and adjusting the vertical spacing in 

your document. You can automatically set the space between all lines of text using a 

baseline grid. You can also set the space between each line or each paragraph separately 

using the Leading option in the Character palette or the Space Before/Space After options 

in the Paragraph palette. In addition, you can use the Vertical Justification options in the 

Text Frame Options dialog box to align text within a frame.

In this section of the lesson, you will use the baseline grid to align text.

 

Using a baseline grid to align text

 

One of the first things you may want to do, once you’ve decided on the font size and 

leading for your document’s body text, is set up a baseline grid (also called a leading grid) 

for the entire document. Baseline grids represent the leading for your document’s body 

text and are used to align the baselines of one column of text with the baselines of neigh-

boring columns. 

Before you set the baseline grid, you’ll want to check the margin value for the top of your 

document and the leading value for the body text so that these elements work with the 

grid in a cohesive design.
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1

 

To view the top margin value for the document, choose Layout > Margins and Columns. 

The top margin is set to 6p0 (6 picas, 0 points). Click Cancel to close the dialog box.

 

2

 

To determine the leading value, select the type tool ( ) in the toolbox and click in a 

body text paragraph. Then click the Character palette tab (or choose Type > Character) 

to make the palette visible. Check the leading value ( ) in the Character palette. The 

leading is set to 14 pt (14 points).

 

3

 

Choose Edit > Preferences > Grids to set your grid options. In the Baseline Grid 

section, type 

 

6

 

 for Start to match your top margin setting of 6p0. This option sets the 

location of the first grid line for the document. If you use InDesign’s default value of 3p0, 

the first grid line would appear above the top margin.

 

4

 

For Increment every, type 

 

14pt 

 

to match your leading. When you select another 

option, InDesign automatically converts the points value to picas, or 1p2. 

 

5

 

Choose 100% for View Threshold. This option sets the document view value at which 

you can see the grid on-screen.

 

6

 

Click OK to close the dialog box.
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Now you’ll make the grid you just set up visible on-screen.

 

1

 

To view the grid in the document window, choose View > Show Baseline Grid. The grid 

does not appear because the document view is lower than the grid’s View Threshold value. 

Choose 100% from the magnification menu at the lower left corner of the document 

window—the grid now appears on-screen.

Now you’ll use the Paragraph palette to align all the text to the grid. You can align multiple 

stories independently of one another or all at once. You’ll align all the stories in this spread 

simultaneously.

 

2

 

Click the Paragraph tab (or choose Type > Paragraph) to make the palette visible.

 

3

 

With the type tool still selected, click an insertion point anywhere in the first paragraph 

on the spread, and then choose Edit > Select All to select all the text in the main story. 
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When applying paragraph attributes, it is not necessary to select an entire paragraph with 

the type tool. Just select a portion of the paragraph or paragraphs you want to format. If you 

are formatting only one paragraph, you can simply click in the paragraph to make an 

insertion point.

 

4

 

In the Paragraph palette, click the Align to Baseline Grid button 

 

(

 

). The text shifts so 

that the baselines of the characters rest on the grid lines.

 

Before and after aligning the text to the baseline grid

 

5

 

If necessary, scroll to the left side of the spread so you can see the pull quote on the side 

of the page; then click an insertion point in the pull quote. 

 

6

 

In the Paragraph palette, click the Align to Baseline Grid button. Because this text is 

formatted using 18 point leading, not the baseline grid leading value of 14pt or 1p2, aligning 

to the grid causes the text to expand to every other grid line (using 28 point leading).

 

Before and after aligning the pull quote to the baseline grid

 

7

 

Save the file.
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Changing the spacing above and below paragraphs

 

When you apply a space before or after a paragraph that you have previously aligned to 

grid, the space automatically adjusts to the next highest multiple of the grid value. For 

example, if your grid is set to 14 points (1p2) and you specify a space after to any value 

under 14, InDesign automatically increases the space value to 14; if you specify a space to 

a value over 14, such as 16, InDesign increases it to the next higher multiple—28. You can 

use the Space Before or After value instead of the baseline grid value, by selecting the Do 

Not Align to Baseline Grid option for the affected paragraph.

 

No space (left), space adjusted to fit grid at 28 pt (middle), and actual space value at 16 pt (right)

 

Here you’ll increase the space after the second paragraph of the main story. All other 

paragraphs in the spread have already been formatted with a 1p2 space after value. 

 

1

 

Make sure the type tool ( ) is still selected, and click anywhere in the second 

paragraph on the page on the left (page 2).

 

2

 

In the Paragraph palette, type 

 

1p2

 

 for Space After ( ) and press Enter or Return. The 

text in the next heading shifts automatically to the next grid line.

 

Before and after applying a Space After value to the paragraph
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Now you’ll increase the space before the heading “The Dos Ventanas Cycling Partnership” 

to give it even more space. 

 

3

 

Click an insertion point in the heading “The Dos Ventanas Cycling Partnership.” In the 

Paragraph palette, type 

 

0p6

 

 for Space Before ( ) and then press Enter or Return. Because 

you previously aligned the heading to the baseline grid, the space before jumps to 14 

points instead of 6. 

To use the 0p6 value instead of 14, and to add more space between the heading and the 

following paragraph, you’ll unalign the heading from the grid. 

 

4

 

With an insertion point still in the heading “The Dos Ventanas Cycling Partnership,” 

click the Do Not Align to Baseline Grid button ( ) in the Paragraph palette. The 

heading shifts upward a bit, away from the body text below.

 

Before and after unaligning the heading from the baseline grid

 

This heading and the heading on the page on the right (page 3) are formatted using the 

Head 1 style. To automatically update the second heading so that it uses the same spacing 

values as the heading you just edited, you’ll redefine the style.

 

5

 

Click the Paragraph Styles palette tab (or choose Type > Paragraph Styles) to make the 

palette visible.

 

6

 

Click an insertion point in the heading “The Dos Ventanas Cycling Partnership.” 

Notice that a plus sign (+) appears after the Head 1 style name in the palette. This sign 

indicates the formatting for the selected text is different from the original formatting for 

the style.
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Position the pointer on the black triangle to the right of the Paragraph Styles tab, and 

choose Redefine Style from the Paragraph Styles palette menu. The Head 1 style now takes 

on the formatting of the current text.

Notice that the plus sign disappears and the space before is added to the heading on page 3.

 

8

 

To unalign the heading on page 3 from the grid, click in the heading and then select the 

Head 1 style in the Paragraph Styles palette to reapply the style. 

 

9

 

Save the file.

 

Changing fonts and type style

 

Changing the fonts and type styles of text can make a dramatic difference to the 

appearance of your document. Here you’ll change the font family, type style, and size for 

the text in one of the pull quotes along the border of the spread. You’ll make these changes 

using the Character palette. 

 

About Fonts

 

A font, also known as a face or typeface, is a complete set of characters: letters, numbers, and symbols that 

share a common weight, width, and style, such as the bold style of Utopia, Minion, or Adobe Garamond.

A font family (or type family) is a collection of fonts sharing an overall appearance and designed to be used 

together, such as Adobe Garamond. A type style is a variant version of an individual font in a font family. 

Typically, the Roman or Plain member of a font family is the base font, which includes styles such as regular, 

bold, italic, and bold italic.

 

–From the 

 

Adobe InDesign User Guide

 

, Chapter 5
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1

 

Click the Character palette tab (or choose Type > Character).

 

2

 

Using the type tool ( ), triple-click in any word in the pull quote along the left side of 

page 2 to select the entire paragraph.

 

3

 

In the Character palette, select Adobe Garamond from the Font Family menu and 

Semibold Italic from the Type Style menu. 

 

4

 

In the Font Size text box, type 

 

15

 

 and press Enter or Return. 

 

5

 

Choose Edit > Deselect All to deselect the text. Notice how the text stays aligned to the 

grid even after changing these attributes. 

 

6

 

You won’t be using the baseline grid for the remainder of the lesson, so you can hide it 

from view. To hide it, choose View > Hide Baseline Grid. 

 

7

 

Save the file.

 

Changing paragraph alignment

 

You can easily manipulate how a paragraph fits in its text frame by changing the 

alignment. You can align text with one or both edges of a text frame or text frame inset. 

Justifying text aligns both edges. In this section, you’ll justify the pull quote. 

 

1

 

Using the type tool ( ), click an insertion point in the pull quote on page 2.
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Click the Paragraph palette tab (or choose Type > Paragraph), and then click the Justify 

All Lines button ( ).

 

Before and after justifying text

 

Adding a decorative font and special character

 

Now you’ll add a decorative font character and a flush space (special character) to the end 

of the pull quote. Used together, a decorative font and flush space can make a dramatic 

difference to the look of a justified paragraph.

 

1

 

Using the type tool ( ), click an insertion point in the pull quote, just after the final 

period.

 

2

 

Choose Type > Insert Character. In the Insert Character dialog box, you can select a 

specific font family and type style from the menu at the bottom of the dialog box and then 

select a character from the scrollable list.

 

3

 

Select Adobe Wood Type

 

®

 

 for the font family and Ornaments Two for the type style.

 

4

 

From the scrollable list select the first character in the first row and click Insert. The 

character appears at the insertion point in the document.
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Click Done. 

Notice how the word spacing in the last line of the pull quote has an overly large space in 

the center. You can address this by adding a flush space to the end of the paragraph. A 

flush space adds a variable amount of space to the last line of a fully justified paragraph. 

You’ll insert the flush space between the period and the decorative end-of-story character 

you just added. 

Now you’ll create a flush space using the context menu.

 

6

 

Using the type tool, click an insertion point in the pull quote after the last period and 

before the decorative character.

 

7

 

Right-click (Windows) or Control-click (Mac OS) and choose Insert White Space > 

Flush Space.

 

Before and after applying a flush space

 

Applying special font features

 

You can add creative touches to your document using InDesign’s special font features. For 

example, you can make the first character or word in a paragraph a drop cap, or apply a 

gradient or color fill to text. Other features include superscript and subscript characters, 

ligatures, and old style numerals. 
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Applying a gradient to text

 

InDesign makes it easy to apply gradients to the fill and stroke of text characters. You can 

apply gradients to an entire text frame or to different character ranges within a frame. 

Here you’ll apply a gradient to the pull quote on page 2. You’ll use a gradient swatch that 

was previously created and added to the Swatches palette. 

 

1

 

Click the Swatches palette tab (or choose Window > Swatches) to make the palette visible.

 

2

 

Make sure the type tool ( ) is still selected, and then triple-click anywhere in the pull 

quote on page 2 to select all of the text in the paragraph. 

 

About text gradients

 

A gradient’s endpoints are always anchored in relation to the bounding box of the gradient’s path or text 

frame. Individual text characters display the part of the gradient over which they are positioned. If you resize 

the text frame or otherwise cause text characters to reflow, the characters are redistributed across the gradient, 

and the colors of individual characters change accordingly.

If you want to adjust a gradient so that its complete color range spans a specific range of text characters, you 

have two options:

 

•

 

Use the gradient tool to reset the gradient’s endpoints so that they span only the characters you selected 

when you applied the gradient.

 

•

 

Select the text and convert it to outlines (editable paths), and then apply a gradient to the resulting 

outlines.

 

–From the 

 

Adobe InDesign User Guide

 

, Chapter 9
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Select the Fill box ( ) in the toolbox, and then select the Text Gradient swatch in the 

Swatches palette (you may need to scroll). To see the gradient, choose Edit > Deselect All.

 

Applying a gradient swatch to selected text creates a left-to-right gradient fill.

 

Notice how the gradient flows from the left to right. If you want to change the direction 

of the gradient, you can use the gradient tool. You’ll do that now to make the gradient flow 

from top to bottom, like the pull quote on page 3.

For a color version of gradient filled text, see figure 6-2 in the color section.

 

4

 

Using the type tool, triple-click anywhere in the pull quote to select all of the text.

 

5

 

Select the gradient tool (not the Gradient button) in the toolbox ( ), and drag a line 

from the top to the bottom of the highlighted text. To ensure that you draw a straight line, 

hold down the Shift key as you drag.

To view the gradient fill, you’ll use a keyboard shortcut to deselect all the text.
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Press Shift+Ctrl+A (Windows) or Shift+Command+A (Mac OS) to deselect the text.

 

The gradient tool (left) lets you set the direction of the gradient fill.

 

For a color version of using the gradient tool, see figure 6-3 in the color section.

 

Creating a drop cap

 

Here you’ll create a three-letter drop cap in the first paragraph of the document. 

 

1

 

Using the type tool ( ), click an insertion point in the first paragraph on page 2.

 

2

 

In the Paragraph palette, type 

 

3

 

 for Drop Cap Number of Lines ( ) to make the letters 

drop down three lines. Then type 

 

3

 

 for Drop Cap One or More Characters ( ) to enlarge 

the first three letters. Press Enter or Return.

 

Before and after applying the drop cap
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Applying a fill and stroke to text

 

Next, you’ll add a fill and stroke to the drop cap letters you just created. 

 

1

 

With the type tool ( ) still selected, select the drop cap characters on page 2. 

 

2

 

If necessary, select the Fill box in the toolbox ( ).

 

3

 

In the Swatches palette, select Sonata Red. InDesign fills the letters with red, though 

you can’t see it yet because the text is still selected.

 

Note:

 

 If you don’t see Sonata Red in the palette, click the Show All Swatches button ( ).

 

4

 

Select the Stroke box in the toolbox ( ).

 

5

 

In the Swatches palette, select Black. A stroke appears around each of the letters. 

The default size of the stroke is 1 point, which is a little heavy for the letters. You’ll change 

it to a half point.

 

6

 

Choose Window > Stroke to open the Stroke palette. 

 

7

 

In the Stroke palette, choose 0.5 pt for Weight. Then, press Shift+Ctrl+A (Windows) 

or Shift+Command+A (Mac OS) to deselect the text to view the fill and stroke effect.

 

Original drop cap (left), drop cap with color fill (middle), and drop cap with fill and stroke (right)

 

8

 

Close the Stroke palette, and then save the file.

For a color version of adding fill and stroke to text, see figure 6-4 in the color section.

 

Adjusting letter and word spacing

 

You can change the spacing between words and letters using InDesign’s kerning and 

tracking features. You can also control the overall spacing of text in a paragraph using the 

single-line or multi-line composers.
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Adjusting the kerning and tracking

In InDesign you can control the space between letters by using the kerning and tracking 

features. Kerning is the process of adding or subtracting space between specific letter 

pairs. Tracking is the process of creating an equal amount of spacing across a range of 

letters. You can use both features on the same text.

Here you’ll manually kern some letters in the heading “The Dos Ventanas Cycling 

Partnership” to close up noticeable gaps. Then you’ll track the heading to bring it all onto 

one line. 

1 To distinguish the amount of space between letters more easily and to see the results of 

the kerning more clearly, select the zoom tool ( ) in the toolbox and drag a marquee 

around the heading “The Dos Ventanas Cycling Partnership.” 

2 If necessary, adjust the zoom level in the magnification menu in the lower left corner 

of the document window.

3 Select the type tool ( ) and click an insertion point between the “V” and the “e” in the 

word “Ventanas.” 

Metrics, optical, and manual kerning 

Metrics kerning uses kern pairs, which are included with most fonts. Kern pairs contain information about 

the spacing of specific pairs of characters. A sample of these are: LA, P., To, Tr, Ta, Tu, Te, Ty, Wa, WA, We, 

Wo, Ya, Yo, and yo. InDesign uses metrics kerning by default so kern pairs are automatically honored when 

you import or type text.

Optical kerning adjusts the spacing between adjacent characters based on their appearance. You can also use 

manual kerning, which is ideal for adjusting the space between two letters. 

If you click an insertion point between two letters, InDesign displays the kerning values in the Character pal-

ette. Metrics and Optical kerning values (kern pairs) appear in parentheses.

–From the Adobe InDesign User Guide, Chapter 5
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4 Press Alt+Left Arrow (Windows) or Option+Left Arrow (Mac OS) to move the letter 

“e” to the left. Press this key combination repeatedly until the two adjacent letters look 

visually pleasing to you. We pressed it four times.

Note: The kerning value changes in the Character palette as you press the key combination.

Before and after kerning

5 If you’ve moved the letter too far, press Alt+Right Arrow (Windows) or Option+Right 

Arrow (Mac OS) to move the letter to the right.

6 Click an insertion point between the “P” and the “a” in the word “Partnership.” 

7 Press Alt/Option+Left Arrow to move the letter “a” to the left. Press this key combi-

nation repeatedly until the two adjacent letters look visually pleasing to you. We pressed 

it four times.

Before and after kerning

Now you’ll set a tracking value for the entire heading “The Dos Ventanas Cycling 

Partnership” to condense the overall spacing and bring it all onto one line. To set tracking 

you must first select the entire range of characters you want to track. 
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8 Choose 200% from the magnification menu at the lower left corner of the document 

window to view more of the page on-screen.

9 Triple-click “The Dos Ventanas Cycling Partnership” to select the entire heading.

10 Click the Character palette tab (or choose Type > Character). Then select -5 for 

Tracking ( ) and press Enter or Return.

Before and after tracking

Now you’ll use a keyboard shortcut to deselect the text.

11 Press Shift+Ctrl+A (Windows) or Shift+Command+A (Mac OS).

12 Press Ctrl+1 (Windows) or Command+1 (Mac OS) to return to a 100% view.

13 Save the file.

Applying the multi-line and single-line composers

The density of a paragraph (sometimes called its color) is determined by the composition 

method used. When composing text, InDesign considers the word spacing, letter spacing, 

glyph scaling, and hyphenation options you’ve selected, and then evaluates and chooses 

the best line breaks. InDesign provides two options for composing text: the multi-line 

composer, which looks at multiple lines at once, or the single-line composer, which looks 

separately at each individual line. 
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When you use the multi-line composer, InDesign composes a line by considering the 

impact on the other lines in the paragraph; in the end, the best overall arrangement of the 

paragraph is established. As you change type in a given line, previous and subsequent 

lines in the same paragraph may break differently, making the overall paragraph appear 

more evenly spaced. When you use the single-line composer, which is the standard for 

other desktop layout and word processing programs, only the lines following the edited 

text are recomposed.

The text in this lesson was composed using the default multi-line composer. Here you’ll 

edit the text in the pull quote on page 3 and recompose it using both composers to 

compare the differences. First you’ll recompose the text using the single-line composer.

1 Move the scroll bar at the bottom of the page to the right to bring page 3 into view.

2 With the type tool ( ) still selected, click an insertion point in the pull quote in the 

lower right corner. Then click the Paragraph tab (or choose Type > Paragraph). Choose 

Adobe Single-line Composer from the Paragraph palette menu. 

3 Click an insertion point immediately after the word “spare” in the pull quote. Then 

insert a space and type “bicycle”. Notice that the text no longer fits in the text frame and 

each line has a different density. 

The single-line composer looks at each line individually and, consequently, can make 

some lines in a paragraph appear more dense or sparse than others, as is the case here. 

Because the multi-line composer looks at multiple lines at once, the density of the lines 

in a paragraph are more consistent.

CIB.book  Page 218  Monday, May 1, 2000  11:21 PM



219ADOBE INDESIGN 1.5
Classroom in a Book

4 Choose Adobe Multi-line Composer from the Paragraph palette menu. Notice how the 

lines of text have a consistent density and all the text fits neatly in the text frame.

Pull quote formatted using the single-line composer (left), and the multi-line composer (right)

For a color version of composition methods, see figure 6-5 in the color section.

Creating a table using tabs
You can use tabs to create tables and position text in specific horizontal locations in a 

frame. Using the Tabs palette, you can organize text and create tab leaders, indents, and 

hanging indents. Here you’ll format the table at the top of page 3 using the Tabs palette. 

The tab markers have already been entered in the text, so all you will be doing is setting 

the final location of the text.

1 If necessary, scroll to the top of page 3 until the table appears on-screen. Then, if you 

want to view the tab markers in the table, choose Type > Show Hidden Characters. 

Choose Type > Show Hidden Characters again to hide them.

2 Using the type tool ( ), click in the word “Category” at the top of the table.

3 Choose Type > Tabs to open the Tabs palette. When an insertion point is in a text 

frame, the Tabs palette snaps to the border of the frame so that the measurements in the 

palette’s ruler exactly match the text.
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4 To center the page on your screen, double-click the page 3 icon in the Pages palette. 

Because the Tabs palette moves independently of the table, the two are no longer aligned.

5 Click the magnet icon ( ) in the Tabs palette to realign the palette with the text.

Clicking the magnet icon in the Tabs palette aligns the ruler with the selected text.

Note: If the Tabs palette did not snap to the table, part of the table may be hidden from view, 

or there may not be enough room for the Tabs palette between the table and the top of the 

document window. Scroll as necessary, and then click the magnet icon ( ) again.

6 Using the type tool, select all of the text in the table’s text frame, from the word 

“Category” to the number “$110,000.”

7 In the Tabs palette, click the Center-Justified Tab button ( ) so that when you set the 

new tab positions, they will align from the center.
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8 In the Tabs palette, position the pointer in the top third of the ruler, just above the 

numbers, and then click to set tab markers at the following locations: 24, 29, 34, 40, and 45. 

You can view the location of the pointer on the ruler in the X: text box. To precisely set the 

value, drag in the ruler while watching the X value before releasing the mouse button. 

The value in the X: text box indicates the location of the selected tab.

Note: If you don’t get the tab locations correct the first time, you can select the tab in the ruler 

and type the location in the text box.

9 Press Shift+Ctrl+A (Windows) or Shift+Command+A (Mac OS) to deselect the text 

and view the new tab settings.

Now you’ll set a tab leader for some of the tabs.
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10 Select all the text in the table from “Mountain” to “$110,000.”

11 In the Tabs palette, click the first tab arrow along the ruler to select it. Now, the leader 

you create will affect any selected tabs at that tab marker.

12 In the Leader text box, type ._ (period, space) and press Enter or Return. You can use 

any character as a tab leader. We used a space between periods to create a more open dot 

sequence.

13 Deselect the table text and view the leaders.
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Creating a hanging indent
Now you’ll use the Tabs palette to create hanging indents. The text frame for this table has 

an inset value of 6 points at the top and 9 points on the sides and bottom. (To see the inset 

values, choose Object > Text Frame Options.) An inset sets the text apart from the frame; 

now you’ll set it apart even more by indenting the three categories in the table. 

You can set an indent in the Tabs palette or the Paragraph palette. You’ll keep the 

Paragraph palette visible so you can see how the values change there too.

1 Make sure the Paragraph palette is visible.

2 In the table, use the type tool ( ) to select all the text from “Mountain” to “$110,000.”

3 Make sure the Tabs palette is still aligned directly above the table. If it has moved, click 

the magnet icon ( ).

4 In the Tabs palette, drag the indent markers ( ) on the left side of the ruler to the right 

until the X value is 2p0. Dragging the bottom marker moves both at once. Notice how all 

the text shifts to the right and the indent option in the Paragraph palette changes to 2p0. 

Don’t deselect the text yet.

Now you’ll bring just the category headings back to their original location in the table to 

create a hanging indent. 
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5 In the Tabs palette, drag the top index marker back to the left until the X: value is -2p0. 

Deselect the text and view the hanging indent.

6 Close the Tabs palette and save the file.

Adding a rule below a paragraph
You can also add a rule, or line, above or below a paragraph. Rules change in size in 

relation to changes to the paragraph’s text frame. For example, if you make the text frame 

wider, the rule also becomes wider. Here you’ll add a rule under the table headings.

1 Using the type tool ( ), click an insertion point in the word “Category” in the table.

2 From the Paragraph palette menu, choose Paragraph Rules. 

3 In the Paragraph Rules dialog box, choose Rule Below from the menu at the top of the 

dialog box, and then select Rule On to activate the rule.

4 To view the rule as you select your options, select Preview and move the dialog box so 

that it is not obstructing your view of the heading.
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5 For Weight, choose 1 pt; for Color, choose Sonata Red; for Width, choose Column; and 

for Offset, type 0p9. Then click OK.

6 Save the file.

For a color version of the completed table, see figure 6-6 in the color section.

Exporting a document to PDF
Now you’ll export the document to Portable Document Format (PDF) so you can 

distribute it electronically or link it to your Web site. When you export a document to 

PDF, all of the formatting remains intact, including all fonts and images, as well as all of 

the spacing settings, special characters, tabs, and other special formatting you applied in 

this lesson. If you link it to a Web site, everyone who views it through their browser will 

see it exactly as you do.

1 Choose File > Export. In the dialog box, for Save as Type (Windows) or Formats (Mac 

OS) choose Adobe PDF . Then name the file Report.pdf, and save it in the ID_06 folder.
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2 If desired, in the Export PDF dialog box, select View PDF after Exporting. Leave all of 

the settings at their defaults and click Export.

InDesign saves the copy of the report as a PDF that can be viewed electronically using 

Adobe Acrobat Reader. It can also be linked to your Web page to be viewed in a browser. 

Acrobat Reader is provided on the Adobe InDesign CD and is available on the Adobe Web 

site (http://www.adobe.com) for free distribution.

Your InDesign document exported as PDF

On your own
Now that you have learned the basics of formatting text in an InDesign document, you're 

ready to apply these skills on your own. Try the following tasks to improve your typog-

raphy skills.
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1 Create a one-letter, three-line raised cap (as opposed to a drop cap) for the word “The” 

that appears at the beginning of the last paragraph on page 2 of the final 06_report.indd 

file. The basic steps to achieve this effect are: (A.) Create a three-line drop cap for the 

paragraph. (B.) Click an insertion point after the first letter in the paragraph, and then 

press Enter/Return twice to move the text down. Another drop cap is created. (C.) Set the 

new Drop Cap values to 0. 

2 Refine the text in the raised cap by kerning the first and second letter so it appears as 

shown:

Original drop cap (left), second drop cap, created to make raised cap (middle), raised cap (right)

3 Use the eyedropper tool ( ) to apply the color from the bicycle photo in the left 

column to the raised cap. The basic steps to achieve this effect are: (A.) Use the type tool 

to select the raised cap. (B.) Click the eyedropper tool. (C.) Click the bicycle photo. You 

may also want to experiment with using the eyedropper tool to apply text formatting to 

other text.

Use the eyedropper tool to apply an image’s color to text.
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4 Use the context menu to add a copyright symbol to the end of the company name 

“Sonata Cycles” in the first paragraph on page 2.

5 Apply Optical Margin Alignment to each paragraph in the main story (everything 

except the pull quotes and table). You can access the Optical Margin Alignment feature 

from Story command in the Type menu. Make sure to set the font size correctly.

Review questions
1 How do you view a baseline grid?

2 When and where do you use a flush space?

3 How do you apply a gradient to only a few words or characters in a paragraph?

4 What is the difference between the multi-line composer and the single-line composer?

Review answers
1 To view a baseline grid, choose View > Show Baseline Grid. The current document 

view must be at or above the View Threshold set in the Baseline Grid preferences. By 

default, that value is 75%.

2 You use a flush space on justified text. For example, if used with a special character or 

decorative font at the end of a paragraph, it absorbs any extra space in the last line.

3 To apply a gradient to a specific range of characters, you first select the text with the 

type tool. Next, you apply the gradient to the text. If the entire range of colors does not 

appear, select the gradient tool and drag from one end of the selected text to the other in 

the direction you want the gradient to flow.

4 The multi-line composer evaluates multiple lines at once when determining the best 

possible line break. The single-line composer looks at only one line at a time when deter-

mining a line break.
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Importing and Linking 
Graphics

 

You can easily enhance your document 

with photographs and artwork created 

in Adobe Photoshop, Adobe Illustrator, 

or other graphics programs. InDesign

can tell you when a newer version of a 

graphic is available, and you can update 

or replace any graphic at any time.
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In this lesson, you’ll learn how to do the following:

 

•

 

Distinguish between vector and bitmap graphics

 

•

 

Place Adobe Photoshop and Adobe Illustrator graphics into an Adobe InDesign layout

 

•

 

Import clipping paths with graphics, and create clipping paths using InDesign and 

Photoshop

 

•

 

Place Adobe PDF files

 

•

 

Manage placed files using the Links palette

 

•

 

Use and create libraries for objects

 

Getting started

 

In this lesson, you’ll assemble a booklet for a compact disc by importing and managing 

graphics from Adobe Photoshop and Adobe Illustrator. After printing and trimming, the 

insert will be folded so that it fits into a CD box. Before you begin, you’ll need to restore 

the default preferences for Adobe InDesign. You’ll also make sure your color management 

settings are consistent for InDesign and Photoshop, so that the colors you use appear 

consistently across both programs.

 

Note:

 

 In the topic “Creating clipping paths from Photoshop paths and alpha channels” on 

page 245, some steps require a full version of Adobe Photoshop 4.0 or later, and enough RAM 

to run both InDesign and Photoshop at the same time. It’s possible to complete the lesson 

without Photoshop by skipping the steps specified in that topic.

 

1

 

To ensure that the tools and palettes function exactly as described in this lesson, delete 

or deactivate (by renaming) the InDesign Defaults file and the InDesign SavedData file. 

See “Restoring default preferences” on page 2. 

 

2

 

To set up the InDesign color management settings, see Chapter 11, “Ensuring 

Consistent Color.”

 

3

 

To make sure Photoshop’s color management settings match InDesign, see 

“Embedding a profile in a Photoshop TIFF image” on page 371.

 

4

 

Start Adobe InDesign.
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Choose File > Open, and open the 07_a.indd file in the ID_07 folder, located inside the 

Lessons folder within the IDCIB folder on your hard disk. A message box appears, saying 

that the publication contains missing or modified links. Click OK; you will fix this later 

in the lesson when you learn how to resolve links to imported graphics which are missing 

or modified. If an alert message appears that asks which dictionary file you want to use, 

click No (Windows) or Document (Mac OS).

 

6

 

Move the Links palette out of the way so it doesn’t obscure your view of the document.

 

7

 

If you want to see what the finished document will look like, open the 07_b.indd file in 

the same folder. If you prefer, you can leave the document open as you work to act as a 

guide. When you’re ready to resume working on the lesson document, choose its name 

from the Window menu.

For a color version of the finished document, see the color section.
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8

 

Choose File > Save As, rename the file 

 

07_cdbook.indd

 

, and save it in the ID_07 folder.

 

Note:

 

 As you work through the lesson, feel free to move palettes around or change the magni-

fication to a level that works best for you. For more information, see “Changing the magnifi-

cation of your document” on page 50 and “Using the Navigator palette” on page 57.

 

Adding graphics from other programs

 

InDesign supports many common graphics file formats. While this allows you to use 

graphics created using a wide range of graphics programs, InDesign works most smoothly 

with other Adobe professional graphics programs such as Photoshop and Illustrator.

By default, imported graphics larger than 48K on disk are 

 

linked,

 

 which means that 

InDesign displays a graphics file on your layout without actually copying the entire 

graphics file into the InDesign document. This saves disk space, especially if you reuse the 

same graphic in many InDesign documents. All linked graphics and text files are listed in 

the Links palette, which provides buttons and commands for managing links. When you 

create final output using PostScript

 

®

 

 or PDF, InDesign uses the links to produce the 

highest level of quality available from the original, externally stored versions of placed 

graphics.

 

Comparing vector and bitmap graphics

 

Adobe InDesign and Adobe Illustrator create 

 

vector graphics,

 

 also called draw graphics, 

which are made up of shapes based on mathematical expressions. Vector graphics consist 

of smooth lines that retain their clarity when scaled. They are appropriate for 

illustrations, type, and graphics such as logos that are typically scaled to different sizes. 

 

CIB.book  Page 234  Monday, May 1, 2000  11:21 PM



 

235

 

ADOBE INDESIGN 1.5

 

Classroom in a Book

 

Bitmap images

 

 are based on a grid of pixels and are created by image-editing applications 

such as Adobe Photoshop. In working with bitmap images, you edit individual pixels 

rather than objects or shapes. Because bitmap graphics can represent subtle gradations of 

shade and color, they are appropriate for continuous-tone images such as photographs or 

artwork created in painting programs. A disadvantage of bitmap graphics is that they lose 

definition and appear “jagged” when enlarged. 

 

Logo drawn as vector art (left), and rasterized as bitmap art (right)

 

In general, use vector drawing tools to create art or type with clean lines that look good 

at any size. You can create vector artwork using InDesign’s drawing tools, or you might 

prefer to take advantage of the wider range of vector drawing tools available in Illustrator. 

You can use Photoshop to create bitmap images that have the soft lines of painted or 

photographic art and for applying special effects to line art.

 

Managing links to imported files

 

When you opened the document, you saw an alert message about problems with linked 

files. You’ll resolve those issues using the Links palette, which provides complete infor-

mation about the status of any linked text or graphics file in your document.

 

Identifying imported images

 

You’ll use the Links palette to identify some of the images that have already been imported 

into the document. Later in this lesson, you’ll use the Links palette to edit and update 

imported graphics.

 

1

 

If necessary, zoom or scroll the document window so that you can see both of the 

document’s spreads.

 

2

 

If the Links palette is not visible, choose File > Links.

ricky records ricky records
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Using the selection tool, select the Orchard of Kings logotype on page 4, the far right 

page of the first spread. Notice that the graphic’s filename, 07_i.ai, becomes selected in the 

Links palette when you select it on the layout.

 

A.

 

 Link

 

B.

 

 Page containing linked graphic

 

C.

 

 Modified-link icon

 

D.

 

 Relink button

 

E.

 

 Go To Link button

 

F.

 

 Update Link button

 

G.

 

 Edit Original button

 

4

 

Using the selection tool, select the large hand graphic that spans all pages of the second 

spread. In the Links palette, this graphic’s filename, 07_j.psd, becomes selected.

Now you’ll use the Links palette to locate a graphic on the layout.

 

5

 

In the Links palette, select 07_h.psd, and then click the Go To Link button ( ). The 

graphic becomes selected and centered on the screen. This is a quick way to find a graphic 

with a known filename.

 

6

 

If the Links palette is still in the center of the document window, you may want to move 

it so that it doesn’t block your view of the page as you work through the rest of the lesson. 

The Links palette opens automatically whenever you open an InDesign document that 

contains missing or modified links.

These techniques for identifying and locating linked graphics are useful throughout this 

lesson and whenever you work with a large number of imported files. Later in this lesson, 

you’ll also use the Links palette to inspect, modify, and update linked graphics.

 

Viewing information about linked files

 

You can use the Links palette to manage placed graphics or text files in many other ways, 

such as updating or replacing text or graphics. All of the techniques you learn in this 

lesson about managing linked files apply equally to graphics files and text files you place 

into your document.

A

D E F G

C

B
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If the Links palette is not visible, choose File > Links to display it. Drag the lower right 

corner of the Links palette to enlarge the Links palette so that you can see as many 

filenames as possible.

 

2

 

Double-click the link 07_g.psd. The Link Information dialog box appears, describing 

the file that the link refers to.

 

3

 

Click Next to view information about the next file. You can quickly examine all of the 

document’s links this way. One or more links may display an alert icon; they indicate a 

linking problem that you’ll address in the next topic. After you’ve examined some link 

information, click Done.

By default, files are sorted in the Links palette so that files that are not up to date are listed 

first. You can use commands in the Links palette menu to sort the file list in different ways.

 

4

 

In the Links palette, choose Sort by Page from the Links palette menu. This lists files on 

the first page at the top of the Links palette, and files on other pages are listed accordingly.

 

Updating a graphic with a newer version

 

As you use other programs to update text and graphics placed in your document, the 

Links palette indicates which files have been modified outside of InDesign, and gives you 

the choice of updating your document to represent the latest versions of those files.

In the Links palette, the file 07_i.ai has an icon ( ) that marks it as out of date. This is the 

file that caused the alert message when you opened this document. You’ll update its link 

so that the InDesign document uses the current version.
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In the Links palette, select the file 07_i.ai, and click the Go To Link button ( ). You 

don’t have to do this step to update a link, but it’s a quick way to double-check which 

imported file you are about to update.

 

Viewing link status in the Links palette

 

A linked graphic can appear in the Links palette in any of the following ways:

 

•

 

An up-to-date graphic displays only the graphic’s filename and its page in the document.

 

•

 

A modified graphic displays a yellow triangle with an exclamation point ( ). This icon means that the 

version of the graphic on disk is more recent than the version in your document. For example, this icon will 

appear if you import a Photoshop graphic into InDesign, and then another artist edits and saves the original 

graphic using Photoshop.

 

•

 

A missing graphic displays a red hexagon with a question mark ( ). This icon means that the graphic isn’t 

at the location from which it was originally imported, though the graphic may still exist somewhere. This can 

happen if someone moves an original file to a different folder or server after it’s been imported into an InDe-

sign document. You can’t know whether a missing graphic is up to date until its original is located. If you 

print or export a document when this icon is displayed, the graphic may not print or export at full resolution.

 

–From the 

 

Adobe InDesign User Guide

 

, chapter 7
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Click the Update Link button ( ). The appearance of the image in the document 

changes to represent its newer version. However, the new image is larger than the previous 

image, causing the new image to be cropped by the previous image’s frame.

 

3

 

Using the selection tool ( ), click the “Orchard of Kings” image to select it, and then 

choose Object > Fitting > Fit Frame to Content.

You’ll replace the large, wide image of the hand that spans the second spread (pages 5–7) 

with a modified image. You can use the Relink button to reassign the link to that graphic.

 

4

 

Go to pages 5–7 (the second spread) and choose View > Fit Spread in Window.

 

5

 

Select the 07_j.psd image on pages 5–7. The filename of the image becomes selected in 

the Links palette.

 

6

 

Click the Relink button ( ) in the Links palette.
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Click Browse, locate the file 07_h.psd in the ID_07 folder, and then click Open 

(Windows) or Choose (Mac OS). The old image is replaced by the one you just selected, 

and the Links palette is updated accordingly.

 

8

 

Save the file.

 

All of the buttons at the bottom of the Links palette are also available as commands on the 

Links palette menu.

 

Placing a Photoshop file

 

Now that you’ve resolved all of the file’s links, you’re ready to start adding more graphics. 

You’ll place a Photoshop file in the InDesign document. InDesign imports Photoshop 

files directly; there is no need to save them in other file formats.

 

1

 

Go to page 7. If necessary, zoom or scroll the document window so that you can see the 

entire page. In the Layers palette, click the Photos layer to target it.

 

2

 

Make sure no objects are selected.

 

3

 

Choose File > Place, and double-click the file 07_c.psd in the ID_07 folder.

 

4

 

Position the loaded graphics icon to the left and slightly below the top edge of the green 

square, and click.
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Don’t be concerned about the white rectangular background behind the image. You’ll 

remove it in the next section of this lesson. Now you’ll zoom in using a high magnification 

so that you can learn about options for display quality.

 

5

 

Click the Navigator palette tab (or choose Window > Navigator) to make the palette 

visible. Use the palette to zoom to 400%, keeping the image you placed in the center of 

the view.

As you place the image, InDesign automatically creates a proxy (low-resolution) version 

of it. This and any other images in this document are currently displaying their low-

resolution proxies, which is why the image appears to have jagged edges. You’ll control the 

degree of detail InDesign displays for placed graphics. Reducing the on-screen quality of 

placed graphics displays pages faster, and doesn’t affect the quality of final output.

 

6

 

Choose Edit > Preferences > General. For Display, choose Full Resolution, and then 

click OK.

 

On-screen display using proxy images (left) and Full Resolution (right)

 

Now InDesign displays images using all available detail. Images now look their best, but 

they will also take longer to appear. InDesign lets you set display resolution for individual 

images, so you’ll balance display speed and quality by displaying the document at proxy 

resolution and the pear image at full resolution.

 

7

 

Choose Edit > Preferences > General. For Display, choose Proxy, and click OK. Now all 

images appear at proxy resolution.

 

8

 

Zoom out until you can see all three pears.

 

9

 

Right-click (Windows) or Control-click (Mac OS) the pear image, and then choose 

Display > Full Resolution from the context menu that appears. The pear image appears 

at full resolution without affecting the rest of the document.

 

10

 

Choose File > Save.
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Working with clipping paths

 

The image you just placed has a solid rectangular background that is blocking your view 

of the area behind it. You can hide unwanted parts of an image using a 

 

clipping path

 

—a 

drawn vector outline that acts as a mask. InDesign can create clipping paths from many 

kinds of images:

 

•

 

If you drew a path in Photoshop and saved it with the image, InDesign can create a 

clipping path from it.

 

•

 

If you painted an 

 

alpha channel

 

 in Photoshop and saved it with the image, InDesign can 

create a clipping path from it. An alpha channel carries transparent and opaque areas, and 

is commonly created with images used for photo or video compositing.

 

•

 

If the image has a light or white background, InDesign can automatically detect its 

edges and create a clipping path.

The pear image you placed doesn’t have a clipping path or an alpha channel, but it does 

have a solid white background that InDesign can remove.

 

Removing a white background using InDesign

 

You can use the Detect Edges option of the Clipping Path command to remove a solid 

white background from an image. The Detect Edges option hides areas of an image by 

changing the shape of the frame containing the image, adding anchor points as necessary. 

For more information about frames and anchor points, see “About paths and frames” on 

page 107.

 

1

 

Using the selection tool ( ), select the pear image 07_c.psd by clicking the image, then 

switch to the direct-selection tool ( ) to activate the image’s default rectangular frame. 

You’ll know that the image’s frame is selected when you see four anchor points and a 

center point. (Six solid handles with no dot inside each handle means that the image is 

selected, and six solid handles with a dot inside each handle means that the image’s 

bounding box is active. The dots indicate that a selected frame includes contents.)

Activating the image’s frame with the direct-selection tool makes the frame’s anchor 

points visible during this procedure, so that you can see exactly how InDesign changes the 

frame into a clipping path. The procedure will still work if you select the image or its 

bounding box instead of its frame, but you won’t get as much visual feedback.
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Choose Object > Clipping Path. If necessary, drag the Clipping Path dialog box so you 

can see the pear image.

 

3

 

Choose Detect Edges from the Type menu.

 

4

 

Make sure Preview is selected, and then for Threshold, drag the slider to hide as much 

of the white background as possible without hiding parts of the subject (darker areas). We 

used a Threshold value of 

 

15

 

.

 

Note:

 

 If you can’t find a setting that removes all of the background without affecting the 

subject, specify a value that leaves the entire subject visible along with small bits of the white 

background. You’ll eliminate the remaining white background by fine-tuning the clipping 

path in the following steps.

 

The Threshold option works by hiding light areas of the image, starting with white. As 

you drag to the right, increasingly darker tones are included within the range of tones that 

becomes hidden.

 

5

 

For Tolerance, drag the slider to the left until the Tolerance value is 

 

1

 

.
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The Tolerance option determines how many points define the frame that’s automatically 

generated. As you drag to the right, InDesign uses fewer points so that the clipping path 

fits the image more loosely (higher tolerance). Using fewer points on the path may speed 

up document printing, but may be less accurate.

 

6

 

For Inset Frame, specify a value that closes up any remaining background areas, and click 

OK. We specified a value of 0p1 (zero picas, one point). This option shrinks the current 

shape of the clipping path uniformly, and is not affected by the lightness values in the image.

 

Before and after applying an inset of 1 point

 

For a color version of clipping path options, see figure 7-1 in the color section.

Now that you’ve completed the clipping path for this image, it’s a good time to speed up 

screen redraw by switching the display of the pear image back to the document default, 

which is currently set to proxy (low) resolution.

 

 You can use the direct-selection tool ( ) or the pen tools to refine the clipping path.
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Right-click (Windows) or Control-click (Mac OS) the pear image, and then choose 

Display > Set to Default from the context menu that appears. The pear image is now set 

at proxy resolution without affecting the rest of the document.

 

8

 

Save the file.

 

 You can also use the Detect Edges feature to remove a solid black background. Just select 

the Invert option and specify a high threshold value.

 

Creating clipping paths from Photoshop paths and alpha channels

 

When an image has a background that isn’t solid white or black, the Detect Edges feature 

may not be able to remove the background effectively. With such images, hiding the 

background’s lightness values may also hide parts of the subject that use the same 

lightness values. Instead, you can use the advanced background removal tools in 

Photoshop to mark transparent areas using paths or alpha channels, and let InDesign 

make a clipping path from those areas.

You imported the previous image using the Place command. This time you’ll simply drag 

a Photoshop image directly onto an InDesign spread. InDesign can use Photoshop paths 

and alpha channels directly—you don’t need to save the Photoshop file in a different file 

format.

 

1

 

In Explorer (Windows) or the Finder (Mac OS), open the ID_07 folder so that the file 

07_d.psd is visible. Arrange the InDesign document window and the ID_07 folder 

window so that you can see both of them side by side.

 

2

 

In InDesign, make sure you can see the lower left quarter of page 2 in the document 

window.
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Drag the file 07_d.psd to the lower left corner of page 2 in the InDesign document. Be 

careful to drop it outside the colored squares. (If you drop it on a square, it will be placed 

inside the square.) If necessary, use the selection tool ( ) to reposition the graphic within 

the page boundaries.

In this image, the hand and the background share many of the same lightness values. 

Therefore, the background can’t easily be isolated using the Detect Edges option in the 

Clipping Path command. Instead, you’ll set up InDesign to use a path or alpha channel 

from Photoshop. First you’ll use the Links palette to open the image directly in Photoshop 

to see what paths or alpha channels it already includes.

 

4

 

If necessary, use the selection tool to select the 07_d.psd image in InDesign.

 

5

 

If you want, maximize the InDesign window now that you’ve finished importing the file.

 

Note:

 

 The next few steps require a full version of Photoshop 4.0 or later and enough available 

RAM to run both InDesign and Photoshop at the same time. If your configuration doesn’t 

meet both of these requirements, simply read steps 6 through 11, and then resume working 

with the source files at step 12.
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With the image still selected, choose File > Links. The image’s filename is selected 

automatically in the Links palette.

In the Links palette, click the Edit Original button ( ). This opens the image in a 

program that can view or edit it. This image was saved from Photoshop, so if Photoshop 

is installed on your computer, InDesign starts Photoshop with the selected file.

Sometimes the Edit Original button opens an image in a program other than Photoshop 

or the program that created it. The Edit Original button uses your operating system’s 

settings for associating files with programs. You can change those settings; see the 

documentation for your operating system. Also, some installer utilities change those 

settings.
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Note: A CMS Profile Mismatch dialog box may appear as the image opens in Photoshop. If 

you’ve properly configured all Photoshop and InDesign color management settings for your 

workflow using accurate ICC profiles, click Convert to reproduce the image properly in 

Photoshop. If you are not using color management, you may click Don’t Convert.

Photoshop file saved with 3 alpha channels

 The Edit Original button also exists as a command on the context menu that appears 

when you right-click (Windows) or Control-click (Mac OS) an image selected with the direct-

selection tool ( ). If the image was selected with the selection tool, the Edit Original 

command appears on the Graphic submenu on the context menu.

7 In Photoshop, choose Window > Show Channels to display the Channels palette, or 

click the Channels palette tab.

The Channels palette contains three alpha channels in addition to the standard RGB 

channels. These channels were drawn using the masking and painting tools in Photoshop. 
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8 In the Channels palette in Photoshop, click Alpha 1 to see how it looks, then click Alpha 

2 and Alpha 3 to compare them.

 If you need only one alpha channel, you don’t have to create a new one. Simply use 

Photoshop tools to make areas of an image transparent (marked by a checkerboard 

background in Photoshop); InDesign will recognize all transparent areas as an alpha channel. 

You can erase to the background using Photoshop tools such as the Background Eraser and 

the Magic Eraser.

9 In Photoshop, choose Window > Show Paths to open the Paths palette, or click the 

Paths palette tab.

The Paths palette contains two named paths, Shapes and Circle. These were drawn using 

the pen tool and other path tools in Photoshop, although they could also be drawn in 

Illustrator and pasted into Photoshop.

10 In the Photoshop Paths palette, click Shapes to view that path. Then click Circle.

Now you’ll return to InDesign and see how you can create different clipping paths from 

the Photoshop paths and alpha channels.

11 Switch to InDesign. Make sure the 07_d.psd Photoshop file is still selected on the 

page; if necessary, select it using the selection tool ( ).
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12 Right-click (Windows) or Control-click (Mac OS) the hand image, and choose 

Display > Full Resolution from the context menu that appears. This step isn’t necessary, 

but it lets you precisely preview the following steps.

13 With the hand image still selected, choose Object > Clipping Path, and make sure 

Preview is selected.

14 Choose Alpha Channel from the Type menu, and then choose 1 from the Alpha menu. 

InDesign creates a clipping path from the alpha channel.

 The clipping path you see represents the default settings for defining an alpha channel’s 

edges. You can fine-tune the clipping path that InDesign creates from an alpha channel by 

adjusting the Threshold and Tolerance options, as you did for the Detect Edges feature earlier 

in this lesson. For alpha channels, start with a low Threshold value such as 1.

15 Choose 2 from the Alpha menu to see the clipping path it would create.

16 Choose 3 from the Alpha menu, and select the Include Inside Edges option.

Selecting the Include Inside Edges option makes InDesign recognize a butterfly-shaped 

hole painted into alpha channel 3, and adds it to the clipping path.

 You can see how the butterfly-shaped hole looks in Photoshop by viewing alpha channel 

3 in the original Photoshop file, as you did in step 8.

17 Choose Photoshop Path from the Type menu, and then choose Shapes from the Path 

menu. InDesign reshapes the image’s frame to match the Photoshop path. 

18 Choose Circle from the Path menu, and then click OK. This is the path that was created 

for this instance of the image.

Since you’re done working with this graphic, you can reset its display resolution to the 

document default.
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19 Right-click (Windows) or Control-click (Mac OS) the hand image, and choose 

Display > Set to Default from the context menu that appears.

20 Save the file.

Importing an Illustrator file
InDesign takes full advantage of the smooth lines provided by EPS vector graphics such 

as those from Adobe Illustrator. When you turn on full-resolution screen display in 

InDesign, EPS vector graphics and type are displayed smoothly at any size or magnifi-

cation. Most EPS vector graphics don’t require a clipping path because most programs 

save them with transparent backgrounds. You’ll drag an Illustrator graphic from a 

folder to the InDesign document.

1 Make sure that the ID_07 folder and the InDesign document window are both visible 

simultaneously. In InDesign, zoom or scroll if necessary so that pages 5 and 6 are both 

visible.

2 In the Layers palette, target the Graphics layer.

Comparing Photoshop paths and alpha channels
If both Photoshop paths and alpha channels can be made into clipping paths, what’s the difference between 

them? A Photoshop path is a drawn vector object with a hard edge, while an alpha channel is a painted bit-

map that can contain up to 256 levels of transparency. Photoshop paths are commonly used to mark trans-

parent areas for printed publications, and alpha channels are commonly used to mark transparent areas 

when compositing photos, videos, and motion pictures. Because graphics are increasingly being reused across 

media, InDesign gives you the flexibility to create clipping paths from either paths or alpha channels. In addi-

tion, the ability to choose from among multiple paths and alpha channels lets you use a single graphic in dif-

ferent ways, or to reveal different parts of the same graphic.
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3 Drag the Illustrator file 07_e.ai to the InDesign document. Position it as shown below.

4 If you want, resize the InDesign window now that you’ve finished importing the file.

Now you’ll see how InDesign’s high-resolution display affects EPS vector graphics.

5 Display the Navigator palette. With the Illustrator graphic selected, type 1000 in the 

magnification text box, and press Enter or Return.

6 If necessary, drag the view box in the Navigator palette so that you can see more detail 

in the Illustrator graphic.

The graphic appears jagged because of two things: You are viewing the EPS file at 1000% 

magnification, and earlier in the lesson you chose the Proxy Images (low-resolution) option 

for graphics display. You’ll switch to high-resolution display and observe the difference.

7 Right-click (Windows) or Control-click (Mac OS) the ivy graphic, and choose Display 

> Full Resolution from the context menu that appears.

On-screen image resolution before and after changing display 
resolution setting
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At the Full Resolution setting, you can see the Illustrator graphic at the highest possible 

level of detail and accuracy. At this setting you can often precisely position and align Illus-

trator and EPS graphics by sight alone, particularly when you zoom in. You’ll switch back 

to proxy images to speed up image display for the rest of the lesson.

8 Right-click (Windows) or Control-click (Mac OS) the ivy graphic, and then choose 

Display > Set to Default from the context menu that appears.

9 Save the file.

Placing a PDF file
You can include Portable Document Format (PDF) files in your InDesign layout. PDF is 

a popular format for exchanging graphics such as advertisements, because it preserves 

professional-quality color, vector graphics, bitmap images, and text among a wide range 

of programs and computing platforms. You can use PDF to publish the same document 

on paper and on the Internet while maintaining quality for both media. You’ll import a 

PDF file that contains a company logo created and saved directly from Adobe Illustrator.

1 Go to page 3, and make sure that all of page 3 is visible. In the Layers palette, make sure 

the Graphics layer is targeted.

Now you’ll use a keyboard shortcut to open the Place dialog box.

2 Press Ctrl+D (Windows) or Command+D (Mac OS). Select Show Import Options, 

and in the ID_07 folder, locate and double-click the file 07_f.pdf.
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The import options for PDF files let you customize how a PDF file is placed into your 

document. For example, this PDF file contains only one page, but when you place a 

multiple-page PDF file, you can choose which page to place.

3 Make sure Bounding Box is selected in the Crop To menu. This sets the size of the 

placed PDF file to the smallest rectangle that encloses all of the objects in the file. For 

example, in this case the logo is much smaller than the page size, so it makes sense for the 

imported file to be the size of the logo, not the page. Leave the other settings as they are.

4 Click OK, and then click the loaded graphics icon above the address on page 3.

5 Save the file.

Using a library to manage objects
Object libraries let you store and organize graphics, text, and pages you frequently use. 

You can also add ruler guides, grids, drawn shapes, and grouped images to a library. Each 

library appears as a separate palette which you can group with other palettes any way you 

like. You can create as many libraries as you need—for example, different libraries for 

each of your projects or clients. You’ll import a graphic currently stored in a library, and 

then you’ll create your own library.
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1 Choose Window > Libraries > Open, select the file 07_k.indl in the ID_07 folder, and 

then click Open. Drag the lower right corner of the palette to reveal more of the items in it.

2 In the 07_k.indl library palette, click the Show Library Subset button ( ). In the last 

box for the Parameters option, type Tree, and click OK.

3 Type 5 into the page navigation box at the bottom of the InDesign document window 

to go to that page, and then press Enter or Return.

4 Make sure that the Links palette is visible. In the Layers palette, make sure the Graphics 

layer is targeted.

5 Out of the 2 objects visible in the 07_k.indl library palette, drag Tree.tif to page 5. The 

file is added to the page, and the filename appears in the Links palette.
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6 Using the selection tool, position the Tree.tif image as shown below.

7 With the Tree.tif image selected, choose Object > Arrange > Send Backward.

Creating a library

Now you’ll create your own library.

1 Choose Window > Libraries > New. Type CD Projects as the library filename, navigate 

to the ID_07 folder, and click Save. The library appears in its own floating palette, labeled 

with the filename you specified.

2 Go to page 3 and, using the selection tool, drag the ricky records logo to the library you 

just created. The logo is now saved in the library for use in other InDesign documents.

3 In the CD Projects library, double-click the ricky records logo. For Item Name, type 

Logo, and then click OK.

4 Using the selection tool, drag the address text block to the library you created. It 

appears in the CD Projects library palette.
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5 In the CD Projects library, double-click the address text block. For Item Name, type 

Address, and then click OK. Now your library contains both text and graphics. As soon 

as you make changes to the library, InDesign saves the changes.

6 Save the file.

Congratulations! You’ve created a CD booklet by importing, updating, and managing 

graphics from many different graphics file formats.

On your own
Now that you’ve had some practice working with imported graphics, here are some 

exercises to try on your own.

1 Place different file formats with the Show Import Options turned on in the Place dialog 

box, and see what options appear for each format. For a full description of all the options 

available for each format, see Chapter 7, “Importing, Exporting, and Managing Graphics” 

in the InDesign User Guide.

2 Place a multiple-page PDF file with Show Import Options turned on, and import 

different pages from it.

3 Create libraries of text and graphics for your work.

Review questions
1 How can you determine the filename of an imported graphic in your document?

2 What are the three options in the Clipping Path command, and what must an 

imported graphic contain for each option to work?

3 What is the difference between updating a file’s link and replacing the file?

4 When an updated version of a graphic becomes available, how do you make sure it’s up 

to date in your InDesign document?
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Review answers
1 Select the graphic and then choose File > Links to see if the graphic’s filename is 

highlighted in the Links palette. The graphic will appear in the Links palette if it takes up 

more than 48KB on disk and was placed or dragged in from the desktop.

2 The Clipping Path command in InDesign can create a clipping path from an imported 

graphic by using:

• The Detect Edges option, when a graphic contains a solid white or solid black 

background.

• The Photoshop Path option, when a Photoshop file contains one or more paths.

• The Alpha Channel option, when a graphic contains one or more alpha channels.

3 Updating a file’s link simply uses the Links palette to update the on-screen represen-

tation of a graphic so that it represents the most recent version of the original. Replacing 

a selected graphic uses the Place command to insert another graphic in place of the 

selected graphic. If you want to change any of a placed graphic’s import options, you must 

replace the graphic.

4 Check the Links palette and make sure that no alert icon is displayed for the file. If an 

alert icon appears, you can simply select the link and click the Update Link button as long 

as the file has not been moved. If the file has been moved you can locate it again using the 

Relink button.
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