
Lesson 7

Special Effects for Film
In this lesson, you’ll create a short scene 

for a motion picture, working with high-

resolution images, blue screen keying, 

and motion tracking.
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The movie you create in this project depicts a short scene from a fictitious motion picture, 

requiring a number of visual effects. 

In this lesson you’ll explore compositing at film resolution, keying out a blue screen, and 

tracking motion to generate keyframes.

This lesson covers the following topics:

• Organizing a project

• Working with film-resolution images
• Creating and using proxies

• Using the Timecode effect

• Setting custom resolution

• Using the Cineon Converter effect

• Using the Production Bundle Glow effect 

• Using the Production Bundle Corner Pin effect 

• Creating a track matte 

• Using the Color Key 

• Using the Production Bundle Color Difference key and Motion Tracker Keyframe 

Assistant

At the end of this lesson you will have created an 8-second scene to be used in a motion 

picture.

It should take approximately 3 to 4 hours to complete this project.
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Viewing the final project
Before you begin, take a look at the finished movie that you’ll create in this lesson.

1 Double-click the 07Final.mov file in the 07Lesson folder to open the final QuickTime 

movie, and then click the Play button.
This scene with special effects consists of an actor who was filmed against a blue screen 

background and then composited over an old-fashioned still image of a feed store. An 

animated compact disc appears out of the sky and hovers over him. A glowing light also 

follows the motion of the actor’s hand.

2 When finished, quit the MoviePlayer application.

Before you begin
This lesson uses several plug-ins from the Production Bundle version of After Effects. 

Before you start, make sure that you have installed the Glow and Corner Pin plug-ins 

according to the instructions in “Installing Production Bundle plug-ins” on page 4. 

This lesson also uses two features that are available only in the Production Bundle version 

of After Effects, and that have not been included on the After Effects Classroom in a Book 

CD. These are the Color Difference Keying Effect and the Motion Tracker Keyframe 

Assistant. If you do not have access to the Production Bundle version of After Effects, 

follow the alternative steps that are provided. 
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Size and memory considerations
If you plan to copy project files from the CD-ROM to your hard disk, you’ll need at least 

450 MB of available space. First try the lesson without copying the files; if After Effects 

seems too slow, copy the files to the hard disk.

On Windows systems, you should have at least 64 MB of RAM installed. On Mac OS 

systems, you should assign at least 20 MB of RAM to After Effects. 

The final goal of this project is to create a full-screen image for film. The original footage 
and final output size of this project is 2048 x 1536, usually referred to as 2K. Part of the 

purpose of this project is to allow you to judge what your machine resources need to be 

to work with this kind of material, but you can work on almost any machine at a lower 

output resolution.

Several strategies are provided to help conserve memory and increase editing speed.

Getting started
1 To ensure that the tools and palettes function exactly as described in this lesson, delete 

or deactivate (by renaming) the After Effects preferences file. See “Restoring default 

preferences” on page 6. 

2 Start After Effects.

Using a process flow
Before you start the project, you will open the completed project and examine some 

process flow issues.

1 Choose File > Open, and select the 07Proj.aep file in the 07Lesson folder. 

2 Click OK if a dialog box prompts you that the file has been changed. 
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The Project window contains six numbered compositions as well as a folder containing 

QuickTime movies and still images.
In this project, compositions are numbered according to a process flow from 1, which is 

a Cineon file conversion composition, to 6, which is the final rendered movie.

Now you’ll close the finished project and start constructing your own special effects for 

film. Instead of creating a new project, you open a project that has already been started.

3 Choose File > Open. You may need to click the Don’t Save button to close the 07project 

file without saving changes. Select 07begin.aep in the 07Lesson folder, and click Open.

This project contains a Timing Script composition that has been set up for you and that 

you will use later in the lesson.

4 Choose File > Save As, name the file 07Work.aep, and save it into your Projects folder.

Setting preferences
Before you get started, set a few preferences that will come in handy during the lesson.

1 Choose File > Preferences > Time, set the Display Style to Frames, and enter 1 for “Start 

Numbering Frames At.” Do not click OK just yet.

All the time rulers will display in frame numbers instead of SMTPE timecode, and the first 

frame in the composition is numbered 0001 instead of 0000.

2 In the Preferences menu, choose Display. Select Disable thumbnails in project window.



LESSON 7302
Special Effects for Film

If you select this option, After Effects doesn’t generate thumbnail previews in the Project 

window, so you’ll save time on screen redraw if you are working with high-resolution files. 

3 Select Auto-Zoom When Resolution Changes.

This option will resize the window to match the resolution. For example, when you 

choose Quarter Resolution, the Magnification changes to 25%. 

4 Select Synchronize Time of All Related Items.
Since you will be creating a lot of different compositions, this option helps to synchronize 

the current-time marker in all related open compositions.

5 Click OK to close the Display Preferences dialog box.

Using the Timecode effect
In this section, you will examine the 1_Timing_Script composition, and then see how the 

Timecode effect is used to help analyze timing cues. 

This composition is a record of how the film scene was originally conceived. There is a 

solid for each event in the sequence, numbered for the starting frame, and named for the 

event. There is also a marker for each layer, with further explanations. In addition, a 

composition-time marker (1–7) has been set at each event start point as a navigation aid. 

Because these layers are intended only for designing the project and contain no footage, 

the video for each of these layers is turned off. 

To set up 1_Timing_Script, we used the Timing.mov file with timecode going through the 

movie frame by frame and setting composition-time markers at important parts of the 

scene. 
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1 On your keyboard, press the 1 key from the number keys (above the letter keys) to go 

to the first composition-time marker. 

The first composition-time marker is set at frame 24, where the flying CD first enters. The 

name of the Solid layer includes the frame number and a description of the action at that 

time. 

2 Press the 3 key from the number keys (above the letter keys) to go to the third compo-

sition-time marker. From frame 43 to frame 78, the CD will fly past the actor. 
3 Continue examining the marker frames in the 1_Timing_Script composition. You’ll 

use this composition again when you are creating the motion for the flying CD. 

Now you will step through the process of adding timecode to the timing movie. You will 

superimpose frame numbers on the footage by applying the Timecode effect. The 

Timecode effect displays or encodes timecode or frame number information in the layer 

to which it is applied. 

4 Press the Home key to go to the beginning of the composition. Choose Layer > New 

Solid, type Timecode for the name, set the size to 110 x 35 pixels, leave the color at the 

default gray, and click OK. 

5 Choose Effect > Video > Timecode. The Timecode Effect Controls window appears.

You can choose to display or encode the current timecode of your composition. For this 

composition, you will display the timecode since it will be used only to analyze timing 

cues.

6 Make sure Display Current Timecode is selected in the Mode menu.
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You have the option to display SMPTE timecode (hours:minutes:seconds:frames) or 

frame numbers. 

7 Choose Frame numbers from the Display Format menu.
8 Since the frame rate of this composition is 24 fps, set the Time Units to 24.

9 Set the Starting Frame to 1, and then set the Text size to 28 points.

10 In the Composition window, drag the solid down below the actor’s feet. 

It doesn’t matter where you put the solid as long as it isn’t obscuring the action and you 

can easily read it. 

11 Close the Effect Controls window and save the project. 

12 Preview the composition with RAM Preview by pressing the 0 key on your numeric 

keypad. 

13 Close the Composition and Time Layout windows. 

Now that you have seen how the 1_Timing_Script composition was created, you will 

begin work on the elements for the movie scene. 
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Understanding the Cineon file format
The standard professional picture file format for working in digital film is the Cineon 

format. Originally developed by the Eastman Kodak Company, the Cineon format is 

designed to contain all the picture information present in a frame of motion picture 

negative film, so that the artist has the maximum possible color correction range 

available. High-resolution motion picture scans can be very expensive, so one naturally 

wants to avoid rescanning footage because of wrong color correction choices. With the 

Cineon format, no choices need be made at the scanner, other than basic calibration to 
your film type. 

Unlike most picture file formats, the Cineon format samples the image at 10 bits per 

channel, and encodes the data in a logarithmic scale which looks extremely low-contrast 

and washed out, as opposed to the normal-contrast linear scale images you’re used to 

seeing. 

After Effects 4.0 was designed to work primarily with 8-bpc (bit per channel) images, so 

some slight liberties have been taken with the normal footage importing process to allow 

you to choose (and even animate) the best possible 8-bpc conversion from the 10-bpc 

Cineon original. 

The file-format plug-in presents the Cineon file to After Effects as if it were an 8-bpc 

image with an alpha channel. After placing the footage in a composition, it will look like 

bad television reception because there is a mismatch between the 8-bit and 10-bit channel 

widths. To properly decode the image, you must apply the Cineon Converter effect. 

Once the Cineon Converter effect has been applied, you then have the choice of working 

in log or linear mode. Linear mode is the more familiar mode, but there are some advan-

tages to keeping your Cineon images in log scale all the way through the compositing 

process. The most important benefit is that an end-to-end log scale composite will result 

in a higher-quality film recording, because it will have retained all the extended highlight 

information which is discarded in the conversion to linear. 

The Windows and UNIX® three-letter file type extension for Cineon is .cin. In Mac OS, 

the file Type should be SDPX and the Creator FXTC for automatic recognition by After 

Effects. 
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The After Effects Cineon Converter is designed to make the task of color management in 

log scale compositing as easy and intuitive as possible. 

Note: Only one real Cineon file is included with this lesson so that you can practice importing 

it. Due to the limited amount of space available on the CD-ROM, a high-resolution log scale 

QuickTime movie will stand in for a Cineon sequence in this lesson. 

Creating a proxy for a high-resolution footage file
You will begin by importing high-resolution footage of an actor filmed against a blue 
screen. Next you’ll create and assign a proxy, or lower-resolution copy, of the original 

footage to make working with the project faster and easier. 

1 Choose File > Import > Footage File, and then select ActHiR01.cin from the 07Lesson 

folder. In the Interpret Footage dialog box, select Treat As Straight (Unmatted), and click 

OK. 

2 Next, choose Composition > New Composition, type 2_Proxy for the name, and 

choose Film (2K) from the Frame Size menu for a Frame Size of 2048 x 1536 pixels. 

3 In the Composition window, choose Quarter from the Resolution menu.

Making a full-size composition at Quarter Resolution is far thriftier with RAM than 

making a 512 x 384 composition and shrinking the 2048 x 1536 image within it.

4 Set the Frame Rate to 24 fps—the standard frame rate for movies made in the United 

States. Set the Duration to 192 frames (8 seconds), and then click OK.

The Composition window opens with a Magnification of 25% and Quarter Resolution. 

The composition has the same dimensions and duration as the original footage, but it will 

be displayed and rendered at a fraction of the original dimensions. It’s best with film-

resolution images to make your proxy at about video resolution; 512 x 384 is close 

enough.

5 Drag the ActHiR01.cin footage file from the Project window into the Time Layout 

window.
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6 The image should look like a mosaic. Choose Effect > Cineon Tools > Cineon 

Converter. The image should now look normal. This is a linear conversion. Note that the 

Conversion Type menu in the Effect Controls window is set to Auto Log to Linear by 

default. Experiment with the Black and White Point, Gamma, and Highlight Rolloff 

sliders.
The original footage was shot sideways, but you’ll correct that when you create a compo-

sition. (You want the proxy to be the same orientation as the original footage.) 

If you don’t have much RAM available you might get an out-of-RAM warning. You can 

lower the resolution of the image even more to conserve RAM.

7 To set a custom resolution, choose Custom from the Resolution menu, and then enter 

8 for both horizontal and vertical pixels, and click OK.

This results in a Resolution of one-eighth, and a window size that is close to the 320 x 240 

windows you’ve been working with throughout this book. It may take a moment to 

display the contents of the Composition window.
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8 Since you’ll be building a log scale composition, choose Auto Log to Log from the 

Conversion Type menu and note the slider settings. Note the very flat (low) image 

contrast. Apply a second Cineon Converter effect, leaving it at the default settings. The 

image has now been relinearized and looks correct. Apart from the loss of extended 

highlight information at the first linearization, you can convert between log and linear 

any number of times without harming the image.

9 When finished, delete the ActHiR01.cin layer, since it is only a single frame.

10 Choose File > Import > Footage File, and then select ActHiR.mov from the 07Lesson 
folder and click Open. Drag it from the Project window into the 2_Proxy Time Layout 

window. 

ActHiR.mov is a high-resolution QuickTime movie made from the Cineon sequence 

using the Auto Log to Log Conversion Type. Although it is an 8-bpc file, it still retains all 

the dynamic range of the 10-bpc Cineon file, but with slightly less color precision. Later, 

you’ll correct this by applying a log-to-log conversion with an adjustment layer. The 

movie was compressed using the standard QuickTime Photo-JPEG compressor, which is 

an excellent choice when you need to retain maximum image quality. At up to 10:1 

compression, Photo-JPEG images are still very close to uncompressed quality, but at the 

expense of native playback speed.

11 Save the project.

If you were to render the project, you would use the following settings: Best Quality, 

Quarter Resolution, and a Frame Rate of 24 fps. The proxy for this lesson was rendered 

with the Photo-JPEG compressor at the High quality setting.

After rendering the proxy, you’ll assign it to represent the original footage.

12 Close the 2_Proxy Composition window and Time Layout window.

Setting a Proxy file
Now you’ll assign a proxy to the high-resolution footage.

1 Select the ActHiR.mov footage item in the Project window, and then choose File > Set 

Proxy > File, select ActPrx.mov from the 07Lesson folder, and click Open.
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A small black square (called a proxy indicator) appears to the left of the ActHiR.mov 

footage item in the Project window, indicating that a proxy has been set. The name of the 

proxy appears next to the thumbnail in the Project window. If you need to switch between 

the original footage and its proxy, click the proxy indicator to turn it on or off.
When you use the ActHiR.mov file in a composition, After Effects will use the proxy for 

display. Effects and properties applied to the proxy are applied to the actual footage when 

the movie is rendered with Use No Proxies selected from the Proxy Use menu in the 

Render Settings dialog box. Even though the proxy is 512 x 384, it behaves as if it’s 2048 x 

1536 in the composition.

Preparing the actor footage
Now you are ready to prepare the footage for the actor. You need to rotate and flip the 

layer, and key out the blue screen background.

1 Create a new composition, name it 3_Actor_Prep, and then set the Frame Size to 600 

x 1536 (this frame size serves to crop the layer). 

2 In the Composition window, set the Resolution to Quarter. 

Note: Depending upon the size of your monitor, you may need to set the resolution even lower 

by choosing Custom from the Resolution menu and entering a value, such as 8. 

3 Make sure the Frame Rate is 24 and Duration is 192 frames, and then click OK.

4 Drag the ActHiR.mov footage item from the Project window into the 3_Actor_Prep 

Time Layout window. Even though you are using the ActHiR.mov footage, the proxy is 

actually being displayed.
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Looking at the ActHiR.mov, you’ll notice that the blue screen footage was shot sideways 

to maximize use of the frame for sharpness. This is typical of the kinds of tricks special 

effects supervisors come up with to improve the quality of their work.

5 Select the ActHiR.mov layer in the Time Layout window. Press the S key and then press 

Shift+R to display the Scale and Rotation properties. Click the underlined Rotation value, 

enter 90 for degrees, and click OK.

6 To flip the image, click the underlined Scale value, deselect Preserve Frame Aspect 

Ratio, and then enter –100 for Height, and click OK.
7 Position the image of the actor inside the composition: click the underlined Position 

value and enter a position of 332 for X-axis and 792 for Y-axis. 

Using color keys
The actor footage has been filmed against a blue screen. Because you want to superimpose 

the actor against the feed-store background in the final composition, you will key out the 

blue screen background. 

The most common example of this procedure is your local news show. The weathercaster 

stands in front of a bright-blue screen. The image is picked up by the camera, but before 

it is broadcast, a keying process makes the blue screen transparent, allowing a computer-

generated weather map to show through. 
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In After Effects, you use keying effects to make certain areas of an image transparent. 

Keying effects base the areas of transparency on particular colors, or on the luminance of 

particular colors. In this section you will use keying effects to key out the blue screen 

background. 

Just like all effects in After Effects, all color keys are applied over time and can be 

animated. In this example you will create a key that is constant for the entire duration of 

the footage. If you encountered a situation where the lighting changed or the actor’s 

movement caused shadows that affected the key, you could change your key values just as 
you animate any other property in After Effects.

Because you’ll be working in Cineon log scale color, the color key is set up in a less direct 

way than if you were keying a linear scale image. The key will be applied to a linear version 

of the footage, which is then turned off as the resulting matte is assigned as a track matte 

to a log version of the footage.

Changing the Background Color to check the key
Before you apply a color key, you’ll change the background color. A bright background 

makes it easier to analyze the effectiveness of your key.

1 Choose Composition > Background Color and click the swatch to display the color 

picker.

2 Choose a bright yellow color and click OK. Click OK again to close the Background 

Color dialog box. 

Keying methods
The standard version of After Effects provides two keying effects: the Color Key effect, for 

keying out a color value, and the Luma Key effect, for keying out a luminance, or lightness 

value. The After Effects Production Bundle provides advanced keying effects with more 

powerful keying capabilities. The keys in the Production Bundle differ from the standard 

keys in that you can make some pixels partially transparent so that you can achieve more 

realistic-looking edges. 

For this lesson, two methods are described. If you are using the After Effects Production 

Bundle, skip to “Using the Color Difference key—Production Bundle version users” on 

page 313. If you are using the standard version of After Effects, perform the following 

procedure to use the Color Key effect. Do not use both keying effects on the footage.
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Both methods require you to apply the keying effects to a linear version of the footage 

first, since keyers are designed to work properly on linear images.

Using the Color Key effect—standard version users
1 With the ActHiR.mov layer selected in the Time Layout window, choose Effect > 

Cineon Tools > Cineon Converter, and set the Highlight Rolloff slider to 0.

2 Choose Effect > Keying > Color Key. 

3 To match the existing blue screen color, click the Key Color eyedropper in the Effect 
Controls window, and click anywhere in the blue screen background to sample the color.

4 To increase the range of color that is keyed out, drag the Color Tolerance slider to the 

right. Experiment with the slider to see what happens. 

As you drag the slider to the right, more and more of the actor becomes transparent. Your 

goal is to find the point where most of the background is keyed out but the actor remains 

opaque. Your final setting should be approximately 60. 

5 To fine-tune the mask at the edges of the actor, adjust the Edge Thin values with the 

Edge Thin slider. This adjusts the width of the keyed area’s border. To increase the trans-

parent area and key out some of the blue at the edges of the actor image, set a positive 

value. Negative values spread the matte. Set the Edge Thin value to 1. 
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To get a more accurate look at the key effect, and especially at the edge pixels, you need to 

display the high-resolution image instead of the proxy. 

6 Click the proxy indicator icon for the ActHiR.mov footage item in the Project window 

to replace the proxy with the high-resolution image. 

7 In the Composition window, set the Resolution to Full. 

If you don’t have enough memory to display the high-resolution image, an out-of-

memory warning will appear. If this occurs, try setting the Resolution to Half. 
Press the Caps Lock key to stop screen refresh while you set the Resolution. 

8 To soften the edge of the mask, set the Edge Feather value to 0.5. Higher values create 

softer edges, but take longer to render. 

9 After refining the edge, close the Effect Controls window, click the proxy indicator icon 

in the Project window to turn the proxy back on, and set Resolution back to Quarter in 

the Composition window. 

10 To restore the layer back to log, choose Effect > Cineon Tools > Cineon Converter. If 

a Cineon error message appears, simply click OK. 

11 In the Effect Controls window, make sure you are looking at the second application 

of Cineon Converter, and change the Conversion Type menu to 8 bit Linear to Log and 

leave the sliders at their default values. 

Skip the next section and go to “Setting a track matte to a log scale layer” on page 318. 

Using the Color Difference key—Production Bundle version users
If you are using the Production Bundle version of After Effects, follow these instructions 

to use the Color Difference Key, Matte Choker, and Spill Suppressor effects.
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1 With the ActHiR.mov layer selected in the Time Layout window, choose Effect > 

Cineon Tools > Cineon Converter, and set the Highlight Rolloff slider to 0.

Now you’ll change a setting in the Cineon Converter’s log to linear transform that will 

make the key easier. 

2 Change the 10 bit White Point setting from 685 to 500.
This brightens the image considerably, washing out the actor. Since you’ll be using this 

layer as a track matte, you can do what you want with the RGB portion of the image.

3 Choose Effect > Keying > Color Difference Key. The Effect Controls window appears.

The Color Difference Key works best with footage shot in front of a blue or green screen. 

Generally speaking, because of the way the color is recorded, blue works better for film 

and green for video. In this project the actor was filmed in front of a blue screen, so it 

should be fairly straightforward to key out the background. The Color Difference Key 

gives you the capability to key images that have semitransparent areas. Other keys 

included in the Production Bundle offer additional control for creating high-quality, 

animated mattes in film, broadcast, or interactive projects. 

4 Resize the Effect Controls window so that you can see the previews.
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5 Make sure that the alpha button is selected beneath the preview thumbnail.
The ActHiR.mov layer is transformed into two grayscale components. The Color 

Difference Key generates a matte using a variation of the optical method used in tradi-

tional blue screening.

6 Leave the Key Color set to blue. 

For the Color Difference key, the key color is used as a general guideline rather than a 

strict matching rule, so you don’t need to change the color. The default will work for most 

shades of blue.

7 Click the A button in the Effect Controls window.

View A is a grayscale matte of color values that differ from the key color. All white pixels 

represent color values that are opaque; the black pixels are transparent; and the gray pixels 

are partially transparent. In View A, all colors very different from the key color are white; 

all colors equal to the key color are black; and colors that contain some amount of the key 

color are gray. 
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8 Click the B button in the Effect Controls window. 
View B is a grayscale matte of the key color. Again, all white pixels represent color values 

that are opaque; the black pixels are transparent; and the gray pixels are partially trans-

parent. In View B, all colors equal to the key color are white; colors very different from the 

key color are black; and colors that contain some amount of the key color are gray. 

Combined, these two views offer separate control over the key color and colors very 

different from the key color. This has the effect of foreground and background control. 

You can edit the matte of the background (the key color) separate from the matte of the 

foreground (colors very different from the key color). 

9 In this case, the best result is achieved by setting the input levels of both Partial A and 

Partial B to reduce grayscale before trimming the final matte stage. Experiment with 

various settings. We used the following settings. 

Control Value

Partial A In Black 35

Partial B In Black 35

Partial A In White 160

Partial B In White 160

Matte In White 200

Matte Gamma 1.5 
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10 There is still some dark fringe on the key, which often happens, so choose Effect > 

Matte Tools > Matte Choker.

Matte Choker works on the principal that an edge can be redefined anywhere within the 

diameter of a blur by adjusting levels. Matte Choker has two stages, 1 and 2. Stage 1 

Geometric Softness blurs the matte slightly, positive Choke values shrink the matte in, 

and Gray Level Softness sets the softness of the choke. Stage 2 gives you the ability to then 

respread the matte slightly, smoothing rough or irregular edges without cutting into the 

foreground too much. The Iterations slider sets how many times the two stages are to be 

performed. 

11 The recommended settings for Matte Choker are shown in the table below. 

In this case, the Geometric Softness 1 is set to 1 rather than the default of 4 and the Itera-

tions are set to 3 so that the choke is done a little at a time rather than all at once, to better 

preserve delicate edge detail. Geometric Softness 2 is being used here simply to soften the 

matte edge. Feel free to experiment; fewer iterations will result in faster rendering. 

Control Value

Geometric Softness 1 1 

Choke 1 75 

Gray Level Softness 1 10% 

Geometric Softness 2 2 

Choke 2 0 

Gray Level Softness 2 100% 

Iterations 3 



LESSON 7318
Special Effects for Film
12 Close the Effect Controls window and save the project. 

Setting a track matte to a log scale layer
Because you used the Cineon Converter to brighten the RGB beyond recoverable limits 

in order to get a better blue screen key, you will now have to use the keyed layer as a track 

matte source for a log scale layer. 

1 In the Time Layout window, select the ActHiR.mov layer and rename it 

ActHiRKey.mov. 

2 Drag the ActHiR.mov footage item from the Project window into the 3_Actor_Prep 

Time Layout window, and drag it below the key layer.

3 Click the Switches/Modes button at the bottom of the Time Layout window to display 

the transfer mode and track matte menus.
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4 Choose Alpha Matte “ActHiRKey.mov” from the new layer’s TrkMat menu. The key 

layer’s visibility will automatically turn off and a dotted line appear between the two layers 

to indicate that the lower layer is using the upper layer as a track matte.
Notice that ActHiR.mov appears behind the track matte, but isn’t aligned with it. You’ll 

now rotate it and reverse it, just as you did when you created the track matte.

5 With the ActHiR.mov layer selected, press the S key and then press Shift+R to display 

the Scale and Rotation properties. Click the underlined Rotation value, enter 90 for 

Degrees, and click OK. 

6 To flip the image, click the underlined Scale value, deselect Preserve Frame Aspect 

Ratio, and then enter –100 for Height, and click OK. 

7 Position the image by clicking the underlined Position value, and then enter a position 

of 332 for X-axis and 792 for Y-axis. 

8 Select ActHiR.mov and choose Effect > Keying > Spill Suppressor, and leave the 

settings at their default values.

The Spill Suppressor effect removes any leftover blue color that might have been reflected 

onto the foreground. Since you are seeing only the image from the layer which received 

the track matte, that is the layer that needs Spill Suppression, rather than the key layer 

itself. 

To see the finished image in natural linear color, you’ll create a preview layer by applying 

the Cineon Converter effect to an adjustment layer. 

9 Choose Layer > New Adjustment Layer, and then in the Time Layout window, rename 

it Linear Preview. Leave this layer at the top of the stack in the Time Layout window. 
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10 With the Linear Preview layer still selected, choose Effect > Cineon Tools > Cineon 

Converter. If you get an error message at this point, simply click OK. In the Effect 

Controls window, set Conversion Type to 8 Bit Log to Linear. Leave the remaining settings 

at the defaults, which are generally a good predictor of what the image will look like on 

film. Close the Effect Controls window. 

Notice how the adjustment layer corrects the color of the other layers. This layer is for 

previewing only, and should be turned off before leaving the composition and before 

rendering. 
11 In the Time Layout window, deselect the Video switch for the Linear Preview layer to 

turn it off. 

12 Close the 3_Actor_Prep Composition and Time Layout windows, and save the 

project. 

Creating the Handlight Composition
Now you will set up a composition that will serve as the hand light effect in the final scene. 

This composition makes a little radiating light that you will track to the actor’s hand, 

giving the impression that the light is emanating from his palm. After creating a solid, you 

will apply a randomizing noise effect.

1 Create a new composition, type 4_Handlight as the name, and set the frame size to 512 

x 512, the Resolution to Full, the Frame Rate to 24 fps, and the Duration to 32 frames. 

Click OK. 

You’ll start with a small solid, and then apply noise to it by using the Noise effect. Next 

you’ll enlarge the dimensions of the solid to fill the frame and stretch the noise pixels to 

create shifting color bars. 

2 Choose Layer > New Solid, name it Handlight, set the size to 64 x 1 pixels, and leave 

the default color as gray, and then click OK. 

3 Use the magnifying glass tool to zoom in to 400% on the small solid. 

4 Choose Effect > Stylize > Noise, and change the Amount of Noise Rate to 100%. 

Deselect both Use Color Noise and Clip Result Values. 
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The Noise effect randomly changes pixel values throughout an image. (Like some other 

effects, the Noise effect does not require keyframes for animation.) Turning off the Color 

Noise option applies the same value to all the channels. The Clipping option determines 

whether noise colors will change once they reach their highest values. Since you want 

random noise based on luminescent values, both options are deselected. 

5 Close the Effect Controls window. 

6 Zoom back to 100%. 
7 Press the S key to display the Scale property, and then click the underlined Scale value. 

In the Scale dialog box, choose % of Composition for Units. 

8 Deselect Preserve Frame Aspect Ratio, enter 100 for both Width and Height, and click 

OK.

This technique creates a series of bars in random colors of gray. 

9 Press the Home key to move to the beginning of the composition, and then press the 

spacebar to see how the noise creates a shifting grayscale composition. 

If you hadn’t created the small solid and stretched it with the Scale command, the noise 

would appear as pixels instead of gray bars. 

Now you’ll darken the layer by using a gray gradient. 

10 Choose Layer > New Solid, name it Gradient, set the size to 512 x 512, leave the rest 

of the defaults, and click OK.

11 Choose Effect > Render > Ramp. This creates a gray blend with white on the bottom 

and black on the top. Leave the default settings as they are, and close the Effect Controls 

window.
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12 In the Time Layout window, click the Switches/Modes button to display the Transfer 

Modes panel, and choose Multiply from the Mode menu for the Gradient layer. The 

Multiply mode combines the two layers, and makes the top part of the hand light image 

darker and the bottom part lighter.
When you add this composition as a layer to the final composition, you will change its 

color and shape and apply the Glow effect. 

13 Close the Composition window and Time Layout window, and save the project.

Positioning the elements for the final composition
Now that you have constructed all the elements that you need, you are ready to import 

the rest of the files and assemble the pieces into the final composition. You’ll import the 

sky and feed-store images and the sky light effect.
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Preparing a still image file for import into After Effects

Before you import a still footage item into After Effects, prepare the file as completely as possible. It is generally 

easier and faster to prepare a file in its original application; this also reduces rendering time in After Effects. 

You can use an image-editing application, such as Adobe Photoshop, to prepare the footage, and then use 

After Effects to manipulate only the image attributes you want to change over time. Before you import still 

image files into After Effects, consider doing the following:

• Set the pixel dimensions of the still image to the resolution at which you will use it in After Effects. If you 

plan to output to DV or D1, you can set the pixel dimensions to a smaller size. If you plan to scale the image 

over time, set image dimensions that provide enough detail at the image’s largest size in the project. The max-
1 Choose File > Import > Footage Files, and then select Fds.psd in the 07Lesson folder, 

and click Open. In the Interpret Footage dialog box, select the Treat as Straight option, 

and click OK.

2 Select Sky.psd, and click Open.

3 Select the FX_HiR.mov file, click Open, and then click Done. 

Both the Fds.psd image and the Sky.psd image are 2918 x 1946 in size, and both were 

scanned into Adobe Photoshop and saved as 72 dpi Photoshop files. 

The FX_HiR.mov file is a 36-frame QuickTime movie of a lens flare. 

imum resolution you can use in After Effects is 4000-by-4000 pixels.

• Set the resolution to even numbers if working in a composition that uses even-numbered resolution (for 

example, 2048 by 1536). Likewise, set the resolution to odd numbers if working in a composition that uses 

odd-numbered resolution. This process prevents additional softening of images.

• Crop the parts of the image that you do not want to be visible in After Effects.

• Correct the contrast and color balance to ensure they are set correctly for broadcast video, if necessary.

• Create an alpha channel if you want to designate areas as transparent.

• If final output will be broadcast video, avoid the use of thin lines, for example, 1-pixel lines, for images or 

text because they may appear to flicker. If you must use thin lines, add a slight blur so the line or text displays 

on both fields instead of flickering between them.

• Save the file using the correct naming convention. For example, if you plan to import the file to After Effects 

on a Windows system, save the file using a three-character extension. If you plan to import the file to Mac 

OS, save the file with a name containing a maximum of 31 characters.

• Make sure the file format is supported in the operating system you plan to use.

—From the Adobe After Effects User Guide, Chapter 3 
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You’ll set proxies to speed up screen redraw. 

4 Select Fds.psd in the Project window, choose File > Set Proxy > File, select FdsPrx.psd 

in the 07Lesson folder and click OK. Select the Treat as Straight option for the alpha 

channel, and then click OK. 

5 Select Sky.psd in the Project window, and then choose File > Set Proxy > File, and select 

SkyPrx.psd in the 07Lesson folder. 

Both the FdsPrx.psd and SkyPrx.psd files are smaller versions of the original Photoshop 
images. When used as proxies, they are scaled up to the same size as the original. 

6 Select FX_HiR.mov, choose File > Set Proxy > File, and select FX_Prx.mov in the 

07Lesson folder. 

Positioning the layers
After positioning the feed-store and sky layers and rotating them slightly, you’ll set 

Position keyframes for the Sky.psd layer so that the sky moves slightly from left to right. 

First, you’ll create a new composition. 

1 Create a new composition, name it 5_Pan_Comp, set the Frame Size to 2700 x 1875, 

and set the Resolution to Quarter. 

2 Make sure the Frame Rate is set to 24 fps, and set the Duration to 192 frames. 

3 If you need to conserve memory, select Custom in the Resolution menu, set both values 

to 8, and then click OK. Click OK again to create the composition. 
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Now you’ll add the files you just imported. 

4 Drag both Sky.psd and Fds.psd from the Project window into the 5_Pan_Comp Time 

Layout window, making sure that Fds.psd is at the top of the stack. 

Both Fds.psd and Sky.psd need to be rotated slightly. 

5 With both the Fds.psd and Sky.psd layers selected in the Time Layout window, press 

the R key to see the Rotation property, and then press the – (minus) key on your numeric 

keypad to rotate the layers one degree counterclockwise. (You can use the + key to rotate 
clockwise in 1-degree increments.) 

6 Deselect Sky.psd, press the P key, and set the Position value for the Fds.psd layer to 1268 

for X-axis and 936 for Y-axis.

7 To move the sky, set the current time to 0001, select the Sky.psd layer, and click the 

stopwatch icon next to Position to set an initial Position keyframe. Then click the under-

lined value and enter 1284 for X-axis and 936 for Y-axis. 

8 Go to the end of the composition, and change the Position value to 1212 for X-axis and 

936 for Y-axis. 

The Fds.psd layer needs some color correction. You’ll use the Levels effect to do this. 

9 Select Fds.psd and choose Effect > Adjust > Levels. In the Effect Controls window, 

choose the channel and enter the values from the following table. 

Now you’ll use the Noise effect to make the Fds.psd layer, which is a still image, look more 

like film. This effect adds random noise that can be used to simulate film grain. After 

applying the Cineon Converter effect to Fds.psd, you’ll copy these two effects and paste 

them into Sky.psd. 

10 With Fds.psd selected, choose Effect > Stylize > Noise. In the Effect Controls window, 

set the Amount of Noise to 2 percent. 

RGB Input Black 26

RGB Gamma 0.8

Red Input White 250

Green Input Black 4 

Blue Input White 251
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Your final adjustment will be to apply the Cineon Converter to convert the linear Fds.psd 

image to log scale. 

11 With Fds.psd selected, choose Effect > Cineon Tools > Cineon Converter. If you get an 

error message at this point, simply click OK. In the Effect Controls window, choose 8 Bit 

Linear to Log from the Conversion Type menu. 

12 Select the Noise and Cineon Converter effects in the Effect Controls window and 

choose Edit > Copy. 
13 Select the Sky.psd layer, and choose Edit > Paste. 

14 You’ll want to be able to see the composition in linear scale, so press the Home key to 

move the current-time marker to the beginning of the composition, choose Layer > New 

Adjustment Layer, and then rename the layer Linear Preview. 

15 Choose Effect > Cineon Tools > Cineon Converter. Leave the settings at the defaults 

and close the Effect Controls window. 

This layer should stay at the top of the stack in the Time Layout window. It should be 

turned off before leaving the composition, and before rendering. 

16 Save the project. 

Adding the FX_HiR.mov footage item
Now you’ll add the FX_HiR.mov image to the composition twice to give the sky a glow.

1 Set the current time to 0004, and then drag the FX_HiR.mov footage item from the 

Project window into the Time Layout window. Display the Transfer Modes panel, and set 

the mode for the FX_HiR.mov layer to Screen. 

The Screen mode keys out the black areas of the FX_HiR.mov image and leaves a glowing 

light over the sky. Unlike the other linear scale layers, you won’t convert the Flare layers 

to log scale. Placed in a log scale composition, the highlight will render as brighter than 

the white point in a standard print. 

2 With the FX_HiR.mov layer selected, choose Edit > Duplicate. The duplicate layer is 

displayed at the top of the layer stack in the Time Layout window. An asterisk appears at 

the end of the layer name to indicate that it is a duplicate. Drag the layer duration bar of 

the duplicate layer until the In point is positioned at frame 152.
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3 To reverse the second layer’s playback direction, select the layer that begins at frame 152 

and press Ctrl+Alt+R (Windows) or Command+Option+R (Mac OS). The layer 

duration bar now has diagonal red stripes, indicating that it has been reversed. 

The layer is automatically time stretched -100% and will play backwards from frame 152.
4 Save the project.

Adding the actor and creating his shadow 
After adding the 3_Actor Prep composition to the 5_Pan Comp, you’ll create the actor’s 

shadow. 

1 Set the current time to 0001. Drag the 3_Actor_Prep composition from the Project 

window into the 5_Pan Comp Time Layout window. 

2 Press the P key to display the Position property in the Time Layout window, and enter 

1728 for X-axis and 1164 for Y-axis. 

Before creating the actor’s shadow, you’ll need to mask out the box on which the actor is 

standing. Because the object you want to mask out is small, you can save time by drawing 

the mask around the box and then reversing the mask. 

3 Double-click the 3_Actor_Prep layer to open the Layer window. Select the pen tool 

from the toolbox and use it to mask out the box which the actor is standing on. When 

finished, close the Layer window. 
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4 With the new mask (Mask 1) selected in the Time Layout window, choose 

Layer > Mask > Inverse. 

Next you’ll use a solid to make the actor’s shadow. 

5 Choose Layer > New Solid, name it Actor Shadow, set the size to 1024 x 128, and leave 

the color at default gray. Click OK. 

6 In the Transfer Modes panel, change the mode for the Solid layer to Multiply. 

7 Position the solid to the right of the actor in the Composition window (2204, 1812), 
and beneath the 3_Actor_Prep layer in the Time Layout window.

8 Double-click the solid layer to display the Layer window, and then create a mask to 

reshape the rectangular solid as shown below.

9 Press the F key to display the Mask Feather property in the Time Layout window, and 

then set Mask Feather to 10 pixels for both Horizontal and Vertical. 

10 Close the Layer window.
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Adding the 4_Handlight layer
Now you’ll add the 4_Handlight layer to the composition and apply a variety of visual 

effects to turn the dull gray bars into glowing light.

1 In the Time Layout window, deselect the Video switches to turn off the video for all 

layers except the 3_Actor_Prep composition.

2 Go to frame 115 and drag the 4_Handlight composition from the Project window into 

the Composition window. Position the hand light on top of the man, obscuring his hands 

and face for the moment. (You will change the position later.)
3 Use the zoom tool to zoom in on the hand light area. 

4 In the Time Layout window, display the Transfer Modes panel. Set the mode for the 

4_Handlight composition layer to Screen. 

Now you’ll apply the Hue/Saturation, Corner Pin, Glow, and Fast Blur effects. 

The Glow and Corner Pin effects are available only in the Production Bundle version of 

After Effects. However, both plug-ins have been included for you on the After Effects 

Classroom in a Book CD-ROM. To use the Corner Pin or Glow effects, make sure that 

you have installed both plug-ins according to the instructions in “Installing Production 

Bundle plug-ins” on page 4.

5 Display the Scale property and click the underlined Scale value. In the Scale dialog box, 

choose % of Source for Units, set the Scale value of the 4_Handlight layer to 75 for both 

Width and Height.
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6 Choose Effect > Adjust > Hue/Saturation, and then select Colorize in the Effect 

Controls window. Now skew the gray ramp to blue: set Colorize Hue to 240, set Colorize 

Saturation to 50, and set Colorize Lightness to –20. 
Next you’ll apply the Glow effect. 

7 Choose Effect > Stylize > Glow, and make sure that the glow is based on the Color 

Channels.

8 Enter 33 for the Glow Threshold and 25 for the Glow Radius. Leave the other settings 

at their defaults.

9 Choose Effect > Blur & Sharpen > Fast Blur, and set the Blurriness value to 10.

Now you’ll use the Corner Pin effect to turn the rectangular shape into a triangular shape 

that fits in the actor’s hand.

10 Collapse the three effect outlines by clicking the triangles in the Effect Controls 

window. Save the project. 
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Using the Corner Pin effect
The Corner Pin effect distorts a layer by repositioning its four corners to simulate a 

perspective view. This is especially useful for aligning layers with elements in other layers. 

For example, you can use the Corner Pin effect to replace the video on a television screen. 

In this example, you will use it to create the directional glow effect.

1 Make sure the 4_Handlight layer is selected in the Time Layout window, and choose 

Effect > Distort > Corner Pin. 

2 In the Effect Controls window, notice the four corner controls. Click the Lower Left 
crosshair. A crosshair appears in the lower left corner of the 4_Handlight layer in the 

Composition window.

3 Click in the center of the layer in the Composition window with the crosshair. 

4 Click the Lower Right crosshair in the Effect Controls window, and click again in the 

middle of the 4_Hand Light layer in the Composition window, but not in the exact same 

position as before. You will not get the desired effect if both positions are identical. 

The effect becomes triangular in shape. If the shape is still rectangular, change one of the 

coordinates slightly in the Effect Controls window. 
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5 In the Time Layout window, drag the 4_Handlight layer below the 3_Actor Prep layer. 

In the Composition window, position the hand light behind the actor’s left hand.
6 If you set a custom resolution to conserve memory when you created 5_Pan Comp, set 

the Resolution of the composition to Quarter. Close the Effect Controls window and save 

the project.

Using the Motion Tracker Keyframe assistant
You will use the Motion Tracker Keyframe Assistant to track the motion of the actor’s 

hand so that you can match the motion of the glow to the moving hand.

The Motion Tracker and several other keyframe assistants are available only with the 

Production Bundle version of After Effects.The Motion Tracker keyframe assistant is not 

included with the After Effects Classroom in a Book. If you do not have the After Effects 

Production Bundle, skip to “Importing keyframes” on page 337. 

Keyframe assistants are a set of plug-ins that generate and manipulate keyframes 

automatically. Other keyframe assistants include the Motion Stabilizer, which eliminates 

movement caused by a handheld camera; Motion Sketch, which captures a motion path 

you draw freehand with the mouse; and several others. 
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Setting up Motion Tracker options
In order to use the Motion Tracker, the composition must have at least two layers—one 

layer to track and one to attach to. At least one of the layers must be a movie or compo-

sition. In this example, you will track the position and rotation of the actor’s hand and 

arm, and then attach the hand light to the actor’s hand.

Note: To ensure sufficient accuracy, you should turn proxies off when using the Motion 

Tracker in a production environment. To conserve memory during this lesson, leave the proxy 

on.
1 Select the 3_Actor_Prep layer in the Time Layout window, and then choose 

Layer > Keyframe Assistant > Motion Tracker. The Motion Tracker window appears.

The Motion Tracker window contains an image of the selected layer, a time ruler, controls 

found in the Layer window, and the Motion Tracker controls.

Note: Although you cannot manually select different tools while the Motion Tracker is active, 

you can select them using the keyboard shortcut commands. 
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2 Click the Options button, and then choose 4_Handlight from the Apply Motion To 

menu.

3 Make sure the Frame Rate is 24 fps, choose 1/8 from the Subpixel Matching menu, and 

click OK.
To define the time range in which you want to track motion, use the time ruler and the In 

and Out buttons just as you would in the Layer window.

4 In the Motion Tracker window, set the current time to frame 0115 by clicking the time 

display, and then click the In button. The Out point will remain at the end of the layer.

A. Time display B. In button

A B
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Defining the tracking range
Now define the Motion Tracker Feature and Search regions. 

1 Choose Track Position & Rotation from the menu.

You’ll use the Position option to track the position of the hand light as it follows the hand, 

and the Rotation option to rotate the hand light in relation to the arm as it swings from 

the elbow.

2 Scroll the image, if necessary, until you locate the Position and Rotation Feature and 
Search regions. They appear as two double boxes. 

The box on the left is the Position Tracker, and the box on the right is the Rotation 

Tracker. The outside rectangle for each box is the Search region, which you use to define 

the area where the Motion Tracker will search for a match to the Feature region. The 

inside box is the Feature region. Resize this box to define precisely the element you want 

to track. 

Note: When dragging the Position Tracking and Rotation Tracking boxes, be careful not to 

accidentally drag a handle. Zoom the image in, if necessary, when dragging the boxes. To 

zoom the image with the Motion Tracker window open, press the Period key to zoom in, and 

press the Comma key to zoom out. 

3 Click inside the left set of boxes and drag it up to the actor’s hands. 
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4 Use the handles to resize the Search region (outer rectangle) to define the area that the 

Motion Tracker will use.

The Search region should be quite wide in this case, since at one point the actor moves his 

hand rather quickly. Make the Search region large enough to contain the greatest possible 

movement of the Feature region from one frame to the next, but no larger. Large Search 

regions slow down the tracking process. 
5 Use the handles to resize the Feature region (inner rectangle) to define the area around 

the top of the actor’s left hand.

6 Drag the Rotation Feature and Search regions to the man’s elbow. The Search region 

can be fairly close to the Feature region, which should cover about 50% of the elbow area. 
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7 Make sure that you can see the actor’s hands so that you can watch the tracking process, 

and then click the Track button. 

A narrow black bar appears under the timeline to mark time regions that have been 

tracked. You can interrupt the tracking process at any time by clicking the mouse or 

pressing any key. 

It can take up to 10 minutes for the Motion Tracker to track the motion for the 4 seconds 

that you have specified.
You may need to experiment with the positioning of the Search region and Feature region 

boxes before you are satisfied. Accurate tracking requires patience and a lot of trial and 

error. If you find that you don’t have the time, you can skip to “Importing keyframes” and 

copy keyframes that have already been created.

8 After you have finished tracking, click the Apply button to generate keyframes.

Examining the keyframes
The Motion Tracker applies Position and Rotation keyframes to the 4_Handlight layer for 

every frame within the tracking region. 

1 Display both the Position and Rotation properties of the HandLight layer: select the 

4_Handlight layer, and then press the P key, and Shift+R. Examine the Position and 

Rotation keyframes that have been automatically created. 

2 Set the work area to just the area where the keyframes are, and press 0 on your numeric 

keypad to preview the motion of the layer. 

For more information on the Motion Tracker keyframe assistant, see the Adobe After 

Effects 4.0 Production Bundle Guide.

Importing keyframes
If you do not have the Production Bundle version of After Effects, you do not have access 

to the Motion Tracker. Instead, you can import a project that contains the 4_HandLight 

layer with the keyframes created for you. If you completed the previous section, skip these 

instructions and go to the next section, “Positioning the CD-ROM image.”

1 Choose File > Import > Project, and then select HndKey.aep in the 07Lesson folder, 

and click Open.
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2 Double-click the HndKey.aep folder in the Project window, and double-click the 

Handlight_Keyframes composition. 

3 With the 4_Handlight layer selected and the Position and Rotation properties 

displayed, Shift-click both properties to select all the keyframes, and choose Edit > Copy.

4 Activate the 5_Pan_Comp window, make sure that the 4_Handlight layer is selected 

and the current-time marker is set to 0115, and then choose Edit > Paste. 

5 If 4_Handlight has shifted so that the layer position no longer matches the actor’s hand 

position, then Shift-click both the Position and Rotation properties to select all 
keyframes, and use the Arrow keys to nudge all the keyframes equally until the 

4_Handlight layer is in correct position. 

6 Close the Handlight_Keyframes Comp and Time Layout windows and save the project.

Positioning the CD-ROM image
The only layer left to add is an image of a CD-ROM, which was created in After Effects. 

To make the CD fly, you’ll create a motion path and define Scale and Rotation keyframes. 

Here’s the flight plan you’ll set up for the flying CD: it starts scaled down to nothing, flies 

out of the center of the light flare in FX_HiR.mov, increases in size and flies past the man, 

circles back, dives into his hand, and then jumps out and back into the light flare. Feel free 

to experiment with your own motion path.

First, import the CD footage item. 

1 Choose File > Import > Footage File, select the CD.mov in the 07Lesson folder, and 

click Open. 

You’ll use the 1_Timing_Script composition to guide you in placing Position keyframes. 

2 Set the current time to 0001, drag the 1_Timing_Script composition from the Project 

window into 5_Pan Comp Time Layout window. Hide the video for the 1_Timing_Script 

layer. 
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3 Double-click the 1_Timing_Script composition in the Project window to open its Time 

Layout window, and then click the 5_Pan Comp tab in the Time Layout window. 
4 In the 5_Pan Comp Time Layout window, turn off the video for all the layers except 

3_Actor_Prep and FX_HiR.mov that starts near the beginning of the composition. 

5 In the 5_Pan Comp Composition window, set the Magnification to 25%, set the 

current time to 0008, and drag in CD.mov from the Project window.

Since you selected the Synchronize Time of All Related Items preference in the beginning 

of the lesson, the current-time marker will reflect the same time in both tabbed compo-

sitions in the Time Layout window.

6 Position the CD.mov layer in the center of the star shape (FX_HiR.mov), and then set 

a Position keyframe for it.
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7 Click the 1_Timing_Script tab in the Time Layout window. According to 

1_Timing_Script, the next important point is frame 0078, where the actor is looking to 

the right side of the frame, so click the 5_Pan Comp tab, set the current time to 0078, and 

set the position coordinates to 2437, 419. 

8 Move the current-time marker to 0123, and set the position coordinates for the CD 

layer to 1421, 315. 

9 Move the current-time marker to 0135, and position the CD.mov layer in the actor’s 

hand.
10 Move the current-time marker to frame 0151, and click the keyframe navigator check 

box to set a duplicate keyframe.

11 Move the current-time marker to frame 0183, and drag the CD.mov layer back to the 

center of the star shape, where it started.
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12 In the Time Layout window, make sure the CD.mov layer is selected, click the word 

Position to select all the keyframes, choose Layer > Keyframe Interpolation, select Bezier 

from the Temporal Interpolation menu, and then click OK.
13 To pause the motion at frame 135, first deselect the keyframes you selected in the 

previous step, and then select the Position keyframe at frame 135 in the Time Layout 

window. Choose Layer > Toggle Hold Keyframe. This holds the position value until the 

next keyframe. 

Note: Although the keyframes at frames 135 and 151 are identical, using Continuous or 

Bezier keyframe interpolation can cause slight motion. The Toggle Hold Keyframe command 

eliminates this motion entirely. 

14 Now you’ll create a smooth motion path at several keyframes. Select the keyframe at 

frame 0078 and drag the direction handles to create a smooth curve. Select the keyframe 

at 0135 and do the same. 

15 Drag the work area markers so that the work area includes all the motion you just 

created, and then press Alt+0 (Windows) or Option+0 (Mac OS) on your numeric 

keypad to create a wireframe preview of the motion.
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Setting the Scale and Rotation keyframes
Next you’ll set the Scale and Rotation keyframes for the CD.mov layer.

1 In the Time Layout window, select the CD.mov layer, set the current time to 0008, 

change the Scale value to 1%, and set a Scale keyframe. 

2 Use the following table to set values for the Scale keyframes. 

Frame Scale

57 78%
3 Make sure the CD.mov layer is selected, click the word Scale to select all the Scale 

keyframes, choose Layer > Keyframe Interpolation, and then select Bezier from the 

Temporal Interpolation menu. Click OK.

Now you will set the Rotation keyframes so that the CD rotates 12 times during the course 

of its travel.

4 Move to frame 0001, and set a Rotation keyframe with a value of 0°.

5 Move to frame 0192, and change the Rotation value to 12 revolutions, 0°.

6 Press 0 on your numeric keypad to preview the motion.

Using the Basic 3D effect
Now add and animate the Basic 3D effect so that the CD will tumble in as it flies around. 

1 Set the current time to frame 0008. With CD.mov selected, choose 

Effect > Perspective > Basic 3D.

2 Press the E key to display the Basic 3D effect in the Time Layout window, click the 

triangle to display the Basic 3D properties, and then set a Swivel keyframe and a Tilt 

keyframe.

78 60%

123 100%

135 10% 

151 10%

162 80%

183 1%
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The Basic 3D effect manipulates a layer in an imaginary three-dimensional space. Swivel 

controls horizontal rotation, and Tilt controls vertical rotation.

3 Change the Swivel value to 37° and the Tilt value to 20°.

4 Move the current-time marker to frame 188, set Swivel to 60°, and set Tilt to 1 

Revolution and 260°. 

5 To see the results of this effect, go to frame 0123 and toggle the Basic 3D effect off and 

on by clicking its check box in the Effect Controls window. When finished, leave the Basic 
3D effect on. 

Finishing the composition
To finish the composition, turn on some of the hidden video.

1 In the 5_Pan Comp Time Layout window, turn on all video except for the 1_Timing 

Script layer and the Linear Preview layer.

2 Click the 1_Timing_Script tab in the Time Layout window, and then click the close box 

on the right side of the tab to close the window. 

3 Close the 5_Pan_Comp, Time Layout, and Effect Controls windows and save the 

project. 

Creating the final composition
To finish the project, you’ll create a new composition, set up a slate to identify the 

beginning and end of your composition to the film output service bureau, add the 

5_Pan_Comp, and set Position keyframes to simulate a camera panning the image.

1 Create a new composition, name it 6_Final_Render, and choose Film (2K) from the 

Frame Size menu to set the size to 2048 x 1536.
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2 Set the Resolution to Quarter, the Frame Rate to 24 fps, and the Duration to 194 

frames. Click OK.

This composition is two frames longer than the others to leave room for one-frame head 

and tail slates.

3 Choose Layer > New Adjustment Layer and name it Linear Preview. Choose 

Effect > Cineon Tools > Cineon Converter, leave the settings at the defaults, and close the 

Effect Controls window. If you get a Cineon error message at this point, simply click OK. 

This layer, like the other linear preview layers, is for preview only; it should be turned off 
before rendering, and should remain at the top of the layer stack.

Creating a slate
It’s good practice to slate (include a labeling frame for) one’s work, to avoid confusion 

with your client and output service bureau over the version and contents of a particular 

composition, as well as providing process control charts. The head slate typically contains 

the shot, version, and date information while the tail slate indicates the end of the 

composite to provide a positive indication that all the frames were recorded to film. 

Usually only one frame each is used because of the cost of film recording. An example of 

a standard slate has been provided.

You will import a standard slate frame and apply the Basic Text effect.

1 Choose File > Import > Footage File and select Adobe_slate.cin from the 07Lesson 

folder. In the Interpret Footage dialog, choose the Treat As Straight alpha interpretation 

and click OK. 

2 Make sure you are at frame 0001, and then drag the Adobe_slate.cin footage item from 

the Project window into the 6_Final_Render Time Layout window. 

3 Rename the Adobe_slate.cin layer Head Slate. 

4 You’ll use the Linear Preview layer later in this exercise, so drag it back to the top of the 

layer stack in the Time Layout window. 

5 Choose Effect > Cineon Tools > Cineon Converter and then choose Auto Log to Log in 

the Conversion Type menu. 
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6 Select the Head Slate layer and choose Effect > Text > Basic Text. Enter on separate lines 

the client, production name, shot number, composite version number, length exclusive of 

the slate, and date. How the text is arranged on screen and the font used are up to you, 

but quick and easy readability will be appreciated by others. Click OK. 

7 In the Effect Controls window, make the text color black and select Composite On 

Original. 

Note: Turn the Linear Preview layer on and off and observe the grayscale patches on the left 

side of the slate frame. Both the 1023 and 685 patches are white when the Linear Preview is 
on, and differentiated when it is off. Likewise, the 95 and 0 patches are black with Linear 

Preview, and differentiated without. That’s because the standard linear transform specifies 

black at 95 on the 10-bpc 0–1023 scale (10 bits contain four times as many discrete values as 

8 bits, which is 0–255).

Even though the differences between these two groups of patches shouldn’t be visible in 

a print from the film recording, the difference between the 1023 and 685 patches partic-

ularly should be visible in the film negative. Thus, a slate like this is a good indicator of 

whether your composition was properly recorded to film. 

8 To make the tail slate, first duplicate the Adobe_slate.cin layer by choosing 

Edit > Duplicate. Then switch the Effect Controls window to the duplicate layer by 

pressing Shift+Ctrl+T (Windows) or Shift+Command+T (Mac OS). Click the under-

lined Options in Basic Text, delete the version and date information after your shot 

number, and type END COMPOSITE on a new line. 

9 In the Time Layout window, rename the duplicate Adobe_slate.cin layer Tail Slate. 

It’s not necessary to have version information on the tail slate, but it is useful to signal to 

the film recording operator that this is the last frame of the composite.

10 Select the head slate layer (a bottom layer) and, with the current time set at 0001, trim 

the layer to a single frame duration by pressing Alt+right bracket (]) (Windows) or 

Option+right bracket (]) (Mac OS). 

11 Select the Tail Slate layer, set the current time to 0194, and then trim the layer to a 

single frame duration by pressing Alt/Option+left bracket ([).
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Adding 5_Pan_Comp
1 Go to frame 0002, drag the 5_Pan_Comp from the Project window into the 

6_Final_Render Time Layout window, and then drag it below the Linear Preview layer. 

2 Display the Transform properties, and set the Scale value to 90%. Because you won’t be 

animating the scale, you don’t need to set a keyframe for this property. 

To create movement simulating a roving camera, you’ll set some position keyframes for 

the 5_Pan_Comp layer. 
3 Set the current time to 0025 and set the Position values to 1200, 827. Set an initial 

Position keyframe. 

4 Move the current-time marker to 0079, and change the Position values to 844, 735.

5 Finally, move the current-time marker to 0193, and change the Position values to 1196, 

700.

6 Select all three Position keyframes choose Layer > Keyframe Interpolation, and choose 

Bezier from the Temporal Interpolation menu. Click OK.

7 Save the project.

Rendering the project
Now you are ready to render the project. Since this project uses high-resolution images, 

you will use proxies when you render the project.

1 Choose Composition > Make Movie, name it 07Movie.mov, and save the file in your 

Projects folder. 

2 In the Render Queue, choose Custom for Render Settings. 
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3 For Quality, choose Best. For Resolution, choose Quarter for a size of 512 x 384. 

Note: You may prefer to render a draft movie. 

4 For Proxy Use, choose Use All Proxies. Make sure Time Span is set to Length of Comp. 

Click OK. 
5 For Output Module, choose Custom, and for Format, choose QuickTime Movie. 

6 In Windows, the QuickTime settings dialog box appears. Set Compressor to None, and 

then click OK. In Mac OS, leave the Video Output options at their defaults. 

7 Select Import into Project When Done, and click OK. 

8 Click Render. 

9 When you are finished rendering the movie, open the footage file that appears in your 

Project window and play it. 

If it doesn’t play smoothly, then create a new composition at 512 x 384 pixels, Full 

Resolution, and 194 frames Duration. Drag the Final.mov footage item from the Project 

window into the Time Layout window and click the RAM Playback button. If you have 

enough RAM available, the movie will now play smoothly. 

10 Save and close the project, and quit After Effects. 

To render the entire project for film output, you would turn proxies off and render at full 

size as Cineon files, using the Full Range preset. (To render a file of this size would take 

more than 150 MB of RAM and 2.4 GB of hard drive space.) You would then take it to a 

motion picture film output service provider, where it would be recorded onto motion 

picture film. To transport such a large file sequence, you could use Exabyte 8mm, DAT 

4mm or DLT format tapes, or a large removable hard drive. 

For more information, see “Rendering for film” on page 363 and “Video transfer issues” 

on page 361. 
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Congratulations! This ends the lessons. You’ve accomplished quite a bit since you began 

setting keyframes and creating simple compositions. As you continue to work with After 

Effects, you might want to refer to specific lessons in this book to remind yourself of 

particular procedures, or to remember how to create a specific effect.

In the next several pages, you’ll find a special “Technical Information” section on working 

with dynamic media and digital video. It includes information on pertinent issues 

including video-to-film conversion and production. You can read it at your leisure, or use 

it as a reference.


	Getting Started
	About Classroom in a Book
	Prerequisites
	Checking system requirements
	Installing Adobe After Effects
	Using the Classroom in a Book files
	Restoring default preferences
	Lesson strategies
	Rendering QuickTime movies
	Special bonus section
	Additional resources
	Adobe certification

	A Quick Tour of Adobe After Effects
	Getting started with your project
	Importing footage items
	Setting up a composition
	Setting layer keyframes
	Scaling a layer
	Copying and pasting keyframes
	Rotating a layer
	Creating a motion path
	Synchronizing animation
	Applying the Drop Shadow effect
	Adding an adjustment layer
	Nesting compositions
	Using RAM Preview
	Adding and previewing audio
	Rendering the project
	Lesson 1

	Getting to Know the Work Area
	Viewing the final project
	Video terminology
	Getting started
	Project window
	Composition window
	Time Layout window
	Layer switches
	Layer properties
	Navigating through time
	Setting a work area
	Previewing the composition
	Rendering a movie
	Viewing the final project
	Getting started
	Size and memory considerations
	Using the footage and layer windows
	Trimming a layer
	Setting a fade-out
	Using the Basic Text effect
	Duplicating and renaming layers
	Copying and pasting keyframes
	Magnifying the Time Graph
	Animating the opacity
	Previewing the animation
	A word on space and time
	Creating a motion path
	Setting Auto-Orient Rotation
	Previewing with RAM Preview
	Managing the speed of layers
	Setting roving keyframes
	Using Motion Sketch to create a motion path
	Creating a draft movie
	Rendering the final movie
	Lesson 2

	Ballet Special Bumper
	Animated L-Train Logo
	Viewing the final project
	Getting started
	Size and memory considerations
	Setting up the project
	Animating the script letter L
	Creating masks with the pen tool
	Creating a template for a composition
	Animating the logo
	Positioning another element
	Positioning the circle
	Continuously rasterizing
	Nesting Script L Comp
	Splitting the comps
	Creating the final composition
	Applying visual effects
	Creating a fade-out composition
	Rendering the movie
	Viewing the final project
	Creating the You Dig? movie segment
	Getting started
	Creating the IDIG movie segment
	Creating the Dig It! movie segment
	Assembling the final project
	Lesson 4

	Multimedia Animation
	Horror Festival Ad
	Viewing the final project
	Examining the Photoshop source document
	Getting started
	Using context menus
	Increasing the duration of still images
	Using the Offset effect
	Setting a luma matte
	Using the Time Stretch command
	Importing footage with an alpha channel
	Preparing video transferred from film
	Time stretching the layer
	Creating a transition between layers
	Creating the ghost by using solids and masks
	Animating masks
	Using a library to store keyframes
	Preparing the audio for an animation
	Marking the Audio layer
	Matching the ghost mouth to the audio
	Using the library of Mask Shape keyframes
	Using the Wave Warp effect
	Adding the lightning footage
	Fine-tuning the audio
	Importing an image sequence
	Creating a gradient wipe
	Time remapping
	Creating a fade
	Rendering the movie
	Lesson 6

	Station Identification
	Viewing the final project
	Getting started
	Size and memory considerations
	Animating the background
	Animating a masked solid
	Copying and pasting keyframes
	Changing Spatial Interpolation
	Duplicating the layer and keyframes
	Animating the moving eyes composition
	Creating the pogo stick motion
	Creating a squash effect
	Setting the interpolation and velocity
	Editing the speed graph
	Changing the influence
	Changing the velocity values
	Copying and pasting multiple keyframes
	Replacing the artwork
	Creating side-to-side motion
	Creating the swinging rotation
	Nesting the Bounce composition into the Sideways composition
	Staggering the animation
	Importing a movie
	Editing a motion path
	Importing the sound
	Rendering the final project
	Lesson 7

	Special Effects for Film
	Viewing the final project
	Before you begin
	Size and memory considerations
	Getting started
	Using a process flow
	Setting preferences
	Using the Timecode effect
	Understanding the Cineon file format
	Creating a proxy for a high-resolution footage file
	Preparing the actor footage
	Using color keys
	Creating the Handlight Composition
	Positioning the elements for the final composition
	Using the Motion Tracker Keyframe assistant
	Positioning the CD-ROM image
	Finishing the composition
	Creating the final composition
	Rendering the project
	Frame rate issue
	Video safe zones
	NTSC color space
	Video aspect ratios
	Interlace issues
	Video transfer issues
	Rendering for film
	Audio issues

	Technical Information

