
Lesson 8

Creating Forms

Acrobat lets you create form fields that 

can be filled out by a user in Acrobat or 

Acrobat Reader. If all the proper soft-

ware and hardware components are in 

place, form data can be submitted over 

the World Wide Web and collected in a 

database just like HTML forms. In this 

lesson, you’ll fill out form fields, create 

them, and learn about submitting forms 

over the Web.
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In this lesson, you’ll learn how to do the following:

• Fill out a PDF form.

• Export form data.

• Import form data.

• Add form fields, and format those fields.

• Use the forms grid.

• Validate form fields to restrict entries to specific values or characters.

• Perform mathematical calculations on two or more numeric form fields.

This lesson will take about 50 minutes to complete.

If needed, remove the previous lesson folder from your hard drive, and copy the Lesson08 

folder onto it.

Working with forms online
With Adobe Acrobat, it’s easy to convert your existing paper and electronic forms to PDF, 

and then use Acrobat to create PDF form fields. Using an existing form lets you maintain 

your organization’s corporate identity and branding, and saves you from having to re-

create the form design itself.

Many forms require the same information—name, address, phone number, and so on. 

Wouldn’t it be nice if you could enter that data once and use it again and again with the 

various forms that you have to fill out? Acrobat’s ability to import and export form data 

makes it possible for you to populate different forms with the same set of data. 

In this part of the lesson, you’ll fill out a Travel Authorization form with personal infor-

mation, export the data, and then import the data into an Expense Report form.

Filling out a form
1 Start Acrobat.



187ADOBE ACROBAT 4.0
Classroom in a Book

2 Choose File > Open. Select Travel.pdf in the Lesson08 folder, located inside the Lessons 

folder within the AA4_CIB folder on your hard drive, and click Open. Then choose 

File > Save As, rename the file Travel1.pdf, and save it in the Lesson08 folder.

This electronic form was designed using a page-layout application and then converted to 

PDF. Form fields have been created so that you can fill out the form from within Acrobat. 

For the purposes of this lesson, some form fields have already been filled out for you.

3 Select the hand tool ( ).

4 Move the pointer to the right of the Today’s Date line. When the pointer changes to an 

I-beam, click to set an insertion point. Enter the current date in numeric month/day/year 

format; for example, 3/01/1999. (Be sure to enter the day as two digits and the year as four 

digits to match the field’s format and to avoid generating an error message.) Press Tab. 

Traveler's Name:

Department:

Manager's Name:

Today's Date:

Departure Date: Return Date:

Destination(s):

Purpose of Travel:

Travel Item Estimated Expense

Airfare

Hotel

Meals (number of days              X $50.00/day)

Other

Total

Travel Authorization Form
JUGGLER

Reset

Print

Booking Agent:

Agent’s Name:

Confirmation No.:

Payment Method: Company Account

Estimated Expenses

Traveler Information

Travel Booking Information

Traveler:

Manager:

Cost Center:

Date

Date

Date

Approval Signatures

Personal Credit Card

Traveler’s Name:

Department:

Manager’s Name:

Today’s Date:

Travel Authorization For

Traveler Information

March 1, 1999

Marketing

Susan Hashad

Traveler’s Name:

Department:

Manager’s Name:

Today’s Date:

Travel Authorization For

Traveler Information

3/01/1999

Marketing

Susan Hashad
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Notice that your date entry automatically updates to a longer date format. Acrobat lets 

you specify format options, such as currency formats and numbers of decimal places, for 

data entered in a form field.

5 Enter your name in the Traveler’s Name field, and press Tab.

Pressing Tab lets you advance in order through a series of fields. You can set the Tab order 

of fields when you create a form.

6 Press the triangle to the far right of the Department field to display the combo box of 

department names. Select Engineering from the list.

A combo box presents a choice of items in a pop-up menu. You can only select one item 

from a combo box.

7 Press Tab until you arrive at the Destination(s) field, and enter Orlando, FL. Then press 

Tab until you arrive at the Airfare field of the Estimated Expenses section.

8 Enter 250 for the Airfare field, and press Tab twice.

Traveler's Name:

Department:

Manager's Name:

Today's Date:

Destination(s):

JUGGLER

Reset

Print

Traveler Information

March 1, 1999

Andrew McGrath

Marketing

Susan Hashad

March 1, 1999Travel Item Estimated Expense

Airfare

Hotel

Meals (number of days              X $50.00/day)

Other

Total

Estimated Expenses

250

300.00

0.00

$300.00
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Notice that the airfare price automatically updates to a U.S. dollar currency format with 

two decimal places. Notice also that the Total field automatically recalculates the sum of 

total expenses.

This section of the form includes a preformatted mathematical calculation in the Meals 

field, which multiplies the number of travel days by $50.00 (the budget allotted for meals 

per day). You’ll enter a new number of days to see the calculation. Later in this lesson, 

you’ll learn to set up predefined and custom calculations for numeric fields.

9 In the Meals field, enter 6 for the number of days and press Tab twice.

Notice that the amount for Meals in the Estimated Expense column changes to $300.00 (6 

x $50.00). The calculation is performed automatically when you enter a new value in the 

number of days field.

10 Press Tab until you arrive at the Confirmation No. field, and try entering 56T123. 

Notice that you cannot enter alphabetic characters. This field has been formatted to 

accept only numeric entries. Delete the current contents of the field, and reenter a confir-

mation number of 567123.

11 For Payment Method, click one of the radio buttons to make a payment choice. You 

can select only one radio button in a set.

The Travel Authorization form was designed to be filled out electronically and then 

printed for final signature approvals and submission. For the purposes of this lesson, 

you’ll save the form in its current state without printing it.

12 Choose File > Save As, make sure that Optimize is selected, and save Travel1.pdf in the 

Lesson08 folder. Click Yes (Windows) or Replace (Mac OS) to confirm replacing the file. 

The Save As command lets you save a smaller, optimized version of your finished file. 

March 1, 1999Travel Item Estimated Expense

Airfare

Hotel

Meals (number of days              X $50.00/day)

Other

Total

Estimated Expenses

$250.00

300.00

300.00

$850.00

6
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Exporting form data
Now that you have filled out the Travel Authorization form, you’ll export the data to a file 

that contains just the data you entered.

1 Choose File > Export > Form Data. Name the file Info.fdf and save it in the Lesson08 

folder (.fdf stands for Forms Data Format, the file format for exported form data).

2 Choose File > Close to close the Travel1.pdf file. You don’t need to save the file because 

the data you entered has already been saved in the exported Info.fdf file.

Importing data
Now you’ll open another form, and import the Info.fdf file to populate the common fields 

with the travel data you just entered. 

You can import a form data file repeatedly to fill in multiple forms as long as those forms 

have the same field names as the original form from which you exported your data. A 

worldwide standard for naming seems unlikely, but it is certainly possible to create a 

standard within an organization. You can consistently name fields that ask for the same 

information with the same name. For example, an address field can always be named 

Address, and a home phone field can always be named Home Phone (keep in mind that 

form field names are case sensitive).

1 Choose File > Open. Select ExpFinal.pdf in the Lesson08 folder, located inside the 

Lessons folder within the AA4_CIB folder on your hard drive, and click Open.

2 Select the form tool ( ) to display the form fields that have been created in the 

document. Form fields appear as boxes with highlighted field names.

Expense ReportName

Transportation

Accommodations and Meals

Manager’s Signature DateTraveler’s Signature Date

Today’s Date

Manager’s Name Department

Check all that apply:

Conference Expense Relocation Expense Recruiting Expense

Unused tickets attached?

Yes

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental AutoDate Description Total

Miles Expense

Lodging Meals
(by yourself) 

Conference &
Meeting Fees

Telephone 
& Fax

Date

Total

Total

Description Total

JUGGLER

Reset

Submit

No

$0.00

$0.00

$0.00

$0.00

$0.00

0.00

0.00

0.00

$0.00

$0.00

$0.00

Marketing
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3 Select the hand tool, and choose File > Import > Form Data. Select Info.fdf in the 

Lesson08 folder, and click Select (Windows) or Open (Mac OS). 

The values you entered in the Travel Authorization form for the Traveler’s Name, 

Manager’s Name, Department, and Airfare form fields are automatically imported into 

the corresponding fields in the Expense Report form. (Estimated Airfare from the Travel 

Authorization form is placed in the first Airfare field in the Transportation section of the 

Expense Report.)

This Expense Report form contains a number of other premade, formatted fields.

4 Select the hand tool, and experiment with filling out the Expense Report form. Later in 

the lesson you’ll learn how to create the various types of form fields that appear in the 

Expense Report.

5 Choose File > Close to close the form without saving it.

Adding form fields
In this part of the lesson, you’ll work with an earlier, partially created version of the 

Expense Report form. You’ll create text fields, check boxes, a combo box, and radio 

buttons. You’ll also learn how to validate entries in the fields and calculate the sum of 

numeric entries in two fields. 

You create form fields by using the form tool to draw the area and location of each 

form field.

Expense RepName Today’s Date

Manager’s Name Department

Check all that apply:

Conference Expense Relocation Expense Recruiting Expense

Unused tickets attached?

Yes No

Susan Hashad Engineering

Andrew McGrath
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Adding and formatting text fields
A text field lets users enter alphabetic or numeric values. You can specify formatting for 

data entered into text fields. For example, you can specify how many decimal places to 

display for numbers or percentages, or the month, day, and year format for dates. 

1 Choose File > Open. Select Expense.pdf in the Lesson08 folder, located inside the 

Lessons folder within the AA4_CIB folder on your hard drive, and click Open. Then 

choose File > Save As, rename the file Expense1.pdf, and save it in the Lesson08 folder.

2 Select the zoom-in tool ( ), and marquee-zoom to magnify the Transportation 

section of the form.

3 Select the form tool ( ) in the tool bar. As you can see from the field names and 

borders that appear, some form fields have already been added for you.

4 Drag to draw a box inside the first cell under Date in the Transportation section. The 

field box should sit inside the solid black lines so that any text the user enters remains 

within the boundaries.

The Field Properties dialog box appears. This dialog box lets you specify form field 

options such as appearance, format, and mathematical calculations.

For a complete description of all the available options, see “Setting form field 

options” in Chapter 9 of the online Adobe Acrobat User Guide.

5 For Name, enter Date.line1, and for Type, choose Text.

6 Click the Appearance tab. Deselect Border Color and Background Color. Make sure 

that Text Color is set to black, and choose a sans serif font and type size. (We used 

10-point Helvetica.)

Transportation

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental AutoDate Description

Miles Expense

Total

Airfare.line1 Miles.line Personal RentalAuto.line1
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Because the boundaries of the Date field are defined by the form design, you don’t need 

to outline the field with color.

7 Click the Format tab. For Category, select Date. For Date Options, select 1/3/81. Leave 

the default settings selected for other options, and click OK to add the Date text field to 

the form.

Now you’ll create another text field for the Description column.

8 Drag to make a box inside the first cell under Description in the Transportation section.
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9 For Name, enter Description.line1, and for Type, choose Text. Accept the defaults for 

other options, and click OK.

10 Click the Actual Size button ( ). Select the hand tool, and experiment with entering 

values in the fields you just created, pressing Enter or Return after each value. Notice that 

the Date value automatically updates to the specified date format.

Validating form fields
You use validation to restrict field entries in text or combo box fields to specific values or 

characters. For example, you can restrict a numeric entry to a certain range. Use 

validation properties to ensure that users enter appropriate data in form fields. 

1 Use the zoom-in tool ( ) to magnify the Transportation section of the form.

2 Select the form tool ( ), and drag to make a box inside the first cell under Fares in the 

Transportation section.

3 For Name, enter Fares.line1, and for Type, choose Text.

4 Click the Options tab and select Right for Alignment. All text you enter will align with 

the right border of the field. 

5 Click the Format tab. For Category, select Number. For Decimal Places, choose 2. 

You’ll designate the Fares field to accept only values between 1 and 1000.

Transportation

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental AutoDate Description

Miles Expense

Total

Airfare.line1 Miles.line Personal RentalAuto.line1Description.line1Date.li
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6 Click the Validate tab. Select Value Must Be Greater Than or Equal To, and enter 1. 

Then enter 1000 for the value Less Than or Equal To. Leave the default settings selected 

for other options, and click OK.

7 Click the Actual Size button ( ). Select the hand tool and click in the Fares field. 

8 Enter 1500, and press Enter or Return to test the validation for the field.

An alert box appears indicating that the value must be between 1 and 1000. 

9 Enter 85 in the Fares field.

The value is accepted and appears in the Fares field formatted as a dollar amount.

10 Choose File > Save to save the Expense1.pdf file.

Using the forms grid
To aid form field creation, you’ll display the forms grid. The forms grid helps you align, 

size, and place form fields precisely.

1 Use the zoom-in tool ( ) to magnify the Transportation section of the form.

2 Choose View > Show Forms Grid.

Although the grid is displayed on-screen, it will not print with the rest of the PDF form. 

Notice that many of the cell boundaries in the form follow the lines of the grid. By aligning 

form field boundaries with the grid, you can ensure consistent size and even spacing 

between the fields.

3 Choose View > Snap to Forms Grid.
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4 Select the form tool ( ), and click the Fares.line1 field to select it.

You can use the form tool to edit the location, size, and properties of a field at any time. 

You’ll resize the Fares.line1 field so that it fills the area of the cell.

5 Position the pointer over a corner of the field to display the double-headed arrow. Then 

drag to resize the form field. Notice that the field boundary automatically snaps to 

grid lines.

6 Drag the remaining corners of the field to align its boundaries with the cell boundaries.

If desired, you can select and resize the Description.line1 and Date.line1 fields.

Adding check boxes
Check boxes allow a user to make multiple selections from a group of items. Adding check 

boxes to this form will let users select the purpose of their travel (Conference, Relocation, 

or Recruiting Expense).

1 Click the Fit in Window button ( ). Then select the zoom-in tool ( ), and marquee-

zoom around the area under the phrase “Check all that apply.”

Transportation

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental AutoDate Description

Miles Expense

Total

Airfare.line1 Fares.line1Description.line1 Miles.line Personal RentalAuto.line1Date.li

Transportation

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental AutoDate Description

Miles Expense

Total

Airfare.line1 Fares.line1Description.line1 Miles.line Personal RentalAuto.line1Date.li
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Notice that the square boxes in this section follow the lines of the grid, for precise sizing 

and alignment. You’ll hide the grid to remove the display of distracting grid lines from 

the form.

2 Choose View > Show Forms Grid. This command toggles between displaying and 

hiding the grid lines.

Although you have hidden the display of the grid, the snap-to-grid behavior is still active.

3 Select the form tool ( ), and drag to make a box inside the square just to the left of 

Conference Expense. Notice that the field automatically snaps to the edges of the square.

4 For Name, enter Conference, and for Type, choose Check Box.

5 Click the Options tab. For Check Style, choose Check (the default style); for Export 

Value, enter Yes.

An export value is the information used by a Common Gateway Interface (CGI) appli-

cation on a Web server to identify the selected field. 

Transportation

Manager’s Name Department

Check all that apply:

Conference Expense Relocation Expense Recruiting Expense

Unused tickets attached?

Yes

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental AutoDate Description

Miles Expense

No

Name.manager
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6 Click the Appearance tab. Deselect Border Color and Background Color, and click OK 

to add the check box to the form. 

7 Drag to draw a field inside the square next to Relocation Expense. Name the new field 

Relocation, accept the current formatting and appearance options, and click OK.

Instead of creating the third check box with the form tool, you’ll duplicate one of the 

existing fields.

8 Click to select the Relocation field you just created. (Selected fields appear highlighted 

in red.) Choose Edit > Copy.

9 Choose Edit > Paste to paste a duplicate of the Relocation field in the center of the 

document window.

You can move a form field and edit its properties at any time with the form tool.

10 Position the pointer inside the duplicate field, and drag it inside the square next to 

Recruiting Expense. Notice that it snaps to the grid lines.

11 Double-click inside the duplicate field to open the Field Properties dialog box.

Because you duplicated this field, it has the same name value as the Relocation field. Each 

check box field must have a distinct name value to work properly.

12 For Name, enter Recruiting. Accept the current formatting and appearance options, 

and click OK.

13 Click the Actual Size button ( ). Select the hand tool, and click inside the newly 

created check box fields. Notice that you can select more than one check box.

Transportation

Manager’s Name Department

Check all that apply:

Conference Expense Relocation Expense Recruiting Expense

Unused tickets attached?

Yes

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental AutoDate Description

Miles Expense

No

Name.manager

Co Re
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Adding a combo box
A combo box contains a list of items that appear in a pop-up menu. You’ll create a combo 

box for the Department section of the form.

1 Use the zoom-in tool ( ) to magnify the top left portion of the form.

2 Select the form tool ( ), and drag to draw a box inside the cell under Department.

3 For Name, enter Department, and for Type, choose Combo Box.

4 Click the Options tab.

Now you’ll enter the names of the items you wish to appear in the combo box.

5 For Item, enter Engineering, and click Add.

Engineering is added to the combo box list at the bottom of the dialog box, and the Item 

field is cleared for you to enter additional items.

6 For Item, enter Marketing, and click Add.

Expense RepName Today’s Date

Manager’s Name Department

Check all that apply:

Conference Expense Relocation Expense Recruiting Expense

Unused tickets attached?

Yes No

Name.manager

Name.employee

Co Re Re
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7 For Item, enter Human Resources, and click Add.

Note: Be sure to click Add after typing each item name to add it to the combo box list. Do not 

press the Enter or Return key; if you do, you’ll exit the dialog box.

All three items now appear in the combo box list, in the order in which you added them.

8 Select the Sort Items option to rearrange the listed items in alphabetical order.

9 Select Marketing to make it the default choice.

10 Click the Appearance tab. Deselect Border Color. Select Background Color and then 

click the color box next to it to choose a color:

• In Windows, click Define Custom Colors. Enter 255 for Red, 255 for Green, and 204 for 

Blue. Then click OK.

• In Mac OS, scroll up to select the CMYK Picker. Enter 0% for Cyan, 0% for Magenta, 

20% for Yellow, and 0% for Black. Then click OK.

11 In the Field Properties dialog box, choose a sans serif font and type size. (We used 

10-point Helvetica.) Then click OK.

12 Click the Actual Size button ( ). Select the hand tool, position the pointer over the 

triangle in the new field, and click to view the pop-up list of items.
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Adding radio buttons
Unlike check boxes, which let you make multiple selections from a group of items, radio 

buttons let you select only one item. 

When creating radio buttons, keep in mind that the fields must share the same name but 

have different export values. For example, for the field “Unused tickets attached?” you can 

have two values: “Yes” or “No.” Now you’ll set up that radio button. 

1 Use the zoom-in tool ( ) to magnify the top right portion of the form.

2 Select the form tool ( ), and drag a box that surrounds the circle just to the left of the 

word “Yes” at the top right of the form.

3 For Name, enter Unused Tickets, and for Type, choose Radio Button.

4 Click the Options tab. For Radio Style, choose Circle. For Export Value, enter Yes.

5 Click the Appearance tab. Deselect Border Color and Background Color. For Width, 

choose Thin, and for Style, choose Solid. Click OK.

Department

Recruiting Expense

Unused tickets attached?

Yes

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental Auto Total

Miles Expense

JUGGLER

Reset

Submit

Noion Expense

Department

Re
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Instead of using the form tool to create the other radio button, you’ll save time by simply 

copying the field you just created. When you duplicate a form field, you must remember 

to edit the appropriate field properties for the new field.

6 Click in a blank area of the form with the form tool to deselect all the fields.

7 Move the pointer inside the Yes field you just created and hold down Control 

(Windows) or Option (Mac OS). Begin dragging the field to the circle next to No (a 

hollow arrow appears, indicating that you are making a copy). Then as you drag, hold 

down Shift to constrain the motion of the duplicate field along the same horizontal or 

vertical line as the original field.

8 Double-click the field next to No to open the Field Properties dialog box. Click the 

Options tab, enter No as the export value, and click OK. 

9 Click the Actual Size button ( ). Select the hand tool, and click inside the newly created 

radio button fields. Notice that you can only select one item at a time.

Because you have set the fields to snap to the grid, the radio buttons should line up evenly 

with the preexisting black circles on the form.

10 Choose File > Save to save the Expense1.pdf file.

Calculating form fields
You can perform mathematical calculations on two or more existing numeric field entries 

and display the results. You perform calculations within text or combo box fields. You can 

apply predefined operations, or you can create custom operations using the JavaScript 

programming language. 

Department

Recruiting Expense

Unused tickets attached?

Yes

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental Auto Total

Miles Expense

JUGGLER

Reset

Submit

NoUnu Unuion Expense

Department

Re
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In the first part of this section, you’ll create a Total field that adds values from the Airfare, 

Fares, Personal Auto, and Rental Auto fields in the Transportation section of the form. 

Then you’ll set a custom calculation for the Personal Auto field.

Specifying a predefined calculation
Acrobat lets you assign common mathematical operations to numeric fields—including 

addition, multiplication, averaging, and finding maximum and minimum values.

1 Use the zoom-in tool to magnify the Transportation section of the form.

2 Select the form tool ( ), and drag to draw a box inside the first cell under Total at the 

right of the Transportation section.

3 Enter Total.line1 for the name, and for Type, choose Text.

A field must be formatted as a number in order to perform calculations for the field. Now 

you’ll format the Total field as a number.

4 Click the Format tab. For Category, select Number. For Decimal Places, choose 2; for 

Currency Symbol, choose Dollar.

5 Click the Calculate tab, and select Value Is the <operation> of the Following Fields.

6 Choose sum (+) from the pop-up list (the default setting), and click Pick.

Recruiting Expense

Unused tickets attached?

Yes

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental Auto Total

Miles Expense

Reset

Submit

Noocation Expense

Airfare.line1 Fares.line1scription.line1 Miles.line Personal RentalAuto.line1 Total.line1

Unus UnusRe
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7 In the Select a Field dialog box, select Airfare.line1 in the scroll list and click Add 

(Windows) or Pick (Mac OS).

8 Repeat step 7 three times, adding Fares.line1, PersonalAuto.line1, and RentalAuto.line1 

to the calculation list. 

Values used for calculation must be formatted as numbers in the same way that you 

formatted the Total field. The Fares.line1, PersonalAuto.line1, and RentalAuto.line1 fields 

have been preformatted as numbers. 

9 Click Done.

The Airfare.line1, Fares.line1, PersonalAuto.line1, and RentalAuto.line1 fields appear in 

the message box next to the Pick button. If you made a mistake in adding fields, you can 

select the value in the message box and delete it or click Pick to add more fields.

10 Click OK to verify the calculation settings and close the Field Properties dialog box.

11 Select the hand tool. The Total field should now contain the value $85.00 (from the 

85.00 in the Fares field). Because the other numeric fields are still empty, they do not affect 

the value in the Total field. 
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12 Now enter 250 in the first cell under Airfare, and press Tab, Enter, or Return to update 

the Total field. 

Specifying a custom calculation
Now you’ll specify a custom JavaScript calculation for the Personal Auto column to 

calculate the personal transportation expense (number of miles driven multiplied by the 

expense per mile).

The Miles and Expense fields have been preformatted as numbers. You’ll open the Field 

Properties dialog box for the Expense field and apply the custom calculation option to 

the field.

1 Select the form tool ( ), and double-click the PersonalAuto.line1 field under 

Personal Auto.

2 Click the Calculate tab. Select Custom Calculation Script and then click Edit.

To create a custom calculation, you write instructions in JavaScript to tell Adobe Acrobat 

what operations to perform. You’ll enter JavaScript code to multiply the number of miles 

driven by 32 cents (the allowable expense per mile for personal auto usage).

Recruiting Expense

Unused tickets attached?

Yes

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental Auto Total

Miles Expense

Reset

Submit

Noocation Expense

250.00 $335.0085.00

Recruiting Expense

Unused tickets attached?

Yes

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental Auto Total

Miles Expense

Reset

Submit

Noocation Expense

Airfare.line1 Fares.line1scription.line1 Miles.line Personal RentalAuto.line1 Total.line1

Unus UnusRe
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3 Enter the JavaScript code exactly as it appears below, including a line break after the 

first semicolon:

var a = this.getField("Miles.line1");
event.value = a.value * .32;

For more information on writing in JavaScript, refer to JavaScript documentation.

4 Click OK. Then click OK again.

Now you’ll enter values to test the calculating operations.

5 Click the Actual Size button ( ). Select the hand tool and click in the first Miles cell 

under Personal Auto. 

6 Enter 100 and press Enter or Return.

The mileage value appears in the Miles column, and the value 32.00 (100 times .32) 

appears as the Personal Auto expense.

Recruiting Expense

Unused tickets attached?

Yes

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental Auto Total

Miles Expense

Reset

Submit

Noocation Expense

250.00 100 32.00 $335.0085.00
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However, notice that the Total field still displays $335.00, the total excluding the Personal 

Auto expense. In the next section, you’ll fix the calculation order so that the Total field 

takes the Personal Auto expense into account.

Setting the calculation order
The Total field displays the wrong value because Acrobat is performing the two assigned 

calculations in the incorrect order. In other words, Acrobat is calculating first the Total, 

and then the Personal Auto expense. You’ll reverse this calculation order so that the Total 

field displays the correct value.

By default, the calculation order follows the tab order of the fields. For more information 

on tab order, see “Exploring on your own” on page 210.

1 Choose Tools > Forms > Set Field Calculation Order.

2 Select PersonalAuto.line1, and click Up to move the field to the top of the Calculated 

Fields list. Then click OK.

3 In the form, delete 100 from the Miles field under Personal Auto. Then enter 200 for 

Miles, and press Enter or Return.

Notice that the Total field now shows the correct sum, taking into account the Personal 

Auto calculation.

4 Choose File > Save to save the Expense1.pdf file.
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Creating a Reset Form field
You can specify a Reset Form action to clear the data that has already been entered in 

a form. You might reset a form to clear a mistake, or to clear the form for another user 

to fill in.

You’ll add the Reset Form action as a button field that clears the form when clicked by the 

user. For this part of the lesson, you’ll turn off the snap-to-grid behavior. To learn more 

about creating buttons for PDF documents, see Lesson 9, “Adding Buttons.”

1 Choose View > Snap to Forms Grid. 

2 Select the form tool ( ), and drag a box around the Reset item at the top right of 

the form.

3 For Name, enter Reset, and for Type, choose Button.

4 Click the Appearance tab. Deselect Border Color and Background Color, and for Style, 

choose Solid.

5 Click the Options tab. For Highlight, choose None, and for Layout, choose Text Only.

6 Click the Actions tab. Select Mouse Up to create an action that occurs when the mouse 

button is released while the pointer is on the Reset button. Then click Add.

The Add an Action dialog box appears, letting you specify the action that will occur after 

the button is clicked.

Department

Recruiting Expense

Unused tickets attached?

Yes

Airfare Fares
(Taxi, Bus, Ferry, 
Parking, & Tolls) 

Personal Auto
(enter Miles only)

Rental Auto Total

Miles Expense

JUGGLER

Reset

Submit

Noion Expense

Department

Unus UnusRe
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7 For Type, choose Reset Form, and click Select Fields. 

8 In the Field Selection dialog box, select All Fields, and click OK. Click Set Action, and 

then click OK to add the Reset button to the form.

9 Select the hand tool and click the Reset button to test it.

The fields in the form are cleared.

10 Choose File > Save As, make sure that Optimize is selected, and save Expense1.pdf 

in the Lesson08 folder. Click Yes (Windows) or Replace (Mac OS) to confirm replacing 

the file. The Save As command lets you save a smaller, optimized version of your finished 

file.

Submitting forms over the Web
PDF forms can be used for submitting and collecting information over the Web. For this 

process to work, you must have a Common Gateway Interface (CGI) application on the 

Web server to collect and route the data to a database. The field names in the forms must 

also match those set in the CGI application. Any existing CGI application that collects 

data from forms (in HTML or FDF format) can be used to collect data from PDF forms.

Keep in mind that CGI scripts must be built outside of Acrobat and require some 

knowledge of computer programming. CGI applications are usually set up by a Web 

server administrator. For information on creating and managing a form database, see the 

FDF (Forms Data Format) Toolkit. If you do not have the FDF Toolkit, contact the Adobe 

Developer Association, or check the Web site at 

partners.adobe.com/supportservice/devrelations/memberapp.html.
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Filling out the fields
Now you can experiment with filling out the fields that you have just created and resetting 

the form. (Because you haven’t set up a CGI application on a Web server, you won’t be 

able to submit the form data.) When you are finished experimenting with the form, 

choose File > Close to close the file without saving it.

You have just learned how to create and use PDF forms. Now you can use your new skills 

to get your existing and future forms online. Work with your Web administrator to collect 

the data from those forms and keep your databases up to date.

Exploring on your own
You can determine the order in which a user tabs through form fields on a single page. 

The default tab order is the order in which the form fields were created. You can set the 

tab order of the Expense Report form so that users tab through fields from left to right, 

and top to bottom.

1 Select the form tool ( ). 

2 Choose Tools > Forms > Fields > Set Tab Order.

The form fields display numbers indicating the current tab order.

3 To reorder the tabs, click the form fields in the order that they should be numbered. 

Start with the Name field, and proceed by rows from left to right.

4 Click outside a form field, or switch tools to exit Set Tab Order.

Expense RepName Today’s Date

Manager’s Name Department

Check all that apply:

Conference Expense Relocation Expense Recruiting Expense

Unused tickets attached?

Yes No

Name.manager Department

Date.expenseName.employee

14

Relo Recr Unus Unus13 16151211

2

1 3
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Review questions
1 What is the difference between a check box and a radio button?

2 When will a user be able to submit a form over the Web?

3 Which fields will populate in a form if you use the Import > Form Data command?

4 What is a combo box?

5 How do you copy a form field by dragging?

6 How do you restrict entries in text or combo box fields?

7 How do you perform mathematical calculations on two or more numeric fields?

Review answers
1 You can select multiple check boxes, whereas you can select only one radio button in 

a series.

2 Users can submit a form over the Web after a CGI (Common Gateway Interface) appli-

cation is set up on a Web server to handle the form data.

3 When you import data from a form data file, the fields that share names in common 

with the imported data fields will be populated.

4 A combo box consists of a pop-up list of items from which users can choose only

one item.

5 To copy a form field, select the form tool and make sure that all form fields are 

deselected. Hold down Ctrl (Windows) or Option (Macintosh) and drag the desired field 

to create and move a copy.

6 To restrict field entries in text or combo box fields and ensure that users enter appro-

priate data in the form fields, you use validation properties.

7 You perform calculations within text or combo box fields by either applying predefined 

operations, or creating custom operations using the JavaScript programming language. 


